Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcletavernie2012-09-17 13:28:15 +0000
committercletavernie2012-09-17 13:28:15 +0000
commitb00718aa2138c1ce5a34eb592d91d178a9803f8e (patch)
tree7bb9144a6f21f862334f6a495f809b122ca99fbd /extraplugins/diagramtemplate
parentbd209383ecf3ad359021d1c9e8633201afc36f17 (diff)
downloadorg.eclipse.papyrus-b00718aa2138c1ce5a34eb592d91d178a9803f8e.tar.gz
org.eclipse.papyrus-b00718aa2138c1ce5a34eb592d91d178a9803f8e.tar.xz
org.eclipse.papyrus-b00718aa2138c1ce5a34eb592d91d178a9803f8e.zip
380517: [Papyrus] We should use explicit plug-in dependencies whenever possible
https://bugs.eclipse.org/bugs/show_bug.cgi?id=380517 + removed some unused dependencies and imports
Diffstat (limited to 'extraplugins/diagramtemplate')
-rw-r--r--extraplugins/diagramtemplate/org.eclipse.papyrus.diagramtemplate.editor/META-INF/MANIFEST.MF7
1 files changed, 4 insertions, 3 deletions
diff --git a/extraplugins/diagramtemplate/org.eclipse.papyrus.diagramtemplate.editor/META-INF/MANIFEST.MF b/extraplugins/diagramtemplate/org.eclipse.papyrus.diagramtemplate.editor/META-INF/MANIFEST.MF
index 4110422ff9b..a3b4194c32f 100644
--- a/extraplugins/diagramtemplate/org.eclipse.papyrus.diagramtemplate.editor/META-INF/MANIFEST.MF
+++ b/extraplugins/diagramtemplate/org.eclipse.papyrus.diagramtemplate.editor/META-INF/MANIFEST.MF
@@ -10,11 +10,11 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.papyrus.diagramtemplate.editor
Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.core.resources;visibility:=reexport,
+ org.eclipse.core.resources,
org.eclipse.papyrus.diagramtemplate.edit;visibility:=reexport,
org.eclipse.emf.ecore.xmi;visibility:=reexport,
org.eclipse.emf.edit.ui;visibility:=reexport,
- org.eclipse.ui.ide;visibility:=reexport,
+ org.eclipse.ui.ide,
org.eclipse.uml2.uml;bundle-version="3.1.0",
org.eclipse.uml2.uml.edit;bundle-version="3.1.0",
org.eclipse.papyrus.editor;bundle-version="0.7.1",
@@ -22,5 +22,6 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.gmf.runtime.notation;bundle-version="1.5.0",
org.eclipse.papyrus.infra.core;bundle-version="0.9.0",
org.eclipse.papyrus.uml.diagram.wizards;bundle-version="0.9.0",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.6.0"
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.6.0",
+ org.eclipse.papyrus.infra.core.sasheditor;bundle-version="0.9.0"
Bundle-ActivationPolicy: lazy

Back to the top