Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Le Menez2015-08-21 11:14:49 +0000
committerQuentin Le Menez2015-08-21 13:03:55 +0000
commiteb5614a6ef6b04af32e077de1a23a1e12ad02b80 (patch)
tree8ebe02a562d3e6232a025ec5e3ba7f29de774c2e /extraplugins/adl4eclipse
parent6f51c1e47c75f2f33207c7da4686eb0ef3043279 (diff)
downloadorg.eclipse.papyrus-eb5614a6ef6b04af32e077de1a23a1e12ad02b80.tar.gz
org.eclipse.papyrus-eb5614a6ef6b04af32e077de1a23a1e12ad02b80.tar.xz
org.eclipse.papyrus-eb5614a6ef6b04af32e077de1a23a1e12ad02b80.zip
[releng] Neon-1.2.0 modification step by step
Change-Id: I9126d707fecad85c9b5384b35074deba995b6527 Signed-off-by: Quentin Le Menez <quentin.lemenez@cea.fr>
Diffstat (limited to 'extraplugins/adl4eclipse')
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/META-INF/MANIFEST.MF18
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/pom.xml2
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF11
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/pom.xml2
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.table/META-INF/MANIFEST.MF51
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.table/pom.xml2
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/META-INF/MANIFEST.MF30
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/pom.xml2
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/META-INF/MANIFEST.MF9
-rw-r--r--extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/pom.xml2
10 files changed, 57 insertions, 72 deletions
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/META-INF/MANIFEST.MF b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/META-INF/MANIFEST.MF
index cc69305ea03..47415f2a1d6 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/META-INF/MANIFEST.MF
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/META-INF/MANIFEST.MF
@@ -1,19 +1,15 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.papyrus.osgi.profile;bundle-version="1.1.0"
+ org.eclipse.papyrus.osgi.profile;bundle-version="1.2.0"
+Export-Package: org.eclipse.papyrus.adl4eclipse.org
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.1.0.qualifier
-Bundle-localization: plugin
+Bundle-Version: 1.2.0.qualifier
Bundle-Name: %pluginName
-Bundle-Activator: org.eclipse.papyrus.adl4eclipse.org.Activator
+Bundle-localization: plugin
Bundle-ManifestVersion: 2
-Bundle-Description: This plugin contains adl4 eclipse profile used to
- model eclipse plugins.The plugins that allow the modelization is or.
- eclipse.papyrus.adl4eclipsetool. More details can be found in the doc
- s directory of or.eclipse.papyrus.adl4eclipsetool.
-Bundle-SymbolicName: org.eclipse.papyrus.adl4eclipse.profile;singleton
- :=true
+Bundle-Activator: org.eclipse.papyrus.adl4eclipse.org.Activator
+Bundle-Description: This plugin contains adl4 eclipse profile used to model eclipse plugins.The plugins that allow the modelization is or.eclipse.papyrus.adl4eclipsetool. More details can be found in the docs directory of or.eclipse.papyrus.adl4eclipsetool.
+Bundle-SymbolicName: org.eclipse.papyrus.adl4eclipse.profile;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.papyrus.adl4eclipse.org
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/pom.xml b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/pom.xml
index dc69e4e66a9..a4852154d27 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/pom.xml
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipse.profile/pom.xml
@@ -4,7 +4,7 @@
<parent>
<artifactId>org.eclipse.papyrus.extra.releng</artifactId>
<groupId>org.eclipse.papyrus</groupId>
- <version>1.1.0-SNAPSHOT</version>
+ <version>1.2.0-SNAPSHOT</version>
<relativePath>../../../releng/extra</relativePath>
</parent>
<artifactId>org.eclipse.papyrus.adl4eclipse.profile</artifactId>
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF
index c24e9d0daa7..11b5bc8bf15 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/META-INF/MANIFEST.MF
@@ -20,16 +20,11 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.infra.gmfdiag.common;bundle-version="1.1.0",
org.eclipse.papyrus.osgi.profile
Bundle-Vendor: %providerName
-Bundle-Version: 1.1.0.qualifier
+Bundle-Version: 1.2.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.adltool.assistant.Activator
Bundle-ManifestVersion: 2
-Bundle-Description: This plugin has in charge to connect the tool to m
- odel eclipse plugins withe the eclipse UI. The plugins that allow the
- modelization is or.eclipse.papyrus.adl4eclipsetool. More details can
- be found in the docs directory of or.eclipse.papyrus.adl4eclipsetool
- .
-Bundle-SymbolicName: org.eclipse.papyrus.adl4eclipsetool.assistant;sin
- gleton:=true
+Bundle-Description: This plugin has in charge to connect the tool to model eclipse plugins withe the eclipse UI. The plugins that allow the modelization is or.eclipse.papyrus.adl4eclipsetool. More details can be found in the docs directory of or.eclipse.papyrus.adl4eclipsetool.
+Bundle-SymbolicName: org.eclipse.papyrus.adl4eclipsetool.assistant;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/pom.xml b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/pom.xml
index 0df5351805e..5533f1b58e2 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/pom.xml
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.assistant/pom.xml
@@ -4,7 +4,7 @@
<parent>
<artifactId>org.eclipse.papyrus.extra.releng</artifactId>
<groupId>org.eclipse.papyrus</groupId>
- <version>1.1.0-SNAPSHOT</version>
+ <version>1.2.0-SNAPSHOT</version>
<relativePath>../../../releng/extra</relativePath>
</parent>
<artifactId>org.eclipse.papyrus.adl4eclipsetool.assistant</artifactId>
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.table/META-INF/MANIFEST.MF b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.table/META-INF/MANIFEST.MF
index 1e6c6ae7922..e9602a8d4c2 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.table/META-INF/MANIFEST.MF
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.table/META-INF/MANIFEST.MF
@@ -1,25 +1,26 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: %Bundle-Name
-Bundle-SymbolicName: org.eclipse.papyrus.adl4eclipsetool.table;singleton:=true
-Bundle-Version: 1.1.0.qualifier
-Bundle-Activator: org.eclipse.papyrus.adl4eclipsetool.table.Activator
-Bundle-Vendor: %Bundle-Vendor
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.papyrus.infra.nattable;bundle-version="1.1.0",
- org.eclipse.papyrus.osgi.profile;bundle-version="1.1.0",
- org.eclipse.papyrus.adl4eclipse.profile;bundle-version="1.1.0",
- org.eclipse.uml2.uml;bundle-version="5.0.1",
- org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.7.0",
- org.eclipse.papyrus.uml.nattable;bundle-version="1.1.0",
- org.eclipse.papyrus.infra.emf.nattable;bundle-version="1.1.0",
- org.eclipse.papyrus.infra.nattable.model;bundle-version="1.1.0",
- org.eclipse.papyrus.infra.widgets;bundle-version="1.1.0",
- org.eclipse.nebula.widgets.nattable.core;bundle-version="1.2.0"
-Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Bundle-ActivationPolicy: lazy
-Bundle-Description: This bundle provides a table for the ADL4Eclipse tool. This synchronized table should be created on a package, and displays all the bundles contained in this package
-Export-Package: org.eclipse.papyrus.adl4eclipsetool.table,
- org.eclipse.papyrus.adl4eclipsetool.table.manager,
- org.eclipse.papyrus.adl4eclipsetool.table.tester
+Manifest-Version: 1.0
+Require-Bundle: org.eclipse.ui,
+ org.eclipse.core.runtime,
+ org.eclipse.papyrus.infra.nattable;bundle-version="1.2.0",
+ org.eclipse.papyrus.osgi.profile;bundle-version="1.2.0",
+ org.eclipse.papyrus.adl4eclipse.profile;bundle-version="1.2.0",
+ org.eclipse.uml2.uml;bundle-version="5.0.1",
+ org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.7.0",
+ org.eclipse.papyrus.uml.nattable;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.emf.nattable;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.nattable.model;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.widgets;bundle-version="1.2.0",
+ org.eclipse.nebula.widgets.nattable.core;bundle-version="1.2.0"
+Export-Package: org.eclipse.papyrus.adl4eclipsetool.table,
+ org.eclipse.papyrus.adl4eclipsetool.table.manager,
+ org.eclipse.papyrus.adl4eclipsetool.table.tester
+Bundle-Vendor: %Bundle-Vendor
+Bundle-ActivationPolicy: lazy
+Bundle-Version: 1.2.0.qualifier
+Bundle-Name: %Bundle-Name
+Bundle-ManifestVersion: 2
+Bundle-Activator: org.eclipse.papyrus.adl4eclipsetool.table.Activator
+Bundle-Description: This bundle provides a table for the ADL4Eclipse tool. This synchronized table should be created on a package,
+ and displays all the bundles contained in this package
+Bundle-SymbolicName: org.eclipse.papyrus.adl4eclipsetool.table;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.table/pom.xml b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.table/pom.xml
index 0813073063f..d1f5dd98431 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.table/pom.xml
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool.table/pom.xml
@@ -4,7 +4,7 @@
<parent>
<artifactId>org.eclipse.papyrus.extra.releng</artifactId>
<groupId>org.eclipse.papyrus</groupId>
- <version>1.1.0-SNAPSHOT</version>
+ <version>1.2.0-SNAPSHOT</version>
<relativePath>../../../releng/extra</relativePath>
</parent>
<artifactId>org.eclipse.papyrus.adl4eclipsetool.table</artifactId>
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/META-INF/MANIFEST.MF b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/META-INF/MANIFEST.MF
index 2206c3438c2..59bcb9c1f22 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/META-INF/MANIFEST.MF
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/META-INF/MANIFEST.MF
@@ -1,4 +1,14 @@
Manifest-Version: 1.0
+Export-Package: org.eclipse.papyrus.adltool,
+ org.eclipse.papyrus.adltool.command,
+ org.eclipse.papyrus.adltool.designer,
+ org.eclipse.papyrus.adltool.reversible,
+ org.eclipse.papyrus.adltool.reversible.factory,
+ org.eclipse.papyrus.adltool.reversible.project
+Bundle-ActivationPolicy: lazy
+Bundle-Localization: plugin
+Bundle-Name: %pluginName
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.emf.transaction,
@@ -13,24 +23,10 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.adl4eclipsetool,
org.eclipse.equinox.registry,
org.eclipse.emf.common
-Export-Package: org.eclipse.papyrus.adltool,
- org.eclipse.papyrus.adltool.command,
- org.eclipse.papyrus.adltool.designer,
- org.eclipse.papyrus.adltool.reversible,
- org.eclipse.papyrus.adltool.reversible.factory,
- org.eclipse.papyrus.adltool.reversible.project
Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.1.0.qualifier
-Bundle-Localization: plugin
-Bundle-Name: %pluginName
+Bundle-Version: 1.2.0.qualifier
Bundle-Activator: org.eclipse.papyrus.adltool.Activator
Bundle-ManifestVersion: 2
-Bundle-Description: The purpose of this plugin is to model the archite
- cture of eclipse-plugin into UML by using OSGI and ADL4Eclipse profil
- e. More details can be found in the docs directory.
-Bundle-SymbolicName: org.eclipse.papyrus.adl4eclipsetool;singleton:=tr
- ue
-Bundle-RequiredExecutionEnvironment: JavaSE-1.7
+Bundle-Description: The purpose of this plugin is to model the architecture of eclipse-plugin into UML by using OSGI and ADL4Eclipse profile. More details can be found in the docs directory.
+Bundle-SymbolicName: org.eclipse.papyrus.adl4eclipsetool;singleton:=true
Import-Package: org.eclipse.papyrus.adltool.reversible
-
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/pom.xml b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/pom.xml
index 9fbe3aa34fb..27a2d719306 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/pom.xml
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.adl4eclipsetool/pom.xml
@@ -4,7 +4,7 @@
<parent>
<artifactId>org.eclipse.papyrus.extra.releng</artifactId>
<groupId>org.eclipse.papyrus</groupId>
- <version>1.1.0-SNAPSHOT</version>
+ <version>1.2.0-SNAPSHOT</version>
<relativePath>../../../releng/extra</relativePath>
</parent>
<artifactId>org.eclipse.papyrus.adl4eclipsetool</artifactId>
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/META-INF/MANIFEST.MF b/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/META-INF/MANIFEST.MF
index 88038776eb8..987b93253b7 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/META-INF/MANIFEST.MF
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/META-INF/MANIFEST.MF
@@ -2,18 +2,15 @@ Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.osgi.profile
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.papyrus.uml.extensionpoints;bundle-version="1.1.0",
+ org.eclipse.papyrus.uml.extensionpoints;bundle-version="1.2.0",
org.eclipse.emf
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.1.0.qualifier
+Bundle-Version: 1.2.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.osgi.profile.Activator
Bundle-ManifestVersion: 2
-Bundle-Description: This plugin contains a part of osgi profile used t
- o model eclipse plugins. The plugins that allow the modelization is
- org.eclipse.papyrus.adl4eclipsetool. More details can be found in the d
- ocs directory of or.eclipse.papyrus.adl4eclipsetool.
+Bundle-Description: This plugin contains a part of osgi profile used to model eclipse plugins. The plugins that allow the modelization is org.eclipse.papyrus.adl4eclipsetool. More details can be found in the docs directory of or.eclipse.papyrus.adl4eclipsetool.
Bundle-SymbolicName: org.eclipse.papyrus.osgi.profile;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/pom.xml b/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/pom.xml
index 81b599bea0b..bec7444aeba 100644
--- a/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/pom.xml
+++ b/extraplugins/adl4eclipse/org.eclipse.papyrus.osgi.profile/pom.xml
@@ -4,7 +4,7 @@
<parent>
<artifactId>org.eclipse.papyrus.extra.releng</artifactId>
<groupId>org.eclipse.papyrus</groupId>
- <version>1.1.0-SNAPSHOT</version>
+ <version>1.2.0-SNAPSHOT</version>
<relativePath>../../../releng/extra</relativePath>
</parent>
<artifactId>org.eclipse.papyrus.osgi.profile</artifactId>

Back to the top