Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlorenzo2011-11-03 12:05:41 -0400
committervlorenzo2011-11-03 12:05:41 -0400
commitdb31917cfa27ab9796e4e25985c0bdebd2f5fecb (patch)
tree792d3f56c848a4c27d9be341ec0e2b7867d67813
parentfa77fb68c9ef8820735225da8debd07a45fc6766 (diff)
downloadorg.eclipse.papyrus-db31917cfa27ab9796e4e25985c0bdebd2f5fecb.tar.gz
org.eclipse.papyrus-db31917cfa27ab9796e4e25985c0bdebd2f5fecb.tar.xz
org.eclipse.papyrus-db31917cfa27ab9796e4e25985c0bdebd2f5fecb.zip
362162: [Architecture - Refactoring] The plug-ins should be renamed to match their layer's qualified name
https://bugs.eclipse.org/bugs/show_bug.cgi?id=362162
-rw-r--r--plugins/core/org.eclipse.xtext.gmf.glue/META-INF/MANIFEST.MF2
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF6
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF4
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF4
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties/plugin.xml2
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization.properties/src/org/eclipse/papyrus/properties/customization/editor/actions/CreateSectionWidgetAction.java2
-rw-r--r--plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.navigation/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF6
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.widgets/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/org.eclipse.papyrus.infra.export/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/table/org.eclipse.papyrus.infra.table.common/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/table/org.eclipse.papyrus.infra.table.menu/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/table/org.eclipse.papyrus.infra.table.modelexplorer/META-INF/MANIFEST.MF2
-rw-r--r--plugins/infra/table/org.eclipse.papyrus.infra.table.properties/META-INF/MANIFEST.MF4
-rw-r--r--plugins/marte/org.eclipse.papyrus.marte.static.profile/META-INF/MANIFEST.MF2
-rw-r--r--plugins/marte/properties/org.eclipse.papyrus.marte.properties.tabbed/META-INF/MANIFEST.MF4
-rw-r--r--plugins/marte/textedit/org.eclipse.papyrus.marte.textedit.constraintwithvsl.xtext.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/marte/textedit/org.eclipse.papyrus.marte.textedit.stereotypeapplicationwithvsl.xtext.ui/META-INF/MANIFEST.MF2
-rw-r--r--plugins/others/org.eclipse.papyrus.parsers/META-INF/MANIFEST.MF2
-rw-r--r--plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.common/META-INF/MANIFEST.MF2
-rw-r--r--plugins/sysml/modelexplorer/org.eclipse.papyrus.sysml.modelexplorer/META-INF/MANIFEST.MF2
-rw-r--r--plugins/sysml/properties/org.eclipse.papyrus.sysml.properties.view/META-INF/MANIFEST.MF2
-rw-r--r--plugins/sysml/properties/org.eclipse.papyrus.sysml.properties/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.modelexplorer/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.navigation/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.widgets/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.compare/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.documentation/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.import/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.menu/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/.project2
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/META-INF/MANIFEST.MF7
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/src/org/eclipse/papyrus/properties/runtime/uml/Activator.java2
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/.project2
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/META-INF/MANIFEST.MF3
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/src/org/eclipse/papyrus/properties/tabbed/profile/Activator.java2
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/.project2
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/META-INF/MANIFEST.MF5
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/src/org/eclipse/papyrus/tabbedproperties/appearance/Activator.java2
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/.project2
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/META-INF/MANIFEST.MF7
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/src/org/eclipse/papyrus/tabbedproperties/comments/Activator.java2
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/.project2
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/META-INF/MANIFEST.MF7
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/src/org/eclipse/papyrus/properties/view/uml/Activator.java2
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties/.project2
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties/META-INF/MANIFEST.MF9
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties/schema/org.eclipse.papyrus.properties.uml.languageEditor.exsd4
-rw-r--r--plugins/uml/properties/org.eclipse.papyrus.uml.properties/src/org/eclipse/papyrus/properties/uml/Activator.java2
-rw-r--r--plugins/uml/table/org.eclipse.papyrus.uml.table.default/.project2
-rw-r--r--plugins/uml/table/org.eclipse.papyrus.uml.table.default/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/table/org.eclipse.papyrus.uml.table.default/src/org/eclipse/papyrus/table/defaultt/Activator.java2
-rw-r--r--plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/.project2
-rw-r--r--plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/META-INF/MANIFEST.MF7
-rw-r--r--plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/src/org/eclipse/papyrus/widget/celleditors/uml/Activator.java2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.generator/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.generator/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui/META-INF/MANIFEST.MF14
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext/META-INF/MANIFEST.MF8
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.generator/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.generator/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.ui/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui/META-INF/MANIFEST.MF9
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.generator/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.generator/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.ui/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.ui/META-INF/MANIFEST.MF7
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext/META-INF/MANIFEST.MF5
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.generator/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.generator/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.ui/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.ui/META-INF/MANIFEST.MF13
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.generator/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.generator/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.ui/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.ui/META-INF/MANIFEST.MF9
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/META-INF/MANIFEST.MF3
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/src/org/eclipse/papyrus/property/editor/xtext/GenerateUmlProperty.mwe24
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/src/org/eclipse/papyrus/property/editor/xtext/UmlProperty.xtext4
-rwxr-xr-xplugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.generator/.project2
-rwxr-xr-xplugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.generator/META-INF/MANIFEST.MF4
-rwxr-xr-xplugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.ui/.project2
-rwxr-xr-xplugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.ui/META-INF/MANIFEST.MF7
-rwxr-xr-xplugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/.project2
-rwxr-xr-xplugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/META-INF/MANIFEST.MF2
-rwxr-xr-xplugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/src/org/eclipse/papyrus/state/editor/xtext/GenerateUmlState.mwe210
-rwxr-xr-xplugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/src/org/eclipse/papyrus/state/editor/xtext/UmlState.xtext4
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.generator/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.generator/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.ui/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.ui/META-INF/MANIFEST.MF7
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/.project2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/src/org/eclipse/papyrus/transition/editor/xtext/GenerateUmlTransition.mwe28
-rw-r--r--plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/src/org/eclipse/papyrus/transition/editor/xtext/UmlTransition.xtext4
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/.project2
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/META-INF/MANIFEST.MF7
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/model/ApplyStereotypeActionConfiguration.genmodel10
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/.project66
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/src/org/eclipse/papyrus/umlutils/Activator.java2
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/.project2
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF7
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/.project2
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/META-INF/MANIFEST.MF5
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation/.project2
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF2
-rw-r--r--plugins/views/documentation/org.eclipse.papyrus.views.documentation/schema/documentationManager.exsd4
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/.project2
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF11
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/.project2
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF11
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/src/org/eclipse/papyrus/modelexplorer/widgets/Activator.java2
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/.project2
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF18
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/src/org/eclipse/papyrus/modelexplorer/Activator.java2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/META-INF/MANIFEST.MF7
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/META-INF/MANIFEST.MF5
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model/META-INF/MANIFEST.MF5
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.model/Model/Properties.genmodel12
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF7
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/src/org/eclipse/papyrus/properties/runtime/Activator.java2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF7
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/src/org/eclipse/papyrus/properties/tabbed/core/Activator.java2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF15
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_predefined_fragments.xml2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_wizards_dialogs.xml2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/src/org/eclipse/papyrus/properties/tabbed/customization/Activator.java2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF3
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/src/org/eclipse/papyrus/tabbedproperties/core/Activator.java2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/.project2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF16
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.ecore4
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.genmodel2
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/plugin.xml4
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/schema/context.exsd4
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/schema/environment.exsd6
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/schema/labelprovider.exsd4
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties/src/org/eclipse/papyrus/properties/Activator.java2
164 files changed, 333 insertions, 360 deletions
diff --git a/plugins/core/org.eclipse.xtext.gmf.glue/META-INF/MANIFEST.MF b/plugins/core/org.eclipse.xtext.gmf.glue/META-INF/MANIFEST.MF
index 4bb9d9773ec..04c737bed95 100644
--- a/plugins/core/org.eclipse.xtext.gmf.glue/META-INF/MANIFEST.MF
+++ b/plugins/core/org.eclipse.xtext.gmf.glue/META-INF/MANIFEST.MF
@@ -19,7 +19,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.sasheditor;bundle-version="0.9.0",
org.eclipse.papyrus.editor;bundle-version="0.9.0",
org.eclipse.papyrus.core;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0"
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0"
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
Bundle-Version: 0.9.0.qualifier
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF
index 2ecb19ea350..efdda0a9d71 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties.generation/META-INF/MANIFEST.MF
@@ -12,15 +12,15 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.ui;bundle-version="3.6.1",
org.eclipse.osgi;bundle-version="3.6.1",
org.eclipse.core.runtime;bundle-version="3.6.0",
- org.eclipse.papyrus.properties.model;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.model;bundle-version="0.9.0",
org.eclipse.m2m.qvt.oml;bundle-version="3.0.1",
org.eclipse.m2m.qvt.oml.common;bundle-version="2.1.0",
org.eclipse.papyrus.log;bundle-version:="0.9.0",
- org.eclipse.papyrus.properties.model.edit;bundle-version:="0.9.0",
+ org.eclipse.papyrus.views.properties.model.edit;bundle-version:="0.9.0",
org.eclipse.emf.common.ui;bundle-version="2.6.0",
org.eclipse.core.resources;bundle-version="3.6.0",
org.eclipse.uml2.uml;bundle-version:="3.1.1",
- org.eclipse.papyrus.properties;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties;bundle-version="0.9.0",
org.eclipse.core.databinding;bundle-version="1.3.100",
org.eclipse.emf.databinding;bundle-version="1.2.0",
org.eclipse.core.databinding.property;bundle-version="1.3.0",
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF
index b3d9d4bc935..dd6e46eb200 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties.model.xwt/META-INF/MANIFEST.MF
@@ -4,8 +4,8 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.m2m.qvt.oml;bundle-version="3.1.0",
org.eclipse.gmt.modisco.xml;bundle-version:="0.9.0",
org.eclipse.gmt.modisco.xml.discoverer;bundle-version:="0.9.0",
- org.eclipse.papyrus.properties;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.model;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.model;bundle-version="0.9.0",
org.eclipse.papyrus.log;bundle-version="0.9.0",
org.eclipse.wst.xml.core;bundle-version:="1.1.600",
org.eclipse.core.resources;bundle-version="3.7.100"
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF
index cf8fe8147d5..902e50480de 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties/META-INF/MANIFEST.MF
@@ -6,8 +6,8 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.papyrus.log;bundle-version="0.9.0",
org.eclipse.papyrus.widgets;bundle-version="0.9.0",
org.eclipse.papyrus.diagram.common;bundle-version="0.9.0",
- org.eclipse.papyrus.properties;bundle-version:="0.9.0",
- org.eclipse.papyrus.properties.model;bundle-version:="0.9.0",
+ org.eclipse.papyrus.views.properties;bundle-version:="0.9.0",
+ org.eclipse.papyrus.views.properties.model;bundle-version:="0.9.0",
org.eclipse.papyrus.properties.model.xwt;bundle-version:="0.9.0",
org.eclipse.emf.ecore.editor;bundle-version="2.6.0",
org.eclipse.emf.facet.infra.facet.core;bundle-version="0.1.0",
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties/plugin.xml b/plugins/customization/org.eclipse.papyrus.customization.properties/plugin.xml
index 1c090c836e1..f093ff622c5 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties/plugin.xml
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties/plugin.xml
@@ -22,7 +22,7 @@
</modelqueryset>
</extension>
<extension point="org.eclipse.ui.editors">
- <editor class="org.eclipse.papyrus.properties.customization.editor.UIEditor" contributorClass="org.eclipse.papyrus.properties.customization.editor.ContextEditorActionBarContributor" default="true" extensions="ctx" icon="platform:/plugin/org.eclipse.papyrus.properties.model.edit/icons/full/obj16/Context.gif" id="org.eclipse.papyrus.property.customization.UIEditor" name="%editor.name">
+ <editor class="org.eclipse.papyrus.properties.customization.editor.UIEditor" contributorClass="org.eclipse.papyrus.properties.customization.editor.ContextEditorActionBarContributor" default="true" extensions="ctx" icon="platform:/plugin/org.eclipse.papyrus.views.properties.model.edit/icons/full/obj16/Context.gif" id="org.eclipse.papyrus.property.customization.UIEditor" name="%editor.name">
</editor>
</extension>
<extension point="org.eclipse.emf.ecore.uri_mapping">
diff --git a/plugins/customization/org.eclipse.papyrus.customization.properties/src/org/eclipse/papyrus/properties/customization/editor/actions/CreateSectionWidgetAction.java b/plugins/customization/org.eclipse.papyrus.customization.properties/src/org/eclipse/papyrus/properties/customization/editor/actions/CreateSectionWidgetAction.java
index 5858d5f1245..c04a4b3040f 100644
--- a/plugins/customization/org.eclipse.papyrus.customization.properties/src/org/eclipse/papyrus/properties/customization/editor/actions/CreateSectionWidgetAction.java
+++ b/plugins/customization/org.eclipse.papyrus.customization.properties/src/org/eclipse/papyrus/properties/customization/editor/actions/CreateSectionWidgetAction.java
@@ -69,7 +69,7 @@ public class CreateSectionWidgetAction extends StaticSelectionCommandAction {
CompositeWidget newWidget = createWidget();
CompoundCommandActionDelegate createActionCommand = new CompoundCommandActionDelegate();
- createActionCommand.setImage(Activator.getDefault().getImage("org.eclipse.papyrus.properties.model.edit", "icons/full/obj16/CompositeWidget.gif")); //$NON-NLS-1$//$NON-NLS-2$
+ createActionCommand.setImage(Activator.getDefault().getImage("org.eclipse.papyrus.views.properties.model.edit", "icons/full/obj16/CompositeWidget.gif")); //$NON-NLS-1$//$NON-NLS-2$
createActionCommand.append(getCreateResourceCommand(newWidget));
createActionCommand.append(getSetWidgetCommand(newWidget));
diff --git a/plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF b/plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF
index 750a15a1f2e..91c8744c564 100644
--- a/plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF
+++ b/plugins/customization/org.eclipse.papyrus.customization/META-INF/MANIFEST.MF
@@ -14,10 +14,10 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.core.resources;bundle-version="3.7.100",
org.eclipse.pde.core;bundle-version="3.7.0",
org.eclipse.papyrus.log;bundle-version:="0.9.0",
- org.eclipse.papyrus.properties;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties;bundle-version="0.9.0",
org.eclipse.pde.ui;bundle-version="3.6.100",
org.eclipse.ui.ide;bundle-version:="3.7.0",
- org.eclipse.papyrus.properties.model;bundle-version:="0.9.0",
+ org.eclipse.papyrus.views.properties.model;bundle-version:="0.9.0",
org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.200",
org.eclipse.papyrus.widgets;bundle-version="0.9.0",
org.eclipse.papyrus.eclipse.project.editors;bundle-version="0.9.0",
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.navigation/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.navigation/META-INF/MANIFEST.MF
index 2a956081fcf..6ddf6acea67 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.navigation/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.navigation/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Require-Bundle: org.eclipse.papyrus.core;bundle-version:="0.9.0";visibility:=ree
org.eclipse.papyrus.core.adaptor.gmf;bundle-version="0.9.0",
org.eclipse.papyrus.ui.toolbox;bundle-version="0.9.0",
org.eclipse.core.expressions;bundle-version:="3.4.300",
- org.eclipse.papyrus.modelexplorer;bundle-version:="0.9.0",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version:="0.9.0",
org.eclipse.ui.navigator;bundle-version="3.5.100",
org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0",
org.eclipse.papyrus.ui.perspectiveconfiguration;bundle-version="0.9.0"
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF
index 736863b56cd..81b71e8a006 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF
@@ -1,8 +1,8 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.papyrus.properties;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.model;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.model;bundle-version="0.9.0",
org.eclipse.gmf.runtime.notation;bundle-version:="1.4.1",
org.eclipse.gef;bundle-version="3.7.0",
org.eclipse.emf.edit;bundle-version="2.7.0",
@@ -11,7 +11,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.emf.databinding;bundle-version="1.2.0",
org.eclipse.core.databinding.property;bundle-version="1.4.0",
org.eclipse.core.databinding.beans;bundle-version="1.2.100",
- org.eclipse.papyrus.properties.uml;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.properties;bundle-version="0.9.0",
org.eclipse.papyrus.log;bundle-version:="0.9.0",
org.eclipse.emf.edit.ui;bundle-version="2.7.0",
org.eclipse.papyrus.core;bundle-version="0.9.0"
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.widgets/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.widgets/META-INF/MANIFEST.MF
index 63fbf0b2c5e..37d3fac289b 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.widgets/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.widgets/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.core.databinding;bundle-version:="1.4.0",
org.eclipse.jface.databinding;bundle-version="1.5.0",
org.eclipse.core.databinding.property;bundle-version="1.4.0",
- org.eclipse.papyrus.properties;bundle-version="0.9.0"
+ org.eclipse.papyrus.views.properties;bundle-version="0.9.0"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
Bundle-Version: 0.9.0.qualifier
diff --git a/plugins/infra/org.eclipse.papyrus.infra.export/META-INF/MANIFEST.MF b/plugins/infra/org.eclipse.papyrus.infra.export/META-INF/MANIFEST.MF
index e2fc049b224..c94401fbef8 100644
--- a/plugins/infra/org.eclipse.papyrus.infra.export/META-INF/MANIFEST.MF
+++ b/plugins/infra/org.eclipse.papyrus.infra.export/META-INF/MANIFEST.MF
@@ -3,9 +3,9 @@ Require-Bundle: org.eclipse.ui.ide;bundle-version="3.7.0",
org.eclipse.gmf.runtime.diagram.ui.render;bundle-version="1.4.1",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
org.eclipse.core.expressions;bundle-version="3.4.300",
- org.eclipse.papyrus.tabbedproperties.core;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.tabbedproperties.core;bundle-version="0.9.0",
org.eclipse.emf.common.ui;bundle-version:="2.7.0",
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0",
org.eclipse.papyrus.onefile;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.export
Bundle-Vendor: %providerName
diff --git a/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF b/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF
index 775a8188310..593838a8e11 100644
--- a/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF
+++ b/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.emf.edit.ui,
org.eclipse.gmf.runtime.notation,
org.eclipse.ui.navigator,
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0",
org.eclipse.papyrus.core;bundle-version="0.9.0",
org.eclipse.papyrus.controlmode.history;bundle-version="0.9.0",
org.eclipse.papyrus.ui.toolbox;bundle-version:="0.9.0",
diff --git a/plugins/infra/table/org.eclipse.papyrus.infra.table.common/META-INF/MANIFEST.MF b/plugins/infra/table/org.eclipse.papyrus.infra.table.common/META-INF/MANIFEST.MF
index 0b71bc9809b..0b52e6678c5 100644
--- a/plugins/infra/table/org.eclipse.papyrus.infra.table.common/META-INF/MANIFEST.MF
+++ b/plugins/infra/table/org.eclipse.papyrus.infra.table.common/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Require-Bundle: org.eclipse.emf.facet.widgets.nattable.instance,
org.eclipse.emf.facet.widgets.nattable,
org.eclipse.papyrus.diagram.common;bundle-version:="0.9.0",
org.eclipse.papyrus.widgets;bundle-version="0.9.0",
- org.eclipse.papyrus.properties;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties;bundle-version="0.9.0",
org.eclipse.emf.databinding;bundle-version="1.2.0",
org.eclipse.papyrus.table.instance;bundle-version="0.9.0",
org.eclipse.emf.facet.infra.query.core;bundle-version="0.1.0",
diff --git a/plugins/infra/table/org.eclipse.papyrus.infra.table.menu/META-INF/MANIFEST.MF b/plugins/infra/table/org.eclipse.papyrus.infra.table.menu/META-INF/MANIFEST.MF
index a1750a6c698..f10f205e5b5 100644
--- a/plugins/infra/table/org.eclipse.papyrus.infra.table.menu/META-INF/MANIFEST.MF
+++ b/plugins/infra/table/org.eclipse.papyrus.infra.table.menu/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.core.expressions,
- org.eclipse.papyrus.table.default;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.table.default;bundle-version="0.9.0",
org.eclipse.papyrus.diagram.common;bundle-version:="0.9.0",
org.eclipse.papyrus.diagram.menu;bundle-version:="0.9.0",
org.eclipse.emf.facet.infra.common.core;bundle-version="0.1.0",
diff --git a/plugins/infra/table/org.eclipse.papyrus.infra.table.modelexplorer/META-INF/MANIFEST.MF b/plugins/infra/table/org.eclipse.papyrus.infra.table.modelexplorer/META-INF/MANIFEST.MF
index 1c3e5ff9e47..4d253fc0886 100644
--- a/plugins/infra/table/org.eclipse.papyrus.infra.table.modelexplorer/META-INF/MANIFEST.MF
+++ b/plugins/infra/table/org.eclipse.papyrus.infra.table.modelexplorer/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.papyrus.resource;bundle-version="0.9.0",
org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.browser.custom.core,
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0",
org.eclipse.core.expressions,
org.eclipse.emf.facet.widgets.nattable.instance;bundle-version="0.1.0",
org.eclipse.papyrus.table.instance;bundle-version="0.9.0",
diff --git a/plugins/infra/table/org.eclipse.papyrus.infra.table.properties/META-INF/MANIFEST.MF b/plugins/infra/table/org.eclipse.papyrus.infra.table.properties/META-INF/MANIFEST.MF
index 0433968e905..8d29267d66a 100644
--- a/plugins/infra/table/org.eclipse.papyrus.infra.table.properties/META-INF/MANIFEST.MF
+++ b/plugins/infra/table/org.eclipse.papyrus.infra.table.properties/META-INF/MANIFEST.MF
@@ -1,8 +1,8 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.papyrus.properties;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.model;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.model;bundle-version="0.9.0",
org.eclipse.emf.edit,
org.eclipse.papyrus.widgets;bundle-version="0.9.0",
org.eclipse.emf.facet.infra.query.core;bundle-version="0.1.0",
diff --git a/plugins/marte/org.eclipse.papyrus.marte.static.profile/META-INF/MANIFEST.MF b/plugins/marte/org.eclipse.papyrus.marte.static.profile/META-INF/MANIFEST.MF
index ca29f9dcf5f..fd2fbb0ff64 100644
--- a/plugins/marte/org.eclipse.papyrus.marte.static.profile/META-INF/MANIFEST.MF
+++ b/plugins/marte/org.eclipse.papyrus.marte.static.profile/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.emf.ecore,
org.eclipse.papyrus.extensionpoints.uml2;bundle-version="0.9.0",
org.eclipse.uml2.uml;bundle-version="3.1.0",
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0",
org.eclipse.papyrus.diagram.common;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.MARTE,
org.eclipse.papyrus.MARTE.MARTE_AnalysisModel.GQAM,
diff --git a/plugins/marte/properties/org.eclipse.papyrus.marte.properties.tabbed/META-INF/MANIFEST.MF b/plugins/marte/properties/org.eclipse.papyrus.marte.properties.tabbed/META-INF/MANIFEST.MF
index 8cee7aaade9..d9641a41ffb 100644
--- a/plugins/marte/properties/org.eclipse.papyrus.marte.properties.tabbed/META-INF/MANIFEST.MF
+++ b/plugins/marte/properties/org.eclipse.papyrus.marte.properties.tabbed/META-INF/MANIFEST.MF
@@ -2,8 +2,8 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.ui.views;bundle-version="3.5.0",
- org.eclipse.papyrus.properties.tabbed.core;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version:="0.9.0",
+ org.eclipse.papyrus.views.properties.tabbed.core;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version:="0.9.0",
org.eclipse.ui.views.properties.tabbed
Bundle-Vendor: CEA LIST
Bundle-ActivationPolicy: lazy
diff --git a/plugins/marte/textedit/org.eclipse.papyrus.marte.textedit.constraintwithvsl.xtext.ui/META-INF/MANIFEST.MF b/plugins/marte/textedit/org.eclipse.papyrus.marte.textedit.constraintwithvsl.xtext.ui/META-INF/MANIFEST.MF
index 34884f0bf65..f9d912fcaa9 100644
--- a/plugins/marte/textedit/org.eclipse.papyrus.marte.textedit.constraintwithvsl.xtext.ui/META-INF/MANIFEST.MF
+++ b/plugins/marte/textedit/org.eclipse.papyrus.marte.textedit.constraintwithvsl.xtext.ui/META-INF/MANIFEST.MF
@@ -16,9 +16,9 @@ Require-Bundle: org.eclipse.papyrus.constraintwithvsl.editor.xtext;bundle-versio
org.eclipse.papyrus.extensionpoints.editors;bundle-version="0.9.0",
org.eclipse.gmf.runtime.diagram.ui;bundle-version:="1.4.0",
org.eclipse.uml2.uml;bundle-version="3.1.0",
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0",
org.eclipse.papyrus.core;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.papyrus.service.edit;bundle-version:="0.9.0",
org.eclipse.papyrus.marte.vsl;bundle-version="0.9.0",
org.eclipse.papyrus.marte.vsl.ui;bundle-version="0.9.0",
diff --git a/plugins/marte/textedit/org.eclipse.papyrus.marte.textedit.stereotypeapplicationwithvsl.xtext.ui/META-INF/MANIFEST.MF b/plugins/marte/textedit/org.eclipse.papyrus.marte.textedit.stereotypeapplicationwithvsl.xtext.ui/META-INF/MANIFEST.MF
index f6c2727cb54..e4206dc40b1 100644
--- a/plugins/marte/textedit/org.eclipse.papyrus.marte.textedit.stereotypeapplicationwithvsl.xtext.ui/META-INF/MANIFEST.MF
+++ b/plugins/marte/textedit/org.eclipse.papyrus.marte.textedit.stereotypeapplicationwithvsl.xtext.ui/META-INF/MANIFEST.MF
@@ -16,7 +16,7 @@ Require-Bundle: org.eclipse.papyrus.stereotypeapplicationwithvsl.editor.xtext;bu
org.eclipse.uml2.uml;bundle-version="3.1.0",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.4.0",
org.eclipse.papyrus.core;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.core.expressions;bundle-version="3.4.200",
org.eclipse.papyrus.extensionpoints.editors;bundle-version="0.9.0",
org.eclipse.papyrus.marte.vsl;bundle-version="0.9.0",
diff --git a/plugins/others/org.eclipse.papyrus.parsers/META-INF/MANIFEST.MF b/plugins/others/org.eclipse.papyrus.parsers/META-INF/MANIFEST.MF
index 71112ab86a5..404cb810b4b 100644
--- a/plugins/others/org.eclipse.papyrus.parsers/META-INF/MANIFEST.MF
+++ b/plugins/others/org.eclipse.papyrus.parsers/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.uml2.uml,
org.eclipse.jface.text,
org.eclipse.ui.editors,
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0",
org.eclipse.papyrus.extensionpoints.editors;bundle-version="0.9.0",
org.antlr.runtime;bundle-version="[3.0.0,4.0.0)"
Export-Package: org.eclipse.papyrus.parsers,
diff --git a/plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.common/META-INF/MANIFEST.MF b/plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.common/META-INF/MANIFEST.MF
index 59ffe420292..746cbd3d498 100644
--- a/plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.common/META-INF/MANIFEST.MF
+++ b/plugins/sysml/diagram/org.eclipse.papyrus.sysml.diagram.common/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.emf;bundle-version="2.6.0",
org.eclipse.uml2.uml;bundle-version="3.1.0",
org.eclipse.papyrus.sysml;bundle-version="0.9.0",
- org.eclipse.papyrus.umlutils;bundle-version:="0.9.0",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version:="0.9.0",
org.eclipse.core.expressions,
org.eclipse.papyrus.diagram.common;bundle-version="0.9.0",
org.eclipse.papyrus.editor;bundle-version:="0.9.0",
diff --git a/plugins/sysml/modelexplorer/org.eclipse.papyrus.sysml.modelexplorer/META-INF/MANIFEST.MF b/plugins/sysml/modelexplorer/org.eclipse.papyrus.sysml.modelexplorer/META-INF/MANIFEST.MF
index 8158bcb4ecd..cbe01282872 100644
--- a/plugins/sysml/modelexplorer/org.eclipse.papyrus.sysml.modelexplorer/META-INF/MANIFEST.MF
+++ b/plugins/sysml/modelexplorer/org.eclipse.papyrus.sysml.modelexplorer/META-INF/MANIFEST.MF
@@ -9,7 +9,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
org.eclipse.papyrus.sysml.service.types;bundle-version="0.9.0",
org.eclipse.papyrus.uml.service.types;bundle-version="0.9.0",
- org.eclipse.papyrus.modelexplorer;bundle-version:="0.9.0",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version:="0.9.0",
org.eclipse.ui.navigator;bundle-version="3.5.0",
org.eclipse.papyrus.sysml.diagram.common;bundle-version="0.9.0",
org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0"
diff --git a/plugins/sysml/properties/org.eclipse.papyrus.sysml.properties.view/META-INF/MANIFEST.MF b/plugins/sysml/properties/org.eclipse.papyrus.sysml.properties.view/META-INF/MANIFEST.MF
index 5c38871404c..a6fb61ae739 100644
--- a/plugins/sysml/properties/org.eclipse.papyrus.sysml.properties.view/META-INF/MANIFEST.MF
+++ b/plugins/sysml/properties/org.eclipse.papyrus.sysml.properties.view/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.papyrus.sysml;bundle-version="0.9.0"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
diff --git a/plugins/sysml/properties/org.eclipse.papyrus.sysml.properties/META-INF/MANIFEST.MF b/plugins/sysml/properties/org.eclipse.papyrus.sysml.properties/META-INF/MANIFEST.MF
index 40e1aadb5a5..e57124c5e2d 100644
--- a/plugins/sysml/properties/org.eclipse.papyrus.sysml.properties/META-INF/MANIFEST.MF
+++ b/plugins/sysml/properties/org.eclipse.papyrus.sysml.properties/META-INF/MANIFEST.MF
@@ -1,8 +1,8 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.properties.model;bundle-version="0.9.0",
- org.eclipse.papyrus.properties;bundle-version:="0.9.0",
- org.eclipse.papyrus.properties.uml;bundle-version:="0.9.0"
+ org.eclipse.papyrus.views.properties.model;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties;bundle-version:="0.9.0",
+ org.eclipse.papyrus.uml.properties;bundle-version:="0.9.0"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
Bundle-Version: 0.9.0.qualifier
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
index 6e02427fc29..4f67664fb2a 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
@@ -50,7 +50,7 @@ Require-Bundle: org.eclipse.uml2.uml.edit;visibility:=reexport,
org.eclipse.gmf.runtime.diagram.ui.resources.editor,
org.eclipse.gmf.runtime.diagram.ui.providers;bundle-version="1.1.0",
org.eclipse.papyrus.extensionpoints.editors;bundle-version="0.9.0",
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0";visibility:=reexport,
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="1.2.0",
org.eclipse.papyrus.wizards;bundle-version="0.9.0",
org.eclipse.papyrus.log;bundle-version="0.9.0";visibility:=reexport,
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.modelexplorer/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.modelexplorer/META-INF/MANIFEST.MF
index 8e5e04f99cd..0d41dadd23b 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.modelexplorer/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.modelexplorer/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.uml.service.types;bundle-version="0.9.0",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
org.eclipse.emf.facet.infra.facet;bundle-version:="0.1.0",
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0",
org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0",
org.eclipse.emf.ecore,
org.eclipse.gmf.runtime.notation,
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.navigation/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.navigation/META-INF/MANIFEST.MF
index 76b6fa3c7a5..3d7d88ffdbd 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.navigation/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.navigation/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.papyrus.navigation;bundle-version="0.9.0",
org.eclipse.uml2.uml,
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0"
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.navigation.uml
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
diff --git a/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.widgets/META-INF/MANIFEST.MF b/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.widgets/META-INF/MANIFEST.MF
index 47ce8fa2d8d..3610c717933 100644
--- a/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.widgets/META-INF/MANIFEST.MF
+++ b/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer.widgets/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.papyrus.modelexplorer.widgets;bundle-version="0.9.0";visibility:=reexport,
+ org.eclipse.papyrus.views.modelexplorer.widgets;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.uml2.uml;bundle-version="3.2.0",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.uml.modelexplorer.widgets
diff --git a/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF b/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF
index 323eb0b12ae..b0c01cbf819 100644
--- a/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF
+++ b/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF
@@ -1,15 +1,15 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0",
org.eclipse.ui.navigator;bundle-version="3.4.0",
org.eclipse.emf.transaction;bundle-version="1.4.0",
org.eclipse.emf.facet.infra.query.core;bundle-version="0.1.0",
org.eclipse.uml2.uml.editor;bundle-version="3.1.0",
org.eclipse.papyrus.uml.service.types;bundle-version="0.9.0",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
- org.eclipse.emf.facet.infra.facet;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.browser.uicore;bundle-version:="0.1.0"
+ org.eclipse.emf.facet.infra.facet;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0"
Export-Package: org.eclipse.papyrus.uml.modelexplorer,
org.eclipse.papyrus.uml.modelexplorer.factory,
org.eclipse.papyrus.uml.modelexplorer.queries
diff --git a/plugins/uml/org.eclipse.papyrus.uml.compare/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.compare/META-INF/MANIFEST.MF
index e4770e16617..ccab398f078 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.compare/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.compare/META-INF/MANIFEST.MF
@@ -15,7 +15,7 @@ Require-Bundle: org.eclipse.emf.compare;bundle-version="1.1.0",
org.eclipse.emf.facet.infra.browser.uicore;bundle-version:="0.1.0",
org.eclipse.emf.facet.infra.browser.custom;bundle-version:="0.1.0",
org.eclipse.emf.facet.infra.browser.custom.core;bundle-version:="0.1.0",
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0"
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
Bundle-Version: 0.9.0.qualifier
diff --git a/plugins/uml/org.eclipse.papyrus.uml.documentation/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.documentation/META-INF/MANIFEST.MF
index effb73b29a8..2c874e1c923 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.documentation/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.documentation/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.documentation;bundle-version="0.9.0",
+Require-Bundle: org.eclipse.papyrus.views.documentation;bundle-version="0.9.0",
org.eclipse.uml2.uml,
org.eclipse.papyrus.uml.profile;bundle-version:="0.9.0"
Bundle-Vendor: %providerName
diff --git a/plugins/uml/org.eclipse.papyrus.uml.import/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.import/META-INF/MANIFEST.MF
index 313f2353bdb..7793dbe2bbb 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.import/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.import/META-INF/MANIFEST.MF
@@ -1,11 +1,11 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0",
org.eclipse.uml2.uml;bundle-version:="3.2.0",
org.eclipse.uml2.common.edit,
org.eclipse.papyrus.extensionpoints.uml2;bundle-version="0.9.0",
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0",
org.eclipse.papyrus.profile;bundle-version:="0.9.0"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
diff --git a/plugins/uml/org.eclipse.papyrus.uml.menu/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.menu/META-INF/MANIFEST.MF
index 1d1a36de80f..fc99c7e554a 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.menu/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.menu/META-INF/MANIFEST.MF
@@ -6,9 +6,9 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.emf;bundle-version="2.6.0",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
org.eclipse.uml2.uml;bundle-version:="3.2.0",
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0",
org.eclipse.core.expressions,
- org.eclipse.papyrus.properties;bundle-version:="0.9.0"
+ org.eclipse.papyrus.views.properties;bundle-version:="0.9.0"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-Version: 0.9.0.qualifier
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/.project b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/.project
index ae7f3bfb113..a590ad467cd 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/.project
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.runtime.uml</name>
+ <name>org.eclipse.papyrus.uml.properties.runtime</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/META-INF/MANIFEST.MF b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/META-INF/MANIFEST.MF
index bb2eb05acf4..443e4655b57 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/META-INF/MANIFEST.MF
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/META-INF/MANIFEST.MF
@@ -1,10 +1,10 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.papyrus.log;bundle-version="0.9.0",
org.eclipse.uml2.uml;bundle-version="3.1.0",
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0",
org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.0",
org.eclipse.gmf.runtime.emf.type.core;bundle-version="1.4.0"
Bundle-Vendor: %providerName
@@ -14,7 +14,6 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.runtime.uml.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.properties.runtime.uml;single
- ton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.properties.runtime;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/src/org/eclipse/papyrus/properties/runtime/uml/Activator.java b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/src/org/eclipse/papyrus/properties/runtime/uml/Activator.java
index 39fb69d40b6..31865bbd7e3 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/src/org/eclipse/papyrus/properties/runtime/uml/Activator.java
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.runtime/src/org/eclipse/papyrus/properties/runtime/uml/Activator.java
@@ -12,7 +12,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
/** The plug-in ID */
- public static final String PLUGIN_ID = "org.eclipse.papyrus.properties.runtime.uml"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.uml.properties.runtime"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/.project b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/.project
index f3d6670ed55..a0f44b67e2a 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/.project
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.tabbed.profile</name>
+ <name>org.eclipse.papyrus.uml.properties.tabbed.profile</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/META-INF/MANIFEST.MF b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/META-INF/MANIFEST.MF
index 19f3a2327b5..3c865c14010 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/META-INF/MANIFEST.MF
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/META-INF/MANIFEST.MF
@@ -13,7 +13,6 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.tabbed.profile.Activa
tor
-Bundle-SymbolicName: org.eclipse.papyrus.properties.tabbed.profile;sin
- gleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.properties.tabbed.profile;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/src/org/eclipse/papyrus/properties/tabbed/profile/Activator.java b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/src/org/eclipse/papyrus/properties/tabbed/profile/Activator.java
index 425b7ddce37..7cc1e630d68 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/src/org/eclipse/papyrus/properties/tabbed/profile/Activator.java
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbed.profile/src/org/eclipse/papyrus/properties/tabbed/profile/Activator.java
@@ -23,7 +23,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
/** The plug-in ID **/
- public static final String PLUGIN_ID = "org.eclipse.papyrus.properties.tabbed.profile"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.uml.properties.tabbed.profile"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/.project b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/.project
index 91f3d5fbd45..2a95967ebba 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/.project
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.tabbedproperties.appearance</name>
+ <name>org.eclipse.papyrus.uml.properties.tabbedproperties.appearance</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/META-INF/MANIFEST.MF b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/META-INF/MANIFEST.MF
index 812ecbfc74e..519603bf3c9 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/META-INF/MANIFEST.MF
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version:="1.1.0",
+Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="1.1.0",
org.eclipse.papyrus.diagram.common;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.tabbedproperties.appearance
Bundle-Vendor: %providerName
@@ -10,7 +10,6 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.tabbedproperties.appearance.Acti
vator
-Bundle-SymbolicName: org.eclipse.papyrus.tabbedproperties.appearance;s
- ingleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.properties.tabbedproperties.appearance;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/src/org/eclipse/papyrus/tabbedproperties/appearance/Activator.java b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/src/org/eclipse/papyrus/tabbedproperties/appearance/Activator.java
index 82ae5c39dc7..e92b632a55f 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/src/org/eclipse/papyrus/tabbedproperties/appearance/Activator.java
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.appearance/src/org/eclipse/papyrus/tabbedproperties/appearance/Activator.java
@@ -18,7 +18,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
// The plug-in ID
- public static final String PLUGIN_ID = "org.eclipse.papyrus.tabbedproperties.appearance";
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.uml.properties.tabbedproperties.appearance";
// The shared instance
private static Activator plugin;
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/.project b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/.project
index 51df358c924..7fc721d744b 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/.project
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.tabbedproperties.comments</name>
+ <name>org.eclipse.papyrus.uml.properties.tabbedproperties.comments</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/META-INF/MANIFEST.MF b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/META-INF/MANIFEST.MF
index 4703e5ae4e1..b8a8fa49093 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/META-INF/MANIFEST.MF
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/META-INF/MANIFEST.MF
@@ -4,11 +4,11 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.ui.views.properties.tabbed,
org.eclipse.emf.ecore;bundle-version="2.5.0",
org.eclipse.uml2.uml;bundle-version="3.0.0",
- org.eclipse.emf.edit;bundle-version:="2.5.0",
+ org.eclipse.emf.edit;bundle-version="2.5.0",
org.eclipse.papyrus.core;bundle-version="0.9.0",
org.eclipse.papyrus.diagram.common;bundle-version="0.9.0",
org.eclipse.epf.richtext;bundle-version="1.2.0",
- org.eclipse.emf.edit.ui;bundle-version:="2.5.0",
+ org.eclipse.emf.edit.ui;bundle-version="2.5.0",
org.eclipse.papyrus.log;bundle-version="0.9.0",
org.eclipse.papyrus.extensionpoints.editors;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.tabbedproperties.comments,
@@ -20,7 +20,6 @@ Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.tabbedproperties.comments.Activa
tor
-Bundle-SymbolicName: org.eclipse.papyrus.tabbedproperties.comments;sin
- gleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.properties.tabbedproperties.comments;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/src/org/eclipse/papyrus/tabbedproperties/comments/Activator.java b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/src/org/eclipse/papyrus/tabbedproperties/comments/Activator.java
index 929211509d5..8701d537ec9 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/src/org/eclipse/papyrus/tabbedproperties/comments/Activator.java
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.tabbedproperties.comments/src/org/eclipse/papyrus/tabbedproperties/comments/Activator.java
@@ -10,7 +10,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
// The plug-in ID
- public static final String PLUGIN_ID = "org.eclipse.papyrus.tabbedproperties.comments";
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.uml.properties.tabbedproperties.comments";
// The shared instance
private static Activator plugin;
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/.project b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/.project
index b1e25d3ffad..cc095b234fc 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/.project
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.view.uml</name>
+ <name>org.eclipse.papyrus.uml.properties.view</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/META-INF/MANIFEST.MF b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/META-INF/MANIFEST.MF
index e6801eb842a..a79cd131651 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/META-INF/MANIFEST.MF
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/META-INF/MANIFEST.MF
@@ -1,10 +1,10 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.uml2.uml;bundle-version="3.1.0",
org.eclipse.papyrus.log;bundle-version="0.9.0",
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0",
org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.0"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
@@ -13,7 +13,6 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.view.uml.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.properties.view.uml;singleton
- :=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.properties.view;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/src/org/eclipse/papyrus/properties/view/uml/Activator.java b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/src/org/eclipse/papyrus/properties/view/uml/Activator.java
index 18b5fd99347..9df8f107e8c 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/src/org/eclipse/papyrus/properties/view/uml/Activator.java
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties.view/src/org/eclipse/papyrus/properties/view/uml/Activator.java
@@ -9,7 +9,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
// The plug-in ID
- public static final String PLUGIN_ID = "org.eclipse.papyrus.properties.view.uml"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.uml.properties.view"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties/.project b/plugins/uml/properties/org.eclipse.papyrus.uml.properties/.project
index cbdebc8dca9..46d1b9bcd82 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties/.project
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.uml</name>
+ <name>org.eclipse.papyrus.uml.properties</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties/META-INF/MANIFEST.MF b/plugins/uml/properties/org.eclipse.papyrus.uml.properties/META-INF/MANIFEST.MF
index 192b836be5c..4b18152cbdb 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties/META-INF/MANIFEST.MF
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.properties.model;bundle-version="0.9.0",
- org.eclipse.papyrus.properties;bundle-version:="0.9.0",
+ org.eclipse.papyrus.views.properties.model;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties;bundle-version="0.9.0",
org.eclipse.papyrus.widgets;bundle-version="0.9.0",
org.eclipse.papyrus.diagram.common;bundle-version="0.9.0",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
@@ -9,7 +9,7 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.emf.databinding;bundle-version="1.2.0",
org.eclipse.jface;bundle-version="3.6.1",
org.eclipse.core.databinding.property;bundle-version="1.3.0",
- org.eclipse.papyrus.log;bundle-version:="0.9.0",
+ org.eclipse.papyrus.log;bundle-version="0.9.0",
org.eclipse.ui;bundle-version="3.6.1",
org.eclipse.papyrus.profile;bundle-version="0.9.0",
org.eclipse.papyrus.uml.modelexplorer.widgets;bundle-version="0.9.0",
@@ -28,7 +28,6 @@ Bundle-Localization: plugin
Bundle-Name: %Bundle-Name
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.uml.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.properties.uml;singleton:=tru
- e
+Bundle-SymbolicName: org.eclipse.papyrus.uml.properties;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties/schema/org.eclipse.papyrus.properties.uml.languageEditor.exsd b/plugins/uml/properties/org.eclipse.papyrus.uml.properties/schema/org.eclipse.papyrus.properties.uml.languageEditor.exsd
index ceb0e70afbb..7b159c54000 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties/schema/org.eclipse.papyrus.properties.uml.languageEditor.exsd
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties/schema/org.eclipse.papyrus.properties.uml.languageEditor.exsd
@@ -1,9 +1,9 @@
<?xml version='1.0' encoding='UTF-8'?>
<!-- Schema file written by PDE -->
-<schema targetNamespace="org.eclipse.papyrus.properties.uml" xmlns="http://www.w3.org/2001/XMLSchema">
+<schema targetNamespace="org.eclipse.papyrus.uml.properties" xmlns="http://www.w3.org/2001/XMLSchema">
<annotation>
<appinfo>
- <meta.schema plugin="org.eclipse.papyrus.properties.uml" id="org.eclipse.papyrus.properties.uml.languageEditor" name="LanguageEditor"/>
+ <meta.schema plugin="org.eclipse.papyrus.uml.properties" id="org.eclipse.papyrus.properties.uml.languageEditor" name="LanguageEditor"/>
</appinfo>
<documentation>
[Enter description of this extension point.]
diff --git a/plugins/uml/properties/org.eclipse.papyrus.uml.properties/src/org/eclipse/papyrus/properties/uml/Activator.java b/plugins/uml/properties/org.eclipse.papyrus.uml.properties/src/org/eclipse/papyrus/properties/uml/Activator.java
index 6dd46ad1335..e0518d01b25 100644
--- a/plugins/uml/properties/org.eclipse.papyrus.uml.properties/src/org/eclipse/papyrus/properties/uml/Activator.java
+++ b/plugins/uml/properties/org.eclipse.papyrus.uml.properties/src/org/eclipse/papyrus/properties/uml/Activator.java
@@ -25,7 +25,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
/** The plug-in ID */
- public static final String PLUGIN_ID = "org.eclipse.papyrus.properties.uml"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.uml.properties"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;
diff --git a/plugins/uml/table/org.eclipse.papyrus.uml.table.default/.project b/plugins/uml/table/org.eclipse.papyrus.uml.table.default/.project
index 21c3a95b25a..9d38ffd9417 100644
--- a/plugins/uml/table/org.eclipse.papyrus.uml.table.default/.project
+++ b/plugins/uml/table/org.eclipse.papyrus.uml.table.default/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.table.default</name>
+ <name>org.eclipse.papyrus.uml.table.default</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/table/org.eclipse.papyrus.uml.table.default/META-INF/MANIFEST.MF b/plugins/uml/table/org.eclipse.papyrus.uml.table.default/META-INF/MANIFEST.MF
index ba1cd8b505b..729d2beda5e 100644
--- a/plugins/uml/table/org.eclipse.papyrus.uml.table.default/META-INF/MANIFEST.MF
+++ b/plugins/uml/table/org.eclipse.papyrus.uml.table.default/META-INF/MANIFEST.MF
@@ -14,6 +14,6 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.table.defaultt.Activator
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.table.default;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.table.default;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/table/org.eclipse.papyrus.uml.table.default/src/org/eclipse/papyrus/table/defaultt/Activator.java b/plugins/uml/table/org.eclipse.papyrus.uml.table.default/src/org/eclipse/papyrus/table/defaultt/Activator.java
index ae2311178d2..490a59fc5c1 100644
--- a/plugins/uml/table/org.eclipse.papyrus.uml.table.default/src/org/eclipse/papyrus/table/defaultt/Activator.java
+++ b/plugins/uml/table/org.eclipse.papyrus.uml.table.default/src/org/eclipse/papyrus/table/defaultt/Activator.java
@@ -25,7 +25,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
/** The plug-in ID */
- public static final String ID = "org.eclipse.papyrus.diagram.nattable"; //$NON-NLS-1$
+ public static final String ID = "org.eclipse.papyrus.uml.table.defaultt"; //$NON-NLS-1$
/** The shared instance */
private static Activator plugin;
diff --git a/plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/.project b/plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/.project
index 8e0973919b2..c94ccff2566 100644
--- a/plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/.project
+++ b/plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.table.widgets.celleditors.uml</name>
+ <name>org.eclipse.papyrus.uml.table.widgets.celleditors</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/META-INF/MANIFEST.MF b/plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/META-INF/MANIFEST.MF
index 4b56af5d02d..1930e45621a 100644
--- a/plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/META-INF/MANIFEST.MF
+++ b/plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/META-INF/MANIFEST.MF
@@ -9,8 +9,8 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.uml.modelexplorer.widgets;bundle-version="0.9.0",
org.eclipse.emf.facet.widgets,
org.eclipse.emf.facet.infra.common.core,
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.uml;bundle-version="0.9.0"
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.properties;bundle-version="0.9.0"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-Version: 0.9.0.qualifier
@@ -18,7 +18,6 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.widget.celleditors.uml.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.table.widgets.celleditors.uml
- ;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.table.widgets.celleditors;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/src/org/eclipse/papyrus/widget/celleditors/uml/Activator.java b/plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/src/org/eclipse/papyrus/widget/celleditors/uml/Activator.java
index f578f19565d..60c576f0eac 100644
--- a/plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/src/org/eclipse/papyrus/widget/celleditors/uml/Activator.java
+++ b/plugins/uml/table/org.eclipse.papyrus.uml.table.widgets.celleditors/src/org/eclipse/papyrus/widget/celleditors/uml/Activator.java
@@ -23,7 +23,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
// The plug-in ID
- public static final String PLUGIN_ID = "org.eclipse.papyrus.widget.celleditors.uml"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.uml.table.widget.celleditors"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.generator/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.generator/.project
index f88b2edf0b0..69377c817d4 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.generator/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.generator/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.collaborationuse.editor.xtext.generator</name>
+ <name>org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.generator</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.generator/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.generator/META-INF/MANIFEST.MF
index 887ff36a702..e4050b7d8a3 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.generator/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.generator/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.collaborationuse.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.collaborationuse.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xpand;visibility:=reexport,
org.eclipse.xtend;visibility:=reexport,
org.eclipse.xtext;visibility:=reexport,
@@ -12,7 +12,7 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.collaborationuse.editor.xtext.generator;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.generator;singleton:=true
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui/.project
index 8c791a86a32..20c1bba8c2a 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.collaborationuse.editor.xtext.ui</name>
+ <name>org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui/META-INF/MANIFEST.MF
index cd5819bd0d8..742ef7fc6d8 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui/META-INF/MANIFEST.MF
@@ -5,30 +5,30 @@ Bundle-ActivationPolicy: lazy
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.papyrus.collaborationuse.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.collaborationuse.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xtext.ui,
org.eclipse.ui.editors;bundle-version="3.5.0",
- org.eclipse.ui.ide;bundle-version:="3.5.0",
+ org.eclipse.ui.ide;bundle-version="3.5.0",
org.eclipse.xtext.ui.shared,
org.eclipse.ui,
org.eclipse.xtext.builder,
org.antlr.runtime,
org.eclipse.papyrus.extensionpoints.editors;bundle-version="0.9.0",
- org.eclipse.papyrus.umlutils;bundle-version:="0.9.0",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0",
org.eclipse.gmf.runtime.common.core;bundle-version="1.4.0",
org.eclipse.gmf.runtime.emf.commands.core;bundle-version="1.4.0",
org.eclipse.papyrus.core;bundle-version="0.9.0",
org.eclipse.uml2.uml;bundle-version="3.1.1",
- org.eclipse.papyrus.properties.runtime;bundle-version:="0.9.0",
- org.eclipse.papyrus.service.edit;bundle-version:="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
org.eclipse.papyrus.diagram.common;bundle-version="0.9.0",
- org.eclipse.papyrus.common.editor.xtext.ui;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.textedit.common.xtext.ui;bundle-version="0.9.0",
org.eclipse.xtext.gmf.glue;bundle-version="0.8.0"
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.collaborationuse.editor.xtext.ui
.internal.UmlCollaborationUseActivator
-Bundle-SymbolicName: org.eclipse.papyrus.collaborationuse.editor.xtext.ui;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.collaborationuse.xtext.ui;singleton:=true
Import-Package: org.apache.log4j
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext/.project
index c29da269c13..b9e7669247c 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.collaborationuse.editor.xtext</name>
+ <name>org.eclipse.papyrus.uml.textedit.collaborationuse.xtext</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext/META-INF/MANIFEST.MF
index 7280a05b6b1..05a5406b883 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.collaborationuse.xtext/META-INF/MANIFEST.MF
@@ -11,11 +11,11 @@ Require-Bundle: org.eclipse.xtext,
org.eclipse.emf.ecore,
org.eclipse.emf.common,
org.antlr.runtime,
- org.eclipse.uml2.codegen.ecore;bundle-version:="1.6.0",
+ org.eclipse.uml2.codegen.ecore;bundle-version="1.6.0",
org.eclipse.uml2.uml;bundle-version="3.1.0",
org.eclipse.papyrus.log;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
- org.eclipse.papyrus.common.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.textedit.common.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xtext.gmf.glue;bundle-version="0.8.0"
Export-Package: org.eclipse.papyrus.collaborationuse.editor.xtext,
org.eclipse.papyrus.collaborationuse.editor.xtext.formatting,
@@ -34,7 +34,7 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.collaborationuse.editor.xtext;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.collaborationuse.xtext;singleton:=true
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.generator/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.generator/.project
index d8a0cb32474..d378f60a1c6 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.generator/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.generator/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.common.editor.xtext.generator</name>
+ <name>org.eclipse.papyrus.uml.textedit.common.xtext.generator</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.generator/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.generator/META-INF/MANIFEST.MF
index b72153fa7d3..37c8d1a48b4 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.generator/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.generator/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.common.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.common.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xpand;visibility:=reexport,
org.eclipse.xtend;visibility:=reexport,
org.eclipse.xtext;visibility:=reexport,
@@ -12,7 +12,7 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.common.editor.xtext.generator;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.common.xtext.generator;singleton:=true
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.ui/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.ui/.project
index 36da0c09192..369d7dd0b4c 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.ui/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.ui/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.common.editor.xtext.ui</name>
+ <name>org.eclipse.papyrus.uml.textedit.common.xtext.ui</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.ui/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.ui/META-INF/MANIFEST.MF
index 66295f53e48..dfe6b512611 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.ui/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext.ui/META-INF/MANIFEST.MF
@@ -11,7 +11,7 @@ Bundle-ActivationPolicy: lazy
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.papyrus.common.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.common.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xtext.ui,
org.eclipse.ui.editors;bundle-version="3.5.0",
org.eclipse.ui.ide;bundle-version="3.5.0",
@@ -25,7 +25,7 @@ Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.common.editor.xtext.ui.internal.
UmlCommonActivator
-Bundle-SymbolicName: org.eclipse.papyrus.common.editor.xtext.ui;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.common.xtext.ui;singleton:=true
Import-Package: org.apache.log4j,
org.eclipse.uml2.uml
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext/.project
index e88e78b23fe..fd4f8c8830d 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.common.editor.xtext</name>
+ <name>org.eclipse.papyrus.uml.textedit.common.xtext</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext/META-INF/MANIFEST.MF
index be31e499230..b82c10433c3 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.common.xtext/META-INF/MANIFEST.MF
@@ -34,6 +34,6 @@ Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Import-Package: org.apache.log4j,
org.eclipse.core.runtime
-Bundle-SymbolicName: org.eclipse.papyrus.common.editor.xtext;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.common.xtext;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui/.project
index a94de03330a..9ca32572cc7 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.connectionpointreference.editor.xtext.ui</name>
+ <name>org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui/META-INF/MANIFEST.MF
index 08496988752..9f1a82b5f7d 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.connectionpointreference.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xtext.ui,
org.eclipse.ui.editors;bundle-version="3.5.0",
org.eclipse.ui.ide;bundle-version="3.5.0",
@@ -10,10 +10,10 @@ Require-Bundle: org.eclipse.papyrus.connectionpointreference.editor.xtext;bundle
org.eclipse.papyrus.extensionpoints.editors;bundle-version="0.9.0",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.4.0",
org.eclipse.uml2.uml;bundle-version="3.1.0",
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0",
org.eclipse.core.expressions;bundle-version="3.4.200",
org.eclipse.papyrus.core;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.xtext.gmf.glue;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.connectionpointreference.editor.xt
ext.ui.contentassist.antlr
@@ -24,8 +24,7 @@ Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.connectionpointreference.editor.
xtext.ui.internal.UMLConnectionPointReferenceActivator
-Bundle-SymbolicName: org.eclipse.papyrus.connectionpointreference.edit
- or.xtext.ui;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext.ui;singleton:=true
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext/.project
index a97b9839803..f6ad632b1c0 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.connectionpointreference.editor.xtext</name>
+ <name>org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext/META-INF/MANIFEST.MF
index d212a4561e0..425a79cd801 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext/META-INF/MANIFEST.MF
@@ -29,6 +29,6 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Import-Package: org.apache.log4j
-Bundle-SymbolicName: org.eclipse.papyrus.connectionpointreference.editor.xtext;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.connectionpointreference.xtext;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext/.project
index 58744a0a5c3..cbecfdae5a5 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.constraintwithessentialocl.editor.xtext</name>
+ <name>org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext/META-INF/MANIFEST.MF
index 29843ba08da..5b7fff2423f 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext/META-INF/MANIFEST.MF
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
-Bundle-SymbolicName: org.eclipse.papyrus.constraintwithessentialocl.editor.xtext;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.constraintwithessentialocl.xtext;singleton:=true
Bundle-Version: 3.1.0.qualifier
Bundle-Activator: org.eclipse.ocl.examples.xtext.papyrus.EssentialOCLPopupPlugin
Require-Bundle: org.eclipse.ui,
@@ -13,7 +13,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.ocl.examples.xtext.essentialocl.ui;bundle-version="3.1.0",
org.eclipse.gef;bundle-version="3.7.0",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.5.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.8.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.8.0",
org.eclipse.papyrus.core;bundle-version="0.8.0",
org.eclipse.core.expressions
Bundle-ActivationPolicy: lazy
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.generator/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.generator/.project
index a4ddac1c485..3455ab4c576 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.generator/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.generator/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.message.editor.xtext.generator</name>
+ <name>org.eclipse.papyrus.uml.textedit.message.xtext.generator</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.generator/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.generator/META-INF/MANIFEST.MF
index f52c4e8898a..a25a7a551c2 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.generator/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.generator/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.message.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.message.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xpand;visibility:=reexport,
org.eclipse.xtend;visibility:=reexport,
org.eclipse.xtext;visibility:=reexport,
@@ -12,7 +12,7 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.message.editor.xtext.generator;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.message.xtext.generator;singleton:=true
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.ui/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.ui/.project
index 7749a10e606..bb144941801 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.ui/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.ui/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.message.editor.xtext.ui</name>
+ <name>org.eclipse.papyrus.uml.textedit.message.xtext.ui</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.ui/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.ui/META-INF/MANIFEST.MF
index 2b6205beb19..3d56ce83b25 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.ui/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext.ui/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Bundle-ActivationPolicy: lazy
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.papyrus.message.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.message.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xtext.ui,
org.eclipse.ui.editors;bundle-version="3.5.0",
org.eclipse.ui.ide;bundle-version="3.5.0",
@@ -19,15 +19,14 @@ Require-Bundle: org.eclipse.papyrus.message.editor.xtext;bundle-version="0.9.0";
org.eclipse.gmf.runtime.emf.commands.core;bundle-version="1.4.0",
org.eclipse.core.expressions;bundle-version="3.4.200",
org.eclipse.papyrus.core;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.xtext.gmf.glue;bundle-version="0.9.0"
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.message.editor.xtext.ui.internal
.UmlMessageActivator
-Bundle-SymbolicName: org.eclipse.papyrus.message.editor.xtext.ui;singl
- eton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.message.xtext.ui;singleton:=true
Import-Package: org.apache.log4j,
org.eclipse.gmf.runtime.diagram.ui.editparts,
org.eclipse.gmf.runtime.emf.commands.core.command,
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext/.project
index 09c0f07d8b0..7ce9e977006 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.message.editor.xtext</name>
+ <name>org.eclipse.papyrus.uml.textedit.message.xtext</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext/META-INF/MANIFEST.MF
index 4b62cf83b3d..ec8b71fe961 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.message.xtext/META-INF/MANIFEST.MF
@@ -14,7 +14,7 @@ Require-Bundle: org.eclipse.xtext,
org.eclipse.uml2.codegen.ecore;bundle-version="1.6.0",
org.eclipse.uml2.uml;bundle-version="3.1.0",
org.eclipse.papyrus.log;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.xtext.gmf.glue;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.message.editor.xtext,
org.eclipse.papyrus.message.editor.xtext.parseTreeConstruction,
@@ -32,8 +32,7 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.message.editor.xtext;singleto
- n:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.message.xtext;singleton:=true
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.generator/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.generator/.project
index 9828753b820..a8310fb4445 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.generator/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.generator/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.parameter.editor.xtext.generator</name>
+ <name>org.eclipse.papyrus.uml.textedit.parameter.xtext.generator</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.generator/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.generator/META-INF/MANIFEST.MF
index bc716e66f09..a2ef8e5cb9b 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.generator/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.generator/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.parameter.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.parameter.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xpand;visibility:=reexport,
org.eclipse.xtend;visibility:=reexport,
org.eclipse.xtext;visibility:=reexport,
@@ -12,7 +12,7 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.parameter.editor.xtext.generator;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.parameter.xtext.generator;singleton:=true
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.ui/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.ui/.project
index 8116e288c51..5cf40888788 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.ui/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.ui/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.parameter.editor.xtext.ui</name>
+ <name>org.eclipse.papyrus.uml.textedit.parameter.xtext.ui</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.ui/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.ui/META-INF/MANIFEST.MF
index 384abf2376f..5230f75ff4a 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.ui/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext.ui/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Bundle-ActivationPolicy: lazy
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.papyrus.parameter.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.parameter.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xtext.ui,
org.eclipse.ui.editors;bundle-version="3.5.0",
org.eclipse.ui.ide;bundle-version="3.5.0",
@@ -16,18 +16,17 @@ Require-Bundle: org.eclipse.papyrus.parameter.editor.xtext;bundle-version="0.9.0
org.eclipse.papyrus.extensionpoints.editors;bundle-version="0.9.0",
org.eclipse.xtext.gmf.glue;bundle-version="0.9.0",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0",
- org.eclipse.papyrus.common.editor.xtext;bundle-version="0.9.0",
- org.eclipse.papyrus.common.editor.xtext.ui;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.textedit.common.xtext;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.textedit.common.xtext.ui;bundle-version="0.9.0",
org.eclipse.papyrus.log;bundle-version="0.9.0"
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.parameter.editor.xtext.ui.intern
al.UmlParameterActivator
-Bundle-SymbolicName: org.eclipse.papyrus.parameter.editor.xtext.ui;sin
- gleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.parameter.xtext.ui;singleton:=true
Import-Package: org.apache.log4j,
org.eclipse.gmf.runtime.common.core.command,
org.eclipse.gmf.runtime.emf.type.core.requests,
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext/.project
index 4fe1a5bbf12..732d86ba1ba 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.parameter.editor.xtext</name>
+ <name>org.eclipse.papyrus.uml.textedit.parameter.xtext</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext/META-INF/MANIFEST.MF
index 0a949107f92..db813b94bed 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.parameter.xtext/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Require-Bundle: org.eclipse.xtext,
org.eclipse.emf.ecore,
org.eclipse.emf.common,
org.antlr.runtime,
- org.eclipse.papyrus.common.editor.xtext;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.textedit.common.xtext;bundle-version="0.9.0",
org.eclipse.xtext.gmf.glue
Export-Package: org.eclipse.papyrus.parameter.editor.xtext,
org.eclipse.papyrus.parameter.editor.xtext.parseTreeConstruction,
@@ -30,7 +30,7 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.parameter.editor.xtext;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.parameter.xtext;singleton:=true
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.generator/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.generator/.project
index 47bb14e23d8..78bc1206519 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.generator/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.generator/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.property.editor.xtext.generator</name>
+ <name>org.eclipse.papyrus.uml.textedit.property.xtext.generator</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.generator/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.generator/META-INF/MANIFEST.MF
index 789b4274c61..213ce91dd04 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.generator/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.generator/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.property.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.property.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xpand;visibility:=reexport,
org.eclipse.xtend;visibility:=reexport,
org.eclipse.xtext;visibility:=reexport,
@@ -12,7 +12,7 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.property.editor.xtext.generator;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.property.xtext.generator;singleton:=true
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.ui/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.ui/.project
index a35faedcf9f..3e661517be2 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.ui/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.ui/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.property.editor.xtext.ui</name>
+ <name>org.eclipse.papyrus.uml.textedit.property.xtext.ui</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.ui/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.ui/META-INF/MANIFEST.MF
index 4a2ce1e9647..7638b6501f8 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.ui/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext.ui/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-ActivationPolicy: lazy
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.papyrus.property.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.property.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xtext.ui,
org.eclipse.ui.editors;bundle-version="3.5.0",
org.eclipse.ui.ide;bundle-version="3.5.0",
@@ -18,17 +18,16 @@ Require-Bundle: org.eclipse.papyrus.property.editor.xtext;bundle-version="0.9.0"
org.eclipse.xtext.gmf.glue;bundle-version="0.9.0",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.4.0",
org.eclipse.uml2.uml;bundle-version="3.1.0",
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0",
org.eclipse.core.expressions;bundle-version="3.4.200",
org.eclipse.papyrus.core;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0"
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.property.editor.xtext.ui.interna
l.UmlPropertyActivator
-Bundle-SymbolicName: org.eclipse.papyrus.property.editor.xtext.ui;sing
- leton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.property.xtext.ui;singleton:=true
Import-Package: org.apache.log4j
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/.project
index c07e257eed4..b3763c47d78 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.property.editor.xtext</name>
+ <name>org.eclipse.papyrus.uml.textedit.property.xtext</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/META-INF/MANIFEST.MF
index 4d3b6b6560e..fb4cfaef7eb 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/META-INF/MANIFEST.MF
@@ -32,7 +32,6 @@ Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Import-Package: org.apache.log4j
-Bundle-SymbolicName: org.eclipse.papyrus.property.editor.xtext;singlet
- on:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.property.xtext;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/src/org/eclipse/papyrus/property/editor/xtext/GenerateUmlProperty.mwe2 b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/src/org/eclipse/papyrus/property/editor/xtext/GenerateUmlProperty.mwe2
index c1dd91efc44..355f64b595c 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/src/org/eclipse/papyrus/property/editor/xtext/GenerateUmlProperty.mwe2
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/src/org/eclipse/papyrus/property/editor/xtext/GenerateUmlProperty.mwe2
@@ -1,10 +1,10 @@
-module org.eclipse.papyrus.property.editor.xtext.UmlProperty
+module org.eclipse.papyrus.uml.textedit.property.xtext.UmlProperty
import org.eclipse.emf.mwe.utils.*
import org.eclipse.xtext.generator.*
import org.eclipse.xtext.ui.generator.*
-var grammarURI = "classpath:/org/eclipse/papyrus/property/editor/xtext/UmlProperty.xtext"
+var grammarURI = "classpath:/org/eclipse/papyrus/uml/textedit/property/xtext/UmlProperty.xtext"
var file.extensions = "umlproperty"
var projectName = "org.eclipse.papyrus.property.editor.xtext"
var runtimeProject = "../${projectName}"
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/src/org/eclipse/papyrus/property/editor/xtext/UmlProperty.xtext b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/src/org/eclipse/papyrus/property/editor/xtext/UmlProperty.xtext
index c4129157e06..c9c95d0ed31 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/src/org/eclipse/papyrus/property/editor/xtext/UmlProperty.xtext
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.property.xtext/src/org/eclipse/papyrus/property/editor/xtext/UmlProperty.xtext
@@ -12,11 +12,11 @@
*
*****************************************************************************/
-grammar org.eclipse.papyrus.property.editor.xtext.UmlProperty with org.eclipse.xtext.common.Terminals
+grammar org.eclipse.papyrus.uml.textedit.property.xtext.UmlProperty with org.eclipse.xtext.common.Terminals
import "http://www.eclipse.org/uml2/3.0.0/UML" as uml
-generate umlProperty "http://www.eclipse.org/papyrus/property/editor/xtext/UmlProperty"
+generate umlProperty "http://www.eclipse.org/papyrus/uml/textedit/property/xtext/UmlProperty"
PropertyRule:
visibility = VisibilityKind
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.generator/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.generator/.project
index 61695bbebd8..41e5de27193 100755
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.generator/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.generator/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.state.editor.xtext.generator</name>
+ <name>org.eclipse.papyrus.uml.textedit.state.xtext.generator</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.generator/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.generator/META-INF/MANIFEST.MF
index 339270e5a45..16179ade5dc 100755
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.generator/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.generator/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.state.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.state.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xpand;visibility:=reexport,
org.eclipse.xtend;visibility:=reexport,
org.eclipse.xtext;visibility:=reexport,
@@ -11,7 +11,7 @@ Bundle-ActivationPolicy: lazy
Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.state.editor.xtext.generator;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.state.xtext.generator;singleton:=true
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.ui/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.ui/.project
index 9dc12615ff6..58ef9d920c1 100755
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.ui/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.ui/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.state.editor.xtext.ui</name>
+ <name>org.eclipse.papyrus.uml.textedit.state.xtext.ui</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.ui/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.ui/META-INF/MANIFEST.MF
index 5ae03d8aa1d..6f1532e01bb 100755
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.ui/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext.ui/META-INF/MANIFEST.MF
@@ -5,7 +5,7 @@ Bundle-ActivationPolicy: lazy
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.papyrus.state.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.state.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xtext.ui,
org.eclipse.ui.editors;bundle-version="3.5.0",
org.eclipse.ui.ide;bundle-version="3.5.0",
@@ -18,14 +18,13 @@ Require-Bundle: org.eclipse.papyrus.state.editor.xtext;bundle-version="0.9.0";vi
org.eclipse.papyrus.extensionpoints.editors;bundle-version="0.9.0",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.4.0",
org.eclipse.papyrus.core;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.xtext.gmf.glue;bundle-version="0.9.0"
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.state.editor.xtext.ui.internal.U
mlStateActivator
-Bundle-SymbolicName: org.eclipse.papyrus.state.editor.xtext.ui;singlet
- on:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.state.xtext.ui;singleton:=true
Import-Package: org.apache.log4j
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/.project
index 4c8320620fc..98ae44994fa 100755
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.state.editor.xtext</name>
+ <name>org.eclipse.papyrus.uml.textedit.state.xtext</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/META-INF/MANIFEST.MF
index 4e16b3b6635..11e24823361 100755
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/META-INF/MANIFEST.MF
@@ -31,6 +31,6 @@ Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Import-Package: org.apache.log4j
-Bundle-SymbolicName: org.eclipse.papyrus.state.editor.xtext;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.state.xtext;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/src/org/eclipse/papyrus/state/editor/xtext/GenerateUmlState.mwe2 b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/src/org/eclipse/papyrus/state/editor/xtext/GenerateUmlState.mwe2
index 50ed6074c46..cdc2757b737 100755
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/src/org/eclipse/papyrus/state/editor/xtext/GenerateUmlState.mwe2
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/src/org/eclipse/papyrus/state/editor/xtext/GenerateUmlState.mwe2
@@ -1,4 +1,4 @@
-module org.eclipse.papyrus.state.editor.xtext.UmlState
+module org.eclipse.papyrus.uml.textedit.state.xtext.UmlState
import org.eclipse.emf.mwe.utils.*
import org.eclipse.xtext.generator.*
@@ -6,7 +6,7 @@ import org.eclipse.xtext.ui.generator.*
var grammarURI = "classpath:/org/eclipse/papyrus/state/editor/xtext/UmlState.xtext"
var file.extensions = "umlstate"
-var projectName = "org.eclipse.papyrus.state.editor.xtext"
+var projectName = "org.eclipse.papyrus.uml.textedit.state.xtext"
var runtimeProject = "../${projectName}"
Workflow {
@@ -19,9 +19,9 @@ Workflow {
registerGeneratedEPackage = "org.eclipse.uml2.uml.UMLPackage"
registerGeneratedEPackage = "org.eclipse.uml2.codegen.ecore.genmodel.GenModelPackage"
uriMap = {from="platform:/plugin/org.eclipse.emf.ecore/model/Ecore.ecore"
- to="platform:/resource/org.eclipse.papyrus.state.editor.xtext/model/Ecore.ecore"}
+ to="platform:/resource/org.eclipse.papyrus.uml.textedit.state.xtext/model/Ecore.ecore"}
uriMap = {from="platform:/plugin/org.eclipse.emf.ecore/model/Ecore.genmodel"
- to="platform:/resource/org.eclipse.papyrus.state.editor.xtext/model/Ecore.genmodel"}
+ to="platform:/resource/org.eclipse.papyrus.uml.textedit.state.xtext/model/Ecore.genmodel"}
}
component = DirectoryCleaner {
@@ -46,7 +46,7 @@ Workflow {
// generates Java API for the generated EPackages
fragment = ecore.EcoreGeneratorFragment {
- referencedGenModels = "platform:/resource/org.eclipse.papyrus.state.editor.xtext/model/UML.genmodel"
+ referencedGenModels = "platform:/resource/org.eclipse.papyrus.uml.textedit.state.xtext/model/UML.genmodel"
}
// the serialization component
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/src/org/eclipse/papyrus/state/editor/xtext/UmlState.xtext b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/src/org/eclipse/papyrus/state/editor/xtext/UmlState.xtext
index de49702f53f..f6f272e3e3b 100755
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/src/org/eclipse/papyrus/state/editor/xtext/UmlState.xtext
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.state.xtext/src/org/eclipse/papyrus/state/editor/xtext/UmlState.xtext
@@ -12,11 +12,11 @@
*
*****************************************************************************/
-grammar org.eclipse.papyrus.state.editor.xtext.UmlState with org.eclipse.xtext.common.Terminals
+grammar org.eclipse.papyrus.uml.textedit.state.xtext.UmlState with org.eclipse.xtext.common.Terminals
import "http://www.eclipse.org/uml2/3.0.0/UML" as uml
-generate umlState "http://www.eclipse.org/papyrus/state/editor/xtext/UmlState"
+generate umlState "http://www.eclipse.org/papyrus/uml/textedit/state/xtext/UmlState"
StateRule :
name = ID
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.generator/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.generator/.project
index f072cfb38eb..a06d7551bfa 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.generator/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.generator/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.transition.editor.xtext.generator</name>
+ <name>org.eclipse.papyrus.uml.textedit.transition.xtext.generator</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.generator/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.generator/META-INF/MANIFEST.MF
index b28e6fa44ad..c2b7711a4fd 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.generator/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.generator/META-INF/MANIFEST.MF
@@ -1,5 +1,5 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.transition.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.transition.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xpand;visibility:=reexport,
org.eclipse.xtend;visibility:=reexport,
org.eclipse.xtext;visibility:=reexport,
@@ -12,7 +12,7 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.transition.editor.xtext.generator;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.transition.xtext.generator;singleton:=true
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.ui/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.ui/.project
index a59e918b8a1..69ec1ec4c3e 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.ui/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.ui/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.transition.editor.xtext.ui</name>
+ <name>org.eclipse.papyrus.uml.textedit.transition.xtext.ui</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.ui/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.ui/META-INF/MANIFEST.MF
index e86f902bfd0..247d67ba146 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.ui/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext.ui/META-INF/MANIFEST.MF
@@ -13,7 +13,7 @@ Bundle-ActivationPolicy: lazy
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.papyrus.transition.editor.xtext;bundle-version="0.9.0";visibility:=reexport,
+Require-Bundle: org.eclipse.papyrus.uml.textedit.transition.xtext;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.xtext.ui,
org.eclipse.ui.editors;bundle-version="3.5.0",
org.eclipse.ui.ide;bundle-version="3.5.0",
@@ -25,7 +25,7 @@ Require-Bundle: org.eclipse.papyrus.transition.editor.xtext;bundle-version="0.9.
org.eclipse.papyrus.extensionpoints.editors;bundle-version="0.9.0",
org.eclipse.gmf.runtime.diagram.ui;bundle-version="1.4.0",
org.eclipse.papyrus.core;bundle-version="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.core.expressions;bundle-version="3.4.200",
org.eclipse.xtext.gmf.glue;bundle-version="0.9.0"
Bundle-Vendor: %providerName
@@ -33,7 +33,6 @@ Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.transition.editor.xtext.ui.inter
nal.UmlTransitionActivator
-Bundle-SymbolicName: org.eclipse.papyrus.transition.editor.xtext.ui;si
- ngleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.transition.xtext.ui;singleton:=true
Import-Package: org.apache.log4j
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/.project b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/.project
index 9ae69aabd47..c16ff2df3af 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/.project
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.transition.editor.xtext</name>
+ <name>org.eclipse.papyrus.uml.textedit.transition.xtext</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/META-INF/MANIFEST.MF b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/META-INF/MANIFEST.MF
index cc142205185..110a7a7d7ce 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/META-INF/MANIFEST.MF
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/META-INF/MANIFEST.MF
@@ -32,6 +32,6 @@ Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Import-Package: org.apache.log4j
-Bundle-SymbolicName: org.eclipse.papyrus.transition.editor.xtext;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.textedit.transition.xtext;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/src/org/eclipse/papyrus/transition/editor/xtext/GenerateUmlTransition.mwe2 b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/src/org/eclipse/papyrus/transition/editor/xtext/GenerateUmlTransition.mwe2
index c08c180b730..f2966eb002f 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/src/org/eclipse/papyrus/transition/editor/xtext/GenerateUmlTransition.mwe2
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/src/org/eclipse/papyrus/transition/editor/xtext/GenerateUmlTransition.mwe2
@@ -6,7 +6,7 @@ import org.eclipse.xtext.ui.generator.*
var grammarURI = "classpath:/org/eclipse/papyrus/transition/editor/xtext/UmlTransition.xtext"
var file.extensions = "umltransition"
-var projectName = "org.eclipse.papyrus.transition.editor.xtext"
+var projectName = "org.eclipse.papyrus.uml.textedit.transition.xtext"
var runtimeProject = "../${projectName}"
Workflow {
@@ -19,9 +19,9 @@ Workflow {
registerGeneratedEPackage = "org.eclipse.uml2.uml.UMLPackage"
registerGeneratedEPackage = "org.eclipse.uml2.codegen.ecore.genmodel.GenModelPackage"
uriMap = {from="platform:/plugin/org.eclipse.emf.ecore/model/Ecore.ecore"
- to="platform:/resource/org.eclipse.papyrus.transition.editor.xtext/model/Ecore.ecore"}
+ to="platform:/resource/org.eclipse.papyrus.uml.textedit.transition.xtext/model/Ecore.ecore"}
uriMap = {from="platform:/plugin/org.eclipse.emf.ecore/model/Ecore.genmodel"
- to="platform:/resource/org.eclipse.papyrus.transition.editor.xtext/model/Ecore.genmodel"}
+ to="platform:/resource/org.eclipse.papyrus.uml.textedit.transition.xtext/model/Ecore.genmodel"}
}
component = DirectoryCleaner {
@@ -47,7 +47,7 @@ Workflow {
// generates Java API for the generated EPackages
fragment = ecore.EcoreGeneratorFragment {
referencedGenModels =
- "platform:/resource/org.eclipse.papyrus.transition.editor.xtext/model/UML.genmodel"
+ "platform:/resource/org.eclipse.papyrus.uml.textedit.transition.xtext/model/UML.genmodel"
}
// the serialization component
diff --git a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/src/org/eclipse/papyrus/transition/editor/xtext/UmlTransition.xtext b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/src/org/eclipse/papyrus/transition/editor/xtext/UmlTransition.xtext
index d978571ab0e..07aed128989 100644
--- a/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/src/org/eclipse/papyrus/transition/editor/xtext/UmlTransition.xtext
+++ b/plugins/uml/textedit/org.eclipse.papyrus.uml.textedit.transition.xtext/src/org/eclipse/papyrus/transition/editor/xtext/UmlTransition.xtext
@@ -1,9 +1,9 @@
-grammar org.eclipse.papyrus.transition.editor.xtext.UmlTransition
+grammar org.eclipse.papyrus.uml.textedit.transition.xtext.UmlTransition
with org.eclipse.xtext.common.Terminals
import "http://www.eclipse.org/uml2/3.0.0/UML" as uml
-generate umlTransition "http://www.eclipse.org/papyrus/transition/editor/xtext/UmlTransition"
+generate umlTransition "http://www.eclipse.org/papyrus/uml/textedit/transition/xtext/UmlTransition"
TransitionRule:
(triggers+=EventRule (',' triggers+=EventRule)*)?
diff --git a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/.project b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/.project
index d7c502e32f6..e34239b9d48 100644
--- a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/.project
+++ b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.extendedtypes.uml</name>
+ <name>org.eclipse.papyrus.uml.tools.extendedtypes</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/META-INF/MANIFEST.MF b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/META-INF/MANIFEST.MF
index 1f159a2dd42..46df7226b36 100644
--- a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/META-INF/MANIFEST.MF
+++ b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/META-INF/MANIFEST.MF
@@ -11,17 +11,16 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.emf.ecore;visibility:=reexport,
org.eclipse.emf.ecore.xmi;visibility:=reexport,
- org.eclipse.papyrus.core.queries.configuration;bundle-version:="0.9.0";visibility:=reexport,
+ org.eclipse.papyrus.core.queries.configuration;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.papyrus.extendedtypes;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.emf.facet.infra.query;visibility:=reexport,
org.eclipse.uml2.uml;visibility:=reexport,
org.eclipse.papyrus.log;bundle-version="0.9.0",
- org.eclipse.papyrus.umlutils;bundle-version:="0.9.0"
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0"
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.extendedtypes.uml.Activator$Impl
ementation
-Bundle-SymbolicName: org.eclipse.papyrus.extendedtypes.uml;singleton:=
- true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.tools.extendedtypes;singleton:=true
diff --git a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/model/ApplyStereotypeActionConfiguration.genmodel b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/model/ApplyStereotypeActionConfiguration.genmodel
index a9cbf464304..a270af31f98 100644
--- a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/model/ApplyStereotypeActionConfiguration.genmodel
+++ b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.extendedtypes/model/ApplyStereotypeActionConfiguration.genmodel
@@ -1,14 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<genmodel:GenModel xmi:version="2.0"
xmlns:xmi="http://www.omg.org/XMI" xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore"
- xmlns:genmodel="http://www.eclipse.org/emf/2002/GenModel" modelDirectory="/org.eclipse.papyrus.extendedtypes.uml/src-gen"
- editDirectory="/org.eclipse.papyrus.extendedtypes.uml.edit/src-gen" editorDirectory="/org.eclipse.papyrus.extendedtypes.uml.editor/src-gen"
- modelPluginID="org.eclipse.papyrus.extendedtypes.uml" modelName="ApplyStereotypeActionConfiguration"
- modelPluginClass="org.eclipse.papyrus.extendedtypes.uml.Activator" testsDirectory="/org.eclipse.papyrus.extendedtypes.uml.tests/src-gen"
+ xmlns:genmodel="http://www.eclipse.org/emf/2002/GenModel" modelDirectory="/org.eclipse.papyrus.uml.tools.extendedtypes/src-gen"
+ editDirectory="/org.eclipse.papyrus.uml.tools.extendedtypes.edit/src-gen" editorDirectory="/org.eclipse.papyrus.uml.tools.extendedtypes.editor/src-gen"
+ modelPluginID="org.eclipse.papyrus.uml.tools.extendedtypes" modelName="ApplyStereotypeActionConfiguration"
+ modelPluginClass="org.eclipse.papyrus.uml.tools.extendedtypes.Activator" testsDirectory="/org.eclipse.papyrus.uml.tools.extendedtypes.tests/src-gen"
importerID="org.eclipse.emf.importer.ecore" complianceLevel="5.0" copyrightFields="false"
usedGenPackages="platform:/plugin/org.eclipse.papyrus.core.queries.configuration/model/Configuration.genmodel#//configuration platform:/plugin/org.eclipse.emf.ecore/model/Ecore.genmodel#//ecore platform:/plugin/org.eclipse.papyrus.extendedtypes/model/ExtendedTypes.genmodel#//extendedtypes platform:/plugin/org.eclipse.emf.facet.infra.query/model/query.genmodel#//query platform:/plugin/org.eclipse.uml2.uml/model/UML.genmodel#//uml">
<foreignModel>ApplyStereotypeActionConfiguration.ecore</foreignModel>
- <genPackages prefix="ApplyStereotypeActionConfiguration" basePackage="org.eclipse.papyrus.extendedtypes.uml"
+ <genPackages prefix="ApplyStereotypeActionConfiguration" basePackage="org.eclipse.papyrus.uml.tools.extendedtypes"
resource="XML" disposableProviderFactory="true" ecorePackage="ApplyStereotypeActionConfiguration.ecore#/">
<genClasses ecoreClass="ApplyStereotypeActionConfiguration.ecore#//ApplyStereotypeActionConfiguration">
<genFeatures property="None" children="true" createChild="true" ecoreFeature="ecore:EReference ApplyStereotypeActionConfiguration.ecore#//ApplyStereotypeActionConfiguration/stereotypesToApply"/>
diff --git a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/.project b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/.project
index 88df603aecd..41cb67dc32e 100644
--- a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/.project
+++ b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/.project
@@ -1,33 +1,33 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<projectDescription>
- <name>org.eclipse.papyrus.umlutils</name>
- <comment></comment>
- <projects>
- </projects>
- <buildSpec>
- <buildCommand>
- <name>com.ibm.etools.common.migration.MigrationBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.jdt.core.javabuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.ManifestBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- <buildCommand>
- <name>org.eclipse.pde.SchemaBuilder</name>
- <arguments>
- </arguments>
- </buildCommand>
- </buildSpec>
- <natures>
- <nature>org.eclipse.pde.PluginNature</nature>
- <nature>org.eclipse.jdt.core.javanature</nature>
- </natures>
-</projectDescription>
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>org.eclipse.papyrus.uml.tools.utils</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ <buildCommand>
+ <name>com.ibm.etools.common.migration.MigrationBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.jdt.core.javabuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.ManifestBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.SchemaBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
+ </buildSpec>
+ <natures>
+ <nature>org.eclipse.pde.PluginNature</nature>
+ <nature>org.eclipse.jdt.core.javanature</nature>
+ </natures>
+</projectDescription>
diff --git a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF
index 927f35db281..eb7bef2c5dc 100644
--- a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF
+++ b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.uml2.uml,
- org.eclipse.jface;bundle-version:="3.4.1",
+ org.eclipse.jface;bundle-version="3.4.1",
org.eclipse.emf.transaction;bundle-version="1.2.1",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.umlutils,
@@ -14,6 +14,6 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.umlutils.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.umlutils;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.uml.tools.utils;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/src/org/eclipse/papyrus/umlutils/Activator.java b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/src/org/eclipse/papyrus/umlutils/Activator.java
index 057a76ab400..f80ac79622f 100644
--- a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/src/org/eclipse/papyrus/umlutils/Activator.java
+++ b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/src/org/eclipse/papyrus/umlutils/Activator.java
@@ -30,7 +30,7 @@ public class Activator extends Plugin {
/**
*
*/
- public static final String PLUGIN_ID = "org.eclipse.papyrus.umlutils";
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.uml.tools.utils";
// The shared instance
/**
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/.project b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/.project
index 28756425437..72e3c5a4396 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/.project
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.documentation.view.papyrus</name>
+ <name>org.eclipse.papyrus.views.documentation.view.papyrus</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF
index 8d470dcc8e4..970ea47fa29 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view.papyrus/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Manifest-Version: 1.0
-Require-Bundle: org.eclipse.papyrus.documentation.view;bundle-version:="0.9.0",
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0",
+Require-Bundle: org.eclipse.papyrus.views.documentation.view;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0",
org.eclipse.papyrus.core.adaptor.gmf;bundle-version="0.9.0",
org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0"
Bundle-Vendor: %providerName
@@ -8,7 +8,6 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.documentation.view.papyrus;si
- ngleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.documentation.view.papyrus;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/.project b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/.project
index 52a6f737c99..60ba04a747c 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/.project
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.documentation.view</name>
+ <name>org.eclipse.papyrus.views.documentation.view</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/META-INF/MANIFEST.MF b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/META-INF/MANIFEST.MF
index e5f6c8c5bb7..428295748fb 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/META-INF/MANIFEST.MF
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation.view/META-INF/MANIFEST.MF
@@ -11,12 +11,11 @@ Require-Bundle: org.eclipse.core.expressions;visibility:=reexport,
org.eclipse.jface.text,
org.eclipse.core.resources,
org.eclipse.epf.richtext,
- org.eclipse.papyrus.documentation;bundle-version="0.9.0";visibility:=reexport
+ org.eclipse.papyrus.views.documentation;bundle-version="0.9.0";visibility:=reexport
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.documentation.view.DocViewPlugin
-Bundle-SymbolicName: org.eclipse.papyrus.documentation.view;singleton:
- =true
+Bundle-SymbolicName: org.eclipse.papyrus.views.documentation.view;singleton:=true
Import-Package: org.eclipse.ui.views.contentoutline
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/.project b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/.project
index d8dc4202fb1..6f2cf1dabb3 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/.project
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.documentation</name>
+ <name>org.eclipse.papyrus.views.documentation</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF
index 10fc0c348db..ee26db08f7d 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/META-INF/MANIFEST.MF
@@ -11,6 +11,6 @@ Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.documentation.Activator
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.documentation;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.documentation;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/schema/documentationManager.exsd b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/schema/documentationManager.exsd
index 2e0a20b1ece..b9451b00dde 100644
--- a/plugins/views/documentation/org.eclipse.papyrus.views.documentation/schema/documentationManager.exsd
+++ b/plugins/views/documentation/org.eclipse.papyrus.views.documentation/schema/documentationManager.exsd
@@ -1,9 +1,9 @@
<?xml version='1.0' encoding='UTF-8'?>
<!-- Schema file written by PDE -->
-<schema targetNamespace="org.eclipse.papyrus.documentation" xmlns="http://www.w3.org/2001/XMLSchema">
+<schema targetNamespace="org.eclipse.papyrus.views.documentation" xmlns="http://www.w3.org/2001/XMLSchema">
<annotation>
<appinfo>
- <meta.schema plugin="org.eclipse.papyrus.documentation" id="modelDocumentationManager" name="modelDocumentationManager"/>
+ <meta.schema plugin="org.eclipse.papyrus.views.documentation" id="modelDocumentationManager" name="modelDocumentationManager"/>
</appinfo>
<documentation>
This extension is used to provide a way to get and set a documentation for an element of a specific meta-model.
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/.project b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/.project
index 64436edba9f..6529ae2f1f2 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/.project
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.modelexplorer.resourceloading</name>
+ <name>org.eclipse.papyrus.views.modelexplorer.resourceloading</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF
index 9f68eafb9d4..63bd2418862 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.resourceloading/META-INF/MANIFEST.MF
@@ -2,12 +2,12 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.emf.converter;bundle-version="2.5.0",
org.eclipse.emf.ecore.editor;bundle-version="2.6.0",
org.eclipse.emf.workspace.ui;bundle-version="1.3.0",
- org.eclipse.papyrus.service.edit;bundle-version:="0.9.0",
- org.eclipse.emf.facet.infra.browser;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.browser.custom;bundle-version:="0.1.0",
+ org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
+ org.eclipse.emf.facet.infra.browser;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.browser.custom;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.common.core;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.facet;bundle-version="0.1.0",
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0",
org.eclipse.papyrus.controlmode.history;bundle-version="0.9.0",
org.eclipse.papyrus.core.resourceloading;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.modelexplorer.resourceloading.hand
@@ -20,7 +20,6 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.modelexplorer.resourceloading.Ac
tivator
-Bundle-SymbolicName: org.eclipse.papyrus.modelexplorer.resourceloading
- ;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.modelexplorer.resourceloading;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/.project b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/.project
index c06b238c31e..e8257602822 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/.project
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.modelexplorer.widgets</name>
+ <name>org.eclipse.papyrus.views.modelexplorer.widgets</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF
index 0de78d32b0b..74d2b9f852f 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/META-INF/MANIFEST.MF
@@ -2,11 +2,11 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.papyrus.widgets;bundle-version="0.9.0";visibility:=reexport,
- org.eclipse.papyrus.modelexplorer;bundle-version="0.9.0";visibility:=reexport,
- org.eclipse.emf.facet.infra.browser;bundle-version:="0.1.0";visibility:=reexport,
+ org.eclipse.papyrus.views.modelexplorer;bundle-version="0.9.0";visibility:=reexport,
+ org.eclipse.emf.facet.infra.browser;bundle-version="0.1.0";visibility:=reexport,
org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0";visibility:=reexport,
- org.eclipse.papyrus.service.edit;bundle-version:="0.9.0",
- org.eclipse.emf.facet.infra.facet;bundle-version:="0.1.0"
+ org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
+ org.eclipse.emf.facet.infra.facet;bundle-version="0.1.0"
Export-Package: org.eclipse.papyrus.modelexplorer.widgets
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
@@ -14,7 +14,6 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.modelexplorer.widgets.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.modelexplorer.widgets;singlet
- on:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.modelexplorer.widgets;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/src/org/eclipse/papyrus/modelexplorer/widgets/Activator.java b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/src/org/eclipse/papyrus/modelexplorer/widgets/Activator.java
index e11b5087f15..15a9396511a 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/src/org/eclipse/papyrus/modelexplorer/widgets/Activator.java
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer.widgets/src/org/eclipse/papyrus/modelexplorer/widgets/Activator.java
@@ -23,7 +23,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
// The plug-in ID
- public static final String PLUGIN_ID = "org.eclipse.papyrus.modelexplorer.widgets"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.views.modelexplorer.widgets"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/.project b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/.project
index 14e921254d8..af06494370e 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/.project
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.modelexplorer</name>
+ <name>org.eclipse.papyrus.views.modelexplorer</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
index 5619c45d774..62521142136 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
@@ -3,22 +3,22 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.ui.navigator;bundle-version="3.4.0",
org.eclipse.papyrus.core;bundle-version="0.9.0";visibility:=reexport,
- org.eclipse.papyrus.log;bundle-version:="0.9.0",
+ org.eclipse.papyrus.log;bundle-version="0.9.0",
org.eclipse.emf.converter;bundle-version="2.5.0",
org.eclipse.papyrus.preferences;bundle-version="0.9.0",
org.eclipse.papyrus.sasheditor.di;bundle-version="0.9.0",
org.eclipse.ltk.core.refactoring;bundle-version="3.5.100",
- org.eclipse.emf.ecore.editor;bundle-version:="2.6.0",
+ org.eclipse.emf.ecore.editor;bundle-version="2.6.0",
org.eclipse.emf.workspace.ui;bundle-version="1.3.0",
org.eclipse.core.expressions;bundle-version="3.4.200",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
org.eclipse.papyrus.validation;bundle-version="0.9.0",
- org.eclipse.emf.facet.infra.browser;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.browser.custom;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.browser.custom.core;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.browser.custom.ui;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.browser.uicore;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.common.core;bundle-version:="0.1.0",
+ org.eclipse.emf.facet.infra.browser;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.browser.custom;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.browser.custom.core;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.browser.custom.ui;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.browser.uicore;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.common.core;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.facet;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.facet.core;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.query.ui;bundle-version="0.1.0",
@@ -42,6 +42,6 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.modelexplorer.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.modelexplorer;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.modelexplorer;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/src/org/eclipse/papyrus/modelexplorer/Activator.java b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/src/org/eclipse/papyrus/modelexplorer/Activator.java
index a2e5568e781..865c542ae0f 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/src/org/eclipse/papyrus/modelexplorer/Activator.java
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/src/org/eclipse/papyrus/modelexplorer/Activator.java
@@ -50,7 +50,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin implements org.eclipse.ui.IStartup {
/** The plug-in ID */
- public static final String PLUGIN_ID = "org.eclipse.papyrus.modelexplorer"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.views.modelexplorer"; //$NON-NLS-1$
/** The plug-in shared instance */
private static Activator plugin;
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/.project
index 1a9997c0c07..831044f61f7 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.model.edit</name>
+ <name>org.eclipse.papyrus.views.properties.model.edit</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/META-INF/MANIFEST.MF
index ec666f4ec1f..7c89f998370 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.edit/META-INF/MANIFEST.MF
@@ -8,14 +8,13 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.papyrus.properties.model;bundle-version="0.9.0";visibility:=reexport,
+ org.eclipse.papyrus.views.properties.model;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.emf.edit;visibility:=reexport,
- org.eclipse.emf.ecore.edit;bundle-version:="2.7.0"
+ org.eclipse.emf.ecore.edit;bundle-version="2.7.0"
Bundle-Vendor: %providerName
Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.environment.provider.
PropertiesEditPlugin$Implementation
-Bundle-SymbolicName: org.eclipse.papyrus.properties.model.edit;singlet
- on:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.model.edit;singleton:=true
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/.project
index 3f533233ef3..787e6aa3989 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.model.editor</name>
+ <name>org.eclipse.papyrus.views.properties.model.editor</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/META-INF/MANIFEST.MF
index 970980a3d76..31a98dbcf59 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model.editor/META-INF/MANIFEST.MF
@@ -9,7 +9,7 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.core.resources;visibility:=reexport,
- org.eclipse.papyrus.properties.model.edit;bundle-version="0.9.0";visibility:=reexport,
+ org.eclipse.papyrus.views.properties.model.edit;bundle-version="0.9.0";visibility:=reexport,
org.eclipse.emf.ecore.xmi;visibility:=reexport,
org.eclipse.emf.edit.ui;visibility:=reexport,
org.eclipse.ui.ide;visibility:=reexport
@@ -18,6 +18,5 @@ Bundle-Version: 0.9.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.environment.presentat
ion.PropertiesEditorPlugin$Implementation
-Bundle-SymbolicName: org.eclipse.papyrus.properties.model.editor;singl
- eton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.model.editor;singleton:=true
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.model/.project
index 62138ff608c..bed8841d83b 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.model</name>
+ <name>org.eclipse.papyrus.views.properties.model</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.model/META-INF/MANIFEST.MF
index 442680d5a55..53031872320 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model/META-INF/MANIFEST.MF
@@ -1,6 +1,6 @@
Manifest-Version: 1.0
Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.emf.ecore;visibility:=reexport
+ org.eclipse.emf.ecore;bundle-version="2.7.0";visibility:=reexport
Export-Package: org.eclipse.papyrus.properties.contexts,
org.eclipse.papyrus.properties.contexts.impl,
org.eclipse.papyrus.properties.contexts.util,
@@ -17,7 +17,6 @@ Bundle-Version: 0.9.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
-Bundle-SymbolicName: org.eclipse.papyrus.properties.model;singleton:=t
- rue
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.model;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.model/Model/Properties.genmodel b/plugins/views/properties/org.eclipse.papyrus.views.properties.model/Model/Properties.genmodel
index 93e2bbf57b0..9a40605c513 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.model/Model/Properties.genmodel
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.model/Model/Properties.genmodel
@@ -1,10 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<genmodel:GenModel xmi:version="2.0"
xmlns:xmi="http://www.omg.org/XMI" xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore"
- xmlns:genmodel="http://www.eclipse.org/emf/2002/GenModel" modelDirectory="/org.eclipse.papyrus.properties.model/src-gen"
- editDirectory="/org.eclipse.papyrus.properties.model.edit/src-gen" editorDirectory="/org.eclipse.papyrus.properties.model.editor/src-gen"
- modelPluginID="org.eclipse.papyrus.properties.model" modelName="Properties" testsDirectory="/org.eclipse.papyrus.properties.model.tests/src-gen"
+ xmlns:genmodel="http://www.eclipse.org/emf/2002/GenModel" modelDirectory="/org.eclipse.papyrus.views.properties.model/src-gen"
+ editDirectory="/org.eclipse.papyrus.views.properties.model.edit/src-gen" editorDirectory="/org.eclipse.papyrus.views.properties.model.editor/src-gen"
+ modelPluginID="org.eclipse.papyrus.views.properties.model" modelName="Properties"
+ editorPluginClass="org.eclipse.papyrus.views.properties.environment.presentation.PropertiesEditorPlugin"
+ testsDirectory="/org.eclipse.papyrus.views.properties.model.tests/src-gen" testSuiteClass="org.eclipse.papyrus.views.properties.environment.tests.PropertiesAllTests"
importerID="org.eclipse.emf.importer.ecore" complianceLevel="5.0" copyrightFields="false"
+ editPluginID="org.eclipse.papyrus.views.properties.model.edit" editorPluginID="org.eclipse.papyrus.views.properties.model.editor"
usedGenPackages="platform:/plugin/org.eclipse.emf.ecore/model/Ecore.genmodel#//ecore">
<foreignModel>Properties.ecore</foreignModel>
<genPackages prefix="Properties" basePackage="org.eclipse.papyrus" disposableProviderFactory="true"
@@ -70,9 +73,6 @@
<genFeatures property="None" children="true" createChild="true" ecoreFeature="ecore:EReference Properties.ecore#//contexts/Context/tabs"/>
<genFeatures property="None" children="true" createChild="true" ecoreFeature="ecore:EReference Properties.ecore#//contexts/Context/views"/>
<genFeatures property="None" children="true" createChild="true" ecoreFeature="ecore:EReference Properties.ecore#//contexts/Context/dataContexts"/>
- <genFeatures createChild="false" ecoreFeature="ecore:EAttribute Properties.ecore#//contexts/Context/author"/>
- <genFeatures createChild="false" ecoreFeature="ecore:EAttribute Properties.ecore#//contexts/Context/description"/>
- <genFeatures createChild="false" ecoreFeature="ecore:EAttribute Properties.ecore#//contexts/Context/version"/>
</genClasses>
<genClasses image="false" ecoreClass="Properties.ecore#//contexts/DisplayUnit">
<genFeatures property="None" children="true" createChild="true" ecoreFeature="ecore:EReference Properties.ecore#//contexts/DisplayUnit/constraints"/>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/.project
index b8e684a66f8..d1fd94213c5 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.runtime</name>
+ <name>org.eclipse.papyrus.views.properties.runtime</name>
<comment></comment>
<projects>
<project>org.eclipse.papyrus.log</project>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF
index 963b4e5014e..d92734bbaee 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/META-INF/MANIFEST.MF
@@ -20,12 +20,12 @@ Require-Bundle: org.eclipse.ui;bundle-version="3.5.1",
org.eclipse.gmf.runtime.common.core;bundle-version="1.2.0",
org.eclipse.gmf.runtime.emf.commands.core;bundle-version="1.2.0",
org.eclipse.gmf.runtime.emf.core;bundle-version="1.2.0",
- org.eclipse.papyrus.log;bundle-version:="0.9.0",
+ org.eclipse.papyrus.log;bundle-version="0.9.0",
org.eclipse.gmf.runtime.common.ui;bundle-version="1.2.1",
org.eclipse.gmf.runtime.common.ui.services;bundle-version="1.2.0",
org.eclipse.uml2.uml.resources;bundle-version="3.1.0",
org.eclipse.emf.edit.ui;bundle-version="2.6.0",
- org.eclipse.uml2.uml;bundle-version:="3.1.0",
+ org.eclipse.uml2.uml;bundle-version="3.1.0",
org.eclipse.papyrus.core;bundle-version="0.9.0",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0"
Bundle-Vendor: %providerName
@@ -35,7 +35,6 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.runtime.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.properties.runtime;singleton:
- =true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.runtime;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/src/org/eclipse/papyrus/properties/runtime/Activator.java b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/src/org/eclipse/papyrus/properties/runtime/Activator.java
index 679b284b8aa..0f6d3a48021 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/src/org/eclipse/papyrus/properties/runtime/Activator.java
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.runtime/src/org/eclipse/papyrus/properties/runtime/Activator.java
@@ -13,7 +13,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
/** plugin ID */
- public static final String ID = "org.eclipse.papyrus.properties.runtime";
+ public static final String ID = "org.eclipse.papyrus.views.properties.runtime";
/** shared instance */
private static Activator plugin;
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/.project
index 0abe5f1581c..f09ff415438 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.tabbed.core</name>
+ <name>org.eclipse.papyrus.views.properties.tabbed.core</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF
index a60cce97534..8cd21af88ef 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/META-INF/MANIFEST.MF
@@ -6,8 +6,8 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.emf.edit.ui;bundle-version="2.6.0",
org.eclipse.gmf.runtime.common.core;bundle-version="1.2.0",
org.eclipse.gmf.runtime.common.ui;bundle-version="1.3.0",
- org.eclipse.papyrus.core;bundle-version:="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.core;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.papyrus.log;bundle-version="0.9.0"
Export-Package: org.eclipse.papyrus.properties.tabbed.core,
org.eclipse.papyrus.properties.tabbed.core.provider,
@@ -20,7 +20,6 @@ Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.tabbed.core.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.properties.tabbed.core;single
- ton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.tabbed.core;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/src/org/eclipse/papyrus/properties/tabbed/core/Activator.java b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/src/org/eclipse/papyrus/properties/tabbed/core/Activator.java
index 4bd0bdb0ba2..808a1978917 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/src/org/eclipse/papyrus/properties/tabbed/core/Activator.java
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.core/src/org/eclipse/papyrus/properties/tabbed/core/Activator.java
@@ -12,7 +12,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
/** identifier of the plugin */
- public static final String PLUGIN_ID = "org.eclipse.papyrus.properties.tabbed.core"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.views.properties.tabbed.core"; //$NON-NLS-1$
/** singleton instance of this plugin */
private static Activator plugin;
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/.project
index 7c1c7b176cc..c677c8570ab 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties.tabbed.customization</name>
+ <name>org.eclipse.papyrus.views.properties.tabbed.customization</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF
index a202d783e9f..38ad03d2001 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/META-INF/MANIFEST.MF
@@ -2,17 +2,17 @@ Manifest-Version: 1.0
Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.ui.views;bundle-version="3.5.0",
- org.eclipse.papyrus.properties.tabbed.core;bundle-version="0.9.0",
- org.eclipse.papyrus.log;bundle-version:="0.9.0",
- org.eclipse.papyrus.properties.runtime;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.tabbed.core;bundle-version="0.9.0",
+ org.eclipse.papyrus.log;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.runtime;bundle-version="0.9.0",
org.eclipse.ui.views.properties.tabbed;bundle-version="3.5.0",
org.eclipse.gmf.runtime.common.ui.services;bundle-version="1.3.0",
org.eclipse.emf.ecore;bundle-version="2.6.0",
- org.eclipse.emf.ecore.edit;bundle-version:="2.6.0",
+ org.eclipse.emf.ecore.edit;bundle-version="2.6.0",
org.eclipse.papyrus.core;bundle-version="0.9.0",
org.eclipse.uml2.uml;bundle-version="3.1.0",
- org.eclipse.papyrus.umlutils;bundle-version="0.9.0",
- org.apache.xml.serializer;bundle-version:="2.7.1",
+ org.eclipse.papyrus.uml.tools.utils;bundle-version="0.9.0",
+ org.apache.xml.serializer;bundle-version="2.7.1",
org.apache.batik.xml;bundle-version="1.6.0",
org.apache.xml.resolver;bundle-version="1.2.0",
org.eclipse.emf.facet.infra.browser.custom;bundle-version="0.1.0",
@@ -31,7 +31,6 @@ Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.tabbed.customization.
Activator
-Bundle-SymbolicName: org.eclipse.papyrus.properties.tabbed.customizati
- on;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.tabbed.customization;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_predefined_fragments.xml b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_predefined_fragments.xml
index 029b80b2346..dcb1513c777 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_predefined_fragments.xml
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_predefined_fragments.xml
@@ -1,5 +1,5 @@
<!--UML Basic fragment-->
-<fragments pluginId="org.eclipse.papyrus.properties.tabbed.customization">
+<fragments pluginId="org.eclipse.papyrus.views.properties.tabbed.customization">
<fragment id="fragment_single_ExpandableContainerDescriptorState">
<context enablesFor="1">
<elementClass name="org.eclipse.papyrus.properties.runtime.view.content.ExpandableContainerDescriptor$ExpandableContainerDescriptorState"/>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_wizards_dialogs.xml b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_wizards_dialogs.xml
index 294c4c4873a..e768a10acd5 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_wizards_dialogs.xml
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/resources/configuration_wizards_dialogs.xml
@@ -1,5 +1,5 @@
<!-- Generic dialogs for UML elements -->
-<dialogs pluginId="org.eclipse.papyrus.properties.tabbed.customization">
+<dialogs pluginId="org.eclipse.papyrus.views.properties.tabbed.customization">
<dialog id="ControllerDescriptorEditorDialog"><!-- Dialog for single controller descriptor state -->
<context enablesFor="1">
<elementClass
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/src/org/eclipse/papyrus/properties/tabbed/customization/Activator.java b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/src/org/eclipse/papyrus/properties/tabbed/customization/Activator.java
index 2ebaf1ac740..f794d497bed 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/src/org/eclipse/papyrus/properties/tabbed/customization/Activator.java
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbed.customization/src/org/eclipse/papyrus/properties/tabbed/customization/Activator.java
@@ -20,7 +20,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
/** plugin ID */
- public static final String ID = "org.eclipse.papyrus.properties.tabbed.customization"; //$NON-NLS-1$
+ public static final String ID = "org.eclipse.papyrus.views.properties.tabbed.customization"; //$NON-NLS-1$
/** singleton instance */
private static Activator plugin;
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/.project
index 56801250e50..657890eb11c 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.tabbedproperties.core</name>
+ <name>org.eclipse.papyrus.views.properties.tabbedproperties.core</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF
index 27c22735ed7..1fc4607e1b0 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/META-INF/MANIFEST.MF
@@ -10,7 +10,6 @@ Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.tabbedproperties.core.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.tabbedproperties.core;singlet
- on:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties.tabbedproperties.core;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/src/org/eclipse/papyrus/tabbedproperties/core/Activator.java b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/src/org/eclipse/papyrus/tabbedproperties/core/Activator.java
index 6bb38b6d001..d4690d31c61 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/src/org/eclipse/papyrus/tabbedproperties/core/Activator.java
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.tabbedproperties.core/src/org/eclipse/papyrus/tabbedproperties/core/Activator.java
@@ -24,7 +24,7 @@ import org.osgi.framework.BundleContext;
public class Activator extends AbstractUIPlugin {
/** Plugin id */
- public static final String PLUGIN_ID = "org.eclipse.papyrus.tabbedproperties.core"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.views.properties.tabbedproperties.core"; //$NON-NLS-1$
/**
* singleton instance of this plugin.
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/.project b/plugins/views/properties/org.eclipse.papyrus.views.properties/.project
index 32de1ef6467..45a258fc7ba 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/.project
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.properties</name>
+ <name>org.eclipse.papyrus.views.properties</name>
<comment></comment>
<projects>
</projects>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF
index 34dc3e2fd9a..86d621dd72f 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/META-INF/MANIFEST.MF
@@ -22,7 +22,7 @@ Require-Bundle: com.ibm.icu,
org.eclipse.emf;bundle-version="2.6.0",
org.eclipse.emf.ecore;bundle-version="2.6.0",
org.eclipse.emf.ecore.xmi;bundle-version="2.5.0",
- org.eclipse.emf.databinding;bundle-version:="1.2.0",
+ org.eclipse.emf.databinding;bundle-version="1.2.0",
org.eclipse.equinox.common;bundle-version="3.6.0",
org.eclipse.ui;bundle-version="3.6.0",
org.eclipse.osgi;bundle-version="3.6.0",
@@ -33,20 +33,20 @@ Require-Bundle: com.ibm.icu,
org.eclipse.jface.databinding,
org.eclipse.core.databinding,
org.eclipse.core.databinding.property;bundle-version="1.3.0",
- org.eclipse.e4.xwt;bundle-version:="0.9.1",
+ org.eclipse.e4.xwt;bundle-version="0.9.1",
org.eclipse.e4.xwt.pde;bundle-version="0.9.1",
- org.eclipse.papyrus.properties.model;bundle-version="0.9.0",
+ org.eclipse.papyrus.views.properties.model;bundle-version="0.9.0",
org.eclipse.papyrus.service.edit;bundle-version="0.9.0",
org.eclipse.papyrus.widgets;bundle-version="0.9.0",
- org.eclipse.core.databinding.beans;bundle-version:="1.2.100",
- org.eclipse.emf.facet.infra.query;bundle-version:="0.1.0",
- org.eclipse.emf.facet.infra.query.core;bundle-version:="0.1.0",
+ org.eclipse.core.databinding.beans;bundle-version="1.2.100",
+ org.eclipse.emf.facet.infra.query;bundle-version="0.1.0",
+ org.eclipse.emf.facet.infra.query.core;bundle-version="0.1.0",
org.eclipse.emf.facet.infra.common.core;bundle-version="0.1.0",
- org.eclipse.papyrus.modelexplorer.widgets;bundle-version="0.9.0"
+ org.eclipse.papyrus.views.modelexplorer.widgets;bundle-version="0.9.0"
Bundle-Vendor: %Bundle-Vendor
Bundle-Version: 0.9.0.qualifier
Eclipse-BuddyPolicy: dependent
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.properties.Activator
-Bundle-SymbolicName: org.eclipse.papyrus.properties;singleton:=true
+Bundle-SymbolicName: org.eclipse.papyrus.views.properties;singleton:=true
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.ecore b/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.ecore
index 86c708091b9..db6bf4c5e82 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.ecore
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.ecore
@@ -5,8 +5,8 @@
nsURI="http://www.eclipse.org/papyrus/properties/root" nsPrefix="root">
<eClassifiers xsi:type="ecore:EClass" name="PropertiesRoot">
<eStructuralFeatures xsi:type="ecore:EReference" name="environments" upperBound="-1"
- eType="ecore:EClass platform:/plugin/org.eclipse.papyrus.properties.model/Model/Properties.ecore#//environment/Environment"/>
+ eType="ecore:EClass platform:/plugin/org.eclipse.papyrus.views.properties.model/Model/Properties.ecore#//environment/Environment"/>
<eStructuralFeatures xsi:type="ecore:EReference" name="contexts" upperBound="-1"
- eType="ecore:EClass platform:/plugin/org.eclipse.papyrus.properties.model/Model/Properties.ecore#//contexts/Context"/>
+ eType="ecore:EClass platform:/plugin/org.eclipse.papyrus.views.properties.model/Model/Properties.ecore#//contexts/Context"/>
</eClassifiers>
</ecore:EPackage>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.genmodel b/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.genmodel
index 5e625276908..5cc9b093945 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.genmodel
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/model/PropertiesRoot.genmodel
@@ -5,7 +5,7 @@
editDirectory="/org.eclipse.papyrus.properties.edit/src-gen" editorDirectory="/org.eclipse.papyrus.properties.editor/src-gen"
modelPluginID="org.eclipse.papyrus.properties" modelName="PropertiesRoot" testsDirectory="/org.eclipse.papyrus.properties.tests/src-gen"
importerID="org.eclipse.emf.importer.ecore" complianceLevel="5.0" copyrightFields="false"
- usedGenPackages="platform:/plugin/org.eclipse.papyrus.properties.model/Model/Properties.genmodel#//properties">
+ usedGenPackages="platform:/plugin/org.eclipse.papyrus.views.properties.model/Model/Properties.genmodel#//properties">
<foreignModel>PropertiesRoot.ecore</foreignModel>
<genPackages prefix="Root" basePackage="org.eclipse.papyrus.properties" disposableProviderFactory="true"
ecorePackage="PropertiesRoot.ecore#/">
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/plugin.xml b/plugins/views/properties/org.eclipse.papyrus.views.properties/plugin.xml
index 4b806121eb8..6a713b73446 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/plugin.xml
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/plugin.xml
@@ -25,7 +25,7 @@
point="org.eclipse.emf.ecore.uri_mapping">
<mapping
source="pathmap://PPEResources/"
- target="platform:/plugin/org.eclipse.papyrus.properties/model/">
+ target="platform:/plugin/org.eclipse.papyrus.views.properties/model/">
</mapping>
</extension>
<extension
@@ -33,7 +33,7 @@
<page
category="org.eclipse.papyrus.preferences.generalcategory"
class="org.eclipse.papyrus.properties.preferences.Preferences"
- id="org.eclipse.papyrus.properties.propertyview"
+ id="org.eclipse.papyrus.views.properties.propertyview"
name="%page.name">
</page>
</extension>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/context.exsd b/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/context.exsd
index 3dcdd57d811..deb4b5bbd2f 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/context.exsd
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/context.exsd
@@ -3,10 +3,10 @@
<schema targetNamespace="org.eclipse.papyrus.properties" xmlns="http://www.w3.org/2001/XMLSchema">
<annotation>
<appInfo>
- <meta.schema plugin="org.eclipse.papyrus.properties" id="Context" name="Context"/>
+ <meta.schema plugin="org.eclipse.papyrus.views.properties" id="Context" name="Context"/>
</appInfo>
<documentation>
- Extension point used to provide new Contexts to the Papyrus Property View. A Context is an EMF Model conforming to http://www.eclipse.org/papyrus/properties (From org.eclipse.papyrus.properties.model), defining a set of Constraint descriptors, and the view to display for each.
+ Extension point used to provide new Contexts to the Papyrus Property View. A Context is an EMF Model conforming to http://www.eclipse.org/papyrus/properties (From org.eclipse.papyrus.views.properties.model), defining a set of Constraint descriptors, and the view to display for each.
</documentation>
</annotation>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/environment.exsd b/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/environment.exsd
index 06d69b73b1d..63850650ed9 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/environment.exsd
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/environment.exsd
@@ -1,12 +1,12 @@
<?xml version='1.0' encoding='UTF-8'?>
<!-- Schema file written by PDE -->
-<schema targetNamespace="org.eclipse.papyrus.properties" xmlns="http://www.w3.org/2001/XMLSchema">
+<schema targetNamespace="org.eclipse.papyrus.views.properties" xmlns="http://www.w3.org/2001/XMLSchema">
<annotation>
<appInfo>
- <meta.schema plugin="org.eclipse.papyrus.properties" id="Environment" name="Environment"/>
+ <meta.schema plugin="org.eclipse.papyrus.views.properties" id="Environment" name="Environment"/>
</appInfo>
<documentation>
- Extension point used to provide new Environment to the Papyrus Property View. An Environment is an EMF Model conforming to http://www.eclipse.org/papyrus/properties/environment (From org.eclipse.papyrus.properties.model), defining a set of element descriptors (Widgets, Factories, ...), which can be used by the different Contexts to define new property views.
+ Extension point used to provide new Environment to the Papyrus Property View. An Environment is an EMF Model conforming to http://www.eclipse.org/papyrus/properties/environment (From org.eclipse.papyrus.views.properties.model), defining a set of element descriptors (Widgets, Factories, ...), which can be used by the different Contexts to define new property views.
</documentation>
</annotation>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/labelprovider.exsd b/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/labelprovider.exsd
index 6db00a591bc..da59dafcad0 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/labelprovider.exsd
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/schema/labelprovider.exsd
@@ -1,9 +1,9 @@
<?xml version='1.0' encoding='UTF-8'?>
<!-- Schema file written by PDE -->
-<schema targetNamespace="org.eclipse.papyrus.properties" xmlns="http://www.w3.org/2001/XMLSchema">
+<schema targetNamespace="org.eclipse.papyrus.views.properties" xmlns="http://www.w3.org/2001/XMLSchema">
<annotation>
<appInfo>
- <meta.schema plugin="org.eclipse.papyrus.properties" id="labelprovider" name="labelprovider"/>
+ <meta.schema plugin="org.eclipse.papyrus.views.properties" id="labelprovider" name="labelprovider"/>
</appInfo>
<documentation>
[Enter description of this extension point.]
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties/src/org/eclipse/papyrus/properties/Activator.java b/plugins/views/properties/org.eclipse.papyrus.views.properties/src/org/eclipse/papyrus/properties/Activator.java
index 8c6745c4ae2..2570b5461aa 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties/src/org/eclipse/papyrus/properties/Activator.java
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties/src/org/eclipse/papyrus/properties/Activator.java
@@ -28,7 +28,7 @@ public class Activator extends AbstractUIPlugin {
/**
* The plug-in ID
*/
- public static final String PLUGIN_ID = "org.eclipse.papyrus.properties"; //$NON-NLS-1$
+ public static final String PLUGIN_ID = "org.eclipse.papyrus.views.properties"; //$NON-NLS-1$
// The shared instance
private static Activator plugin;

Back to the top