Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Le Menez2018-04-21 17:11:59 -0400
committerQuentin Le Menez2018-04-21 17:13:17 -0400
commit583f3e40fbbd646a5e13b3db29bbba77fb9efb0a (patch)
treeae7e3bba49581abcd8358a0063c594ff8c8e4ee8
parent0bdf62f7a9968d362c762f84a5a3e6da34f9f7a9 (diff)
downloadorg.eclipse.papyrus-583f3e40fbbd646a5e13b3db29bbba77fb9efb0a.tar.gz
org.eclipse.papyrus-583f3e40fbbd646a5e13b3db29bbba77fb9efb0a.tar.xz
org.eclipse.papyrus-583f3e40fbbd646a5e13b3db29bbba77fb9efb0a.zip
Revert "Bug 533804 - [Diagram] Update batik dependencies for 1.9.1"
- a compilation error was introduced by this change, this needs to be reverted until resolved. This reverts commit 0bdf62f7a9968d362c762f84a5a3e6da34f9f7a9. Change-Id: Idfb6e8ebd7f04654e22bb017e61d3cd6ea36b65d
-rwxr-xr-xplugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF87
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/src/org/eclipse/papyrus/infra/gmfdiag/common/service/shape/AbstractShapeProvider.java17
-rw-r--r--plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java2
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.export/META-INF/MANIFEST.MF5
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.export/pom.xml2
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.export/src/org/eclipse/papyrus/uml/export/extension/contribution/CommentAnnotateSVG.java4
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.export/src/org/eclipse/papyrus/uml/export/svgextension/PapyrusDiagramSVGGenerator.java63
-rw-r--r--releng/main-tests/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.eclipse.target.target28
-rw-r--r--releng/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.target28
-rw-r--r--releng/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.tpd4
-rw-r--r--releng/main/targetPlatform/eclipse/org.eclipse.papyrus.main.eclipse.target.target20
-rw-r--r--releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.target20
-rwxr-xr-xreleng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.tpd16
-rw-r--r--releng/rcp/targetPlatform/eclipse/org.eclipse.papyrus.rcp.eclipse.target.target26
-rw-r--r--releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.target26
-rw-r--r--releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.tpd2
-rw-r--r--releng/toolsmiths/targetPlatform/eclipse/org.eclipse.papyrus.toolsmiths.eclipse.targetplatform.target32
-rw-r--r--releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.target32
-rw-r--r--releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.tpd6
-rwxr-xr-xtests/junit/framework/org.eclipse.papyrus.bundles.tests/src/org/eclipse/papyrus/bundles/tests/BundlesTests.java2
20 files changed, 149 insertions, 273 deletions
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF
index 65975c90599..7dfd8dac3e0 100755
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF
@@ -1,48 +1,4 @@
Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: %pluginName
-Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.common;singleton:=true
-Bundle-Version: 3.100.0.qualifier
-Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Require-Bundle:
- org.eclipse.emf.ecore.edit;bundle-version="[2.9.0,3.0.0)",
- org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)";visibility:=reexport,
- org.eclipse.papyrus.infra.emf.appearance;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)";visibility:=reexport,
- org.eclipse.gmf.runtime.draw2d.ui.render;bundle-version="[1.7.0,2.0.0)";visibility:=reexport,
- org.eclipse.gmf.runtime.draw2d.ui.render.awt;bundle-version="[1.8.0,2.0.0)",
- org.w3c.dom.svg;bundle-version="[1.1.0,2.0.0)";visibility:=reexport,
- org.apache.batik.anim;bundle-version="[1.9.1, 2.0.0)",
- org.apache.batik.dom;bundle-version="[1.9.1, 2.0.0)",
- org.apache.batik.dom.svg;bundle-version="[1.9.1, 2.0.0)",
- org.apache.batik.xml;bundle-version="[1.9.1, 2.0.0)",
- org.apache.batik.util;bundle-version="[1.9.1, 2.0.0)",
- org.apache.batik.svggen;bundle-version="[1.9.1, 2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[3.0.0,4.0.0)";visibility:=reexport,
- com.ibm.icu,
- org.eclipse.papyrus.infra.services.decoration;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
- org.eclipse.gmf.runtime.diagram.ui.providers;bundle-version="[1.7.0,2.0.0)",
- org.eclipse.papyrus.infra.emf.readonly;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.types.core;bundle-version="[3.0.0,4.0.0)";visibility:=reexport,
- org.eclipse.papyrus.infra.sync;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
- org.eclipse.papyrus.infra.services.edit.ui;bundle-version="[3.0.0,4.0.0)";visibility:=reexport,
- org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.internationalization.utils;bundle-version="[1.0.0,2.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.gmfdiag.representation;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
- org.eclipse.papyrus.infra.gmfdiag.style;bundle-version="[1.0.0,2.0.0)";visibility:=reexport,
- org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.filters;bundle-version="1.2.0",
- org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[3.0.0,4.0.0)",
- org.eclipse.papyrus.infra.architecture.representation;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.architecture;bundle-version="[1.0.0,2.0.0)"
-Bundle-Vendor: %providerName
-Bundle-ActivationPolicy: lazy
-Bundle-ClassPath: .
-Bundle-Localization: plugin
-Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.common.Activator
Export-Package: org.eclipse.papyrus.infra.gmfdiag.common,
org.eclipse.papyrus.infra.gmfdiag.common.adapter,
org.eclipse.papyrus.infra.gmfdiag.common.advice,
@@ -87,7 +43,48 @@ Export-Package: org.eclipse.papyrus.infra.gmfdiag.common,
org.eclipse.papyrus.infra.gmfdiag.common.utils,
org.eclipse.papyrus.infra.gmfdiag.internal.common.expressions;x-internal:=true,
org.eclipse.papyrus.infra.gmfdiag.internal.common.model;x-internal:=true
+Require-Bundle: org.eclipse.emf.ecore.edit;bundle-version="[2.9.0,3.0.0)",
+ org.eclipse.gmf.runtime.diagram.ui.resources.editor;bundle-version="[1.7.0,2.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.infra.emf.appearance;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.commands;bundle-version="[3.0.0,4.0.0)";visibility:=reexport,
+ org.eclipse.gmf.runtime.draw2d.ui.render;bundle-version="[1.7.0,2.0.0)";visibility:=reexport,
+ org.eclipse.gmf.runtime.draw2d.ui.render.awt;bundle-version="[1.8.0,2.0.0)",
+ org.apache.batik.util;bundle-version="[1.6.0,1.7.0)",
+ org.apache.batik.svggen;bundle-version="[1.6.0,1.7.0)",
+ org.w3c.dom.svg;bundle-version="[1.1.0,2.0.0)";visibility:=reexport,
+ org.apache.batik.dom.svg;bundle-version="[1.6.0,1.7.0)",
+ org.apache.batik.dom;bundle-version="[1.6.0,1.7.0)",
+ org.apache.batik.xml;bundle-version="[1.6.0,1.7.0)",
+ org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[3.0.0,4.0.0)";visibility:=reexport,
+ com.ibm.icu,
+ org.eclipse.papyrus.infra.services.decoration;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
+ org.eclipse.gmf.runtime.diagram.ui.providers;bundle-version="[1.7.0,2.0.0)",
+ org.eclipse.papyrus.infra.emf.readonly;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.types.core;bundle-version="[3.0.0,4.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.infra.sync;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.infra.services.edit.ui;bundle-version="[3.0.0,4.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.internationalization.utils;bundle-version="[1.0.0,2.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.tooling.runtime;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.gmfdiag.representation;bundle-version="[1.0.0,3.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.infra.gmfdiag.style;bundle-version="[1.0.0,2.0.0)";visibility:=reexport,
+ org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration;bundle-version="[3.0.0,4.0.0)",
+ org.eclipse.papyrus.infra.filters;bundle-version="1.2.0",
+ org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[2.100.0,4.0.0)",
+ org.eclipse.papyrus.infra.architecture.representation;bundle-version="[1.0.0,3.0.0)",
+ org.eclipse.papyrus.infra.architecture;bundle-version="[1.0.0,2.0.0)"
+Bundle-Vendor: %providerName
+Bundle-ActivationPolicy: lazy
+Bundle-ClassPath: .
+Bundle-Version: 3.100.0.qualifier
+Bundle-Localization: plugin
+Bundle-Name: %pluginName
+Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.common.Activator
+Bundle-ManifestVersion: 2
+Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.common;singleton:=true
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: com.google.common.base;version="21.0.0",
com.google.common.collect;version="21.0.0",
com.google.common.util.concurrent;version="21.0.0"
-Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.common
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/src/org/eclipse/papyrus/infra/gmfdiag/common/service/shape/AbstractShapeProvider.java b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/src/org/eclipse/papyrus/infra/gmfdiag/common/service/shape/AbstractShapeProvider.java
index 4a4af7a6634..555f65cfdd5 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/src/org/eclipse/papyrus/infra/gmfdiag/common/service/shape/AbstractShapeProvider.java
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/src/org/eclipse/papyrus/infra/gmfdiag/common/service/shape/AbstractShapeProvider.java
@@ -20,7 +20,7 @@ import java.util.HashMap;
import java.util.Map;
import java.util.WeakHashMap;
-import org.apache.batik.anim.dom.SAXSVGDocumentFactory;
+import org.apache.batik.dom.svg.SAXSVGDocumentFactory;
import org.apache.batik.dom.util.DOMUtilities;
import org.eclipse.core.runtime.IConfigurationElement;
import org.eclipse.draw2d.PositionConstants;
@@ -165,12 +165,12 @@ public abstract class AbstractShapeProvider extends AbstractProvider implements
*/
protected synchronized SVGDocument getSVGDocument(EObject view, String location) {
if (relativePaths == null) {
- relativePaths = new WeakHashMap<>();
+ relativePaths = new WeakHashMap<Resource, Map<String, String>>();
}
- if (location.contains("/" + POSITION_KEY) || location.contains("." + POSITION_KEY)) { //$NON-NLS-1$//$NON-NLS-2$
+ if (location.contains("/" + POSITION_KEY) || location.contains("." + POSITION_KEY)) { //$NON-NLS-1$//$NON-NLS-2$
// load a specific variant of a symbol (with a different orientation) if the file name
// contains a specific "magic" key. The motivation is that symbols on the border of a parent
- // (e.g. a port symbol) could always point into the parent shape depending on its position
+ // (e.g. a port symbol) could always point into the parent shape depending on its position
try {
IMultiDiagramEditor editor = ServiceUtilsForEObject.getInstance().getService(IMultiDiagramEditor.class, view);
@@ -201,9 +201,7 @@ public abstract class AbstractShapeProvider extends AbstractProvider implements
/**
* Get a position key (enumeration) from the bit-vector representation of the position
- *
- * @param side
- * the binary encoded position
+ * @param side the binary encoded position
* @return the position key
*/
protected PositionEnum getPositionKey(int side) {
@@ -218,7 +216,6 @@ public abstract class AbstractShapeProvider extends AbstractProvider implements
return PositionEnum.SOUTH;
}
}
-
/**
* Loads a SVG document from the given location.
* This method uses a cache so that any given document is only loaded once.
@@ -229,7 +226,7 @@ public abstract class AbstractShapeProvider extends AbstractProvider implements
*/
protected synchronized SVGDocument getSVGDocument(String location) {
if (cache == null) {
- cache = new HashMap<>();
+ cache = new HashMap<String, SVGDocument>();
}
if (cache.containsKey(location)) {
return cache.get(location);
@@ -288,7 +285,7 @@ public abstract class AbstractShapeProvider extends AbstractProvider implements
Map<String, String> resMap = relativePaths.get(model.eResource());
if (resMap == null) {
- resMap = new HashMap<>();
+ resMap = new HashMap<String, String>();
relativePaths.put(model.eResource(), resMap);
}
String canonical = resMap.get(uri);
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java b/plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java
index cd9e7425b64..431d632fa29 100644
--- a/plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java
+++ b/plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java
@@ -34,7 +34,7 @@ public class VersionRules {
private final VersionRule rule = VersionRule.composeAll(
new CurrentVersionRule(), // The default behaviour
- new FixedRangeRule(dep -> dep.startsWith("org.apache.batik"), "[1.9.1, 2.0.0)"), //$NON-NLS-1$//$NON-NLS-2$
+ new FixedRangeRule(dep -> dep.startsWith("org.apache.batik"), "[1.6.0,1.7.0)"), //$NON-NLS-1$//$NON-NLS-2$
new SkipRule("com.ibm.icu"), //$NON-NLS-1$
new FixedRangeRule("com.google.guava", "21.0.0") //$NON-NLS-1$
);
diff --git a/plugins/uml/org.eclipse.papyrus.uml.export/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.export/META-INF/MANIFEST.MF
index e4074ce0489..b62b9dafd52 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.export/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.export/META-INF/MANIFEST.MF
@@ -2,11 +2,11 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.uml.export;singleton:=true
-Bundle-Version: 1.0.100.qualifier
+Bundle-Version: 1.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.jdt.ui;bundle-version="[3.13.50,4.0.0)",
org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
- org.apache.batik.anim;bundle-version="[1.9.1, 2.0.0)",
+ org.apache.batik.dom.svg;bundle-version="[1.6.0,1.7.0)",
com.google.gson;bundle-version="2.7.0",
org.eclipse.gmf.runtime.diagram.ui.render;bundle-version="[1.7.0,2.0.0)",
org.eclipse.gmf.runtime.draw2d.ui.render.awt;bundle-version="[1.7.0,2.0.0)",
@@ -28,4 +28,3 @@ Export-Package: org.eclipse.papyrus.uml.export,
org.eclipse.papyrus.uml.export.ui,
org.eclipse.papyrus.uml.export.util
Bundle-Localization: plugin
-Automatic-Module-Name: org.eclipse.papyrus.uml.export
diff --git a/plugins/uml/org.eclipse.papyrus.uml.export/pom.xml b/plugins/uml/org.eclipse.papyrus.uml.export/pom.xml
index 7b6f6566322..4d9899b18d7 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.export/pom.xml
+++ b/plugins/uml/org.eclipse.papyrus.uml.export/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.export</artifactId>
- <version>1.0.100-SNAPSHOT</version>
+ <version>1.0.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/uml/org.eclipse.papyrus.uml.export/src/org/eclipse/papyrus/uml/export/extension/contribution/CommentAnnotateSVG.java b/plugins/uml/org.eclipse.papyrus.uml.export/src/org/eclipse/papyrus/uml/export/extension/contribution/CommentAnnotateSVG.java
index 3d0f7f9b9c6..925e3d104a6 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.export/src/org/eclipse/papyrus/uml/export/extension/contribution/CommentAnnotateSVG.java
+++ b/plugins/uml/org.eclipse.papyrus.uml.export/src/org/eclipse/papyrus/uml/export/extension/contribution/CommentAnnotateSVG.java
@@ -11,7 +11,7 @@
*****************************************************************************/
package org.eclipse.papyrus.uml.export.extension.contribution;
-import org.apache.batik.anim.dom.SVGDOMImplementation;
+import org.apache.batik.dom.svg.SVGDOMImplementation;
import org.eclipse.emf.common.util.EList;
import org.eclipse.emf.ecore.EObject;
import org.eclipse.gmf.runtime.draw2d.ui.render.awt.internal.svg.export.GraphicsSVG;
@@ -46,7 +46,7 @@ public class CommentAnnotateSVG implements AnnotateSVG {
EObject eObject = view.getElement();
if (eObject instanceof NamedElement) {
NamedElement namedElement = (NamedElement) eObject;
- EList<Comment> ownedComments = namedElement.getOwnedComments();
+ EList<Comment> ownedComments = namedElement.getOwnedComments();
if (!ownedComments.isEmpty()) {
rectangle.setAttributeNS(null, ATTRIBUTE_TITLE, ownedComments.get(0).getBody());
Element title = svgG.getDocument().createElementNS(SVGDOMImplementation.SVG_NAMESPACE_URI, ATTRIBUTE_TITLE);
diff --git a/plugins/uml/org.eclipse.papyrus.uml.export/src/org/eclipse/papyrus/uml/export/svgextension/PapyrusDiagramSVGGenerator.java b/plugins/uml/org.eclipse.papyrus.uml.export/src/org/eclipse/papyrus/uml/export/svgextension/PapyrusDiagramSVGGenerator.java
index 53f55e4a4e9..a2b1064023b 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.export/src/org/eclipse/papyrus/uml/export/svgextension/PapyrusDiagramSVGGenerator.java
+++ b/plugins/uml/org.eclipse.papyrus.uml.export/src/org/eclipse/papyrus/uml/export/svgextension/PapyrusDiagramSVGGenerator.java
@@ -26,7 +26,7 @@ import javax.xml.transform.TransformerFactory;
import javax.xml.transform.dom.DOMSource;
import javax.xml.transform.stream.StreamResult;
-import org.apache.batik.anim.dom.SVGDOMImplementation;
+import org.apache.batik.dom.svg.SVGDOMImplementation;
import org.eclipse.core.runtime.IStatus;
import org.eclipse.draw2d.Graphics;
import org.eclipse.draw2d.geometry.Rectangle;
@@ -57,17 +57,15 @@ import org.w3c.dom.Element;
public class PapyrusDiagramSVGGenerator extends OpenAPIDiagramSVGGenerator {
/** The annotations. */
- private List<AnnotateSVG> annotations = new ArrayList<>();
-
+ private List<AnnotateSVG> annotations = new ArrayList<>();
+
/**
* Instantiates a new papyrus diagram SVG generator.
*
- * @param diagramEditPart
- * the diagram edit part
- * @param annotations
- * the annotations
+ * @param diagramEditPart the diagram edit part
+ * @param annotations the annotations
*/
- public PapyrusDiagramSVGGenerator(DiagramEditPart diagramEditPart, List<AnnotateSVG> annotations) {
+ public PapyrusDiagramSVGGenerator(DiagramEditPart diagramEditPart, List<AnnotateSVG> annotations ) {
super(diagramEditPart);
this.annotations = annotations;
}
@@ -118,11 +116,11 @@ public class PapyrusDiagramSVGGenerator extends OpenAPIDiagramSVGGenerator {
Activator.log(IStatus.INFO, "Start transformation from Graphics to image descriptor");
GraphicsSVG svgG = (GraphicsSVG) g;
- svgRoot = svgG.getRoot();
-
+ svgRoot = svgG.getRoot();
+
//////// Papyrus Specific code //////////
List<PartPositionInfo> allPartPositionInfo = this.getDiagramPartInfo();
-
+
Collections.reverse(allPartPositionInfo);// Required to have property after class
for (PartPositionInfo partPositionInfo : allPartPositionInfo) {
Element rectangle = svgG.getDocument().createElementNS(SVGDOMImplementation.SVG_NAMESPACE_URI, "rect");
@@ -130,27 +128,27 @@ public class PapyrusDiagramSVGGenerator extends OpenAPIDiagramSVGGenerator {
NamedElement nameElement = (NamedElement) partPositionInfo.getSemanticElement();
rectangle.setAttributeNS(null, "id", nameElement.getName());// useful for svg debug
}
-
+
rectangle.setAttributeNS(null, "x", String.valueOf(partPositionInfo.getPartX()));
rectangle.setAttributeNS(null, "y", String.valueOf(partPositionInfo.getPartY()));
rectangle.setAttributeNS(null, "width", String.valueOf(partPositionInfo.getPartWidth()));
rectangle.setAttributeNS(null, "height", String.valueOf(partPositionInfo.getPartHeight()));
- rectangle.setAttributeNS(null, "fill-opacity", "0"); // transparent
+ rectangle.setAttributeNS(null, "fill-opacity", "0"); //transparent
rectangle.setAttributeNS(null, "stroke-opacity", "0"); // no border
- View view = partPositionInfo.getView();
+ View view = partPositionInfo.getView();
if (view instanceof Shape) { // filter on shape only to avoid duplication
boolean hasAnnotation = applyAll(view, svgG, rectangle);
if (hasAnnotation) {
- svgRoot.appendChild(rectangle);
- }
+ svgRoot.appendChild(rectangle);
+ }
}
}
-
+
/////////////////////////
-
-
+
+
ByteArrayOutputStream os = new ByteArrayOutputStream(5000); // 5K
// buffer
stream(os);
@@ -159,25 +157,22 @@ public class PapyrusDiagramSVGGenerator extends OpenAPIDiagramSVGGenerator {
setRenderedImage(RenderedImageFactory.getInstance(os.toByteArray()));
return RenderedImageDescriptor
- .createFromRenderedImage(getRenderedImage());
+ .createFromRenderedImage(getRenderedImage());
} catch (IOException ex) {
Log.error(DiagramUIRenderPlugin.getInstance(), IStatus.ERROR, ex
- .getMessage(), ex);
+ .getMessage(), ex);
}
return null;
}
-
+
/**
* Apply all.
*
- * @param view
- * the view
- * @param svgG
- * the svg G
- * @param rectangle
- * the rectangle
+ * @param view the view
+ * @param svgG the svg G
+ * @param rectangle the rectangle
* @return true, if successful
*/
public boolean applyAll(View view, GraphicsSVG svgG, Element rectangle) {
@@ -186,15 +181,14 @@ public class PapyrusDiagramSVGGenerator extends OpenAPIDiagramSVGGenerator {
res = res || annotateSVG.addAnnotation(view, svgG, rectangle);
}
return true;
- }
-
+ }
+
/**
* Writes the SVG Model out to a file.
*
* @param outputStream
* output stream to store the SVG Model
*/
- @Override
public void stream(OutputStream outputStream) {
try {
// Define the view box
@@ -230,12 +224,11 @@ public class PapyrusDiagramSVGGenerator extends OpenAPIDiagramSVGGenerator {
* @see org.eclipse.gmf.runtime.diagram.ui.internal.clipboard.DiagramGenerator#
* createAWTImageForParts(java.util.List)
*/
- @Override
public Image createAWTImageForParts(List editparts, org.eclipse.swt.graphics.Rectangle sourceRect) {
createSWTImageDescriptorForParts(editparts, sourceRect);
if (getRenderedImage() != null) {
try {
- BufferedImage bufImg = getRenderedImage().getAdapter(BufferedImage.class);
+ BufferedImage bufImg = (BufferedImage) getRenderedImage().getAdapter(BufferedImage.class);
if (bufImg == null)
bufImg = ImageConverter.convert(getRenderedImage().getSWTImage());
return bufImg;
@@ -264,7 +257,6 @@ public class PapyrusDiagramSVGGenerator extends OpenAPIDiagramSVGGenerator {
* @return Returns the rendered image created by previous call to
* createSWTImageDescriptorForParts
*/
- @Override
public RenderedImage getRenderedImage() {
return renderedImage;
}
@@ -272,8 +264,7 @@ public class PapyrusDiagramSVGGenerator extends OpenAPIDiagramSVGGenerator {
/**
* Sets the rendered image.
*
- * @param renderedImage
- * the new rendered image
+ * @param renderedImage the new rendered image
*/
private void setRenderedImage(RenderedImage renderedImage) {
this.renderedImage = renderedImage;
diff --git a/releng/main-tests/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.eclipse.target.target b/releng/main-tests/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.eclipse.target.target
index a4c34d8541f..a207ef4274c 100644
--- a/releng/main-tests/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.eclipse.target.target
+++ b/releng/main-tests/targetPlatform/eclipse/org.eclipse.papyrus.main.tests.eclipse.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->
-<target name="Papyrus Tests" sequenceNumber="1524152643">
+<target name="Papyrus Tests" sequenceNumber="1521016135">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.8.0.v20180130-0706"/>
@@ -42,8 +42,8 @@
<repository id="mwe" location="file:/home/data/httpd/download.eclipse.org/modeling/emft/mwe/updates/releases/2.9.1/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201804101955"/>
- <repository id="webtools" location="file:/home/data/httpd/download.eclipse.org/webtools/downloads/drops/R3.10.0/I-latest/repository/"/>
+ <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201802261859"/>
+ <repository id="webtools" location="file:/home/data/httpd/download.eclipse.org/webtools/downloads/drops/R3.10.0/S-3.10.0.M6-20180309052619/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201801291558"/>
@@ -94,27 +94,15 @@
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
- <unit id="org.apache.batik.anim" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.anim.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen.source" version="1.9.1.v20180227-1645"/>
- <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/downloads/drops/S20180302171354/repository"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.3.201803131355"/>
- <repository id="emfCompare" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201803131355"/>
+ <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/S-builds/S20180119201206/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.gmf.tooling.codegen.xtend2.feature.group" version="3.3.1.201509291144"/>
<repository id="gmfTooling" location="file:/home/data/httpd/download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases-3.3.1a"/>
</location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.2.201709090201"/>
+ <repository id="emfCompare" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/compare/updates/releases/3.3"/>
+ </location>
</locations>
</target>
diff --git a/releng/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.target b/releng/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.target
index 106f30b4080..02980a06e1f 100644
--- a/releng/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.target
+++ b/releng/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->
-<target name="Papyrus Tests" sequenceNumber="1524152643">
+<target name="Papyrus Tests" sequenceNumber="1521016135">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.8.0.v20180130-0706"/>
@@ -42,8 +42,8 @@
<repository id="mwe" location="http://download.eclipse.org/modeling/emft/mwe/updates/releases/2.9.1/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201804101955"/>
- <repository id="webtools" location="http://download.eclipse.org/webtools/downloads/drops/R3.10.0/I-latest/repository/"/>
+ <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201802261859"/>
+ <repository id="webtools" location="http://download.eclipse.org/webtools/downloads/drops/R3.10.0/S-3.10.0.M6-20180309052619/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201801291558"/>
@@ -94,27 +94,15 @@
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
- <unit id="org.apache.batik.anim" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.anim.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen.source" version="1.9.1.v20180227-1645"/>
- <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/S20180302171354/repository"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.3.201803131355"/>
- <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201803131355"/>
+ <repository id="orbit" location="http://download.eclipse.org/tools/orbit/S-builds/S20180119201206/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.gmf.tooling.codegen.xtend2.feature.group" version="3.3.1.201509291144"/>
<repository id="gmfTooling" location="http://download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases-3.3.1a"/>
</location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.2.201709090201"/>
+ <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/releases/3.3"/>
+ </location>
</locations>
</target>
diff --git a/releng/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.tpd b/releng/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.tpd
index 74a41a2b91c..cc0c159e09c 100644
--- a/releng/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.tpd
+++ b/releng/main-tests/targetPlatform/portable/org.eclipse.papyrus.main.tests.portable.target.tpd
@@ -4,7 +4,7 @@ include "../../../main/targetPlatform/portable/org.eclipse.papyrus.main.portable
//updateFrom("EMF COMPARE",0)
-location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201803131355" {
+location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/releases/latest" {
org.eclipse.emf.compare.source.feature.group
}
@@ -12,4 +12,4 @@ location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/mi
location gmfTooling "http://download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases-3.3.1a" {
org.eclipse.gmf.tooling.codegen.xtend2.feature.group
-} \ No newline at end of file
+}
diff --git a/releng/main/targetPlatform/eclipse/org.eclipse.papyrus.main.eclipse.target.target b/releng/main/targetPlatform/eclipse/org.eclipse.papyrus.main.eclipse.target.target
index 60a99d2f594..4c1c0ea9695 100644
--- a/releng/main/targetPlatform/eclipse/org.eclipse.papyrus.main.eclipse.target.target
+++ b/releng/main/targetPlatform/eclipse/org.eclipse.papyrus.main.eclipse.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->
-<target name="Papyrus Main" sequenceNumber="1524152643">
+<target name="Papyrus Main" sequenceNumber="1521016135">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.8.0.v20180130-0706"/>
@@ -42,8 +42,8 @@
<repository id="mwe" location="file:/home/data/httpd/download.eclipse.org/modeling/emft/mwe/updates/releases/2.9.1/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201804101955"/>
- <repository id="webtools" location="file:/home/data/httpd/download.eclipse.org/webtools/downloads/drops/R3.10.0/I-latest/repository/"/>
+ <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201802261859"/>
+ <repository id="webtools" location="file:/home/data/httpd/download.eclipse.org/webtools/downloads/drops/R3.10.0/S-3.10.0.M6-20180309052619/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201801291558"/>
@@ -94,19 +94,7 @@
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
- <unit id="org.apache.batik.anim" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.anim.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen.source" version="1.9.1.v20180227-1645"/>
- <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/downloads/drops/S20180302171354/repository"/>
+ <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/S-builds/S20180119201206/repository"/>
</location>
</locations>
</target>
diff --git a/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.target b/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.target
index ddfb9bb44e5..528a2ff470c 100644
--- a/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.target
+++ b/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->
-<target name="Papyrus Main" sequenceNumber="1524152643">
+<target name="Papyrus Main" sequenceNumber="1521016135">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.8.0.v20180130-0706"/>
@@ -42,8 +42,8 @@
<repository id="mwe" location="http://download.eclipse.org/modeling/emft/mwe/updates/releases/2.9.1/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201804101955"/>
- <repository id="webtools" location="http://download.eclipse.org/webtools/downloads/drops/R3.10.0/I-latest/repository/"/>
+ <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201802261859"/>
+ <repository id="webtools" location="http://download.eclipse.org/webtools/downloads/drops/R3.10.0/S-3.10.0.M6-20180309052619/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201801291558"/>
@@ -94,19 +94,7 @@
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
- <unit id="org.apache.batik.anim" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.anim.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen.source" version="1.9.1.v20180227-1645"/>
- <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/S20180302171354/repository"/>
+ <repository id="orbit" location="http://download.eclipse.org/tools/orbit/S-builds/S20180119201206/repository"/>
</location>
</locations>
</target>
diff --git a/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.tpd b/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.tpd
index edb83ea6b40..15da36f014d 100755
--- a/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.tpd
+++ b/releng/main/targetPlatform/portable/org.eclipse.papyrus.main.portable.target.tpd
@@ -58,7 +58,7 @@ location mwe "http://download.eclipse.org/modeling/emft/mwe/updates/releases/2.9
//updateFrom("WebTools",0)
-location webtools "http://download.eclipse.org/webtools/downloads/drops/R3.10.0/I-latest/repository/" {
+location webtools "http://download.eclipse.org/webtools/downloads/drops/R3.10.0/S-3.10.0.M6-20180309052619/repository/" {
org.eclipse.wst.xml_ui.feature.feature.group
}
@@ -127,23 +127,11 @@ location nattable "http://download.eclipse.org/nattable/releases/1.5.0/repositor
//manualUpdate (Needed by infra.tools, API Evolution Report generation and other plugins)
-location orbit "http://download.eclipse.org/tools/orbit/downloads/drops/S20180302171354/repository" {
+location orbit "http://download.eclipse.org/tools/orbit/S-builds/S20180119201206/repository" {
com.google.guava 21.0.0
com.google.guava.source 21.0.0
com.google.gson [2.7.0,2.8.0)
com.google.gson.source [2.7.0,2.8.0)
org.apache.commons.lang3 3.1.0
org.apache.commons.lang3.source 3.1.0
- org.apache.batik.anim [1.9.1,2.0.0)
- org.apache.batik.anim.source [1.9.1,2.0.0)
- org.apache.batik.dom [1.9.1,2.0.0)
- org.apache.batik.dom.source [1.9.1,2.0.0)
- org.apache.batik.dom.svg [1.9.1,2.0.0)
- org.apache.batik.dom.svg.source [1.9.1,2.0.0)
- org.apache.batik.xml [1.9.1,2.0.0)
- org.apache.batik.xml.source [1.9.1,2.0.0)
- org.apache.batik.util [1.9.1,2.0.0)
- org.apache.batik.util.source [1.9.1,2.0.0)
- org.apache.batik.svggen [1.9.1,2.0.0)
- org.apache.batik.svggen.source [1.9.1,2.0.0)
} \ No newline at end of file
diff --git a/releng/rcp/targetPlatform/eclipse/org.eclipse.papyrus.rcp.eclipse.target.target b/releng/rcp/targetPlatform/eclipse/org.eclipse.papyrus.rcp.eclipse.target.target
index 69888b4b907..2e65a5b79ff 100644
--- a/releng/rcp/targetPlatform/eclipse/org.eclipse.papyrus.rcp.eclipse.target.target
+++ b/releng/rcp/targetPlatform/eclipse/org.eclipse.papyrus.rcp.eclipse.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->
-<target name="Papyrus RCP" sequenceNumber="1524152645">
+<target name="Papyrus RCP" sequenceNumber="1521016142">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.8.0.v20180130-0706"/>
@@ -38,8 +38,8 @@
<repository id="mwe" location="file:/home/data/httpd/download.eclipse.org/modeling/emft/mwe/updates/releases/2.9.1/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201804101955"/>
- <repository id="webtools" location="file:/home/data/httpd/download.eclipse.org/webtools/downloads/drops/R3.10.0/I-latest/repository/"/>
+ <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201802261859"/>
+ <repository id="webtools" location="file:/home/data/httpd/download.eclipse.org/webtools/downloads/drops/R3.10.0/S-3.10.0.M6-20180309052619/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201801291558"/>
@@ -86,19 +86,7 @@
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
- <unit id="org.apache.batik.anim" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.anim.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen.source" version="1.9.1.v20180227-1645"/>
- <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/downloads/drops/S20180302171354/repository"/>
+ <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/S-builds/S20180119201206/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.egit.feature.group" version="4.10.0.201712302008-r"/>
@@ -115,10 +103,10 @@
<unit id="org.eclipse.mylyn.ide_feature.feature.group" version="3.24.0.v20170629-2230"/>
<unit id="org.eclipse.mylyn.java_feature.feature.group" version="3.24.0.v20170629-2230"/>
<unit id="org.eclipse.mylyn.pde_feature.feature.group" version="3.24.0.v20170629-2230"/>
- <unit id="org.eclipse.mylyn.bugzilla_feature.feature.group" version="3.24.0.v20180221-1812"/>
+ <unit id="org.eclipse.mylyn.bugzilla_feature.feature.group" version="3.24.0.v20170629-1737"/>
<unit id="org.eclipse.mylyn.context_feature.feature.group" version="3.24.0.v20170629-2230"/>
- <unit id="org.eclipse.mylyn_feature.feature.group" version="3.24.0.v20180227-0955"/>
- <repository id="mylyn" location="file:/home/data/httpd/download.eclipse.org/mylyn/drops/3.24.0/v20180404-1809"/>
+ <unit id="org.eclipse.mylyn_feature.feature.group" version="3.24.0.v20170704-1739"/>
+ <repository id="mylyn" location="file:/home/data/httpd/download.eclipse.org/mylyn/drops/3.24.0/v20170705-2102"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.3.201803131355"/>
diff --git a/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.target b/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.target
index 568c672cb6a..a19fa01bd1d 100644
--- a/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.target
+++ b/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->
-<target name="Papyrus RCP" sequenceNumber="1524152645">
+<target name="Papyrus RCP" sequenceNumber="1521016142">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.8.0.v20180130-0706"/>
@@ -38,8 +38,8 @@
<repository id="mwe" location="http://download.eclipse.org/modeling/emft/mwe/updates/releases/2.9.1/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201804101955"/>
- <repository id="webtools" location="http://download.eclipse.org/webtools/downloads/drops/R3.10.0/I-latest/repository/"/>
+ <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201802261859"/>
+ <repository id="webtools" location="http://download.eclipse.org/webtools/downloads/drops/R3.10.0/S-3.10.0.M6-20180309052619/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201801291558"/>
@@ -86,19 +86,7 @@
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
- <unit id="org.apache.batik.anim" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.anim.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen.source" version="1.9.1.v20180227-1645"/>
- <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/S20180302171354/repository"/>
+ <repository id="orbit" location="http://download.eclipse.org/tools/orbit/S-builds/S20180119201206/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.egit.feature.group" version="4.10.0.201712302008-r"/>
@@ -115,10 +103,10 @@
<unit id="org.eclipse.mylyn.ide_feature.feature.group" version="3.24.0.v20170629-2230"/>
<unit id="org.eclipse.mylyn.java_feature.feature.group" version="3.24.0.v20170629-2230"/>
<unit id="org.eclipse.mylyn.pde_feature.feature.group" version="3.24.0.v20170629-2230"/>
- <unit id="org.eclipse.mylyn.bugzilla_feature.feature.group" version="3.24.0.v20180221-1812"/>
+ <unit id="org.eclipse.mylyn.bugzilla_feature.feature.group" version="3.24.0.v20170629-1737"/>
<unit id="org.eclipse.mylyn.context_feature.feature.group" version="3.24.0.v20170629-2230"/>
- <unit id="org.eclipse.mylyn_feature.feature.group" version="3.24.0.v20180227-0955"/>
- <repository id="mylyn" location="http://download.eclipse.org/mylyn/drops/3.24.0/v20180404-1809"/>
+ <unit id="org.eclipse.mylyn_feature.feature.group" version="3.24.0.v20170704-1739"/>
+ <repository id="mylyn" location="http://download.eclipse.org/mylyn/drops/3.24.0/v20170705-2102"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.3.201803131355"/>
diff --git a/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.tpd b/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.tpd
index b80324d6440..601a598cc2c 100644
--- a/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.tpd
+++ b/releng/rcp/targetPlatform/portable/org.eclipse.papyrus.rcp.portable.target.tpd
@@ -20,7 +20,7 @@ location platform "http://download.eclipse.org/eclipse/updates/4.8milestones/S-4
//updateFrom("Mylyn",0)
-location mylyn "http://download.eclipse.org/mylyn/drops/3.24.0/v20180404-1809" {
+location mylyn "http://download.eclipse.org/mylyn/drops/3.24.0/v20170705-2102" {
org.eclipse.mylyn.ide_feature.feature.group
org.eclipse.mylyn.java_feature.feature.group
org.eclipse.mylyn.pde_feature.feature.group
diff --git a/releng/toolsmiths/targetPlatform/eclipse/org.eclipse.papyrus.toolsmiths.eclipse.targetplatform.target b/releng/toolsmiths/targetPlatform/eclipse/org.eclipse.papyrus.toolsmiths.eclipse.targetplatform.target
index 637bae978b5..38d969f06dd 100644
--- a/releng/toolsmiths/targetPlatform/eclipse/org.eclipse.papyrus.toolsmiths.eclipse.targetplatform.target
+++ b/releng/toolsmiths/targetPlatform/eclipse/org.eclipse.papyrus.toolsmiths.eclipse.targetplatform.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->
-<target name="Papyrus Toolsmiths" sequenceNumber="1524152650">
+<target name="Papyrus Toolsmiths" sequenceNumber="1521016146">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.8.0.v20180130-0706"/>
@@ -42,8 +42,8 @@
<repository id="mwe" location="file:/home/data/httpd/download.eclipse.org/modeling/emft/mwe/updates/releases/2.9.1/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201804101955"/>
- <repository id="webtools" location="file:/home/data/httpd/download.eclipse.org/webtools/downloads/drops/R3.10.0/I-latest/repository/"/>
+ <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201802261859"/>
+ <repository id="webtools" location="file:/home/data/httpd/download.eclipse.org/webtools/downloads/drops/R3.10.0/S-3.10.0.M6-20180309052619/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201801291558"/>
@@ -94,19 +94,7 @@
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
- <unit id="org.apache.batik.anim" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.anim.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen.source" version="1.9.1.v20180227-1645"/>
- <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/downloads/drops/S20180302171354/repository"/>
+ <repository id="orbit" location="file:/home/data/httpd/download.eclipse.org/tools/orbit/S-builds/S20180119201206/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.oomph.version.feature.group" version="1.9.0.v20180116-0432"/>
@@ -134,12 +122,7 @@
<repository id="m2e" location="file:/home/data/httpd/download.eclipse.org/technology/m2e/milestones/1.9/1.9.0.20180313-2237"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <repository id="mylyn" location="file:/home/data/httpd/download.eclipse.org/mylyn/drops/3.24.0/v20180404-1809"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.emf.compare.ide.ui.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.3.201803131355"/>
- <repository id="emfCompare" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201803131355"/>
+ <repository id="mylyn" location="file:/home/data/httpd/download.eclipse.org/mylyn/drops/3.24.0/v20170705-2102"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="fr.obeo.releng.targetplatform-feature.feature.group" version="2.1.1.201410251450"/>
@@ -152,6 +135,11 @@
<repository id="cbiAggregator" location="file:/home/data/httpd/download.eclipse.org/cbi/updates/aggregator/ide/4.8/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.compare.ide.ui.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="0.0.0"/>
+ <repository id="emfCompare" location="file:/home/data/httpd/download.eclipse.org/modeling/emf/compare/updates/releases/latest"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.gmf.tooling.feature.group" version="3.3.1.201509291144"/>
<unit id="org.eclipse.gmf.tooling.runtime.feature.group" version="3.3.1.201509291144"/>
<unit id="org.eclipse.gmf.tooling.codegen.xtend2.feature.group" version="3.3.1.201509291144"/>
diff --git a/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.target b/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.target
index c92b56ec36d..b12a706129f 100644
--- a/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.target
+++ b/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.target
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/mbarbero/fr.obeo.releng.targetplatform -->
-<target name="Papyrus Toolsmiths" sequenceNumber="1524152650">
+<target name="Papyrus Toolsmiths" sequenceNumber="1521016146">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.m2m.qvt.oml.sdk.feature.group" version="3.8.0.v20180130-0706"/>
@@ -42,8 +42,8 @@
<repository id="mwe" location="http://download.eclipse.org/modeling/emft/mwe/updates/releases/2.9.1/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201804101955"/>
- <repository id="webtools" location="http://download.eclipse.org/webtools/downloads/drops/R3.10.0/I-latest/repository/"/>
+ <unit id="org.eclipse.wst.xml_ui.feature.feature.group" version="3.9.2.v201802261859"/>
+ <repository id="webtools" location="http://download.eclipse.org/webtools/downloads/drops/R3.10.0/S-3.10.0.M6-20180309052619/repository/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.gmf.runtime.sdk.feature.group" version="1.12.0.201801291558"/>
@@ -94,19 +94,7 @@
<unit id="com.google.gson.source" version="2.7.0.v20170129-0911"/>
<unit id="org.apache.commons.lang3" version="3.1.0.v201403281430"/>
<unit id="org.apache.commons.lang3.source" version="3.1.0.v201403281430"/>
- <unit id="org.apache.batik.anim" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.anim.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.dom.svg.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.xml.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.util.source" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen" version="1.9.1.v20180227-1645"/>
- <unit id="org.apache.batik.svggen.source" version="1.9.1.v20180227-1645"/>
- <repository id="orbit" location="http://download.eclipse.org/tools/orbit/downloads/drops/S20180302171354/repository"/>
+ <repository id="orbit" location="http://download.eclipse.org/tools/orbit/S-builds/S20180119201206/repository"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.oomph.version.feature.group" version="1.9.0.v20180116-0432"/>
@@ -134,12 +122,7 @@
<repository id="m2e" location="http://download.eclipse.org/technology/m2e/milestones/1.9/1.9.0.20180313-2237"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <repository id="mylyn" location="http://download.eclipse.org/mylyn/drops/3.24.0/v20180404-1809"/>
- </location>
- <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
- <unit id="org.eclipse.emf.compare.ide.ui.feature.group" version="0.0.0"/>
- <unit id="org.eclipse.emf.compare.source.feature.group" version="3.3.3.201803131355"/>
- <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201803131355"/>
+ <repository id="mylyn" location="http://download.eclipse.org/mylyn/drops/3.24.0/v20170705-2102"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="fr.obeo.releng.targetplatform-feature.feature.group" version="2.1.1.201410251450"/>
@@ -152,6 +135,11 @@
<repository id="cbiAggregator" location="http://download.eclipse.org/cbi/updates/aggregator/ide/4.8/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
+ <unit id="org.eclipse.emf.compare.ide.ui.feature.group" version="0.0.0"/>
+ <unit id="org.eclipse.emf.compare.source.feature.group" version="0.0.0"/>
+ <repository id="emfCompare" location="http://download.eclipse.org/modeling/emf/compare/updates/releases/latest"/>
+ </location>
+ <location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="false" type="InstallableUnit">
<unit id="org.eclipse.gmf.tooling.feature.group" version="3.3.1.201509291144"/>
<unit id="org.eclipse.gmf.tooling.runtime.feature.group" version="3.3.1.201509291144"/>
<unit id="org.eclipse.gmf.tooling.codegen.xtend2.feature.group" version="3.3.1.201509291144"/>
diff --git a/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.tpd b/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.tpd
index 2a27920495f..5ef37bb55c9 100644
--- a/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.tpd
+++ b/releng/toolsmiths/targetPlatform/portable/org.eclipse.papyrus.toolsmiths.portable.targetplatform.tpd
@@ -36,11 +36,11 @@ location m2e "http://download.eclipse.org/technology/m2e/milestones/1.9/1.9.0.20
//updateFrom("Mylyn",0)
-location mylyn "http://download.eclipse.org/mylyn/drops/3.24.0/v20180404-1809" // oomph
+location mylyn "http://download.eclipse.org/mylyn/drops/3.24.0/v20170705-2102" // oomph
//updateFrom("EMF COMPARE",0)
-location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201803131355" {
+location emfCompare "http://download.eclipse.org/modeling/emf/compare/updates/releases/latest" {
org.eclipse.emf.compare.ide.ui.feature.group lazy
org.eclipse.emf.compare.source.feature.group
}
@@ -67,4 +67,4 @@ location gmfTooling "http://download.eclipse.org/modeling/gmp/gmf-tooling/update
org.eclipse.gmf.tooling.feature.group
org.eclipse.gmf.tooling.runtime.feature.group
org.eclipse.gmf.tooling.codegen.xtend2.feature.group
-} \ No newline at end of file
+}
diff --git a/tests/junit/framework/org.eclipse.papyrus.bundles.tests/src/org/eclipse/papyrus/bundles/tests/BundlesTests.java b/tests/junit/framework/org.eclipse.papyrus.bundles.tests/src/org/eclipse/papyrus/bundles/tests/BundlesTests.java
index 765d46ef28a..9ac4563248c 100755
--- a/tests/junit/framework/org.eclipse.papyrus.bundles.tests/src/org/eclipse/papyrus/bundles/tests/BundlesTests.java
+++ b/tests/junit/framework/org.eclipse.papyrus.bundles.tests/src/org/eclipse/papyrus/bundles/tests/BundlesTests.java
@@ -56,7 +56,7 @@ public class BundlesTests extends AbstractPapyrusTest {
private static final String INCUBATION_KEYWORD = "(Incubation)"; //$NON-NLS-1$
- private static final String BATIK_VERSION = "\"[1.9.1,2.0.0)\""; //$NON-NLS-1$
+ private static final String BATIK_VERSION = "\"[1.6.0,1.7.0)\""; //$NON-NLS-1$
private static final String NATTABLE_VERSION = "1.5.0"; //$NON-NLS-1$

Back to the top