Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan D. Brooks2014-01-15 22:01:58 +0000
committerRoberto E. Escobar2014-03-04 19:42:08 +0000
commit6e07e07e8fe5f5bf40425338902039002345e613 (patch)
treeed2483a00db7a292ed5bdbb2c6cbe8c9794da8d3 /plugins/org.eclipse.osee.framework.manager.servlet
parentfff76a1dd16a84035978a990452ded43f8e8eb7c (diff)
downloadorg.eclipse.osee-6e07e07e8fe5f5bf40425338902039002345e613.tar.gz
org.eclipse.osee-6e07e07e8fe5f5bf40425338902039002345e613.tar.xz
org.eclipse.osee-6e07e07e8fe5f5bf40425338902039002345e613.zip
refactor: Use package dependencies instead of bundle dependencies
Diffstat (limited to 'plugins/org.eclipse.osee.framework.manager.servlet')
-rw-r--r--plugins/org.eclipse.osee.framework.manager.servlet/META-INF/MANIFEST.MF13
1 files changed, 8 insertions, 5 deletions
diff --git a/plugins/org.eclipse.osee.framework.manager.servlet/META-INF/MANIFEST.MF b/plugins/org.eclipse.osee.framework.manager.servlet/META-INF/MANIFEST.MF
index b8916315bcc..b217c586db0 100644
--- a/plugins/org.eclipse.osee.framework.manager.servlet/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.osee.framework.manager.servlet/META-INF/MANIFEST.MF
@@ -1,10 +1,16 @@
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Servlet Plug-in
-Bundle-SymbolicName: org.eclipse.osee.framework.manager.servlet;singleton:=true
+Bundle-SymbolicName: org.eclipse.osee.framework.manager.servlet
Bundle-Version: 0.17.0.qualifier
Bundle-ActivationPolicy: lazy
-Import-Package: org.eclipse.osee.event,
+Import-Package: com.google.common.base,
+ com.google.common.collect,
+ javax.servlet,
+ javax.servlet.http,
+ org.eclipse.core.runtime,
+ org.eclipse.core.runtime.jobs,
+ org.eclipse.osee.event,
org.eclipse.osee.executor.admin,
org.eclipse.osee.framework.core.data,
org.eclipse.osee.framework.core.enums,
@@ -38,6 +44,3 @@ Import-Package: org.eclipse.osee.event,
org.osgi.util.tracker
Service-Component: OSGI-INF/*.xml
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Require-Bundle: org.eclipse.core.runtime,
- javax.servlet;bundle-version="2.5.0",
- com.google.guava;bundle-version="[11.0.0,15.0.0)"

Back to the top