Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorspingel2008-04-01 06:05:33 +0000
committerspingel2008-04-01 06:05:33 +0000
commit88649c889d5fdf5d16c3f55a1dfa6865dc99823c (patch)
tree94306847ad57e6df11acb4cf5a9bd8d8522e4649 /org.eclipse.mylyn.trac.ui
parentde097120075206abaf422697ced95d4eda8a8e8d (diff)
downloadorg.eclipse.mylyn.tasks-88649c889d5fdf5d16c3f55a1dfa6865dc99823c.tar.gz
org.eclipse.mylyn.tasks-88649c889d5fdf5d16c3f55a1dfa6865dc99823c.tar.xz
org.eclipse.mylyn.tasks-88649c889d5fdf5d16c3f55a1dfa6865dc99823c.zip
NEW - bug 225040: mark internal packages as x-internal
https://bugs.eclipse.org/bugs/show_bug.cgi?id=225040
Diffstat (limited to 'org.eclipse.mylyn.trac.ui')
-rw-r--r--org.eclipse.mylyn.trac.ui/.project6
-rw-r--r--org.eclipse.mylyn.trac.ui/META-INF/MANIFEST.MF6
2 files changed, 9 insertions, 3 deletions
diff --git a/org.eclipse.mylyn.trac.ui/.project b/org.eclipse.mylyn.trac.ui/.project
index fce887b43..6c9ffc283 100644
--- a/org.eclipse.mylyn.trac.ui/.project
+++ b/org.eclipse.mylyn.trac.ui/.project
@@ -20,9 +20,15 @@
<arguments>
</arguments>
</buildCommand>
+ <buildCommand>
+ <name>org.eclipse.pde.api.tools.apiAnalysisBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
</buildSpec>
<natures>
<nature>org.eclipse.pde.PluginNature</nature>
<nature>org.eclipse.jdt.core.javanature</nature>
+ <nature>org.eclipse.pde.api.tools.apiAnalysisNature</nature>
</natures>
</projectDescription>
diff --git a/org.eclipse.mylyn.trac.ui/META-INF/MANIFEST.MF b/org.eclipse.mylyn.trac.ui/META-INF/MANIFEST.MF
index 8b19cac06..0f6458ed3 100644
--- a/org.eclipse.mylyn.trac.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.trac.ui/META-INF/MANIFEST.MF
@@ -20,7 +20,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.ui.workbench.texteditor,
org.eclipse.mylyn.web.core;bundle-version="[3.0.0,4.0.0)"
Eclipse-LazyStart: true
-Export-Package: org.eclipse.mylyn.internal.trac.ui,
- org.eclipse.mylyn.internal.trac.ui.editor,
- org.eclipse.mylyn.internal.trac.ui.wizard
+Export-Package: org.eclipse.mylyn.internal.trac.ui;x-internal:=true,
+ org.eclipse.mylyn.internal.trac.ui.editor;x-internal:=true,
+ org.eclipse.mylyn.internal.trac.ui.wizard;x-internal:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5

Back to the top