Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEd Willink2018-12-16 19:13:06 +0000
committerEd Willink2018-12-16 19:30:57 +0000
commitc718a1bcd390ba8419ae642fedbca81425f3d423 (patch)
tree8a5613044fd61ddd309c9d8f8640e45a279743dd
parent90c1b701d8d7348aa495a97d2c9593e6aa7d24dd (diff)
downloadorg.eclipse.qvtd-c718a1bcd390ba8419ae642fedbca81425f3d423.tar.gz
org.eclipse.qvtd-c718a1bcd390ba8419ae642fedbca81425f3d423.tar.xz
org.eclipse.qvtd-c718a1bcd390ba8419ae642fedbca81425f3d423.zip
[releng] +0.1.0 to 0.18.0
-rw-r--r--doc/org.eclipse.qvtd.doc.miniocl.build/META-INF/MANIFEST.MF8
-rw-r--r--doc/org.eclipse.qvtd.doc.miniocl/.polyglot.build.properties13
-rw-r--r--doc/org.eclipse.qvtd.doc.miniocl/META-INF/MANIFEST.MF2
-rw-r--r--doc/org.eclipse.qvtd.doc.minioclcs.xtext.ide/META-INF/MANIFEST.MF4
-rw-r--r--doc/org.eclipse.qvtd.doc.minioclcs.xtext.ui/META-INF/MANIFEST.MF8
-rw-r--r--doc/org.eclipse.qvtd.doc.minioclcs.xtext/.polyglot.build.properties13
-rw-r--r--doc/org.eclipse.qvtd.doc.minioclcs.xtext/META-INF/MANIFEST.MF4
-rw-r--r--doc/org.eclipse.qvtd.doc/.polyglot.build.properties13
-rw-r--r--doc/org.eclipse.qvtd.doc/META-INF/MANIFEST.MF2
-rw-r--r--doc/pom.xml4
-rw-r--r--examples/org.eclipse.qvtd.examples.qvtcore.uml2rdbms/.polyglot.build.properties13
-rw-r--r--examples/org.eclipse.qvtd.examples.qvtcore.uml2rdbms/META-INF/MANIFEST.MF2
-rw-r--r--examples/org.eclipse.qvtd.examples.qvtrelation.hstm2fstm/.polyglot.build.properties13
-rw-r--r--examples/org.eclipse.qvtd.examples.qvtrelation.hstm2fstm/META-INF/MANIFEST.MF2
-rw-r--r--examples/org.eclipse.qvtd.examples.qvtrelation.modelmorf/.polyglot.build.properties13
-rw-r--r--examples/org.eclipse.qvtd.examples.qvtrelation.modelmorf/META-INF/MANIFEST.MF2
-rw-r--r--examples/org.eclipse.qvtd.examples.qvtrelation.reltocore/.polyglot.build.properties13
-rw-r--r--examples/org.eclipse.qvtd.examples.qvtrelation.reltocore/META-INF/MANIFEST.MF2
-rw-r--r--examples/org.eclipse.qvtd.examples.umlx.hstm2fstm/.polyglot.build.properties13
-rw-r--r--examples/org.eclipse.qvtd.examples.umlx.hstm2fstm/META-INF/MANIFEST.MF2
-rw-r--r--examples/org.eclipse.qvtd.examples/META-INF/MANIFEST.MF2
-rw-r--r--examples/org.eclipse.qvtd.examples/pom.xml4
-rw-r--r--examples/pom.xml4
-rw-r--r--features/org.eclipse.qvtd.atl-feature/.polyglot.build.properties13
-rw-r--r--features/org.eclipse.qvtd.atl-feature/feature.xml2
-rw-r--r--features/org.eclipse.qvtd.doc-feature/.polyglot.build.properties13
-rw-r--r--features/org.eclipse.qvtd.doc-feature/feature.xml2
-rw-r--r--features/org.eclipse.qvtd.examples-feature/.polyglot.build.properties13
-rw-r--r--features/org.eclipse.qvtd.examples-feature/feature.xml2
-rw-r--r--features/org.eclipse.qvtd.master-feature/.polyglot.build.properties13
-rw-r--r--features/org.eclipse.qvtd.master-feature/feature.xml2
-rw-r--r--features/org.eclipse.qvtd.tests-feature/.polyglot.build.properties13
-rw-r--r--features/org.eclipse.qvtd.tests-feature/feature.xml2
-rw-r--r--features/org.eclipse.qvtd.umlx-feature/.polyglot.build.properties13
-rw-r--r--features/org.eclipse.qvtd.umlx-feature/feature.xml2
-rw-r--r--features/pom.xml4
-rw-r--r--plugins/org.eclipse.qvt/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvt/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.qvtd.atl/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.atl/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.qvtd.codegen/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.codegen/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.qvtd.compiler/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.compiler/META-INF/MANIFEST.MF12
-rw-r--r--plugins/org.eclipse.qvtd.cs2as.build/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.qvtd.cs2as.compiler/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.cs2as.compiler/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.qvtd.cs2as.xtext.generator/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.qvtd.cs2as.xtext.runtime/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.qvtd.debug.ui/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.debug.ui/META-INF/MANIFEST.MF16
-rw-r--r--plugins/org.eclipse.qvtd.debug/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.debug/META-INF/MANIFEST.MF12
-rw-r--r--plugins/org.eclipse.qvtd.master/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.pivot.qvtbase/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.pivot.qvtbase/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.qvtd.pivot.qvtcore/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.pivot.qvtcore/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.qvtd.pivot.qvtimperative/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.pivot.qvtimperative/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.qvtd.pivot.qvtrelation/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.pivot.qvtrelation/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.qvtd.pivot.qvtschedule/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.pivot.qvtschedule/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.qvtd.pivot.qvttemplate/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.pivot.qvttemplate/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.qvtd.runtime/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.runtime/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.qvtd.text/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.text/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.qvtd.umlx.design/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.umlx.design/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.qvtd.umlx.ui/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.umlx.ui/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.qvtd.umlx/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.umlx/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.qvtd.xml.design/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.xml.design/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.qvtd.xml/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.xml/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtbase.ui/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtbase.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtbase/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtbase/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtcore.ui/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtcore.ui/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtcore/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtcore/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtimperative.ui/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtimperative.ui/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtimperative/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtimperative/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtrelation.ui/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtrelation.ui/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtrelation/.polyglot.build.properties13
-rw-r--r--plugins/org.eclipse.qvtd.xtext.qvtrelation/META-INF/MANIFEST.MF6
-rw-r--r--plugins/pom.xml4
-rw-r--r--releng/org.eclipse.qvtd.build/META-INF/MANIFEST.MF22
-rw-r--r--releng/org.eclipse.qvtd.releng.build-site/feature.xml2
-rw-r--r--releng/org.eclipse.qvtd.releng.build-site/pom.xml4
-rw-r--r--releng/org.eclipse.qvtd.releng.tycho/README.txt22
-rw-r--r--releng/org.eclipse.qvtd.releng.tycho/pom.xml4
-rw-r--r--releng/pom.xml4
-rw-r--r--tests/org.eclipse.qvtd.all.tests/META-INF/MANIFEST.MF14
-rw-r--r--tests/org.eclipse.qvtd.all.tests/pom.xml4
-rw-r--r--tests/org.eclipse.qvtd.atl.tests/META-INF/MANIFEST.MF8
-rw-r--r--tests/org.eclipse.qvtd.atl.tests/pom.xml4
-rw-r--r--tests/org.eclipse.qvtd.compiler.tests/META-INF/MANIFEST.MF8
-rw-r--r--tests/org.eclipse.qvtd.compiler.tests/pom.xml4
-rw-r--r--tests/org.eclipse.qvtd.cs2as.compiler.tests/META-INF/MANIFEST.MF8
-rw-r--r--tests/org.eclipse.qvtd.cs2as.compiler.tests/pom.xml4
-rw-r--r--tests/org.eclipse.qvtd.doc.bigmde2016.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/org.eclipse.qvtd.doc.bigmde2016.tests/pom.xml4
-rw-r--r--tests/org.eclipse.qvtd.doc.exe2016.tests/META-INF/MANIFEST.MF2
-rw-r--r--tests/org.eclipse.qvtd.doc.exe2016.tests/pom.xml4
-rw-r--r--tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/META-INF/MANIFEST.MF6
-rw-r--r--tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/pom.xml4
-rw-r--r--tests/org.eclipse.qvtd.umlx.tests/META-INF/MANIFEST.MF12
-rw-r--r--tests/org.eclipse.qvtd.umlx.tests/pom.xml4
-rw-r--r--tests/org.eclipse.qvtd.xtext.qvtbase.tests/META-INF/MANIFEST.MF10
-rw-r--r--tests/org.eclipse.qvtd.xtext.qvtbase.tests/pom.xml4
-rw-r--r--tests/org.eclipse.qvtd.xtext.qvtcore.tests/META-INF/MANIFEST.MF12
-rw-r--r--tests/org.eclipse.qvtd.xtext.qvtcore.tests/pom.xml4
-rw-r--r--tests/org.eclipse.qvtd.xtext.qvtimperative.tests/META-INF/MANIFEST.MF12
-rw-r--r--tests/org.eclipse.qvtd.xtext.qvtimperative.tests/pom.xml4
-rw-r--r--tests/org.eclipse.qvtd.xtext.qvtrelation.tests/META-INF/MANIFEST.MF26
-rw-r--r--tests/org.eclipse.qvtd.xtext.qvtrelation.tests/pom.xml4
-rw-r--r--tests/pom.xml4
128 files changed, 798 insertions, 233 deletions
diff --git a/doc/org.eclipse.qvtd.doc.miniocl.build/META-INF/MANIFEST.MF b/doc/org.eclipse.qvtd.doc.miniocl.build/META-INF/MANIFEST.MF
index 84005438e..bafe3298e 100644
--- a/doc/org.eclipse.qvtd.doc.miniocl.build/META-INF/MANIFEST.MF
+++ b/doc/org.eclipse.qvtd.doc.miniocl.build/META-INF/MANIFEST.MF
@@ -4,11 +4,11 @@ Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-SymbolicName: org.eclipse.qvtd.doc.miniocl.build
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.emf.mwe2.launch;bundle-version="[2.9.0,3.0.0)",
org.eclipse.ocl.examples.build;bundle-version="[2.7.0,2.8.0)",
- org.eclipse.qvtd.cs2as.build;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.doc.minioclcs.xtext;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.doc.miniocl;bundle-version="[0.17.0,1.0.0)"
+ org.eclipse.qvtd.cs2as.build;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.doc.minioclcs.xtext;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.doc.miniocl;bundle-version="[0.18.0,1.0.0)"
Automatic-Module-Name: org.eclipse.qvtd.doc.miniocl.build
diff --git a/doc/org.eclipse.qvtd.doc.miniocl/.polyglot.build.properties b/doc/org.eclipse.qvtd.doc.miniocl/.polyglot.build.properties
new file mode 100644
index 000000000..235d146a8
--- /dev/null
+++ b/doc/org.eclipse.qvtd.doc.miniocl/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-doc</groupId>
+ <artifactId>org.eclipse.qvtd.doc-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.doc.miniocl</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/doc/org.eclipse.qvtd.doc.miniocl/META-INF/MANIFEST.MF b/doc/org.eclipse.qvtd.doc.miniocl/META-INF/MANIFEST.MF
index bbf25ab1d..70f7442fd 100644
--- a/doc/org.eclipse.qvtd.doc.miniocl/META-INF/MANIFEST.MF
+++ b/doc/org.eclipse.qvtd.doc.miniocl/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-SymbolicName: org.eclipse.qvtd.doc.miniocl;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Require-Bundle: org.eclipse.ocl.pivot;bundle-version="[1.7.0,1.8.0)"
Export-Package: org.eclipse.qvtd.doc.miniocl,
org.eclipse.qvtd.doc.miniocl.impl,
diff --git a/doc/org.eclipse.qvtd.doc.minioclcs.xtext.ide/META-INF/MANIFEST.MF b/doc/org.eclipse.qvtd.doc.minioclcs.xtext.ide/META-INF/MANIFEST.MF
index c9d1cecd4..59277b3e1 100644
--- a/doc/org.eclipse.qvtd.doc.minioclcs.xtext.ide/META-INF/MANIFEST.MF
+++ b/doc/org.eclipse.qvtd.doc.minioclcs.xtext.ide/META-INF/MANIFEST.MF
@@ -3,10 +3,10 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-SymbolicName: org.eclipse.qvtd.doc.minioclcs.xtext.ide; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.qvtd.doc.minioclcs.xtext;bundle-version="[0.17.0,1.0.0)",
+Require-Bundle: org.eclipse.qvtd.doc.minioclcs.xtext;bundle-version="[0.18.0,1.0.0)",
org.eclipse.xtext.ide;bundle-version="[2.9.0,3.0.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.qvtd.doc.ide.contentassist.antlr.internal,
diff --git a/doc/org.eclipse.qvtd.doc.minioclcs.xtext.ui/META-INF/MANIFEST.MF b/doc/org.eclipse.qvtd.doc.minioclcs.xtext.ui/META-INF/MANIFEST.MF
index 619144394..a520cb50b 100644
--- a/doc/org.eclipse.qvtd.doc.minioclcs.xtext.ui/META-INF/MANIFEST.MF
+++ b/doc/org.eclipse.qvtd.doc.minioclcs.xtext.ui/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-SymbolicName: org.eclipse.qvtd.doc.minioclcs.xtext.ui; singleton:=true
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.compare;bundle-version="[3.5.0,4.0.0)",
@@ -13,9 +13,9 @@ Require-Bundle: org.eclipse.compare;bundle-version="[3.5.0,4.0.0)",
org.eclipse.xtext.ui.codetemplates.ui;bundle-version="[2.9.0,3.0.0)",
org.eclipse.xtext.ui.shared;bundle-version="[2.9.0,3.0.0)",
org.eclipse.ocl.pivot;bundle-version="[1.7.0,1.8.0)",
- org.eclipse.qvtd.doc.miniocl;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.doc.minioclcs.xtext;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.doc.minioclcs.xtext.ide;bundle-version="[0.17.0,1.0.0)"
+ org.eclipse.qvtd.doc.miniocl;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.doc.minioclcs.xtext;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.doc.minioclcs.xtext.ide;bundle-version="[0.18.0,1.0.0)"
Import-Package: org.apache.log4j
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.qvtd.doc.minioclcs.xtext.ui.internal,
diff --git a/doc/org.eclipse.qvtd.doc.minioclcs.xtext/.polyglot.build.properties b/doc/org.eclipse.qvtd.doc.minioclcs.xtext/.polyglot.build.properties
new file mode 100644
index 000000000..79a760cbf
--- /dev/null
+++ b/doc/org.eclipse.qvtd.doc.minioclcs.xtext/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-doc</groupId>
+ <artifactId>org.eclipse.qvtd.doc-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.doc.minioclcs.xtext</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/doc/org.eclipse.qvtd.doc.minioclcs.xtext/META-INF/MANIFEST.MF b/doc/org.eclipse.qvtd.doc.minioclcs.xtext/META-INF/MANIFEST.MF
index 962e2d1d9..47f294de2 100644
--- a/doc/org.eclipse.qvtd.doc.minioclcs.xtext/META-INF/MANIFEST.MF
+++ b/doc/org.eclipse.qvtd.doc.minioclcs.xtext/META-INF/MANIFEST.MF
@@ -3,12 +3,12 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-SymbolicName: org.eclipse.qvtd.doc.minioclcs.xtext; singleton:=true
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.xtext;bundle-version="[2.9.0,3.0.0)",
org.eclipse.ocl.pivot;bundle-version="[1.7.0,1.8.0)",
- org.eclipse.qvtd.doc.miniocl;bundle-version="[0.17.0,1.0.0)"
+ org.eclipse.qvtd.doc.miniocl;bundle-version="[0.18.0,1.0.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.qvtd.doc,
org.eclipse.qvtd.doc.generator,
diff --git a/doc/org.eclipse.qvtd.doc/.polyglot.build.properties b/doc/org.eclipse.qvtd.doc/.polyglot.build.properties
new file mode 100644
index 000000000..785fe9738
--- /dev/null
+++ b/doc/org.eclipse.qvtd.doc/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-doc</groupId>
+ <artifactId>org.eclipse.qvtd.doc-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.doc</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/doc/org.eclipse.qvtd.doc/META-INF/MANIFEST.MF b/doc/org.eclipse.qvtd.doc/META-INF/MANIFEST.MF
index 1c1752079..13bd05644 100644
--- a/doc/org.eclipse.qvtd.doc/META-INF/MANIFEST.MF
+++ b/doc/org.eclipse.qvtd.doc/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.doc;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Require-Bundle: org.eclipse.help;bundle-version="[3.5.0,4.0.0)"
diff --git a/doc/pom.xml b/doc/pom.xml
index f8ab57e04..027b93e7d 100644
--- a/doc/pom.xml
+++ b/doc/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-doc</groupId>
<artifactId>org.eclipse.qvtd.doc-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>pom</packaging>
<parent>
<groupId>org.eclipse.qvtd</groupId>
<artifactId>org.eclipse.qvtd.releng.tycho</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<relativePath>../releng/org.eclipse.qvtd.releng.tycho</relativePath>
</parent>
<modules>
diff --git a/examples/org.eclipse.qvtd.examples.qvtcore.uml2rdbms/.polyglot.build.properties b/examples/org.eclipse.qvtd.examples.qvtcore.uml2rdbms/.polyglot.build.properties
new file mode 100644
index 000000000..8045cc468
--- /dev/null
+++ b/examples/org.eclipse.qvtd.examples.qvtcore.uml2rdbms/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-examples</groupId>
+ <artifactId>org.eclipse.qvtd.examples-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.examples.qvtcore.uml2rdbms</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/examples/org.eclipse.qvtd.examples.qvtcore.uml2rdbms/META-INF/MANIFEST.MF b/examples/org.eclipse.qvtd.examples.qvtcore.uml2rdbms/META-INF/MANIFEST.MF
index 94ebd0cce..ab378dd79 100644
--- a/examples/org.eclipse.qvtd.examples.qvtcore.uml2rdbms/META-INF/MANIFEST.MF
+++ b/examples/org.eclipse.qvtd.examples.qvtcore.uml2rdbms/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.examples.qvtcore.uml2rdbms;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/examples/org.eclipse.qvtd.examples.qvtrelation.hstm2fstm/.polyglot.build.properties b/examples/org.eclipse.qvtd.examples.qvtrelation.hstm2fstm/.polyglot.build.properties
new file mode 100644
index 000000000..d83282bd4
--- /dev/null
+++ b/examples/org.eclipse.qvtd.examples.qvtrelation.hstm2fstm/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-examples</groupId>
+ <artifactId>org.eclipse.qvtd.examples-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.examples.qvtrelation.hstm2fstm</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/examples/org.eclipse.qvtd.examples.qvtrelation.hstm2fstm/META-INF/MANIFEST.MF b/examples/org.eclipse.qvtd.examples.qvtrelation.hstm2fstm/META-INF/MANIFEST.MF
index 24709c7e2..3a0900149 100644
--- a/examples/org.eclipse.qvtd.examples.qvtrelation.hstm2fstm/META-INF/MANIFEST.MF
+++ b/examples/org.eclipse.qvtd.examples.qvtrelation.hstm2fstm/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.examples.qvtrelation.hstm2fstm;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/examples/org.eclipse.qvtd.examples.qvtrelation.modelmorf/.polyglot.build.properties b/examples/org.eclipse.qvtd.examples.qvtrelation.modelmorf/.polyglot.build.properties
new file mode 100644
index 000000000..7e7d3e15e
--- /dev/null
+++ b/examples/org.eclipse.qvtd.examples.qvtrelation.modelmorf/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-examples</groupId>
+ <artifactId>org.eclipse.qvtd.examples-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.examples.qvtrelation.modelmorf</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/examples/org.eclipse.qvtd.examples.qvtrelation.modelmorf/META-INF/MANIFEST.MF b/examples/org.eclipse.qvtd.examples.qvtrelation.modelmorf/META-INF/MANIFEST.MF
index bcc2bc9f4..9e028a5cf 100644
--- a/examples/org.eclipse.qvtd.examples.qvtrelation.modelmorf/META-INF/MANIFEST.MF
+++ b/examples/org.eclipse.qvtd.examples.qvtrelation.modelmorf/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.examples.qvtrelation.modelmorf
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Export-Package: org.eclipse.qvtd.examples.qvtrelation.modelmorf
Bundle-Vendor: %providerName
Bundle-Localization: plugin
diff --git a/examples/org.eclipse.qvtd.examples.qvtrelation.reltocore/.polyglot.build.properties b/examples/org.eclipse.qvtd.examples.qvtrelation.reltocore/.polyglot.build.properties
new file mode 100644
index 000000000..5c434046f
--- /dev/null
+++ b/examples/org.eclipse.qvtd.examples.qvtrelation.reltocore/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-examples</groupId>
+ <artifactId>org.eclipse.qvtd.examples-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.examples.qvtrelation.reltocore</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/examples/org.eclipse.qvtd.examples.qvtrelation.reltocore/META-INF/MANIFEST.MF b/examples/org.eclipse.qvtd.examples.qvtrelation.reltocore/META-INF/MANIFEST.MF
index 14b40b18e..42a4572dc 100644
--- a/examples/org.eclipse.qvtd.examples.qvtrelation.reltocore/META-INF/MANIFEST.MF
+++ b/examples/org.eclipse.qvtd.examples.qvtrelation.reltocore/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.examples.qvtrelation.reltocore;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Export-Package: org.eclipse.qvtd.examples.qvtrelation.reltocore
Bundle-Vendor: %providerName
Bundle-Localization: plugin
diff --git a/examples/org.eclipse.qvtd.examples.umlx.hstm2fstm/.polyglot.build.properties b/examples/org.eclipse.qvtd.examples.umlx.hstm2fstm/.polyglot.build.properties
new file mode 100644
index 000000000..daab9a015
--- /dev/null
+++ b/examples/org.eclipse.qvtd.examples.umlx.hstm2fstm/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-examples</groupId>
+ <artifactId>org.eclipse.qvtd.examples-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.examples.umlx.hstm2fstm</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/examples/org.eclipse.qvtd.examples.umlx.hstm2fstm/META-INF/MANIFEST.MF b/examples/org.eclipse.qvtd.examples.umlx.hstm2fstm/META-INF/MANIFEST.MF
index bdba921c9..c2d41e17d 100644
--- a/examples/org.eclipse.qvtd.examples.umlx.hstm2fstm/META-INF/MANIFEST.MF
+++ b/examples/org.eclipse.qvtd.examples.umlx.hstm2fstm/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.examples.umlx.hstm2fstm;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/examples/org.eclipse.qvtd.examples/META-INF/MANIFEST.MF b/examples/org.eclipse.qvtd.examples/META-INF/MANIFEST.MF
index 11dac0f6a..98c692809 100644
--- a/examples/org.eclipse.qvtd.examples/META-INF/MANIFEST.MF
+++ b/examples/org.eclipse.qvtd.examples/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.examples;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-Localization: plugin
Bundle-Activator: org.eclipse.qvtd.examples.QVTDeclarativeExamplesPlugin
Require-Bundle: org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
diff --git a/examples/org.eclipse.qvtd.examples/pom.xml b/examples/org.eclipse.qvtd.examples/pom.xml
index 1eb7fa69e..09a0a5a8a 100644
--- a/examples/org.eclipse.qvtd.examples/pom.xml
+++ b/examples/org.eclipse.qvtd.examples/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd</groupId>
<artifactId>org.eclipse.qvtd.examples</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<parent>
<groupId>org.eclipse.qvtd-examples</groupId>
<artifactId>org.eclipse.qvtd.examples-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
</parent>
<build>
<plugins>
diff --git a/examples/pom.xml b/examples/pom.xml
index 72a9776b4..4aba5732d 100644
--- a/examples/pom.xml
+++ b/examples/pom.xml
@@ -6,12 +6,12 @@
<parent>
<groupId>org.eclipse.qvtd</groupId>
<artifactId>org.eclipse.qvtd.releng.tycho</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<relativePath>../releng/org.eclipse.qvtd.releng.tycho</relativePath>
</parent>
<groupId>org.eclipse.qvtd-examples</groupId>
<artifactId>org.eclipse.qvtd.examples-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>pom</packaging>
<modules>
diff --git a/features/org.eclipse.qvtd.atl-feature/.polyglot.build.properties b/features/org.eclipse.qvtd.atl-feature/.polyglot.build.properties
new file mode 100644
index 000000000..185f41358
--- /dev/null
+++ b/features/org.eclipse.qvtd.atl-feature/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-features</groupId>
+ <artifactId>org.eclipse.qvtd.features-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.atl</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-feature</packaging>
+</project>
diff --git a/features/org.eclipse.qvtd.atl-feature/feature.xml b/features/org.eclipse.qvtd.atl-feature/feature.xml
index a2ba55642..79d0c327f 100644
--- a/features/org.eclipse.qvtd.atl-feature/feature.xml
+++ b/features/org.eclipse.qvtd.atl-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.qvtd.atl"
label="%featureName"
- version="0.17.0.qualifier"
+ version="0.18.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.qvtd.atl"
license-feature="org.eclipse.license"
diff --git a/features/org.eclipse.qvtd.doc-feature/.polyglot.build.properties b/features/org.eclipse.qvtd.doc-feature/.polyglot.build.properties
new file mode 100644
index 000000000..919efc8ca
--- /dev/null
+++ b/features/org.eclipse.qvtd.doc-feature/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-features</groupId>
+ <artifactId>org.eclipse.qvtd.features-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.doc</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-feature</packaging>
+</project>
diff --git a/features/org.eclipse.qvtd.doc-feature/feature.xml b/features/org.eclipse.qvtd.doc-feature/feature.xml
index beb02d50d..b52ac2643 100644
--- a/features/org.eclipse.qvtd.doc-feature/feature.xml
+++ b/features/org.eclipse.qvtd.doc-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.qvtd.doc"
label="%featureName"
- version="0.17.0.qualifier"
+ version="0.18.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.qvtd.doc"
license-feature="org.eclipse.license"
diff --git a/features/org.eclipse.qvtd.examples-feature/.polyglot.build.properties b/features/org.eclipse.qvtd.examples-feature/.polyglot.build.properties
new file mode 100644
index 000000000..a5c9bd677
--- /dev/null
+++ b/features/org.eclipse.qvtd.examples-feature/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-features</groupId>
+ <artifactId>org.eclipse.qvtd.features-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.examples</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-feature</packaging>
+</project>
diff --git a/features/org.eclipse.qvtd.examples-feature/feature.xml b/features/org.eclipse.qvtd.examples-feature/feature.xml
index 8ce138c60..10949479d 100644
--- a/features/org.eclipse.qvtd.examples-feature/feature.xml
+++ b/features/org.eclipse.qvtd.examples-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.qvtd.examples"
label="%featureName"
- version="0.17.0.qualifier"
+ version="0.18.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.license"
license-feature-version="0.0.0">
diff --git a/features/org.eclipse.qvtd.master-feature/.polyglot.build.properties b/features/org.eclipse.qvtd.master-feature/.polyglot.build.properties
new file mode 100644
index 000000000..ab88ad211
--- /dev/null
+++ b/features/org.eclipse.qvtd.master-feature/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-features</groupId>
+ <artifactId>org.eclipse.qvtd.features-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.master</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-feature</packaging>
+</project>
diff --git a/features/org.eclipse.qvtd.master-feature/feature.xml b/features/org.eclipse.qvtd.master-feature/feature.xml
index 92953f0f6..d84fe6d49 100644
--- a/features/org.eclipse.qvtd.master-feature/feature.xml
+++ b/features/org.eclipse.qvtd.master-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.qvtd.master"
label="%featureName"
- version="0.17.0.qualifier"
+ version="0.18.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.qvtd.master"
license-feature="org.eclipse.license"
diff --git a/features/org.eclipse.qvtd.tests-feature/.polyglot.build.properties b/features/org.eclipse.qvtd.tests-feature/.polyglot.build.properties
new file mode 100644
index 000000000..a0cc45d75
--- /dev/null
+++ b/features/org.eclipse.qvtd.tests-feature/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-features</groupId>
+ <artifactId>org.eclipse.qvtd.features-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.tests</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-feature</packaging>
+</project>
diff --git a/features/org.eclipse.qvtd.tests-feature/feature.xml b/features/org.eclipse.qvtd.tests-feature/feature.xml
index 68eca9e65..5cdeba995 100644
--- a/features/org.eclipse.qvtd.tests-feature/feature.xml
+++ b/features/org.eclipse.qvtd.tests-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.qvtd.tests"
label="%featureName"
- version="0.17.0.qualifier"
+ version="0.18.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.qvtd.all.tests"
license-feature="org.eclipse.license"
diff --git a/features/org.eclipse.qvtd.umlx-feature/.polyglot.build.properties b/features/org.eclipse.qvtd.umlx-feature/.polyglot.build.properties
new file mode 100644
index 000000000..d57ee9e2f
--- /dev/null
+++ b/features/org.eclipse.qvtd.umlx-feature/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd-features</groupId>
+ <artifactId>org.eclipse.qvtd.features-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.umlx</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-feature</packaging>
+</project>
diff --git a/features/org.eclipse.qvtd.umlx-feature/feature.xml b/features/org.eclipse.qvtd.umlx-feature/feature.xml
index fb9a3c543..077581c70 100644
--- a/features/org.eclipse.qvtd.umlx-feature/feature.xml
+++ b/features/org.eclipse.qvtd.umlx-feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.qvtd.umlx"
label="%featureName"
- version="0.17.0.qualifier"
+ version="0.18.0.qualifier"
provider-name="%providerName"
plugin="org.eclipse.qvtd.umlx.design"
license-feature="org.eclipse.license"
diff --git a/features/pom.xml b/features/pom.xml
index fffeb068e..07c40138c 100644
--- a/features/pom.xml
+++ b/features/pom.xml
@@ -6,12 +6,12 @@
<parent>
<groupId>org.eclipse.qvtd</groupId>
<artifactId>org.eclipse.qvtd.releng.tycho</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<relativePath>../releng/org.eclipse.qvtd.releng.tycho</relativePath>
</parent>
<groupId>org.eclipse.qvtd-features</groupId>
<artifactId>org.eclipse.qvtd.features-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>pom</packaging>
<modules>
diff --git a/plugins/org.eclipse.qvt/.polyglot.build.properties b/plugins/org.eclipse.qvt/.polyglot.build.properties
new file mode 100644
index 000000000..1a27d19bc
--- /dev/null
+++ b/plugins/org.eclipse.qvt/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvt</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvt/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvt/META-INF/MANIFEST.MF
index 1af94ff17..f4b239792 100644
--- a/plugins/org.eclipse.qvt/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvt/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvt;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/plugins/org.eclipse.qvtd.atl/.polyglot.build.properties b/plugins/org.eclipse.qvtd.atl/.polyglot.build.properties
new file mode 100644
index 000000000..30f9281f9
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.atl/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.atl</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.atl/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.atl/META-INF/MANIFEST.MF
index 3ad66e6ce..ea82b2856 100644
--- a/plugins/org.eclipse.qvtd.atl/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.atl/META-INF/MANIFEST.MF
@@ -3,12 +3,12 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-SymbolicName: org.eclipse.qvtd.atl;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Localization: plugin
Require-Bundle: org.eclipse.m2m.atl.common;bundle-version="[4.0.0,5.0.0)";visibility:=reexport,
- org.eclipse.qvtd.pivot.qvtrelation;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.runtime;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.pivot.qvtrelation;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.runtime;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Export-Package: org.eclipse.qvtd.atl.atl2qvtr,
org.eclipse.qvtd.atl.atl2qvtr.trace_ATL2QVTr,
org.eclipse.qvtd.atl.atl2qvtr.trace_ATL2QVTr.impl,
diff --git a/plugins/org.eclipse.qvtd.codegen/.polyglot.build.properties b/plugins/org.eclipse.qvtd.codegen/.polyglot.build.properties
new file mode 100644
index 000000000..b4de68a6b
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.codegen/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.codegen</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.codegen/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.codegen/META-INF/MANIFEST.MF
index 27eb12d58..f38b633e8 100644
--- a/plugins/org.eclipse.qvtd.codegen/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.codegen/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.codegen;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -10,7 +10,7 @@ Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.objectweb.asm;bundle-version="[5.0.0,8.0.0)",
org.eclipse.ocl.examples.codegen;bundle-version="[2.7.0,2.8.0)";visibility:=reexport,
- org.eclipse.qvtd.pivot.qvtimperative;bundle-version="[0.17.0,1.0.0)"
+ org.eclipse.qvtd.pivot.qvtimperative;bundle-version="[0.18.0,1.0.0)"
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.qvtd.codegen.qvti,
org.eclipse.qvtd.codegen.qvti.analyzer,
diff --git a/plugins/org.eclipse.qvtd.compiler/.polyglot.build.properties b/plugins/org.eclipse.qvtd.compiler/.polyglot.build.properties
new file mode 100644
index 000000000..a44fb2af8
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.compiler/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.compiler</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.compiler/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.compiler/META-INF/MANIFEST.MF
index c521ee0f2..b1a7959da 100644
--- a/plugins/org.eclipse.qvtd.compiler/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.compiler/META-INF/MANIFEST.MF
@@ -2,17 +2,17 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.compiler;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Require-Bundle: org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.qvtd.pivot.qvtcore;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.pivot.qvtimperative;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.pivot.qvtrelation;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.pivot.qvtschedule;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.codegen;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.pivot.qvtcore;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.pivot.qvtimperative;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.pivot.qvtrelation;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.pivot.qvtschedule;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.codegen;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
org.eclipse.emf.codegen.ecore;bundle-version="[2.14.0,3.0.0)",
org.eclipse.emf.importer.ecore;bundle-version="[2.6.0,3.0.0)",
org.eclipse.emf.importer;bundle-version="[2.7.0,3.0.0)"
diff --git a/plugins/org.eclipse.qvtd.cs2as.build/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.cs2as.build/META-INF/MANIFEST.MF
index 219817bac..dceeec108 100644
--- a/plugins/org.eclipse.qvtd.cs2as.build/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.cs2as.build/META-INF/MANIFEST.MF
@@ -2,16 +2,16 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.cs2as.build;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Export-Package: org.eclipse.qvtd.cs2as.build.mwe
Require-Bundle: org.eclipse.emf.codegen.ecore;bundle-version="[2.7.0,3.0.0)",
org.eclipse.emf.mwe.core;bundle-version="[1.3.10,2.0.0)",
org.eclipse.emf.mwe.utils;bundle-version="[1.3.10,2.0.0)",
org.eclipse.ocl.pivot;bundle-version="[1.7.0,1.8.0)",
org.eclipse.ocl.examples.build;bundle-version="[2.7.0,2.8.0)",
- org.eclipse.qvtd.cs2as.compiler;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.runtime;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.compiler;bundle-version="[0.17.0,1.0.0)"
+ org.eclipse.qvtd.cs2as.compiler;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.runtime;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.compiler;bundle-version="[0.18.0,1.0.0)"
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: %providerName
diff --git a/plugins/org.eclipse.qvtd.cs2as.compiler/.polyglot.build.properties b/plugins/org.eclipse.qvtd.cs2as.compiler/.polyglot.build.properties
new file mode 100644
index 000000000..c93d536c9
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.cs2as.compiler/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.cs2as.compiler</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.cs2as.compiler/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.cs2as.compiler/META-INF/MANIFEST.MF
index b45207b92..6a936dfeb 100644
--- a/plugins/org.eclipse.qvtd.cs2as.compiler/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.cs2as.compiler/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.cs2as.compiler;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -12,8 +12,8 @@ Export-Package: org.eclipse.qvtd.cs2as.compiler,
org.eclipse.qvtd.cs2as.compiler.cgmodel.util,
org.eclipse.qvtd.cs2as.compiler.internal;x-friends:="org.eclipse.qvtd.cs2as.compiler.tests,org.eclipse.qvtd.cs2as.build"
Require-Bundle: org.eclipse.ocl.xtext.completeocl;bundle-version="[1.7.0,1.8.0)",
- org.eclipse.qvtd.xtext.qvtimperative;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.compiler;bundle-version="[0.17.0,1.0.0)"
+ org.eclipse.qvtd.xtext.qvtimperative;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.compiler;bundle-version="[0.18.0,1.0.0)"
Bundle-ActivationPolicy: lazy
Import-Package: org.apache.commons.logging,
org.apache.log4j
diff --git a/plugins/org.eclipse.qvtd.cs2as.xtext.generator/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.cs2as.xtext.generator/META-INF/MANIFEST.MF
index 43660f988..53b95c5ed 100644
--- a/plugins/org.eclipse.qvtd.cs2as.xtext.generator/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.cs2as.xtext.generator/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-SymbolicName: org.eclipse.qvtd.cs2as.xtext.generator
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Require-Bundle: org.eclipse.xtext.generator;bundle-version="[2.8.1,3.0.0)",
com.google.inject;resolution:=optional,
org.eclipse.xtext;bundle-version="2.10.0"
diff --git a/plugins/org.eclipse.qvtd.cs2as.xtext.runtime/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.cs2as.xtext.runtime/META-INF/MANIFEST.MF
index 799c89538..33220e966 100644
--- a/plugins/org.eclipse.qvtd.cs2as.xtext.runtime/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.cs2as.xtext.runtime/META-INF/MANIFEST.MF
@@ -4,10 +4,10 @@ Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-SymbolicName: org.eclipse.qvtd.cs2as.xtext.runtime
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Export-Package: org.eclipse.qvtd.cs2as.xtext.runtime
Require-Bundle: org.eclipse.xtext;bundle-version="[2.8.1,3.0.0)",
org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.qvtd.runtime;bundle-version="[0.17.0,1.0.0)"
+ org.eclipse.qvtd.runtime;bundle-version="[0.18.0,1.0.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Automatic-Module-Name: org.eclipse.qvtd.cs2as.xtext.runtime
diff --git a/plugins/org.eclipse.qvtd.debug.ui/.polyglot.build.properties b/plugins/org.eclipse.qvtd.debug.ui/.polyglot.build.properties
new file mode 100644
index 000000000..154d52236
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.debug.ui/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.debug.ui</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.debug.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.debug.ui/META-INF/MANIFEST.MF
index 2e0352b27..976cbce69 100644
--- a/plugins/org.eclipse.qvtd.debug.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.debug.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.debug.ui;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -14,13 +14,13 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.emf.common.ui;bundle-version="[2.7.0,3.0.0)",
org.eclipse.ocl.examples.codegen;bundle-version="[2.7.0,2.8.0)",
org.eclipse.ocl.examples.debug.vm.ui;bundle-version="[2.7.0,2.8.0)",
- org.eclipse.qvtd.debug;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.codegen;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.compiler;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtcore;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtimperative;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtimperative.ui;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtrelation;bundle-version="[0.17.0,1.0.0)"
+ org.eclipse.qvtd.debug;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.codegen;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.compiler;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtcore;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtimperative;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtimperative.ui;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtrelation;bundle-version="[0.18.0,1.0.0)"
Bundle-Activator: org.eclipse.qvtd.debug.ui.QVTdDebugUIPlugin
Bundle-ActivationPolicy: lazy
Import-Package: org.apache.log4j,
diff --git a/plugins/org.eclipse.qvtd.debug/.polyglot.build.properties b/plugins/org.eclipse.qvtd.debug/.polyglot.build.properties
new file mode 100644
index 000000000..bf87f0ad8
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.debug/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.debug</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.debug/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.debug/META-INF/MANIFEST.MF
index cf5083439..1679c12d4 100644
--- a/plugins/org.eclipse.qvtd.debug/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.debug/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.debug;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -11,11 +11,11 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.debug.core;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ocl.examples.debug;bundle-version="[2.7.0,2.8.0)",
org.eclipse.ocl.examples.debug.vm;bundle-version="[2.7.0,2.8.0)",
- org.eclipse.qvtd.compiler;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.codegen;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.xtext.qvtcore;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtimperative;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtrelation;bundle-version="[0.17.0,1.0.0)"
+ org.eclipse.qvtd.compiler;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.codegen;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.xtext.qvtcore;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtimperative;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtrelation;bundle-version="[0.18.0,1.0.0)"
Export-Package: org.eclipse.qvtd.debug,
org.eclipse.qvtd.debug.core,
org.eclipse.qvtd.debug.evaluator,
diff --git a/plugins/org.eclipse.qvtd.master/.polyglot.build.properties b/plugins/org.eclipse.qvtd.master/.polyglot.build.properties
new file mode 100644
index 000000000..7f08d5aed
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.master/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.master</artifactId>
+ <version>0.15.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.pivot.qvtbase/.polyglot.build.properties b/plugins/org.eclipse.qvtd.pivot.qvtbase/.polyglot.build.properties
new file mode 100644
index 000000000..608c94449
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.pivot.qvtbase/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.pivot.qvtbase</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.pivot.qvtbase/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.pivot.qvtbase/META-INF/MANIFEST.MF
index d039bd213..8d1e463a5 100644
--- a/plugins/org.eclipse.qvtd.pivot.qvtbase/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.pivot.qvtbase/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.pivot.qvtbase;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -18,7 +18,7 @@ Export-Package: org.eclipse.qvtd.pivot.qvtbase,
Require-Bundle: org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ocl.pivot;bundle-version="[1.7.0,1.8.0)";visibility:=reexport,
- org.eclipse.qvtd.runtime;bundle-version="[0.17.0,1.0.0)"
+ org.eclipse.qvtd.runtime;bundle-version="[0.18.0,1.0.0)"
Bundle-ActivationPolicy: lazy
Import-Package: com.google.common.collect,
com.google.inject
diff --git a/plugins/org.eclipse.qvtd.pivot.qvtcore/.polyglot.build.properties b/plugins/org.eclipse.qvtd.pivot.qvtcore/.polyglot.build.properties
new file mode 100644
index 000000000..cc2ecf606
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.pivot.qvtcore/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.pivot.qvtcore</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.pivot.qvtcore/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.pivot.qvtcore/META-INF/MANIFEST.MF
index e485ba7a4..774edb851 100644
--- a/plugins/org.eclipse.qvtd.pivot.qvtcore/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.pivot.qvtcore/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.pivot.qvtcore;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -16,7 +16,7 @@ Export-Package: org.eclipse.qvtd.pivot.qvtcore,
org.eclipse.qvtd.pivot.qvtcore.utilities
Require-Bundle: org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.qvtd.pivot.qvtschedule;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.pivot.qvtschedule;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
Import-Package: com.google.common.collect,
com.google.inject
diff --git a/plugins/org.eclipse.qvtd.pivot.qvtimperative/.polyglot.build.properties b/plugins/org.eclipse.qvtd.pivot.qvtimperative/.polyglot.build.properties
new file mode 100644
index 000000000..5fa134bdb
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.pivot.qvtimperative/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.pivot.qvtimperative</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.pivot.qvtimperative/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.pivot.qvtimperative/META-INF/MANIFEST.MF
index 627938ee2..787c29f59 100644
--- a/plugins/org.eclipse.qvtd.pivot.qvtimperative/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.pivot.qvtimperative/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.pivot.qvtimperative;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -20,8 +20,8 @@ Export-Package: org.eclipse.qvtd.pivot.qvtimperative,
org.eclipse.qvtd.pivot.qvtimperative.utilities
Require-Bundle: org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.qvtd.pivot.qvtschedule;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.runtime;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.pivot.qvtschedule;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.runtime;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
Import-Package: com.google.inject,
com.google.common.collect,
diff --git a/plugins/org.eclipse.qvtd.pivot.qvtrelation/.polyglot.build.properties b/plugins/org.eclipse.qvtd.pivot.qvtrelation/.polyglot.build.properties
new file mode 100644
index 000000000..133bb9271
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.pivot.qvtrelation/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.pivot.qvtrelation</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.pivot.qvtrelation/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.pivot.qvtrelation/META-INF/MANIFEST.MF
index 6cbe1e3a2..2475b6e27 100644
--- a/plugins/org.eclipse.qvtd.pivot.qvtrelation/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.pivot.qvtrelation/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.pivot.qvtrelation;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -15,7 +15,7 @@ Export-Package: org.eclipse.qvtd.pivot.qvtrelation,
org.eclipse.qvtd.pivot.qvtrelation.utilities
Require-Bundle: org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.qvtd.pivot.qvttemplate;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.pivot.qvttemplate;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
Import-Package: com.google.common.collect,
com.google.inject
diff --git a/plugins/org.eclipse.qvtd.pivot.qvtschedule/.polyglot.build.properties b/plugins/org.eclipse.qvtd.pivot.qvtschedule/.polyglot.build.properties
new file mode 100644
index 000000000..e93aeaec6
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.pivot.qvtschedule/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.pivot.qvtschedule</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.pivot.qvtschedule/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.pivot.qvtschedule/META-INF/MANIFEST.MF
index 0457d72e7..265cf6e19 100644
--- a/plugins/org.eclipse.qvtd.pivot.qvtschedule/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.pivot.qvtschedule/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.pivot.qvtschedule;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -12,7 +12,7 @@ Export-Package: org.eclipse.qvtd.pivot.qvtschedule,
org.eclipse.qvtd.pivot.qvtschedule.util,
org.eclipse.qvtd.pivot.qvtschedule.utilities
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.qvtd.pivot.qvtbase;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.pivot.qvtbase;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
Import-Package: com.google.common.base,
com.google.common.collect,
diff --git a/plugins/org.eclipse.qvtd.pivot.qvttemplate/.polyglot.build.properties b/plugins/org.eclipse.qvtd.pivot.qvttemplate/.polyglot.build.properties
new file mode 100644
index 000000000..4ece66acb
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.pivot.qvttemplate/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.pivot.qvttemplate</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.pivot.qvttemplate/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.pivot.qvttemplate/META-INF/MANIFEST.MF
index 7c60e199a..ba0a1c235 100644
--- a/plugins/org.eclipse.qvtd.pivot.qvttemplate/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.pivot.qvttemplate/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.pivot.qvttemplate;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -14,7 +14,7 @@ Export-Package: org.eclipse.qvtd.pivot.qvttemplate,
org.eclipse.qvtd.pivot.qvttemplate.util,
org.eclipse.qvtd.pivot.qvttemplate.utilities
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.qvtd.pivot.qvtbase;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.pivot.qvtbase;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
Import-Package: com.google.inject
Automatic-Module-Name: org.eclipse.qvtd.pivot.qvttemplate
diff --git a/plugins/org.eclipse.qvtd.runtime/.polyglot.build.properties b/plugins/org.eclipse.qvtd.runtime/.polyglot.build.properties
new file mode 100644
index 000000000..54dc86de5
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.runtime/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.runtime</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.runtime/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.runtime/META-INF/MANIFEST.MF
index e7a2f813d..883e40a2d 100644
--- a/plugins/org.eclipse.qvtd.runtime/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.runtime/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.runtime;singleton:=true
Bundle-Vendor: %providerName
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Localization: plugin
Require-Bundle: org.eclipse.osgi;bundle-version="[3.5.0,4.0.0)",
diff --git a/plugins/org.eclipse.qvtd.text/.polyglot.build.properties b/plugins/org.eclipse.qvtd.text/.polyglot.build.properties
new file mode 100644
index 000000000..adf12672d
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.text/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.text</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.text/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.text/META-INF/MANIFEST.MF
index 7ed956345..ac5e4643c 100644
--- a/plugins/org.eclipse.qvtd.text/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.text/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.text;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.qvtd.umlx.design/.polyglot.build.properties b/plugins/org.eclipse.qvtd.umlx.design/.polyglot.build.properties
new file mode 100644
index 000000000..65dce57dc
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.umlx.design/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.umlx.design</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.umlx.design/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.umlx.design/META-INF/MANIFEST.MF
index 03a6748d0..bbac3e414 100644
--- a/plugins/org.eclipse.qvtd.umlx.design/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.umlx.design/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.umlx.design;singleton:=true
-Bundle-Version: 0.16.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-Activator: org.eclipse.qvtd.umlx.design.Activator
Bundle-Localization: plugin
Require-Bundle: org.eclipse.ui;bundle-version="[3.5.0,4.0.0)",
@@ -11,7 +11,7 @@ Require-Bundle: org.eclipse.ui;bundle-version="[3.5.0,4.0.0)",
org.eclipse.sirius;bundle-version="[4.0.0,7.0.0)",
org.eclipse.sirius.common.acceleo.aql;bundle-version="[4.0.0,7.0.0)",
org.eclipse.ocl.pivot;bundle-version="[1.7.0,1.8.0)",
- org.eclipse.qvtd.umlx;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.umlx;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: %providerName
diff --git a/plugins/org.eclipse.qvtd.umlx.ui/.polyglot.build.properties b/plugins/org.eclipse.qvtd.umlx.ui/.polyglot.build.properties
new file mode 100644
index 000000000..435a8331c
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.umlx.ui/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.umlx.ui</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.umlx.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.umlx.ui/META-INF/MANIFEST.MF
index b9a5f2ced..5083a25f1 100644
--- a/plugins/org.eclipse.qvtd.umlx.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.umlx.ui/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-SymbolicName: org.eclipse.qvtd.umlx.ui;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Localization: plugin
Require-Bundle: org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
@@ -11,10 +11,10 @@ Require-Bundle: org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ui.ide;bundle-version="[3.5.0,4.0.0)",
org.eclipse.xtext.ui;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
org.eclipse.xtext.ui.shared;bundle-version="[2.10.0,3.0.0)";visibility:=reexport,
- org.eclipse.qvtd.xtext.qvtcore;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.compiler;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.debug.ui;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.umlx;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.xtext.qvtcore;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.compiler;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.debug.ui;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.umlx;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Export-Package: org.eclipse.qvtd.umlx.ui.commands,
org.eclipse.qvtd.umlx.ui.launching,
org.eclipse.qvtd.umlx.ui.messages
diff --git a/plugins/org.eclipse.qvtd.umlx/.polyglot.build.properties b/plugins/org.eclipse.qvtd.umlx/.polyglot.build.properties
new file mode 100644
index 000000000..90eca53cf
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.umlx/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.umlx</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.umlx/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.umlx/META-INF/MANIFEST.MF
index 3c275ed67..38593b2d7 100644
--- a/plugins/org.eclipse.qvtd.umlx/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.umlx/META-INF/MANIFEST.MF
@@ -3,11 +3,11 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-SymbolicName: org.eclipse.qvtd.umlx; singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Require-Bundle: org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
- org.eclipse.qvtd.compiler;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtrelation;bundle-version="[0.17.0,1.0.0)"
+ org.eclipse.qvtd.compiler;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtrelation;bundle-version="[0.18.0,1.0.0)"
Export-Package: org.eclipse.qvtd.umlx,
org.eclipse.qvtd.umlx.compiler,
org.eclipse.qvtd.umlx.impl,
diff --git a/plugins/org.eclipse.qvtd.xml.design/.polyglot.build.properties b/plugins/org.eclipse.qvtd.xml.design/.polyglot.build.properties
new file mode 100644
index 000000000..99209f827
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.xml.design/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.xml.design</artifactId>
+ <version>0.17.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.xml.design/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.xml.design/META-INF/MANIFEST.MF
index d847b034b..45949f4d6 100644
--- a/plugins/org.eclipse.qvtd.xml.design/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.xml.design/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.xml.design;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-Activator: org.eclipse.qvtd.xml.design.Activator
Bundle-Localization: plugin
Require-Bundle: org.eclipse.ui,
diff --git a/plugins/org.eclipse.qvtd.xml/.polyglot.build.properties b/plugins/org.eclipse.qvtd.xml/.polyglot.build.properties
new file mode 100644
index 000000000..4ee2e7e41
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.xml/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.xml</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.xml/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.xml/META-INF/MANIFEST.MF
index 11e0736a4..05dbd92c9 100644
--- a/plugins/org.eclipse.qvtd.xml/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.xml/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.xml;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtbase.ui/.polyglot.build.properties b/plugins/org.eclipse.qvtd.xtext.qvtbase.ui/.polyglot.build.properties
new file mode 100644
index 000000000..ad591c4b5
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.xtext.qvtbase.ui/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.xtext.qvtbase.ui</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtbase.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.xtext.qvtbase.ui/META-INF/MANIFEST.MF
index 9d6698482..4ac0850b6 100644
--- a/plugins/org.eclipse.qvtd.xtext.qvtbase.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.xtext.qvtbase.ui/META-INF/MANIFEST.MF
@@ -2,14 +2,14 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.xtext.qvtbase.ui;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Localization: plugin
Bundle-Vendor: %providerName
Require-Bundle: org.eclipse.jdt.core;bundle-version="[3.5.0,4.0.0)",
org.eclipse.xtext.builder;bundle-version="[2.10.0,3.0.0)",
org.eclipse.ocl.xtext.essentialocl.ui;bundle-version="[1.7.0,1.8.0)";visibility:=reexport,
- org.eclipse.qvtd.xtext.qvtbase;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.xtext.qvtbase;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Export-Package: org.eclipse.qvtd.xtext.qvtbase.ui,
org.eclipse.qvtd.xtext.qvtbase.ui.builder,
org.eclipse.qvtd.xtext.qvtbase.ui.commands,
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtbase/.polyglot.build.properties b/plugins/org.eclipse.qvtd.xtext.qvtbase/.polyglot.build.properties
new file mode 100644
index 000000000..cc31ea56e
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.xtext.qvtbase/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.xtext.qvtbase</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtbase/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.xtext.qvtbase/META-INF/MANIFEST.MF
index e2cb33e27..12f07c1ef 100644
--- a/plugins/org.eclipse.qvtd.xtext.qvtbase/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.xtext.qvtbase/META-INF/MANIFEST.MF
@@ -4,7 +4,7 @@ Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-SymbolicName: org.eclipse.qvtd.xtext.qvtbase;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.qvtd.xtext.qvtbase.utilities.QVTbasePlugin$Implementation
@@ -13,7 +13,7 @@ Require-Bundle: org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.jdt.core;bundle-version="[3.7.0,4.0.0)",
org.eclipse.xtext;bundle-version="[2.10.0,3.0.0)",
org.eclipse.ocl.xtext.essentialocl.ui;bundle-version="[1.7.0,1.8.0)";visibility:=reexport,
- org.eclipse.qvtd.pivot.qvtbase;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.pivot.qvtbase;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Export-Package: org.eclipse.qvtd.xtext.qvtbase,
org.eclipse.qvtd.xtext.qvtbase.as2cs,
org.eclipse.qvtd.xtext.qvtbase.cs2as,
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtcore.ui/.polyglot.build.properties b/plugins/org.eclipse.qvtd.xtext.qvtcore.ui/.polyglot.build.properties
new file mode 100644
index 000000000..c1c3a9118
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.xtext.qvtcore.ui/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.xtext.qvtcore.ui</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtcore.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.xtext.qvtcore.ui/META-INF/MANIFEST.MF
index 6964e9295..01d0feaec 100644
--- a/plugins/org.eclipse.qvtd.xtext.qvtcore.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.xtext.qvtcore.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.xtext.qvtcore.ui; singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
@@ -16,8 +16,8 @@ Export-Package: org.eclipse.qvtd.xtext.qvtcore.ui,
org.eclipse.qvtd.xtext.qvtcore.ui.outline,
org.eclipse.qvtd.xtext.qvtcore.ui.quickfix
Require-Bundle: org.eclipse.xtext.builder;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.qvtd.xtext.qvtcore;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.xtext.qvtbase.ui;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.xtext.qvtcore;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.xtext.qvtbase.ui;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Import-Package: org.apache.log4j
Bundle-Activator: org.eclipse.qvtd.xtext.qvtcore.ui.internal.QVTcoreActivator
Bundle-Vendor: %providerName
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtcore/.polyglot.build.properties b/plugins/org.eclipse.qvtd.xtext.qvtcore/.polyglot.build.properties
new file mode 100644
index 000000000..9e2d8b082
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.xtext.qvtcore/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.xtext.qvtcore</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtcore/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.xtext.qvtcore/META-INF/MANIFEST.MF
index 280983c53..c324d7eba 100644
--- a/plugins/org.eclipse.qvtd.xtext.qvtcore/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.xtext.qvtcore/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.xtext.qvtcore;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -24,8 +24,8 @@ Export-Package: org.eclipse.qvtd.xtext.qvtcore,
org.eclipse.qvtd.xtext.qvtcorecs.util
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.xtext;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.qvtd.pivot.qvtcore;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.xtext.qvtbase;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.pivot.qvtcore;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.xtext.qvtbase;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Bundle-Activator: org.eclipse.qvtd.xtext.qvtcore.utilities.QVTcorePlugin$Implementation
Import-Package: org.apache.log4j
Automatic-Module-Name: org.eclipse.qvtd.xtext.qvtcore
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtimperative.ui/.polyglot.build.properties b/plugins/org.eclipse.qvtd.xtext.qvtimperative.ui/.polyglot.build.properties
new file mode 100644
index 000000000..21419abb8
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.xtext.qvtimperative.ui/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.xtext.qvtimperative.ui</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtimperative.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.xtext.qvtimperative.ui/META-INF/MANIFEST.MF
index 0f18fb2c0..0b4f40a8b 100644
--- a/plugins/org.eclipse.qvtd.xtext.qvtimperative.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.xtext.qvtimperative.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.xtext.qvtimperative.ui;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
@@ -16,8 +16,8 @@ Export-Package: org.eclipse.qvtd.xtext.qvtimperative.ui,
org.eclipse.qvtd.xtext.qvtimperative.ui.outline,
org.eclipse.qvtd.xtext.qvtimperative.ui.quickfix
Require-Bundle: org.eclipse.xtext.builder;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.qvtd.xtext.qvtimperative;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.xtext.qvtbase.ui;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.xtext.qvtimperative;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.xtext.qvtbase.ui;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Import-Package: org.apache.log4j
Bundle-Activator: org.eclipse.qvtd.xtext.qvtimperative.ui.internal.QVTimperativeActivator
Bundle-Vendor: %providerName
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtimperative/.polyglot.build.properties b/plugins/org.eclipse.qvtd.xtext.qvtimperative/.polyglot.build.properties
new file mode 100644
index 000000000..a7bd3dd69
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.xtext.qvtimperative/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.xtext.qvtimperative</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtimperative/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.xtext.qvtimperative/META-INF/MANIFEST.MF
index ebd9b5388..29d4820c9 100644
--- a/plugins/org.eclipse.qvtd.xtext.qvtimperative/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.xtext.qvtimperative/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.xtext.qvtimperative;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -25,7 +25,7 @@ Export-Package: org.eclipse.qvtd.xtext.qvtimperative,
org.eclipse.qvtd.xtext.qvtimperativecs.util
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.xtext;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.qvtd.pivot.qvtimperative;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.xtext.qvtbase;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.pivot.qvtimperative;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.xtext.qvtbase;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Import-Package: org.apache.log4j
Automatic-Module-Name: org.eclipse.qvtd.xtext.qvtimperative
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtrelation.ui/.polyglot.build.properties b/plugins/org.eclipse.qvtd.xtext.qvtrelation.ui/.polyglot.build.properties
new file mode 100644
index 000000000..62d1523a8
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.xtext.qvtrelation.ui/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.xtext.qvtrelation.ui</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtrelation.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.xtext.qvtrelation.ui/META-INF/MANIFEST.MF
index ea9e4eff3..4ea6ff8b8 100644
--- a/plugins/org.eclipse.qvtd.xtext.qvtrelation.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.xtext.qvtrelation.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.xtext.qvtrelation.ui; singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
@@ -16,8 +16,8 @@ Export-Package: org.eclipse.qvtd.xtext.qvtrelation.ui,
org.eclipse.qvtd.xtext.qvtrelation.ui.outline,
org.eclipse.qvtd.xtext.qvtrelation.ui.quickfix
Require-Bundle: org.eclipse.xtext.builder;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.qvtd.xtext.qvtbase.ui;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.xtext.qvtrelation;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.xtext.qvtbase.ui;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.xtext.qvtrelation;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Import-Package: org.apache.log4j
Bundle-Activator: org.eclipse.qvtd.xtext.qvtrelation.ui.internal.QVTrelationActivator
Bundle-Vendor: %providerName
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtrelation/.polyglot.build.properties b/plugins/org.eclipse.qvtd.xtext.qvtrelation/.polyglot.build.properties
new file mode 100644
index 000000000..71d93b985
--- /dev/null
+++ b/plugins/org.eclipse.qvtd.xtext.qvtrelation/.polyglot.build.properties
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.eclipse.qvtd</groupId>
+ <artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ </parent>
+ <artifactId>org.eclipse.qvtd.xtext.qvtrelation</artifactId>
+ <version>0.18.0-SNAPSHOT</version>
+ <packaging>eclipse-plugin</packaging>
+</project>
diff --git a/plugins/org.eclipse.qvtd.xtext.qvtrelation/META-INF/MANIFEST.MF b/plugins/org.eclipse.qvtd.xtext.qvtrelation/META-INF/MANIFEST.MF
index 2a189c709..9aedb17bc 100644
--- a/plugins/org.eclipse.qvtd.xtext.qvtrelation/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.qvtd.xtext.qvtrelation/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.xtext.qvtrelation;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -25,7 +25,7 @@ Export-Package: org.eclipse.qvtd.xtext.qvtrelation,
org.eclipse.qvtd.xtext.qvtrelationcs.util
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.xtext;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.qvtd.pivot.qvtrelation;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.xtext.qvtbase;bundle-version="[0.17.0,1.0.0)";visibility:=reexport
+ org.eclipse.qvtd.pivot.qvtrelation;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.xtext.qvtbase;bundle-version="[0.18.0,1.0.0)";visibility:=reexport
Import-Package: org.apache.log4j
Automatic-Module-Name: org.eclipse.qvtd.xtext.qvtrelation
diff --git a/plugins/pom.xml b/plugins/pom.xml
index 8aca9697c..74a3c8689 100644
--- a/plugins/pom.xml
+++ b/plugins/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd</groupId>
<artifactId>org.eclipse.qvtd.plugins-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>pom</packaging>
<parent>
<groupId>org.eclipse.qvtd</groupId>
<artifactId>org.eclipse.qvtd.releng.tycho</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<relativePath>../releng/org.eclipse.qvtd.releng.tycho</relativePath>
</parent>
diff --git a/releng/org.eclipse.qvtd.build/META-INF/MANIFEST.MF b/releng/org.eclipse.qvtd.build/META-INF/MANIFEST.MF
index fc670187e..acdaa7b62 100644
--- a/releng/org.eclipse.qvtd.build/META-INF/MANIFEST.MF
+++ b/releng/org.eclipse.qvtd.build/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.build;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.core.resources,
@@ -11,16 +11,16 @@ Require-Bundle: org.eclipse.core.resources,
org.eclipse.xtext.generator;bundle-version="[2.5.0,3.0.0)",
org.eclipse.ocl.examples.build;bundle-version="[2.7.0,2.8.0)",
org.eclipse.m2m.atl.common,
- org.eclipse.qvtd.atl;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.codegen;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.cs2as.compiler.tests;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.pivot.qvtschedule;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.text;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.umlx;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xml;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtcore.tests;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtimperative.tests;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtrelation.tests;bundle-version="[0.17.0,1.0.0)"
+ org.eclipse.qvtd.atl;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.codegen;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.cs2as.compiler.tests;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.pivot.qvtschedule;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.text;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.umlx;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xml;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtcore.tests;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtimperative.tests;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtrelation.tests;bundle-version="[0.18.0,1.0.0)"
Import-Package: org.apache.commons.logging,
org.apache.log4j
Bundle-Vendor: %providerName
diff --git a/releng/org.eclipse.qvtd.releng.build-site/feature.xml b/releng/org.eclipse.qvtd.releng.build-site/feature.xml
index bddcc522a..a39b812f9 100644
--- a/releng/org.eclipse.qvtd.releng.build-site/feature.xml
+++ b/releng/org.eclipse.qvtd.releng.build-site/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.qvtd.releng.build"
label="QVTd Build Site (Incubation)"
- version="0.17.0.qualifier"
+ version="0.18.0.qualifier"
provider-name="%providerName"
license-feature="org.eclipse.license"
license-feature-version="0.0.0">
diff --git a/releng/org.eclipse.qvtd.releng.build-site/pom.xml b/releng/org.eclipse.qvtd.releng.build-site/pom.xml
index d392233c5..bf31bd22f 100644
--- a/releng/org.eclipse.qvtd.releng.build-site/pom.xml
+++ b/releng/org.eclipse.qvtd.releng.build-site/pom.xml
@@ -5,12 +5,12 @@
<parent>
<groupId>org.eclipse.qvtd</groupId>
<artifactId>org.eclipse.qvtd.releng-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<relativePath>..</relativePath>
</parent>
<groupId>org.eclipse.qvtd</groupId>
<artifactId>org.eclipse.qvtd.releng.build-site</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-repository</packaging>
<build>
<resources>
diff --git a/releng/org.eclipse.qvtd.releng.tycho/README.txt b/releng/org.eclipse.qvtd.releng.tycho/README.txt
index 75a23e9a4..8b41b9276 100644
--- a/releng/org.eclipse.qvtd.releng.tycho/README.txt
+++ b/releng/org.eclipse.qvtd.releng.tycho/README.txt
@@ -1,30 +1,36 @@
The Tycho build automatically promotes downloads and updates, so no cron job help is necessary.
The updates can be checked by looking for the new entry on http://www.eclipse.org/mmt/downloads/?project=qvtd
-or installing new software from e.g. http://download.eclipse.org/mmt/qvtd/updates/milestones/0.16.0/S201408191819
+or installing new software from e.g. http://download.eclipse.org/mmt/qvtd/updates/milestones/0.18.0/S201408191819
However operations on composite repositories are not automated, partly because they are sufficiently important to deserve manual attention.
A new milestone build can be added to the composite repository by:
logon to build.eclipse.org
-cd downloads/mmt/qvtd/updates/milestones/0.16.0
-ant -f /shared/modeling/tools/promotion/manage-composite.xml add -Dchild.repository=S201408191819 -Dcomposite.name="QVTd 0.16.0 milestones"
+cd ~/downloads/mmt/qvtd/updates/milestones/0.18.0
+ant -f /shared/modeling/tools/promotion/manage-composite.xml add -Dchild.repository=S201408191819 -Dcomposite.name="QVTd 0.18.0 milestones"
-(This can be checked by installing new software from e.g. http://download.eclipse.org/mmt/qvtd/updates/milestones/0.16.0)
+(This can be checked by installing new software from e.g. http://download.eclipse.org/mmt/qvtd/updates/milestones/0.18.0)
The SimRel aggregator is configured by GIT\org.eclipse.simrel.build\qvtd.aggrcon to use an explicit milestone entry
So edit qvtd.aggrcon to update
-location="http://download.eclipse.org/mmt/qvtd/updates/milestones/0.16.0/S201408191819"
+location="http://download.eclipse.org/mmt/qvtd/updates/milestones/0.18.0/S201408191819"
push first to Getrrit refs/for/master and if successful to refs/head/master and start a new build at https://ci.eclipse.org/simrel/job/simrel.photon.runaggregator/
Once a release has been promoted update qvtd.aggrcon to the final release
-location="http://download.eclipse.org/mmt/qvtd/updates/releases/0.16.0"
+location="http://download.eclipse.org/mmt/qvtd/updates/releases/0.18.0"
After each first repo contribution, remember to update the aggregates e.g.
-cd downloads/mmt/qvtd/updates/milestones
-ant -f /shared/modeling/tools/promotion/manage-composite.xml add -Dchild.repository=0.16.0
+cd ~/downloads/mmt/qvtd/updates/milestones
+ant -f /shared/modeling/tools/promotion/manage-composite.xml add -Dchild.repository=0.18.0
+
+Downloads are accessible at
+cd ~/downloads/mmt/qvtd/downloads/drops/0.18.0
+
+Archives are accessible at
+cd /home/data/httpd/archive.eclipse.org/mmt/qvtd/downloads/drops
--------
diff --git a/releng/org.eclipse.qvtd.releng.tycho/pom.xml b/releng/org.eclipse.qvtd.releng.tycho/pom.xml
index 9e4117883..740bc897e 100644
--- a/releng/org.eclipse.qvtd.releng.tycho/pom.xml
+++ b/releng/org.eclipse.qvtd.releng.tycho/pom.xml
@@ -15,7 +15,7 @@
</prerequisites>
<groupId>org.eclipse.qvtd</groupId>
<artifactId>org.eclipse.qvtd.releng.tycho</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>pom</packaging>
<licenses>
<license>
@@ -106,7 +106,7 @@
<artifact>
<groupId>org.eclipse.qvtd</groupId>
<artifactId>org.eclipse.qvtd.releng.tycho</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<classifier>${targetPlatform}</classifier>
</artifact>
</target>
diff --git a/releng/pom.xml b/releng/pom.xml
index bf1c930cb..fe82eb313 100644
--- a/releng/pom.xml
+++ b/releng/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd</groupId>
<artifactId>org.eclipse.qvtd.releng-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>pom</packaging>
<parent>
<groupId>org.eclipse.qvtd</groupId>
<artifactId>org.eclipse.qvtd.releng.tycho</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<relativePath>../releng/org.eclipse.qvtd.releng.tycho</relativePath>
</parent>
diff --git a/tests/org.eclipse.qvtd.all.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.qvtd.all.tests/META-INF/MANIFEST.MF
index 0306d1bf6..6635eda07 100644
--- a/tests/org.eclipse.qvtd.all.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.qvtd.all.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.all.tests
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Comment: org.eclipse.equinox.ds is a workaround to Bug 539655,
@@ -13,12 +13,12 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ocl.xtext.oclinecore;bundle-version="[1.7.0,1.8.0)",
org.eclipse.ocl.xtext.oclstdlib;bundle-version="[1.7.0,1.8.0)",
org.eclipse.ocl.xtext.completeocl;bundle-version="[1.7.0,1.8.0)",
- org.eclipse.qvtd.atl;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.compiler.tests;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtcore.tests;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtimperative.tests;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtrelation.tests;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.umlx.tests;bundle-version="[0.17.0,1.0.0)",
+ org.eclipse.qvtd.atl;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.compiler.tests;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtcore.tests;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtimperative.tests;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtrelation.tests;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.umlx.tests;bundle-version="[0.18.0,1.0.0)",
org.eclipse.qvtd.doc.bigmde2016.tests,
org.eclipse.qvtd.doc.exe2016.tests,
org.eclipse.qvtd.doc.minioclcs.xtext.tests,
diff --git a/tests/org.eclipse.qvtd.all.tests/pom.xml b/tests/org.eclipse.qvtd.all.tests/pom.xml
index 9a3aa247a..7866845a3 100644
--- a/tests/org.eclipse.qvtd.all.tests/pom.xml
+++ b/tests/org.eclipse.qvtd.all.tests/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.all.tests</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<parent>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.tests-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
</parent>
<build>
<plugins>
diff --git a/tests/org.eclipse.qvtd.atl.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.qvtd.atl.tests/META-INF/MANIFEST.MF
index e1dbd7fbf..ad6361fa3 100644
--- a/tests/org.eclipse.qvtd.atl.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.qvtd.atl.tests/META-INF/MANIFEST.MF
@@ -3,7 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-SymbolicName: org.eclipse.qvtd.atl.tests;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Localization: plugin
Export-Package: org.eclipse.qvtd.atl.tests
@@ -13,9 +13,9 @@ Require-Bundle: org.junit,
org.eclipse.core.resources;bundle-version="[3.5.0,4.0.0)",
org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.xtext.util;bundle-version="[2.7.0,3.0.0)",
- org.eclipse.qvtd.atl;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.pivot.qvtimperative;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.pivot.qvtrelation;bundle-version="[0.17.0,1.0.0)",
+ org.eclipse.qvtd.atl;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.pivot.qvtimperative;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.pivot.qvtrelation;bundle-version="[0.18.0,1.0.0)",
org.eclipse.m2m.atl.emftvm.compiler;bundle-version="[4.0.0,5.0.0)",
org.eclipse.m2m.atl.dsls;bundle-version="[4.0.0,5.0.0)",
org.eclipse.m2m.atl.emftvm;bundle-version="[4.0.0,5.0.0)",
diff --git a/tests/org.eclipse.qvtd.atl.tests/pom.xml b/tests/org.eclipse.qvtd.atl.tests/pom.xml
index 0344d5fb7..44224b429 100644
--- a/tests/org.eclipse.qvtd.atl.tests/pom.xml
+++ b/tests/org.eclipse.qvtd.atl.tests/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.atl.tests</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<parent>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.tests-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
</parent>
<build>
<plugins>
diff --git a/tests/org.eclipse.qvtd.compiler.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.qvtd.compiler.tests/META-INF/MANIFEST.MF
index ea6247167..6e43666e0 100644
--- a/tests/org.eclipse.qvtd.compiler.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.qvtd.compiler.tests/META-INF/MANIFEST.MF
@@ -2,15 +2,15 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.compiler.tests
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Comment: org.eclipse.equinox.ds is a workaround to Bug 539655,
javax.annotation is a workaround to Bug 539038
-Require-Bundle: org.eclipse.qvtd.compiler;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtbase.tests;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtcore.tests;bundle-version="[0.17.0,1.0.0)",
+Require-Bundle: org.eclipse.qvtd.compiler;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtbase.tests;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtcore.tests;bundle-version="[0.18.0,1.0.0)",
org.eclipse.equinox.ds;resolution:=optional,
javax.annotation;resolution:=optional
Export-Package: org.eclipse.qvtd.compiler.tests
diff --git a/tests/org.eclipse.qvtd.compiler.tests/pom.xml b/tests/org.eclipse.qvtd.compiler.tests/pom.xml
index c83f921fc..3e8d4027d 100644
--- a/tests/org.eclipse.qvtd.compiler.tests/pom.xml
+++ b/tests/org.eclipse.qvtd.compiler.tests/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.compiler.tests</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<parent>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.tests-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
</parent>
<build>
<plugins>
diff --git a/tests/org.eclipse.qvtd.cs2as.compiler.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.qvtd.cs2as.compiler.tests/META-INF/MANIFEST.MF
index e68bf9d33..41d7d7f0a 100644
--- a/tests/org.eclipse.qvtd.cs2as.compiler.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.qvtd.cs2as.compiler.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.cs2as.compiler.tests;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -11,9 +11,9 @@ Comment: org.eclipse.equinox.ds is a workaround to Bug 539655,
Require-Bundle: org.junit,
org.eclipse.osgi,
org.eclipse.ocl.xtext.completeocl;bundle-version="[1.7.0,1.8.0)",
- org.eclipse.qvtd.xtext.qvtimperative;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtbase.tests;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.cs2as.compiler;bundle-version="[0.17.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtimperative;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtbase.tests;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.cs2as.compiler;bundle-version="[0.18.0,1.0.0)",
org.eclipse.qvtd.xtext.qvtimperative.tests,
org.eclipse.qvtd.xtext.qvtcore.tests,
org.eclipse.equinox.ds;resolution:=optional,
diff --git a/tests/org.eclipse.qvtd.cs2as.compiler.tests/pom.xml b/tests/org.eclipse.qvtd.cs2as.compiler.tests/pom.xml
index 7f54de776..b5d779426 100644
--- a/tests/org.eclipse.qvtd.cs2as.compiler.tests/pom.xml
+++ b/tests/org.eclipse.qvtd.cs2as.compiler.tests/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.cs2as.compiler.tests</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<parent>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.tests-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
</parent>
<build>
<plugins>
diff --git a/tests/org.eclipse.qvtd.doc.bigmde2016.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.qvtd.doc.bigmde2016.tests/META-INF/MANIFEST.MF
index d1cee2273..1d4d30f3b 100644
--- a/tests/org.eclipse.qvtd.doc.bigmde2016.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.qvtd.doc.bigmde2016.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.doc.bigmde2016.tests;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Comment: org.eclipse.equinox.ds is a workaround to Bug 539655,
diff --git a/tests/org.eclipse.qvtd.doc.bigmde2016.tests/pom.xml b/tests/org.eclipse.qvtd.doc.bigmde2016.tests/pom.xml
index 1fc22ae6c..ade95db6d 100644
--- a/tests/org.eclipse.qvtd.doc.bigmde2016.tests/pom.xml
+++ b/tests/org.eclipse.qvtd.doc.bigmde2016.tests/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.doc.bigmde2016.tests</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<parent>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.tests-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
</parent>
<build>
<plugins>
diff --git a/tests/org.eclipse.qvtd.doc.exe2016.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.qvtd.doc.exe2016.tests/META-INF/MANIFEST.MF
index 51cdec205..c10966809 100644
--- a/tests/org.eclipse.qvtd.doc.exe2016.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.qvtd.doc.exe2016.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.doc.exe2016.tests;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Comment: org.eclipse.equinox.ds is a workaround to Bug 539655,
diff --git a/tests/org.eclipse.qvtd.doc.exe2016.tests/pom.xml b/tests/org.eclipse.qvtd.doc.exe2016.tests/pom.xml
index 30e05a0b0..d3b6ea4d3 100644
--- a/tests/org.eclipse.qvtd.doc.exe2016.tests/pom.xml
+++ b/tests/org.eclipse.qvtd.doc.exe2016.tests/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.doc.exe2016.tests</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<parent>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.tests-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
</parent>
<build>
<plugins>
diff --git a/tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/META-INF/MANIFEST.MF
index 396cf1f68..748ad61c8 100644
--- a/tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/META-INF/MANIFEST.MF
@@ -3,15 +3,15 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-SymbolicName: org.eclipse.qvtd.doc.minioclcs.xtext.tests; singleton:=true
Bundle-ActivationPolicy: lazy
Comment: org.eclipse.equinox.ds is a workaround to Bug 539655,
javax.annotation is a workaround to Bug 539038
Require-Bundle: org.junit,
org.eclipse.xtext.xbase.lib;bundle-version="[2.10.0,3.0.0)",
- org.eclipse.qvtd.doc.minioclcs.xtext;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtbase.tests;bundle-version="[0.17.0,1.0.0)",
+ org.eclipse.qvtd.doc.minioclcs.xtext;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtbase.tests;bundle-version="[0.18.0,1.0.0)",
org.eclipse.equinox.ds;resolution:=optional,
javax.annotation;resolution:=optional
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/pom.xml b/tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/pom.xml
index 3d8de3e9e..8bd058628 100644
--- a/tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/pom.xml
+++ b/tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.doc.minioclcs.xtext.tests</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<parent>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.tests-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
</parent>
<build>
<plugins>
diff --git a/tests/org.eclipse.qvtd.umlx.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.qvtd.umlx.tests/META-INF/MANIFEST.MF
index c03dd7fcd..5f0f6642f 100644
--- a/tests/org.eclipse.qvtd.umlx.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.qvtd.umlx.tests/META-INF/MANIFEST.MF
@@ -3,15 +3,15 @@ Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-SymbolicName: org.eclipse.qvtd.umlx.tests;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Comment: org.eclipse.equinox.ds is a workaround to Bug 539655,
javax.annotation is a workaround to Bug 539038
-Require-Bundle: org.eclipse.qvtd.compiler;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.umlx.ui;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtcore.tests;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtrelation.tests;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.examples.umlx.hstm2fstm;bundle-version="[0.17.0,1.0.0)",
+Require-Bundle: org.eclipse.qvtd.compiler;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.umlx.ui;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtcore.tests;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtrelation.tests;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.examples.umlx.hstm2fstm;bundle-version="[0.18.0,1.0.0)",
org.eclipse.equinox.ds;resolution:=optional,
javax.annotation;resolution:=optional
Bundle-Localization: plugin
diff --git a/tests/org.eclipse.qvtd.umlx.tests/pom.xml b/tests/org.eclipse.qvtd.umlx.tests/pom.xml
index d9985b8ee..1c72dc4de 100644
--- a/tests/org.eclipse.qvtd.umlx.tests/pom.xml
+++ b/tests/org.eclipse.qvtd.umlx.tests/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.umlx.tests</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<parent>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.tests-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
</parent>
<build>
<plugins>
diff --git a/tests/org.eclipse.qvtd.xtext.qvtbase.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.qvtd.xtext.qvtbase.tests/META-INF/MANIFEST.MF
index 73455b54f..0ed97602c 100644
--- a/tests/org.eclipse.qvtd.xtext.qvtbase.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.qvtd.xtext.qvtbase.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.xtext.qvtbase.tests;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Comment: org.eclipse.equinox.ds is a workaround to Bug 539655,
javax.annotation is a workaround to Bug 539038
@@ -14,10 +14,10 @@ Require-Bundle: org.junit;visibility:=reexport,
org.eclipse.uml2.uml.resources;bundle-version="[5.0.0,6.0.0)";visibility:=reexport,
org.eclipse.ocl.xtext.oclstdlib;bundle-version="[1.7.0,1.8.0)",
org.eclipse.ocl.examples.xtext.tests;bundle-version="[3.12.0,3.13.0)";visibility:=reexport,
- org.eclipse.qvtd.compiler;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.xtext.qvtimperative;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtcore;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtrelation;bundle-version="[0.17.0,1.0.0)",
+ org.eclipse.qvtd.compiler;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.xtext.qvtimperative;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtcore;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtrelation;bundle-version="[0.18.0,1.0.0)",
org.eclipse.equinox.ds;resolution:=optional,
javax.annotation;resolution:=optional
Bundle-Vendor: %providerName
diff --git a/tests/org.eclipse.qvtd.xtext.qvtbase.tests/pom.xml b/tests/org.eclipse.qvtd.xtext.qvtbase.tests/pom.xml
index 7b8a7bb53..89f871846 100644
--- a/tests/org.eclipse.qvtd.xtext.qvtbase.tests/pom.xml
+++ b/tests/org.eclipse.qvtd.xtext.qvtbase.tests/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.xtext.qvtbase.tests</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<parent>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.tests-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
</parent>
<build>
<plugins>
diff --git a/tests/org.eclipse.qvtd.xtext.qvtcore.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.qvtd.xtext.qvtcore.tests/META-INF/MANIFEST.MF
index 322fab862..3d2a49186 100644
--- a/tests/org.eclipse.qvtd.xtext.qvtcore.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.qvtd.xtext.qvtcore.tests/META-INF/MANIFEST.MF
@@ -2,18 +2,18 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.xtext.qvtcore.tests;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Comment: org.eclipse.equinox.ds is a workaround to Bug 539655,
javax.annotation is a workaround to Bug 539038
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.5.0,4.0.0)",
org.eclipse.ocl.xtext.completeocl;bundle-version="[1.7.0,1.8.0)",
- org.eclipse.qvtd.codegen;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.compiler;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtimperative.tests;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.xtext.qvtcore.ui;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.examples.qvtcore.uml2rdbms;bundle-version="[0.17.0,1.0.0)",
+ org.eclipse.qvtd.codegen;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.compiler;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtimperative.tests;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.xtext.qvtcore.ui;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.examples.qvtcore.uml2rdbms;bundle-version="[0.18.0,1.0.0)",
org.eclipse.equinox.ds;resolution:=optional,
javax.annotation;resolution:=optional
Bundle-ActivationPolicy: lazy
diff --git a/tests/org.eclipse.qvtd.xtext.qvtcore.tests/pom.xml b/tests/org.eclipse.qvtd.xtext.qvtcore.tests/pom.xml
index 593144c79..1823a9745 100644
--- a/tests/org.eclipse.qvtd.xtext.qvtcore.tests/pom.xml
+++ b/tests/org.eclipse.qvtd.xtext.qvtcore.tests/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.xtext.qvtcore.tests</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<parent>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.tests-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
</parent>
<build>
<plugins>
diff --git a/tests/org.eclipse.qvtd.xtext.qvtimperative.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.qvtd.xtext.qvtimperative.tests/META-INF/MANIFEST.MF
index f09ad2845..332689041 100644
--- a/tests/org.eclipse.qvtd.xtext.qvtimperative.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.qvtd.xtext.qvtimperative.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.xtext.qvtimperative.tests;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-ClassPath: .
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
@@ -17,11 +17,11 @@ Require-Bundle: org.junit,
org.eclipse.ui.ide,
org.eclipse.ocl.xtext.completeocl;bundle-version="[1.7.0,1.8.0)",
org.eclipse.ocl.examples.debug.vm;bundle-version="[2.7.0,2.8.0)",
- org.eclipse.qvtd.codegen;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.debug;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.debug.ui;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtimperative.ui;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.xtext.qvtbase.tests;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.codegen;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.debug;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.debug.ui;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtimperative.ui;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.xtext.qvtbase.tests;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
org.eclipse.equinox.ds;resolution:=optional,
javax.annotation;resolution:=optional
Export-Package: org.eclipse.qvtd.xtext.qvtimperative.tests
diff --git a/tests/org.eclipse.qvtd.xtext.qvtimperative.tests/pom.xml b/tests/org.eclipse.qvtd.xtext.qvtimperative.tests/pom.xml
index 5d9d2e609..3cad87092 100644
--- a/tests/org.eclipse.qvtd.xtext.qvtimperative.tests/pom.xml
+++ b/tests/org.eclipse.qvtd.xtext.qvtimperative.tests/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.xtext.qvtimperative.tests</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<parent>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.tests-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
</parent>
<build>
<plugins>
diff --git a/tests/org.eclipse.qvtd.xtext.qvtrelation.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.qvtd.xtext.qvtrelation.tests/META-INF/MANIFEST.MF
index dc49e155c..ba7d62d29 100644
--- a/tests/org.eclipse.qvtd.xtext.qvtrelation.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.qvtd.xtext.qvtrelation.tests/META-INF/MANIFEST.MF
@@ -2,24 +2,24 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.qvtd.xtext.qvtrelation.tests;singleton:=true
-Bundle-Version: 0.17.0.qualifier
+Bundle-Version: 0.18.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Comment: org.eclipse.equinox.ds is a workaround to Bug 539655,
javax.annotation is a workaround to Bug 539038
-Require-Bundle: org.eclipse.qvtd.xtext.qvtbase.tests;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvtd.xtext.qvtrelation.ui;bundle-version="[0.17.0,1.0.0)";visibility:=reexport,
- org.eclipse.qvt;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.atl;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.examples.qvtrelation.modelmorf;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.examples.qvtrelation.reltocore;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.pivot.qvtimperative;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.compiler;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.codegen;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtimperative.tests;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.xtext.qvtcore.tests;bundle-version="[0.17.0,1.0.0)",
- org.eclipse.qvtd.examples.qvtrelation.hstm2fstm;bundle-version="[0.17.0,1.0.0)",
+Require-Bundle: org.eclipse.qvtd.xtext.qvtbase.tests;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvtd.xtext.qvtrelation.ui;bundle-version="[0.18.0,1.0.0)";visibility:=reexport,
+ org.eclipse.qvt;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.atl;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.examples.qvtrelation.modelmorf;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.examples.qvtrelation.reltocore;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.pivot.qvtimperative;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.compiler;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.codegen;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtimperative.tests;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.xtext.qvtcore.tests;bundle-version="[0.18.0,1.0.0)",
+ org.eclipse.qvtd.examples.qvtrelation.hstm2fstm;bundle-version="[0.18.0,1.0.0)",
org.eclipse.m2m.atl.common;bundle-version="3.8.0",
org.eclipse.m2m.atl.emftvm.compiler,
org.eclipse.m2m.atl.engine,
diff --git a/tests/org.eclipse.qvtd.xtext.qvtrelation.tests/pom.xml b/tests/org.eclipse.qvtd.xtext.qvtrelation.tests/pom.xml
index 94111d672..22fc0636e 100644
--- a/tests/org.eclipse.qvtd.xtext.qvtrelation.tests/pom.xml
+++ b/tests/org.eclipse.qvtd.xtext.qvtrelation.tests/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.xtext.qvtrelation.tests</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>eclipse-test-plugin</packaging>
<parent>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.tests-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
</parent>
<build>
<plugins>
diff --git a/tests/pom.xml b/tests/pom.xml
index 3d4a505b3..d98f3d4f2 100644
--- a/tests/pom.xml
+++ b/tests/pom.xml
@@ -4,12 +4,12 @@
<modelVersion>4.0.0</modelVersion>
<groupId>org.eclipse.qvtd-tests</groupId>
<artifactId>org.eclipse.qvtd.tests-folder</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<packaging>pom</packaging>
<parent>
<groupId>org.eclipse.qvtd</groupId>
<artifactId>org.eclipse.qvtd.releng.tycho</artifactId>
- <version>0.17.0-SNAPSHOT</version>
+ <version>0.18.0-SNAPSHOT</version>
<relativePath>../releng/org.eclipse.qvtd.releng.tycho</relativePath>
</parent>

Back to the top