Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdolfo SBH2016-10-19 12:22:43 +0000
committerEd Willink2016-10-22 14:16:46 +0000
commit74f5b1747b6e3a52bf3b570cc42ecf86dbac1ba7 (patch)
tree6eade4716bb05e3e5b772ade6e45197bed38d42b
parentbf4d1ded4233c6e6a87c4b542863e1fe10d94e95 (diff)
downloadorg.eclipse.qvtd-74f5b1747b6e3a52bf3b570cc42ecf86dbac1ba7.tar.gz
org.eclipse.qvtd-74f5b1747b6e3a52bf3b570cc42ecf86dbac1ba7.tar.xz
org.eclipse.qvtd-74f5b1747b6e3a52bf3b570cc42ecf86dbac1ba7.zip
[cs2as] - Cleaning some dependencies
- Removing dependency on cs2as.xtext.generator
-rw-r--r--doc/org.eclipse.qvtd.doc.miniocl/META-INF/MANIFEST.MF3
-rw-r--r--doc/org.eclipse.qvtd.doc.minioclcs.xtext/META-INF/MANIFEST.MF7
-rw-r--r--doc/org.eclipse.qvtd.doc.minioclcs.xtext/build.properties3
-rw-r--r--tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/META-INF/MANIFEST.MF15
4 files changed, 6 insertions, 22 deletions
diff --git a/doc/org.eclipse.qvtd.doc.miniocl/META-INF/MANIFEST.MF b/doc/org.eclipse.qvtd.doc.miniocl/META-INF/MANIFEST.MF
index c520daa77..d02ca87e0 100644
--- a/doc/org.eclipse.qvtd.doc.miniocl/META-INF/MANIFEST.MF
+++ b/doc/org.eclipse.qvtd.doc.miniocl/META-INF/MANIFEST.MF
@@ -3,8 +3,7 @@ Bundle-ManifestVersion: 2
Bundle-Name: MiniOCL Example - AS Infrastructure
Bundle-SymbolicName: org.eclipse.qvtd.doc.miniocl;singleton:=true
Bundle-Version: 0.14.0.qualifier
-Require-Bundle: org.eclipse.emf.ecore,
- org.eclipse.ocl.pivot;bundle-version="[1.1.0,2.0.0)"
+Require-Bundle: org.eclipse.ocl.pivot;bundle-version="[1.1.0,2.0.0)"
Export-Package: org.eclipse.qvtd.doc.miniocl,
org.eclipse.qvtd.doc.miniocl.impl,
org.eclipse.qvtd.doc.miniocl.lookup,
diff --git a/doc/org.eclipse.qvtd.doc.minioclcs.xtext/META-INF/MANIFEST.MF b/doc/org.eclipse.qvtd.doc.minioclcs.xtext/META-INF/MANIFEST.MF
index 88c2b482e..cb90210d2 100644
--- a/doc/org.eclipse.qvtd.doc.minioclcs.xtext/META-INF/MANIFEST.MF
+++ b/doc/org.eclipse.qvtd.doc.minioclcs.xtext/META-INF/MANIFEST.MF
@@ -6,14 +6,7 @@ Bundle-Version: 0.14.0.qualifier
Bundle-SymbolicName: org.eclipse.qvtd.doc.minioclcs.xtext; singleton:=true
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.xtext,
- org.eclipse.xtext.xbase,
- org.eclipse.equinox.common;bundle-version="3.5.0",
- org.eclipse.emf.ecore,
- org.eclipse.xtext.xbase.lib,
org.antlr.runtime,
- org.eclipse.xtext.util,
- org.eclipse.xtend.lib,
- org.eclipse.emf.common,
org.eclipse.ocl.pivot;bundle-version="[1.1.0,2.0.0)",
org.eclipse.qvtd.doc.miniocl;bundle-version="[0.14.0,1.0.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/doc/org.eclipse.qvtd.doc.minioclcs.xtext/build.properties b/doc/org.eclipse.qvtd.doc.minioclcs.xtext/build.properties
index b4c6859c5..392bfcc01 100644
--- a/doc/org.eclipse.qvtd.doc.minioclcs.xtext/build.properties
+++ b/doc/org.eclipse.qvtd.doc.minioclcs.xtext/build.properties
@@ -16,5 +16,4 @@ additional.bundles = org.eclipse.xtext.xbase,\
org.apache.commons.logging,\
org.apache.log4j,\
com.ibm.icu,\
- org.eclipse.jdt.annotation,\
- org.eclipse.qvtd.cs2as.xtext.generator
+ org.eclipse.jdt.annotation
diff --git a/tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/META-INF/MANIFEST.MF
index 84d07de79..3ee88a991 100644
--- a/tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.qvtd.doc.minioclcs.xtext.tests/META-INF/MANIFEST.MF
@@ -5,18 +5,11 @@ Bundle-Vendor: My Company
Bundle-Version: 1.0.0.qualifier
Bundle-SymbolicName: org.eclipse.qvtd.doc.minioclcs.xtext.tests; singleton:=true
Bundle-ActivationPolicy: lazy
-Require-Bundle: org.eclipse.qvtd.doc.miniocl;bundle-version="0.13.0",
- org.eclipse.qvtd.doc.minioclcs.xtext,
+Require-Bundle: org.eclipse.qvtd.doc.minioclcs.xtext,
org.junit;bundle-version="4.7.0",
org.eclipse.xtext.junit4,
- org.eclipse.xtext.xbase.junit,
- org.eclipse.xtext.xbase.lib
+ org.eclipse.xtext.xbase.junit
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.eclipse.qvtd.doc.minioclcs.xtext.tests
-Import-Package: org.hamcrest.core,
- org.junit;version="4.5.0",
- org.junit.runners.model;version="4.5.0",
- org.junit.runner;version="4.5.0",
- org.junit.runners;version="4.5.0",
- org.junit.runner.manipulation;version="4.5.0",
- org.junit.runner.notification;version="4.5.0"
+Import-Package: org.junit;version="4.5.0",
+ org.junit.runner;version="4.5.0"

Back to the top