Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Sohn2015-08-31 07:38:18 +0000
committerMatthias Sohn2015-08-31 09:34:06 +0000
commit3a4a5a4e57f41c595ba950ea6f6680260669bf34 (patch)
tree01205dad24fd52ea85348f0e51b46ae8bd948909 /org.eclipse.jgit.junit.http/META-INF/MANIFEST.MF
parent05acf1c62f415e263d835ae991268e97e7f7ced3 (diff)
downloadjgit-3a4a5a4e57f41c595ba950ea6f6680260669bf34.tar.gz
jgit-3a4a5a4e57f41c595ba950ea6f6680260669bf34.tar.xz
jgit-3a4a5a4e57f41c595ba950ea6f6680260669bf34.zip
Update uses-clauses in OSGi manifests
In Bug 476164 it was reported that EGit doesn't start when the platform comes with jsch 0.1.51 while this version of EGit/JGit brings jsch 0.1.53. This could be caused by outdated uses-clauses. Hence recompute them using PDE tooling. Bug: 476164 Change-Id: I185ba097884ead9cd034eba842bd3bf34181a99b Signed-off-by: Matthias Sohn <matthias.sohn@sap.com>
Diffstat (limited to 'org.eclipse.jgit.junit.http/META-INF/MANIFEST.MF')
-rw-r--r--org.eclipse.jgit.junit.http/META-INF/MANIFEST.MF13
1 files changed, 11 insertions, 2 deletions
diff --git a/org.eclipse.jgit.junit.http/META-INF/MANIFEST.MF b/org.eclipse.jgit.junit.http/META-INF/MANIFEST.MF
index ad319f5e73..73221e49c2 100644
--- a/org.eclipse.jgit.junit.http/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.junit.http/META-INF/MANIFEST.MF
@@ -5,7 +5,6 @@ Bundle-SymbolicName: org.eclipse.jgit.junit.http
Bundle-Version: 4.1.0.qualifier
Bundle-Localization: plugin
Bundle-Vendor: %provider_name
-Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Import-Package: javax.servlet;version="[2.5.0,3.2.0)",
javax.servlet.http;version="[2.5.0,3.2.0)",
@@ -29,4 +28,14 @@ Import-Package: javax.servlet;version="[2.5.0,3.2.0)",
org.eclipse.jgit.transport;version="[4.1.0,4.2.0)",
org.eclipse.jgit.transport.resolver;version="[4.1.0,4.2.0)",
org.junit;version="[4.0.0,5.0.0)"
-Export-Package: org.eclipse.jgit.junit.http;version="4.1.0"
+Export-Package: org.eclipse.jgit.junit.http;version="4.1.0";
+ uses:="org.eclipse.jgit.transport,
+ org.eclipse.jgit.junit,
+ javax.servlet.http,
+ org.eclipse.jgit.lib,
+ org.eclipse.jgit.revwalk,
+ org.eclipse.jetty.server.handler,
+ javax.servlet,
+ org.eclipse.jetty.server,
+ org.eclipse.jetty.util.log,
+ org.eclipse.jetty.servlet"

Back to the top