Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorShawn O. Pearce2010-02-03 04:03:03 +0000
committerShawn O. Pearce2010-02-03 04:03:03 +0000
commit179a9ba4a2f33b52c74c9a9685985232ace68c89 (patch)
tree6bf9635d36104a394ac82914fbfeec92e8c3e49f /org.eclipse.jgit.http.test/META-INF/MANIFEST.MF
parent0e137c4d9e5c245424e78208a104fbc8b3aaee2a (diff)
downloadjgit-179a9ba4a2f33b52c74c9a9685985232ace68c89.tar.gz
jgit-179a9ba4a2f33b52c74c9a9685985232ace68c89.tar.xz
jgit-179a9ba4a2f33b52c74c9a9685985232ace68c89.zip
Cleanup OSGi Import-Package specifications to use versions
Actually set the range of versions we are willing to accept for each package we import, lest we import something in the future that isn't compatible with our needs. Change-Id: I25dbbb9eaabe852631b677e0c608792b3ed97532 Signed-off-by: Shawn O. Pearce <spearce@spearce.org>
Diffstat (limited to 'org.eclipse.jgit.http.test/META-INF/MANIFEST.MF')
-rw-r--r--org.eclipse.jgit.http.test/META-INF/MANIFEST.MF50
1 files changed, 25 insertions, 25 deletions
diff --git a/org.eclipse.jgit.http.test/META-INF/MANIFEST.MF b/org.eclipse.jgit.http.test/META-INF/MANIFEST.MF
index 1481391f52..9e6e77aab1 100644
--- a/org.eclipse.jgit.http.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.http.test/META-INF/MANIFEST.MF
@@ -6,28 +6,28 @@ Bundle-Version: 0.6.0.qualifier
Bundle-Vendor: %provider_name
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: javax.servlet;version="2.5.0",
- javax.servlet.http;version="2.5.0",
- junit.framework;version="3.8.2",
- org.eclipse.jetty.continuation;version="7.0.1",
- org.eclipse.jetty.http;version="7.0.1",
- org.eclipse.jetty.http.security;version="7.0.1",
- org.eclipse.jetty.io;version="7.0.1",
- org.eclipse.jetty.security;version="7.0.1",
- org.eclipse.jetty.security.authentication;version="7.0.1",
- org.eclipse.jetty.server;version="7.0.1",
- org.eclipse.jetty.server.handler;version="7.0.1",
- org.eclipse.jetty.server.nio;version="7.0.1",
- org.eclipse.jetty.servlet;version="7.0.1",
- org.eclipse.jetty.util.component;version="7.0.1",
- org.eclipse.jetty.util.log;version="7.0.1",
- org.eclipse.jetty.util.thread;version="7.0.1",
- org.eclipse.jgit.errors;version="0.6.0",
- org.eclipse.jgit.http.server;version="0.6.0",
- org.eclipse.jgit.http.server.glue;version="0.6.0",
- org.eclipse.jgit.http.server.resolver;version="0.6.0",
- org.eclipse.jgit.junit;version="0.6.0",
- org.eclipse.jgit.lib;version="0.6.0",
- org.eclipse.jgit.revwalk;version="0.6.0",
- org.eclipse.jgit.transport;version="0.6.0",
- org.eclipse.jgit.util;version="0.6.0"
+Import-Package: javax.servlet;version="[2.5.0,3.0.0)",
+ javax.servlet.http;version="[2.5.0,3.0.0)",
+ junit.framework;version="[3.8.2,4.0.0)",
+ org.eclipse.jetty.continuation;version="[7.0.1,8.0.0)",
+ org.eclipse.jetty.http;version="[7.0.1,8.0.0)",
+ org.eclipse.jetty.http.security;version="[7.0.1,8.0.0)",
+ org.eclipse.jetty.io;version="[7.0.1,8.0.0)",
+ org.eclipse.jetty.security;version="[7.0.1,8.0.0)",
+ org.eclipse.jetty.security.authentication;version="[7.0.1,8.0.0)",
+ org.eclipse.jetty.server;version="[7.0.1,8.0.0)",
+ org.eclipse.jetty.server.handler;version="[7.0.1,8.0.0)",
+ org.eclipse.jetty.server.nio;version="[7.0.1,8.0.0)",
+ org.eclipse.jetty.servlet;version="[7.0.1,8.0.0)",
+ org.eclipse.jetty.util.component;version="[7.0.1,8.0.0)",
+ org.eclipse.jetty.util.log;version="[7.0.1,8.0.0)",
+ org.eclipse.jetty.util.thread;version="[7.0.1,8.0.0)",
+ org.eclipse.jgit.errors;version="[0.6.0,0.7.0)",
+ org.eclipse.jgit.http.server;version="[0.6.0,0.7.0)",
+ org.eclipse.jgit.http.server.glue;version="[0.6.0,0.7.0)",
+ org.eclipse.jgit.http.server.resolver;version="[0.6.0,0.7.0)",
+ org.eclipse.jgit.junit;version="[0.6.0,0.7.0)",
+ org.eclipse.jgit.lib;version="[0.6.0,0.7.0)",
+ org.eclipse.jgit.revwalk;version="[0.6.0,0.7.0)",
+ org.eclipse.jgit.transport;version="[0.6.0,0.7.0)",
+ org.eclipse.jgit.util;version="[0.6.0,0.7.0)"

Back to the top