Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Sohn2015-01-26 22:33:14 +0000
committerMatthias Sohn2015-01-27 07:48:26 +0000
commit94ebdbfada07e4ab7ca63a3291095f3217e1ff89 (patch)
treefc253dbbe87c48330f3bedcc995396941c29a687
parent66cbf9255cef5a6c7f3c008fa9cb36c2bd8066a9 (diff)
downloadjgit-94ebdbfada07e4ab7ca63a3291095f3217e1ff89.tar.gz
jgit-94ebdbfada07e4ab7ca63a3291095f3217e1ff89.tar.xz
jgit-94ebdbfada07e4ab7ca63a3291095f3217e1ff89.zip
Prepare 4.0.0-SNAPSHOT builds
Change-Id: I414ba8ccc82866d3107ba7083a567ea70c879bdf Signed-off-by: Matthias Sohn <matthias.sohn@sap.com>
-rw-r--r--org.eclipse.jgit.ant.test/META-INF/MANIFEST.MF12
-rw-r--r--org.eclipse.jgit.ant.test/pom.xml2
-rw-r--r--org.eclipse.jgit.ant/META-INF/MANIFEST.MF6
-rw-r--r--org.eclipse.jgit.ant/pom.xml2
-rw-r--r--org.eclipse.jgit.archive/META-INF/MANIFEST.MF10
-rw-r--r--org.eclipse.jgit.archive/META-INF/SOURCE-MANIFEST.MF4
-rw-r--r--org.eclipse.jgit.archive/pom.xml2
-rw-r--r--org.eclipse.jgit.console/META-INF/MANIFEST.MF12
-rw-r--r--org.eclipse.jgit.console/pom.xml2
-rw-r--r--org.eclipse.jgit.http.apache/META-INF/MANIFEST.MF10
-rw-r--r--org.eclipse.jgit.http.apache/pom.xml2
-rw-r--r--org.eclipse.jgit.http.server/META-INF/MANIFEST.MF24
-rw-r--r--org.eclipse.jgit.http.server/pom.xml2
-rw-r--r--org.eclipse.jgit.http.test/META-INF/MANIFEST.MF36
-rw-r--r--org.eclipse.jgit.http.test/pom.xml2
-rw-r--r--org.eclipse.jgit.java7.test/META-INF/MANIFEST.MF22
-rw-r--r--org.eclipse.jgit.java7.test/pom.xml2
-rw-r--r--org.eclipse.jgit.java7/META-INF/MANIFEST.MF4
-rw-r--r--org.eclipse.jgit.java7/META-INF/SOURCE-MANIFEST.MF4
-rw-r--r--org.eclipse.jgit.java7/pom.xml2
-rw-r--r--org.eclipse.jgit.junit.http/META-INF/MANIFEST.MF20
-rw-r--r--org.eclipse.jgit.junit.http/pom.xml2
-rw-r--r--org.eclipse.jgit.junit/META-INF/MANIFEST.MF30
-rw-r--r--org.eclipse.jgit.junit/pom.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.feature/feature.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.feature/pom.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.http.apache.feature/feature.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.http.apache.feature/pom.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.java7.feature/feature.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.java7.feature/pom.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.junit.feature/feature.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.junit.feature/pom.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.feature/feature.xml4
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.feature/pom.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.source.feature/feature.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.source.feature/pom.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.repository/pom.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.source.feature/feature.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.source.feature/pom.xml2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.target/META-INF/MANIFEST.MF2
-rw-r--r--org.eclipse.jgit.packaging/org.eclipse.jgit.target/pom.xml2
-rw-r--r--org.eclipse.jgit.packaging/pom.xml2
-rw-r--r--org.eclipse.jgit.pgm.test/META-INF/MANIFEST.MF34
-rw-r--r--org.eclipse.jgit.pgm.test/pom.xml2
-rw-r--r--org.eclipse.jgit.pgm/META-INF/MANIFEST.MF62
-rw-r--r--org.eclipse.jgit.pgm/META-INF/SOURCE-MANIFEST.MF4
-rw-r--r--org.eclipse.jgit.pgm/pom.xml2
-rw-r--r--org.eclipse.jgit.test/META-INF/MANIFEST.MF78
-rw-r--r--org.eclipse.jgit.test/pom.xml2
-rw-r--r--org.eclipse.jgit.ui/META-INF/MANIFEST.MF18
-rw-r--r--org.eclipse.jgit.ui/pom.xml2
-rw-r--r--org.eclipse.jgit/META-INF/MANIFEST.MF72
-rw-r--r--org.eclipse.jgit/META-INF/SOURCE-MANIFEST.MF4
-rw-r--r--org.eclipse.jgit/pom.xml2
-rw-r--r--pom.xml2
55 files changed, 269 insertions, 269 deletions
diff --git a/org.eclipse.jgit.ant.test/META-INF/MANIFEST.MF b/org.eclipse.jgit.ant.test/META-INF/MANIFEST.MF
index 84e64ab287..392bb95e39 100644
--- a/org.eclipse.jgit.ant.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.ant.test/META-INF/MANIFEST.MF
@@ -3,14 +3,14 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit.ant.test
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Import-Package: org.apache.tools.ant,
- org.eclipse.jgit.ant.tasks;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal.storage.file;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.junit;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.lib;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util;version="[3.7.0,3.8.0)",
+ org.eclipse.jgit.ant.tasks;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal.storage.file;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.junit;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.lib;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util;version="[4.0.0,4.1.0)",
org.hamcrest;version="[1.1.0,2.0.0)",
org.junit;version="[4.0.0,5.0.0)"
diff --git a/org.eclipse.jgit.ant.test/pom.xml b/org.eclipse.jgit.ant.test/pom.xml
index ecf8650282..eb6cc4893c 100644
--- a/org.eclipse.jgit.ant.test/pom.xml
+++ b/org.eclipse.jgit.ant.test/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.ant.test</artifactId>
diff --git a/org.eclipse.jgit.ant/META-INF/MANIFEST.MF b/org.eclipse.jgit.ant/META-INF/MANIFEST.MF
index ba5d1295d7..76b6d77bdd 100644
--- a/org.eclipse.jgit.ant/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.ant/META-INF/MANIFEST.MF
@@ -2,11 +2,11 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.jgit.ant
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Import-Package: org.apache.tools.ant,
- org.eclipse.jgit.storage.file;version="[3.7.0,3.8.0)"
+ org.eclipse.jgit.storage.file;version="[4.0.0,4.1.0)"
Bundle-Localization: plugin
Bundle-Vendor: %Provider-Name
-Export-Package: org.eclipse.jgit.ant.tasks;version="3.7.0";
+Export-Package: org.eclipse.jgit.ant.tasks;version="4.0.0";
uses:="org.apache.tools.ant.types,org.apache.tools.ant"
diff --git a/org.eclipse.jgit.ant/pom.xml b/org.eclipse.jgit.ant/pom.xml
index 326c9720bd..eb7c4595d4 100644
--- a/org.eclipse.jgit.ant/pom.xml
+++ b/org.eclipse.jgit.ant/pom.xml
@@ -48,7 +48,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.ant</artifactId>
diff --git a/org.eclipse.jgit.archive/META-INF/MANIFEST.MF b/org.eclipse.jgit.archive/META-INF/MANIFEST.MF
index a9dd94a871..c91080fb18 100644
--- a/org.eclipse.jgit.archive/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.archive/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit.archive
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %provider_name
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
@@ -12,13 +12,13 @@ Import-Package: org.apache.commons.compress.archivers;version="[1.4,2.0)",
org.apache.commons.compress.compressors.bzip2;version="[1.4,2.0)",
org.apache.commons.compress.compressors.gzip;version="[1.4,2.0)",
org.apache.commons.compress.compressors.xz;version="[1.4,2.0)",
- org.eclipse.jgit.api;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.lib;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.nls;version="[3.7.0,3.8.0)",
+ org.eclipse.jgit.api;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.lib;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.nls;version="[4.0.0,4.1.0)",
org.osgi.framework;version="[1.3.0,2.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.jgit.archive.FormatActivator
-Export-Package: org.eclipse.jgit.archive;version="3.7.0";
+Export-Package: org.eclipse.jgit.archive;version="4.0.0";
uses:="org.eclipse.jgit.lib,
org.eclipse.jgit.api,
org.apache.commons.compress.archivers,
diff --git a/org.eclipse.jgit.archive/META-INF/SOURCE-MANIFEST.MF b/org.eclipse.jgit.archive/META-INF/SOURCE-MANIFEST.MF
index 8de8575187..fbeb56fb1e 100644
--- a/org.eclipse.jgit.archive/META-INF/SOURCE-MANIFEST.MF
+++ b/org.eclipse.jgit.archive/META-INF/SOURCE-MANIFEST.MF
@@ -3,5 +3,5 @@ Bundle-ManifestVersion: 2
Bundle-Name: org.eclipse.jgit.archive - Sources
Bundle-SymbolicName: org.eclipse.jgit.archive.source
Bundle-Vendor: Eclipse.org - JGit
-Bundle-Version: 3.7.0.qualifier
-Eclipse-SourceBundle: org.eclipse.jgit.archive;version="3.7.0.qualifier";roots="."
+Bundle-Version: 4.0.0.qualifier
+Eclipse-SourceBundle: org.eclipse.jgit.archive;version="4.0.0.qualifier";roots="."
diff --git a/org.eclipse.jgit.archive/pom.xml b/org.eclipse.jgit.archive/pom.xml
index 4c1edba733..40be851745 100644
--- a/org.eclipse.jgit.archive/pom.xml
+++ b/org.eclipse.jgit.archive/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.archive</artifactId>
diff --git a/org.eclipse.jgit.console/META-INF/MANIFEST.MF b/org.eclipse.jgit.console/META-INF/MANIFEST.MF
index 0ebd5c4f7e..625c1e8448 100644
--- a/org.eclipse.jgit.console/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.console/META-INF/MANIFEST.MF
@@ -3,11 +3,11 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit.console
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %provider_name
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Export-Package: org.eclipse.jgit.console;version="3.7.0"
-Import-Package: org.eclipse.jgit.errors;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.nls;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util;version="[3.7.0,3.8.0)"
+Export-Package: org.eclipse.jgit.console;version="4.0.0"
+Import-Package: org.eclipse.jgit.errors;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.nls;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util;version="[4.0.0,4.1.0)"
diff --git a/org.eclipse.jgit.console/pom.xml b/org.eclipse.jgit.console/pom.xml
index e262faa8ab..a1c7eaa72d 100644
--- a/org.eclipse.jgit.console/pom.xml
+++ b/org.eclipse.jgit.console/pom.xml
@@ -52,7 +52,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.console</artifactId>
diff --git a/org.eclipse.jgit.http.apache/META-INF/MANIFEST.MF b/org.eclipse.jgit.http.apache/META-INF/MANIFEST.MF
index d6e685741e..d3746e4129 100644
--- a/org.eclipse.jgit.http.apache/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.http.apache/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.jgit.http.apache
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-Localization: plugin
Bundle-Vendor: %Provider-Name
@@ -18,10 +18,10 @@ Import-Package: org.apache.http;version="[4.1.0,5.0.0)",
org.apache.http.impl.client;version="[4.1.0,5.0.0)",
org.apache.http.impl.client.cache;version="[4.1.0,5.0.0)",
org.apache.http.params;version="[4.1.0,5.0.0)",
- org.eclipse.jgit.nls;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport.http;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util;version="[3.7.0,3.8.0)"
-Export-Package: org.eclipse.jgit.transport.http.apache;version="3.7.0";
+ org.eclipse.jgit.nls;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport.http;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util;version="[4.0.0,4.1.0)"
+Export-Package: org.eclipse.jgit.transport.http.apache;version="4.0.0";
uses:="org.eclipse.jgit.transport.http,
javax.net.ssl,
org.apache.http.client,
diff --git a/org.eclipse.jgit.http.apache/pom.xml b/org.eclipse.jgit.http.apache/pom.xml
index 28c8e842a2..02df914840 100644
--- a/org.eclipse.jgit.http.apache/pom.xml
+++ b/org.eclipse.jgit.http.apache/pom.xml
@@ -48,7 +48,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.http.apache</artifactId>
diff --git a/org.eclipse.jgit.http.server/META-INF/MANIFEST.MF b/org.eclipse.jgit.http.server/META-INF/MANIFEST.MF
index aeb5b6f4a9..a3e266e353 100644
--- a/org.eclipse.jgit.http.server/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.http.server/META-INF/MANIFEST.MF
@@ -2,13 +2,13 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit.http.server
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Localization: plugin
Bundle-Vendor: %provider_name
-Export-Package: org.eclipse.jgit.http.server;version="3.7.0",
- org.eclipse.jgit.http.server.glue;version="3.7.0";
+Export-Package: org.eclipse.jgit.http.server;version="4.0.0",
+ org.eclipse.jgit.http.server.glue;version="4.0.0";
uses:="javax.servlet,javax.servlet.http",
- org.eclipse.jgit.http.server.resolver;version="3.7.0";
+ org.eclipse.jgit.http.server.resolver;version="4.0.0";
uses:="org.eclipse.jgit.transport.resolver,
org.eclipse.jgit.lib,
org.eclipse.jgit.transport,
@@ -17,11 +17,11 @@ Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Import-Package: javax.servlet;version="[2.5.0,3.0.0)",
javax.servlet.http;version="[2.5.0,3.0.0)",
- org.eclipse.jgit.errors;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal.storage.file;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.lib;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.nls;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revwalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport.resolver;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util;version="[3.7.0,3.8.0)"
+ org.eclipse.jgit.errors;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal.storage.file;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.lib;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.nls;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revwalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport.resolver;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util;version="[4.0.0,4.1.0)"
diff --git a/org.eclipse.jgit.http.server/pom.xml b/org.eclipse.jgit.http.server/pom.xml
index dd11cd5735..38aa64c9d8 100644
--- a/org.eclipse.jgit.http.server/pom.xml
+++ b/org.eclipse.jgit.http.server/pom.xml
@@ -52,7 +52,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.http.server</artifactId>
diff --git a/org.eclipse.jgit.http.test/META-INF/MANIFEST.MF b/org.eclipse.jgit.http.test/META-INF/MANIFEST.MF
index 0588e54f68..6c5cc70a5b 100644
--- a/org.eclipse.jgit.http.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.http.test/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit.http.test
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %provider_name
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
@@ -22,23 +22,23 @@ Import-Package: javax.servlet;version="[2.5.0,3.0.0)",
org.eclipse.jetty.util.log;version="[7.6.0,8.0.0)",
org.eclipse.jetty.util.security;version="[7.6.0,8.0.0)",
org.eclipse.jetty.util.thread;version="[7.6.0,8.0.0)",
- org.eclipse.jgit.errors;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.http.server;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.http.server.glue;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.http.server.resolver;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal.storage.file;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.junit;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.junit.http;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.lib;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.nls;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revwalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.storage.file;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport.http;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport.http.apache;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport.resolver;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util;version="[3.7.0,3.8.0)",
+ org.eclipse.jgit.errors;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.http.server;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.http.server.glue;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.http.server.resolver;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal.storage.file;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.junit;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.junit.http;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.lib;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.nls;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revwalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.storage.file;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport.http;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport.http.apache;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport.resolver;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util;version="[4.0.0,4.1.0)",
org.hamcrest.core;version="[1.1.0,2.0.0)",
org.junit;version="[4.0.0,5.0.0)",
org.junit.runner;version="[4.0.0,5.0.0)",
diff --git a/org.eclipse.jgit.http.test/pom.xml b/org.eclipse.jgit.http.test/pom.xml
index 819c9fa0d4..9457933f27 100644
--- a/org.eclipse.jgit.http.test/pom.xml
+++ b/org.eclipse.jgit.http.test/pom.xml
@@ -51,7 +51,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.http.test</artifactId>
diff --git a/org.eclipse.jgit.java7.test/META-INF/MANIFEST.MF b/org.eclipse.jgit.java7.test/META-INF/MANIFEST.MF
index a6e8f67dd5..ad8800103b 100644
--- a/org.eclipse.jgit.java7.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.java7.test/META-INF/MANIFEST.MF
@@ -2,17 +2,17 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit.java7.test
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %provider_name
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
-Import-Package: org.eclipse.jgit.api;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.diff;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.dircache;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal.storage.file;version="3.7.0",
- org.eclipse.jgit.junit;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.lib;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revwalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.storage.file;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.treewalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util;version="[3.7.0,3.8.0)",
+Import-Package: org.eclipse.jgit.api;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.diff;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.dircache;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal.storage.file;version="4.0.0",
+ org.eclipse.jgit.junit;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.lib;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revwalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.storage.file;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.treewalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util;version="[4.0.0,4.1.0)",
org.junit;version="[4.11.0,5.0.0)"
diff --git a/org.eclipse.jgit.java7.test/pom.xml b/org.eclipse.jgit.java7.test/pom.xml
index 5fb70a3fd6..3dcf7efeec 100644
--- a/org.eclipse.jgit.java7.test/pom.xml
+++ b/org.eclipse.jgit.java7.test/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.java7.test</artifactId>
diff --git a/org.eclipse.jgit.java7/META-INF/MANIFEST.MF b/org.eclipse.jgit.java7/META-INF/MANIFEST.MF
index 938e060919..c373181238 100644
--- a/org.eclipse.jgit.java7/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.java7/META-INF/MANIFEST.MF
@@ -3,8 +3,8 @@ Bundle-ManifestVersion: 2
Fragment-Host: org.eclipse.jgit;bundle-version="3.1.1"
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit.java7
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Localization: plugin
Bundle-Vendor: %provider_name
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
-Export-Package: org.eclipse.jgit.util;version="3.7.0"
+Export-Package: org.eclipse.jgit.util;version="4.0.0"
diff --git a/org.eclipse.jgit.java7/META-INF/SOURCE-MANIFEST.MF b/org.eclipse.jgit.java7/META-INF/SOURCE-MANIFEST.MF
index 58d294b929..77cc74c914 100644
--- a/org.eclipse.jgit.java7/META-INF/SOURCE-MANIFEST.MF
+++ b/org.eclipse.jgit.java7/META-INF/SOURCE-MANIFEST.MF
@@ -3,6 +3,6 @@ Bundle-ManifestVersion: 2
Bundle-Name: org.eclipse.jgit.java7 - Sources
Bundle-SymbolicName: org.eclipse.jgit.java7.source
Bundle-Vendor: Eclipse.org - JGit
-Bundle-Version: 3.7.0.qualifier
-Eclipse-SourceBundle: org.eclipse.jgit.java7;version="3.7.0.qualifier";roots="."
+Bundle-Version: 4.0.0.qualifier
+Eclipse-SourceBundle: org.eclipse.jgit.java7;version="4.0.0.qualifier";roots="."
diff --git a/org.eclipse.jgit.java7/pom.xml b/org.eclipse.jgit.java7/pom.xml
index 93c9b5c0b4..9796223c70 100644
--- a/org.eclipse.jgit.java7/pom.xml
+++ b/org.eclipse.jgit.java7/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.java7</artifactId>
diff --git a/org.eclipse.jgit.junit.http/META-INF/MANIFEST.MF b/org.eclipse.jgit.junit.http/META-INF/MANIFEST.MF
index 5ede10778d..67293e72c9 100644
--- a/org.eclipse.jgit.junit.http/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.junit.http/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit.junit.http
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Localization: plugin
Bundle-Vendor: %provider_name
Bundle-ActivationPolicy: lazy
@@ -20,13 +20,13 @@ Import-Package: javax.servlet;version="[2.5.0,3.0.0)",
org.eclipse.jetty.util.component;version="[7.6.0,8.0.0)",
org.eclipse.jetty.util.log;version="[7.6.0,8.0.0)",
org.eclipse.jetty.util.security;version="[7.6.0,8.0.0)",
- org.eclipse.jgit.errors;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.http.server;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal.storage.file;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.junit;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.lib;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revwalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport.resolver;version="[3.7.0,3.8.0)",
+ org.eclipse.jgit.errors;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.http.server;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal.storage.file;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.junit;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.lib;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revwalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport.resolver;version="[4.0.0,4.1.0)",
org.junit;version="[4.0.0,5.0.0)"
-Export-Package: org.eclipse.jgit.junit.http;version="3.7.0"
+Export-Package: org.eclipse.jgit.junit.http;version="4.0.0"
diff --git a/org.eclipse.jgit.junit.http/pom.xml b/org.eclipse.jgit.junit.http/pom.xml
index a082e50d53..2365907aa4 100644
--- a/org.eclipse.jgit.junit.http/pom.xml
+++ b/org.eclipse.jgit.junit.http/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.junit.http</artifactId>
diff --git a/org.eclipse.jgit.junit/META-INF/MANIFEST.MF b/org.eclipse.jgit.junit/META-INF/MANIFEST.MF
index 47e03420d0..8ef4d49a13 100644
--- a/org.eclipse.jgit.junit/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.junit/META-INF/MANIFEST.MF
@@ -2,23 +2,23 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit.junit
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Localization: plugin
Bundle-Vendor: %provider_name
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: org.eclipse.jgit.api;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.api.errors;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.dircache;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.errors;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal.storage.file;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal.storage.pack;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.lib;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revwalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.storage.file;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.treewalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.treewalk.filter;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util.io;version="[3.7.0,3.8.0)",
+Import-Package: org.eclipse.jgit.api;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.api.errors;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.dircache;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.errors;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal.storage.file;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal.storage.pack;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.lib;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revwalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.storage.file;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.treewalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.treewalk.filter;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util.io;version="[4.0.0,4.1.0)",
org.junit;version="[4.0.0,5.0.0)"
-Export-Package: org.eclipse.jgit.junit;version="3.7.0"
+Export-Package: org.eclipse.jgit.junit;version="4.0.0"
diff --git a/org.eclipse.jgit.junit/pom.xml b/org.eclipse.jgit.junit/pom.xml
index 39a9e60497..77f0511b34 100644
--- a/org.eclipse.jgit.junit/pom.xml
+++ b/org.eclipse.jgit.junit/pom.xml
@@ -52,7 +52,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.junit</artifactId>
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.feature/feature.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.feature/feature.xml
index 10ea2c9e56..e630292d2b 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.feature/feature.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.jgit"
label="%featureName"
- version="3.7.0.qualifier"
+ version="4.0.0.qualifier"
provider-name="%providerName">
<description url="http://www.eclipse.org/jgit/">
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.feature/pom.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.feature/pom.xml
index 253342255d..a6c12092d3 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.feature/pom.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.feature/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>jgit.tycho.parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.jgit.feature</groupId>
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.http.apache.feature/feature.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.http.apache.feature/feature.xml
index 71ad4ffef1..40d325d3cb 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.http.apache.feature/feature.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.http.apache.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.jgit.http.apache"
label="%featureName"
- version="3.7.0.qualifier"
+ version="4.0.0.qualifier"
provider-name="%providerName">
<description url="http://www.eclipse.org/jgit/">
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.http.apache.feature/pom.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.http.apache.feature/pom.xml
index e7dd844a2d..2fb5396b41 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.http.apache.feature/pom.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.http.apache.feature/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>jgit.tycho.parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.jgit.feature</groupId>
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.java7.feature/feature.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.java7.feature/feature.xml
index 49ddae7652..bd0f3b019a 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.java7.feature/feature.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.java7.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.jgit.java7"
label="%featureName"
- version="3.7.0.qualifier"
+ version="4.0.0.qualifier"
provider-name="%providerName">
<description url="http://www.eclipse.org/jgit/">
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.java7.feature/pom.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.java7.feature/pom.xml
index ffbbb1427c..fec2e3164c 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.java7.feature/pom.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.java7.feature/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>jgit.tycho.parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.jgit.feature</groupId>
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.junit.feature/feature.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.junit.feature/feature.xml
index 6446a2c82b..bba437523b 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.junit.feature/feature.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.junit.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.jgit.junit"
label="%featureName"
- version="3.7.0.qualifier"
+ version="4.0.0.qualifier"
provider-name="%providerName">
<description url="http://www.eclipse.org/jgit/">
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.junit.feature/pom.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.junit.feature/pom.xml
index ce3355dbc5..ed5c6b3970 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.junit.feature/pom.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.junit.feature/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>jgit.tycho.parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.jgit.feature</groupId>
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.feature/feature.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.feature/feature.xml
index 3296f502ac..df315bce3c 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.feature/feature.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.jgit.pgm"
label="%featureName"
- version="3.7.0.qualifier"
+ version="4.0.0.qualifier"
provider-name="%providerName">
<description url="http://www.eclipse.org/jgit/">
@@ -27,7 +27,7 @@
version="0.0.0"/>
<requires>
- <import feature="org.eclipse.jgit" version="3.7.0" match="equivalent"/>
+ <import feature="org.eclipse.jgit" version="4.0.0" match="equivalent"/>
</requires>
<plugin
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.feature/pom.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.feature/pom.xml
index b8ee9ac0d8..f80c8ce54b 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.feature/pom.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.feature/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>jgit.tycho.parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.jgit.feature</groupId>
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.source.feature/feature.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.source.feature/feature.xml
index 3a52006ca9..caa2b44c65 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.source.feature/feature.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.source.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.jgit.pgm.source"
label="%featureName"
- version="3.7.0.qualifier"
+ version="4.0.0.qualifier"
provider-name="%providerName">
<description url="http://www.eclipse.org/jgit/">
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.source.feature/pom.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.source.feature/pom.xml
index c3b8150f45..d914825303 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.source.feature/pom.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.pgm.source.feature/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>jgit.tycho.parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.jgit.feature</groupId>
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.repository/pom.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.repository/pom.xml
index 96d74e5b35..f2aa7af61a 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.repository/pom.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.repository/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>jgit.tycho.parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.repository</artifactId>
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.source.feature/feature.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.source.feature/feature.xml
index b1eb163dfd..937c0fdbe2 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.source.feature/feature.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.source.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.jgit.source"
label="%featureName"
- version="3.7.0.qualifier"
+ version="4.0.0.qualifier"
provider-name="%providerName">
<description url="http://www.eclipse.org/jgit/">
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.source.feature/pom.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.source.feature/pom.xml
index 257495510c..69db69f208 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.source.feature/pom.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.source.feature/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>jgit.tycho.parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<groupId>org.eclipse.jgit.feature</groupId>
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.target/META-INF/MANIFEST.MF b/org.eclipse.jgit.packaging/org.eclipse.jgit.target/META-INF/MANIFEST.MF
index 46dcb3ff9f..0550f9a069 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.target/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.target/META-INF/MANIFEST.MF
@@ -2,4 +2,4 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: JGit Target Platform Bundle
Bundle-SymbolicName: org.eclipse.jgit.target
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
diff --git a/org.eclipse.jgit.packaging/org.eclipse.jgit.target/pom.xml b/org.eclipse.jgit.packaging/org.eclipse.jgit.target/pom.xml
index f303f08bf9..b3e7d02c6a 100644
--- a/org.eclipse.jgit.packaging/org.eclipse.jgit.target/pom.xml
+++ b/org.eclipse.jgit.packaging/org.eclipse.jgit.target/pom.xml
@@ -49,7 +49,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>jgit.tycho.parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.target</artifactId>
diff --git a/org.eclipse.jgit.packaging/pom.xml b/org.eclipse.jgit.packaging/pom.xml
index 66adffa9d2..40d9ceba63 100644
--- a/org.eclipse.jgit.packaging/pom.xml
+++ b/org.eclipse.jgit.packaging/pom.xml
@@ -53,7 +53,7 @@
<groupId>org.eclipse.jgit</groupId>
<artifactId>jgit.tycho.parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
<packaging>pom</packaging>
<name>JGit Tycho Parent</name>
diff --git a/org.eclipse.jgit.pgm.test/META-INF/MANIFEST.MF b/org.eclipse.jgit.pgm.test/META-INF/MANIFEST.MF
index 1289f98ae0..d43ff09101 100644
--- a/org.eclipse.jgit.pgm.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.pgm.test/META-INF/MANIFEST.MF
@@ -2,27 +2,27 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit.pgm.test
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %provider_name
Bundle-Localization: plugin
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: org.eclipse.jgit.api;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.api.errors;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.diff;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.dircache;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.junit;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.lib;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.merge;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.pgm;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.pgm.internal;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.pgm.opt;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revwalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.storage.file;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.treewalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util.io;version="[3.7.0,3.8.0)",
+Import-Package: org.eclipse.jgit.api;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.api.errors;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.diff;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.dircache;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.junit;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.lib;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.merge;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.pgm;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.pgm.internal;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.pgm.opt;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revwalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.storage.file;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.treewalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util.io;version="[4.0.0,4.1.0)",
org.hamcrest.core;bundle-version="[1.1.0,2.0.0)",
org.junit;version="[4.4.0,5.0.0)",
org.kohsuke.args4j;version="[2.0.12,2.1.0)"
diff --git a/org.eclipse.jgit.pgm.test/pom.xml b/org.eclipse.jgit.pgm.test/pom.xml
index 2a87690fb6..bd4317c1b1 100644
--- a/org.eclipse.jgit.pgm.test/pom.xml
+++ b/org.eclipse.jgit.pgm.test/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.pgm.test</artifactId>
diff --git a/org.eclipse.jgit.pgm/META-INF/MANIFEST.MF b/org.eclipse.jgit.pgm/META-INF/MANIFEST.MF
index a8ff1b8840..a701e38210 100644
--- a/org.eclipse.jgit.pgm/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.pgm/META-INF/MANIFEST.MF
@@ -2,43 +2,43 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit.pgm
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %provider_name
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Import-Package: org.apache.commons.compress.archivers;version="[1.3,2.0)",
org.apache.commons.compress.archivers.tar;version="[1.3,2.0)",
org.apache.commons.compress.archivers.zip;version="[1.3,2.0)",
- org.eclipse.jgit.api;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.api.errors;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.archive;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.awtui;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.blame;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.diff;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.dircache;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.errors;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.gitrepo;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal.storage.file;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal.storage.pack;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.lib;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.merge;version="3.7.0",
- org.eclipse.jgit.nls;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.notes;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revplot;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revwalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revwalk.filter;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.storage.file;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.storage.pack;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport.resolver;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.treewalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.treewalk.filter;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util.io;version="[3.7.0,3.8.0)",
+ org.eclipse.jgit.api;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.api.errors;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.archive;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.awtui;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.blame;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.diff;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.dircache;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.errors;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.gitrepo;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal.storage.file;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal.storage.pack;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.lib;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.merge;version="4.0.0",
+ org.eclipse.jgit.nls;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.notes;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revplot;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revwalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revwalk.filter;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.storage.file;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.storage.pack;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport.resolver;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.treewalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.treewalk.filter;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util.io;version="[4.0.0,4.1.0)",
org.kohsuke.args4j;version="[2.0.12,2.1.0)",
org.kohsuke.args4j.spi;version="[2.0.12,2.1.0)"
Bundle-ActivationPolicy: lazy
-Export-Package: org.eclipse.jgit.pgm;version="3.7.0";
+Export-Package: org.eclipse.jgit.pgm;version="4.0.0";
uses:="org.eclipse.jgit.revwalk,
org.eclipse.jgit.treewalk.filter,
org.eclipse.jgit.pgm.opt,
@@ -49,10 +49,10 @@ Export-Package: org.eclipse.jgit.pgm;version="3.7.0";
org.eclipse.jgit.treewalk,
javax.swing,
org.eclipse.jgit.transport",
- org.eclipse.jgit.pgm.debug;version="3.7.0";
+ org.eclipse.jgit.pgm.debug;version="4.0.0";
uses:="org.eclipse.jgit.pgm",
- org.eclipse.jgit.pgm.internal;version="3.7.0";x-friends:="org.eclipse.jgit.pgm.test,org.eclipse.jgit.test",
- org.eclipse.jgit.pgm.opt;version="3.7.0";
+ org.eclipse.jgit.pgm.internal;version="4.0.0";x-friends:="org.eclipse.jgit.pgm.test,org.eclipse.jgit.test",
+ org.eclipse.jgit.pgm.opt;version="4.0.0";
uses:="org.eclipse.jgit.lib,
org.eclipse.jgit.revwalk,
org.kohsuke.args4j.spi,
diff --git a/org.eclipse.jgit.pgm/META-INF/SOURCE-MANIFEST.MF b/org.eclipse.jgit.pgm/META-INF/SOURCE-MANIFEST.MF
index d1ba9ca4fb..6810b9ff43 100644
--- a/org.eclipse.jgit.pgm/META-INF/SOURCE-MANIFEST.MF
+++ b/org.eclipse.jgit.pgm/META-INF/SOURCE-MANIFEST.MF
@@ -3,5 +3,5 @@ Bundle-ManifestVersion: 2
Bundle-Name: org.eclipse.jgit.pgm - Sources
Bundle-SymbolicName: org.eclipse.jgit.pgm.source
Bundle-Vendor: Eclipse.org - JGit
-Bundle-Version: 3.7.0.qualifier
-Eclipse-SourceBundle: org.eclipse.jgit.pgm;version="3.7.0.qualifier";roots="."
+Bundle-Version: 4.0.0.qualifier
+Eclipse-SourceBundle: org.eclipse.jgit.pgm;version="4.0.0.qualifier";roots="."
diff --git a/org.eclipse.jgit.pgm/pom.xml b/org.eclipse.jgit.pgm/pom.xml
index 53dc7744aa..c6dc83f65c 100644
--- a/org.eclipse.jgit.pgm/pom.xml
+++ b/org.eclipse.jgit.pgm/pom.xml
@@ -50,7 +50,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.pgm</artifactId>
diff --git a/org.eclipse.jgit.test/META-INF/MANIFEST.MF b/org.eclipse.jgit.test/META-INF/MANIFEST.MF
index af40e883cd..2e7ed203f7 100644
--- a/org.eclipse.jgit.test/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.test/META-INF/MANIFEST.MF
@@ -2,50 +2,50 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit.test
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Localization: plugin
Bundle-Vendor: %provider_name
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Import-Package: com.googlecode.javaewah;version="[0.7.9,0.8.0)",
- org.eclipse.jgit.api;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.api.errors;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.attributes;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.awtui;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.blame;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.console;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.diff;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.dircache;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.errors;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.events;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.fnmatch;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.gitrepo;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.ignore;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.ignore.internal;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal.storage.dfs;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal.storage.file;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.internal.storage.pack;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.junit;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.lib;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.merge;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.nls;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.notes;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.patch;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.pgm;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.pgm.internal;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revplot;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revwalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revwalk.filter;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.storage.file;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.storage.pack;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.submodule;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport.http;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.treewalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.treewalk.filter;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util.io;version="[3.7.0,3.8.0)",
+ org.eclipse.jgit.api;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.api.errors;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.attributes;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.awtui;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.blame;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.console;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.diff;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.dircache;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.errors;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.events;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.fnmatch;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.gitrepo;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.ignore;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.ignore.internal;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal.storage.dfs;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal.storage.file;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.internal.storage.pack;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.junit;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.lib;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.merge;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.nls;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.notes;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.patch;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.pgm;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.pgm.internal;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revplot;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revwalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revwalk.filter;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.storage.file;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.storage.pack;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.submodule;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport.http;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.treewalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.treewalk.filter;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util.io;version="[4.0.0,4.1.0)",
org.hamcrest;version="[1.1.0,2.0.0)",
org.junit;version="[4.4.0,5.0.0)",
org.junit.experimental.theories;version="[4.4.0,5.0.0)",
diff --git a/org.eclipse.jgit.test/pom.xml b/org.eclipse.jgit.test/pom.xml
index 1d33337939..f31f0f5571 100644
--- a/org.eclipse.jgit.test/pom.xml
+++ b/org.eclipse.jgit.test/pom.xml
@@ -52,7 +52,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.test</artifactId>
diff --git a/org.eclipse.jgit.ui/META-INF/MANIFEST.MF b/org.eclipse.jgit.ui/META-INF/MANIFEST.MF
index ff33691ebc..773f8b8e9d 100644
--- a/org.eclipse.jgit.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit.ui/META-INF/MANIFEST.MF
@@ -3,14 +3,14 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit.ui
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Vendor: %provider_name
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Export-Package: org.eclipse.jgit.awtui;version="3.7.0"
-Import-Package: org.eclipse.jgit.errors;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.lib;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.nls;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revplot;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.revwalk;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.transport;version="[3.7.0,3.8.0)",
- org.eclipse.jgit.util;version="[3.7.0,3.8.0)"
+Export-Package: org.eclipse.jgit.awtui;version="4.0.0"
+Import-Package: org.eclipse.jgit.errors;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.lib;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.nls;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revplot;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.revwalk;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.transport;version="[4.0.0,4.1.0)",
+ org.eclipse.jgit.util;version="[4.0.0,4.1.0)"
diff --git a/org.eclipse.jgit.ui/pom.xml b/org.eclipse.jgit.ui/pom.xml
index a808eb42b1..df364d7cd2 100644
--- a/org.eclipse.jgit.ui/pom.xml
+++ b/org.eclipse.jgit.ui/pom.xml
@@ -52,7 +52,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit.ui</artifactId>
diff --git a/org.eclipse.jgit/META-INF/MANIFEST.MF b/org.eclipse.jgit/META-INF/MANIFEST.MF
index eea13ec7be..eeb9a952a7 100644
--- a/org.eclipse.jgit/META-INF/MANIFEST.MF
+++ b/org.eclipse.jgit/META-INF/MANIFEST.MF
@@ -2,10 +2,10 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %plugin_name
Bundle-SymbolicName: org.eclipse.jgit
-Bundle-Version: 3.7.0.qualifier
+Bundle-Version: 4.0.0.qualifier
Bundle-Localization: plugin
Bundle-Vendor: %provider_name
-Export-Package: org.eclipse.jgit.api;version="3.7.0";
+Export-Package: org.eclipse.jgit.api;version="4.0.0";
uses:="org.eclipse.jgit.revwalk,
org.eclipse.jgit.treewalk.filter,
org.eclipse.jgit.diff,
@@ -19,53 +19,53 @@ Export-Package: org.eclipse.jgit.api;version="3.7.0";
org.eclipse.jgit.submodule,
org.eclipse.jgit.transport,
org.eclipse.jgit.merge",
- org.eclipse.jgit.api.errors;version="3.7.0";
+ org.eclipse.jgit.api.errors;version="4.0.0";
uses:="org.eclipse.jgit.lib,org.eclipse.jgit.errors",
- org.eclipse.jgit.attributes;version="3.7.0",
- org.eclipse.jgit.blame;version="3.7.0";
+ org.eclipse.jgit.attributes;version="4.0.0",
+ org.eclipse.jgit.blame;version="4.0.0";
uses:="org.eclipse.jgit.lib,
org.eclipse.jgit.revwalk,
org.eclipse.jgit.treewalk.filter,
org.eclipse.jgit.diff",
- org.eclipse.jgit.diff;version="3.7.0";
+ org.eclipse.jgit.diff;version="4.0.0";
uses:="org.eclipse.jgit.patch,
org.eclipse.jgit.lib,
org.eclipse.jgit.treewalk,
org.eclipse.jgit.revwalk,
org.eclipse.jgit.treewalk.filter,
org.eclipse.jgit.util",
- org.eclipse.jgit.dircache;version="3.7.0";
+ org.eclipse.jgit.dircache;version="4.0.0";
uses:="org.eclipse.jgit.lib,
org.eclipse.jgit.treewalk,
org.eclipse.jgit.util,
org.eclipse.jgit.events,
org.eclipse.jgit.attributes",
- org.eclipse.jgit.errors;version="3.7.0";
+ org.eclipse.jgit.errors;version="4.0.0";
uses:="org.eclipse.jgit.lib,
org.eclipse.jgit.internal.storage.pack,
org.eclipse.jgit.transport,
org.eclipse.jgit.dircache",
- org.eclipse.jgit.events;version="3.7.0";
+ org.eclipse.jgit.events;version="4.0.0";
uses:="org.eclipse.jgit.lib",
- org.eclipse.jgit.fnmatch;version="3.7.0",
- org.eclipse.jgit.gitrepo;version="3.7.0";
+ org.eclipse.jgit.fnmatch;version="4.0.0",
+ org.eclipse.jgit.gitrepo;version="4.0.0";
uses:="org.eclipse.jgit.api,
org.eclipse.jgit.lib,
org.eclipse.jgit.revwalk",
- org.eclipse.jgit.gitrepo.internal;version="3.7.0";x-internal:=true,
- org.eclipse.jgit.ignore;version="3.7.0",
- org.eclipse.jgit.ignore.internal;version="3.7.0";x-friends:="org.eclipse.jgit.test",
- org.eclipse.jgit.internal;version="3.7.0";x-friends:="org.eclipse.jgit.test,org.eclipse.jgit.http.test",
- org.eclipse.jgit.internal.storage.dfs;version="3.7.0";x-friends:="org.eclipse.jgit.test",
- org.eclipse.jgit.internal.storage.file;version="3.7.0";
+ org.eclipse.jgit.gitrepo.internal;version="4.0.0";x-internal:=true,
+ org.eclipse.jgit.ignore;version="4.0.0",
+ org.eclipse.jgit.ignore.internal;version="4.0.0";x-friends:="org.eclipse.jgit.test",
+ org.eclipse.jgit.internal;version="4.0.0";x-friends:="org.eclipse.jgit.test,org.eclipse.jgit.http.test",
+ org.eclipse.jgit.internal.storage.dfs;version="4.0.0";x-friends:="org.eclipse.jgit.test",
+ org.eclipse.jgit.internal.storage.file;version="4.0.0";
x-friends:="org.eclipse.jgit.test,
org.eclipse.jgit.junit,
org.eclipse.jgit.junit.http,
org.eclipse.jgit.http.server,
org.eclipse.jgit.java7.test,
org.eclipse.jgit.pgm",
- org.eclipse.jgit.internal.storage.pack;version="3.7.0";x-friends:="org.eclipse.jgit.junit,org.eclipse.jgit.test,org.eclipse.jgit.pgm",
- org.eclipse.jgit.lib;version="3.7.0";
+ org.eclipse.jgit.internal.storage.pack;version="4.0.0";x-friends:="org.eclipse.jgit.junit,org.eclipse.jgit.test,org.eclipse.jgit.pgm",
+ org.eclipse.jgit.lib;version="4.0.0";
uses:="org.eclipse.jgit.revwalk,
org.eclipse.jgit.treewalk.filter,
org.eclipse.jgit.util,
@@ -75,41 +75,41 @@ Export-Package: org.eclipse.jgit.api;version="3.7.0";
org.eclipse.jgit.treewalk,
org.eclipse.jgit.transport,
org.eclipse.jgit.submodule",
- org.eclipse.jgit.merge;version="3.7.0";
+ org.eclipse.jgit.merge;version="4.0.0";
uses:="org.eclipse.jgit.lib,
org.eclipse.jgit.treewalk,
org.eclipse.jgit.revwalk,
org.eclipse.jgit.diff,
org.eclipse.jgit.dircache,
org.eclipse.jgit.api",
- org.eclipse.jgit.nls;version="3.7.0",
- org.eclipse.jgit.notes;version="3.7.0";
+ org.eclipse.jgit.nls;version="4.0.0",
+ org.eclipse.jgit.notes;version="4.0.0";
uses:="org.eclipse.jgit.lib,
org.eclipse.jgit.treewalk,
org.eclipse.jgit.revwalk,
org.eclipse.jgit.merge",
- org.eclipse.jgit.patch;version="3.7.0";
+ org.eclipse.jgit.patch;version="4.0.0";
uses:="org.eclipse.jgit.lib,org.eclipse.jgit.diff",
- org.eclipse.jgit.revplot;version="3.7.0";
+ org.eclipse.jgit.revplot;version="4.0.0";
uses:="org.eclipse.jgit.lib,
org.eclipse.jgit.revwalk",
- org.eclipse.jgit.revwalk;version="3.7.0";
+ org.eclipse.jgit.revwalk;version="4.0.0";
uses:="org.eclipse.jgit.lib,
org.eclipse.jgit.treewalk,
org.eclipse.jgit.treewalk.filter,
org.eclipse.jgit.diff,
org.eclipse.jgit.revwalk.filter",
- org.eclipse.jgit.revwalk.filter;version="3.7.0";
+ org.eclipse.jgit.revwalk.filter;version="4.0.0";
uses:="org.eclipse.jgit.revwalk,org.eclipse.jgit.util",
- org.eclipse.jgit.storage.file;version="3.7.0";
+ org.eclipse.jgit.storage.file;version="4.0.0";
uses:="org.eclipse.jgit.lib,org.eclipse.jgit.util",
- org.eclipse.jgit.storage.pack;version="3.7.0";
+ org.eclipse.jgit.storage.pack;version="4.0.0";
uses:="org.eclipse.jgit.lib",
- org.eclipse.jgit.submodule;version="3.7.0";
+ org.eclipse.jgit.submodule;version="4.0.0";
uses:="org.eclipse.jgit.lib,
org.eclipse.jgit.treewalk.filter,
org.eclipse.jgit.treewalk",
- org.eclipse.jgit.transport;version="3.7.0";
+ org.eclipse.jgit.transport;version="4.0.0";
uses:="org.eclipse.jgit.transport.resolver,
org.eclipse.jgit.revwalk,
org.eclipse.jgit.internal.storage.pack,
@@ -121,26 +121,26 @@ Export-Package: org.eclipse.jgit.api;version="3.7.0";
org.eclipse.jgit.transport.http,
org.eclipse.jgit.errors,
org.eclipse.jgit.storage.pack",
- org.eclipse.jgit.transport.http;version="3.7.0";
+ org.eclipse.jgit.transport.http;version="4.0.0";
uses:="javax.net.ssl",
- org.eclipse.jgit.transport.resolver;version="3.7.0";
+ org.eclipse.jgit.transport.resolver;version="4.0.0";
uses:="org.eclipse.jgit.lib,
org.eclipse.jgit.transport",
- org.eclipse.jgit.treewalk;version="3.7.0";
+ org.eclipse.jgit.treewalk;version="4.0.0";
uses:="org.eclipse.jgit.lib,
org.eclipse.jgit.revwalk,
org.eclipse.jgit.attributes,
org.eclipse.jgit.treewalk.filter,
org.eclipse.jgit.util,
org.eclipse.jgit.dircache",
- org.eclipse.jgit.treewalk.filter;version="3.7.0";
+ org.eclipse.jgit.treewalk.filter;version="4.0.0";
uses:="org.eclipse.jgit.treewalk",
- org.eclipse.jgit.util;version="3.7.0";
+ org.eclipse.jgit.util;version="4.0.0";
uses:="org.eclipse.jgit.lib,
org.eclipse.jgit.transport.http,
org.eclipse.jgit.storage.file,
org.ietf.jgss",
- org.eclipse.jgit.util.io;version="3.7.0"
+ org.eclipse.jgit.util.io;version="4.0.0"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: com.jcraft.jsch;bundle-version="[0.1.37,0.2.0)"
diff --git a/org.eclipse.jgit/META-INF/SOURCE-MANIFEST.MF b/org.eclipse.jgit/META-INF/SOURCE-MANIFEST.MF
index ddb1e57d56..41b6066630 100644
--- a/org.eclipse.jgit/META-INF/SOURCE-MANIFEST.MF
+++ b/org.eclipse.jgit/META-INF/SOURCE-MANIFEST.MF
@@ -3,5 +3,5 @@ Bundle-ManifestVersion: 2
Bundle-Name: org.eclipse.jgit - Sources
Bundle-SymbolicName: org.eclipse.jgit.source
Bundle-Vendor: Eclipse.org - JGit
-Bundle-Version: 3.7.0.qualifier
-Eclipse-SourceBundle: org.eclipse.jgit;version="3.7.0.qualifier";roots="."
+Bundle-Version: 4.0.0.qualifier
+Eclipse-SourceBundle: org.eclipse.jgit;version="4.0.0.qualifier";roots="."
diff --git a/org.eclipse.jgit/pom.xml b/org.eclipse.jgit/pom.xml
index 36a579ec22..02af2c199b 100644
--- a/org.eclipse.jgit/pom.xml
+++ b/org.eclipse.jgit/pom.xml
@@ -53,7 +53,7 @@
<parent>
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.jgit</artifactId>
diff --git a/pom.xml b/pom.xml
index d222dc2ba4..79e905ccd1 100644
--- a/pom.xml
+++ b/pom.xml
@@ -51,7 +51,7 @@
<groupId>org.eclipse.jgit</groupId>
<artifactId>org.eclipse.jgit-parent</artifactId>
<packaging>pom</packaging>
- <version>3.7.0-SNAPSHOT</version>
+ <version>4.0.0-SNAPSHOT</version>
<name>JGit - Parent</name>
<url>${jgit-url}</url>

Back to the top