Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Erdfelt2013-08-05 16:53:48 +0000
committerJoakim Erdfelt2013-08-05 16:53:48 +0000
commit8636c7da4588db00404a0959b738faa4483f5cdf (patch)
tree6e74dd0878847b4e37f91302740634d7199cc8bd /pom.xml
parentdfd3d5af29cb45098266fc32465e94b226867c3d (diff)
parent74991f90d6498aa8c170b768d843c010a1064b09 (diff)
downloadorg.eclipse.jetty.project-8636c7da4588db00404a0959b738faa4483f5cdf.tar.gz
org.eclipse.jetty.project-8636c7da4588db00404a0959b738faa4483f5cdf.tar.xz
org.eclipse.jetty.project-8636c7da4588db00404a0959b738faa4483f5cdf.zip
Merge branch 'master' into jetty-9.1
Conflicts: jetty-maven-plugin/pom.xml pom.xml
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml16
1 files changed, 8 insertions, 8 deletions
diff --git a/pom.xml b/pom.xml
index 45e04b3929..43202cae52 100644
--- a/pom.xml
+++ b/pom.xml
@@ -137,7 +137,7 @@
</configuration>
</execution>
<execution>
- <id>ban-junit.jar</id>
+ <id>ban-junit-dep.jar</id>
<goals>
<goal>enforce</goal>
</goals>
@@ -145,10 +145,10 @@
<rules>
<bannedDependencies>
<excludes>
- <exclude>junit:junit:*:jar</exclude>
+ <exclude>junit:junit-dep:*:jar</exclude>
</excludes>
<searchTransitive>true</searchTransitive>
- <message>We use junit-dep.jar, not junit.jar (as the standard junit.jar aggregates too many 3rd party libs inside of it)</message>
+ <message>We use junit.jar, not junit-dep.jar (as of junit 4.11, hamcrest is no longer embedded)</message>
</bannedDependencies>
</rules>
</configuration>
@@ -553,7 +553,7 @@
<dependency>
<groupId>org.eclipse.jetty.toolchain</groupId>
<artifactId>jetty-test-helper</artifactId>
- <version>2.3</version>
+ <version>2.5</version>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
@@ -575,7 +575,7 @@
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
- <version>4.8.1</version>
+ <version>4.11</version>
</dependency>
-->
<dependency>
@@ -586,17 +586,17 @@
<dependency>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-core</artifactId>
- <version>1.2.1</version>
+ <version>1.3</version>
</dependency>
<dependency>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-library</artifactId>
- <version>1.2.1</version>
+ <version>1.3</version>
</dependency>
<dependency>
<groupId>org.mockito</groupId>
<artifactId>mockito-core</artifactId>
- <version>1.8.5</version>
+ <version>1.9.5</version>
<exclusions>
<exclusion>
<groupId>junit</groupId>

Back to the top