Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Collier2017-11-27 21:48:12 +0000
committerJohn Collier2017-11-27 21:48:12 +0000
commit3a73dcb05327d686759bfcf66e3cfee1951c5b3d (patch)
tree3e106c2ec5115dcfbdd5ee56afc395f184af1e0a /plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet
parent501464a3c699bea9bc75afd2d632d5bf5ce31ff9 (diff)
downloadwebtools.javaee-3a73dcb05327d686759bfcf66e3cfee1951c5b3d.tar.gz
webtools.javaee-3a73dcb05327d686759bfcf66e3cfee1951c5b3d.tar.xz
webtools.javaee-3a73dcb05327d686759bfcf66e3cfee1951c5b3d.zip
Bug 527825: Allow for Servlet 3.1 listeners to be added to EE8 projects
This patch updates the Filter/Listener/Servlet wizard pages to allow for them to be added to Web 4.0 projects in WTP. Signed-off-by: John Collier <John.J.Collier@ibm.com>
Diffstat (limited to 'plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet')
-rw-r--r--plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddFilterWizardPage.java2
-rw-r--r--plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddListenerWizardPage.java2
-rw-r--r--plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddServletWizardPage.java2
3 files changed, 3 insertions, 3 deletions
diff --git a/plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddFilterWizardPage.java b/plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddFilterWizardPage.java
index c6cc7907e..11335ac6d 100644
--- a/plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddFilterWizardPage.java
+++ b/plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddFilterWizardPage.java
@@ -178,7 +178,7 @@ public class AddFilterWizardPage extends DataModelWizardPage {
public void setVisible(boolean visible) {
super.setVisible(visible);
String javaEEVersion = model.getStringProperty(INewServletClassDataModelProperties.JAVA_EE_VERSION);
- if("3.0".equals(javaEEVersion) || "3.1".equals(javaEEVersion)){ //$NON-NLS-1$ //$NON-NLS-2$
+ if("3.0".equals(javaEEVersion) || "3.1".equals(javaEEVersion) || "4.0".equals(javaEEVersion)){ //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
asyncSupportCheckBox.setVisible(true);
}
else
diff --git a/plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddListenerWizardPage.java b/plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddListenerWizardPage.java
index 13fac9025..987615e93 100644
--- a/plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddListenerWizardPage.java
+++ b/plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddListenerWizardPage.java
@@ -276,7 +276,7 @@ public class AddListenerWizardPage extends DataModelWizardPage {
public void setVisible(boolean visible) {
super.setVisible(visible);
String javaEEVersion = model.getStringProperty(INewServletClassDataModelProperties.JAVA_EE_VERSION);
- if("3.1".equals(javaEEVersion)){ //$NON-NLS-1$
+ if("3.1".equals(javaEEVersion) || "4.0".equals(javaEEVersion)){ //$NON-NLS-1$ //$NON-NLS-2$
setServlet31ListenersVisible(true);
}
else{
diff --git a/plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddServletWizardPage.java b/plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddServletWizardPage.java
index 9df611ad2..6140d85ef 100644
--- a/plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddServletWizardPage.java
+++ b/plugins/org.eclipse.jst.servlet.ui/servlet_ui/org/eclipse/jst/servlet/ui/internal/wizard/AddServletWizardPage.java
@@ -217,7 +217,7 @@ public class AddServletWizardPage extends DataModelWizardPage {
public void setVisible(boolean visible) {
super.setVisible(visible);
String javaEEVersion = model.getStringProperty(INewServletClassDataModelProperties.JAVA_EE_VERSION);
- if("3.0".equals(javaEEVersion) || "3.1".equals(javaEEVersion)){ //$NON-NLS-1$ //$NON-NLS-2$
+ if("3.0".equals(javaEEVersion) || "3.1".equals(javaEEVersion) || "4.0".equals(javaEEVersion)){ //$NON-NLS-1$ //$NON-NLS-2$ //$NON-NLS-3$
asyncSupportCheckBox.setVisible(true);
}
else

Back to the top