Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xfeatures/org.eclipse.gmf.tooling-feature/feature.xml99
1 files changed, 93 insertions, 6 deletions
diff --git a/features/org.eclipse.gmf.tooling-feature/feature.xml b/features/org.eclipse.gmf.tooling-feature/feature.xml
index 0b1dbf422..a233f723b 100755
--- a/features/org.eclipse.gmf.tooling-feature/feature.xml
+++ b/features/org.eclipse.gmf.tooling-feature/feature.xml
@@ -27,12 +27,99 @@ http://www.eclipse.org/legal/epl-v10.html
</url>
<requires>
- <import feature="org.eclipse.emf" version="2.3.0"/>
- <import feature="org.eclipse.gef" version="3.3.0"/>
- <import feature="org.eclipse.ocl" version="1.1.0"/>
- <import feature="org.eclipse.emf.validation" version="1.1.0"/>
- <import feature="org.eclipse.gmf" version="1.1.0"/>
- <import feature="org.eclipse.m2m.qvt.oml.sdk" version="2.0.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.core.runtime" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.common.ui" version="2.3.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.codegen" version="2.3.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.codegen.ecore" version="2.3.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.ecore.xmi" version="2.3.0" match="compatible"/>
+ <import plugin="org.eclipse.core.resources" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.ui.ide" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.ui.forms" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.jdt.core" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.jface.text" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.jface" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.jdt.ui" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.xpand" version="2.0.0" match="compatible"/>
+ <import plugin="org.eclipse.core.runtime" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.core.resources" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.ecore" version="2.4.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.codegen.ecore" version="2.4.0" match="compatible"/>
+ <import plugin="org.eclipse.draw2d" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.common" version="1.1.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.validate" version="1.1.0" match="compatible"/>
+ <import plugin="org.eclipse.m2m.qvt.oml" version="2.0.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.codegen" version="2.0.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.edit" version="2.4.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.ecore.xmi" version="2.4.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.edit.ui" version="2.4.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.codegen.ecore.ui" version="2.3.0" match="compatible"/>
+ <import plugin="org.eclipse.ui" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.bridge" version="1.1.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.bridge.ui.dashboard" version="2.0.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.codegen.edit" version="2.0.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.graphdef.codegen.ui" version="1.0.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.importer" version="2.3.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.bridge.ui" version="1.1.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.graphdef" version="2.0.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.tooldef" version="2.0.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.map" version="2.0.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.graphdef.edit" version="2.0.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.tooldef.edit" version="2.0.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.ecore.edit" version="2.4.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.runtime.notation" version="1.0.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.graphdef.codegen" version="2.0.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.common" version="2.3.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.ecore.edit" version="2.3.0" match="compatible"/>
+ <import plugin="org.eclipse.gmf.map.edit" version="2.0.0" match="compatible"/>
+ <import plugin="org.eclipse.m2m.qvt.oml.runtime" version="1.0.100" match="compatible"/>
+ <import plugin="org.eclipse.emf.ecore.editor" version="2.3.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.ecore" version="2.3.0" match="compatible"/>
+ <import plugin="org.eclipse.pde.ui" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.pde.core" version="3.3.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.edit" version="2.3.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.edit.ui" version="2.3.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.validation" version="1.1.0" match="compatible"/>
+ <import plugin="org.eclipse.ocl.ecore" version="1.1.0" match="compatible"/>
+ <import plugin="org.eclipse.core.expressions"/>
+ <import plugin="org.eclipse.ui.views"/>
+ <import plugin="org.eclipse.ui.navigator"/>
+ <import plugin="org.eclipse.gef"/>
+ <import plugin="org.eclipse.gmf.runtime.emf.core"/>
+ <import plugin="org.eclipse.gmf.runtime.emf.commands.core"/>
+ <import plugin="org.eclipse.gmf.runtime.emf.ui.properties"/>
+ <import plugin="org.eclipse.gmf.runtime.diagram.ui"/>
+ <import plugin="org.eclipse.gmf.runtime.diagram.ui.printing.render"/>
+ <import plugin="org.eclipse.gmf.runtime.diagram.ui.printing"/>
+ <import plugin="org.eclipse.gmf.runtime.diagram.ui.properties"/>
+ <import plugin="org.eclipse.gmf.runtime.diagram.ui.providers"/>
+ <import plugin="org.eclipse.gmf.runtime.diagram.ui.providers.ide"/>
+ <import plugin="org.eclipse.gmf.runtime.diagram.ui.render"/>
+ <import plugin="org.eclipse.gmf.runtime.diagram.ui.resources.editor"/>
+ <import plugin="org.eclipse.gmf.runtime.diagram.ui.resources.editor.ide"/>
+ <import plugin="org.eclipse.gmf.runtime.draw2d.ui"/>
+ <import plugin="org.eclipse.ui.navigator.resources"/>
+ <import plugin="org.eclipse.emf.ecore" version="2.2.0" match="compatible"/>
+ <import plugin="net.sourceforge.lpg.lpgjavaruntime" version="1.1.0" match="compatible"/>
+ <import plugin="org.eclipse.m2m.qvt.oml.common" version="1.0.100" match="compatible"/>
+ <import plugin="org.eclipse.m2m.qvt.oml.emf.util" version="1.0.100" match="compatible"/>
+ <import plugin="org.eclipse.gmf.xpand.qvtlibrary" version="1.0.0" match="compatible"/>
+ <import plugin="org.eclipse.core.filebuffers"/>
+ <import plugin="org.eclipse.core.jobs"/>
+ <import plugin="org.eclipse.osgi"/>
+ <import plugin="org.eclipse.ui" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.text" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.jface.text" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.ui.editors" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.ui.workbench.texteditor" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.ui.views" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.ui.ide" version="3.2.0" match="compatible"/>
+ <import plugin="org.eclipse.ocl.ecore" version="1.3.0" match="compatible"/>
+ <import plugin="org.eclipse.emf.ecore" version="2.4.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.ocl.ecore" version="1.2.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.text" version="3.4.100" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.ui.ide" version="3.4.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.jdt.core" version="3.5.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.m2m.qvt.oml" version="2.0.0" match="greaterOrEqual"/>
</requires>
<plugin

Back to the top