Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Ross2013-12-09 16:02:54 +0000
committerJohn Ross2013-12-09 16:02:54 +0000
commit4c6549e6614839f60134514c87ed6722b1cf1b3a (patch)
tree3bbc4edd28059f2e8a11a1e65547c748beb8a546 /bundles/org.eclipse.osgi/supplement
parent657ca124941d2871ac0fc9d0146e1e645d4270ec (diff)
downloadrt.equinox.framework-4c6549e6614839f60134514c87ed6722b1cf1b3a.tar.gz
rt.equinox.framework-4c6549e6614839f60134514c87ed6722b1cf1b3a.tar.xz
rt.equinox.framework-4c6549e6614839f60134514c87ed6722b1cf1b3a.zip
Bug 423479 - Framework incorrectly disallows osgi.ee requirement in extension bundle
If an extension bundle contains the Require-Capability header, parse the header and throw an exception only if a namespace outside of osgi.ee is encountered. Change error message to include the offending namespace.
Diffstat (limited to 'bundles/org.eclipse.osgi/supplement')
-rw-r--r--bundles/org.eclipse.osgi/supplement/src/org/eclipse/osgi/internal/messages/ExternalMessages.properties2
1 files changed, 1 insertions, 1 deletions
diff --git a/bundles/org.eclipse.osgi/supplement/src/org/eclipse/osgi/internal/messages/ExternalMessages.properties b/bundles/org.eclipse.osgi/supplement/src/org/eclipse/osgi/internal/messages/ExternalMessages.properties
index b9d8b593f..ab873225a 100644
--- a/bundles/org.eclipse.osgi/supplement/src/org/eclipse/osgi/internal/messages/ExternalMessages.properties
+++ b/bundles/org.eclipse.osgi/supplement/src/org/eclipse/osgi/internal/messages/ExternalMessages.properties
@@ -138,7 +138,7 @@ ModuleResolver_SingletonDisabledError=Could not resolve mandatory modules becaus
OSGiManifestBuilderFactory_ExtensionImportError=Extension bundles cannot import packages.
OSGiManifestBuilderFactory_ExtensionNativeError=Extension bundles cannot have native code.
OSGiManifestBuilderFactory_ExtensionReqBundleError=Extension bundles cannot require bundles.
-OSGiManifestBuilderFactory_ExtensionReqCapError=Extension bundles cannot require capabilities.
+OSGiManifestBuilderFactory_ExtensionReqCapError=Extension bundles cannot require capabilities outside of the osgi.ee namespace: {0}.
OSGiManifestBuilderFactory_InvalidManifestError=Invalid Manifest header "{0}": {1}
SystemModule_LockError=Could not lock the system bundle state for shutdown.

Back to the top