Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Watson2017-04-28 16:49:04 +0000
committerThomas Watson2017-06-16 12:38:08 +0000
commit9c940504036225a9c7d3f869f6d1ca0f55083e50 (patch)
tree0457ec5d293c13fbbaa124dcff9bc0e06240a21a /bundles/org.eclipse.osgi.util/META-INF
parent89617708753627e2aecdea7393d64ccf24a0b0eb (diff)
downloadrt.equinox.framework-9c940504036225a9c7d3f869f6d1ca0f55083e50.tar.gz
rt.equinox.framework-9c940504036225a9c7d3f869f6d1ca0f55083e50.tar.xz
rt.equinox.framework-9c940504036225a9c7d3f869f6d1ca0f55083e50.zip
Update promise and function API to 1.1
Change-Id: I606cabb03fb6a9ea7f1aed9757a197e3d70480d8 Signed-off-by: Thomas Watson <tjwatson@us.ibm.com>
Diffstat (limited to 'bundles/org.eclipse.osgi.util/META-INF')
-rw-r--r--bundles/org.eclipse.osgi.util/META-INF/MANIFEST.MF10
1 files changed, 5 insertions, 5 deletions
diff --git a/bundles/org.eclipse.osgi.util/META-INF/MANIFEST.MF b/bundles/org.eclipse.osgi.util/META-INF/MANIFEST.MF
index 7e7bf9de7..19894f6df 100644
--- a/bundles/org.eclipse.osgi.util/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.osgi.util/META-INF/MANIFEST.MF
@@ -8,16 +8,16 @@ Bundle-Vendor: %eclipse.org
Bundle-Localization: plugin
Bundle-DocUrl: http://www.eclipse.org
Bundle-ContactAddress: www.eclipse.org
-Export-Package: org.osgi.util.function;version="1.0",
+Export-Package: org.osgi.util.function;version="1.1",
org.osgi.util.measurement;version="1.0.1",
org.osgi.util.position;version="1.0.1";uses:="org.osgi.util.measurement",
- org.osgi.util.promise;version="1.0";uses:="org.osgi.util.function",
+ org.osgi.util.promise;version="1.1";uses:="org.osgi.util.function",
org.osgi.util.xml;version="1.0.1";uses:="org.osgi.framework,javax.xml.parsers"
Import-Package: org.osgi.framework; version=1.1,
javax.xml.parsers,
- org.osgi.util.function; version="[1.0, 1.1)",
+ org.osgi.util.function; version="[1.1, 1.2)",
org.osgi.util.measurement; version="[1.0.1, 1.1)",
org.osgi.util.position; version="[1.0.1, 1.1)",
- org.osgi.util.promise; version="[1.0, 1.1)",
+ org.osgi.util.promise; version="[1.1, 1.2)",
org.osgi.util.xml; version="[1.0.1, 1.1)"
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.7

Back to the top