Skip to main content
aboutsummaryrefslogtreecommitdiffstats
blob: 267d89a94530ee5cd74fe5c96e47577ea01b01df (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %bundleName
Bundle-SymbolicName: org.eclipse.equinox.ds;singleton:=true
Bundle-Version: 1.1.0.qualifier
Bundle-Vendor: %bundleVendor
Bundle-Activator: org.eclipse.equinox.internal.ds.Activator
Bundle-Description: This bundle provides support for OSGi 
 Declarative Services. This module implements a declarative service model,
 which allows a bundle to delay instantiating the service object until
 they are needed, and thus minimizing the resource consumption at
 any point of time. That module is  also one of the core components for
 the OSGi R4.
Import-Package: 
 org.eclipse.equinox.internal.util.event;version="1.0",
 org.eclipse.equinox.internal.util.hash;version="1.0",
 org.eclipse.equinox.internal.util.pool;version="1.0",
 org.eclipse.equinox.internal.util.ref;version="1.0",
 org.eclipse.equinox.internal.util.threadpool;version="1.0",
 org.eclipse.equinox.internal.util.timer;version="1.0",
 org.eclipse.osgi.framework.console;version="1.0",
 org.eclipse.osgi.service.debug;version="1.0",
 org.eclipse.osgi.util,
 org.osgi.framework;version="1.3",
 org.osgi.service.cm;version="1.2",
 org.osgi.service.component;version="1.1",
 org.osgi.service.log;version="1.3.0",
 org.osgi.service.metatype;version="1.1",
 org.osgi.util.tracker;version="1.3"
Export-Package: 
 org.eclipse.equinox.internal.ds;x-internal:=true,
 org.eclipse.equinox.internal.ds.impl;x-internal:=true,
 org.eclipse.equinox.internal.ds.model;x-internal:=true,
 org.eclipse.equinox.internal.ds.storage.file;x-internal:=true,
 org.eclipse.equinox.internal.util.io;x-internal:=true,
 org.eclipse.equinox.internal.util.xml;x-internal:=true,
 org.eclipse.equinox.internal.util.xml.impl;x-internal:=true,
 org.eclipse.equinox.internal.util.string;x-internal:=true
Bundle-RequiredExecutionEnvironment: OSGi/Minimum-1.2,
 CDC-1.1/Foundation-1.1,
 J2SE-1.4
Lazy-ManifestFilter: (Service-Component=*)
Bundle-Localization: plugin

Back to the top