Skip to main content
aboutsummaryrefslogtreecommitdiffstats
blob: 0fc2de02db86e1f23e39f4bb5ef396849a28e575 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
#tell pde.build not to generate start levels
org.eclipse.pde.build.append.startlevels=false

#add requirement on org.eclipse.platform.ide
requires.1.namespace=org.eclipse.equinox.p2.iu
requires.1.name=org.eclipse.platform.ide
requires.1.range=[3.5.0.I20090522-1710,3.5.0.I20090522-1710]
requires.1.greedy=true

instructions.install=\
  setProgramProperty(propName:osgi.splashPath, propValue:platform:/base/plugins/org.eclipse.epp.package.pulsar);\
  setProgramProperty(propName:eclipse.product,propValue:org.eclipse.epp.package.pulsar.product);\
  setProgramProperty(propName:eclipse.application,propValue:org.eclipse.ui.ide.workbench);
  
instructions.uninstall=\
  setProgramProperty(propName:osgi.splashPath,propValue:);\
  setProgramProperty(propName:eclipse.product,propValue:);\
  setProgramProperty(propName:eclipse.application,propValue:);

Back to the top