Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/org.eclipse.epp.package.dsl.feature/feature.xml12
-rw-r--r--packages/org.eclipse.epp.package.dsl.product/epp.product7
2 files changed, 16 insertions, 3 deletions
diff --git a/packages/org.eclipse.epp.package.dsl.feature/feature.xml b/packages/org.eclipse.epp.package.dsl.feature/feature.xml
index ea98eaf6..5a9c5802 100644
--- a/packages/org.eclipse.epp.package.dsl.feature/feature.xml
+++ b/packages/org.eclipse.epp.package.dsl.feature/feature.xml
@@ -21,12 +21,22 @@
</license>
<requires>
+ <!--
+ All requirements to features and the content of the product are defined
+ in the product configuration epp.product since Eclipse Neon. For further
+ details see the following bug:
+
+ Bug 332989 - Allow parts of a package to upgraded or removed
+ https://bugs.eclipse.org/bugs/show_bug.cgi?id=332989
+
+ Since the DSL package already moved some of the dependencies to the product
+ definition, no need to change anything here.
+ -->
<import feature="org.eclipse.sdk"/>
<import feature="org.eclipse.egit"/>
<import feature="org.eclipse.egit.import"/>
<import feature="org.eclipse.m2e.feature"/>
<import feature="org.eclipse.m2e.logback.feature"/>
- <import feature="org.eclipse.epp.package.common.feature"/>
<import feature="org.eclipse.wst.xml_ui.feature"/>
<import feature="org.eclipse.buildship"/>
</requires>
diff --git a/packages/org.eclipse.epp.package.dsl.product/epp.product b/packages/org.eclipse.epp.package.dsl.product/epp.product
index 84bd2ae6..dd15b48c 100644
--- a/packages/org.eclipse.epp.package.dsl.product/epp.product
+++ b/packages/org.eclipse.epp.package.dsl.product/epp.product
@@ -186,10 +186,13 @@ Java and all Java-based trademarks are trademarks of Oracle Corporation in the U
<features>
<feature id="org.eclipse.epp.package.dsl.feature" version="4.6.0.qualifier"/>
- <feature id="org.eclipse.xtext.sdk" installMode="root"/>
+ <feature id="org.eclipse.epp.package.common.feature" version="4.6.0.qualifier"/>
+ <feature id="org.eclipse.platform" version="4.6.0.qualifier"/>
+
+ <feature id="org.eclipse.emf.ecore.xcore.sdk" installMode="root"/>
<feature id="org.eclipse.emf.mwe2.language.sdk" installMode="root"/>
<feature id="org.eclipse.emf.sdk" installMode="root"/>
- <feature id="org.eclipse.emf.ecore.xcore.sdk" installMode="root"/>
+ <feature id="org.eclipse.xtext.sdk" installMode="root"/>
</features>

Back to the top