Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc-Andre Laperle2016-04-01 21:57:29 +0000
committerMarc-Andre Laperle2016-04-01 21:57:29 +0000
commit73bb3b8fccec13ad41cac130bd974fb5f6146137 (patch)
treef235aa18a3004264174691bc1fea36cc409dbd63 /packages/org.eclipse.epp.package.cpp.feature
parent651db1d85a620d50015c4fdbf48f161888418fdb (diff)
downloadorg.eclipse.epp.packages-73bb3b8fccec13ad41cac130bd974fb5f6146137.tar.gz
org.eclipse.epp.packages-73bb3b8fccec13ad41cac130bd974fb5f6146137.tar.xz
org.eclipse.epp.packages-73bb3b8fccec13ad41cac130bd974fb5f6146137.zip
Bug 490552 - Move features that are not OS specific to top level
To be able to upgrade features, they need to be at the top level. Some features used to be installable only on Linux so they had to be put in p2.inf to be optional but some are now installable eveywhere. So the features that are not Linux-specific can be moved to the top level again. Change-Id: I96351b4be27c618184b88a596416a5ede8998e76 Signed-off-by: Marc-Andre Laperle <marc-andre.laperle@ericsson.com>
Diffstat (limited to 'packages/org.eclipse.epp.package.cpp.feature')
-rw-r--r--packages/org.eclipse.epp.package.cpp.feature/p2.inf71
1 files changed, 8 insertions, 63 deletions
diff --git a/packages/org.eclipse.epp.package.cpp.feature/p2.inf b/packages/org.eclipse.epp.package.cpp.feature/p2.inf
index 44c503a6..244dac69 100644
--- a/packages/org.eclipse.epp.package.cpp.feature/p2.inf
+++ b/packages/org.eclipse.epp.package.cpp.feature/p2.inf
@@ -6,81 +6,26 @@ requires.1.namespace=org.eclipse.equinox.p2.iu
requires.1.name=org.eclipse.platform.ide
requires.1.greedy=true
-# <import feature="org.eclipse.linuxtools.cdt.libhover.feature"/>
+# <import feature="org.eclipse.linuxtools.oprofile.feature"/>
requires.2.namespace=org.eclipse.equinox.p2.iu
-requires.2.name=org.eclipse.linuxtools.cdt.libhover.feature.feature.group
+requires.2.name=org.eclipse.linuxtools.oprofile.feature.feature.group
requires.2.optional=true
-# <import feature="org.eclipse.linuxtools.cdt.libhover.devhelp.feature"/>
+# <import feature="org.eclipse.linuxtools.perf.feature"/>
requires.3.namespace=org.eclipse.equinox.p2.iu
-requires.3.name=org.eclipse.linuxtools.cdt.libhover.devhelp.feature.feature.group
+requires.3.name=org.eclipse.linuxtools.perf.feature.feature.group
requires.3.optional=true
-# <import feature="org.eclipse.linuxtools.changelog.c"/>
+# <import feature="org.eclipse.linuxtools.systemtap"/>
requires.4.namespace=org.eclipse.equinox.p2.iu
-requires.4.name=org.eclipse.linuxtools.changelog.c.feature.group
+requires.4.name=org.eclipse.linuxtools.systemtap.feature.group
requires.4.optional=true
-# <import feature="org.eclipse.linuxtools.gprof.feature"/>
+# <import feature="org.eclipse.linuxtools.callgraph.feature"/>
requires.5.namespace=org.eclipse.equinox.p2.iu
-requires.5.name=org.eclipse.linuxtools.gprof.feature.feature.group
+requires.5.name=org.eclipse.linuxtools.callgraph.feature.feature.group
requires.5.optional=true
-# <import feature="org.eclipse.linuxtools.oprofile.feature"/>
-requires.6.namespace=org.eclipse.equinox.p2.iu
-requires.6.name=org.eclipse.linuxtools.oprofile.feature.feature.group
-requires.6.optional=true
-
-# <import feature="org.eclipse.linuxtools.perf.feature"/>
-requires.7.namespace=org.eclipse.equinox.p2.iu
-requires.7.name=org.eclipse.linuxtools.perf.feature.feature.group
-requires.7.optional=true
-
-# <import feature="org.eclipse.linuxtools.rpm"/>
-requires.8.namespace=org.eclipse.equinox.p2.iu
-requires.8.name=org.eclipse.linuxtools.rpm.feature.group
-requires.8.optional=true
-
-# <import feature="org.eclipse.linuxtools.systemtap"/>
-requires.10.namespace=org.eclipse.equinox.p2.iu
-requires.10.name=org.eclipse.linuxtools.systemtap.feature.group
-requires.10.optional=true
-
-# <import feature="org.eclipse.linuxtools.callgraph.feature"/>
-requires.11.namespace=org.eclipse.equinox.p2.iu
-requires.11.name=org.eclipse.linuxtools.callgraph.feature.feature.group
-requires.11.optional=true
-
-# <import feature="org.eclipse.linuxtools.valgrind"/>
-requires.12.namespace=org.eclipse.equinox.p2.iu
-requires.12.name=org.eclipse.linuxtools.valgrind.feature.group
-requires.12.optional=true
-
-# <import feature="org.eclipse.linuxtools.gcov"/>
-requires.13.namespace=org.eclipse.equinox.p2.iu
-requires.13.name=org.eclipse.linuxtools.gcov.feature.group
-requires.13.optional=true
-
-# <import feature="org.eclipse.tracecompass.lttng2.control"/>
-requires.14.namespace=org.eclipse.equinox.p2.iu
-requires.14.name=org.eclipse.tracecompass.lttng2.control.feature.group
-requires.14.optional=true
-
-# <import feature="org.eclipse.tracecompass.lttng2.kernel"/>
-requires.15.namespace=org.eclipse.equinox.p2.iu
-requires.15.name=org.eclipse.tracecompass.lttng2.kernel.feature.group
-requires.15.optional=true
-
-# <import feature="org.eclipse.tracecompass.gdbtrace"/>
-requires.16.namespace=org.eclipse.equinox.p2.iu
-requires.16.name=org.eclipse.tracecompass.gdbtrace.feature.group
-requires.16.optional=true
-
-# <import feature="org.eclipse.tracecompass.lttng2.ust"/>
-requires.17.namespace=org.eclipse.equinox.p2.iu
-requires.17.name=org.eclipse.tracecompass.lttng2.ust.feature.group
-requires.17.optional=true
-
# Bug 490515 - Prevent upgrade from old to new EPP package layout
# https://bugs.eclipse.org/bugs/show_bug.cgi?id=490515
#

Back to the top