Skip to main content
aboutsummaryrefslogtreecommitdiffstats
AgeCommit message (Collapse)AuthorFilesLines
7 days[580798] Support GenModel versions for 2022-09 and EMF 2.32 and JDK 20HEADmasterEd Merks1-1/+1
2022-09-10[releng] Update to build for 2022-12 (EMF/XSD 2.32)Ed Merks2-4/+4
2022-08-19[Releng] Generated changes with latest xtend.Ed Merks8-44/+44
2022-07-06[releng] Increment versionsEd Merks2-5/+5
2022-04-25[releng] Increment Xcore versions.Ed Merks1-1/+1
2022-03-25[releng] Increment versions.Ed Merks2-4/+4
2022-01-23[releng] Increment versions.Ed Merks2-5/+5
2021-09-25[576261] Support GenModel versions for 2021-12 and EMF 2.28Ed Merks1-1/+1
2021-09-24[releng] Reset version baselineEd Merks2-5/+5
Use use https://download.eclipse in instead of http://download.eclipse.org consistently.
2021-04-05[540281] Replace usage of String#replaceAll where no regexp neededEd Merks1-1/+1
Change-Id: I07b6594ad5ad0ee6c30eed429593d4419ba21713
2021-03-31[572486] Support GenModel versions for 2021-06 and EMF 2.26Ed Merks1-1/+1
Change-Id: I320b72f5ed8e203293309443dc42580298785ebd
2021-03-19[releng] More updates to enable builds for 2021-06Ed Merks2-4/+4
Reset the version baseline. Change Xcore projects to BREE 1.8 because Tycho 2.2.0 fails to build them for BREE 1.6 and we need Tycho 2.2.0 to be able to launch surefire where older Tycho versions depend on the deleted IPlatformRunnable.
2021-01-25[releng] Xtend compiler changes for Xcore.R2_25_0Ed Merks2-2/+0
2020-12-31[569989] Support GenModel versions for 2021-03 and EMF 2.25 and JDK 17Ed Merks1-1/+1
2020-12-30[releng] Increment versions.Ed Merks2-4/+4
2020-11-05[releng] Relax upper bound for org.objectweb.asmR2_24_0Ed Merks1-1/+1
2020-11-05[releng] Relax upper bound for org.objectweb.asmEd Merks1-2/+2
2020-09-17[releng] Eliminate all deprecation warnings.Ed Merks4-5/+11
2020-06-30[releng] Eliminate warnings and version problems.Ed Merks1-1/+1
2020-06-29[563042] Migrating to the new Xtext generator workflow.Tamas Miklossy5-22/+51
-------------- I. org.eclipse.emf.ecore.xcore plugin ------------------ 1. Modify the GenerateXcore.mwe2 workflow to use the new Xtext generator workflow (org.eclipse.xtext.xtext.generator.*) packages instead of the old deprecated generator workflow (org.eclipse.xtext.generator.*) packages. 2. Rename XcoreJavaValidator to XcoreValidator. 3. Update generated code in the src-gen folder. -------------- II. org.eclipse.emf.ecore.xcore.ui plugin -------------- 1. Move the content assist infrastructure from the org.eclipse.emf.ecore.xcore.ui package into the org.eclipse.emf.ecore.xcore.ide package. 2. Rename XcoreEditor to CustomXcoreEditor to avoid naming collision with the generated editor. Modify the hand-written CustomXcoreEditor to inherit from the generated XcoreEditor. 3. Update plugin.xml_gen 4. Merge plugin.xml_gen into plugin.xml. -------------- III. org.eclipse.emf.test.ecore.xcore plugin ----------- 1. Move the XcoreInjectorProvider from the org.eclipse.emf.ecore.xcore package to the org.eclipse.emf.ecore.xcore.tests package. 2. Add generated XcoreUiInjectorProvider class. 3. Update META-INF/MANIFEST.MF file. -------------- IV. Versions and Builds -------------------------------- 1. Modify the lower bounds of plugin dependencies because minimally Xtext 2.18 is required 2. Ensure that all plugin dependencies have version ranges. 2. Modify the releng POMs so that the build of Xcore and the site, which depends on Xcore, is disabled for target platforms < 2019-06. Change-Id: I81e446995025832dc2e84decc818cfe533293ff4 Signed-off-by: Tamas Miklossy <miklossy@itemis.de>
2020-04-24[releng] Increment Xcore versions.Ed Merks2-4/+4
2019-12-04[releng] Prepare for 2.20 release.Ed Merks1-0/+1
Fix issues related to building against the Xtext 2.20 release, i.e., make sure the Xcore tests run. Fix issues for building against older target platforms.
2019-09-20[releng] Update versionsEd Merks2-4/+4
2019-06-25[releng] Update Xcore versionsEd Merks2-4/+4
2019-03-23[releng] Fix missing exported packageEd Merks2-5/+15
This is a new warning from Eclipse 2019-03. In the case of GWT, these warnings are kind of bogus because the package in question only contain resources so do not actually need to be exported, so suppress the warnings for those specific projects.
2019-01-09[543296] An @SuppressWarnings("deprecation") is generated for a factoryEd Merks1-1/+1
class inappropriately
2018-12-20[releng] Avoid deprecated org.eclipse.xtext.util.MergeableManifestEd Merks2-3/+3
Use org.eclipse.xtext.util.MergeableManifest2 instead.
2018-12-03[releng] Relax upper bound on org.objectweb.asm to allow a 7.x versionEd Merks1-1/+1
2018-11-05[540757] Ensure that version checker updates lower bounds for allEd Merks1-2/+2
releases
2018-11-04[540745] Add GenModel versions for EMF Runtime, Eclipse Runtime, and JDKEd Merks2-2/+2
versions
2018-07-06[releng] Update EPL in about.htmlEd Merks1-1/+1
2018-06-26[releng] Migrate to EPL 2.0.Ed Merks33-64/+64
2018-05-27[releng] Relax the version range for org.objectweb.asm requirementsEd Merks1-1/+1
2018-01-25[Releng] Updates for working in Photon with a Photon target platformEd Merks1-0/+1
This includes the following: Regenerated *.java files JET templates using EMF 2.14 Automatic-Module-Name in all MANIFEST.MFs Deprecation warning suppression EMFDevelopmentEnvironmentConfiguration.setup Commenting out com.google.gwt.eclipse.core.gwtProjectValidator All GWT projects fail to validate to build The GWT Project validator is broken as of Oxygen.2 and Photon
2018-01-23[Releng] Add commit ID reference to all about.propertiesEd Merks1-1/+2
2018-01-23[529487] Migrate EMF/XSD build to TychoEd Merks11-85/+118
2017-09-22[418619] Add custom EAnnotation validation supportEd Merks4-0/+12
2017-08-15[520970] Eliminate warnings in XcoreEd Merks30-89/+90
2017-08-14[releng] Generated changes for building with latest xtendEd Merks8-463/+147
2017-03-08Revert "Xtext requires java 8"Dennis Huebner1-1/+0
This reverts commit ea4ec3058536dc024c8f0756b184acf0f0e0aee8.
2017-03-08Xtext requires java 8Dennis Huebner1-0/+1
Change-Id: I1c63443ff057b20308a4a2d2b6db136f3dc4eace
2017-01-08[510033] instanceof / typeof and casting problem when working withEd Merks2-0/+136
dynamic instances
2016-08-19[releng] Fix tests problems caused by 2.10 generated injector providerEd Merks24-46/+65
2016-08-16[499731] Use new IFormatter2 for Xcore formattingEd Merks4-89/+104
Also regenerated with the mwe and built with the latest released Xtend.
2016-01-27[479585] The default genmodel java level in non-eclipse caseDennis Huebner2-6/+112
Change-Id: I8cbfd5b7c8d8bfd7c72274ee0f405f742165fc76 Signed-off-by: Dennis Huebner <dennis.huebner@gmail.com>
2015-12-03[tests] Fixed test expectation. Dennis Huebner2-1/+9
Signed-off-by: Dennis Huebner <dennis.huebner@gmail.com>
2015-10-05[releng] Increment bundle and feature versions.Ed Merks1-1/+1
2015-02-06[459287] Regenerate xcore with latest XbaseSebastian Zarnekow6-71/+75
Signed-off-by: Sebastian Zarnekow <Sebastian.Zarnekow@itemis.de> Change-Id: Ie99d0a92398167b8056465bad2d324c50e5ac2f5
2015-02-06[459287] Use unique package names in testsSebastian Zarnekow47-127/+125
Also moved the xcore test files to an own non-source folder to prevent them from being loaded twice during the tests. Preparation for the new UniqueClassNameValidation in Xtext Change-Id: Ie99d0a92398167b8056465bad2d324c50e5ac2f6 Signed-off-by: Sebastian Zarnekow <Sebastian.Zarnekow@itemis.de>
2014-10-16[447412] Added missing members to inferred enum typeSebastian Zarnekow2-0/+107
Signed-off-by: Sebastian Zarnekow <Sebastian.Zarnekow@itemis.de>

Back to the top