Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorShawn O. Pearce2010-02-11 23:57:21 +0000
committerMatthias Sohn2010-02-14 02:57:10 +0000
commit058456865a75ff36d85d63105650d3897ee21105 (patch)
treef2ae32126b33536d083dbf70532e7cea5cd153bd /org.eclipse.egit-feature/feature.xml
parentf701560d6f08edbf55a3afad2765400ecf1753ba (diff)
downloadegit-058456865a75ff36d85d63105650d3897ee21105.tar.gz
egit-058456865a75ff36d85d63105650d3897ee21105.tar.xz
egit-058456865a75ff36d85d63105650d3897ee21105.zip
Fix build and test failures
- Correcting versions. [ms: - Correcting wrong version for org.eclipse.core.filesystem to [1.1,2.0) - "Require-Bundle:" needs to use "bundle-version:" to specify version. - Manifest refered to JUnit 4 but test execution specified JUnit 3. - Fix tests which have been broken by the change 667f571b "Fix enabling team operations on project import." - Split packages between org.eclipse.egit.core and org.eclipse.egit.core.test caused ClassNotFoundException in test execution hence moving test packages. ] Change-Id: Ic76335ecb34daa76431b3d7daae566d97a7413f0 Signed-off-by: Shawn O. Pearce <spearce@spearce.org> Signed-off-by: Matthias Sohn <matthias.sohn@sap.com>
Diffstat (limited to 'org.eclipse.egit-feature/feature.xml')
-rw-r--r--org.eclipse.egit-feature/feature.xml4
1 files changed, 2 insertions, 2 deletions
diff --git a/org.eclipse.egit-feature/feature.xml b/org.eclipse.egit-feature/feature.xml
index 30fd126e19..ee62e45b03 100644
--- a/org.eclipse.egit-feature/feature.xml
+++ b/org.eclipse.egit-feature/feature.xml
@@ -26,14 +26,14 @@
<requires>
<import plugin="org.eclipse.core.runtime" version="3.4" match="compatible"/>
<import plugin="org.eclipse.core.resources" version="3.4.0" match="compatible"/>
- <import plugin="org.eclipse.core.filesystem" version="3.4.0" match="compatible"/>
+ <import plugin="org.eclipse.core.filesystem" version="1.1.0" match="compatible"/>
<import plugin="org.eclipse.ui" version="3.4.0" match="compatible"/>
<import plugin="org.eclipse.team.ui" version="3.4.0" match="compatible"/>
<import plugin="org.eclipse.jface.text" version="3.4.0" match="compatible"/>
<import plugin="org.eclipse.ui.ide" version="3.4.0" match="compatible"/>
<import plugin="org.eclipse.ui.workbench.texteditor" version="3.4.0" match="compatible"/>
<import plugin="org.eclipse.compare" version="3.4.0" match="compatible"/>
- <import plugin="org.eclipse.core.net" version="3.4.0" match="compatible"/>
+ <import plugin="org.eclipse.core.net" version="1.1.0" match="compatible"/>
<import plugin="org.eclipse.team.core" version="3.4.0" match="compatible"/>
<import plugin="org.eclipse.jsch.ui" version="1.1.100" match="compatible"/>
<import plugin="org.eclipse.jsch.core" version="1.1.100" match="compatible"/>

Back to the top