Skip to main content
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.asciidoc.fx.e4/META-INF/MANIFEST.MF14
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.asciidoc.fx.e4/pom.xml2
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.asciidoc.fx/META-INF/MANIFEST.MF2
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.asciidoc.fx/pom.xml2
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.asciidoc/META-INF/MANIFEST.MF4
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.asciidoc/pom.xml2
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.e4/META-INF/MANIFEST.MF20
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.e4/pom.xml2
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.fx.e4/META-INF/MANIFEST.MF20
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.fx.e4/pom.xml2
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.fx.themes/META-INF/MANIFEST.MF4
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.fx.themes/pom.xml2
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.fx/META-INF/MANIFEST.MF26
-rw-r--r--bundles/code/org.eclipse.fx.code.editor.fx/pom.xml2
-rw-r--r--bundles/code/org.eclipse.fx.code.editor/META-INF/MANIFEST.MF14
-rw-r--r--bundles/code/org.eclipse.fx.code.editor/pom.xml2
-rw-r--r--bundles/code/org.eclipse.fx.text.compat/META-INF/MANIFEST.MF2
-rw-r--r--bundles/code/org.eclipse.fx.text.compat/pom.xml2
-rw-r--r--bundles/code/org.eclipse.fx.text.ui/META-INF/MANIFEST.MF2
-rw-r--r--bundles/code/org.eclipse.fx.text.ui/pom.xml2
-rw-r--r--bundles/code/org.eclipse.fx.text/META-INF/MANIFEST.MF4
-rw-r--r--bundles/code/org.eclipse.fx.text/pom.xml2
-rwxr-xr-xbundles/runtime/javax.annotation.jre/pom.xml2
-rwxr-xr-xbundles/runtime/javax.xml.jre/pom.xml2
-rw-r--r--bundles/runtime/org.eclipse.fx.core.databinding.tests/META-INF/MANIFEST.MF2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core.databinding/META-INF/MANIFEST.MF4
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core.databinding/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core.databinding/src/org/eclipse/fx/core/databinding/AdapterFactory.java40
-rw-r--r--bundles/runtime/org.eclipse.fx.core.di.context.tests/META-INF/MANIFEST.MF2
-rw-r--r--bundles/runtime/org.eclipse.fx.core.di.context/META-INF/MANIFEST.MF18
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core.di.context/pom.xml2
-rw-r--r--bundles/runtime/org.eclipse.fx.core.di/META-INF/MANIFEST.MF8
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core.di/pom.xml2
-rw-r--r--bundles/runtime/org.eclipse.fx.core.fxml/META-INF/MANIFEST.MF4
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core.fxml/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core.guice/META-INF/MANIFEST.MF6
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core.guice/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core.log4j/META-INF/MANIFEST.MF6
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core.log4j/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core.p2/META-INF/MANIFEST.MF10
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core.p2/pom.xml2
-rw-r--r--bundles/runtime/org.eclipse.fx.core.slf4j/META-INF/MANIFEST.MF6
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core.slf4j/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core/META-INF/MANIFEST.MF22
-rwxr-xr-xbundles/runtime/org.eclipse.fx.core/pom.xml2
-rw-r--r--bundles/runtime/org.eclipse.fx.core/src/org/eclipse/fx/core/Util.java8
-rwxr-xr-xbundles/runtime/org.eclipse.fx.emf.databinding/META-INF/MANIFEST.MF4
-rwxr-xr-xbundles/runtime/org.eclipse.fx.emf.databinding/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.emf.edit.ui/META-INF/MANIFEST.MF10
-rwxr-xr-xbundles/runtime/org.eclipse.fx.emf.edit.ui/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.formats.svg/META-INF/MANIFEST.MF2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.formats.svg/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.javafx/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.osgi.util/META-INF/MANIFEST.MF14
-rwxr-xr-xbundles/runtime/org.eclipse.fx.osgi.util/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.osgi/META-INF/MANIFEST.MF2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.osgi/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.animation/META-INF/MANIFEST.MF10
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.animation/pom.xml2
-rw-r--r--bundles/runtime/org.eclipse.fx.ui.controls/META-INF/MANIFEST.MF42
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.controls/pom.xml2
-rw-r--r--bundles/runtime/org.eclipse.fx.ui.controls/src/controls.cssext15
-rw-r--r--bundles/runtime/org.eclipse.fx.ui.databinding/META-INF/MANIFEST.MF8
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.databinding/pom.xml2
-rw-r--r--bundles/runtime/org.eclipse.fx.ui.di.interopt/META-INF/MANIFEST.MF10
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.di.interopt/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.di/META-INF/MANIFEST.MF12
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.di/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.dialogs/META-INF/MANIFEST.MF8
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.dialogs/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.keybindings.e4/META-INF/MANIFEST.MF10
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.keybindings.e4/pom.xml2
-rw-r--r--bundles/runtime/org.eclipse.fx.ui.keybindings.generic/.settings/ca.ecliptical.pde.ds.prefs5
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.keybindings.generic/META-INF/MANIFEST.MF8
-rw-r--r--bundles/runtime/org.eclipse.fx.ui.keybindings.generic/OSGI-INF/services/org.eclipse.fx.ui.keybindings.generic.BindingFactoryImpl.xml (renamed from bundles/runtime/org.eclipse.fx.ui.keybindings.generic/OSGI-INF/org.eclipse.fx.ui.keybindings.generic.BindingFactoryImpl.xml)12
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.keybindings.generic/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.keybindings/META-INF/MANIFEST.MF6
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.keybindings/pom.xml2
-rw-r--r--bundles/runtime/org.eclipse.fx.ui.mobile/META-INF/MANIFEST.MF6
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.mobile/pom.xml2
-rw-r--r--bundles/runtime/org.eclipse.fx.ui.modelviewer/META-INF/MANIFEST.MF12
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.panes/META-INF/MANIFEST.MF4
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.panes/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.services/META-INF/MANIFEST.MF26
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.services/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.theme/META-INF/MANIFEST.MF12
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.theme/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.workbench.base/META-INF/MANIFEST.MF24
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.workbench.base/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.workbench.fx/META-INF/MANIFEST.MF40
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.workbench.fx/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.workbench.renderers.base/META-INF/MANIFEST.MF26
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.workbench.renderers.base/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.workbench.renderers.fx/META-INF/MANIFEST.MF48
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.workbench.renderers.fx/pom.xml2
-rw-r--r--bundles/runtime/org.eclipse.fx.ui.workbench.services/META-INF/MANIFEST.MF8
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.workbench.services/pom.xml2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.workbench3/META-INF/MANIFEST.MF2
-rwxr-xr-xbundles/runtime/org.eclipse.fx.ui.workbench3/pom.xml2
-rw-r--r--releng/code/org.eclipse.fx.code.target.feature/feature.xml2
-rw-r--r--releng/code/org.eclipse.fx.code.target.feature/pom.xml2
-rw-r--r--releng/org.eclipse.fx.core.shared.updatesite/pom.xml2
-rw-r--r--releng/org.eclipse.fx.core.shared.updatesite/site.xml4
-rwxr-xr-xreleng/org.eclipse.fx.releng/pom.xml2
-rw-r--r--releng/org.eclipse.fx.runtime.doc/META-INF/MANIFEST.MF2
-rwxr-xr-xreleng/org.eclipse.fx.runtime.doc/pom.xml4
-rw-r--r--releng/org.eclipse.fx.shared.doc/META-INF/MANIFEST.MF2
-rwxr-xr-xreleng/org.eclipse.fx.shared.doc/pom.xml4
-rwxr-xr-xreleng/org.eclipse.fx.shared.releng/pom.xml2
-rw-r--r--releng/org.eclipse.fx.updatesite/pom.xml2
-rw-r--r--releng/org.eclipse.fx.updatesite/site.xml16
-rw-r--r--releng/runtime/org.eclipse.fx..slf4j.target.feature/feature.xml2
-rw-r--r--releng/runtime/org.eclipse.fx..slf4j.target.feature/pom.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.core.feature/feature.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.core.feature/pom.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.core.shared.feature/feature.xml4
-rw-r--r--releng/runtime/org.eclipse.fx.core.shared.feature/pom.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.runtime.e4fx.feature/feature.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.runtime.e4fx.feature/pom.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/.gitignore1
-rw-r--r--releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/feature.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/pom.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.runtime.feature/feature.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.runtime.feature/pom.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.runtime.min.feature/feature.xml4
-rw-r--r--releng/runtime/org.eclipse.fx.runtime.min.feature/pom.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.swtfx.feature/feature.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.swtfx.feature/pom.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.target.feature/feature.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.target.feature/pom.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.target.rcp.feature/feature.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.target.rcp.feature/pom.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.target.rcp4.feature/feature.xml2
-rw-r--r--releng/runtime/org.eclipse.fx.target.rcp4.feature/pom.xml2
134 files changed, 442 insertions, 379 deletions
diff --git a/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx.e4/META-INF/MANIFEST.MF b/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx.e4/META-INF/MANIFEST.MF
index 995271303..ea47cb225 100644
--- a/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx.e4/META-INF/MANIFEST.MF
+++ b/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx.e4/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: E4
Bundle-SymbolicName: org.eclipse.fx.code.editor.asciidoc.fx.e4
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.e4.ui.model.workbench;bundle-version="1.1.100",
org.eclipse.e4.ui.workbench;bundle-version="1.3.0",
@@ -11,12 +11,12 @@ Require-Bundle: org.eclipse.e4.ui.model.workbench;bundle-version="1.1.100",
org.eclipse.e4.ui.di;bundle-version="1.1.0",
org.eclipse.e4.core.di;bundle-version="1.5.0"
Import-Package: javax.inject,
- org.eclipse.fx.code.editor;version="2.2.0",
- org.eclipse.fx.code.editor.asciidoc;version="2.2.0",
- org.eclipse.fx.code.editor.fx.e4,
- org.eclipse.fx.code.editor.services;version="2.2.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.di;version="2.2.0",
+ org.eclipse.fx.code.editor;version="2.3.0",
+ org.eclipse.fx.code.editor.asciidoc;version="2.3.0",
+ org.eclipse.fx.code.editor.fx.e4;version="2.3.0",
+ org.eclipse.fx.code.editor.services;version="2.3.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.di;version="2.3.0",
org.osgi.service.component.annotations;version="1.2.0";resolution:=optional
Service-Component: OSGI-INF/services/org.eclipse.fx.code.editor.asciidoc.fx.e4.AsciiDoctorEditorOpenerTypeProvider.xml
Bundle-ActivationPolicy: lazy
diff --git a/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx.e4/pom.xml b/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx.e4/pom.xml
index 3a71ccca1..3f0d42d00 100644
--- a/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx.e4/pom.xml
+++ b/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx.e4/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx/META-INF/MANIFEST.MF b/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx/META-INF/MANIFEST.MF
index 85f48637f..773716d37 100644
--- a/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx/META-INF/MANIFEST.MF
+++ b/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Fx
Bundle-SymbolicName: org.eclipse.fx.code.editor.asciidoc.fx
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.fx.code.editor,
org.eclipse.fx.code.editor.asciidoc,
diff --git a/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx/pom.xml b/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx/pom.xml
index cd96143a7..3a23d1e2e 100644
--- a/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx/pom.xml
+++ b/bundles/code/org.eclipse.fx.code.editor.asciidoc.fx/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/code/org.eclipse.fx.code.editor.asciidoc/META-INF/MANIFEST.MF b/bundles/code/org.eclipse.fx.code.editor.asciidoc/META-INF/MANIFEST.MF
index 661df9ccd..524d418c3 100644
--- a/bundles/code/org.eclipse.fx.code.editor.asciidoc/META-INF/MANIFEST.MF
+++ b/bundles/code/org.eclipse.fx.code.editor.asciidoc/META-INF/MANIFEST.MF
@@ -2,6 +2,6 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Asciidoc
Bundle-SymbolicName: org.eclipse.fx.code.editor.asciidoc
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Export-Package: org.eclipse.fx.code.editor.asciidoc;version="2.2.0"
+Export-Package: org.eclipse.fx.code.editor.asciidoc;version="2.3.0"
diff --git a/bundles/code/org.eclipse.fx.code.editor.asciidoc/pom.xml b/bundles/code/org.eclipse.fx.code.editor.asciidoc/pom.xml
index cc776f6e5..c644bb315 100644
--- a/bundles/code/org.eclipse.fx.code.editor.asciidoc/pom.xml
+++ b/bundles/code/org.eclipse.fx.code.editor.asciidoc/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/code/org.eclipse.fx.code.editor.e4/META-INF/MANIFEST.MF b/bundles/code/org.eclipse.fx.code.editor.e4/META-INF/MANIFEST.MF
index 55694c066..43604d062 100644
--- a/bundles/code/org.eclipse.fx.code.editor.e4/META-INF/MANIFEST.MF
+++ b/bundles/code/org.eclipse.fx.code.editor.e4/META-INF/MANIFEST.MF
@@ -2,11 +2,11 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Basic service APIs for an Editor into Eclipse 4
Bundle-SymbolicName: org.eclipse.fx.code.editor.e4
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-Vendor: Eclipse.org
-Export-Package: org.eclipse.fx.code.editor.e4;version="2.2.0";x-internal:=true,
- org.eclipse.fx.code.editor.e4.addons;version="2.2.0";x-internal:=true,
- org.eclipse.fx.code.editor.e4.handlers;version="2.2.0";x-internal:=true
+Export-Package: org.eclipse.fx.code.editor.e4;version="2.3.0";x-internal:=true,
+ org.eclipse.fx.code.editor.e4.addons;version="2.3.0";x-internal:=true,
+ org.eclipse.fx.code.editor.e4.handlers;version="2.3.0";x-internal:=true
Require-Bundle: org.eclipse.e4.core.contexts,
org.eclipse.e4.core.di;bundle-version="1.5.0",
org.eclipse.text;bundle-version="3.5.400",
@@ -17,12 +17,12 @@ Require-Bundle: org.eclipse.e4.core.contexts,
org.eclipse.e4.ui.di
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: javax.inject;version="1.0.0",
- org.eclipse.fx.code.editor;version="2.2.0",
- org.eclipse.fx.code.editor.services;version="2.2.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.di;version="2.2.0",
- org.eclipse.fx.core.di.context;version="2.2.0",
- org.eclipse.fx.core.event;version="2.2.0",
+ org.eclipse.fx.code.editor;version="2.3.0",
+ org.eclipse.fx.code.editor.services;version="2.3.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.di;version="2.3.0",
+ org.eclipse.fx.core.di.context;version="2.3.0",
+ org.eclipse.fx.core.event;version="2.3.0",
org.osgi.service.component.annotations;version="1.2.0";resolution:=optional
Service-Component: OSGI-INF/services/org.eclipse.fx.code.editor.e4.internal.DocumentPartitionerContextFunction.xml,
OSGI-INF/services/org.eclipse.fx.code.editor.e4.internal.AnnotationModelContextFunction.xml,
diff --git a/bundles/code/org.eclipse.fx.code.editor.e4/pom.xml b/bundles/code/org.eclipse.fx.code.editor.e4/pom.xml
index 7a05661b7..9f8de7986 100644
--- a/bundles/code/org.eclipse.fx.code.editor.e4/pom.xml
+++ b/bundles/code/org.eclipse.fx.code.editor.e4/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/code/org.eclipse.fx.code.editor.fx.e4/META-INF/MANIFEST.MF b/bundles/code/org.eclipse.fx.code.editor.fx.e4/META-INF/MANIFEST.MF
index a2d38101a..d635f232c 100644
--- a/bundles/code/org.eclipse.fx.code.editor.fx.e4/META-INF/MANIFEST.MF
+++ b/bundles/code/org.eclipse.fx.code.editor.fx.e4/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Integration the JavaFX code editor into Eclipse 4
Bundle-SymbolicName: org.eclipse.fx.code.editor.fx.e4
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.e4.core.contexts;bundle-version="1.4.0",
@@ -10,16 +10,16 @@ Require-Bundle: org.eclipse.e4.core.contexts;bundle-version="1.4.0",
org.eclipse.e4.ui.workbench;bundle-version="1.3.0",
org.eclipse.e4.core.di;bundle-version="1.5.0",
org.eclipse.e4.core.services;bundle-version="2.0.0",
- org.eclipse.fx.text.ui;bundle-version="2.2.0",
+ org.eclipse.fx.text.ui;bundle-version="2.3.0",
org.eclipse.text;bundle-version="3.5.400"
Import-Package: javax.inject,
- org.eclipse.fx.code.editor;version="2.2.0",
- org.eclipse.fx.code.editor.e4;version="2.2.0",
- org.eclipse.fx.code.editor.fx.services;version="2.2.0",
- org.eclipse.fx.code.editor.services;version="2.2.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.di;version="2.2.0",
- org.eclipse.fx.core.di.context;version="2.2.0",
+ org.eclipse.fx.code.editor;version="2.3.0",
+ org.eclipse.fx.code.editor.e4;version="2.3.0",
+ org.eclipse.fx.code.editor.fx.services;version="2.3.0",
+ org.eclipse.fx.code.editor.services;version="2.3.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.di;version="2.3.0",
+ org.eclipse.fx.core.di.context;version="2.3.0",
org.osgi.service.component.annotations;resolution:=optional
Service-Component: OSGI-INF/services/org.eclipse.fx.code.editor.fx.e4.internal.SourceViewerConfigurationContextFunction.xml,
OSGI-INF/services/org.eclipse.fx.code.editor.fx.e4.internal.PresentationReconcilerContextFunction.xml,
@@ -30,4 +30,4 @@ Service-Component: OSGI-INF/services/org.eclipse.fx.code.editor.fx.e4.internal.S
OSGI-INF/services/org.eclipse.fx.code.editor.fx.e4.internal.CompletionProposalPresenterTypeProviderContextFunction.xml,
OSGI-INF/services/org.eclipse.fx.code.editor.fx.e4.internal.ContextInformationPresenterTypeProviderContextFunction.xml
Bundle-Vendor: Eclipse.org
-Export-Package: org.eclipse.fx.code.editor.fx.e4
+Export-Package: org.eclipse.fx.code.editor.fx.e4;version="2.3.0";x-internal:=true
diff --git a/bundles/code/org.eclipse.fx.code.editor.fx.e4/pom.xml b/bundles/code/org.eclipse.fx.code.editor.fx.e4/pom.xml
index 625cb685e..3de226426 100644
--- a/bundles/code/org.eclipse.fx.code.editor.fx.e4/pom.xml
+++ b/bundles/code/org.eclipse.fx.code.editor.fx.e4/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/code/org.eclipse.fx.code.editor.fx.themes/META-INF/MANIFEST.MF b/bundles/code/org.eclipse.fx.code.editor.fx.themes/META-INF/MANIFEST.MF
index 664124249..42d626c42 100644
--- a/bundles/code/org.eclipse.fx.code.editor.fx.themes/META-INF/MANIFEST.MF
+++ b/bundles/code/org.eclipse.fx.code.editor.fx.themes/META-INF/MANIFEST.MF
@@ -2,9 +2,9 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Basic editor Themes
Bundle-SymbolicName: org.eclipse.fx.code.editor.fx.themes
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: org.eclipse.fx.ui.services.theme;version="2.2.0",
+Import-Package: org.eclipse.fx.ui.services.theme;version="2.3.0",
org.osgi.service.component.annotations;resolution:=optional
Service-Component: OSGI-INF/services/org.eclipse.fx.code.editor.fx.themes.internal.DefaultEditorStylesheet.xml
Bundle-ActivationPolicy: lazy
diff --git a/bundles/code/org.eclipse.fx.code.editor.fx.themes/pom.xml b/bundles/code/org.eclipse.fx.code.editor.fx.themes/pom.xml
index caa6be74c..ea1b8da6d 100644
--- a/bundles/code/org.eclipse.fx.code.editor.fx.themes/pom.xml
+++ b/bundles/code/org.eclipse.fx.code.editor.fx.themes/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/code/org.eclipse.fx.code.editor.fx/META-INF/MANIFEST.MF b/bundles/code/org.eclipse.fx.code.editor.fx/META-INF/MANIFEST.MF
index 81bb586e8..6207657e8 100644
--- a/bundles/code/org.eclipse.fx.code.editor.fx/META-INF/MANIFEST.MF
+++ b/bundles/code/org.eclipse.fx.code.editor.fx/META-INF/MANIFEST.MF
@@ -2,28 +2,28 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Basic editor APIs for JavaFX
Bundle-SymbolicName: org.eclipse.fx.code.editor.fx
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: javax.inject,
org.eclipse.e4.ui.di,
- org.eclipse.fx.code.editor;version="2.2.0",
- org.eclipse.fx.code.editor.services;version="2.2.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.di;version="2.2.0",
- org.eclipse.fx.core.preferences;version="2.2.0",
- org.eclipse.fx.ui.controls.filesystem;version="2.2.0",
- org.eclipse.fx.ui.controls.styledtext;version="2.2.0",
- org.eclipse.fx.ui.controls.tree;version="2.2.0",
+ org.eclipse.fx.code.editor;version="2.3.0",
+ org.eclipse.fx.code.editor.services;version="2.3.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.di;version="2.3.0",
+ org.eclipse.fx.core.preferences;version="2.3.0",
+ org.eclipse.fx.ui.controls.filesystem;version="2.3.0",
+ org.eclipse.fx.ui.controls.styledtext;version="2.3.0",
+ org.eclipse.fx.ui.controls.tree;version="2.3.0",
org.osgi.service.component.annotations;version="1.2.0";resolution:=optional
Require-Bundle: org.eclipse.e4.core.di.annotations;bundle-version="1.4.0",
- org.eclipse.fx.text.ui;bundle-version="2.2.0",
- org.eclipse.fx.text;bundle-version="2.2.0",
+ org.eclipse.fx.text.ui;bundle-version="2.3.0",
+ org.eclipse.fx.text;bundle-version="2.3.0",
org.eclipse.text,
org.eclipse.fx.text.compat
Service-Component: OSGI-INF/services/org.eclipse.fx.code.editor.fx.services.internal.DefaultSourceViewerConfigurationTypeProvider.xml,
OSGI-INF/services/org.eclipse.fx.code.editor.fx.services.internal.NoHighlightPresentationReconcilerTypeProvider.xml,
OSGI-INF/services/org.eclipse.fx.code.editor.fx.services.internal.SystemEditorFontProvider.xml
Bundle-ActivationPolicy: lazy
-Export-Package: org.eclipse.fx.code.editor.fx;version="2.2.0";x-internal:=true,
- org.eclipse.fx.code.editor.fx.services;version="2.2.0";x-internal:=true
+Export-Package: org.eclipse.fx.code.editor.fx;version="2.3.0";x-internal:=true,
+ org.eclipse.fx.code.editor.fx.services;version="2.3.0";x-internal:=true
Bundle-Vendor: Eclipse.org
diff --git a/bundles/code/org.eclipse.fx.code.editor.fx/pom.xml b/bundles/code/org.eclipse.fx.code.editor.fx/pom.xml
index d367e8d26..d618b1624 100644
--- a/bundles/code/org.eclipse.fx.code.editor.fx/pom.xml
+++ b/bundles/code/org.eclipse.fx.code.editor.fx/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/code/org.eclipse.fx.code.editor/META-INF/MANIFEST.MF b/bundles/code/org.eclipse.fx.code.editor/META-INF/MANIFEST.MF
index b3b9aed74..e01ccb14d 100644
--- a/bundles/code/org.eclipse.fx.code.editor/META-INF/MANIFEST.MF
+++ b/bundles/code/org.eclipse.fx.code.editor/META-INF/MANIFEST.MF
@@ -2,19 +2,19 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Basic service APIs for an Editor
Bundle-SymbolicName: org.eclipse.fx.code.editor
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: javax.inject,
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.adapter;version="2.2.0",
- org.eclipse.fx.core.event;version="2.2.0",
- org.eclipse.fx.core.function;version="2.2.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.adapter;version="2.3.0",
+ org.eclipse.fx.core.event;version="2.3.0",
+ org.eclipse.fx.core.function;version="2.3.0",
org.eclipse.jface.text.rules,
org.osgi.service.component.annotations;version="1.2.0"
Require-Bundle: org.eclipse.text;bundle-version="3.5.400",
org.eclipse.e4.core.di.annotations;bundle-version="1.4.0"
-Export-Package: org.eclipse.fx.code.editor;version="2.2.0";x-internal:=true,
- org.eclipse.fx.code.editor.services;version="2.2.0";x-internal:=true
+Export-Package: org.eclipse.fx.code.editor;version="2.3.0";x-internal:=true,
+ org.eclipse.fx.code.editor.services;version="2.3.0";x-internal:=true
Bundle-ActivationPolicy: lazy
Service-Component: OSGI-INF/services/org.eclipse.fx.code.editor.services.internal.URLToPathAdapterProvider.xml,
OSGI-INF/services/org.eclipse.fx.code.editor.services.internal.FileInputTypeProvider.xml,
diff --git a/bundles/code/org.eclipse.fx.code.editor/pom.xml b/bundles/code/org.eclipse.fx.code.editor/pom.xml
index 5a8a94932..d1be811bb 100644
--- a/bundles/code/org.eclipse.fx.code.editor/pom.xml
+++ b/bundles/code/org.eclipse.fx.code.editor/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/code/org.eclipse.fx.text.compat/META-INF/MANIFEST.MF b/bundles/code/org.eclipse.fx.text.compat/META-INF/MANIFEST.MF
index bc7aa5dbc..68a335530 100644
--- a/bundles/code/org.eclipse.fx.text.compat/META-INF/MANIFEST.MF
+++ b/bundles/code/org.eclipse.fx.text.compat/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Compat
Bundle-SymbolicName: org.eclipse.fx.text.compat
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.equinox.common;bundle-version="3.7.0",
org.eclipse.text;bundle-version="3.5.400"
diff --git a/bundles/code/org.eclipse.fx.text.compat/pom.xml b/bundles/code/org.eclipse.fx.text.compat/pom.xml
index e39d0849e..c83e6ed2a 100644
--- a/bundles/code/org.eclipse.fx.text.compat/pom.xml
+++ b/bundles/code/org.eclipse.fx.text.compat/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/code/org.eclipse.fx.text.ui/META-INF/MANIFEST.MF b/bundles/code/org.eclipse.fx.text.ui/META-INF/MANIFEST.MF
index 7139dd936..41eb64170 100644
--- a/bundles/code/org.eclipse.fx.text.ui/META-INF/MANIFEST.MF
+++ b/bundles/code/org.eclipse.fx.text.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Basic JavaFX components
Bundle-SymbolicName: org.eclipse.fx.text.ui
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.fx.ui.controls;bundle-version="1.0.0",
org.eclipse.text;bundle-version="3.5.300",
diff --git a/bundles/code/org.eclipse.fx.text.ui/pom.xml b/bundles/code/org.eclipse.fx.text.ui/pom.xml
index 55aeaa9ea..9f320ef78 100644
--- a/bundles/code/org.eclipse.fx.text.ui/pom.xml
+++ b/bundles/code/org.eclipse.fx.text.ui/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/code/org.eclipse.fx.text/META-INF/MANIFEST.MF b/bundles/code/org.eclipse.fx.text/META-INF/MANIFEST.MF
index 4838a8776..51021d3a9 100644
--- a/bundles/code/org.eclipse.fx.text/META-INF/MANIFEST.MF
+++ b/bundles/code/org.eclipse.fx.text/META-INF/MANIFEST.MF
@@ -2,9 +2,9 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Basic Text extension
Bundle-SymbolicName: org.eclipse.fx.text
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Export-Package: org.eclipse.fx.text.rules;version="2.2.0";x-internal:=true
+Export-Package: org.eclipse.fx.text.rules;version="2.3.0";x-internal:=true
Require-Bundle: org.eclipse.text;bundle-version="3.5.300",
org.eclipse.equinox.common;bundle-version="3.6.200"
Bundle-Vendor: Eclipse.org
diff --git a/bundles/code/org.eclipse.fx.text/pom.xml b/bundles/code/org.eclipse.fx.text/pom.xml
index 833d903f4..66a8b53b8 100644
--- a/bundles/code/org.eclipse.fx.text/pom.xml
+++ b/bundles/code/org.eclipse.fx.text/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/javax.annotation.jre/pom.xml b/bundles/runtime/javax.annotation.jre/pom.xml
index 9d546f07c..6b2f2fbad 100755
--- a/bundles/runtime/javax.annotation.jre/pom.xml
+++ b/bundles/runtime/javax.annotation.jre/pom.xml
@@ -11,7 +11,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/javax.xml.jre/pom.xml b/bundles/runtime/javax.xml.jre/pom.xml
index 15c6fdf1a..0c23285d3 100755
--- a/bundles/runtime/javax.xml.jre/pom.xml
+++ b/bundles/runtime/javax.xml.jre/pom.xml
@@ -11,7 +11,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.core.databinding.tests/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.core.databinding.tests/META-INF/MANIFEST.MF
index 10abf51d3..f110b4368 100644
--- a/bundles/runtime/org.eclipse.fx.core.databinding.tests/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.core.databinding.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Tests
Bundle-SymbolicName: org.eclipse.fx.core.databinding.tests
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.junit;bundle-version="4.11.0",
org.eclipse.core.databinding;bundle-version="1.4.1",
diff --git a/bundles/runtime/org.eclipse.fx.core.databinding/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.core.databinding/META-INF/MANIFEST.MF
index 0ba583185..9085702ea 100755
--- a/bundles/runtime/org.eclipse.fx.core.databinding/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.core.databinding/META-INF/MANIFEST.MF
@@ -2,11 +2,11 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.fx.core.databinding
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.core.databinding.observable;bundle-version="1.5.0",
org.eclipse.core.databinding.property;bundle-version="1.5.0",
org.eclipse.equinox.common;bundle-version="3.7.0",
org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
-Export-Package: org.eclipse.fx.core.databinding;version="2.2.0"
+Export-Package: org.eclipse.fx.core.databinding;version="2.3.0"
Bundle-Vendor: %Bundle-Vendor
diff --git a/bundles/runtime/org.eclipse.fx.core.databinding/pom.xml b/bundles/runtime/org.eclipse.fx.core.databinding/pom.xml
index fcc741bc7..cdba4bb90 100755
--- a/bundles/runtime/org.eclipse.fx.core.databinding/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.core.databinding/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.core.databinding/src/org/eclipse/fx/core/databinding/AdapterFactory.java b/bundles/runtime/org.eclipse.fx.core.databinding/src/org/eclipse/fx/core/databinding/AdapterFactory.java
index c8892b843..a23a284cb 100755
--- a/bundles/runtime/org.eclipse.fx.core.databinding/src/org/eclipse/fx/core/databinding/AdapterFactory.java
+++ b/bundles/runtime/org.eclipse.fx.core.databinding/src/org/eclipse/fx/core/databinding/AdapterFactory.java
@@ -37,6 +37,7 @@ import org.eclipse.core.databinding.observable.value.ValueChangeEvent;
import javafx.beans.InvalidationListener;
import javafx.beans.binding.Bindings;
+import javafx.beans.property.ObjectPropertyBase;
import javafx.beans.value.ChangeListener;
import javafx.beans.value.ObservableValue;
import javafx.beans.value.WritableValue;
@@ -485,6 +486,45 @@ public class AdapterFactory {
}
}
+ class WrappedValueProperty<T> extends ObjectPropertyBase<T> {
+
+ @Override
+ public Object getBean() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ @Override
+ public String getName() {
+ // TODO Auto-generated method stub
+ return null;
+ }
+
+ @Override
+ public void set(T newValue) {
+ // TODO Auto-generated method stub
+ super.set(newValue);
+ }
+
+ @Override
+ public T getValue() {
+ // TODO Auto-generated method stub
+ return super.getValue();
+ }
+
+ @Override
+ public void setValue(T v) {
+ // TODO Auto-generated method stub
+ super.setValue(v);
+ }
+
+ @Override
+ public T get() {
+ // TODO Auto-generated method stub
+ return super.get();
+ }
+ }
+
/**
* Adapt an {@link IObservableValue} to an {@link ObservableWritableValue}
*
diff --git a/bundles/runtime/org.eclipse.fx.core.di.context.tests/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.core.di.context.tests/META-INF/MANIFEST.MF
index df31a02ab..1111da612 100644
--- a/bundles/runtime/org.eclipse.fx.core.di.context.tests/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.core.di.context.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Tests
Bundle-SymbolicName: org.eclipse.fx.core.di.context.tests
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.junit;bundle-version="4.11.0",
org.eclipse.fx.core.di;bundle-version="0.9.0",
diff --git a/bundles/runtime/org.eclipse.fx.core.di.context/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.core.di.context/META-INF/MANIFEST.MF
index 1b7dd3131..09f556d36 100644
--- a/bundles/runtime/org.eclipse.fx.core.di.context/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.core.di.context/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Context
Bundle-SymbolicName: org.eclipse.fx.core.di.context
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.e4.core.contexts;bundle-version="1.3.0",
@@ -14,14 +14,14 @@ Require-Bundle: org.eclipse.e4.core.contexts;bundle-version="1.3.0",
org.eclipse.equinox.preferences;bundle-version="3.5.300"
Import-Package: javax.annotation;version="1.1.0";resolution:=optional,
javax.inject;version="1.0.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.adapter;version="2.2.0",
- org.eclipse.fx.core.di;version="2.2.0",
- org.eclipse.fx.core.event;version="2.2.0",
- org.eclipse.fx.core.log;version="2.2.0",
- org.eclipse.fx.core.preferences;version="2.2.0",
- org.eclipse.fx.core.text;version="2.2.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.adapter;version="2.3.0",
+ org.eclipse.fx.core.di;version="2.3.0",
+ org.eclipse.fx.core.event;version="2.3.0",
+ org.eclipse.fx.core.log;version="2.3.0",
+ org.eclipse.fx.core.preferences;version="2.3.0",
+ org.eclipse.fx.core.text;version="2.3.0",
org.osgi.framework;version="1.8.0"
Service-Component: OSGI-INF/services/*
-Export-Package: org.eclipse.fx.core.di.context;version="2.2.0"
+Export-Package: org.eclipse.fx.core.di.context;version="2.3.0"
Bundle-Vendor: Eclipse.org
diff --git a/bundles/runtime/org.eclipse.fx.core.di.context/pom.xml b/bundles/runtime/org.eclipse.fx.core.di.context/pom.xml
index c345074e6..b1bbe3a0c 100755
--- a/bundles/runtime/org.eclipse.fx.core.di.context/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.core.di.context/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.core.di/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.core.di/META-INF/MANIFEST.MF
index 73388cd73..5f6e11e57 100644
--- a/bundles/runtime/org.eclipse.fx.core.di/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.core.di/META-INF/MANIFEST.MF
@@ -2,12 +2,12 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Di
Bundle-SymbolicName: org.eclipse.fx.core.di
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Import-Package: javax.annotation;version="1.2.0";resolution:=optional,
javax.inject;version="1.0.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.adapter;version="2.2.0"
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.adapter;version="2.3.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
-Export-Package: org.eclipse.fx.core.di;version="2.2.0"
+Export-Package: org.eclipse.fx.core.di;version="2.3.0"
Bundle-Vendor: Eclipse.org
diff --git a/bundles/runtime/org.eclipse.fx.core.di/pom.xml b/bundles/runtime/org.eclipse.fx.core.di/pom.xml
index 4d7d93e49..9b33114fa 100755
--- a/bundles/runtime/org.eclipse.fx.core.di/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.core.di/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.core.fxml/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.core.fxml/META-INF/MANIFEST.MF
index 3136cbf3b..7e8893500 100644
--- a/bundles/runtime/org.eclipse.fx.core.fxml/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.core.fxml/META-INF/MANIFEST.MF
@@ -2,8 +2,8 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Fxml
Bundle-SymbolicName: org.eclipse.fx.core.fxml
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.jdt.annotation;bundle-version="2.0.0";resolution:=optional
-Export-Package: org.eclipse.fx.core.fxml;version="2.2.0"
+Export-Package: org.eclipse.fx.core.fxml;version="2.3.0"
Bundle-Vendor: Eclipse.org
diff --git a/bundles/runtime/org.eclipse.fx.core.fxml/pom.xml b/bundles/runtime/org.eclipse.fx.core.fxml/pom.xml
index 08a1ba269..588465478 100755
--- a/bundles/runtime/org.eclipse.fx.core.fxml/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.core.fxml/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.core.guice/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.core.guice/META-INF/MANIFEST.MF
index c7a28bbf3..83b8aad33 100755
--- a/bundles/runtime/org.eclipse.fx.core.guice/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.core.guice/META-INF/MANIFEST.MF
@@ -2,14 +2,14 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.fx.core.guice
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Require-Bundle: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: com.google.inject;version="[1.3.0,2.0.0)",
com.google.inject.spi;version="[1.3.0,2.0.0)",
javax.inject;version="1.0.0",
- org.eclipse.fx.core.log;version="2.2.0",
+ org.eclipse.fx.core.log;version="2.3.0",
org.osgi.framework;version="1.8.0"
Bundle-Vendor: %Bundle-Vendor
-Export-Package: org.eclipse.fx.core.guice;version="2.2.0"
+Export-Package: org.eclipse.fx.core.guice;version="2.3.0"
diff --git a/bundles/runtime/org.eclipse.fx.core.guice/pom.xml b/bundles/runtime/org.eclipse.fx.core.guice/pom.xml
index 3c61e8a53..de6e2630f 100755
--- a/bundles/runtime/org.eclipse.fx.core.guice/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.core.guice/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.core.log4j/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.core.log4j/META-INF/MANIFEST.MF
index e63af2030..a91681752 100755
--- a/bundles/runtime/org.eclipse.fx.core.log4j/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.core.log4j/META-INF/MANIFEST.MF
@@ -2,14 +2,14 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.fx.core.log4j
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Service-Component: OSGI-INF/services/org.eclipse.fx.core.log4j.Log4JLoggerFactory.xml
Import-Package: javax.inject;version="1.0.0",
org.apache.log4j;version="1.2.15",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.log;version="2.2.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.log;version="2.3.0",
org.osgi.service.component.annotations;version="1.2.0"
Bundle-Vendor: %Bundle-Vendor
diff --git a/bundles/runtime/org.eclipse.fx.core.log4j/pom.xml b/bundles/runtime/org.eclipse.fx.core.log4j/pom.xml
index 9330eff66..5c724397b 100755
--- a/bundles/runtime/org.eclipse.fx.core.log4j/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.core.log4j/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.core.p2/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.core.p2/META-INF/MANIFEST.MF
index 821ebf637..4bb4f9936 100755
--- a/bundles/runtime/org.eclipse.fx.core.p2/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.core.p2/META-INF/MANIFEST.MF
@@ -2,15 +2,15 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: P2
Bundle-SymbolicName: org.eclipse.fx.core.p2
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Import-Package: org.eclipse.equinox.p2.core;version="2.0.0",
org.eclipse.equinox.p2.operations;version="2.0.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.log;version="2.2.0",
- org.eclipse.fx.core.operation;version="2.2.0",
- org.eclipse.fx.core.update;version="2.2.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.log;version="2.3.0",
+ org.eclipse.fx.core.operation;version="2.3.0",
+ org.eclipse.fx.core.update;version="2.3.0",
org.osgi.framework;version="1.3.0",
org.osgi.service.component.annotations;version="1.2.0"
Require-Bundle: org.eclipse.core.jobs,
diff --git a/bundles/runtime/org.eclipse.fx.core.p2/pom.xml b/bundles/runtime/org.eclipse.fx.core.p2/pom.xml
index 4b974ad30..2a1b394b4 100755
--- a/bundles/runtime/org.eclipse.fx.core.p2/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.core.p2/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.core.slf4j/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.core.slf4j/META-INF/MANIFEST.MF
index 238214b11..054baab97 100644
--- a/bundles/runtime/org.eclipse.fx.core.slf4j/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.core.slf4j/META-INF/MANIFEST.MF
@@ -2,13 +2,13 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.fx.core.slf4j
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Service-Component: OSGI-INF/slf4jlogger.xml
Import-Package: javax.inject;version="1.0.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.log;version="2.2.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.log;version="2.3.0",
org.slf4j;version="1.7.2"
Bundle-Vendor: %Bundle-Vendor
diff --git a/bundles/runtime/org.eclipse.fx.core.slf4j/pom.xml b/bundles/runtime/org.eclipse.fx.core.slf4j/pom.xml
index 7c5abbe5a..81469c41f 100755
--- a/bundles/runtime/org.eclipse.fx.core.slf4j/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.core.slf4j/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.core/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.core/META-INF/MANIFEST.MF
index c9110f81e..01426bc61 100755
--- a/bundles/runtime/org.eclipse.fx.core/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.core/META-INF/MANIFEST.MF
@@ -2,23 +2,23 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.fx.core
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: javax.annotation;resolution:=optional,
javax.inject;version="1.0.0",
org.apache.commons.lang.text;version="2.6.0",
org.osgi.framework;version="1.8.0";resolution:=optional,
org.osgi.service.component.annotations;version="1.2.0";resolution:=optional
-Export-Package: org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.adapter;version="2.2.0",
- org.eclipse.fx.core.command;version="2.2.0",
- org.eclipse.fx.core.event;version="2.2.0",
- org.eclipse.fx.core.function;version="2.2.0",
- org.eclipse.fx.core.log;version="2.2.0",
- org.eclipse.fx.core.operation;version="2.2.0",
- org.eclipse.fx.core.preferences;version="2.2.0",
- org.eclipse.fx.core.text;version="2.2.0",
- org.eclipse.fx.core.update;version="2.2.0"
+Export-Package: org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.adapter;version="2.3.0",
+ org.eclipse.fx.core.command;version="2.3.0",
+ org.eclipse.fx.core.event;version="2.3.0",
+ org.eclipse.fx.core.function;version="2.3.0",
+ org.eclipse.fx.core.log;version="2.3.0",
+ org.eclipse.fx.core.operation;version="2.3.0",
+ org.eclipse.fx.core.preferences;version="2.3.0",
+ org.eclipse.fx.core.text;version="2.3.0",
+ org.eclipse.fx.core.update;version="2.3.0"
Bundle-Vendor: %Bundle-Vendor
Service-Component: OSGI-INF/services/org.eclipse.fx.core.internal.JAXBObjectSerializer.xml,
OSGI-INF/services/org.eclipse.fx.core.internal.JUtilLoggerFactory.xml,
diff --git a/bundles/runtime/org.eclipse.fx.core/pom.xml b/bundles/runtime/org.eclipse.fx.core/pom.xml
index 7aae08e5d..fb751e314 100755
--- a/bundles/runtime/org.eclipse.fx.core/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.core/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.core/src/org/eclipse/fx/core/Util.java b/bundles/runtime/org.eclipse.fx.core/src/org/eclipse/fx/core/Util.java
index e437ffd45..e44edec82 100644
--- a/bundles/runtime/org.eclipse.fx.core/src/org/eclipse/fx/core/Util.java
+++ b/bundles/runtime/org.eclipse.fx.core/src/org/eclipse/fx/core/Util.java
@@ -342,6 +342,14 @@ public class Util {
}
/**
+ * @return <code>true</code> if running on windows
+ * @since 2.2.0
+ */
+ public static boolean isWindows() {
+ return System.getProperty("os.name").toLowerCase().contains("windows"); //$NON-NLS-1$//$NON-NLS-2$
+ }
+
+ /**
* Constraint the given value to the upper and lower bound
*
* @param v
diff --git a/bundles/runtime/org.eclipse.fx.emf.databinding/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.emf.databinding/META-INF/MANIFEST.MF
index 0340e731a..25ab0aec6 100755
--- a/bundles/runtime/org.eclipse.fx.emf.databinding/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.emf.databinding/META-INF/MANIFEST.MF
@@ -2,11 +2,11 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: EMF Databinding for JavaFX
Bundle-SymbolicName: org.eclipse.fx.emf.databinding
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: org.osgi.framework;version="1.3.0"
Require-Bundle: org.eclipse.emf.edit;bundle-version="2.7.0",
org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
-Export-Package: org.eclipse.fx.emf.databinding.edit;version="2.2.0"
+Export-Package: org.eclipse.fx.emf.databinding.edit;version="2.3.0"
Bundle-Vendor: Eclipse.org
diff --git a/bundles/runtime/org.eclipse.fx.emf.databinding/pom.xml b/bundles/runtime/org.eclipse.fx.emf.databinding/pom.xml
index d94261944..dfde1b1cf 100755
--- a/bundles/runtime/org.eclipse.fx.emf.databinding/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.emf.databinding/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.emf.edit.ui/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.emf.edit.ui/META-INF/MANIFEST.MF
index 61ea33b10..3f777d955 100755
--- a/bundles/runtime/org.eclipse.fx.emf.edit.ui/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.emf.edit.ui/META-INF/MANIFEST.MF
@@ -2,12 +2,12 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: EMF Edit UI for JavaFX
Bundle-SymbolicName: org.eclipse.fx.emf.edit.ui
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.emf.edit;bundle-version="2.7.0",
org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
-Export-Package: org.eclipse.fx.emf.edit.ui;version="2.2.0",
- org.eclipse.fx.emf.edit.ui.dnd;version="2.2.0"
+Export-Package: org.eclipse.fx.emf.edit.ui;version="2.3.0",
+ org.eclipse.fx.emf.edit.ui.dnd;version="2.3.0"
Bundle-Vendor: Eclipse.org
-Import-Package: org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.ui.controls.tree;version="2.2.0"
+Import-Package: org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.ui.controls.tree;version="2.3.0"
diff --git a/bundles/runtime/org.eclipse.fx.emf.edit.ui/pom.xml b/bundles/runtime/org.eclipse.fx.emf.edit.ui/pom.xml
index 5d0c27ede..c45a1e211 100755
--- a/bundles/runtime/org.eclipse.fx.emf.edit.ui/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.emf.edit.ui/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.formats.svg/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.formats.svg/META-INF/MANIFEST.MF
index 049524daf..9ab4359fc 100755
--- a/bundles/runtime/org.eclipse.fx.formats.svg/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.formats.svg/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.fx.formats.svg;singleton:=true
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
diff --git a/bundles/runtime/org.eclipse.fx.formats.svg/pom.xml b/bundles/runtime/org.eclipse.fx.formats.svg/pom.xml
index fc610f111..d5159b2a8 100755
--- a/bundles/runtime/org.eclipse.fx.formats.svg/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.formats.svg/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.javafx/pom.xml b/bundles/runtime/org.eclipse.fx.javafx/pom.xml
index 7559fe5b6..b17b881aa 100755
--- a/bundles/runtime/org.eclipse.fx.javafx/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.javafx/pom.xml
@@ -11,7 +11,7 @@
<groupId>org.eclipse.fx.shared</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.shared.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.osgi.util/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.osgi.util/META-INF/MANIFEST.MF
index 7e76cd747..9fcfce7d6 100755
--- a/bundles/runtime/org.eclipse.fx.osgi.util/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.osgi.util/META-INF/MANIFEST.MF
@@ -2,16 +2,18 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.fx.osgi.util
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: org.eclipse.equinox.app;version="1.1.0";resolution:=optional,
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.databinding;version="2.2.0";resolution:=optional,
+Import-Package: javax.inject;version="1.0.0",
+ org.eclipse.equinox.app;version="1.1.0";resolution:=optional,
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.databinding;version="2.3.0";resolution:=optional,
org.osgi.framework;version="1.6.0",
org.osgi.framework.wiring;version="1.0.0",
org.osgi.service.component.annotations;version="1.2.0";resolution:=optional,
- org.osgi.service.event;version="1.3.0";resolution:=optional
-Export-Package: org.eclipse.fx.osgi.util;version="2.2.0"
+ org.osgi.service.event;version="1.3.0";resolution:=optional,
+ org.osgi.service.url;version="1.0.0"
+Export-Package: org.eclipse.fx.osgi.util;version="2.3.0"
Bundle-Vendor: %Bundle-Vendor
Require-Bundle: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional,
org.eclipse.core.databinding.observable;bundle-version="1.4.1";resolution:=optional,
diff --git a/bundles/runtime/org.eclipse.fx.osgi.util/pom.xml b/bundles/runtime/org.eclipse.fx.osgi.util/pom.xml
index 7020dc997..54584662c 100755
--- a/bundles/runtime/org.eclipse.fx.osgi.util/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.osgi.util/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.osgi/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.osgi/META-INF/MANIFEST.MF
index 400b8b9be..c99faf4c8 100755
--- a/bundles/runtime/org.eclipse.fx.osgi/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.osgi/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.fx.osgi
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Fragment-Host: org.eclipse.osgi;bundle-version="3.10.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-Vendor: %Bundle-Vendor
diff --git a/bundles/runtime/org.eclipse.fx.osgi/pom.xml b/bundles/runtime/org.eclipse.fx.osgi/pom.xml
index afbf81a49..260619129 100755
--- a/bundles/runtime/org.eclipse.fx.osgi/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.osgi/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx.shared</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.shared.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.animation/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.animation/META-INF/MANIFEST.MF
index 0075e77c9..9473b8fbb 100755
--- a/bundles/runtime/org.eclipse.fx.ui.animation/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.animation/META-INF/MANIFEST.MF
@@ -2,11 +2,11 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Animationutils
Bundle-SymbolicName: org.eclipse.fx.ui.animation;singleton:=true
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: Eclipse.org
-Export-Package: org.eclipse.fx.ui.animation;version="2.2.0",
- org.eclipse.fx.ui.animation.morph;version="2.2.0",
- org.eclipse.fx.ui.animation.pagetransition;version="2.2.0",
- org.eclipse.fx.ui.animation.pagetransition.animation;version="2.2.0"
+Export-Package: org.eclipse.fx.ui.animation;version="2.3.0",
+ org.eclipse.fx.ui.animation.morph;version="2.3.0",
+ org.eclipse.fx.ui.animation.pagetransition;version="2.3.0",
+ org.eclipse.fx.ui.animation.pagetransition.animation;version="2.3.0"
Require-Bundle: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
diff --git a/bundles/runtime/org.eclipse.fx.ui.animation/pom.xml b/bundles/runtime/org.eclipse.fx.ui.animation/pom.xml
index 7035571dc..b72827074 100755
--- a/bundles/runtime/org.eclipse.fx.ui.animation/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.animation/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.controls/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.controls/META-INF/MANIFEST.MF
index 495004ff3..a8d88f39a 100644
--- a/bundles/runtime/org.eclipse.fx.ui.controls/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.controls/META-INF/MANIFEST.MF
@@ -2,35 +2,35 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Controls
Bundle-SymbolicName: org.eclipse.fx.ui.controls
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
-Export-Package: org.eclipse.fx.ui.controls;version="2.2.0",
- org.eclipse.fx.ui.controls.dialog;version="2.2.0";x-internal:=true,
- org.eclipse.fx.ui.controls.dnd;version="2.2.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx",
- org.eclipse.fx.ui.controls.filesystem;version="2.2.0",
- org.eclipse.fx.ui.controls.image;version="2.2.0",
- org.eclipse.fx.ui.controls.list;version="2.2.0",
- org.eclipse.fx.ui.controls.markers;version="2.2.0",
- org.eclipse.fx.ui.controls.media;version="2.2.0",
- org.eclipse.fx.ui.controls.paint;version="2.2.0",
- org.eclipse.fx.ui.controls.sceneviewer;version="2.2.0",
- org.eclipse.fx.ui.controls.stage;version="2.2.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx",
- org.eclipse.fx.ui.controls.styledtext;version="2.2.0",
- org.eclipse.fx.ui.controls.styledtext.behavior;version="2.2.0";x-internal:=true,
+Export-Package: org.eclipse.fx.ui.controls;version="2.3.0",
+ org.eclipse.fx.ui.controls.dialog;version="2.3.0";x-internal:=true,
+ org.eclipse.fx.ui.controls.dnd;version="2.3.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx",
+ org.eclipse.fx.ui.controls.filesystem;version="2.3.0",
+ org.eclipse.fx.ui.controls.image;version="2.3.0",
+ org.eclipse.fx.ui.controls.list;version="2.3.0",
+ org.eclipse.fx.ui.controls.markers;version="2.3.0",
+ org.eclipse.fx.ui.controls.media;version="2.3.0",
+ org.eclipse.fx.ui.controls.paint;version="2.3.0",
+ org.eclipse.fx.ui.controls.sceneviewer;version="2.3.0",
+ org.eclipse.fx.ui.controls.stage;version="2.3.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx",
+ org.eclipse.fx.ui.controls.styledtext;version="2.3.0",
+ org.eclipse.fx.ui.controls.styledtext.behavior;version="2.3.0";x-internal:=true,
org.eclipse.fx.ui.controls.styledtext.events,
org.eclipse.fx.ui.controls.styledtext.model,
- org.eclipse.fx.ui.controls.styledtext.skin;version="2.2.0";x-internal:=true,
+ org.eclipse.fx.ui.controls.styledtext.skin;version="2.3.0";x-internal:=true,
org.eclipse.fx.ui.controls.table,
- org.eclipse.fx.ui.controls.tabpane;version="2.2.0",
- org.eclipse.fx.ui.controls.tree;version="2.2.0",
- org.eclipse.fx.ui.controls.vectorgraphics;version="2.2.0"
+ org.eclipse.fx.ui.controls.tabpane;version="2.3.0",
+ org.eclipse.fx.ui.controls.tree;version="2.3.0",
+ org.eclipse.fx.ui.controls.vectorgraphics;version="2.3.0"
Bundle-ActivationPolicy: lazy
Service-Component: OSGI-INF/services/org.eclipse.fx.ui.controls.styledtext.UnderlineStrategyFactory.xml,
OSGI-INF/services/org.eclipse.fx.ui.controls.image.fontawesome.FontAwesomeIconFontProvider.xml
Bundle-Vendor: Eclipse.org
Import-Package: com.google.common.collect;version="15.0.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.text;version="2.2.0",
- org.eclipse.fx.ui.panes;version="2.2.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.text;version="2.3.0",
+ org.eclipse.fx.ui.panes;version="2.3.0",
org.osgi.service.component.annotations;resolution:=optional
diff --git a/bundles/runtime/org.eclipse.fx.ui.controls/pom.xml b/bundles/runtime/org.eclipse.fx.ui.controls/pom.xml
index 75da950a6..f014e3421 100755
--- a/bundles/runtime/org.eclipse.fx.ui.controls/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.controls/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.controls/src/controls.cssext b/bundles/runtime/org.eclipse.fx.ui.controls/src/controls.cssext
index f40c79f42..63f2354ae 100644
--- a/bundles/runtime/org.eclipse.fx.ui.controls/src/controls.cssext
+++ b/bundles/runtime/org.eclipse.fx.ui.controls/src/controls.cssext
@@ -1,10 +1,17 @@
import javafx.scene.Group
package org.eclipse.fx.ui.controls {
- PositionMarker extends Group styleclass position-marker {
- -fx-fill <javafx.paint> default: "rgb(0, 139, 255)";
+ package markers {
+ PositionMarker extends Group styleclass position-marker {
+ -fx-fill <javafx.paint> default: "rgb(0, 139, 255)";
+ }
+ TabOutlineMarker extends Group styleclass tab-outline-marker {
+ -fx-fill <javafx.paint> default: "orange";
+ }
}
- TabOutlineMarker extends Group styleclass tab-outline-marker {
- -fx-fill <javafx.paint> default: "orange";
+ package styledtext {
+ StyledTextArea extends javafx.scene.control.Control {
+ -fx-fixed-line-height <javafx.length> default: 12;
+ }
}
} \ No newline at end of file
diff --git a/bundles/runtime/org.eclipse.fx.ui.databinding/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.databinding/META-INF/MANIFEST.MF
index 46535c360..308ed9527 100644
--- a/bundles/runtime/org.eclipse.fx.ui.databinding/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.databinding/META-INF/MANIFEST.MF
@@ -2,13 +2,13 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Databinding
Bundle-SymbolicName: org.eclipse.fx.ui.databinding
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.core.databinding.observable;bundle-version="1.4.1",
org.eclipse.core.databinding.property,
org.eclipse.core.databinding,
org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
-Export-Package: org.eclipse.fx.ui.databinding;version="2.2.0",
- org.eclipse.fx.ui.databinding.converters;version="2.2.0"
+Export-Package: org.eclipse.fx.ui.databinding;version="2.3.0",
+ org.eclipse.fx.ui.databinding.converters;version="2.3.0"
Bundle-Vendor: Eclipse.org
-Import-Package: org.eclipse.fx.core.databinding;version="2.2.0"
+Import-Package: org.eclipse.fx.core.databinding;version="2.3.0"
diff --git a/bundles/runtime/org.eclipse.fx.ui.databinding/pom.xml b/bundles/runtime/org.eclipse.fx.ui.databinding/pom.xml
index 4f394833f..ebf0e7115 100755
--- a/bundles/runtime/org.eclipse.fx.ui.databinding/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.databinding/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.di.interopt/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.di.interopt/META-INF/MANIFEST.MF
index ec0cc4766..a5046ff5e 100644
--- a/bundles/runtime/org.eclipse.fx.ui.di.interopt/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.di.interopt/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Interopt
Bundle-SymbolicName: org.eclipse.fx.ui.di.interopt
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.swt;bundle-version="3.100.1";resolution:=optional,
org.eclipse.e4.core.contexts;bundle-version="1.2.0",
@@ -15,9 +15,9 @@ Service-Component: OSGI-INF/services/org.eclipse.fx.ui.di.interopt.UISynchronize
OSGI-INF/services/org.eclipse.fx.ui.di.interopt.InteroptContextFunction.xml,
OSGI-INF/services/org.eclipse.fx.ui.di.interopt.CommandServiceImplCF.xml
Import-Package: javax.inject;version="1.0.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.command;version="2.2.0",
- org.eclipse.fx.core.log;version="2.2.0",
- org.eclipse.fx.ui.services.theme;version="2.2.0";resolution:=optional,
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.command;version="2.3.0",
+ org.eclipse.fx.core.log;version="2.3.0",
+ org.eclipse.fx.ui.services.theme;version="2.3.0";resolution:=optional,
org.osgi.service.component.annotations;version="1.2.0";resolution:=optional
Bundle-Vendor: Eclipse.org
diff --git a/bundles/runtime/org.eclipse.fx.ui.di.interopt/pom.xml b/bundles/runtime/org.eclipse.fx.ui.di.interopt/pom.xml
index 01158dcb6..7860b13c7 100755
--- a/bundles/runtime/org.eclipse.fx.ui.di.interopt/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.di.interopt/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.di/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.di/META-INF/MANIFEST.MF
index 0f5a8e64f..78bab28a6 100755
--- a/bundles/runtime/org.eclipse.fx.ui.di/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.di/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.fx.ui.di
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.e4.core.contexts;bundle-version="0.9.0",
org.eclipse.e4.core.di;bundle-version="0.9.0",
@@ -11,13 +11,13 @@ Require-Bundle: org.eclipse.core.runtime,
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: javax.annotation;version="1.0.0";resolution:=optional,
javax.inject;version="1.0.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.fxml;version="2.2.0",
- org.eclipse.fx.core.log;version="2.2.0",
- org.eclipse.fx.osgi.util;version="2.2.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.fxml;version="2.3.0",
+ org.eclipse.fx.core.log;version="2.3.0",
+ org.eclipse.fx.osgi.util;version="2.3.0",
org.osgi.service.component.annotations;version="1.2.0"
Bundle-ActivationPolicy: lazy
-Export-Package: org.eclipse.fx.ui.di;version="2.2.0"
+Export-Package: org.eclipse.fx.ui.di;version="2.3.0"
Service-Component: OSGI-INF/services/org.eclipse.fx.ui.di.internal.ResourcePoolFactory.xml,
OSGI-INF/services/org.eclipse.fx.ui.di.internal.FXMLLoaderSupplier.xml,
OSGI-INF/services/org.eclipse.fx.ui.di.internal.ResourceServiceImpl.xml
diff --git a/bundles/runtime/org.eclipse.fx.ui.di/pom.xml b/bundles/runtime/org.eclipse.fx.ui.di/pom.xml
index d3d0d5291..2c17dc47b 100755
--- a/bundles/runtime/org.eclipse.fx.ui.di/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.di/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.dialogs/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.dialogs/META-INF/MANIFEST.MF
index 84f61984d..5cd229d59 100755
--- a/bundles/runtime/org.eclipse.fx.ui.dialogs/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.dialogs/META-INF/MANIFEST.MF
@@ -2,10 +2,10 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Dialogs
Bundle-SymbolicName: org.eclipse.fx.ui.dialogs
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Require-Bundle: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Export-Package: org.eclipse.fx.ui.dialogs;version="2.2.0"
+Export-Package: org.eclipse.fx.ui.dialogs;version="2.3.0"
Bundle-Vendor: Eclipse.org
-Import-Package: org.eclipse.fx.ui.controls.stage;version="2.2.0",
- org.eclipse.fx.ui.panes;version="2.2.0"
+Import-Package: org.eclipse.fx.ui.controls.stage;version="2.3.0",
+ org.eclipse.fx.ui.panes;version="2.3.0"
diff --git a/bundles/runtime/org.eclipse.fx.ui.dialogs/pom.xml b/bundles/runtime/org.eclipse.fx.ui.dialogs/pom.xml
index a4707beee..0b974704a 100755
--- a/bundles/runtime/org.eclipse.fx.ui.dialogs/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.dialogs/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.keybindings.e4/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.keybindings.e4/META-INF/MANIFEST.MF
index 90e9b3bb1..4f979a7ff 100755
--- a/bundles/runtime/org.eclipse.fx.ui.keybindings.e4/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.keybindings.e4/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: E4
Bundle-SymbolicName: org.eclipse.fx.ui.keybindings.e4
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.e4.core.contexts;bundle-version="1.1.0",
org.eclipse.e4.core.di;bundle-version="1.1.0",
@@ -16,9 +16,9 @@ Require-Bundle: org.eclipse.e4.core.contexts;bundle-version="1.1.0",
org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: javax.annotation;version="1.2.0";resolution:=optional,
javax.inject;version="1.0.0",
- org.eclipse.fx.core.log;version="2.2.0",
- org.eclipse.fx.ui.keybindings;version="2.2.0",
- org.eclipse.fx.ui.keybindings.service;version="2.2.0",
+ org.eclipse.fx.core.log;version="2.3.0",
+ org.eclipse.fx.ui.keybindings;version="2.3.0",
+ org.eclipse.fx.ui.keybindings.service;version="2.3.0",
org.osgi.service.event;version="1.3.1"
-Export-Package: org.eclipse.fx.ui.keybindings.e4;version="2.2.0"
+Export-Package: org.eclipse.fx.ui.keybindings.e4;version="2.3.0"
Bundle-Vendor: Eclipse.org
diff --git a/bundles/runtime/org.eclipse.fx.ui.keybindings.e4/pom.xml b/bundles/runtime/org.eclipse.fx.ui.keybindings.e4/pom.xml
index 326017745..0668336cd 100755
--- a/bundles/runtime/org.eclipse.fx.ui.keybindings.e4/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.keybindings.e4/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/.settings/ca.ecliptical.pde.ds.prefs b/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/.settings/ca.ecliptical.pde.ds.prefs
new file mode 100644
index 000000000..3c38f2952
--- /dev/null
+++ b/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/.settings/ca.ecliptical.pde.ds.prefs
@@ -0,0 +1,5 @@
+eclipse.preferences.version=1
+enabled=true
+path=OSGI-INF/services
+validationErrorLevel=error
+validationErrorLevel.missingImplicitUnbindMethod=error
diff --git a/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/META-INF/MANIFEST.MF
index 122f73049..48d94836b 100755
--- a/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/META-INF/MANIFEST.MF
@@ -2,13 +2,13 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Generic
Bundle-SymbolicName: org.eclipse.fx.ui.keybindings.generic
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.core.commands;bundle-version="3.6.0",
org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
-Service-Component: OSGI-INF/org.eclipse.fx.ui.keybindings.generic.BindingFactoryImpl.xml
+Service-Component: OSGI-INF/services/org.eclipse.fx.ui.keybindings.generic.BindingFactoryImpl.xml
Bundle-Vendor: Eclipse.org
-Import-Package: org.eclipse.fx.ui.keybindings;version="2.2.0",
- org.eclipse.fx.ui.keybindings.service;version="2.2.0",
+Import-Package: org.eclipse.fx.ui.keybindings;version="2.3.0",
+ org.eclipse.fx.ui.keybindings.service;version="2.3.0",
org.osgi.service.component.annotations;version="1.2.0";resolution:=optional
diff --git a/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/OSGI-INF/org.eclipse.fx.ui.keybindings.generic.BindingFactoryImpl.xml b/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/OSGI-INF/services/org.eclipse.fx.ui.keybindings.generic.BindingFactoryImpl.xml
index 2825b193c..35311cf18 100644
--- a/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/OSGI-INF/org.eclipse.fx.ui.keybindings.generic.BindingFactoryImpl.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/OSGI-INF/services/org.eclipse.fx.ui.keybindings.generic.BindingFactoryImpl.xml
@@ -1,7 +1,7 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<scr:component xmlns:scr="http://www.osgi.org/xmlns/scr/v1.1.0" name="org.eclipse.fx.ui.keybindings.generic.BindingFactoryImpl">
- <implementation class="org.eclipse.fx.ui.keybindings.generic.BindingFactoryImpl"/>
- <service>
- <provide interface="org.eclipse.fx.ui.keybindings.service.BindingFactory"/>
- </service>
+<?xml version="1.0" encoding="UTF-8"?>
+<scr:component xmlns:scr="http://www.osgi.org/xmlns/scr/v1.1.0" name="org.eclipse.fx.ui.keybindings.generic.BindingFactoryImpl">
+ <service>
+ <provide interface="org.eclipse.fx.ui.keybindings.service.BindingFactory"/>
+ </service>
+ <implementation class="org.eclipse.fx.ui.keybindings.generic.BindingFactoryImpl"/>
</scr:component> \ No newline at end of file
diff --git a/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/pom.xml b/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/pom.xml
index 4d86cfeaa..728990821 100755
--- a/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.keybindings.generic/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.keybindings/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.keybindings/META-INF/MANIFEST.MF
index 6a3d08027..1fe74645d 100755
--- a/bundles/runtime/org.eclipse.fx.ui.keybindings/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.keybindings/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Bindings
Bundle-SymbolicName: org.eclipse.fx.ui.keybindings
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Require-Bundle: org.eclipse.core.commands;bundle-version="3.6.0",
@@ -11,6 +11,6 @@ Require-Bundle: org.eclipse.core.commands;bundle-version="3.6.0",
org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: javax.annotation;version="1.0.0";resolution:=optional,
javax.inject;version="1.0.0"
-Export-Package: org.eclipse.fx.ui.keybindings;version="2.2.0",
- org.eclipse.fx.ui.keybindings.service;version="2.2.0"
+Export-Package: org.eclipse.fx.ui.keybindings;version="2.3.0",
+ org.eclipse.fx.ui.keybindings.service;version="2.3.0"
Bundle-Vendor: Eclipse.org
diff --git a/bundles/runtime/org.eclipse.fx.ui.keybindings/pom.xml b/bundles/runtime/org.eclipse.fx.ui.keybindings/pom.xml
index 983124dd3..bbd8f14c5 100755
--- a/bundles/runtime/org.eclipse.fx.ui.keybindings/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.keybindings/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.mobile/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.mobile/META-INF/MANIFEST.MF
index ff3a3587d..7a22081ed 100644
--- a/bundles/runtime/org.eclipse.fx.ui.mobile/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.mobile/META-INF/MANIFEST.MF
@@ -2,9 +2,9 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Mobile
Bundle-SymbolicName: org.eclipse.fx.ui.mobile
-Bundle-Version: 2.2.0.qualifier
-Export-Package: org.eclipse.fx.ui.mobile;version="2.2.0",
- org.eclipse.fx.ui.mobile.animations;version="2.2.0"
+Bundle-Version: 2.3.0.qualifier
+Export-Package: org.eclipse.fx.ui.mobile;version="2.3.0",
+ org.eclipse.fx.ui.mobile.animations;version="2.3.0"
Require-Bundle: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: Eclipse.org
diff --git a/bundles/runtime/org.eclipse.fx.ui.mobile/pom.xml b/bundles/runtime/org.eclipse.fx.ui.mobile/pom.xml
index 21b1daf88..934f25038 100755
--- a/bundles/runtime/org.eclipse.fx.ui.mobile/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.mobile/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.modelviewer/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.modelviewer/META-INF/MANIFEST.MF
index 9fc834d22..c1e3850fa 100644
--- a/bundles/runtime/org.eclipse.fx.ui.modelviewer/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.modelviewer/META-INF/MANIFEST.MF
@@ -2,14 +2,14 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Modelviewer
Bundle-SymbolicName: org.eclipse.fx.ui.modelviewer;singleton:=true
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: javax.annotation;version="1.1.0";resolution:=optional,
javax.inject;version="1.0.0",
- org.eclipse.fx.core.databinding;version="2.2.0",
- org.eclipse.fx.core.di;version="2.2.0",
- org.eclipse.fx.core.log;version="2.2.0",
- org.eclipse.fx.ui.databinding;version="2.2.0"
+ org.eclipse.fx.core.databinding;version="2.3.0",
+ org.eclipse.fx.core.di;version="2.3.0",
+ org.eclipse.fx.core.log;version="2.3.0",
+ org.eclipse.fx.ui.databinding;version="2.3.0"
Require-Bundle: org.eclipse.e4.ui.model.workbench;bundle-version="1.0.1",
org.eclipse.core.databinding;bundle-version="1.4.1",
org.eclipse.core.databinding.observable;bundle-version="1.4.1",
@@ -18,7 +18,7 @@ Require-Bundle: org.eclipse.e4.ui.model.workbench;bundle-version="1.0.1",
org.eclipse.emf.databinding;bundle-version="1.3.0",
org.eclipse.emf.databinding.edit;bundle-version="1.3.0",
org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
-Export-Package: org.eclipse.fx.ui.modelviewer;version="2.2.0"
+Export-Package: org.eclipse.fx.ui.modelviewer;version="2.3.0"
Service-Component: OSGI-INF/services/registry.xml,
OSGI-INF/services/defaultDelegates.xml
Bundle-ActivationPolicy: lazy
diff --git a/bundles/runtime/org.eclipse.fx.ui.panes/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.panes/META-INF/MANIFEST.MF
index c7e06abf1..a227411d8 100755
--- a/bundles/runtime/org.eclipse.fx.ui.panes/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.panes/META-INF/MANIFEST.MF
@@ -2,8 +2,8 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.fx.ui.panes
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Vendor: %Bundle-Vendor
-Export-Package: org.eclipse.fx.ui.panes;version="2.2.0"
+Export-Package: org.eclipse.fx.ui.panes;version="2.3.0"
Require-Bundle: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
diff --git a/bundles/runtime/org.eclipse.fx.ui.panes/pom.xml b/bundles/runtime/org.eclipse.fx.ui.panes/pom.xml
index d252f5ee9..df75de2d4 100755
--- a/bundles/runtime/org.eclipse.fx.ui.panes/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.panes/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.services/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.services/META-INF/MANIFEST.MF
index 51b98a6d9..1f4047c24 100755
--- a/bundles/runtime/org.eclipse.fx.ui.services/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.services/META-INF/MANIFEST.MF
@@ -2,22 +2,22 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.fx.ui.services
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Export-Package: org.eclipse.fx.ui.services;version="2.2.0",
- org.eclipse.fx.ui.services.commands;version="2.2.0",
- org.eclipse.fx.ui.services.dialog;version="2.2.0",
- org.eclipse.fx.ui.services.resources;version="2.2.0",
- org.eclipse.fx.ui.services.restart;version="2.2.0",
- org.eclipse.fx.ui.services.startup;version="2.2.0",
- org.eclipse.fx.ui.services.sync;version="2.2.0",
- org.eclipse.fx.ui.services.theme;version="2.2.0"
+Export-Package: org.eclipse.fx.ui.services;version="2.3.0",
+ org.eclipse.fx.ui.services.commands;version="2.3.0",
+ org.eclipse.fx.ui.services.dialog;version="2.3.0",
+ org.eclipse.fx.ui.services.resources;version="2.3.0",
+ org.eclipse.fx.ui.services.restart;version="2.3.0",
+ org.eclipse.fx.ui.services.startup;version="2.3.0",
+ org.eclipse.fx.ui.services.sync;version="2.3.0",
+ org.eclipse.fx.ui.services.theme;version="2.3.0"
Bundle-Vendor: %Bundle-Vendor
Import-Package: javax.inject;version="1.0.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.ui.controls;version="2.2.0",
- org.eclipse.fx.ui.controls.image;version="2.2.0",
- org.eclipse.fx.ui.controls.stage;version="2.2.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.ui.controls;version="2.3.0",
+ org.eclipse.fx.ui.controls.image;version="2.3.0",
+ org.eclipse.fx.ui.controls.stage;version="2.3.0",
org.osgi.service.component.annotations;version="1.2.0"
Require-Bundle: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional,
org.eclipse.core.runtime;bundle-version="3.10.0";resolution:=optional
diff --git a/bundles/runtime/org.eclipse.fx.ui.services/pom.xml b/bundles/runtime/org.eclipse.fx.ui.services/pom.xml
index 57e2bee62..3543e81b5 100755
--- a/bundles/runtime/org.eclipse.fx.ui.services/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.services/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.theme/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.theme/META-INF/MANIFEST.MF
index d8c23ddda..7895b142e 100755
--- a/bundles/runtime/org.eclipse.fx.ui.theme/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.theme/META-INF/MANIFEST.MF
@@ -2,18 +2,18 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.fx.ui.theme;singleton:=true
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-Activator: org.eclipse.fx.ui.theme.internal.Activator
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.jdt.annotation;bundle-version="1.1.0";resolution:=optional
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Service-Component: OSGI-INF/services/org.eclipse.fx.ui.theme.internal.DefaultThemeManager.xml
-Import-Package: org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.log;version="2.2.0",
- org.eclipse.fx.ui.services;version="2.2.0",
- org.eclipse.fx.ui.services.theme;version="2.2.0",
+Import-Package: org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.log;version="2.3.0",
+ org.eclipse.fx.ui.services;version="2.3.0",
+ org.eclipse.fx.ui.services.theme;version="2.3.0",
org.osgi.service.component.annotations;version="1.2.0";resolution:=optional,
org.osgi.service.event;version="1.3.0"
Bundle-Vendor: %Bundle-Vendor
-Export-Package: org.eclipse.fx.ui.theme;version="2.2.0"
+Export-Package: org.eclipse.fx.ui.theme;version="2.3.0"
diff --git a/bundles/runtime/org.eclipse.fx.ui.theme/pom.xml b/bundles/runtime/org.eclipse.fx.ui.theme/pom.xml
index bd390522b..e43aec07c 100755
--- a/bundles/runtime/org.eclipse.fx.ui.theme/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.theme/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.workbench.base/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.workbench.base/META-INF/MANIFEST.MF
index 5913fc235..33ee96b3f 100755
--- a/bundles/runtime/org.eclipse.fx.ui.workbench.base/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.workbench.base/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Base
Bundle-SymbolicName: org.eclipse.fx.ui.workbench.base
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.e4.core.contexts;bundle-version="1.1.0",
org.eclipse.e4.ui.model.workbench;bundle-version="0.10.1",
@@ -21,19 +21,19 @@ Require-Bundle: org.eclipse.e4.core.contexts;bundle-version="1.1.0",
org.eclipse.e4.core.commands,
org.eclipse.core.commands;bundle-version="3.6.100",
org.eclipse.emf.ecore.xmi;bundle-version="2.11.0"
-Export-Package: org.eclipse.fx.ui.workbench.base;version="2.2.0";x-friends:="org.eclipse.fx.ui.workbench.fx,org.eclipse.fx.ui.workbench.renderers.fx,org.eclipse.fx.ui.workbench.renderers.base",
- org.eclipse.fx.ui.workbench.base.rendering;version="2.2.0";x-friends:="org.eclipse.fx.ui.workbench.fx,org.eclipse.fx.ui.workbench.renderers.fx,org.eclipse.fx.ui.workbench.renderers.base"
+Export-Package: org.eclipse.fx.ui.workbench.base;version="2.3.0";x-friends:="org.eclipse.fx.ui.workbench.fx,org.eclipse.fx.ui.workbench.renderers.fx,org.eclipse.fx.ui.workbench.renderers.base",
+ org.eclipse.fx.ui.workbench.base.rendering;version="2.3.0";x-friends:="org.eclipse.fx.ui.workbench.fx,org.eclipse.fx.ui.workbench.renderers.fx,org.eclipse.fx.ui.workbench.renderers.base"
Import-Package: javax.annotation;version="1.2.0";resolution:=optional,
javax.inject;version="1.0.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.adapter;version="2.2.0",
- org.eclipse.fx.core.command;version="2.2.0",
- org.eclipse.fx.core.log;version="2.2.0",
- org.eclipse.fx.ui.services;version="2.2.0",
- org.eclipse.fx.ui.services.restart;version="2.2.0",
- org.eclipse.fx.ui.services.startup;version="2.2.0",
- org.eclipse.fx.ui.services.sync;version="2.2.0",
- org.eclipse.fx.ui.workbench.services;version="2.2.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.adapter;version="2.3.0",
+ org.eclipse.fx.core.command;version="2.3.0",
+ org.eclipse.fx.core.log;version="2.3.0",
+ org.eclipse.fx.ui.services;version="2.3.0",
+ org.eclipse.fx.ui.services.restart;version="2.3.0",
+ org.eclipse.fx.ui.services.startup;version="2.3.0",
+ org.eclipse.fx.ui.services.sync;version="2.3.0",
+ org.eclipse.fx.ui.workbench.services;version="2.3.0",
org.osgi.service.component.annotations;version="1.2.0"
Bundle-Activator: org.eclipse.fx.ui.workbench.base.internal.Activator
Bundle-ActivationPolicy: lazy
diff --git a/bundles/runtime/org.eclipse.fx.ui.workbench.base/pom.xml b/bundles/runtime/org.eclipse.fx.ui.workbench.base/pom.xml
index 0ce7c3ee3..922e46289 100755
--- a/bundles/runtime/org.eclipse.fx.ui.workbench.base/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.workbench.base/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.workbench.fx/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.workbench.fx/META-INF/MANIFEST.MF
index 9a320ab82..c4f66f0ff 100755
--- a/bundles/runtime/org.eclipse.fx.ui.workbench.fx/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.workbench.fx/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Fx
Bundle-SymbolicName: org.eclipse.fx.ui.workbench.fx;singleton:=true
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.e4.core.contexts;bundle-version="1.1.0",
org.eclipse.e4.core.di;bundle-version="1.1.0",
@@ -19,29 +19,29 @@ Require-Bundle: org.eclipse.e4.core.contexts;bundle-version="1.1.0",
org.eclipse.core.databinding.observable;bundle-version="1.4.1",
org.eclipse.e4.core.di.extensions;bundle-version="0.12.0"
Import-Package: org.apache.commons.lang.text;version="2.6.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.databinding;version="2.2.0",
- org.eclipse.fx.core.function;version="2.2.0",
- org.eclipse.fx.core.log;version="2.2.0",
- org.eclipse.fx.osgi.util;version="2.2.0",
- org.eclipse.fx.ui.keybindings;version="2.2.0",
- org.eclipse.fx.ui.keybindings.e4;version="2.2.0",
- org.eclipse.fx.ui.keybindings.service;version="2.2.0",
- org.eclipse.fx.ui.services;version="2.2.0",
- org.eclipse.fx.ui.services.commands;version="2.2.0",
- org.eclipse.fx.ui.services.resources;version="2.2.0",
- org.eclipse.fx.ui.services.startup;version="2.2.0",
- org.eclipse.fx.ui.services.sync;version="2.2.0",
- org.eclipse.fx.ui.services.theme;version="2.2.0",
- org.eclipse.fx.ui.workbench.base;version="2.2.0",
- org.eclipse.fx.ui.workbench.base.rendering;version="2.2.0",
- org.eclipse.fx.ui.workbench.renderers.base.widget;version="2.2.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.databinding;version="2.3.0",
+ org.eclipse.fx.core.function;version="2.3.0",
+ org.eclipse.fx.core.log;version="2.3.0",
+ org.eclipse.fx.osgi.util;version="2.3.0",
+ org.eclipse.fx.ui.keybindings;version="2.3.0",
+ org.eclipse.fx.ui.keybindings.e4;version="2.3.0",
+ org.eclipse.fx.ui.keybindings.service;version="2.3.0",
+ org.eclipse.fx.ui.services;version="2.3.0",
+ org.eclipse.fx.ui.services.commands;version="2.3.0",
+ org.eclipse.fx.ui.services.resources;version="2.3.0",
+ org.eclipse.fx.ui.services.startup;version="2.3.0",
+ org.eclipse.fx.ui.services.sync;version="2.3.0",
+ org.eclipse.fx.ui.services.theme;version="2.3.0",
+ org.eclipse.fx.ui.workbench.base;version="2.3.0",
+ org.eclipse.fx.ui.workbench.base.rendering;version="2.3.0",
+ org.eclipse.fx.ui.workbench.renderers.base.widget;version="2.3.0",
org.eclipse.osgi.service.environment;version="1.3.0",
org.osgi.framework;version="1.6.0",
org.osgi.service.component.annotations;version="1.2.0",
org.osgi.service.event;version="1.3.0"
-Export-Package: org.eclipse.fx.ui.workbench.fx;version="2.2.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx",
- org.eclipse.fx.ui.workbench.fx.key;version="2.2.0";x-internal:=true
+Export-Package: org.eclipse.fx.ui.workbench.fx;version="2.3.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx",
+ org.eclipse.fx.ui.workbench.fx.key;version="2.3.0";x-internal:=true
Bundle-ActivationPolicy: lazy
Service-Component: OSGI-INF/services/org.eclipse.fx.ui.workbench.fx.internal.UISynchronizeImpl.xml,
OSGI-INF/services/org.eclipse.fx.ui.workbench.fx.key.FxKeyLookup.xml,
diff --git a/bundles/runtime/org.eclipse.fx.ui.workbench.fx/pom.xml b/bundles/runtime/org.eclipse.fx.ui.workbench.fx/pom.xml
index b60e0201b..a5f84c4e1 100755
--- a/bundles/runtime/org.eclipse.fx.ui.workbench.fx/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.workbench.fx/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.base/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.base/META-INF/MANIFEST.MF
index fdc068d9c..5ec2750bd 100755
--- a/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.base/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.base/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Base
Bundle-SymbolicName: org.eclipse.fx.ui.workbench.renderers.base
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Require-Bundle: org.eclipse.e4.ui.model.workbench;bundle-version="1.1.0",
org.eclipse.e4.core.contexts;bundle-version="1.1.0",
org.eclipse.e4.core.services;bundle-version="1.0.0",
@@ -19,21 +19,21 @@ Require-Bundle: org.eclipse.e4.ui.model.workbench;bundle-version="1.1.0",
Import-Package: com.google.common.base;version="15.0.0",
javax.annotation;version="1.0.0";resolution:=optional,
javax.inject;version="1.0.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.di;version="2.2.0",
- org.eclipse.fx.core.log;version="2.2.0",
- org.eclipse.fx.ui.keybindings;version="2.2.0",
- org.eclipse.fx.ui.keybindings.e4;version="2.2.0",
- org.eclipse.fx.ui.workbench.base.rendering;version="2.2.0",
- org.eclipse.fx.ui.workbench.services;version="2.2.0",
- org.eclipse.fx.ui.workbench.services.lifecycle.annotation;version="2.2.0",
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.di;version="2.3.0",
+ org.eclipse.fx.core.log;version="2.3.0",
+ org.eclipse.fx.ui.keybindings;version="2.3.0",
+ org.eclipse.fx.ui.keybindings.e4;version="2.3.0",
+ org.eclipse.fx.ui.workbench.base.rendering;version="2.3.0",
+ org.eclipse.fx.ui.workbench.services;version="2.3.0",
+ org.eclipse.fx.ui.workbench.services.lifecycle.annotation;version="2.3.0",
org.osgi.service.component.annotations;version="1.2.0";resolution:=optional,
org.osgi.service.event;version="1.3.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Export-Package: org.eclipse.fx.ui.workbench.renderers.base;version="2.2.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx",
- org.eclipse.fx.ui.workbench.renderers.base.addons;version="2.2.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx",
- org.eclipse.fx.ui.workbench.renderers.base.services;version="2.2.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx",
- org.eclipse.fx.ui.workbench.renderers.base.widget;version="2.2.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx"
+Export-Package: org.eclipse.fx.ui.workbench.renderers.base;version="2.3.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx",
+ org.eclipse.fx.ui.workbench.renderers.base.addons;version="2.3.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx",
+ org.eclipse.fx.ui.workbench.renderers.base.services;version="2.3.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx",
+ org.eclipse.fx.ui.workbench.renderers.base.widget;version="2.3.0";x-friends:="org.eclipse.fx.ui.workbench.renderers.fx"
Bundle-Vendor: Eclipse.org
Service-Component: OSGI-INF/services/org.eclipse.fx.ui.workbench.renderers.base.internal.MaximizationServiceContextFunction.xml
Bundle-ActivationPolicy: lazy
diff --git a/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.base/pom.xml b/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.base/pom.xml
index 9d52a7200..4022983de 100755
--- a/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.base/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.base/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.fx/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.fx/META-INF/MANIFEST.MF
index 974e1d3c1..46585d24b 100755
--- a/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.fx/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.fx/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Fx
Bundle-SymbolicName: org.eclipse.fx.ui.workbench.renderers.fx
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.e4.ui.model.workbench;bundle-version="0.10.1",
org.eclipse.core.commands;bundle-version="3.6.0",
@@ -20,29 +20,29 @@ Require-Bundle: org.eclipse.e4.ui.model.workbench;bundle-version="0.10.1",
Import-Package: com.google.common.base;version="15.0.0",
javax.annotation;version="1.0.0";resolution:=optional,
javax.inject;version="1.0.0",
- org.eclipse.fx.core;version="2.2.0",
- org.eclipse.fx.core.log;version="2.2.0",
- org.eclipse.fx.ui.controls.dialog;version="2.2.0",
- org.eclipse.fx.ui.controls.dnd;version="2.2.0",
- org.eclipse.fx.ui.controls.markers;version="2.2.0",
- org.eclipse.fx.ui.controls.stage;version="2.2.0",
- org.eclipse.fx.ui.controls.tabpane;version="2.2.0",
- org.eclipse.fx.ui.di;version="2.2.0",
- org.eclipse.fx.ui.dialogs;version="2.2.0",
- org.eclipse.fx.ui.keybindings;version="2.2.0",
- org.eclipse.fx.ui.panes;version="2.2.0",
- org.eclipse.fx.ui.services;version="2.2.0",
- org.eclipse.fx.ui.services.dialog;version="2.2.0",
- org.eclipse.fx.ui.services.resources;version="2.2.0",
- org.eclipse.fx.ui.services.sync;version="2.2.0",
- org.eclipse.fx.ui.services.theme;version="2.2.0",
- org.eclipse.fx.ui.workbench.base.rendering;version="2.2.0",
- org.eclipse.fx.ui.workbench.fx;version="2.2.0",
- org.eclipse.fx.ui.workbench.fx.key;version="2.2.0",
- org.eclipse.fx.ui.workbench.renderers.base;version="2.2.0",
- org.eclipse.fx.ui.workbench.renderers.base.services;version="2.2.0",
- org.eclipse.fx.ui.workbench.renderers.base.widget;version="2.2.0",
- org.eclipse.fx.ui.workbench.services;version="2.2.0"
+ org.eclipse.fx.core;version="2.3.0",
+ org.eclipse.fx.core.log;version="2.3.0",
+ org.eclipse.fx.ui.controls.dialog;version="2.3.0",
+ org.eclipse.fx.ui.controls.dnd;version="2.3.0",
+ org.eclipse.fx.ui.controls.markers;version="2.3.0",
+ org.eclipse.fx.ui.controls.stage;version="2.3.0",
+ org.eclipse.fx.ui.controls.tabpane;version="2.3.0",
+ org.eclipse.fx.ui.di;version="2.3.0",
+ org.eclipse.fx.ui.dialogs;version="2.3.0",
+ org.eclipse.fx.ui.keybindings;version="2.3.0",
+ org.eclipse.fx.ui.panes;version="2.3.0",
+ org.eclipse.fx.ui.services;version="2.3.0",
+ org.eclipse.fx.ui.services.dialog;version="2.3.0",
+ org.eclipse.fx.ui.services.resources;version="2.3.0",
+ org.eclipse.fx.ui.services.sync;version="2.3.0",
+ org.eclipse.fx.ui.services.theme;version="2.3.0",
+ org.eclipse.fx.ui.workbench.base.rendering;version="2.3.0",
+ org.eclipse.fx.ui.workbench.fx;version="2.3.0",
+ org.eclipse.fx.ui.workbench.fx.key;version="2.3.0",
+ org.eclipse.fx.ui.workbench.renderers.base;version="2.3.0",
+ org.eclipse.fx.ui.workbench.renderers.base.services;version="2.3.0",
+ org.eclipse.fx.ui.workbench.renderers.base.widget;version="2.3.0",
+ org.eclipse.fx.ui.workbench.services;version="2.3.0"
Service-Component: OSGI-INF/services/org.eclipse.fx.ui.workbench.renderers.fx.internal.FXDialogServiceFunction.xml,
OSGI-INF/services/org.eclipse.fx.ui.workbench.renderers.fx.internal.DefaultDnDFeedback.xml,
OSGI-INF/services/org.eclipse.fx.ui.workbench.renderers.fx.internal.PartPopupMenuServiceFunction.xml
diff --git a/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.fx/pom.xml b/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.fx/pom.xml
index ae5fd9a18..fc0a024ca 100755
--- a/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.fx/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.workbench.renderers.fx/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.workbench.services/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.workbench.services/META-INF/MANIFEST.MF
index 015025b9f..260175117 100644
--- a/bundles/runtime/org.eclipse.fx.ui.workbench.services/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.workbench.services/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Services
Bundle-SymbolicName: org.eclipse.fx.ui.workbench.services
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.e4.ui.model.workbench;bundle-version="1.1.0",
org.eclipse.jdt.annotation;bundle-version="2.0.0";resolution:=optional,
@@ -12,9 +12,9 @@ Require-Bundle: org.eclipse.e4.ui.model.workbench;bundle-version="1.1.0",
org.eclipse.e4.core.di;bundle-version="1.4.0",
org.eclipse.emf.common,
org.eclipse.emf.ecore;bundle-version="2.10.0"
-Export-Package: org.eclipse.fx.ui.workbench.services;version="2.2.0",
- org.eclipse.fx.ui.workbench.services.lifecycle;version="2.2.0",
- org.eclipse.fx.ui.workbench.services.lifecycle.annotation;version="2.2.0"
+Export-Package: org.eclipse.fx.ui.workbench.services;version="2.3.0",
+ org.eclipse.fx.ui.workbench.services.lifecycle;version="2.3.0",
+ org.eclipse.fx.ui.workbench.services.lifecycle.annotation;version="2.3.0"
Import-Package: javax.annotation;version="1.2.0";resolution:=optional,
javax.inject;version="1.0.0",
org.osgi.service.component.annotations;version="1.2.0",
diff --git a/bundles/runtime/org.eclipse.fx.ui.workbench.services/pom.xml b/bundles/runtime/org.eclipse.fx.ui.workbench.services/pom.xml
index d0ea09dae..900d4cb6e 100755
--- a/bundles/runtime/org.eclipse.fx.ui.workbench.services/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.workbench.services/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/bundles/runtime/org.eclipse.fx.ui.workbench3/META-INF/MANIFEST.MF b/bundles/runtime/org.eclipse.fx.ui.workbench3/META-INF/MANIFEST.MF
index d1bdfc87e..000833d8c 100755
--- a/bundles/runtime/org.eclipse.fx.ui.workbench3/META-INF/MANIFEST.MF
+++ b/bundles/runtime/org.eclipse.fx.ui.workbench3/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.fx.ui.workbench3
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Require-Bundle: org.eclipse.ui.workbench;bundle-version="3.7.0";visibility:=reexport,
org.eclipse.swt;bundle-version="3.7.0";visibility:=reexport,
diff --git a/bundles/runtime/org.eclipse.fx.ui.workbench3/pom.xml b/bundles/runtime/org.eclipse.fx.ui.workbench3/pom.xml
index 31c4fc3a0..2021cb153 100755
--- a/bundles/runtime/org.eclipse.fx.ui.workbench3/pom.xml
+++ b/bundles/runtime/org.eclipse.fx.ui.workbench3/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx.shared</groupId>
<artifactId>releng</artifactId>
<relativePath>../../../releng/org.eclipse.fx.shared.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<build>
diff --git a/releng/code/org.eclipse.fx.code.target.feature/feature.xml b/releng/code/org.eclipse.fx.code.target.feature/feature.xml
index 17927bebc..b480ad26c 100644
--- a/releng/code/org.eclipse.fx.code.target.feature/feature.xml
+++ b/releng/code/org.eclipse.fx.code.target.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.fx.code.target.feature"
label="Code editing target platform"
- version="2.2.0.qualifier"
+ version="2.3.0.qualifier"
provider-name="Eclipse.org">
<description>
diff --git a/releng/code/org.eclipse.fx.code.target.feature/pom.xml b/releng/code/org.eclipse.fx.code.target.feature/pom.xml
index cccb43774..605f4d6ff 100644
--- a/releng/code/org.eclipse.fx.code.target.feature/pom.xml
+++ b/releng/code/org.eclipse.fx.code.target.feature/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
</project> \ No newline at end of file
diff --git a/releng/org.eclipse.fx.core.shared.updatesite/pom.xml b/releng/org.eclipse.fx.core.shared.updatesite/pom.xml
index 8b31c30aa..9b028e464 100644
--- a/releng/org.eclipse.fx.core.shared.updatesite/pom.xml
+++ b/releng/org.eclipse.fx.core.shared.updatesite/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx.shared</groupId>
<artifactId>releng</artifactId>
<relativePath>../org.eclipse.fx.shared.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<properties>
diff --git a/releng/org.eclipse.fx.core.shared.updatesite/site.xml b/releng/org.eclipse.fx.core.shared.updatesite/site.xml
index 407baaa8a..50ce471de 100644
--- a/releng/org.eclipse.fx.core.shared.updatesite/site.xml
+++ b/releng/org.eclipse.fx.core.shared.updatesite/site.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<site>
- <feature url="features/org.eclipse.fx.core.shared.feature_2.2.0.qualifier.jar" id="org.eclipse.fx.core.shared.feature" version="2.2.0.qualifier"/>
- <feature url="features/org.eclipse.fx.runtime.min.feature_2.2.0.qualifier.jar" id="org.eclipse.fx.runtime.min.feature" version="2.2.0.qualifier"/>
+ <feature url="features/org.eclipse.fx.core.shared.feature_2.3.0.qualifier.jar" id="org.eclipse.fx.core.shared.feature" version="2.3.0.qualifier"/>
+ <feature url="features/org.eclipse.fx.runtime.min.feature_2.3.0.qualifier.jar" id="org.eclipse.fx.runtime.min.feature" version="2.3.0.qualifier"/>
</site>
diff --git a/releng/org.eclipse.fx.releng/pom.xml b/releng/org.eclipse.fx.releng/pom.xml
index 7e9f50dd7..e4b79d0e1 100755
--- a/releng/org.eclipse.fx.releng/pom.xml
+++ b/releng/org.eclipse.fx.releng/pom.xml
@@ -11,7 +11,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
<packaging>pom</packaging>
<properties>
<tycho-version>0.23.1</tycho-version>
diff --git a/releng/org.eclipse.fx.runtime.doc/META-INF/MANIFEST.MF b/releng/org.eclipse.fx.runtime.doc/META-INF/MANIFEST.MF
index 2abfad6fe..6e248fbb2 100644
--- a/releng/org.eclipse.fx.runtime.doc/META-INF/MANIFEST.MF
+++ b/releng/org.eclipse.fx.runtime.doc/META-INF/MANIFEST.MF
@@ -2,5 +2,5 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Doc
Bundle-SymbolicName: org.eclipse.fx.runtime.doc
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/releng/org.eclipse.fx.runtime.doc/pom.xml b/releng/org.eclipse.fx.runtime.doc/pom.xml
index bd5267c0e..7015b6b09 100755
--- a/releng/org.eclipse.fx.runtime.doc/pom.xml
+++ b/releng/org.eclipse.fx.runtime.doc/pom.xml
@@ -10,14 +10,14 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<dependencies>
<dependency>
<groupId>org.eclipse.fx.runtime</groupId>
<artifactId>org.eclipse.fx.runtime.feature</artifactId>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</dependency>
</dependencies>
diff --git a/releng/org.eclipse.fx.shared.doc/META-INF/MANIFEST.MF b/releng/org.eclipse.fx.shared.doc/META-INF/MANIFEST.MF
index 4e73c9f4f..9e20b68bf 100644
--- a/releng/org.eclipse.fx.shared.doc/META-INF/MANIFEST.MF
+++ b/releng/org.eclipse.fx.shared.doc/META-INF/MANIFEST.MF
@@ -2,5 +2,5 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Doc
Bundle-SymbolicName: org.eclipse.fx.shared.doc
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
diff --git a/releng/org.eclipse.fx.shared.doc/pom.xml b/releng/org.eclipse.fx.shared.doc/pom.xml
index f232bbbe4..bece38a19 100755
--- a/releng/org.eclipse.fx.shared.doc/pom.xml
+++ b/releng/org.eclipse.fx.shared.doc/pom.xml
@@ -10,14 +10,14 @@
<groupId>org.eclipse.fx.shared</groupId>
<artifactId>releng</artifactId>
<relativePath>../org.eclipse.fx.shared.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<dependencies>
<dependency>
<groupId>org.eclipse.fx.shared</groupId>
<artifactId>org.eclipse.fx.core.shared.feature</artifactId>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</dependency>
</dependencies>
diff --git a/releng/org.eclipse.fx.shared.releng/pom.xml b/releng/org.eclipse.fx.shared.releng/pom.xml
index 41ec6f4a7..d99ec9459 100755
--- a/releng/org.eclipse.fx.shared.releng/pom.xml
+++ b/releng/org.eclipse.fx.shared.releng/pom.xml
@@ -11,7 +11,7 @@
<groupId>org.eclipse.fx.shared</groupId>
<artifactId>releng</artifactId>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
<packaging>pom</packaging>
<properties>
<tycho-version>0.22.0</tycho-version>
diff --git a/releng/org.eclipse.fx.updatesite/pom.xml b/releng/org.eclipse.fx.updatesite/pom.xml
index 77e5191b1..48eac90c1 100644
--- a/releng/org.eclipse.fx.updatesite/pom.xml
+++ b/releng/org.eclipse.fx.updatesite/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
<properties>
diff --git a/releng/org.eclipse.fx.updatesite/site.xml b/releng/org.eclipse.fx.updatesite/site.xml
index 5d8aac1f6..ef9b7c49e 100644
--- a/releng/org.eclipse.fx.updatesite/site.xml
+++ b/releng/org.eclipse.fx.updatesite/site.xml
@@ -1,27 +1,27 @@
<?xml version="1.0" encoding="UTF-8"?>
<site>
- <feature url="features/org.eclipse.fx.core.feature_2.2.0.qualifier.jar" id="org.eclipse.fx.core.feature" version="2.2.0.qualifier">
+ <feature url="features/org.eclipse.fx.core.feature_2.3.0.qualifier.jar" id="org.eclipse.fx.core.feature" version="2.3.0.qualifier">
<category name="fxruntime"/>
</feature>
- <feature url="features/org.eclipse.fx.target.feature_2.2.0.qualifier.jar" id="org.eclipse.fx.target.feature" version="2.2.0.qualifier">
+ <feature url="features/org.eclipse.fx.target.feature_2.3.0.qualifier.jar" id="org.eclipse.fx.target.feature" version="2.3.0.qualifier">
<category name="fxtarget"/>
</feature>
- <feature url="features/org.eclipse.fx.target.rcp.feature_2.2.0.qualifier.jar" id="org.eclipse.fx.target.rcp.feature" version="2.2.0.qualifier">
+ <feature url="features/org.eclipse.fx.target.rcp.feature_2.3.0.qualifier.jar" id="org.eclipse.fx.target.rcp.feature" version="2.3.0.qualifier">
<category name="fxtarget"/>
</feature>
- <feature url="features/org.eclipse.fx.runtime.feature_2.2.0.qualifier.jar" id="org.eclipse.fx.runtime.feature" version="2.2.0.qualifier">
+ <feature url="features/org.eclipse.fx.runtime.feature_2.3.0.qualifier.jar" id="org.eclipse.fx.runtime.feature" version="2.3.0.qualifier">
<category name="fxruntime"/>
</feature>
- <feature url="features/org.eclipse.fx.target.rcp4.feature_2.2.0.qualifier.jar" id="org.eclipse.fx.target.rcp4.feature" version="2.2.0.qualifier">
+ <feature url="features/org.eclipse.fx.target.rcp4.feature_2.3.0.qualifier.jar" id="org.eclipse.fx.target.rcp4.feature" version="2.3.0.qualifier">
<category name="fxtarget"/>
</feature>
- <feature url="features/org.eclipse.fx.runtime.min.feature_2.2.0.qualifier.jar" id="org.eclipse.fx.runtime.min.feature" version="2.2.0.qualifier">
+ <feature url="features/org.eclipse.fx.runtime.min.feature_2.3.0.qualifier.jar" id="org.eclipse.fx.runtime.min.feature" version="2.3.0.qualifier">
<category name="fxtarget"/>
</feature>
- <feature url="features/org.eclipse.fx.code.target.feature_2.2.0.qualifier.jar" id="org.eclipse.fx.code.target.feature" version="2.2.0.qualifier">
+ <feature url="features/org.eclipse.fx.code.target.feature_2.3.0.qualifier.jar" id="org.eclipse.fx.code.target.feature" version="2.3.0.qualifier">
<category name="fxtarget"/>
</feature>
- <feature url="features/org.eclipse.fx.slf4j.target.feature_2.2.0.qualifier.jar" id="org.eclipse.fx.slf4j.target.feature" version="2.2.0.qualifier">
+ <feature url="features/org.eclipse.fx.slf4j.target.feature_2.3.0.qualifier.jar" id="org.eclipse.fx.slf4j.target.feature" version="2.3.0.qualifier">
<category name="fxtarget"/>
</feature>
<category-def name="fxruntime" label="FX Runtime"/>
diff --git a/releng/runtime/org.eclipse.fx..slf4j.target.feature/feature.xml b/releng/runtime/org.eclipse.fx..slf4j.target.feature/feature.xml
index 7d910bec9..b16d8472b 100644
--- a/releng/runtime/org.eclipse.fx..slf4j.target.feature/feature.xml
+++ b/releng/runtime/org.eclipse.fx..slf4j.target.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.fx.slf4j.target.feature"
label="Feature"
- version="2.2.0.qualifier">
+ version="2.3.0.qualifier">
<description url="http://www.example.com/description">
Feature used to define a target which holds all slf4j providers (Do not install into IDE)
diff --git a/releng/runtime/org.eclipse.fx..slf4j.target.feature/pom.xml b/releng/runtime/org.eclipse.fx..slf4j.target.feature/pom.xml
index dfe7021a8..60003b2c8 100644
--- a/releng/runtime/org.eclipse.fx..slf4j.target.feature/pom.xml
+++ b/releng/runtime/org.eclipse.fx..slf4j.target.feature/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
</project> \ No newline at end of file
diff --git a/releng/runtime/org.eclipse.fx.core.feature/feature.xml b/releng/runtime/org.eclipse.fx.core.feature/feature.xml
index ac914db9f..974cc957e 100644
--- a/releng/runtime/org.eclipse.fx.core.feature/feature.xml
+++ b/releng/runtime/org.eclipse.fx.core.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.fx.core.feature"
label="e(fx)clipse core Feature"
- version="2.2.0.qualifier"
+ version="2.3.0.qualifier"
provider-name="Eclipse.org">
<description>
diff --git a/releng/runtime/org.eclipse.fx.core.feature/pom.xml b/releng/runtime/org.eclipse.fx.core.feature/pom.xml
index 850a7806c..f500ed849 100644
--- a/releng/runtime/org.eclipse.fx.core.feature/pom.xml
+++ b/releng/runtime/org.eclipse.fx.core.feature/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
</project> \ No newline at end of file
diff --git a/releng/runtime/org.eclipse.fx.core.shared.feature/feature.xml b/releng/runtime/org.eclipse.fx.core.shared.feature/feature.xml
index 71259ed5c..c940703bb 100644
--- a/releng/runtime/org.eclipse.fx.core.shared.feature/feature.xml
+++ b/releng/runtime/org.eclipse.fx.core.shared.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.fx.core.shared.feature"
label="Feature"
- version="2.2.0.qualifier"
+ version="2.3.0.qualifier"
provider-name="Eclipse.org">
<description>
@@ -74,7 +74,7 @@ including, but not limited to the following locations:
- Feature directories
Note: if a Feature made available by the Eclipse Foundation is installed using the
-Provisioning Technology (as defined below), you must agree to a license (&quot;Feature
+Provisioning Technology (as defined below), you must agree to a license (&quot;Feature
Update License&quot;) during the installation process. If the Feature contains
Included Features, the Feature Update License should either provide you
with the terms and conditions governing the Included Features or inform
diff --git a/releng/runtime/org.eclipse.fx.core.shared.feature/pom.xml b/releng/runtime/org.eclipse.fx.core.shared.feature/pom.xml
index 07d96852b..9d5fd9e3b 100644
--- a/releng/runtime/org.eclipse.fx.core.shared.feature/pom.xml
+++ b/releng/runtime/org.eclipse.fx.core.shared.feature/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx.shared</groupId>
<artifactId>releng</artifactId>
<relativePath>../../org.eclipse.fx.shared.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
</project> \ No newline at end of file
diff --git a/releng/runtime/org.eclipse.fx.runtime.e4fx.feature/feature.xml b/releng/runtime/org.eclipse.fx.runtime.e4fx.feature/feature.xml
index bf88e9420..2c616fe88 100644
--- a/releng/runtime/org.eclipse.fx.runtime.e4fx.feature/feature.xml
+++ b/releng/runtime/org.eclipse.fx.runtime.e4fx.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.fx.runtime.e4fx.feature"
label="minimal e4 application framework feature"
- version="2.2.0.qualifier"
+ version="2.3.0.qualifier"
provider-name="Eclipse.org">
<description url="http://www.example.com/description">
diff --git a/releng/runtime/org.eclipse.fx.runtime.e4fx.feature/pom.xml b/releng/runtime/org.eclipse.fx.runtime.e4fx.feature/pom.xml
index 5c7c037c5..4ad536544 100644
--- a/releng/runtime/org.eclipse.fx.runtime.e4fx.feature/pom.xml
+++ b/releng/runtime/org.eclipse.fx.runtime.e4fx.feature/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
</project> \ No newline at end of file
diff --git a/releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/.gitignore b/releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/.gitignore
new file mode 100644
index 000000000..b83d22266
--- /dev/null
+++ b/releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/.gitignore
@@ -0,0 +1 @@
+/target/
diff --git a/releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/feature.xml b/releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/feature.xml
index e92298d61..b9e9a5795 100644
--- a/releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/feature.xml
+++ b/releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.fx.runtime.e4fx.p2.feature"
label="Feature"
- version="2.2.0.qualifier"
+ version="2.3.0.qualifier"
provider-name="Eclipse.org">
<description>
diff --git a/releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/pom.xml b/releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/pom.xml
index 6cd3a20bd..c7238c160 100644
--- a/releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/pom.xml
+++ b/releng/runtime/org.eclipse.fx.runtime.e4fx.p2.feature/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
</project> \ No newline at end of file
diff --git a/releng/runtime/org.eclipse.fx.runtime.feature/feature.xml b/releng/runtime/org.eclipse.fx.runtime.feature/feature.xml
index 7253e4387..2aa98d760 100644
--- a/releng/runtime/org.eclipse.fx.runtime.feature/feature.xml
+++ b/releng/runtime/org.eclipse.fx.runtime.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.fx.runtime.feature"
label="Rutime Bundle Collector Feature"
- version="2.2.0.qualifier"
+ version="2.3.0.qualifier"
provider-name="Eclipse.org">
<description>
diff --git a/releng/runtime/org.eclipse.fx.runtime.feature/pom.xml b/releng/runtime/org.eclipse.fx.runtime.feature/pom.xml
index 253ef217a..82f95c8cb 100644
--- a/releng/runtime/org.eclipse.fx.runtime.feature/pom.xml
+++ b/releng/runtime/org.eclipse.fx.runtime.feature/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
</project> \ No newline at end of file
diff --git a/releng/runtime/org.eclipse.fx.runtime.min.feature/feature.xml b/releng/runtime/org.eclipse.fx.runtime.min.feature/feature.xml
index d2f017f64..f4fd83dfd 100644
--- a/releng/runtime/org.eclipse.fx.runtime.min.feature/feature.xml
+++ b/releng/runtime/org.eclipse.fx.runtime.min.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.fx.runtime.min.feature"
label="e(fx)clipse - Minimal JavaFX OSGi integration bundles"
- version="2.2.0.qualifier"
+ version="2.3.0.qualifier"
provider-name="Eclipse.org">
<description>
@@ -74,7 +74,7 @@ including, but not limited to the following locations:
- Feature directories
Note: if a Feature made available by the Eclipse Foundation is installed using the
-Provisioning Technology (as defined below), you must agree to a license (&quot;Feature
+Provisioning Technology (as defined below), you must agree to a license (&quot;Feature
Update License&quot;) during the installation process. If the Feature contains
Included Features, the Feature Update License should either provide you
with the terms and conditions governing the Included Features or inform
diff --git a/releng/runtime/org.eclipse.fx.runtime.min.feature/pom.xml b/releng/runtime/org.eclipse.fx.runtime.min.feature/pom.xml
index 73f2681b5..ce3f7f19a 100644
--- a/releng/runtime/org.eclipse.fx.runtime.min.feature/pom.xml
+++ b/releng/runtime/org.eclipse.fx.runtime.min.feature/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx.shared</groupId>
<artifactId>releng</artifactId>
<relativePath>../../org.eclipse.fx.shared.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
</project> \ No newline at end of file
diff --git a/releng/runtime/org.eclipse.fx.swtfx.feature/feature.xml b/releng/runtime/org.eclipse.fx.swtfx.feature/feature.xml
index 1b50b19a2..fa95a5b62 100644
--- a/releng/runtime/org.eclipse.fx.swtfx.feature/feature.xml
+++ b/releng/runtime/org.eclipse.fx.swtfx.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.fx.swtfx.feature"
label="SWT on JavaFX implementation"
- version="2.2.0.qualifier"
+ version="2.3.0.qualifier"
provider-name="Eclipse.org">
<description>
diff --git a/releng/runtime/org.eclipse.fx.swtfx.feature/pom.xml b/releng/runtime/org.eclipse.fx.swtfx.feature/pom.xml
index 1af990de2..aafd34502 100644
--- a/releng/runtime/org.eclipse.fx.swtfx.feature/pom.xml
+++ b/releng/runtime/org.eclipse.fx.swtfx.feature/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx.experimental</groupId>
<artifactId>releng</artifactId>
<relativePath>../../org.eclipse.fx.experimental.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
</project>
diff --git a/releng/runtime/org.eclipse.fx.target.feature/feature.xml b/releng/runtime/org.eclipse.fx.target.feature/feature.xml
index 103a3d3d9..3996af923 100644
--- a/releng/runtime/org.eclipse.fx.target.feature/feature.xml
+++ b/releng/runtime/org.eclipse.fx.target.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.fx.target.feature"
label="Target Platform Feature"
- version="2.2.0.qualifier"
+ version="2.3.0.qualifier"
provider-name="Eclipse.org">
<description>
diff --git a/releng/runtime/org.eclipse.fx.target.feature/pom.xml b/releng/runtime/org.eclipse.fx.target.feature/pom.xml
index a1da2688d..5d62079a3 100644
--- a/releng/runtime/org.eclipse.fx.target.feature/pom.xml
+++ b/releng/runtime/org.eclipse.fx.target.feature/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
</project> \ No newline at end of file
diff --git a/releng/runtime/org.eclipse.fx.target.rcp.feature/feature.xml b/releng/runtime/org.eclipse.fx.target.rcp.feature/feature.xml
index 99dcd51fa..067a07d78 100644
--- a/releng/runtime/org.eclipse.fx.target.rcp.feature/feature.xml
+++ b/releng/runtime/org.eclipse.fx.target.rcp.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.fx.target.rcp.feature"
label="RCP 3.x Target Platform Feature"
- version="2.2.0.qualifier"
+ version="2.3.0.qualifier"
provider-name="Eclipse.org">
<description>
diff --git a/releng/runtime/org.eclipse.fx.target.rcp.feature/pom.xml b/releng/runtime/org.eclipse.fx.target.rcp.feature/pom.xml
index 03419a39c..f8cc4ea4f 100644
--- a/releng/runtime/org.eclipse.fx.target.rcp.feature/pom.xml
+++ b/releng/runtime/org.eclipse.fx.target.rcp.feature/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
</project> \ No newline at end of file
diff --git a/releng/runtime/org.eclipse.fx.target.rcp4.feature/feature.xml b/releng/runtime/org.eclipse.fx.target.rcp4.feature/feature.xml
index 816be5118..fbe44b44d 100644
--- a/releng/runtime/org.eclipse.fx.target.rcp4.feature/feature.xml
+++ b/releng/runtime/org.eclipse.fx.target.rcp4.feature/feature.xml
@@ -2,7 +2,7 @@
<feature
id="org.eclipse.fx.target.rcp4.feature"
label="RCP e4 Target Platform Feature"
- version="2.2.0.qualifier"
+ version="2.3.0.qualifier"
provider-name="Eclipse.org">
<description url="http://www.example.com/description">
diff --git a/releng/runtime/org.eclipse.fx.target.rcp4.feature/pom.xml b/releng/runtime/org.eclipse.fx.target.rcp4.feature/pom.xml
index fc52c8d34..4c93809e7 100644
--- a/releng/runtime/org.eclipse.fx.target.rcp4.feature/pom.xml
+++ b/releng/runtime/org.eclipse.fx.target.rcp4.feature/pom.xml
@@ -10,7 +10,7 @@
<groupId>org.eclipse.fx</groupId>
<artifactId>releng</artifactId>
<relativePath>../../org.eclipse.fx.releng/pom.xml</relativePath>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
</parent>
</project> \ No newline at end of file

Back to the top