Skip to main content
aboutsummaryrefslogtreecommitdiffstats
path: root/tests
diff options
context:
space:
mode:
authorStéphane Bégaudeau2016-04-21 09:04:38 +0000
committerStéphane Bégaudeau2016-04-28 13:34:21 +0000
commit73797362ca3ca073156f6de1113a8113abf39129 (patch)
treee13c016e2df6637ebbca068c9a2aecaad27aa504 /tests
parentd405a1d16c71226d7ad47663f93d1f1e37351977 (diff)
downloadorg.eclipse.eef-73797362ca3ca073156f6de1113a8113abf39129.tar.gz
org.eclipse.eef-73797362ca3ca073156f6de1113a8113abf39129.tar.xz
org.eclipse.eef-73797362ca3ca073156f6de1113a8113abf39129.zip
Improve the APIs
1) Improve the documentation of two extension points (Lifecycle Manager Provider and Tab Descriptor Provider) 2) Remove two useless extension points along with their code (View Description Provider and Interpreter Provider) 3) Move some interfaces related to Lifecycle Managers in order to have all APIs for the Lifecycle Managers (2 abstract classes and 2 interfaces) in the same package. 4) Move the two classes of o.e.eef.properties.ui.legacy in an internal package since they are only used in this bundle (I18N & Messages) 5) Update the behavior of the Lifecycle Manager Provider extension point to let contibutors replace existing Lifecycle Managers Change-Id: I76aa69e0650cbc6d34e56baaadbc33bdacbcb957 Signed-off-by: Stéphane Bégaudeau <stephane.begaudeau@obeo.fr>
Diffstat (limited to 'tests')
-rw-r--r--tests/org.eclipse.eef.tests/META-INF/MANIFEST.MF2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/org.eclipse.eef.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.eef.tests/META-INF/MANIFEST.MF
index e5ca143f5..4235e8382 100644
--- a/tests/org.eclipse.eef.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.eef.tests/META-INF/MANIFEST.MF
@@ -15,5 +15,5 @@ Require-Bundle: org.junit;bundle-version="[4.11.0,5.0.0)",
org.eclipse.sirius.common.interpreter;bundle-version="[4.0.0,5.0.0)",
org.eclipse.emf.ecore.xmi;bundle-version="[2.8.0,3.0.0)",
org.eclipse.acceleo.query;bundle-version="[5.0.0,6.0.0)",
- org.antlr.runtime;bundle-version="4.3.0"
+ org.antlr.runtime;bundle-version="[4.3.0,5.0.0)"
Import-Package: com.google.common.cache;version="[15.0.0,16.0.0)"

Back to the top