Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--doc/bundles/org.eclipse.ecf.doc/plugin.xml2
-rw-r--r--doc/bundles/org.eclipse.ecf.tutorial/.classpath2
-rw-r--r--doc/bundles/org.eclipse.ecf.tutorial/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--doc/bundles/org.eclipse.ecf.tutorial/META-INF/MANIFEST.MF1
-rw-r--r--doc/bundles/org.eclipse.ecf.tutorial/plugin.xml2
-rw-r--r--examples/bundles/org.eclipse.ecf.example.clients/META-INF/MANIFEST.MF1
-rw-r--r--examples/bundles/org.eclipse.ecf.example.clients/plugin.xml2
-rw-r--r--examples/bundles/org.eclipse.ecf.example.collab.editor/.classpath2
-rw-r--r--examples/bundles/org.eclipse.ecf.example.collab.editor/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--examples/bundles/org.eclipse.ecf.example.collab.editor/META-INF/MANIFEST.MF1
-rw-r--r--examples/bundles/org.eclipse.ecf.example.collab.editor/plugin.xml2
-rw-r--r--examples/bundles/org.eclipse.ecf.example.collab/.classpath2
-rw-r--r--examples/bundles/org.eclipse.ecf.example.collab/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--examples/bundles/org.eclipse.ecf.example.collab/META-INF/MANIFEST.MF1
-rw-r--r--examples/bundles/org.eclipse.ecf.example.collab/plugin.xml2
-rw-r--r--examples/bundles/org.eclipse.ecf.example.pubsub/META-INF/MANIFEST.MF1
-rw-r--r--examples/bundles/org.eclipse.ecf.example.pubsub/plugin.xml2
-rw-r--r--examples/bundles/org.eclipse.ecf.example.sdo.editor/.classpath2
-rw-r--r--examples/bundles/org.eclipse.ecf.example.sdo.editor/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--examples/bundles/org.eclipse.ecf.example.sdo.editor/META-INF/MANIFEST.MF1
-rw-r--r--examples/bundles/org.eclipse.ecf.example.sdo.editor/plugin.xml2
-rw-r--r--examples/bundles/org.eclipse.ecf.sdo/.classpath2
-rw-r--r--examples/bundles/org.eclipse.ecf.sdo/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--examples/bundles/org.eclipse.ecf.sdo/META-INF/MANIFEST.MF1
-rw-r--r--examples/bundles/org.eclipse.ecf.sdo/plugin.xml2
-rw-r--r--framework/bundles/org.eclipse.ecf.datashare/.classpath2
-rw-r--r--framework/bundles/org.eclipse.ecf.datashare/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--framework/bundles/org.eclipse.ecf.datashare/META-INF/MANIFEST.MF1
-rw-r--r--framework/bundles/org.eclipse.ecf.discovery/.classpath2
-rw-r--r--framework/bundles/org.eclipse.ecf.discovery/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--framework/bundles/org.eclipse.ecf.discovery/META-INF/MANIFEST.MF1
-rw-r--r--framework/bundles/org.eclipse.ecf.presence/.classpath2
-rw-r--r--framework/bundles/org.eclipse.ecf.presence/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--framework/bundles/org.eclipse.ecf.presence/META-INF/MANIFEST.MF1
-rw-r--r--framework/bundles/org.eclipse.ecf.presence/plugin.xml2
-rw-r--r--framework/bundles/org.eclipse.ecf.provider/.classpath2
-rw-r--r--framework/bundles/org.eclipse.ecf.provider/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--framework/bundles/org.eclipse.ecf.provider/META-INF/MANIFEST.MF1
-rw-r--r--framework/bundles/org.eclipse.ecf.provider/plugin.xml2
-rw-r--r--framework/bundles/org.eclipse.ecf.ui/.classpath2
-rw-r--r--framework/bundles/org.eclipse.ecf.ui/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--framework/bundles/org.eclipse.ecf.ui/META-INF/MANIFEST.MF1
-rw-r--r--framework/bundles/org.eclipse.ecf.ui/plugin.xml2
-rw-r--r--framework/bundles/org.eclipse.ecf/.classpath2
-rw-r--r--framework/bundles/org.eclipse.ecf/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--framework/bundles/org.eclipse.ecf/META-INF/MANIFEST.MF1
-rw-r--r--framework/bundles/org.eclipse.ecf/plugin.xml2
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.datashare/.classpath2
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.datashare/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.datashare/META-INF/MANIFEST.MF1
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.datashare/plugin.xml2
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.jmdns/.classpath2
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.jmdns/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.jmdns/META-INF/MANIFEST.MF1
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.jmdns/plugin.xml2
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.xmpp/.classpath2
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.xmpp/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.xmpp/META-INF/MANIFEST.MF1
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.xmpp/plugin.xml2
-rw-r--r--server-side/bundles/org.eclipse.ecf.server/.classpath2
-rw-r--r--server-side/bundles/org.eclipse.ecf.server/.settings/org.eclipse.jdt.core.prefs7
-rw-r--r--server-side/bundles/org.eclipse.ecf.server/META-INF/MANIFEST.MF1
62 files changed, 152 insertions, 30 deletions
diff --git a/doc/bundles/org.eclipse.ecf.doc/plugin.xml b/doc/bundles/org.eclipse.ecf.doc/plugin.xml
index 5d4ff8bd4..ad23ff0ea 100644
--- a/doc/bundles/org.eclipse.ecf.doc/plugin.xml
+++ b/doc/bundles/org.eclipse.ecf.doc/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
<extension
diff --git a/doc/bundles/org.eclipse.ecf.tutorial/.classpath b/doc/bundles/org.eclipse.ecf.tutorial/.classpath
index 751c8f2e5..ce7393340 100644
--- a/doc/bundles/org.eclipse.ecf.tutorial/.classpath
+++ b/doc/bundles/org.eclipse.ecf.tutorial/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/doc/bundles/org.eclipse.ecf.tutorial/.settings/org.eclipse.jdt.core.prefs b/doc/bundles/org.eclipse.ecf.tutorial/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..03ef9ecf2
--- /dev/null
+++ b/doc/bundles/org.eclipse.ecf.tutorial/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:32:09 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/doc/bundles/org.eclipse.ecf.tutorial/META-INF/MANIFEST.MF b/doc/bundles/org.eclipse.ecf.tutorial/META-INF/MANIFEST.MF
index d5d59978f..42da47233 100644
--- a/doc/bundles/org.eclipse.ecf.tutorial/META-INF/MANIFEST.MF
+++ b/doc/bundles/org.eclipse.ecf.tutorial/META-INF/MANIFEST.MF
@@ -16,3 +16,4 @@ Require-Bundle: org.eclipse.core.runtime,
Eclipse-LazyStart: true
Eclipse-AutoStart: true
Bundle-ClassPath: tutorial.jar
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/doc/bundles/org.eclipse.ecf.tutorial/plugin.xml b/doc/bundles/org.eclipse.ecf.tutorial/plugin.xml
index 46cd46588..449fb7505 100644
--- a/doc/bundles/org.eclipse.ecf.tutorial/plugin.xml
+++ b/doc/bundles/org.eclipse.ecf.tutorial/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
<extension
point="org.eclipse.ui.actionSets">
diff --git a/examples/bundles/org.eclipse.ecf.example.clients/META-INF/MANIFEST.MF b/examples/bundles/org.eclipse.ecf.example.clients/META-INF/MANIFEST.MF
index 27f5cd58c..a21b7f915 100644
--- a/examples/bundles/org.eclipse.ecf.example.clients/META-INF/MANIFEST.MF
+++ b/examples/bundles/org.eclipse.ecf.example.clients/META-INF/MANIFEST.MF
@@ -12,4 +12,5 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.ecf,
org.eclipse.ecf.presence,
org.eclipse.ecf.provider.xmpp
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/examples/bundles/org.eclipse.ecf.example.clients/plugin.xml b/examples/bundles/org.eclipse.ecf.example.clients/plugin.xml
index 7e0f87227..309fc2165 100644
--- a/examples/bundles/org.eclipse.ecf.example.clients/plugin.xml
+++ b/examples/bundles/org.eclipse.ecf.example.clients/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
<extension
id="robot"
diff --git a/examples/bundles/org.eclipse.ecf.example.collab.editor/.classpath b/examples/bundles/org.eclipse.ecf.example.collab.editor/.classpath
index 751c8f2e5..ce7393340 100644
--- a/examples/bundles/org.eclipse.ecf.example.collab.editor/.classpath
+++ b/examples/bundles/org.eclipse.ecf.example.collab.editor/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/examples/bundles/org.eclipse.ecf.example.collab.editor/.settings/org.eclipse.jdt.core.prefs b/examples/bundles/org.eclipse.ecf.example.collab.editor/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..a7f5c9abc
--- /dev/null
+++ b/examples/bundles/org.eclipse.ecf.example.collab.editor/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:15:44 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/examples/bundles/org.eclipse.ecf.example.collab.editor/META-INF/MANIFEST.MF b/examples/bundles/org.eclipse.ecf.example.collab.editor/META-INF/MANIFEST.MF
index 7fdb68681..8337ab6cc 100644
--- a/examples/bundles/org.eclipse.ecf.example.collab.editor/META-INF/MANIFEST.MF
+++ b/examples/bundles/org.eclipse.ecf.example.collab.editor/META-INF/MANIFEST.MF
@@ -24,3 +24,4 @@ Require-Bundle: org.eclipse.ui,
Eclipse-LazyStart: true
Bundle-Vendor: Eclipse.org
Bundle-ClassPath: collabeditor.jar
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/examples/bundles/org.eclipse.ecf.example.collab.editor/plugin.xml b/examples/bundles/org.eclipse.ecf.example.collab.editor/plugin.xml
index bbb29f4a3..56282a0ae 100644
--- a/examples/bundles/org.eclipse.ecf.example.collab.editor/plugin.xml
+++ b/examples/bundles/org.eclipse.ecf.example.collab.editor/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
<extension
diff --git a/examples/bundles/org.eclipse.ecf.example.collab/.classpath b/examples/bundles/org.eclipse.ecf.example.collab/.classpath
index 751c8f2e5..ce7393340 100644
--- a/examples/bundles/org.eclipse.ecf.example.collab/.classpath
+++ b/examples/bundles/org.eclipse.ecf.example.collab/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/examples/bundles/org.eclipse.ecf.example.collab/.settings/org.eclipse.jdt.core.prefs b/examples/bundles/org.eclipse.ecf.example.collab/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..4ce28dd67
--- /dev/null
+++ b/examples/bundles/org.eclipse.ecf.example.collab/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:15:24 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/examples/bundles/org.eclipse.ecf.example.collab/META-INF/MANIFEST.MF b/examples/bundles/org.eclipse.ecf.example.collab/META-INF/MANIFEST.MF
index d8e1054ea..8c9229165 100644
--- a/examples/bundles/org.eclipse.ecf.example.collab/META-INF/MANIFEST.MF
+++ b/examples/bundles/org.eclipse.ecf.example.collab/META-INF/MANIFEST.MF
@@ -25,3 +25,4 @@ Export-Package: org.eclipse.ecf.example.collab, org.eclipse.ecf.example.collab.s
Eclipse-LazyStart: true
Provide-Package: org.eclipse.ecf.example.collab
Bundle-ManifestVersion: 2
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/examples/bundles/org.eclipse.ecf.example.collab/plugin.xml b/examples/bundles/org.eclipse.ecf.example.collab/plugin.xml
index b2d1e2d4f..ab001aa30 100644
--- a/examples/bundles/org.eclipse.ecf.example.collab/plugin.xml
+++ b/examples/bundles/org.eclipse.ecf.example.collab/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
<extension
id="org.eclipse.ecf.example.collab.ui.ClientPreferencePage"
diff --git a/examples/bundles/org.eclipse.ecf.example.pubsub/META-INF/MANIFEST.MF b/examples/bundles/org.eclipse.ecf.example.pubsub/META-INF/MANIFEST.MF
index 00cf6812e..9790095cf 100644
--- a/examples/bundles/org.eclipse.ecf.example.pubsub/META-INF/MANIFEST.MF
+++ b/examples/bundles/org.eclipse.ecf.example.pubsub/META-INF/MANIFEST.MF
@@ -12,6 +12,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.core.resources,
org.eclipse.ecf.example.collab
Eclipse-AutoStart: true
+Eclipse-LazyStart: true
Bundle-RequiredExecutionEnvironment: J2SE-1.4
Export-Package: org.eclipse.ecf.example.pubsub,
org.eclipse.ecf.pubsub,
diff --git a/examples/bundles/org.eclipse.ecf.example.pubsub/plugin.xml b/examples/bundles/org.eclipse.ecf.example.pubsub/plugin.xml
index 4cc481889..6bf3c82b8 100644
--- a/examples/bundles/org.eclipse.ecf.example.pubsub/plugin.xml
+++ b/examples/bundles/org.eclipse.ecf.example.pubsub/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.2"?>
+<?eclipse version="3.1"?>
<plugin>
<extension-point id="modelUpdater" name="Shared Model Updater" schema="schema/modelUpdater.exsd"/>
<extension
diff --git a/examples/bundles/org.eclipse.ecf.example.sdo.editor/.classpath b/examples/bundles/org.eclipse.ecf.example.sdo.editor/.classpath
index 751c8f2e5..ce7393340 100644
--- a/examples/bundles/org.eclipse.ecf.example.sdo.editor/.classpath
+++ b/examples/bundles/org.eclipse.ecf.example.sdo.editor/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/examples/bundles/org.eclipse.ecf.example.sdo.editor/.settings/org.eclipse.jdt.core.prefs b/examples/bundles/org.eclipse.ecf.example.sdo.editor/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..72524eb89
--- /dev/null
+++ b/examples/bundles/org.eclipse.ecf.example.sdo.editor/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:21:55 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/examples/bundles/org.eclipse.ecf.example.sdo.editor/META-INF/MANIFEST.MF b/examples/bundles/org.eclipse.ecf.example.sdo.editor/META-INF/MANIFEST.MF
index 7dfa6b26c..a8877ca64 100644
--- a/examples/bundles/org.eclipse.ecf.example.sdo.editor/META-INF/MANIFEST.MF
+++ b/examples/bundles/org.eclipse.ecf.example.sdo.editor/META-INF/MANIFEST.MF
@@ -16,3 +16,4 @@ Require-Bundle: org.eclipse.ui,
Eclipse-AutoStart: true
Provide-Package: org.eclipse.ecf.example.sdo.editor
Export-Package: org.eclipse.ecf.example.sdo.editor
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/examples/bundles/org.eclipse.ecf.example.sdo.editor/plugin.xml b/examples/bundles/org.eclipse.ecf.example.sdo.editor/plugin.xml
index 01c1b067d..0d42f196b 100644
--- a/examples/bundles/org.eclipse.ecf.example.sdo.editor/plugin.xml
+++ b/examples/bundles/org.eclipse.ecf.example.sdo.editor/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
<extension
point="org.eclipse.ui.editors">
diff --git a/examples/bundles/org.eclipse.ecf.sdo/.classpath b/examples/bundles/org.eclipse.ecf.sdo/.classpath
index 751c8f2e5..ce7393340 100644
--- a/examples/bundles/org.eclipse.ecf.sdo/.classpath
+++ b/examples/bundles/org.eclipse.ecf.sdo/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/examples/bundles/org.eclipse.ecf.sdo/.settings/org.eclipse.jdt.core.prefs b/examples/bundles/org.eclipse.ecf.sdo/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..bc03244b5
--- /dev/null
+++ b/examples/bundles/org.eclipse.ecf.sdo/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:29:56 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/examples/bundles/org.eclipse.ecf.sdo/META-INF/MANIFEST.MF b/examples/bundles/org.eclipse.ecf.sdo/META-INF/MANIFEST.MF
index f53d5dcd8..438dc6fb9 100644
--- a/examples/bundles/org.eclipse.ecf.sdo/META-INF/MANIFEST.MF
+++ b/examples/bundles/org.eclipse.ecf.sdo/META-INF/MANIFEST.MF
@@ -15,3 +15,4 @@ Provide-Package: org.eclipse.ecf.sdo,
org.eclipse.ecf.sdo.emf
Export-Package: org.eclipse.ecf.sdo,
org.eclipse.ecf.internal.sdo
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/examples/bundles/org.eclipse.ecf.sdo/plugin.xml b/examples/bundles/org.eclipse.ecf.sdo/plugin.xml
index e87b752c5..27aa3d31d 100644
--- a/examples/bundles/org.eclipse.ecf.sdo/plugin.xml
+++ b/examples/bundles/org.eclipse.ecf.sdo/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
<extension-point id="manager" name="Data Graph Sharing Manager" schema="schema/manager.exsd"/>
diff --git a/framework/bundles/org.eclipse.ecf.datashare/.classpath b/framework/bundles/org.eclipse.ecf.datashare/.classpath
index 751c8f2e5..ce7393340 100644
--- a/framework/bundles/org.eclipse.ecf.datashare/.classpath
+++ b/framework/bundles/org.eclipse.ecf.datashare/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/framework/bundles/org.eclipse.ecf.datashare/.settings/org.eclipse.jdt.core.prefs b/framework/bundles/org.eclipse.ecf.datashare/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..53d1ddb11
--- /dev/null
+++ b/framework/bundles/org.eclipse.ecf.datashare/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:11:54 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/framework/bundles/org.eclipse.ecf.datashare/META-INF/MANIFEST.MF b/framework/bundles/org.eclipse.ecf.datashare/META-INF/MANIFEST.MF
index b1ec920e4..8896f9964 100644
--- a/framework/bundles/org.eclipse.ecf.datashare/META-INF/MANIFEST.MF
+++ b/framework/bundles/org.eclipse.ecf.datashare/META-INF/MANIFEST.MF
@@ -12,3 +12,4 @@ Require-Bundle: org.eclipse.ecf;visibility:=reexport,
Export-Package: org.eclipse.ecf.datashare,
org.eclipse.ecf.datashare.events,
org.eclipse.ecf.datashare.mergeable
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/framework/bundles/org.eclipse.ecf.discovery/.classpath b/framework/bundles/org.eclipse.ecf.discovery/.classpath
index 751c8f2e5..ce7393340 100644
--- a/framework/bundles/org.eclipse.ecf.discovery/.classpath
+++ b/framework/bundles/org.eclipse.ecf.discovery/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/framework/bundles/org.eclipse.ecf.discovery/.settings/org.eclipse.jdt.core.prefs b/framework/bundles/org.eclipse.ecf.discovery/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..de6a77f60
--- /dev/null
+++ b/framework/bundles/org.eclipse.ecf.discovery/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:12:30 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/framework/bundles/org.eclipse.ecf.discovery/META-INF/MANIFEST.MF b/framework/bundles/org.eclipse.ecf.discovery/META-INF/MANIFEST.MF
index 67ac3caea..b48e1a001 100644
--- a/framework/bundles/org.eclipse.ecf.discovery/META-INF/MANIFEST.MF
+++ b/framework/bundles/org.eclipse.ecf.discovery/META-INF/MANIFEST.MF
@@ -12,3 +12,4 @@ Require-Bundle: org.eclipse.core.runtime,
Eclipse-LazyStart: true
Eclipse-AutoStart: true
Export-Package: org.eclipse.ecf.discovery
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/framework/bundles/org.eclipse.ecf.presence/.classpath b/framework/bundles/org.eclipse.ecf.presence/.classpath
index 751c8f2e5..ce7393340 100644
--- a/framework/bundles/org.eclipse.ecf.presence/.classpath
+++ b/framework/bundles/org.eclipse.ecf.presence/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/framework/bundles/org.eclipse.ecf.presence/.settings/org.eclipse.jdt.core.prefs b/framework/bundles/org.eclipse.ecf.presence/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..b14e79db5
--- /dev/null
+++ b/framework/bundles/org.eclipse.ecf.presence/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:22:42 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/framework/bundles/org.eclipse.ecf.presence/META-INF/MANIFEST.MF b/framework/bundles/org.eclipse.ecf.presence/META-INF/MANIFEST.MF
index d4c7ec245..b32fa2fe3 100644
--- a/framework/bundles/org.eclipse.ecf.presence/META-INF/MANIFEST.MF
+++ b/framework/bundles/org.eclipse.ecf.presence/META-INF/MANIFEST.MF
@@ -12,3 +12,4 @@ Eclipse-LazyStart: true
Eclipse-AutoStart: true
Export-Package: org.eclipse.ecf.presence, org.eclipse.ecf.presence.impl, org.eclipse.ecf.presence.chat
Bundle-ManifestVersion: 2
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/framework/bundles/org.eclipse.ecf.presence/plugin.xml b/framework/bundles/org.eclipse.ecf.presence/plugin.xml
index 8e49b5212..9f5c84948 100644
--- a/framework/bundles/org.eclipse.ecf.presence/plugin.xml
+++ b/framework/bundles/org.eclipse.ecf.presence/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
</plugin>
diff --git a/framework/bundles/org.eclipse.ecf.provider/.classpath b/framework/bundles/org.eclipse.ecf.provider/.classpath
index 751c8f2e5..ce7393340 100644
--- a/framework/bundles/org.eclipse.ecf.provider/.classpath
+++ b/framework/bundles/org.eclipse.ecf.provider/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/framework/bundles/org.eclipse.ecf.provider/.settings/org.eclipse.jdt.core.prefs b/framework/bundles/org.eclipse.ecf.provider/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..31554fb89
--- /dev/null
+++ b/framework/bundles/org.eclipse.ecf.provider/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:22:59 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/framework/bundles/org.eclipse.ecf.provider/META-INF/MANIFEST.MF b/framework/bundles/org.eclipse.ecf.provider/META-INF/MANIFEST.MF
index 983166447..c6d953bcb 100644
--- a/framework/bundles/org.eclipse.ecf.provider/META-INF/MANIFEST.MF
+++ b/framework/bundles/org.eclipse.ecf.provider/META-INF/MANIFEST.MF
@@ -14,4 +14,5 @@ Provide-Package: org.eclipse.ecf.provider.comm.tcp, org.eclipse.ecf.provider.app
Export-Package: org.eclipse.ecf.provider.comm.tcp, org.eclipse.ecf.provider.app, org.eclipse.ecf.provider.generic, org.eclipse.ecf.provider.generic.gmm
Eclipse-BuddyPolicy: global
Bundle-ManifestVersion: 2
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/framework/bundles/org.eclipse.ecf.provider/plugin.xml b/framework/bundles/org.eclipse.ecf.provider/plugin.xml
index 9fc8b1188..10ed0c70f 100644
--- a/framework/bundles/org.eclipse.ecf.provider/plugin.xml
+++ b/framework/bundles/org.eclipse.ecf.provider/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
<extension
point="org.eclipse.ecf.connectionFactory">
diff --git a/framework/bundles/org.eclipse.ecf.ui/.classpath b/framework/bundles/org.eclipse.ecf.ui/.classpath
index 751c8f2e5..ce7393340 100644
--- a/framework/bundles/org.eclipse.ecf.ui/.classpath
+++ b/framework/bundles/org.eclipse.ecf.ui/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/framework/bundles/org.eclipse.ecf.ui/.settings/org.eclipse.jdt.core.prefs b/framework/bundles/org.eclipse.ecf.ui/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..a7851a26b
--- /dev/null
+++ b/framework/bundles/org.eclipse.ecf.ui/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:32:26 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/framework/bundles/org.eclipse.ecf.ui/META-INF/MANIFEST.MF b/framework/bundles/org.eclipse.ecf.ui/META-INF/MANIFEST.MF
index 67404dfc3..9222ba036 100644
--- a/framework/bundles/org.eclipse.ecf.ui/META-INF/MANIFEST.MF
+++ b/framework/bundles/org.eclipse.ecf.ui/META-INF/MANIFEST.MF
@@ -21,4 +21,5 @@ Provide-Package: org.eclipse.ecf.ui,
Export-Package: org.eclipse.ecf.ui.views, org.eclipse.ecf.ui.dialogs
Eclipse-RegisterBuddy: org.eclipse.ecf
Eclipse-BuddyPolicy: dependent
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/framework/bundles/org.eclipse.ecf.ui/plugin.xml b/framework/bundles/org.eclipse.ecf.ui/plugin.xml
index 3185a63de..cdedd2f7a 100644
--- a/framework/bundles/org.eclipse.ecf.ui/plugin.xml
+++ b/framework/bundles/org.eclipse.ecf.ui/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
<extension
point="org.eclipse.ui.views">
diff --git a/framework/bundles/org.eclipse.ecf/.classpath b/framework/bundles/org.eclipse.ecf/.classpath
index 751c8f2e5..ce7393340 100644
--- a/framework/bundles/org.eclipse.ecf/.classpath
+++ b/framework/bundles/org.eclipse.ecf/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/framework/bundles/org.eclipse.ecf/.settings/org.eclipse.jdt.core.prefs b/framework/bundles/org.eclipse.ecf/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..5b1fbaf9f
--- /dev/null
+++ b/framework/bundles/org.eclipse.ecf/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 16:09:07 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/framework/bundles/org.eclipse.ecf/META-INF/MANIFEST.MF b/framework/bundles/org.eclipse.ecf/META-INF/MANIFEST.MF
index 1714324ac..0e14d15cc 100644
--- a/framework/bundles/org.eclipse.ecf/META-INF/MANIFEST.MF
+++ b/framework/bundles/org.eclipse.ecf/META-INF/MANIFEST.MF
@@ -22,3 +22,4 @@ Provide-Package: org.eclipse.ecf.core,
org.eclipse.ecf.core.user,
org.eclipse.ecf.core.util
Bundle-ManifestVersion: 2
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/framework/bundles/org.eclipse.ecf/plugin.xml b/framework/bundles/org.eclipse.ecf/plugin.xml
index e65011194..c2b32d42c 100644
--- a/framework/bundles/org.eclipse.ecf/plugin.xml
+++ b/framework/bundles/org.eclipse.ecf/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
<extension-point id="containerFactory" name="ECF Container Factory" schema="schema/containerFactory.exsd"/>
<extension-point id="namespace" name="ECF Namespace" schema="schema/namespace.exsd"/>
diff --git a/providers/bundles/org.eclipse.ecf.provider.datashare/.classpath b/providers/bundles/org.eclipse.ecf.provider.datashare/.classpath
index 751c8f2e5..ce7393340 100644
--- a/providers/bundles/org.eclipse.ecf.provider.datashare/.classpath
+++ b/providers/bundles/org.eclipse.ecf.provider.datashare/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/providers/bundles/org.eclipse.ecf.provider.datashare/.settings/org.eclipse.jdt.core.prefs b/providers/bundles/org.eclipse.ecf.provider.datashare/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..20ba83fdc
--- /dev/null
+++ b/providers/bundles/org.eclipse.ecf.provider.datashare/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:23:16 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/providers/bundles/org.eclipse.ecf.provider.datashare/META-INF/MANIFEST.MF b/providers/bundles/org.eclipse.ecf.provider.datashare/META-INF/MANIFEST.MF
index eb94289bc..22be08e63 100644
--- a/providers/bundles/org.eclipse.ecf.provider.datashare/META-INF/MANIFEST.MF
+++ b/providers/bundles/org.eclipse.ecf.provider.datashare/META-INF/MANIFEST.MF
@@ -16,4 +16,5 @@ Eclipse-RegisterBuddy: org.eclipse.ecf
Eclipse-BuddyPolicy: dependent
Bundle-ClassPath: dsprovider.jar
Export-Package: org.eclipse.ecf.provider.datashare
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/providers/bundles/org.eclipse.ecf.provider.datashare/plugin.xml b/providers/bundles/org.eclipse.ecf.provider.datashare/plugin.xml
index 88f388441..af02f6455 100644
--- a/providers/bundles/org.eclipse.ecf.provider.datashare/plugin.xml
+++ b/providers/bundles/org.eclipse.ecf.provider.datashare/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
<extension
point="org.eclipse.ecf.containerFactory">
diff --git a/providers/bundles/org.eclipse.ecf.provider.jmdns/.classpath b/providers/bundles/org.eclipse.ecf.provider.jmdns/.classpath
index b2947b979..c645d1461 100644
--- a/providers/bundles/org.eclipse.ecf.provider.jmdns/.classpath
+++ b/providers/bundles/org.eclipse.ecf.provider.jmdns/.classpath
@@ -2,7 +2,7 @@
<classpath>
<classpathentry kind="src" path="src"/>
<classpathentry exported="true" kind="lib" path="lib/jmdns-1.0.3.jar"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/providers/bundles/org.eclipse.ecf.provider.jmdns/.settings/org.eclipse.jdt.core.prefs b/providers/bundles/org.eclipse.ecf.provider.jmdns/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..8a27ff10e
--- /dev/null
+++ b/providers/bundles/org.eclipse.ecf.provider.jmdns/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:29:15 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/providers/bundles/org.eclipse.ecf.provider.jmdns/META-INF/MANIFEST.MF b/providers/bundles/org.eclipse.ecf.provider.jmdns/META-INF/MANIFEST.MF
index 3429a6c92..744bd2120 100644
--- a/providers/bundles/org.eclipse.ecf.provider.jmdns/META-INF/MANIFEST.MF
+++ b/providers/bundles/org.eclipse.ecf.provider.jmdns/META-INF/MANIFEST.MF
@@ -13,3 +13,4 @@ Require-Bundle: org.eclipse.core.runtime,
Eclipse-LazyStart: true
Bundle-ClassPath: jmdns.jar,
lib/jmdns-1.0.3.jar
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/providers/bundles/org.eclipse.ecf.provider.jmdns/plugin.xml b/providers/bundles/org.eclipse.ecf.provider.jmdns/plugin.xml
index 246522818..53f7ab38c 100644
--- a/providers/bundles/org.eclipse.ecf.provider.jmdns/plugin.xml
+++ b/providers/bundles/org.eclipse.ecf.provider.jmdns/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
<extension
point="org.eclipse.ecf.containerFactory">
diff --git a/providers/bundles/org.eclipse.ecf.provider.xmpp/.classpath b/providers/bundles/org.eclipse.ecf.provider.xmpp/.classpath
index 751c8f2e5..ce7393340 100644
--- a/providers/bundles/org.eclipse.ecf.provider.xmpp/.classpath
+++ b/providers/bundles/org.eclipse.ecf.provider.xmpp/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/providers/bundles/org.eclipse.ecf.provider.xmpp/.settings/org.eclipse.jdt.core.prefs b/providers/bundles/org.eclipse.ecf.provider.xmpp/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..44ab8165b
--- /dev/null
+++ b/providers/bundles/org.eclipse.ecf.provider.xmpp/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:29:32 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/providers/bundles/org.eclipse.ecf.provider.xmpp/META-INF/MANIFEST.MF b/providers/bundles/org.eclipse.ecf.provider.xmpp/META-INF/MANIFEST.MF
index 48641a3da..b7a57a03d 100644
--- a/providers/bundles/org.eclipse.ecf.provider.xmpp/META-INF/MANIFEST.MF
+++ b/providers/bundles/org.eclipse.ecf.provider.xmpp/META-INF/MANIFEST.MF
@@ -14,4 +14,5 @@ Require-Bundle: org.eclipse.core.runtime,
Eclipse-AutoStart: true
Export-Package: org.eclipse.ecf.provider.xmpp.container, org.eclipse.ecf.provider.xmpp.identity
Eclipse-BuddyPolicy: global
+Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/providers/bundles/org.eclipse.ecf.provider.xmpp/plugin.xml b/providers/bundles/org.eclipse.ecf.provider.xmpp/plugin.xml
index 432b4b043..3ca7fb0fb 100644
--- a/providers/bundles/org.eclipse.ecf.provider.xmpp/plugin.xml
+++ b/providers/bundles/org.eclipse.ecf.provider.xmpp/plugin.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<?eclipse version="3.0"?>
+<?eclipse version="3.1"?>
<plugin>
<extension
point="org.eclipse.ecf.containerFactory">
diff --git a/server-side/bundles/org.eclipse.ecf.server/.classpath b/server-side/bundles/org.eclipse.ecf.server/.classpath
index 751c8f2e5..ce7393340 100644
--- a/server-side/bundles/org.eclipse.ecf.server/.classpath
+++ b/server-side/bundles/org.eclipse.ecf.server/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
<classpathentry kind="src" path="src"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/server-side/bundles/org.eclipse.ecf.server/.settings/org.eclipse.jdt.core.prefs b/server-side/bundles/org.eclipse.ecf.server/.settings/org.eclipse.jdt.core.prefs
new file mode 100644
index 000000000..b368da518
--- /dev/null
+++ b/server-side/bundles/org.eclipse.ecf.server/.settings/org.eclipse.jdt.core.prefs
@@ -0,0 +1,7 @@
+#Mon Sep 11 15:30:07 EDT 2006
+eclipse.preferences.version=1
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.2
+org.eclipse.jdt.core.compiler.compliance=1.4
+org.eclipse.jdt.core.compiler.problem.assertIdentifier=warning
+org.eclipse.jdt.core.compiler.problem.enumIdentifier=warning
+org.eclipse.jdt.core.compiler.source=1.3
diff --git a/server-side/bundles/org.eclipse.ecf.server/META-INF/MANIFEST.MF b/server-side/bundles/org.eclipse.ecf.server/META-INF/MANIFEST.MF
index 1d514685f..fe4e5b901 100644
--- a/server-side/bundles/org.eclipse.ecf.server/META-INF/MANIFEST.MF
+++ b/server-side/bundles/org.eclipse.ecf.server/META-INF/MANIFEST.MF
@@ -11,3 +11,4 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.ecf.provider
Eclipse-LazyStart: true
Eclipse-AutoStart: true
+Bundle-RequiredExecutionEnvironment: J2SE-1.4

Back to the top