Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorslewis2014-03-13 03:06:37 +0000
committerslewis2014-03-13 03:06:37 +0000
commit14182af5c69cbf8a0503035196ab64ad2df26192 (patch)
treeb59ca1023932bd5e7dc566c9c2731ac9bfa3f088 /providers
parent89d4b259bb9577951499335a419542eeefc8e937 (diff)
downloadorg.eclipse.ecf-14182af5c69cbf8a0503035196ab64ad2df26192.tar.gz
org.eclipse.ecf-14182af5c69cbf8a0503035196ab64ad2df26192.tar.xz
org.eclipse.ecf-14182af5c69cbf8a0503035196ab64ad2df26192.zip
Added Provide-Capability for use of RSA 1.1 discovery capability
Diffstat (limited to 'providers')
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.discovery/META-INF/MANIFEST.MF1
-rw-r--r--providers/bundles/org.eclipse.ecf.provider.dnssd/META-INF/MANIFEST.MF1
2 files changed, 2 insertions, 0 deletions
diff --git a/providers/bundles/org.eclipse.ecf.provider.discovery/META-INF/MANIFEST.MF b/providers/bundles/org.eclipse.ecf.provider.discovery/META-INF/MANIFEST.MF
index 84d8b55a8..61f45237b 100644
--- a/providers/bundles/org.eclipse.ecf.provider.discovery/META-INF/MANIFEST.MF
+++ b/providers/bundles/org.eclipse.ecf.provider.discovery/META-INF/MANIFEST.MF
@@ -16,3 +16,4 @@ Bundle-RequiredExecutionEnvironment: CDC-1.1/Foundation-1.1,
Bundle-Activator: org.eclipse.ecf.internal.provider.discovery.Activator
Export-Package: org.eclipse.ecf.provider.discovery;x-friends:="org.eclipse.ecf.tests.provider.discovery"
Bundle-ActivationPolicy: lazy
+Provide-Capability: osgi.remoteserviceadmin.discovery;protocols:List<String>=”ecf.discovery.composite,ecf.discovery.composite.locator,ecf.discovery.composite.advertiser”;version:Version=1.1
diff --git a/providers/bundles/org.eclipse.ecf.provider.dnssd/META-INF/MANIFEST.MF b/providers/bundles/org.eclipse.ecf.provider.dnssd/META-INF/MANIFEST.MF
index f5b132cb8..dc75317b0 100644
--- a/providers/bundles/org.eclipse.ecf.provider.dnssd/META-INF/MANIFEST.MF
+++ b/providers/bundles/org.eclipse.ecf.provider.dnssd/META-INF/MANIFEST.MF
@@ -24,3 +24,4 @@ Export-Package: org.eclipse.ecf.provider.dnssd;version="1.0.0"
Require-Bundle: org.xbill.dns;bundle-version="2.0.8",
org.eclipse.equinox.common
Bundle-Localization: plugin
+Provide-Capability: osgi.remoteserviceadmin.discovery;protocols:List<String>=”DNSSD”;version:Version=1.1

Back to the top