Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonah Graham2019-08-03 15:17:58 +0000
committerJonah Graham2019-08-07 04:48:15 +0000
commit6c34f9bad560b48024f0dd90d643aca0ca5810f6 (patch)
treed55a50e337ee5f30737dfae2afb39f0005d6e8cc /debug/org.eclipse.cdt.debug.dap-feature
parentacbceb04ee9e472119ef3255a47986c833fcf4c2 (diff)
downloadorg.eclipse.cdt-6c34f9bad560b48024f0dd90d643aca0ca5810f6.tar.gz
org.eclipse.cdt-6c34f9bad560b48024f0dd90d643aca0ca5810f6.tar.xz
org.eclipse.cdt-6c34f9bad560b48024f0dd90d643aca0ca5810f6.zip
Bug 542488: JTAG debug support based on DAP remote debugging
Diffstat (limited to 'debug/org.eclipse.cdt.debug.dap-feature')
-rw-r--r--debug/org.eclipse.cdt.debug.dap-feature/feature.xml5
1 files changed, 3 insertions, 2 deletions
diff --git a/debug/org.eclipse.cdt.debug.dap-feature/feature.xml b/debug/org.eclipse.cdt.debug.dap-feature/feature.xml
index 4aa5fb543d8..0f8b8624df8 100644
--- a/debug/org.eclipse.cdt.debug.dap-feature/feature.xml
+++ b/debug/org.eclipse.cdt.debug.dap-feature/feature.xml
@@ -22,12 +22,14 @@
<requires>
<import plugin="org.apache.commons.io"/>
<import plugin="org.eclipse.core.runtime"/>
+ <import plugin="org.eclipse.lsp4e" version="0.11.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.genericeditor" version="1.0.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.jface.text"/>
<import plugin="org.eclipse.cdt.ui"/>
<import plugin="org.eclipse.cdt.core"/>
<import plugin="org.eclipse.jface"/>
<import plugin="org.eclipse.ui"/>
+ <import plugin="org.eclipse.lsp4j" version="0.7.2" match="greaterOrEqual"/>
<import plugin="org.eclipse.core.commands"/>
<import plugin="org.eclipse.core.expressions"/>
<import plugin="org.eclipse.core.resources"/>
@@ -43,8 +45,7 @@
<import plugin="com.google.guava"/>
<import plugin="org.eclipse.xtext.xbase.lib"/>
<import plugin="org.eclipse.ui.editors"/>
- <import plugin="org.eclipse.lsp4e" version="0.11.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.lsp4j" version="0.7.2" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.cdt.dsf.gdb" version="5.7.200" match="greaterOrEqual"/>
</requires>
<plugin

Back to the top