Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEike Stepper2012-09-30 17:01:44 +0000
committerEike Stepper2012-09-30 17:01:44 +0000
commit6ed4654283170b6857405a5e2bb894ddff6b543b (patch)
treea6727310fafccc94c753036757b6a219c04aa199
parente52b9d928eccf929f390442bf8f189c63c32b939 (diff)
downloadcdo-drops/I20120930-1321.tar.gz
cdo-drops/I20120930-1321.tar.xz
cdo-drops/I20120930-1321.zip
Install all external dependencies from Elver.orgdrops/I20120930-1321
-rw-r--r--plugins/org.eclipse.emf.cdo.tests.db/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.emf.cdo.tests.db/src/org/eclipse/emf/cdo/tests/db/PostgresqlConfig.java12
-rw-r--r--plugins/org.eclipse.net4j.db.postgresql/.settings/.api_filters18
-rw-r--r--plugins/org.eclipse.net4j.db.postgresql/META-INF/MANIFEST.MF9
-rw-r--r--plugins/org.eclipse.net4j.db.postgresql/plugin.xml2
-rw-r--r--plugins/org.eclipse.net4j.db.postgresql/src/org/eclipse/net4j/db/postgresql/PostgreSQLAdapter.java8
6 files changed, 36 insertions, 17 deletions
diff --git a/plugins/org.eclipse.emf.cdo.tests.db/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.tests.db/META-INF/MANIFEST.MF
index db7f46a5e5..06d980007e 100644
--- a/plugins/org.eclipse.emf.cdo.tests.db/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.tests.db/META-INF/MANIFEST.MF
@@ -21,8 +21,8 @@ Import-Package: com.mysql.jdbc.jdbc2.optional;version="[5.0.0,6.0.0)",
org.apache.derby.jdbc;version="[10.0.0,11.0.0)",
org.h2.jdbcx;version="[1.0.0,2.0.0)",
org.hsqldb.jdbc;version="[2.0.0,3.0.0)",
- org.postgresql.ds.common;version="[9.0.0,10.0.0)",
- org.postgresql.jdbc3;version="[9.0.0,10.0.0)"
+ org.postgresql.ds;version="[9.0.0,10.0.0)",
+ org.postgresql.ds.common;version="[9.0.0,10.0.0)"
Export-Package: org.eclipse.emf.cdo.tests.db;version="4.0.200";x-friends:="org.eclipse.emf.cdo.tests.all",
org.eclipse.emf.cdo.tests.db.bundle;version="4.0.200";x-internal:=true,
org.eclipse.emf.cdo.tests.db.capabilities;version="4.0.200";x-friends:="org.eclipse.emf.cdo.tests.all",
diff --git a/plugins/org.eclipse.emf.cdo.tests.db/src/org/eclipse/emf/cdo/tests/db/PostgresqlConfig.java b/plugins/org.eclipse.emf.cdo.tests.db/src/org/eclipse/emf/cdo/tests/db/PostgresqlConfig.java
index 23ea0dee39..0df8795f5b 100644
--- a/plugins/org.eclipse.emf.cdo.tests.db/src/org/eclipse/emf/cdo/tests/db/PostgresqlConfig.java
+++ b/plugins/org.eclipse.emf.cdo.tests.db/src/org/eclipse/emf/cdo/tests/db/PostgresqlConfig.java
@@ -4,7 +4,7 @@
* are made available under the terms of the Eclipse Public License v1.0
* which accompanies this distribution, and is available at
* http://www.eclipse.org/legal/epl-v10.html
- *
+ *
* Contributors:
* Eike Stepper - initial API and implementation
*/
@@ -18,7 +18,7 @@ import org.eclipse.net4j.db.IDBAdapter;
import org.eclipse.net4j.db.postgresql.PostgreSQLAdapter;
import org.eclipse.net4j.util.io.IOUtil;
-import org.postgresql.jdbc3.Jdbc3SimpleDataSource;
+import org.postgresql.ds.PGSimpleDataSource;
import javax.sql.DataSource;
@@ -35,9 +35,9 @@ public class PostgresqlConfig extends DBConfig
private static final long serialVersionUID = 1L;
- private transient Jdbc3SimpleDataSource dataSource;
+ private transient PGSimpleDataSource dataSource;
- private transient Jdbc3SimpleDataSource setupDataSource;
+ private transient PGSimpleDataSource setupDataSource;
private String currentRepositoryName = "cdodb1";
@@ -64,7 +64,7 @@ public class PostgresqlConfig extends DBConfig
{
currentRepositoryName = repoName;
- dataSource = new Jdbc3SimpleDataSource();
+ dataSource = new PGSimpleDataSource();
dataSource.setServerName("localhost");
dataSource.setDatabaseName(currentRepositoryName);
dataSource.setUser("sa");
@@ -116,7 +116,7 @@ public class PostgresqlConfig extends DBConfig
{
if (setupDataSource == null)
{
- setupDataSource = new Jdbc3SimpleDataSource();
+ setupDataSource = new PGSimpleDataSource();
setupDataSource.setServerName("localhost");
setupDataSource.setDatabaseName(currentRepositoryName);
setupDataSource.setUser("sa");
diff --git a/plugins/org.eclipse.net4j.db.postgresql/.settings/.api_filters b/plugins/org.eclipse.net4j.db.postgresql/.settings/.api_filters
new file mode 100644
index 0000000000..b02d05cb24
--- /dev/null
+++ b/plugins/org.eclipse.net4j.db.postgresql/.settings/.api_filters
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<component id="org.eclipse.net4j.db.postgresql" version="2">
+ <resource path="src/org/eclipse/net4j/db/postgresql/PostgreSQLAdapter.java" type="org.eclipse.net4j.db.postgresql.PostgreSQLAdapter">
+ <filter id="338792546">
+ <message_arguments>
+ <message_argument value="org.eclipse.net4j.db.postgresql.PostgreSQLAdapter"/>
+ <message_argument value="getJDBCDriver()"/>
+ </message_arguments>
+ </filter>
+ <filter id="388194388">
+ <message_arguments>
+ <message_argument value="org.eclipse.net4j.db.postgresql.PostgreSQLAdapter"/>
+ <message_argument value="VERSION"/>
+ <message_argument value="8.3"/>
+ </message_arguments>
+ </filter>
+ </resource>
+</component>
diff --git a/plugins/org.eclipse.net4j.db.postgresql/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.db.postgresql/META-INF/MANIFEST.MF
index fa6d1494a3..517fadde42 100644
--- a/plugins/org.eclipse.net4j.db.postgresql/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.db.postgresql/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.net4j.db.postgresql;singleton:=true
-Bundle-Version: 4.0.100.qualifier
+Bundle-Version: 4.1.0.qualifier
Bundle-Vendor: %providerName
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ClassPath: .
@@ -12,7 +12,8 @@ Bundle-Activator: org.eclipse.net4j.db.internal.postgresql.bundle.OM$Activator
Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.db;bundle-version="[4.0.0,5.0.0)";visibility:=reexport
Import-Package: org.postgresql;version="[9.0.0,10.0.0)",
- org.postgresql.ds;version="[9.0.0,10.0.0)"
-Export-Package: org.eclipse.net4j.db.internal.postgresql.bundle;version="4.0.100";x-internal:=true,
- org.eclipse.net4j.db.postgresql;version="4.0.100"
+ org.postgresql.ds;version="[9.0.0,10.0.0)",
+ org.postgresql.ds.common;version="[9.0.0,10.0.0)"
+Export-Package: org.eclipse.net4j.db.internal.postgresql.bundle;version="4.1.0";x-internal:=true,
+ org.eclipse.net4j.db.postgresql;version="4.1.0"
Eclipse-RegisterBuddy: org.eclipse.net4j.db
diff --git a/plugins/org.eclipse.net4j.db.postgresql/plugin.xml b/plugins/org.eclipse.net4j.db.postgresql/plugin.xml
index 9a089173fd..2d060b26db 100644
--- a/plugins/org.eclipse.net4j.db.postgresql/plugin.xml
+++ b/plugins/org.eclipse.net4j.db.postgresql/plugin.xml
@@ -19,7 +19,7 @@
<dbAdapter
class="org.eclipse.net4j.db.postgresql.PostgreSQLAdapter"
name="postgresql"
- version="8.3">
+ version="9.0">
</dbAdapter>
</extension>
diff --git a/plugins/org.eclipse.net4j.db.postgresql/src/org/eclipse/net4j/db/postgresql/PostgreSQLAdapter.java b/plugins/org.eclipse.net4j.db.postgresql/src/org/eclipse/net4j/db/postgresql/PostgreSQLAdapter.java
index fae3e1f67e..3ff7c75a9e 100644
--- a/plugins/org.eclipse.net4j.db.postgresql/src/org/eclipse/net4j/db/postgresql/PostgreSQLAdapter.java
+++ b/plugins/org.eclipse.net4j.db.postgresql/src/org/eclipse/net4j/db/postgresql/PostgreSQLAdapter.java
@@ -22,11 +22,11 @@ import org.eclipse.net4j.db.internal.postgresql.bundle.OM;
import org.eclipse.net4j.spi.db.DBAdapter;
import org.eclipse.net4j.util.om.trace.ContextTracer;
-import org.postgresql.Driver;
import org.postgresql.ds.PGSimpleDataSource;
import javax.sql.DataSource;
+import java.sql.Driver;
import java.sql.SQLException;
import java.sql.Savepoint;
import java.sql.Statement;
@@ -40,7 +40,7 @@ public class PostgreSQLAdapter extends DBAdapter
{
public static final String NAME = "postgresql"; //$NON-NLS-1$
- public static final String VERSION = "8.3"; //$NON-NLS-1$
+ public static final String VERSION = "9.0"; //$NON-NLS-1$
private static final ContextTracer TRACER = new ContextTracer(OM.DEBUG_SQL, DBAdapter.class);
@@ -64,7 +64,7 @@ public class PostgreSQLAdapter extends DBAdapter
public Driver getJDBCDriver()
{
- return new Driver();
+ return new org.postgresql.Driver();
}
public DataSource createJDBCDataSource()
@@ -78,7 +78,7 @@ public class PostgreSQLAdapter extends DBAdapter
@Override
public int getMaxTableNameLength()
{
- // http://www.postgresql.org/docs/8.2/static/sql-syntax-lexical.html
+ // http://www.postgresql.org/docs/9.0/static/sql-syntax-lexical.html
return 63;
}

Back to the top