Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEike Stepper2008-05-22 08:26:03 +0000
committerEike Stepper2008-05-22 08:26:03 +0000
commitb86494137f005c3c3c6ff45647688d38f86cb564 (patch)
treeb79fa9dff18078f9becbff88686e343c3d6cb5d4
parentfb5cf03ecbd5c091d7b5923a1bca2ab827177c89 (diff)
downloadcdo-b86494137f005c3c3c6ff45647688d38f86cb564.tar.gz
cdo-b86494137f005c3c3c6ff45647688d38f86cb564.tar.xz
cdo-b86494137f005c3c3c6ff45647688d38f86cb564.zip
[233406] 'Eclipse-LazyStart' header is deprecated
https://bugs.eclipse.org/bugs/show_bug.cgi?id=233406
-rw-r--r--plugins/org.eclipse.emf.cdo.edit/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.emf.cdo.examples/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.emf.cdo.migrator/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.emf.cdo.server.db/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.emf.cdo.server.hibernate.teneo/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.cdo.server.hibernate/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.emf.cdo.server/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.emf.cdo.tests.hibernate/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.emf.cdo.tests.mango/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.emf.cdo.tests.model1/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.cdo.tests.model2/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.cdo.tests.model3/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.emf.cdo.tests/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.emf.cdo.ui/META-INF/MANIFEST.MF14
-rw-r--r--plugins/org.eclipse.emf.cdo/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.net4j.buddies.server/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.buddies.ui/META-INF/MANIFEST.MF8
-rw-r--r--plugins/org.eclipse.net4j.buddies/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.db.derby/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.net4j.db.hsqldb/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.net4j.db.mysql/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.net4j.db.tests/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.db/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.debug/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.examples/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.jms.admin/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.jms.server.jdbc/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.jms.server/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.jms.tests/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.net4j.jms/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.jvm/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.tcp/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.tests/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j.util.ui/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.net4j.util/META-INF/MANIFEST.MF4
-rw-r--r--plugins/org.eclipse.net4j/META-INF/MANIFEST.MF4
37 files changed, 83 insertions, 83 deletions
diff --git a/plugins/org.eclipse.emf.cdo.edit/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.edit/META-INF/MANIFEST.MF
index 4480643d16..8cccc521ee 100644
--- a/plugins/org.eclipse.emf.cdo.edit/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.edit/META-INF/MANIFEST.MF
@@ -8,11 +8,11 @@ Bundle-Activator: org.eclipse.emf.cdo.eresource.provider.EresourceEditPlugin$Imp
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.emf.edit;bundle-version="[2.3.0,3.0.0)";visibility:=reexport,
- org.eclipse.emf.ecore;bundle-version="[2.3.0,3.0.0)";visibility:=reexport,
- org.eclipse.emf.ecore.edit;bundle-version="[2.3.0,3.0.0)";visibility:=reexport,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.emf.edit;bundle-version="[2.4.0,3.0.0)";visibility:=reexport,
+ org.eclipse.emf.ecore;bundle-version="[2.4.0,3.0.0)";visibility:=reexport,
+ org.eclipse.emf.ecore.edit;bundle-version="[2.4.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.cdo;visibility:=reexport
Export-Package: org.eclipse.emf.cdo.edit;version="0.8.0",
org.eclipse.emf.cdo.eresource.provider;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.emf.cdo.examples/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.examples/META-INF/MANIFEST.MF
index 1daf7b96a2..193e388ba6 100644
--- a/plugins/org.eclipse.emf.cdo.examples/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.examples/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Bundle-Activator: org.eclipse.emf.cdo.internal.examples.bundle.OM$Activator
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)";resolution:=optional,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)";resolution:=optional,
org.eclipse.emf.cdo;visibility:=reexport,
org.eclipse.net4j.tcp;visibility:=reexport
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.emf.cdo.migrator/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.migrator/META-INF/MANIFEST.MF
index 7610db3f91..f352cfd52c 100644
--- a/plugins/org.eclipse.emf.cdo.migrator/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.migrator/META-INF/MANIFEST.MF
@@ -7,11 +7,11 @@ Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.core.resources;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.ui;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.emf.ecore.xmi;bundle-version="[2.3.0,3.0.0)",
- org.eclipse.emf.importer;bundle-version="[2.3.0,3.0.0)"
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.resources,
+ org.eclipse.ui,
+ org.eclipse.emf.ecore.xmi;bundle-version="[2.4.0,3.0.0)",
+ org.eclipse.emf.importer;bundle-version="[2.4.0,3.0.0)"
Export-Package: org.eclipse.emf.cdo.migrator;version="0.8.0",
org.eclipse.emf.cdo.migrator.actions;version="0.8.0",
org.eclipse.emf.cdo.migrator.wizards;version="0.8.0"
diff --git a/plugins/org.eclipse.emf.cdo.server.db/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.server.db/META-INF/MANIFEST.MF
index f7119f0a52..be6f2da67a 100644
--- a/plugins/org.eclipse.emf.cdo.server.db/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.server.db/META-INF/MANIFEST.MF
@@ -8,9 +8,9 @@ Bundle-Activator: org.eclipse.emf.cdo.server.internal.db.bundle.OM$Activator
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.db;visibility:=reexport,
org.eclipse.emf.cdo.server;visibility:=reexport
Export-Package: org.eclipse.emf.cdo.server.db;version="0.8.0",
org.eclipse.emf.cdo.server.internal.db;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.emf.cdo.server.hibernate.teneo/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.server.hibernate.teneo/META-INF/MANIFEST.MF
index e3e5f87973..48caec1f09 100644
--- a/plugins/org.eclipse.emf.cdo.server.hibernate.teneo/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.server.hibernate.teneo/META-INF/MANIFEST.MF
@@ -6,7 +6,7 @@ Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.emf.ecore.xmi;bundle-version="[2.3.0,3.0.0)",
+Require-Bundle: org.eclipse.emf.ecore.xmi;bundle-version="[2.4.0,3.0.0)",
org.eclipse.emf.cdo.server.hibernate;visibility:=reexport,
org.eclipse.emf.teneo.hibernate.mapper;visibility:=reexport
Import-Package: org.hibernate.cfg
diff --git a/plugins/org.eclipse.emf.cdo.server.hibernate/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.server.hibernate/META-INF/MANIFEST.MF
index f9307c79ab..84ac289c37 100644
--- a/plugins/org.eclipse.emf.cdo.server.hibernate/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.server.hibernate/META-INF/MANIFEST.MF
@@ -5,11 +5,11 @@ Bundle-Version: 0.8.0.qualifier
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-Activator: org.eclipse.emf.cdo.server.internal.hibernate.bundle.OM$Activator
Bundle-ActivationPolicy: lazy
+Bundle-Activator: org.eclipse.emf.cdo.server.internal.hibernate.bundle.OM$Activator
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ClassPath: .
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.emf.cdo;visibility:=reexport,
org.eclipse.emf.cdo.server;visibility:=reexport,
org.eclipse.emf.cdo.server.hibernate.libraries;visibility:=reexport,
diff --git a/plugins/org.eclipse.emf.cdo.server/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.server/META-INF/MANIFEST.MF
index 43b45a64b6..f08abe28dc 100644
--- a/plugins/org.eclipse.emf.cdo.server/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.server/META-INF/MANIFEST.MF
@@ -8,9 +8,9 @@ Bundle-Activator: org.eclipse.emf.cdo.internal.server.bundle.OM$Activator
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)";resolution:=optional,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)";resolution:=optional,
org.eclipse.emf.cdo.protocol;visibility:=reexport
Export-Package: org.eclipse.emf.cdo.internal.server;version="0.8.0",
org.eclipse.emf.cdo.internal.server.protocol;version="0.8.0",
org.eclipse.emf.cdo.server;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.emf.cdo.tests.hibernate/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.tests.hibernate/META-INF/MANIFEST.MF
index e0cec26498..39fa9fdc34 100644
--- a/plugins/org.eclipse.emf.cdo.tests.hibernate/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.tests.hibernate/META-INF/MANIFEST.MF
@@ -5,11 +5,11 @@ Bundle-Version: 0.8.0.qualifier
Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Bundle-Activator: org.eclipse.emf.cdo.tests.hibernate.Activator
Bundle-ActivationPolicy: lazy
+Bundle-Activator: org.eclipse.emf.cdo.tests.hibernate.Activator
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ClassPath: .
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.db.mysql;bundle-version="0.8.0",
org.eclipse.net4j.tcp,
org.eclipse.emf.cdo,
diff --git a/plugins/org.eclipse.emf.cdo.tests.mango/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.tests.mango/META-INF/MANIFEST.MF
index 4950914ef5..0875df28ff 100644
--- a/plugins/org.eclipse.emf.cdo.tests.mango/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.tests.mango/META-INF/MANIFEST.MF
@@ -10,7 +10,7 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.emf.cdo.tests.mango,
org.eclipse.emf.cdo.tests.mango.impl,
org.eclipse.emf.cdo.tests.mango.util
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.emf.ecore;bundle-version="[2.3.0,3.0.0)";visibility:=reexport,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.emf.ecore;bundle-version="[2.4.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.cdo;visibility:=reexport
diff --git a/plugins/org.eclipse.emf.cdo.tests.model1/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.tests.model1/META-INF/MANIFEST.MF
index 2a2f068649..0dd7478f18 100644
--- a/plugins/org.eclipse.emf.cdo.tests.model1/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.tests.model1/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.emf.cdo;visibility:=reexport
Export-Package: org.eclipse.emf.cdo.tests.model1,
org.eclipse.emf.cdo.tests.model1.impl,
diff --git a/plugins/org.eclipse.emf.cdo.tests.model2/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.tests.model2/META-INF/MANIFEST.MF
index 0ae51a6d25..589d82ce83 100644
--- a/plugins/org.eclipse.emf.cdo.tests.model2/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.tests.model2/META-INF/MANIFEST.MF
@@ -14,4 +14,4 @@ Require-Bundle: org.eclipse.core.runtime,
org.eclipse.emf.ecore;visibility:=reexport,
org.eclipse.emf.cdo;visibility:=reexport,
org.eclipse.emf.cdo.tests.model1;visibility:=reexport
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.emf.cdo.tests.model3/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.tests.model3/META-INF/MANIFEST.MF
index ec38b4c190..087ccc5fd4 100644
--- a/plugins/org.eclipse.emf.cdo.tests.model3/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.tests.model3/META-INF/MANIFEST.MF
@@ -16,4 +16,4 @@ Export-Package: org.eclipse.emf.cdo.tests.model3,
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.emf.ecore;visibility:=reexport,
org.eclipse.emf.cdo;visibility:=reexport
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.emf.cdo.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.tests/META-INF/MANIFEST.MF
index 198259f8fe..510e598093 100644
--- a/plugins/org.eclipse.emf.cdo.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.tests/META-INF/MANIFEST.MF
@@ -8,8 +8,8 @@ Bundle-Vendor: %providerName
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.emf.ecore.xmi;bundle-version="[2.3.0,3.0.0)";visibility:=reexport,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.emf.ecore.xmi;bundle-version="[2.4.0,3.0.0)";visibility:=reexport,
org.eclipse.net4j.db.hsqldb;resolution:=optional;visibility:=reexport,
org.eclipse.net4j.jvm;resolution:=optional;visibility:=reexport,
org.eclipse.net4j.tcp;resolution:=optional;visibility:=reexport,
@@ -23,4 +23,4 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
org.junit;visibility:=reexport
Export-Package: org.eclipse.emf.cdo.tests,
org.eclipse.net4j.tests
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.emf.cdo.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo.ui/META-INF/MANIFEST.MF
index abd13ba30a..c018d23b63 100644
--- a/plugins/org.eclipse.emf.cdo.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo.ui/META-INF/MANIFEST.MF
@@ -8,12 +8,12 @@ Bundle-Vendor: %providerName
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.core.resources;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.ui;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.ui.ide;bundle-version="[3.3.0,4.0.0)";visibility:=reexport,
- org.eclipse.emf.edit.ui;bundle-version="[2.3.0,3.0.0)";visibility:=reexport,
- org.eclipse.emf.ecore.edit;bundle-version="[2.3.0,3.0.0)";visibility:=reexport,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.resources,
+ org.eclipse.ui,
+ org.eclipse.ui.ide;visibility:=reexport,
+ org.eclipse.emf.edit.ui;bundle-version="[2.4.0,3.0.0)";visibility:=reexport,
+ org.eclipse.emf.ecore.edit;bundle-version="[2.4.0,3.0.0)";visibility:=reexport,
org.eclipse.net4j;visibility:=reexport,
org.eclipse.net4j.util.ui;visibility:=reexport,
org.eclipse.emf.cdo;visibility:=reexport,
@@ -25,4 +25,4 @@ Export-Package: org.eclipse.emf.cdo.internal.ui;version="0.8.0",
org.eclipse.emf.cdo.internal.ui.preferences;version="0.8.0",
org.eclipse.emf.cdo.internal.ui.views;version="0.8.0",
org.eclipse.emf.cdo.ui;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.emf.cdo/META-INF/MANIFEST.MF b/plugins/org.eclipse.emf.cdo/META-INF/MANIFEST.MF
index 95113c11dc..757f968203 100644
--- a/plugins/org.eclipse.emf.cdo/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.emf.cdo/META-INF/MANIFEST.MF
@@ -8,9 +8,9 @@ Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-Activator: org.eclipse.emf.internal.cdo.bundle.Activator$Implementation
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.emf.ecore;bundle-version="[2.3.0,3.0.0)";visibility:=reexport,
- org.eclipse.emf.ecore.xmi;bundle-version="[2.3.0,3.0.0)";visibility:=reexport,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.emf.ecore;bundle-version="[2.4.0,3.0.0)";visibility:=reexport,
+ org.eclipse.emf.ecore.xmi;bundle-version="[2.4.0,3.0.0)";visibility:=reexport,
org.eclipse.emf.cdo.protocol;visibility:=reexport
Export-Package: org.eclipse.emf.cdo;version="0.8.0",
org.eclipse.emf.cdo.analyzer;version="0.8.0",
@@ -23,4 +23,4 @@ Export-Package: org.eclipse.emf.cdo;version="0.8.0",
org.eclipse.emf.internal.cdo.bundle;version="0.8.0";x-friends:="org.eclipse.emf.cdo.ui",
org.eclipse.emf.internal.cdo.protocol;version="0.8.0",
org.eclipse.emf.internal.cdo.util;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.buddies.server/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.buddies.server/META-INF/MANIFEST.MF
index 5267cc2e54..80286815b5 100644
--- a/plugins/org.eclipse.net4j.buddies.server/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.buddies.server/META-INF/MANIFEST.MF
@@ -8,9 +8,9 @@ Bundle-Activator: org.eclipse.net4j.buddies.internal.server.bundle.OM$Activator
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)";resolution:=optional,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)";resolution:=optional,
org.eclipse.net4j.buddies.protocol;visibility:=reexport
Export-Package: org.eclipse.net4j.buddies.internal.server;version="0.8.0",
org.eclipse.net4j.buddies.internal.server.protocol;version="0.8.0",
org.eclipse.net4j.buddies.server;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.buddies.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.buddies.ui/META-INF/MANIFEST.MF
index 9eeb770955..f0dc1a2b81 100644
--- a/plugins/org.eclipse.net4j.buddies.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.buddies.ui/META-INF/MANIFEST.MF
@@ -8,9 +8,9 @@ Bundle-Vendor: %providerName
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.ui;bundle-version="[3.3.0,4.0.0)";visibility:=reexport,
- org.eclipse.ui.ide;bundle-version="[3.3.0,4.0.0)";visibility:=reexport,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui;visibility:=reexport,
+ org.eclipse.ui.ide;visibility:=reexport,
org.eclipse.net4j;visibility:=reexport,
org.eclipse.net4j.util.ui;visibility:=reexport,
org.eclipse.net4j.buddies;visibility:=reexport,
@@ -21,4 +21,4 @@ Export-Package: org.eclipse.net4j.buddies.internal.ui;version="0.8.0",
org.eclipse.net4j.buddies.internal.ui.preferences;version="0.8.0",
org.eclipse.net4j.buddies.internal.ui.views;version="0.8.0",
org.eclipse.net4j.buddies.ui;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.buddies/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.buddies/META-INF/MANIFEST.MF
index 370477e902..950945e512 100644
--- a/plugins/org.eclipse.net4j.buddies/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.buddies/META-INF/MANIFEST.MF
@@ -8,9 +8,9 @@ Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-Activator: org.eclipse.net4j.internal.buddies.bundle.OM$Activator
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.buddies.protocol;visibility:=reexport
Export-Package: org.eclipse.net4j.buddies;version="0.8.0",
org.eclipse.net4j.internal.buddies;version="0.8.0",
org.eclipse.net4j.internal.buddies.protocol;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.db.derby/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.db.derby/META-INF/MANIFEST.MF
index 65ae8ac42d..e90a372339 100644
--- a/plugins/org.eclipse.net4j.db.derby/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.db.derby/META-INF/MANIFEST.MF
@@ -9,7 +9,7 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ClassPath: .,
lib/derby.jar,
lib/derbyclient.jar
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.db;visibility:=reexport
Export-Package: org.apache.derby.authentication,
org.apache.derby.catalog,
diff --git a/plugins/org.eclipse.net4j.db.hsqldb/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.db.hsqldb/META-INF/MANIFEST.MF
index 66e0850e1e..b526e78fb9 100644
--- a/plugins/org.eclipse.net4j.db.hsqldb/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.db.hsqldb/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Bundle-Localization: plugin
Bundle-ClassPath: .,
lib/hsqldb.jar
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.db;bundle-version="0.8.0";visibility:=reexport
Export-Package: org.eclipse.net4j.db.hsqldb;version="0.8.0",
org.eclipse.net4j.db.internal.hsqldb;version="0.8.0",
diff --git a/plugins/org.eclipse.net4j.db.mysql/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.db.mysql/META-INF/MANIFEST.MF
index 98958e76ba..5324223030 100644
--- a/plugins/org.eclipse.net4j.db.mysql/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.db.mysql/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ClassPath: .,
lib/mysql-connector-java-5.1.5-bin.jar
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.db;visibility:=reexport
Export-Package: com.mysql.jdbc,
com.mysql.jdbc.exceptions,
diff --git a/plugins/org.eclipse.net4j.db.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.db.tests/META-INF/MANIFEST.MF
index 40482f3ecb..98cbdc86ba 100644
--- a/plugins/org.eclipse.net4j.db.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.db.tests/META-INF/MANIFEST.MF
@@ -8,8 +8,8 @@ Bundle-Activator: org.eclipse.net4j.db.tests.bundle.Activator
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.tests;visibility:=reexport,
org.eclipse.net4j.db.derby;visibility:=reexport
Export-Package: org.eclipse.net4j.db.tests
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.db/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.db/META-INF/MANIFEST.MF
index 6964942410..7278186d22 100644
--- a/plugins/org.eclipse.net4j.db/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.db/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Bundle-Vendor: %providerName
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.util;visibility:=reexport
Export-Package: org.eclipse.net4j.db;version="0.8.0",
org.eclipse.net4j.db.ddl;version="0.8.0",
@@ -17,5 +17,5 @@ Export-Package: org.eclipse.net4j.db;version="0.8.0",
org.eclipse.net4j.internal.db.bundle;version="0.8.0",
org.eclipse.net4j.internal.db.ddl;version="0.8.0",
org.eclipse.net4j.internal.db.dml;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
Eclipse-BuddyPolicy: registered
diff --git a/plugins/org.eclipse.net4j.debug/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.debug/META-INF/MANIFEST.MF
index 5eaa9f7dae..a6210b8b9e 100644
--- a/plugins/org.eclipse.net4j.debug/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.debug/META-INF/MANIFEST.MF
@@ -8,6 +8,6 @@ Bundle-Activator: org.eclipse.net4j.internal.debug.bundle.OM$Activator
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.util.ui;visibility:=reexport
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.examples/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.examples/META-INF/MANIFEST.MF
index ca3f3a5ac5..22331c68b7 100644
--- a/plugins/org.eclipse.net4j.examples/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.examples/META-INF/MANIFEST.MF
@@ -8,8 +8,8 @@ Bundle-Activator: org.eclipse.net4j.internal.examples.bundle.OM$Activator
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)";resolution:=optional,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)";resolution:=optional,
org.eclipse.net4j;visibility:=reexport,
org.eclipse.net4j.tcp;visibility:=reexport,
org.eclipse.net4j.jvm;visibility:=reexport
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.jms.admin/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.jms.admin/META-INF/MANIFEST.MF
index 07dcc9be84..819e8803c1 100644
--- a/plugins/org.eclipse.net4j.jms.admin/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.jms.admin/META-INF/MANIFEST.MF
@@ -8,9 +8,9 @@ Bundle-Activator: org.eclipse.net4j.jms.internal.admin.bundle.OM
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.jms;visibility:=reexport
Export-Package: org.eclipse.net4j.jms.admin;version="0.8.0",
org.eclipse.net4j.jms.internal.admin;version="0.8.0",
org.eclipse.net4j.jms.internal.admin.protocol;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.jms.server.jdbc/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.jms.server.jdbc/META-INF/MANIFEST.MF
index 43e3e3ac83..5311e682e7 100644
--- a/plugins/org.eclipse.net4j.jms.server.jdbc/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.jms.server.jdbc/META-INF/MANIFEST.MF
@@ -8,10 +8,10 @@ Bundle-Activator: org.eclipse.net4j.jms.server.internal.jdbc.bundle.OM
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.jms.server;visibility:=reexport,
org.eclipse.net4j.db;visibility:=reexport
Import-Package: javax.jms;version="1.1.0"
Export-Package: org.eclipse.net4j.jms.server.internal.jdbc;version="0.8.0",
org.eclipse.net4j.jms.server.jdbc;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.jms.server/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.jms.server/META-INF/MANIFEST.MF
index 18c94c4e65..7a84d75911 100644
--- a/plugins/org.eclipse.net4j.jms.server/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.jms.server/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Bundle-Activator: org.eclipse.net4j.jms.internal.server.bundle.OM
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.jms;visibility:=reexport
Import-Package: javax.jms;version="1.1.0"
Export-Package: org.eclipse.net4j.jms.internal.server;version="0.8.0",
@@ -16,4 +16,4 @@ Export-Package: org.eclipse.net4j.jms.internal.server;version="0.8.0",
org.eclipse.net4j.jms.internal.server.protocol.admin;version="0.8.0",
org.eclipse.net4j.jms.internal.server.store;version="0.8.0",
org.eclipse.net4j.jms.server;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.jms.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.jms.tests/META-INF/MANIFEST.MF
index 22d6250fea..763678238a 100644
--- a/plugins/org.eclipse.net4j.jms.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.jms.tests/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Bundle-Vendor: %providerName
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.tcp,
org.eclipse.net4j.jms,
org.eclipse.net4j.jms.admin,
diff --git a/plugins/org.eclipse.net4j.jms/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.jms/META-INF/MANIFEST.MF
index 75952d5a8b..a09de597e4 100644
--- a/plugins/org.eclipse.net4j.jms/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.jms/META-INF/MANIFEST.MF
@@ -8,11 +8,11 @@ Bundle-Activator: org.eclipse.net4j.internal.jms.bundle.OM$Activator
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j;visibility:=reexport
Import-Package: javax.jms;version="1.1.0"
Export-Package: org.eclipse.net4j.internal.jms;version="0.8.0",
org.eclipse.net4j.internal.jms.protocol;version="0.8.0",
org.eclipse.net4j.internal.jms.util;version="0.8.0",
org.eclipse.net4j.jms;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.jvm/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.jvm/META-INF/MANIFEST.MF
index b227222d19..72b1c972e9 100644
--- a/plugins/org.eclipse.net4j.jvm/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.jvm/META-INF/MANIFEST.MF
@@ -8,9 +8,9 @@ Bundle-Vendor: %providerName
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)";resolution:=optional,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)";resolution:=optional,
org.eclipse.net4j;visibility:=reexport
Import-Package: org.osgi.framework;version="1.3.0";resolution:=optional
Export-Package: org.eclipse.net4j.internal.jvm;version="0.8.0",
org.eclipse.net4j.jvm;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.tcp/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.tcp/META-INF/MANIFEST.MF
index 6a58f45d05..8bd74a1e43 100644
--- a/plugins/org.eclipse.net4j.tcp/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.tcp/META-INF/MANIFEST.MF
@@ -8,9 +8,9 @@ Bundle-Vendor: %providerName
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)";resolution:=optional,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)";resolution:=optional,
org.eclipse.net4j;visibility:=reexport
Import-Package: org.osgi.framework;version="1.3.0";resolution:=optional
Export-Package: org.eclipse.net4j.internal.tcp;version="0.8.0",
org.eclipse.net4j.tcp;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.tests/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.tests/META-INF/MANIFEST.MF
index 52751a2d8b..baf51c0fe0 100644
--- a/plugins/org.eclipse.net4j.tests/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.tests/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Bundle-Activator: org.eclipse.net4j.tests.bundle.Activator
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j.tcp;visibility:=reexport,
org.eclipse.net4j.jvm;visibility:=reexport,
org.junit;visibility:=reexport
@@ -16,4 +16,4 @@ Export-Package: org.eclipse.net4j.tests,
org.eclipse.net4j.tests.signal,
org.eclipse.net4j.util.tests,
org.eclipse.net4j.util.tests.cache
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.ui/META-INF/MANIFEST.MF
index 538e65dc08..73435e6fa7 100644
--- a/plugins/org.eclipse.net4j.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.ui/META-INF/MANIFEST.MF
@@ -8,9 +8,9 @@ Bundle-Activator: org.eclipse.net4j.internal.ui.bundle.OM$Activator
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
org.eclipse.net4j;visibility:=reexport,
org.eclipse.net4j.util.ui;visibility:=reexport
Export-Package: org.eclipse.net4j.internal.ui;version="0.8.0",
org.eclipse.net4j.internal.ui.views;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.util.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.util.ui/META-INF/MANIFEST.MF
index 3954cf018d..7b6f812ff6 100644
--- a/plugins/org.eclipse.net4j.util.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.util.ui/META-INF/MANIFEST.MF
@@ -8,8 +8,8 @@ Bundle-Vendor: %providerName
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)",
- org.eclipse.ui;bundle-version="[3.3.0,4.0.0)";visibility:=reexport,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui;visibility:=reexport,
org.eclipse.net4j.util;visibility:=reexport
Export-Package: org.eclipse.net4j.util.internal.ui;version="0.8.0",
org.eclipse.net4j.util.internal.ui.actions;version="0.8.0",
@@ -22,4 +22,4 @@ Export-Package: org.eclipse.net4j.util.internal.ui;version="0.8.0",
org.eclipse.net4j.util.ui.proposals;version="0.8.0",
org.eclipse.net4j.util.ui.views;version="0.8.0",
org.eclipse.net4j.util.ui.widgets;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j.util/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j.util/META-INF/MANIFEST.MF
index e416bf6bb3..1dbb4473e8 100644
--- a/plugins/org.eclipse.net4j.util/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j.util/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Bundle-Activator: org.eclipse.net4j.internal.util.bundle.OM$Activator
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)";resolution:=optional
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)";resolution:=optional
Import-Package: org.eclipse.osgi.service.debug;version="1.0.0";resolution:=optional,
org.osgi.framework;version="1.3.0";resolution:=optional,
org.osgi.service.log;version="1.3.0";resolution:=optional,
@@ -50,4 +50,4 @@ Export-Package: org.eclipse.net4j.internal.util.bundle;version="0.8.0";x-interna
org.eclipse.net4j.util.registry;version="0.8.0",
org.eclipse.net4j.util.security;version="0.8.0",
org.eclipse.net4j.util.transaction;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy
diff --git a/plugins/org.eclipse.net4j/META-INF/MANIFEST.MF b/plugins/org.eclipse.net4j/META-INF/MANIFEST.MF
index aaf4457c2c..dc4f4f703f 100644
--- a/plugins/org.eclipse.net4j/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.net4j/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Bundle-Activator: org.eclipse.internal.net4j.bundle.OM$Activator
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.3.0,4.0.0)";resolution:=optional,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)";resolution:=optional,
org.eclipse.net4j.util;visibility:=reexport
Export-Package: org.eclipse.internal.net4j;version="0.8.0",
org.eclipse.internal.net4j.acceptor;version="0.8.0",
@@ -26,4 +26,4 @@ Export-Package: org.eclipse.internal.net4j;version="0.8.0",
org.eclipse.net4j.signal;version="0.8.0",
org.eclipse.net4j.signal.failover;version="0.8.0",
org.eclipse.net4j.signal.wrapping;version="0.8.0"
-Eclipse-LazyStart: true
+Bundle-ActivationPolicy: lazy

Back to the top