Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--admin/pom-config.xml3
-rw-r--r--target_explorer/features/org.eclipse.tcf.te.feature/feature.xml20
-rw-r--r--target_explorer/features/org.eclipse.tcf.te.sdk.feature/feature.xml1
-rw-r--r--target_explorer/features/org.eclipse.tcf.te.tcf.core.feature/feature.xml4
-rw-r--r--target_explorer/features/org.eclipse.tcf.te.terminals.feature/feature.xml17
-rw-r--r--target_explorer/features/org.eclipse.tcf.te.terminals.sdk.feature/feature.xml1
-rw-r--r--target_explorer/plugins/org.eclipse.tcf.te.tcf.terminals.ui/META-INF/MANIFEST.MF10
-rw-r--r--target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.process/META-INF/MANIFEST.MF8
-rw-r--r--target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.process/src/org/eclipse/tcf/te/ui/terminals/process/ProcessSettingsPage.java4
-rw-r--r--target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.serial/META-INF/MANIFEST.MF12
-rw-r--r--target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.ssh/META-INF/MANIFEST.MF12
-rw-r--r--target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.telnet/META-INF/MANIFEST.MF12
-rw-r--r--target_explorer/plugins/org.eclipse.tcf.te.ui.terminals/META-INF/MANIFEST.MF14
-rw-r--r--target_explorer/plugins/org.eclipse.tcf.te.ui.terminals/src/org/eclipse/tcf/te/ui/terminals/internal/dialogs/LaunchTerminalSettingsDialog.java3
14 files changed, 64 insertions, 57 deletions
diff --git a/admin/pom-config.xml b/admin/pom-config.xml
index 8fece4837..9959eac86 100644
--- a/admin/pom-config.xml
+++ b/admin/pom-config.xml
@@ -53,7 +53,10 @@
<!-- P2 repository URL's -->
<platform-site>http://download.eclipse.org/eclipse/updates/3.8</platform-site>
<cdt-site>http://download.eclipse.org/tools/cdt/releases/juno</cdt-site>
+ <!--
<tm-site>http://download.eclipse.org/tm/updates/3.4/</tm-site>
+ -->
+ <tm-site>http://download.eclipse.org/tm/builds/juno/nightly/</tm-site>
<rxtx-site>http://rxtx.qbang.org/eclipse</rxtx-site>
<orbit-site>http://download.eclipse.org/tools/orbit/downloads/drops/R20120526062928/repository/</orbit-site>
</properties>
diff --git a/target_explorer/features/org.eclipse.tcf.te.feature/feature.xml b/target_explorer/features/org.eclipse.tcf.te.feature/feature.xml
index fd30589d9..a7a18901e 100644
--- a/target_explorer/features/org.eclipse.tcf.te.feature/feature.xml
+++ b/target_explorer/features/org.eclipse.tcf.te.feature/feature.xml
@@ -24,22 +24,24 @@
<requires>
<import plugin="org.eclipse.core.runtime" version="3.8.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui" version="3.8.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui.ide" version="3.8.0" match="greaterOrEqual"/>
- <import feature="org.eclipse.tcf.feature" version="1.1.0" match="greaterOrEqual"/>
- <import feature="org.eclipse.tm.terminal" version="3.2.0" match="greaterOrEqual"/>
- <import feature="org.eclipse.tm.terminal.serial" version="2.1.100" match="greaterOrEqual"/>
- <import feature="org.eclipse.tm.terminal.ssh" version="2.1.100" match="greaterOrEqual"/>
- <import feature="org.eclipse.tm.terminal.telnet" version="2.1.100" match="greaterOrEqual"/>
<import plugin="org.eclipse.core.expressions" version="3.4.400" match="greaterOrEqual"/>
- <import plugin="org.eclipse.cdt.core" version="5.4.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.debug.core" version="3.7.100" match="greaterOrEqual"/>
- <import plugin="org.eclipse.debug.ui" version="3.8.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.ui" version="3.8.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.forms" version="3.5.200" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.navigator" version="3.5.200" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.views.properties.tabbed" version="3.5.300" match="greaterOrEqual"/>
<import plugin="org.eclipse.help" version="3.6.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.equinox.security" version="1.1.100" match="greaterOrEqual"/>
+ <import feature="org.eclipse.tcf.feature" version="1.1.0" match="greaterOrEqual"/>
+ <import feature="org.eclipse.tm.terminal" version="3.2.2" match="greaterOrEqual"/>
+ <import feature="org.eclipse.tm.terminal.serial" version="2.1.200" match="greaterOrEqual"/>
+ <import feature="org.eclipse.tm.terminal.ssh" version="2.1.200" match="greaterOrEqual"/>
+ <import feature="org.eclipse.tm.terminal.telnet" version="2.1.200" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.cdt.core" version="5.4.1" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.cdt.debug.core" version="7.2.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.debug.ui" version="3.8.1" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.ui.ide" version="3.8.1" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.core.variables" version="3.2.600" match="greaterOrEqual"/>
</requires>
<plugin
diff --git a/target_explorer/features/org.eclipse.tcf.te.sdk.feature/feature.xml b/target_explorer/features/org.eclipse.tcf.te.sdk.feature/feature.xml
index 4f42b724e..6537c1855 100644
--- a/target_explorer/features/org.eclipse.tcf.te.sdk.feature/feature.xml
+++ b/target_explorer/features/org.eclipse.tcf.te.sdk.feature/feature.xml
@@ -23,6 +23,7 @@
<requires>
<import feature="org.eclipse.tcf.te.feature" version="1.1.0" match="greaterOrEqual"/>
+ <import feature="org.eclipse.tm.terminal.core.sdk" version="3.3.2" match="greaterOrEqual"/>
</requires>
<plugin
diff --git a/target_explorer/features/org.eclipse.tcf.te.tcf.core.feature/feature.xml b/target_explorer/features/org.eclipse.tcf.te.tcf.core.feature/feature.xml
index 762bb4a7d..c57b7935b 100644
--- a/target_explorer/features/org.eclipse.tcf.te.tcf.core.feature/feature.xml
+++ b/target_explorer/features/org.eclipse.tcf.te.tcf.core.feature/feature.xml
@@ -28,7 +28,6 @@
<import plugin="org.eclipse.core.filesystem" version="1.3.200" match="greaterOrEqual"/>
<import plugin="org.eclipse.compare" version="3.5.300" match="greaterOrEqual"/>
<import plugin="org.eclipse.text" version="3.5.200" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui.ide" version="3.8.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.navigator" version="3.5.200" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.views.properties.tabbed" version="3.5.300" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.workbench.texteditor" version="3.8.0" match="greaterOrEqual"/>
@@ -37,7 +36,8 @@
<import plugin="org.eclipse.ui.console" version="3.5.100" match="greaterOrEqual"/>
<import feature="org.eclipse.tcf.core.feature" version="1.1.0" match="greaterOrEqual"/>
<import feature="org.eclipse.tcf.te.feature" version="1.1.0" match="greaterOrEqual"/>
- <import feature="org.eclipse.tm.terminal" version="3.2.0" match="greaterOrEqual"/>
+ <import feature="org.eclipse.tm.terminal" version="3.2.2" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.ui.ide" version="3.8.1" match="greaterOrEqual"/>
</requires>
<plugin
diff --git a/target_explorer/features/org.eclipse.tcf.te.terminals.feature/feature.xml b/target_explorer/features/org.eclipse.tcf.te.terminals.feature/feature.xml
index b660f0e77..bbc6ec265 100644
--- a/target_explorer/features/org.eclipse.tcf.te.terminals.feature/feature.xml
+++ b/target_explorer/features/org.eclipse.tcf.te.terminals.feature/feature.xml
@@ -23,22 +23,23 @@
</url>
<requires>
- <import plugin="org.eclipse.core.runtime" version="3.8.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.core.expressions" version="3.4.400" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui" version="3.8.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui.ide" version="3.8.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui.forms" version="3.5.200" match="greaterOrEqual"/>
- <import plugin="org.eclipse.tm.terminal" version="3.2.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.core.runtime" version="3.8.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf.te.core" version="1.1.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf.te.runtime" version="1.1.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf.te.runtime.services" version="1.1.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf.te.ui" version="1.1.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf.te.ui.controls" version="1.1.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf.te.ui.swt" version="1.1.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.ui" version="3.8.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.ui.forms" version="3.5.200" match="greaterOrEqual"/>
<import plugin="org.eclipse.equinox.security" version="1.1.100" match="greaterOrEqual"/>
- <import plugin="org.eclipse.tm.terminal.serial" version="2.1.100" match="greaterOrEqual"/>
- <import plugin="org.eclipse.tm.terminal.ssh" version="2.1.100" match="greaterOrEqual"/>
- <import plugin="org.eclipse.tm.terminal.telnet" version="2.1.100" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.ui.ide" version="3.8.1" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.tcf.te.ui.terminals" version="1.1.0" match="greaterOrEqual"/>
+ <import feature="org.eclipse.tm.terminal" version="3.2.2" match="greaterOrEqual"/>
+ <import feature="org.eclipse.tm.terminal.serial" version="2.1.200" match="greaterOrEqual"/>
+ <import feature="org.eclipse.tm.terminal.ssh" version="2.1.200" match="greaterOrEqual"/>
+ <import feature="org.eclipse.tm.terminal.telnet" version="2.1.200" match="greaterOrEqual"/>
</requires>
<plugin
diff --git a/target_explorer/features/org.eclipse.tcf.te.terminals.sdk.feature/feature.xml b/target_explorer/features/org.eclipse.tcf.te.terminals.sdk.feature/feature.xml
index 8d2eaaaba..438408c0e 100644
--- a/target_explorer/features/org.eclipse.tcf.te.terminals.sdk.feature/feature.xml
+++ b/target_explorer/features/org.eclipse.tcf.te.terminals.sdk.feature/feature.xml
@@ -23,6 +23,7 @@
<requires>
<import feature="org.eclipse.tcf.te.terminals.feature" version="1.1.0" match="equivalent"/>
+ <import feature="org.eclipse.tm.terminal.core.sdk" version="3.3.2" match="greaterOrEqual"/>
</requires>
<plugin
diff --git a/target_explorer/plugins/org.eclipse.tcf.te.tcf.terminals.ui/META-INF/MANIFEST.MF b/target_explorer/plugins/org.eclipse.tcf.te.tcf.terminals.ui/META-INF/MANIFEST.MF
index 459983b0c..c9363b42a 100644
--- a/target_explorer/plugins/org.eclipse.tcf.te.tcf.terminals.ui/META-INF/MANIFEST.MF
+++ b/target_explorer/plugins/org.eclipse.tcf.te.tcf.terminals.ui/META-INF/MANIFEST.MF
@@ -5,10 +5,8 @@ Bundle-SymbolicName: org.eclipse.tcf.te.tcf.terminals.ui;singleton:=true
Bundle-Version: 1.1.0.qualifier
Bundle-Activator: org.eclipse.tcf.te.tcf.terminals.ui.activator.UIPlugin
Bundle-Vendor: %providerName
-Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0",
- org.eclipse.core.expressions;bundle-version="3.4.400",
- org.eclipse.ui;bundle-version="3.8.0",
- org.eclipse.ui.forms;bundle-version="3.5.200",
+Require-Bundle: org.eclipse.core.expressions;bundle-version="3.4.400",
+ org.eclipse.core.runtime;bundle-version="3.8.0",
org.eclipse.tcf.te.runtime;bundle-version="1.1.0",
org.eclipse.tcf.te.runtime.model;bundle-version="1.1.0",
org.eclipse.tcf.te.runtime.services;bundle-version="1.1.0",
@@ -18,7 +16,9 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0",
org.eclipse.tcf.te.ui;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.terminals;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.controls;bundle-version="1.1.0",
- org.eclipse.tm.terminal;bundle-version="3.2.0"
+ org.eclipse.tm.terminal;bundle-version="3.2.2",
+ org.eclipse.ui;bundle-version="3.8.0",
+ org.eclipse.ui.forms;bundle-version="3.5.200"
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
diff --git a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.process/META-INF/MANIFEST.MF b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.process/META-INF/MANIFEST.MF
index 0b96ba255..973930374 100644
--- a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.process/META-INF/MANIFEST.MF
+++ b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.process/META-INF/MANIFEST.MF
@@ -5,15 +5,15 @@ Bundle-SymbolicName: org.eclipse.tcf.te.ui.terminals.process;singleton:=true
Bundle-Version: 1.1.0.qualifier
Bundle-Activator: org.eclipse.tcf.te.ui.terminals.process.activator.UIPlugin
Bundle-Vendor: %providerName
-Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0",
+Require-Bundle: org.eclipse.cdt.core;bundle-version="5.4.1",
org.eclipse.core.resources;bundle-version="3.8.1";resolution:=optional,
- org.eclipse.ui;bundle-version="3.8.0",
- org.eclipse.cdt.core;bundle-version="5.4.1",
+ org.eclipse.core.runtime;bundle-version="3.8.0",
org.eclipse.tcf.te.runtime;bundle-version="1.1.0",
org.eclipse.tcf.te.runtime.services;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.terminals;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.swt;bundle-version="1.1.0",
- org.eclipse.tm.terminal;bundle-version="3.2.0"
+ org.eclipse.tm.terminal;bundle-version="3.2.2",
+ org.eclipse.ui;bundle-version="3.8.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
diff --git a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.process/src/org/eclipse/tcf/te/ui/terminals/process/ProcessSettingsPage.java b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.process/src/org/eclipse/tcf/te/ui/terminals/process/ProcessSettingsPage.java
index cb28ff1f3..1066944e8 100644
--- a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.process/src/org/eclipse/tcf/te/ui/terminals/process/ProcessSettingsPage.java
+++ b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.process/src/org/eclipse/tcf/te/ui/terminals/process/ProcessSettingsPage.java
@@ -25,9 +25,9 @@ import org.eclipse.swt.widgets.FileDialog;
import org.eclipse.swt.widgets.Label;
import org.eclipse.swt.widgets.Shell;
import org.eclipse.swt.widgets.Text;
-import org.eclipse.tm.internal.terminal.provisional.api.ISettingsPage;
import org.eclipse.tcf.te.ui.swt.SWTControlUtil;
import org.eclipse.tcf.te.ui.terminals.nls.Messages;
+import org.eclipse.tm.internal.terminal.provisional.api.AbstractSettingsPage;
import org.eclipse.ui.PlatformUI;
import org.osgi.framework.Bundle;
@@ -35,7 +35,7 @@ import org.osgi.framework.Bundle;
* Process connector settings page implementation.
*/
@SuppressWarnings("restriction")
-public class ProcessSettingsPage implements ISettingsPage {
+public class ProcessSettingsPage extends AbstractSettingsPage {
private Text processImageSelectorControl;
private Button processImageSelectorControlButton;
private Text processArgumentsControl;
diff --git a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.serial/META-INF/MANIFEST.MF b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.serial/META-INF/MANIFEST.MF
index b1089d42d..bea74ea5e 100644
--- a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.serial/META-INF/MANIFEST.MF
+++ b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.serial/META-INF/MANIFEST.MF
@@ -5,19 +5,19 @@ Bundle-SymbolicName: org.eclipse.tcf.te.ui.terminals.serial;singleton:=true
Bundle-Version: 1.1.0.qualifier
Bundle-Activator: org.eclipse.tcf.te.ui.terminals.serial.activator.UIPlugin
Bundle-Vendor: %providerName
-Require-Bundle: org.eclipse.equinox.security;bundle-version="1.1.100",
+Require-Bundle: org.eclipse.core.expressions;bundle-version="3.4.400",
org.eclipse.core.runtime;bundle-version="3.8.0",
- org.eclipse.core.expressions;bundle-version="3.4.400",
- org.eclipse.ui;bundle-version="3.8.0",
- org.eclipse.ui.forms;bundle-version="3.5.200",
+ org.eclipse.equinox.security;bundle-version="1.1.100",
org.eclipse.tcf.te.runtime;bundle-version="1.1.0",
org.eclipse.tcf.te.runtime.services;bundle-version="1.1.0",
org.eclipse.tcf.te.ui;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.controls;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.swt;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.terminals;bundle-version="1.1.0",
- org.eclipse.tm.terminal;bundle-version="3.2.0",
- org.eclipse.tm.terminal.serial;bundle-version="2.1.100"
+ org.eclipse.tm.terminal;bundle-version="3.2.2",
+ org.eclipse.tm.terminal.serial;bundle-version="2.1.200",
+ org.eclipse.ui;bundle-version="3.8.0",
+ org.eclipse.ui.forms;bundle-version="3.5.200"
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
diff --git a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.ssh/META-INF/MANIFEST.MF b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.ssh/META-INF/MANIFEST.MF
index a3a46280c..33e2c02b0 100644
--- a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.ssh/META-INF/MANIFEST.MF
+++ b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.ssh/META-INF/MANIFEST.MF
@@ -5,19 +5,19 @@ Bundle-SymbolicName: org.eclipse.tcf.te.ui.terminals.ssh;singleton:=true
Bundle-Version: 1.1.0.qualifier
Bundle-Activator: org.eclipse.tcf.te.ui.terminals.ssh.activator.UIPlugin
Bundle-Vendor: %providerName
-Require-Bundle: org.eclipse.equinox.security;bundle-version="1.1.100",
+Require-Bundle: org.eclipse.core.expressions;bundle-version="3.4.400",
org.eclipse.core.runtime;bundle-version="3.8.0",
- org.eclipse.core.expressions;bundle-version="3.4.400",
- org.eclipse.ui;bundle-version="3.8.0",
- org.eclipse.ui.forms;bundle-version="3.5.200",
+ org.eclipse.equinox.security;bundle-version="1.1.100",
org.eclipse.tcf.te.runtime;bundle-version="1.1.0",
org.eclipse.tcf.te.runtime.services;bundle-version="1.1.0",
org.eclipse.tcf.te.ui;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.terminals;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.controls;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.swt;bundle-version="1.1.0",
- org.eclipse.tm.terminal;bundle-version="3.2.0",
- org.eclipse.tm.terminal.ssh;bundle-version="2.1.100"
+ org.eclipse.tm.terminal;bundle-version="3.2.2",
+ org.eclipse.tm.terminal.ssh;bundle-version="2.1.200",
+ org.eclipse.ui;bundle-version="3.8.0",
+ org.eclipse.ui.forms;bundle-version="3.5.200"
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
diff --git a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.telnet/META-INF/MANIFEST.MF b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.telnet/META-INF/MANIFEST.MF
index ff740aba3..a0e1ee7b6 100644
--- a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.telnet/META-INF/MANIFEST.MF
+++ b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals.telnet/META-INF/MANIFEST.MF
@@ -5,19 +5,19 @@ Bundle-SymbolicName: org.eclipse.tcf.te.ui.terminals.telnet;singleton:=true
Bundle-Version: 1.1.0.qualifier
Bundle-Activator: org.eclipse.tcf.te.ui.terminals.telnet.activator.UIPlugin
Bundle-Vendor: %providerName
-Require-Bundle: org.eclipse.equinox.security;bundle-version="1.1.100",
+Require-Bundle: org.eclipse.core.expressions;bundle-version="3.4.400",
org.eclipse.core.runtime;bundle-version="3.8.0",
- org.eclipse.core.expressions;bundle-version="3.4.400",
- org.eclipse.ui;bundle-version="3.8.0",
- org.eclipse.ui.forms;bundle-version="3.5.200",
+ org.eclipse.equinox.security;bundle-version="1.1.100",
org.eclipse.tcf.te.runtime;bundle-version="1.1.0",
org.eclipse.tcf.te.runtime.services;bundle-version="1.1.0",
org.eclipse.tcf.te.ui;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.terminals;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.controls;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.swt;bundle-version="1.1.0",
- org.eclipse.tm.terminal;bundle-version="3.2.0",
- org.eclipse.tm.terminal.telnet;bundle-version="2.1.100"
+ org.eclipse.tm.terminal;bundle-version="3.2.2",
+ org.eclipse.tm.terminal.telnet;bundle-version="2.1.200",
+ org.eclipse.ui;bundle-version="3.8.0",
+ org.eclipse.ui.forms;bundle-version="3.5.200"
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
diff --git a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals/META-INF/MANIFEST.MF b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals/META-INF/MANIFEST.MF
index c7bc5156b..a871f1bfa 100644
--- a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals/META-INF/MANIFEST.MF
+++ b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals/META-INF/MANIFEST.MF
@@ -5,19 +5,19 @@ Bundle-SymbolicName: org.eclipse.tcf.te.ui.terminals;singleton:=true
Bundle-Version: 1.1.0.qualifier
Bundle-Activator: org.eclipse.tcf.te.ui.terminals.activator.UIPlugin
Bundle-Vendor: %providerName
-Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0",
- org.eclipse.core.expressions;bundle-version="3.4.400",
+Require-Bundle: org.eclipse.core.expressions;bundle-version="3.4.400",
+ org.eclipse.core.runtime;bundle-version="3.8.0",
org.eclipse.core.resources;bundle-version="3.8.1";resolution:=optional,
- org.eclipse.ui;bundle-version="3.8.0",
- org.eclipse.ui.ide;bundle-version="3.8.1",
- org.eclipse.ui.forms;bundle-version="3.5.200",
- org.eclipse.tm.terminal;bundle-version="3.2.0",
org.eclipse.tcf.te.core;bundle-version="1.1.0",
org.eclipse.tcf.te.runtime;bundle-version="1.1.0",
org.eclipse.tcf.te.runtime.services;bundle-version="1.1.0",
org.eclipse.tcf.te.ui;bundle-version="1.1.0",
org.eclipse.tcf.te.ui.controls;bundle-version="1.1.0",
- org.eclipse.tcf.te.ui.swt;bundle-version="1.1.0"
+ org.eclipse.tcf.te.ui.swt;bundle-version="1.1.0",
+ org.eclipse.tm.terminal;bundle-version="3.2.2",
+ org.eclipse.ui;bundle-version="3.8.0",
+ org.eclipse.ui.forms;bundle-version="3.5.200",
+ org.eclipse.ui.ide;bundle-version="3.8.1"
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
diff --git a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals/src/org/eclipse/tcf/te/ui/terminals/internal/dialogs/LaunchTerminalSettingsDialog.java b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals/src/org/eclipse/tcf/te/ui/terminals/internal/dialogs/LaunchTerminalSettingsDialog.java
index 20a26b5c1..a493c5a7f 100644
--- a/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals/src/org/eclipse/tcf/te/ui/terminals/internal/dialogs/LaunchTerminalSettingsDialog.java
+++ b/target_explorer/plugins/org.eclipse.tcf.te.ui.terminals/src/org/eclipse/tcf/te/ui/terminals/internal/dialogs/LaunchTerminalSettingsDialog.java
@@ -426,9 +426,8 @@ public class LaunchTerminalSettingsDialog extends CustomTrayDialog {
IWizardConfigurationPanel panel = this.settings.getConfigurationPanel(terminals.getText());
if(!panel.isValid()){
- String strTitle = Messages.LaunchTerminalSettingsDialog_error_title;
MessageBox mb = new MessageBox(getShell(), SWT.ICON_ERROR | SWT.OK);
- mb.setText(strTitle);
+ mb.setText(Messages.LaunchTerminalSettingsDialog_error_title);
mb.setMessage(Messages.LaunchTerminalSettingsDialog_error_invalidSettings);
mb.open();
return;

Back to the top