Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Stieber2013-01-23 11:24:48 -0500
committerUwe Stieber2013-01-23 11:24:48 -0500
commitae75d404146564da22105c23ed9cdff267a227ab (patch)
tree76e33ac97fac28e507edcbe02416db2675b962a2
parent18f8e3438452f038b56f1cb9d179e2a00adc6496 (diff)
downloadorg.eclipse.tcf-ae75d404146564da22105c23ed9cdff267a227ab.tar.gz
org.eclipse.tcf-ae75d404146564da22105c23ed9cdff267a227ab.tar.xz
org.eclipse.tcf-ae75d404146564da22105c23ed9cdff267a227ab.zip
Releng: Synchronize required bundle constraints with the current target platform
-rw-r--r--.gitignore1
-rw-r--r--admin/pom-build.xml49
-rw-r--r--features/org.eclipse.tcf.cdt.feature/feature.xml8
-rw-r--r--features/org.eclipse.tcf.core.feature/feature.xml2
-rw-r--r--features/org.eclipse.tcf.feature/feature.xml8
-rw-r--r--features/org.eclipse.tcf.rse.feature/feature.xml10
-rw-r--r--plugins/org.eclipse.tcf.cdt.ui/META-INF/MANIFEST.MF10
-rw-r--r--plugins/org.eclipse.tcf.debug.ui/META-INF/MANIFEST.MF6
-rw-r--r--plugins/org.eclipse.tcf.debug/META-INF/MANIFEST.MF2
-rw-r--r--plugins/org.eclipse.tcf.rse/META-INF/MANIFEST.MF8
-rw-r--r--target_explorer/features/org.eclipse.tcf.te.tcf.feature/feature.xml2
11 files changed, 78 insertions, 28 deletions
diff --git a/.gitignore b/.gitignore
index ae45e2013..bd4a84fe0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -11,3 +11,4 @@ bin/
target/
coverage/
artifacts/
+/ManifestValidationResult.html
diff --git a/admin/pom-build.xml b/admin/pom-build.xml
index d25ce5b59..94aaf7d1e 100644
--- a/admin/pom-build.xml
+++ b/admin/pom-build.xml
@@ -41,6 +41,9 @@
<!-- Not deployed to nexus yet. Must be build locally -->
<!-- before running this profile. -->
<!-- See http://wiki.eclipse.org/Platform-releng/Platform_Build#Building for details -->
+ <!-- -->
+ <!-- Works only if the build runs at a Eclipse build server -->
+
<build>
<plugins>
<plugin>
@@ -75,5 +78,51 @@
</plugins>
</build>
</profile>
+
+ <profile>
+ <id>validate</id>
+ <!-- The validate profile is does work only inside the WR network. -->
+ <!-- The profile requires a custom plug-in to generate the validation report -->
+
+ <pluginRepositories>
+ <pluginRepository>
+ <id>wr</id>
+ <url>http://szg-bld-wb.wrs.com/wb-sd/maven/</url>
+ <snapshots>
+ <enabled>true</enabled>
+ </snapshots>
+ <releases>
+ <enabled>true</enabled>
+ </releases>
+ </pluginRepository>
+ </pluginRepositories>
+
+ <build>
+ <plugins>
+ <plugin>
+ <groupId>com.windriver.tycho-ext</groupId>
+ <artifactId>manifest-validation-plugin</artifactId>
+ <version>1.0.2</version>
+ <executions>
+ <execution>
+ <id>clean</id>
+ <phase>clean</phase>
+ <goals>
+ <goal>clean</goal>
+ </goals>
+ </execution>
+ <execution>
+ <id>validate</id>
+ <phase>validate</phase>
+ <goals>
+ <goal>validate-required-bundle-versions</goal>
+ </goals>
+ </execution>
+ </executions>
+ </plugin>
+ </plugins>
+ </build>
+
+ </profile>
</profiles>
</project>
diff --git a/features/org.eclipse.tcf.cdt.feature/feature.xml b/features/org.eclipse.tcf.cdt.feature/feature.xml
index 202736296..a2cf6120f 100644
--- a/features/org.eclipse.tcf.cdt.feature/feature.xml
+++ b/features/org.eclipse.tcf.cdt.feature/feature.xml
@@ -36,14 +36,14 @@
version="0.0.0"/>
<requires>
- <import feature="org.eclipse.cdt" version="8.0.0" match="greaterOrEqual"/>
+ <import feature="org.eclipse.cdt" version="8.1.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.core.runtime" version="3.8.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.core.resources" version="3.8.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.core.resources" version="3.8.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.text" version="3.5.200" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui" version="3.8.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.debug.core" version="3.7.100" match="greaterOrEqual"/>
- <import plugin="org.eclipse.debug.ui" version="3.8.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.jface.text" version="3.8.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.debug.ui" version="3.8.1" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.jface.text" version="3.8.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.core.expressions" version="3.4.400" match="greaterOrEqual"/>
<import feature="org.eclipse.tcf.feature" version="1.1.0" match="greaterOrEqual"/>
</requires>
diff --git a/features/org.eclipse.tcf.core.feature/feature.xml b/features/org.eclipse.tcf.core.feature/feature.xml
index 6953d86c8..d6d11f49e 100644
--- a/features/org.eclipse.tcf.core.feature/feature.xml
+++ b/features/org.eclipse.tcf.core.feature/feature.xml
@@ -32,7 +32,7 @@
</url>
<requires>
- <import plugin="org.eclipse.osgi"/>
+ <import plugin="org.eclipse.osgi" version="3.8.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.core.runtime" version="3.8.0" match="greaterOrEqual"/>
</requires>
diff --git a/features/org.eclipse.tcf.feature/feature.xml b/features/org.eclipse.tcf.feature/feature.xml
index 0b128351d..26449c892 100644
--- a/features/org.eclipse.tcf.feature/feature.xml
+++ b/features/org.eclipse.tcf.feature/feature.xml
@@ -34,19 +34,19 @@
<requires>
<import plugin="org.eclipse.core.filesystem" version="1.3.200" match="greaterOrEqual"/>
<import plugin="org.eclipse.core.runtime" version="3.8.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.core.resources" version="3.8.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.core.resources" version="3.8.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.debug.core" version="3.7.100" match="greaterOrEqual"/>
<import plugin="com.jcraft.jsch" version="0.1.46" match="greaterOrEqual"/>
<import plugin="org.eclipse.core.expressions" version="3.4.400" match="greaterOrEqual"/>
- <import plugin="org.eclipse.debug.ui" version="3.8.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.jface.text" version="3.8.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.debug.ui" version="3.8.1" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.jface.text" version="3.8.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.jsch.core" version="1.1.400" match="greaterOrEqual"/>
<import plugin="org.eclipse.jsch.ui" version="1.1.400" match="greaterOrEqual"/>
<import plugin="org.eclipse.text" version="3.5.200" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui" version="3.8.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.console" version="3.5.100" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.editors" version="3.8.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui.ide" version="3.8.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.ui.ide" version="3.8.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.views" version="3.6.100" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.workbench.texteditor" version="3.8.0" match="greaterOrEqual"/>
<import feature="org.eclipse.tcf.core.feature" version="1.1.0" match="greaterOrEqual"/>
diff --git a/features/org.eclipse.tcf.rse.feature/feature.xml b/features/org.eclipse.tcf.rse.feature/feature.xml
index 291798388..d16be6957 100644
--- a/features/org.eclipse.tcf.rse.feature/feature.xml
+++ b/features/org.eclipse.tcf.rse.feature/feature.xml
@@ -37,20 +37,20 @@
<requires>
<import plugin="org.eclipse.core.runtime" version="3.8.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.core.resources" version="3.8.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.rse.core" version="3.3.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.core.resources" version="3.8.1" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.rse.core" version="3.3.2" match="greaterOrEqual"/>
<import plugin="org.eclipse.rse.processes.ui" version="3.0.400" match="greaterOrEqual"/>
<import plugin="org.eclipse.rse.services" version="3.2.200" match="greaterOrEqual"/>
- <import plugin="org.eclipse.rse.subsystems.files.core" version="3.3.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.rse.subsystems.files.core" version="3.3.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.rse.subsystems.processes.core" version="3.1.300" match="greaterOrEqual"/>
<import plugin="org.eclipse.rse.subsystems.terminals.core" version="1.0.300" match="greaterOrEqual"/>
<import plugin="org.eclipse.rse.subsystems.shells.core" version="3.1.300" match="greaterOrEqual"/>
- <import plugin="org.eclipse.rse.ui" version="3.3.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.rse.ui" version="3.3.3" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf" version="1.1.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf.core" version="1.1.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui" version="3.8.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.views" version="3.6.100" match="greaterOrEqual"/>
- <import feature="org.eclipse.rse" version="3.4.0" match="greaterOrEqual"/>
+ <import feature="org.eclipse.rse" version="3.4.1" match="greaterOrEqual"/>
</requires>
<plugin
diff --git a/plugins/org.eclipse.tcf.cdt.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.tcf.cdt.ui/META-INF/MANIFEST.MF
index e5b7724a0..f575fbdcf 100644
--- a/plugins/org.eclipse.tcf.cdt.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.tcf.cdt.ui/META-INF/MANIFEST.MF
@@ -6,19 +6,19 @@ Bundle-Version: 1.1.0.qualifier
Bundle-Localization: plugin
Bundle-Activator: org.eclipse.tcf.internal.cdt.ui.Activator
Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0",
- org.eclipse.core.resources;bundle-version="3.8.0",
+ org.eclipse.core.resources;bundle-version="3.8.1",
org.eclipse.text;bundle-version="3.5.200",
org.eclipse.ui;bundle-version="3.8.0",
org.eclipse.debug.core;bundle-version="3.7.100",
- org.eclipse.debug.ui;bundle-version="3.8.0",
- org.eclipse.cdt.core;bundle-version="5.4.0",
- org.eclipse.cdt.ui;bundle-version="5.4.0",
+ org.eclipse.debug.ui;bundle-version="3.8.1",
+ org.eclipse.cdt.core;bundle-version="5.4.1",
+ org.eclipse.cdt.ui;bundle-version="5.5.0",
org.eclipse.cdt.debug.core;bundle-version="7.2.0",
org.eclipse.cdt.debug.ui;bundle-version="7.2.0",
org.eclipse.tcf.core;bundle-version="1.1.0",
org.eclipse.tcf.debug;bundle-version="1.1.0",
org.eclipse.tcf.debug.ui;bundle-version="1.1.0",
- org.eclipse.jface.text;bundle-version="3.8.0",
+ org.eclipse.jface.text;bundle-version="3.8.1",
org.eclipse.core.expressions;bundle-version="3.4.400",
org.eclipse.cdt.launch;bundle-version="7.1.0",
org.eclipse.cdt.dsf.ui;bundle-version="2.3.0"
diff --git a/plugins/org.eclipse.tcf.debug.ui/META-INF/MANIFEST.MF b/plugins/org.eclipse.tcf.debug.ui/META-INF/MANIFEST.MF
index 49ca74b68..f11a1369f 100644
--- a/plugins/org.eclipse.tcf.debug.ui/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.tcf.debug.ui/META-INF/MANIFEST.MF
@@ -11,15 +11,15 @@ Require-Bundle: com.jcraft.jsch;bundle-version="0.1.46",
org.eclipse.core.expressions;bundle-version="3.4.400",
org.eclipse.core.filesystem;bundle-version="1.3.200",
org.eclipse.debug.core;bundle-version="3.7.100",
- org.eclipse.debug.ui;bundle-version="3.8.0",
- org.eclipse.jface.text;bundle-version="3.8.0",
+ org.eclipse.debug.ui;bundle-version="3.8.1",
+ org.eclipse.jface.text;bundle-version="3.8.1",
org.eclipse.jsch.core;bundle-version="1.1.400",
org.eclipse.jsch.ui;bundle-version="1.1.400",
org.eclipse.text;bundle-version="3.5.200",
org.eclipse.ui;bundle-version="3.8.0",
org.eclipse.ui.console;bundle-version="3.5.100",
org.eclipse.ui.editors;bundle-version="3.8.0",
- org.eclipse.ui.ide;bundle-version="3.8.0",
+ org.eclipse.ui.ide;bundle-version="3.8.1",
org.eclipse.ui.views;bundle-version="3.6.100",
org.eclipse.ui.workbench.texteditor;bundle-version="3.8.0",
org.eclipse.tcf.debug;bundle-version="1.1.0"
diff --git a/plugins/org.eclipse.tcf.debug/META-INF/MANIFEST.MF b/plugins/org.eclipse.tcf.debug/META-INF/MANIFEST.MF
index 361bf8275..deb1a0602 100644
--- a/plugins/org.eclipse.tcf.debug/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.tcf.debug/META-INF/MANIFEST.MF
@@ -8,7 +8,7 @@ Bundle-Vendor: %providerName
Bundle-Localization: plugin
Require-Bundle: org.eclipse.core.filesystem;bundle-version="1.3.200",
org.eclipse.core.runtime;bundle-version="3.8.0",
- org.eclipse.core.resources;bundle-version="3.8.0",
+ org.eclipse.core.resources;bundle-version="3.8.1",
org.eclipse.debug.core;bundle-version="3.7.100"
Import-Package: org.eclipse.tcf.core;version="1.1.0",
org.eclipse.tcf.protocol;version="1.1.0",
diff --git a/plugins/org.eclipse.tcf.rse/META-INF/MANIFEST.MF b/plugins/org.eclipse.tcf.rse/META-INF/MANIFEST.MF
index ce8ec2e3c..54255b3b2 100644
--- a/plugins/org.eclipse.tcf.rse/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.tcf.rse/META-INF/MANIFEST.MF
@@ -7,15 +7,15 @@ Bundle-Activator: org.eclipse.tcf.internal.rse.Activator
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0",
- org.eclipse.core.resources;bundle-version="3.8.0",
- org.eclipse.rse.core;bundle-version="3.3.0",
+ org.eclipse.core.resources;bundle-version="3.8.1",
+ org.eclipse.rse.core;bundle-version="3.3.2",
org.eclipse.rse.processes.ui;bundle-version="3.0.400",
org.eclipse.rse.services;bundle-version="3.2.200",
- org.eclipse.rse.subsystems.files.core;bundle-version="3.3.0",
+ org.eclipse.rse.subsystems.files.core;bundle-version="3.3.1",
org.eclipse.rse.subsystems.processes.core;bundle-version="3.1.300",
org.eclipse.rse.subsystems.terminals.core;bundle-version="1.0.300",
org.eclipse.rse.subsystems.shells.core;bundle-version="3.1.300",
- org.eclipse.rse.ui;bundle-version="3.3.0",
+ org.eclipse.rse.ui;bundle-version="3.3.3",
org.eclipse.tcf;bundle-version="1.1.0",
org.eclipse.tcf.core;bundle-version="1.1.0",
org.eclipse.ui;bundle-version="3.8.0",
diff --git a/target_explorer/features/org.eclipse.tcf.te.tcf.feature/feature.xml b/target_explorer/features/org.eclipse.tcf.te.tcf.feature/feature.xml
index af7e5bf1e..0bb29da15 100644
--- a/target_explorer/features/org.eclipse.tcf.te.tcf.feature/feature.xml
+++ b/target_explorer/features/org.eclipse.tcf.te.tcf.feature/feature.xml
@@ -25,7 +25,7 @@
<requires>
<import plugin="org.eclipse.core.runtime" version="3.8.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.debug.core" version="3.7.100" match="greaterOrEqual"/>
- <import plugin="org.eclipse.debug.ui" version="3.8.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.debug.ui" version="3.8.1" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui" version="3.8.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.forms" version="3.5.200" match="greaterOrEqual"/>
<import plugin="org.eclipse.ui.navigator" version="3.5.200" match="greaterOrEqual"/>

Back to the top