Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Stieber2015-01-27 13:13:24 -0500
committerUwe Stieber2015-01-27 13:13:24 -0500
commite6bfca79ca9cd80e1a3869a79235bfb26d0e1c69 (patch)
tree652b7714d78d119093ef1281fa249fedfda2343d
parent18268121a1948a7570ef1c55e74b5eb4a946cd80 (diff)
downloadorg.eclipse.tcf-e6bfca79ca9cd80e1a3869a79235bfb26d0e1c69.tar.gz
org.eclipse.tcf-e6bfca79ca9cd80e1a3869a79235bfb26d0e1c69.tar.xz
org.eclipse.tcf-e6bfca79ca9cd80e1a3869a79235bfb26d0e1c69.zip
Releng: Fix imported bundle versions of remote service plug-ins to still support Eclipse 3.8.x
-rw-r--r--target_explorer/features/org.eclipse.tcf.te.tcf.remote.feature/feature.xml9
-rw-r--r--target_explorer/plugins/org.eclipse.tcf.te.tcf.remote.ui/META-INF/MANIFEST.MF7
2 files changed, 7 insertions, 9 deletions
diff --git a/target_explorer/features/org.eclipse.tcf.te.tcf.remote.feature/feature.xml b/target_explorer/features/org.eclipse.tcf.te.tcf.remote.feature/feature.xml
index a31e5d49b..08ad9a019 100644
--- a/target_explorer/features/org.eclipse.tcf.te.tcf.remote.feature/feature.xml
+++ b/target_explorer/features/org.eclipse.tcf.te.tcf.remote.feature/feature.xml
@@ -25,7 +25,7 @@
<requires>
<import plugin="org.eclipse.core.runtime" version="3.8.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.remote.core" version="1.0.0" match="compatible"/>
+ <import plugin="org.eclipse.remote.core" version="1.0.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf.te.tcf.locator" version="1.3.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf.core" version="1.3.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf.te.runtime" version="1.3.0" match="greaterOrEqual"/>
@@ -34,11 +34,10 @@
<import plugin="org.eclipse.core.filesystem" version="1.3.200" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf.te.tcf.core" version="1.3.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf.te.tcf.processes.core" version="1.3.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.remote.ui" version="1.1.0" match="compatible"/>
+ <import plugin="org.eclipse.remote.ui" version="1.1.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.tcf.te.tcf.remote.core" version="1.3.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.swt" version="3.103.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.jface" version="3.10.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.ui.ide" version="3.10.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.ui" version="3.8.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.ui.ide" version="3.8.1" match="greaterOrEqual"/>
<import feature="org.eclipse.remote" version="1.1.0" match="compatible"/>
<import feature="org.eclipse.tcf.te.tcf.core.feature" version="1.3.0" match="greaterOrEqual"/>
</requires>
diff --git a/target_explorer/plugins/org.eclipse.tcf.te.tcf.remote.ui/META-INF/MANIFEST.MF b/target_explorer/plugins/org.eclipse.tcf.te.tcf.remote.ui/META-INF/MANIFEST.MF
index 2f68d7ee0..552f73d21 100644
--- a/target_explorer/plugins/org.eclipse.tcf.te.tcf.remote.ui/META-INF/MANIFEST.MF
+++ b/target_explorer/plugins/org.eclipse.tcf.te.tcf.remote.ui/META-INF/MANIFEST.MF
@@ -9,10 +9,9 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.8.0",
org.eclipse.remote.ui;bundle-version="1.1.0",
org.eclipse.remote.core;bundle-version="1.0.0",
org.eclipse.tcf.te.tcf.remote.core;bundle-version="1.3.0",
- org.eclipse.swt;bundle-version="3.103.0",
- org.eclipse.jface;bundle-version="3.10.0",
- org.eclipse.core.filesystem;bundle-version="1.4.0",
- org.eclipse.ui.ide;bundle-version="3.10.0",
+ org.eclipse.core.filesystem;bundle-version="1.3.200",
+ org.eclipse.ui;bundle-version="3.8.0",
+ org.eclipse.ui.ide;bundle-version="3.8.1",
org.eclipse.tcf.te.tcf.locator;bundle-version="1.3.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ActivationPolicy: lazy

Back to the top