aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Sewe2012-12-12 04:04:45 (EST)
committerGerrit Code Review @ Eclipse.org2012-12-12 04:07:09 (EST)
commit6d4480a24349267ba0fe49ba10c0688bef77bcbc (patch)
tree96ec7bbafd45e0540e1cc0a6f2ff2cb548ab8076
parentf28aa1ad579dfa8b777758fdafba3a2b0443973e (diff)
downloadorg.eclipse.recommenders-6d4480a24349267ba0fe49ba10c0688bef77bcbc.zip
org.eclipse.recommenders-6d4480a24349267ba0fe49ba10c0688bef77bcbc.tar.gz
org.eclipse.recommenders-6d4480a24349267ba0fe49ba10c0688bef77bcbc.tar.bz2
[releng] Added missing uses directives in RDK manifest.refs/changes/78/9178/2
-rw-r--r--plugins/org.eclipse.recommenders.rdk/META-INF/MANIFEST.MF14
1 files changed, 10 insertions, 4 deletions
diff --git a/plugins/org.eclipse.recommenders.rdk/META-INF/MANIFEST.MF b/plugins/org.eclipse.recommenders.rdk/META-INF/MANIFEST.MF
index 1bd9646..1674f28 100644
--- a/plugins/org.eclipse.recommenders.rdk/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.recommenders.rdk/META-INF/MANIFEST.MF
@@ -5,9 +5,13 @@ Bundle-SymbolicName: org.eclipse.recommenders.rdk
Bundle-Version: 0.0.0.qualifier
Bundle-Activator: org.eclipse.recommenders.internal.rdk.wiring.Activator
Bundle-Vendor: Eclipse Code Recommenders
-Export-Package: org.eclipse.recommenders.rdk.utils
-Require-Bundle: org.eclipse.recommenders.aether,
- org.apache.felix.gogo.runtime;bundle-version="0.8.0",
+Export-Package: org.eclipse.recommenders.rdk.utils;
+ uses:="org.eclipse.core.runtime,
+ org.osgi.framework,
+ org.sonatype.aether.artifact,
+ org.w3c.dom,
+ com.google.common.base"
+Require-Bundle: org.apache.felix.gogo.runtime;bundle-version="0.8.0",
org.apache.lucene;bundle-version="3.5.0",
com.google.gson;bundle-version="[2.0.0,3.0.0)",
com.google.guava;bundle-version="[10.0.0,11.0.0)",
@@ -19,5 +23,7 @@ Require-Bundle: org.eclipse.recommenders.aether,
org.eclipse.xtext.xbase.lib,
org.slf4j.api
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Import-Package: org.osgi.framework;version="1.3.0"
+Import-Package: org.osgi.framework;version="1.3.0",
+ org.sonatype.aether.artifact,
+ org.sonatype.aether.util.artifact
Bundle-ActivationPolicy: lazy