aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCurtis Windatt2012-02-09 13:45:21 (EST)
committerPaul Webster2012-02-09 13:45:21 (EST)
commit154f39587dfebd62e1f8156f9a016c8f3b685433 (patch)
treed856dc67c77ea86b336daf5bbf49dad99b2e46a9
parentc7772d8f312ba73f20c2f8e1af3906b1120e7ca3 (diff)
downloadeclipse.platform.ui-154f39587dfebd62e1f8156f9a016c8f3b685433.zip
eclipse.platform.ui-154f39587dfebd62e1f8156f9a016c8f3b685433.tar.gz
eclipse.platform.ui-154f39587dfebd62e1f8156f9a016c8f3b685433.tar.bz2
Bug 370617 - Platform UI e4 bundles should use version ranges forv20120209-1845
dependencies widened range on emf bundles as well.
-rw-r--r--bundles/org.eclipse.e4.core.commands/.settings/org.eclipse.pde.prefs35
-rw-r--r--bundles/org.eclipse.e4.core.commands/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.e4.core.contexts.debug/.settings/org.eclipse.pde.prefs35
-rw-r--r--bundles/org.eclipse.e4.core.contexts.debug/META-INF/MANIFEST.MF8
-rw-r--r--bundles/org.eclipse.e4.core.contexts.debug/plugin.properties2
-rw-r--r--bundles/org.eclipse.e4.core.contexts.debug/plugin.xml2
-rw-r--r--bundles/org.eclipse.e4.ui.bindings/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.bindings/META-INF/MANIFEST.MF8
-rw-r--r--bundles/org.eclipse.e4.ui.css.core/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.css.core/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.e4.ui.css.core/plugin.properties2
-rw-r--r--bundles/org.eclipse.e4.ui.css.core/plugin.xml2
-rw-r--r--bundles/org.eclipse.e4.ui.css.swt.theme/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.css.swt.theme/META-INF/MANIFEST.MF8
-rw-r--r--bundles/org.eclipse.e4.ui.css.swt.theme/plugin.properties4
-rw-r--r--bundles/org.eclipse.e4.ui.css.swt.theme/plugin.xml2
-rw-r--r--bundles/org.eclipse.e4.ui.css.swt/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.css.swt/META-INF/MANIFEST.MF8
-rw-r--r--bundles/org.eclipse.e4.ui.css.swt/plugin.properties4
-rw-r--r--bundles/org.eclipse.e4.ui.css.swt/plugin.xml2
-rw-r--r--bundles/org.eclipse.e4.ui.di/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.di/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.e4.ui.model.workbench.edit/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.model.workbench.edit/META-INF/MANIFEST.MF10
-rw-r--r--bundles/org.eclipse.e4.ui.model.workbench/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.model.workbench/META-INF/MANIFEST.MF12
-rw-r--r--bundles/org.eclipse.e4.ui.model.workbench/plugin.xml2
-rw-r--r--bundles/org.eclipse.e4.ui.services/.settings/org.eclipse.pde.core.prefs4
-rw-r--r--bundles/org.eclipse.e4.ui.services/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.services/META-INF/MANIFEST.MF4
-rw-r--r--bundles/org.eclipse.e4.ui.widgets/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.widgets/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.e4.ui.workbench.addons.swt/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.workbench.addons.swt/META-INF/MANIFEST.MF8
-rw-r--r--bundles/org.eclipse.e4.ui.workbench.addons.swt/plugin.properties2
-rw-r--r--bundles/org.eclipse.e4.ui.workbench.addons.swt/plugin.xml2
-rw-r--r--bundles/org.eclipse.e4.ui.workbench.renderers.swt/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.workbench.renderers.swt/META-INF/MANIFEST.MF16
-rw-r--r--bundles/org.eclipse.e4.ui.workbench.swt/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.workbench.swt/META-INF/MANIFEST.MF30
-rw-r--r--bundles/org.eclipse.e4.ui.workbench.swt/plugin.properties5
-rw-r--r--bundles/org.eclipse.e4.ui.workbench.swt/plugin.xml14
-rw-r--r--bundles/org.eclipse.e4.ui.workbench/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.workbench/META-INF/MANIFEST.MF17
-rw-r--r--bundles/org.eclipse.e4.ui.workbench/plugin.properties5
-rw-r--r--bundles/org.eclipse.e4.ui.workbench/plugin.xml4
-rw-r--r--bundles/org.eclipse.e4.ui.workbench3/.settings/org.eclipse.pde.prefs32
-rw-r--r--bundles/org.eclipse.e4.ui.workbench3/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.ui.workbench/.settings/org.eclipse.pde.prefs39
-rw-r--r--bundles/org.eclipse.ui.workbench/META-INF/MANIFEST.MF6
-rw-r--r--bundles/org.eclipse.ui/.settings/org.eclipse.pde.prefs39
51 files changed, 692 insertions, 109 deletions
diff --git a/bundles/org.eclipse.e4.core.commands/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.core.commands/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..486a796
--- /dev/null
+++ b/bundles/org.eclipse.e4.core.commands/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,35 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=0
+compilers.p.discouraged-class=1
+compilers.p.illegal-att-value=0
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=2
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=0
+compilers.p.unknown-attribute=0
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.p.unused-element-or-attribute=1
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+compilers.use-project=true
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.core.commands/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.core.commands/META-INF/MANIFEST.MF
index d9bf7d8..0c6e16d 100644
--- a/bundles/org.eclipse.e4.core.commands/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.core.commands/META-INF/MANIFEST.MF
@@ -23,5 +23,5 @@ Export-Package: org.eclipse.e4.core.commands;
org.eclipse.ui.workbench,
org.eclipse.e4.ui.workbench.swt",
org.eclipse.e4.core.commands.internal;x-friends:="org.eclipse.e4.ui.bindings,org.eclipse.ui.workbench"
-Require-Bundle: org.eclipse.equinox.common;bundle-version="3.6.0",
+Require-Bundle: org.eclipse.equinox.common;bundle-version="[3.6.0,4.0.0)",
org.eclipse.e4.core.di;bundle-version="0.9.0"
diff --git a/bundles/org.eclipse.e4.core.contexts.debug/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.core.contexts.debug/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..486a796
--- /dev/null
+++ b/bundles/org.eclipse.e4.core.contexts.debug/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,35 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=0
+compilers.p.discouraged-class=1
+compilers.p.illegal-att-value=0
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=2
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=0
+compilers.p.unknown-attribute=0
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.p.unused-element-or-attribute=1
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+compilers.use-project=true
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.core.contexts.debug/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.core.contexts.debug/META-INF/MANIFEST.MF
index 6e294a9..da1aa7a 100644
--- a/bundles/org.eclipse.e4.core.contexts.debug/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.core.contexts.debug/META-INF/MANIFEST.MF
@@ -6,15 +6,15 @@ Bundle-Version: 0.1.0.qualifier
Bundle-Vendor: %providerName
Bundle-Activator: org.eclipse.e4.core.internal.contexts.debug.ui.Activator
Bundle-Localization: plugin
-Require-Bundle: org.eclipse.ui,
- org.eclipse.core.runtime,
+Require-Bundle: org.eclipse.ui;bundle-version="[3.102.0,4.0.0)",
+ org.eclipse.core.runtime;bundle-version="[3.8.0,4.0.0)",
org.eclipse.e4.core.contexts;bundle-version="0.9.0",
org.eclipse.e4.core.di;bundle-version="0.9.0",
org.eclipse.e4.core.di.extensions;bundle-version="0.9.0",
org.eclipse.e4.ui.workbench;bundle-version="0.9.1",
org.eclipse.e4.ui.di;bundle-version="0.9.0",
- org.eclipse.osgi.services;bundle-version="3.3.0",
- org.eclipse.e4.ui.workbench.swt
+ org.eclipse.osgi.services;bundle-version="[3.3.0,4.0.0)",
+ org.eclipse.e4.ui.workbench.swt;bundle-version="0.10.0"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Import-Package: javax.annotation;version="1.0.0",
diff --git a/bundles/org.eclipse.e4.core.contexts.debug/plugin.properties b/bundles/org.eclipse.e4.core.contexts.debug/plugin.properties
index 8c20b32..e4e9bdb 100644
--- a/bundles/org.eclipse.e4.core.contexts.debug/plugin.properties
+++ b/bundles/org.eclipse.e4.core.contexts.debug/plugin.properties
@@ -12,3 +12,5 @@
pluginName = Eclipse Context Trace and Debug
providerName = Eclipse.org
traceView = Contexts Trace and Debug
+
+extension.contextdebugmodel.name = Context Trace and Debug
diff --git a/bundles/org.eclipse.e4.core.contexts.debug/plugin.xml b/bundles/org.eclipse.e4.core.contexts.debug/plugin.xml
index d2e4b21..8038d71 100644
--- a/bundles/org.eclipse.e4.core.contexts.debug/plugin.xml
+++ b/bundles/org.eclipse.e4.core.contexts.debug/plugin.xml
@@ -3,7 +3,7 @@
<plugin>
<extension
id="ContextDebug"
- name="Context Trace and Debug"
+ name="%extension.contextdebugmodel.name"
point="org.eclipse.e4.workbench.model">
<processor
beforefragment="true"
diff --git a/bundles/org.eclipse.e4.ui.bindings/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.bindings/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.bindings/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.bindings/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.bindings/META-INF/MANIFEST.MF
index 787490c..a47f206 100644
--- a/bundles/org.eclipse.e4.ui.bindings/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.bindings/META-INF/MANIFEST.MF
@@ -20,10 +20,10 @@ Import-Package: javax.annotation;version="1.0.0",
org.eclipse.jface.dialogs,
org.eclipse.jface.window,
org.osgi.framework;version="1.5.0"
-Require-Bundle: org.eclipse.swt;bundle-version="3.6.0",
- org.eclipse.core.commands;bundle-version="3.5.0",
- org.eclipse.e4.core.contexts,
- org.eclipse.e4.core.di
+Require-Bundle: org.eclipse.swt;bundle-version="[3.6.0,4.0.0)",
+ org.eclipse.core.commands;bundle-version="[3.5.0,4.0.0)",
+ org.eclipse.e4.core.contexts;bundle-version="1.0.0",
+ org.eclipse.e4.core.di;bundle-version="1.1.0"
Export-Package: org.eclipse.e4.ui.bindings;
x-friends:="org.eclipse.e4.ui.workbench,
org.eclipse.e4.ui.workbench.renderers.swt,
diff --git a/bundles/org.eclipse.e4.ui.css.core/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.css.core/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.css.core/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.css.core/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.css.core/META-INF/MANIFEST.MF
index fdb479b..930136e 100644
--- a/bundles/org.eclipse.e4.ui.css.core/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.css.core/META-INF/MANIFEST.MF
@@ -34,6 +34,6 @@ Export-Package: org.eclipse.e4.ui.css.core;x-internal:=true,
org.eclipse.e4.ui.css.xml.properties.css2;x-friends:="org.eclipse.e4.ui.css.swt"
Require-Bundle: org.w3c.css.sac;bundle-version="1.3.0",
org.apache.batik.css;bundle-version="[1.6.0,1.7.0)",
- org.eclipse.equinox.common;bundle-version="3.5.0",
- org.eclipse.core.runtime;bundle-version="3.6.0"
+ org.eclipse.equinox.common;bundle-version="[3.5.0,4.0.0)",
+ org.eclipse.core.runtime;bundle-version="[3.6.0,4.0.0)"
Bundle-RequiredExecutionEnvironment: J2SE-1.5
diff --git a/bundles/org.eclipse.e4.ui.css.core/plugin.properties b/bundles/org.eclipse.e4.ui.css.core/plugin.properties
index 88d6fda..c3187d8 100644
--- a/bundles/org.eclipse.e4.ui.css.core/plugin.properties
+++ b/bundles/org.eclipse.e4.ui.css.core/plugin.properties
@@ -10,3 +10,5 @@
###############################################################################
pluginName = Eclipse CSS Core Support
providerName = Eclipse.org
+
+extension-point.elementprovider.name = element_provider \ No newline at end of file
diff --git a/bundles/org.eclipse.e4.ui.css.core/plugin.xml b/bundles/org.eclipse.e4.ui.css.core/plugin.xml
index 9dcedb9..666f9e0 100644
--- a/bundles/org.eclipse.e4.ui.css.core/plugin.xml
+++ b/bundles/org.eclipse.e4.ui.css.core/plugin.xml
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.4"?>
<plugin>
- <extension-point id="org.eclipse.e4.u.css.core.elementProvider" name="element_provider" schema="schema/org.eclipse.e4.u.css.core.elementProvider.exsd"/>
+ <extension-point id="org.eclipse.e4.u.css.core.elementProvider" name="%extension-point.elementprovider.name" schema="schema/org.eclipse.e4.u.css.core.elementProvider.exsd"/>
</plugin>
diff --git a/bundles/org.eclipse.e4.ui.css.swt.theme/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.css.swt.theme/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.css.swt.theme/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.css.swt.theme/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.css.swt.theme/META-INF/MANIFEST.MF
index af191ca..9c1af70 100644
--- a/bundles/org.eclipse.e4.ui.css.swt.theme/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.css.swt.theme/META-INF/MANIFEST.MF
@@ -6,13 +6,13 @@ Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.swt;bundle-version="3.6.0",
+Require-Bundle: org.eclipse.swt;bundle-version="[3.6.0,4.0.0)",
org.eclipse.e4.ui.css.swt;bundle-version="0.9.1",
org.eclipse.e4.ui.css.core;bundle-version="0.9.0",
- org.eclipse.equinox.common;bundle-version="3.6.0",
+ org.eclipse.equinox.common;bundle-version="[3.6.0,4.0.0)",
org.w3c.css.sac;bundle-version="1.3.0",
- org.eclipse.equinox.registry;bundle-version="3.5.0",
- org.eclipse.equinox.preferences;bundle-version="3.3.0"
+ org.eclipse.equinox.registry;bundle-version="[3.5.0,4.0.0)",
+ org.eclipse.equinox.preferences;bundle-version="[3.3.0,4.0.0)"
Service-Component: OSGI-INF/thememanager.xml
Bundle-ActivationPolicy: lazy
Export-Package: org.eclipse.e4.ui.css.swt.internal.theme;x-internal:=true,
diff --git a/bundles/org.eclipse.e4.ui.css.swt.theme/plugin.properties b/bundles/org.eclipse.e4.ui.css.swt.theme/plugin.properties
index 52c55ff..ed7d7dd 100644
--- a/bundles/org.eclipse.e4.ui.css.swt.theme/plugin.properties
+++ b/bundles/org.eclipse.e4.ui.css.swt.theme/plugin.properties
@@ -1,5 +1,5 @@
###############################################################################
-# Copyright (c) 2010 IBM Corporation and others.
+# Copyright (c) 2010, 2012 IBM Corporation and others.
# All rights reserved. This program and the accompanying materials
# are made available under the terms of the Eclipse Public License v1.0
# which accompanies this distribution, and is available at
@@ -10,3 +10,5 @@
###############################################################################
pluginName = Eclipse CSS SWT Theme Support
providerName = Eclipse.org
+
+extension-point.themes.name = Themes \ No newline at end of file
diff --git a/bundles/org.eclipse.e4.ui.css.swt.theme/plugin.xml b/bundles/org.eclipse.e4.ui.css.swt.theme/plugin.xml
index d2be86e..2d59e3c 100644
--- a/bundles/org.eclipse.e4.ui.css.swt.theme/plugin.xml
+++ b/bundles/org.eclipse.e4.ui.css.swt.theme/plugin.xml
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.4"?>
<plugin>
- <extension-point id="org.eclipse.e4.ui.css.swt.theme" name="Themes" schema="schema/org.eclipse.e4.ui.css.swt.theme.exsd"/>
+ <extension-point id="org.eclipse.e4.ui.css.swt.theme" name="%extension-point.themes.name" schema="schema/org.eclipse.e4.ui.css.swt.theme.exsd"/>
</plugin>
diff --git a/bundles/org.eclipse.e4.ui.css.swt/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.css.swt/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.css.swt/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.css.swt/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.css.swt/META-INF/MANIFEST.MF
index 34422c6..0315dcf 100644
--- a/bundles/org.eclipse.e4.ui.css.swt/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.css.swt/META-INF/MANIFEST.MF
@@ -19,12 +19,12 @@ Export-Package: org.eclipse.e4.ui.css.swt;x-internal:=true,
org.eclipse.e4.ui.css.swt.serializers;x-internal:=true,
org.eclipse.e4.ui.internal.css.swt;x-internal:=true
Require-Bundle: org.eclipse.e4.ui.css.core;bundle-version="0.9.0",
- org.eclipse.swt;bundle-version="3.4.1",
+ org.eclipse.swt;bundle-version="[3.4.1,4.0.0)",
org.w3c.css.sac;bundle-version="1.3.0",
- org.eclipse.e4.core.contexts,
- org.eclipse.e4.core.di,
+ org.eclipse.e4.core.contexts;bundle-version="1.0.0",
+ org.eclipse.e4.core.di;bundle-version="1.1.0",
org.eclipse.e4.core.services;bundle-version="0.9.1",
- org.eclipse.core.runtime;bundle-version="3.6.0",
+ org.eclipse.core.runtime;bundle-version="[3.6.0,4.0.0)",
org.eclipse.e4.ui.widgets;bundle-version="0.11.0"
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-Activator: org.eclipse.e4.ui.internal.css.swt.CSSActivator
diff --git a/bundles/org.eclipse.e4.ui.css.swt/plugin.properties b/bundles/org.eclipse.e4.ui.css.swt/plugin.properties
index 3cb1d92..061714e 100644
--- a/bundles/org.eclipse.e4.ui.css.swt/plugin.properties
+++ b/bundles/org.eclipse.e4.ui.css.swt/plugin.properties
@@ -1,5 +1,5 @@
###############################################################################
-# Copyright (c) 2010 IBM Corporation and others.
+# Copyright (c) 2010, 2012 IBM Corporation and others.
# All rights reserved. This program and the accompanying materials
# are made available under the terms of the Eclipse Public License v1.0
# which accompanies this distribution, and is available at
@@ -10,3 +10,5 @@
###############################################################################
pluginName = Eclipse CSS SWT Support
providerName = Eclipse.org
+
+extension-point.properties.name = Properties \ No newline at end of file
diff --git a/bundles/org.eclipse.e4.ui.css.swt/plugin.xml b/bundles/org.eclipse.e4.ui.css.swt/plugin.xml
index 0c90c31..786e12c 100644
--- a/bundles/org.eclipse.e4.ui.css.swt/plugin.xml
+++ b/bundles/org.eclipse.e4.ui.css.swt/plugin.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.4"?>
<plugin>
- <extension-point id="org.eclipse.e4.ui.css.swt.property.handler" name="Properties" schema="schema/org.eclipse.e4.ui.css.swt.property.handler.exsd"/>
+ <extension-point id="org.eclipse.e4.ui.css.swt.property.handler" name="%extension-point.properties.name" schema="schema/org.eclipse.e4.ui.css.swt.property.handler.exsd"/>
<extension
point="org.eclipse.e4.u.css.core.elementProvider">
<provider
diff --git a/bundles/org.eclipse.e4.ui.di/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.di/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.di/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.di/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.di/META-INF/MANIFEST.MF
index cdad615..3600c64 100644
--- a/bundles/org.eclipse.e4.ui.di/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.di/META-INF/MANIFEST.MF
@@ -12,5 +12,5 @@ Export-Package: org.eclipse.e4.ui.di;x-friends:="org.eclipse.e4.ui.workbench,org
org.eclipse.e4.ui.internal.di;x-internal:=true
Require-Bundle: org.eclipse.e4.core.di;bundle-version="0.9.0",
org.eclipse.e4.core.di.extensions;bundle-version="0.9.0",
- org.eclipse.osgi.services;bundle-version="3.2.100"
+ org.eclipse.osgi.services;bundle-version="[3.2.100,4.0.0)"
Service-Component: OSGI-INF/eventsui.xml
diff --git a/bundles/org.eclipse.e4.ui.model.workbench.edit/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.model.workbench.edit/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.model.workbench.edit/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.model.workbench.edit/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.model.workbench.edit/META-INF/MANIFEST.MF
index f77cf13..ef425f5 100644
--- a/bundles/org.eclipse.e4.ui.model.workbench.edit/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.model.workbench.edit/META-INF/MANIFEST.MF
@@ -15,10 +15,10 @@ Export-Package: org.eclipse.e4.ui.model.application.commands.provider,
org.eclipse.e4.ui.model.application.ui.basic.provider,
org.eclipse.e4.ui.model.application.ui.menu.provider,
org.eclipse.e4.ui.model.application.ui.provider
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.e4.ui.model.workbench;visibility:=reexport,
- org.eclipse.emf.edit;visibility:=reexport,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.7.0,4.0.0)",
+ org.eclipse.e4.ui.model.workbench;bundle-version="0.10.0";visibility:=reexport,
+ org.eclipse.emf.edit;bundle-version="[2.6.0,3.0.0)";visibility:=reexport,
org.eclipse.e4.core.services;bundle-version="0.9.1",
- org.eclipse.e4.core.contexts,
- org.eclipse.e4.core.di
+ org.eclipse.e4.core.contexts;bundle-version="1.0.0",
+ org.eclipse.e4.core.di;bundle-version="1.1.0"
Bundle-ActivationPolicy: lazy
diff --git a/bundles/org.eclipse.e4.ui.model.workbench/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.model.workbench/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.model.workbench/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.model.workbench/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.model.workbench/META-INF/MANIFEST.MF
index 75983cb..05d6bc3 100644
--- a/bundles/org.eclipse.e4.ui.model.workbench/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.model.workbench/META-INF/MANIFEST.MF
@@ -89,11 +89,11 @@ Export-Package: org.eclipse.e4.ui.model;x-friends:="org.eclipse.e4.ui.workbench,
org.eclipse.e4.ui.model.fragment.impl;x-friends:="org.eclipse.e4.ui.workbench",
org.eclipse.e4.ui.model.fragment.util;x-internal:=true,
org.eclipse.e4.ui.model.internal;x-friends:="org.eclipse.e4.ui.workbench"
-Require-Bundle: org.eclipse.core.runtime,
- org.eclipse.emf.ecore;visibility:=reexport,
- org.eclipse.emf.ecore.xmi;visibility:=reexport,
+Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.7.0,4.0.0)",
+ org.eclipse.emf.ecore;bundle-version="[2.6.0,3.0.0)";visibility:=reexport,
+ org.eclipse.emf.ecore.xmi;bundle-version="[2.6.0,3.0.0)";visibility:=reexport,
org.eclipse.e4.core.services;bundle-version="0.9.0",
- org.eclipse.e4.core.contexts,
- org.eclipse.core.commands;bundle-version="3.5.0",
- org.eclipse.e4.core.di
+ org.eclipse.e4.core.contexts;bundle-version="1.0.0",
+ org.eclipse.core.commands;bundle-version="[3.5.0,4.0.0)",
+ org.eclipse.e4.core.di;bundle-version="1.0.0"
Bundle-ActivationPolicy: lazy
diff --git a/bundles/org.eclipse.e4.ui.model.workbench/plugin.xml b/bundles/org.eclipse.e4.ui.model.workbench/plugin.xml
index ae6c94b..13382c9 100644
--- a/bundles/org.eclipse.e4.ui.model.workbench/plugin.xml
+++ b/bundles/org.eclipse.e4.ui.model.workbench/plugin.xml
@@ -2,7 +2,7 @@
<?eclipse version="3.0"?>
<!--
- Copyright (c) 2008 IBM Corporation and others.
+ Copyright (c) 2008, 2012 IBM Corporation and others.
All rights reserved. This program and the accompanying materials
are made available under the terms of the Eclipse Public License v1.0
which accompanies this distribution, and is available at
diff --git a/bundles/org.eclipse.e4.ui.services/.settings/org.eclipse.pde.core.prefs b/bundles/org.eclipse.e4.ui.services/.settings/org.eclipse.pde.core.prefs
deleted file mode 100644
index d237e73..0000000
--- a/bundles/org.eclipse.e4.ui.services/.settings/org.eclipse.pde.core.prefs
+++ /dev/null
@@ -1,4 +0,0 @@
-#Thu Jul 24 16:23:03 EDT 2008
-eclipse.preferences.version=1
-pluginProject.extensions=true
-resolve.requirebundle=false
diff --git a/bundles/org.eclipse.e4.ui.services/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.services/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.services/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.services/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.services/META-INF/MANIFEST.MF
index f54dbd1..0c0d67f 100644
--- a/bundles/org.eclipse.e4.ui.services/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.services/META-INF/MANIFEST.MF
@@ -11,9 +11,9 @@ Import-Package: javax.annotation;version="1.0.0",
javax.inject;version="1.0.0",
org.osgi.framework;version="1.3.0",
org.osgi.service.event;resolution:=optional
-Require-Bundle: org.eclipse.core.commands;bundle-version="3.4.0",
+Require-Bundle: org.eclipse.core.commands;bundle-version="[3.4.0,4.0.0)",
org.eclipse.e4.core.services;bundle-version="0.9.0",
- org.eclipse.osgi;bundle-version="3.6.0",
+ org.eclipse.osgi;bundle-version="[3.6.0,4.0.0)",
org.eclipse.e4.core.contexts;bundle-version="0.9.0",
org.eclipse.e4.core.di;bundle-version="0.9.0",
org.eclipse.e4.ui.di;bundle-version="0.9.0"
diff --git a/bundles/org.eclipse.e4.ui.widgets/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.widgets/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.widgets/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.widgets/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.widgets/META-INF/MANIFEST.MF
index b875336..7f40327 100644
--- a/bundles/org.eclipse.e4.ui.widgets/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.widgets/META-INF/MANIFEST.MF
@@ -7,4 +7,4 @@ Bundle-SymbolicName: org.eclipse.e4.ui.widgets
Bundle-Version: 0.11.0.qualifier
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Export-Package: org.eclipse.e4.ui.widgets
-Require-Bundle: org.eclipse.swt;bundle-version="3.6.0"
+Require-Bundle: org.eclipse.swt;bundle-version="[3.6.0,4.0.0)"
diff --git a/bundles/org.eclipse.e4.ui.workbench.addons.swt/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.workbench.addons.swt/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.workbench.addons.swt/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.workbench.addons.swt/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.workbench.addons.swt/META-INF/MANIFEST.MF
index 406936d..0e149f8 100644
--- a/bundles/org.eclipse.e4.ui.workbench.addons.swt/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.workbench.addons.swt/META-INF/MANIFEST.MF
@@ -10,14 +10,14 @@ Require-Bundle: org.eclipse.e4.ui.model.workbench;bundle-version="0.9.1",
org.eclipse.e4.core.di;bundle-version="0.9.0",
org.eclipse.e4.ui.workbench;bundle-version="0.9.1",
org.eclipse.e4.core.services;bundle-version="0.9.1",
- org.eclipse.osgi.services;bundle-version="3.2.100",
+ org.eclipse.osgi.services;bundle-version="[3.2.100,4.0.0)",
org.eclipse.e4.ui.workbench.renderers.swt;bundle-version="0.9.1",
org.eclipse.e4.ui.widgets;bundle-version="0.11.0",
org.eclipse.e4.ui.css.swt;bundle-version="0.9.1",
org.eclipse.e4.ui.css.core;bundle-version="0.9.0",
- org.eclipse.swt;bundle-version="3.7.0",
- org.eclipse.jface;bundle-version="3.7.0",
- org.eclipse.core.runtime;bundle-version="3.7.0"
+ org.eclipse.swt;bundle-version="[3.7.0,4.0.0)",
+ org.eclipse.jface;bundle-version="[3.7.0,4.0.0)",
+ org.eclipse.core.runtime;bundle-version="[3.7.0,4.0.0)"
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-ActivationPolicy: lazy
Import-Package: javax.annotation;version="1.0.0",
diff --git a/bundles/org.eclipse.e4.ui.workbench.addons.swt/plugin.properties b/bundles/org.eclipse.e4.ui.workbench.addons.swt/plugin.properties
index 1fe85a7..bb42176 100644
--- a/bundles/org.eclipse.e4.ui.workbench.addons.swt/plugin.properties
+++ b/bundles/org.eclipse.e4.ui.workbench.addons.swt/plugin.properties
@@ -10,3 +10,5 @@
###############################################################################
pluginName = Eclipse e4 Workbench Add-ons
providerName = Eclipse.org
+
+extension.addonsnippet.name = Addon Snippet \ No newline at end of file
diff --git a/bundles/org.eclipse.e4.ui.workbench.addons.swt/plugin.xml b/bundles/org.eclipse.e4.ui.workbench.addons.swt/plugin.xml
index 4c4d2ac..d1340c6 100644
--- a/bundles/org.eclipse.e4.ui.workbench.addons.swt/plugin.xml
+++ b/bundles/org.eclipse.e4.ui.workbench.addons.swt/plugin.xml
@@ -3,7 +3,7 @@
<plugin>
<extension
id="AddonSnippet"
- name="Addon Snippet"
+ name="%extension.addonsnippet.name"
point="org.eclipse.e4.workbench.model">
<processor
beforefragment="true"
diff --git a/bundles/org.eclipse.e4.ui.workbench.renderers.swt/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.workbench.renderers.swt/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.workbench.renderers.swt/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.workbench.renderers.swt/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.workbench.renderers.swt/META-INF/MANIFEST.MF
index c70cac6..017ad99 100644
--- a/bundles/org.eclipse.e4.ui.workbench.renderers.swt/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.workbench.renderers.swt/META-INF/MANIFEST.MF
@@ -8,22 +8,22 @@ Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.e4.ui.workbench;bundle-version="0.9.0",
org.eclipse.e4.core.services;bundle-version="0.9.0",
- org.eclipse.e4.core.contexts,
- org.eclipse.e4.core.di,
+ org.eclipse.e4.core.contexts;bundle-version="1.0.0",
+ org.eclipse.e4.core.di;bundle-version="1.1.0",
org.eclipse.e4.ui.services;bundle-version="0.9.0",
org.eclipse.e4.ui.widgets;bundle-version="0.11.0",
- org.eclipse.swt;bundle-version="3.5.0",
- org.eclipse.jface;bundle-version="3.5.0",
+ org.eclipse.swt;bundle-version="[3.5.0,4.0.0)",
+ org.eclipse.jface;bundle-version="[3.5.0,4.0.0)",
org.eclipse.e4.ui.workbench.swt;bundle-version="0.9.0",
org.eclipse.e4.ui.model.workbench;bundle-version="0.9.0",
- org.eclipse.osgi.services;bundle-version="3.2.0",
+ org.eclipse.osgi.services;bundle-version="[3.2.0,4.0.0)",
org.eclipse.e4.core.commands;bundle-version="0.9.0",
org.eclipse.e4.ui.bindings;bundle-version="0.9.0",
- org.eclipse.equinox.common;bundle-version="3.6.0",
- org.eclipse.core.expressions;bundle-version="3.4.200",
+ org.eclipse.equinox.common;bundle-version="[3.6.0,4.0.0)",
+ org.eclipse.core.expressions;bundle-version="[3.4.200,4.0.0)",
org.eclipse.e4.ui.css.swt.theme;bundle-version="0.9.0",
org.eclipse.e4.ui.css.core;bundle-version="0.9.0",
- org.eclipse.osgi;bundle-version="3.6.0",
+ org.eclipse.osgi;bundle-version="[3.6.0,4.0.0)",
org.eclipse.e4.ui.di;bundle-version="0.9.0"
Export-Package: org.eclipse.e4.ui.internal.workbench.renderers.swt;x-internal:=true,
org.eclipse.e4.ui.workbench.renderers.swt;x-friends:="org.eclipse.e4.ui.workbench.addons.swt,org.eclipse.ui.workbench"
diff --git a/bundles/org.eclipse.e4.ui.workbench.swt/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.workbench.swt/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.workbench.swt/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.workbench.swt/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.workbench.swt/META-INF/MANIFEST.MF
index 924e169..62698aa 100644
--- a/bundles/org.eclipse.e4.ui.workbench.swt/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.workbench.swt/META-INF/MANIFEST.MF
@@ -6,27 +6,27 @@ Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-Activator: org.eclipse.e4.ui.internal.workbench.swt.WorkbenchSWTActivator
-Require-Bundle: org.eclipse.equinox.registry,
- org.eclipse.equinox.app,
- org.eclipse.e4.ui.workbench,
- org.eclipse.e4.core.services,
- org.eclipse.e4.ui.services,
- org.eclipse.jface;bundle-version="3.5.0",
- org.eclipse.core.databinding;bundle-version="1.2.0",
- org.eclipse.jface.databinding;bundle-version="1.3.0",
+Require-Bundle: org.eclipse.equinox.registry;bundle-version="[3.5.0,4.0.0)",
+ org.eclipse.equinox.app;bundle-version="[1.3.0,2.0.0)",
+ org.eclipse.e4.ui.workbench;bundle-version="0.10.0",
+ org.eclipse.e4.core.services;bundle-version="1.0.0",
+ org.eclipse.e4.ui.services;bundle-version="0.1.0",
+ org.eclipse.jface;bundle-version="[3.5.0,4.0.0)",
+ org.eclipse.core.databinding;bundle-version="[1.2.0,2.0.0)",
+ org.eclipse.jface.databinding;bundle-version="[1.3.0,2.0.0)",
org.eclipse.e4.ui.css.core;bundle-version="0.9.0",
org.eclipse.e4.ui.css.swt;bundle-version="0.9.0",
org.w3c.css.sac;bundle-version="1.3.0",
- org.eclipse.osgi.services;bundle-version="3.2.0",
+ org.eclipse.osgi.services;bundle-version="[3.2.0,4.0.0)",
org.eclipse.e4.ui.bindings;bundle-version="0.9.0",
- org.eclipse.e4.core.contexts,
+ org.eclipse.e4.core.contexts;bundle-version="1.0.0",
org.eclipse.e4.ui.workbench3;bundle-version="0.11.0",
- org.eclipse.core.jobs;bundle-version="3.5.0",
- org.eclipse.e4.core.di,
+ org.eclipse.core.jobs;bundle-version="[3.5.0,4.0.0)",
+ org.eclipse.e4.core.di;bundle-version="1.1.0",
org.eclipse.e4.ui.css.swt.theme;bundle-version="0.9.0",
- org.eclipse.core.expressions;bundle-version="3.4.200",
- org.eclipse.osgi;bundle-version="3.6.0",
- org.eclipse.core.runtime;bundle-version="3.6.0",
+ org.eclipse.core.expressions;bundle-version="[3.4.200,4.0.0)",
+ org.eclipse.osgi;bundle-version="[3.6.0,4.0.0)",
+ org.eclipse.core.runtime;bundle-version="[3.6.0,4.0.0)",
org.eclipse.e4.core.commands;bundle-version="0.9.0",
org.eclipse.e4.ui.widgets;bundle-version="0.11.0",
org.eclipse.e4.ui.di;bundle-version="0.9.0"
diff --git a/bundles/org.eclipse.e4.ui.workbench.swt/plugin.properties b/bundles/org.eclipse.e4.ui.workbench.swt/plugin.properties
index b138cbf..b4a7ba8 100644
--- a/bundles/org.eclipse.e4.ui.workbench.swt/plugin.properties
+++ b/bundles/org.eclipse.e4.ui.workbench.swt/plugin.properties
@@ -1,5 +1,5 @@
###############################################################################
-# Copyright (c) 2010 IBM Corporation and others.
+# Copyright (c) 2010, 2012 IBM Corporation and others.
# All rights reserved. This program and the accompanying materials
# are made available under the terms of the Eclipse Public License v1.0
# which accompanies this distribution, and is available at
@@ -10,3 +10,6 @@
###############################################################################
pluginName = Eclipse e4 Workbench SWT
providerName = Eclipse.org
+
+extension.e4application.name = E4 Application
+extension.generatetopic.name = Internal Model Topic Generator \ No newline at end of file
diff --git a/bundles/org.eclipse.e4.ui.workbench.swt/plugin.xml b/bundles/org.eclipse.e4.ui.workbench.swt/plugin.xml
index b4388c2..a179e5c 100644
--- a/bundles/org.eclipse.e4.ui.workbench.swt/plugin.xml
+++ b/bundles/org.eclipse.e4.ui.workbench.swt/plugin.xml
@@ -1,9 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.4"?>
+<!--
+ Copyright (c) 2012 IBM Corporation and others.
+ All rights reserved. This program and the accompanying materials
+ are made available under the terms of the Eclipse Public License v1.0
+ which accompanies this distribution, and is available at
+ http://www.eclipse.org/legal/epl-v10.html
+
+ Contributors:
+ IBM Corporation - initial API and implementation
+ -->
<plugin>
<extension
id="E4Application"
- name="E4 Application"
+ name="%extension.e4application.name"
point="org.eclipse.core.runtime.applications">
<application
cardinality="singleton-global"
@@ -16,7 +26,7 @@
</extension>
<extension
id="GenTopic"
- name="Internal Model Topic Generator"
+ name="%extension.generatetopic.name"
point="org.eclipse.core.runtime.applications">
<application
cardinality="singleton-global"
diff --git a/bundles/org.eclipse.e4.ui.workbench/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.workbench/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.workbench/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.workbench/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.workbench/META-INF/MANIFEST.MF
index 2fb5360..c5acfd0 100644
--- a/bundles/org.eclipse.e4.ui.workbench/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.workbench/META-INF/MANIFEST.MF
@@ -6,19 +6,19 @@ Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Require-Bundle: org.eclipse.e4.ui.model.workbench;bundle-version="0.9.0";visibility:=reexport,
- org.eclipse.equinox.common;bundle-version="3.4.0",
- org.eclipse.osgi;bundle-version="3.4.0",
+ org.eclipse.equinox.common;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.osgi;bundle-version="[3.4.0,4.0.0)",
org.eclipse.e4.ui.services;bundle-version="0.9.0",
- org.eclipse.equinox.registry;bundle-version="3.4.0",
+ org.eclipse.equinox.registry;bundle-version="[3.4.0,4.0.0)",
org.eclipse.e4.core.services;bundle-version="0.9.0",
- org.eclipse.e4.core.contexts,
- org.eclipse.e4.core.di,
+ org.eclipse.e4.core.contexts;bundle-version="1.0.0",
+ org.eclipse.e4.core.di;bundle-version="1.1.0",
org.eclipse.core.jobs;bundle-version="[3.4.0,4.0.0)",
- org.eclipse.core.commands;bundle-version="3.5.0",
- org.eclipse.osgi.services;bundle-version="3.2.0",
+ org.eclipse.core.commands;bundle-version="[3.5.0,4.0.0)",
+ org.eclipse.osgi.services;bundle-version="[3.2.0,4.0.0)",
org.eclipse.e4.core.commands;bundle-version="0.9.0",
org.eclipse.emf.ecore.change;bundle-version="2.5.0",
- org.eclipse.core.expressions;bundle-version="3.4.200",
+ org.eclipse.core.expressions;bundle-version="[3.4.200,4.0.0)",
org.eclipse.e4.ui.di;bundle-version="0.9.0"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.5
@@ -27,6 +27,7 @@ Export-Package: org.eclipse.e4.ui.internal.workbench;
org.eclipse.e4.ui.workbench.renderers.swt,
org.eclipse.e4.ui.workbench.swt,
org.eclipse.ui.workbench",
+ org.eclipse.e4.ui.internal.workbench.addons;x-internal:=true,
org.eclipse.e4.ui.internal.workbench.handlers;x-internal:=true,
org.eclipse.e4.ui.workbench;
x-friends:="org.eclipse.e4.ui.workbench.swt,
diff --git a/bundles/org.eclipse.e4.ui.workbench/plugin.properties b/bundles/org.eclipse.e4.ui.workbench/plugin.properties
index b046db3..ad95409 100644
--- a/bundles/org.eclipse.e4.ui.workbench/plugin.properties
+++ b/bundles/org.eclipse.e4.ui.workbench/plugin.properties
@@ -1,5 +1,5 @@
###############################################################################
-# Copyright (c) 2010 IBM Corporation and others.
+# Copyright (c) 2010, 2012 IBM Corporation and others.
# All rights reserved. This program and the accompanying materials
# are made available under the terms of the Eclipse Public License v1.0
# which accompanies this distribution, and is available at
@@ -10,3 +10,6 @@
###############################################################################
pluginName = Eclipse e4 Workbench
providerName = Eclipse.org
+
+content-type.e4.name = e4 XMI
+extension-point.name = Model extensions \ No newline at end of file
diff --git a/bundles/org.eclipse.e4.ui.workbench/plugin.xml b/bundles/org.eclipse.e4.ui.workbench/plugin.xml
index 8de9bda..6ad8365 100644
--- a/bundles/org.eclipse.e4.ui.workbench/plugin.xml
+++ b/bundles/org.eclipse.e4.ui.workbench/plugin.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.2"?>
<plugin>
- <extension-point id="org.eclipse.e4.workbench.model" name="Model extensions" schema="schema/org.eclipse.e4.workbench.model.exsd"/>
+ <extension-point id="org.eclipse.e4.workbench.model" name="%extension-point.model.name" schema="schema/org.eclipse.e4.workbench.model.exsd"/>
<extension
point="org.eclipse.core.runtime.adapters">
<factory
@@ -34,7 +34,7 @@
base-type="org.eclipse.core.runtime.xml"
file-extensions="e4xmi"
id="org.eclipse.e4.content-type"
- name="e4 XMI"
+ name="%content-type.e4.name"
priority="low">
</content-type>
</extension>
diff --git a/bundles/org.eclipse.e4.ui.workbench3/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.e4.ui.workbench3/.settings/org.eclipse.pde.prefs
new file mode 100644
index 0000000..2ce5047
--- /dev/null
+++ b/bundles/org.eclipse.e4.ui.workbench3/.settings/org.eclipse.pde.prefs
@@ -0,0 +1,32 @@
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
+compilers.p.deprecated=1
+compilers.p.discouraged-class=1
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=1
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=1
+compilers.p.unknown-attribute=1
+compilers.p.unknown-class=1
+compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
+compilers.p.unknown-resource=1
+compilers.p.unresolved-ex-points=0
+compilers.p.unresolved-import=0
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.e4.ui.workbench3/META-INF/MANIFEST.MF b/bundles/org.eclipse.e4.ui.workbench3/META-INF/MANIFEST.MF
index c72ebac..3dcbd12 100644
--- a/bundles/org.eclipse.e4.ui.workbench3/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.e4.ui.workbench3/META-INF/MANIFEST.MF
@@ -6,5 +6,5 @@ Bundle-Name: %pluginName
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Require-Bundle: org.eclipse.equinox.common;bundle-version="3.6.0"
+Require-Bundle: org.eclipse.equinox.common;bundle-version="[3.6.0,4.0.0)"
Export-Package: org.eclipse.ui.testing;x-friends:="org.eclipse.e4.ui.workbench.swt"
diff --git a/bundles/org.eclipse.ui.workbench/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.ui.workbench/.settings/org.eclipse.pde.prefs
index d8e8469..486a796 100644
--- a/bundles/org.eclipse.ui.workbench/.settings/org.eclipse.pde.prefs
+++ b/bundles/org.eclipse.ui.workbench/.settings/org.eclipse.pde.prefs
@@ -1,14 +1,35 @@
-#Tue Nov 16 14:12:29 EST 2004
-compilers.p.unused-element-or-attribute=1
-compilers.p.unresolved-ex-points=0
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
compilers.p.deprecated=0
+compilers.p.discouraged-class=1
+compilers.p.illegal-att-value=0
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=2
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=0
+compilers.p.unknown-attribute=0
+compilers.p.unknown-class=1
compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
compilers.p.unknown-resource=1
-compilers.p.unknown-class=1
-compilers.p.unknown-attribute=0
-compilers.p.no-required-att=0
-eclipse.preferences.version=1
+compilers.p.unresolved-ex-points=0
compilers.p.unresolved-import=0
-compilers.p.not-externalized-att=0
-compilers.p.illegal-att-value=0
+compilers.p.unused-element-or-attribute=1
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
compilers.use-project=true
+eclipse.preferences.version=1
diff --git a/bundles/org.eclipse.ui.workbench/META-INF/MANIFEST.MF b/bundles/org.eclipse.ui.workbench/META-INF/MANIFEST.MF
index d828a44..893cf3c 100644
--- a/bundles/org.eclipse.ui.workbench/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.ui.workbench/META-INF/MANIFEST.MF
@@ -95,9 +95,9 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.6.0,4.0.0)",
org.eclipse.jface.databinding;bundle-version="[1.3.0,2.0.0)",
org.eclipse.core.databinding.property;bundle-version="[1.2.0,2.0.0)",
org.eclipse.core.databinding.observable;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.e4.core.services,
- org.eclipse.e4.core.contexts,
- org.eclipse.e4.core.di,
+ org.eclipse.e4.core.services;bundle-version="1.0.0",
+ org.eclipse.e4.core.contexts;bundle-version="1.0.0",
+ org.eclipse.e4.core.di;bundle-version="1.1.0",
org.eclipse.e4.ui.workbench.swt;bundle-version="0.9.1",
org.eclipse.e4.ui.di;bundle-version="0.9.0",
org.eclipse.e4.ui.model.workbench;bundle-version="0.9.1",
diff --git a/bundles/org.eclipse.ui/.settings/org.eclipse.pde.prefs b/bundles/org.eclipse.ui/.settings/org.eclipse.pde.prefs
index 3544248..486a796 100644
--- a/bundles/org.eclipse.ui/.settings/org.eclipse.pde.prefs
+++ b/bundles/org.eclipse.ui/.settings/org.eclipse.pde.prefs
@@ -1,14 +1,35 @@
-#Tue Nov 16 14:10:37 EST 2004
-compilers.p.unused-element-or-attribute=1
-compilers.p.unresolved-ex-points=0
+compilers.f.unresolved-features=1
+compilers.f.unresolved-plugins=1
+compilers.incompatible-environment=1
+compilers.p.build=1
+compilers.p.build.bin.includes=1
+compilers.p.build.encodings=2
+compilers.p.build.java.compiler=2
+compilers.p.build.java.compliance=1
+compilers.p.build.missing.output=1
+compilers.p.build.output.library=1
+compilers.p.build.source.library=1
+compilers.p.build.src.includes=1
compilers.p.deprecated=0
+compilers.p.discouraged-class=1
+compilers.p.illegal-att-value=0
+compilers.p.internal=1
+compilers.p.missing-packages=1
+compilers.p.missing-version-export-package=2
+compilers.p.missing-version-import-package=2
+compilers.p.missing-version-require-bundle=1
+compilers.p.no-required-att=0
+compilers.p.not-externalized-att=0
+compilers.p.unknown-attribute=0
+compilers.p.unknown-class=1
compilers.p.unknown-element=1
+compilers.p.unknown-identifier=1
compilers.p.unknown-resource=1
-compilers.p.unknown-class=1
-compilers.p.unknown-attribute=0
-compilers.p.no-required-att=0
-eclipse.preferences.version=1
+compilers.p.unresolved-ex-points=0
compilers.p.unresolved-import=0
-compilers.p.not-externalized-att=0
-compilers.p.illegal-att-value=0
+compilers.p.unused-element-or-attribute=1
+compilers.s.create-docs=false
+compilers.s.doc-folder=doc
+compilers.s.open-tags=1
compilers.use-project=true
+eclipse.preferences.version=1