Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kurtakov2019-02-13 07:45:25 -0500
committerAlexander Kurtakov2019-02-13 08:06:44 -0500
commitd4aa0100abd68b27bb6f7334e48330f73c2ecb91 (patch)
treee842c7c5f7bffd1d268a5d0460b483ae9bde46a6
parent4466a92c1607ffafb97f447841920ac62148ce12 (diff)
downloadeclipse.platform.team-I20190214-1800.tar.gz
eclipse.platform.team-I20190214-1800.tar.xz
eclipse.platform.team-I20190214-1800.zip
Remove unused problem filters.Y20190213-2200I20190214-1800I20190213-1800
-rw-r--r--bundles/org.eclipse.compare.win32/.settings/.api_filters11
-rw-r--r--bundles/org.eclipse.compare.win32/META-INF/MANIFEST.MF2
-rw-r--r--bundles/org.eclipse.compare.win32/pom.xml2
-rw-r--r--bundles/org.eclipse.compare/.settings/.api_filters29
-rw-r--r--bundles/org.eclipse.team.core/.settings/.api_filters10
5 files changed, 2 insertions, 52 deletions
diff --git a/bundles/org.eclipse.compare.win32/.settings/.api_filters b/bundles/org.eclipse.compare.win32/.settings/.api_filters
deleted file mode 100644
index a7559c04d..000000000
--- a/bundles/org.eclipse.compare.win32/.settings/.api_filters
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.compare.win32" version="2">
- <resource path="META-INF/MANIFEST.MF">
- <filter comment="Bug 516457: Many of plug-ins need a version increase" id="926941240">
- <message_arguments>
- <message_argument value="1.2.0"/>
- <message_argument value="1.1.0"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/bundles/org.eclipse.compare.win32/META-INF/MANIFEST.MF b/bundles/org.eclipse.compare.win32/META-INF/MANIFEST.MF
index 4a5be8189..124efe42c 100644
--- a/bundles/org.eclipse.compare.win32/META-INF/MANIFEST.MF
+++ b/bundles/org.eclipse.compare.win32/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.compare.win32;singleton:=true
-Bundle-Version: 1.2.300.qualifier
+Bundle-Version: 1.2.400.qualifier
Bundle-Vendor: %providerName
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Eclipse-PlatformFilter: (osgi.os=win32)
diff --git a/bundles/org.eclipse.compare.win32/pom.xml b/bundles/org.eclipse.compare.win32/pom.xml
index 59e3f7fef..5de9fc2ea 100644
--- a/bundles/org.eclipse.compare.win32/pom.xml
+++ b/bundles/org.eclipse.compare.win32/pom.xml
@@ -19,7 +19,7 @@
</parent>
<groupId>org.eclipse.compare</groupId>
<artifactId>org.eclipse.compare.win32</artifactId>
- <version>1.2.300-SNAPSHOT</version>
+ <version>1.2.400-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<build>
diff --git a/bundles/org.eclipse.compare/.settings/.api_filters b/bundles/org.eclipse.compare/.settings/.api_filters
deleted file mode 100644
index be062b169..000000000
--- a/bundles/org.eclipse.compare/.settings/.api_filters
+++ /dev/null
@@ -1,29 +0,0 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<component id="org.eclipse.compare" version="2">
- <resource path="compare/org/eclipse/compare/ICompareFilter.java" type="org.eclipse.compare.ICompareFilter">
- <filter comment="Workaround for bug 411257: .api_description files in Kepler release do not contain @noreference restrictions" id="406052990">
- <message_arguments>
- <message_argument value="org.eclipse.compare.ICompareFilter"/>
- <message_argument value="canCacheFilteredRegions()"/>
- </message_arguments>
- </filter>
- <filter comment="Workaround for bug 411257: .api_description files in Kepler release do not contain @noreference restrictions" id="406052990">
- <message_arguments>
- <message_argument value="org.eclipse.compare.ICompareFilter"/>
- <message_argument value="getFilteredRegions(HashMap)"/>
- </message_arguments>
- </filter>
- <filter comment="Workaround for bug 411257: .api_description files in Kepler release do not contain @noreference restrictions" id="406052990">
- <message_arguments>
- <message_argument value="org.eclipse.compare.ICompareFilter"/>
- <message_argument value="isEnabledInitially()"/>
- </message_arguments>
- </filter>
- <filter comment="Workaround for bug 411257: .api_description files in Kepler release do not contain @noreference restrictions" id="406052990">
- <message_arguments>
- <message_argument value="org.eclipse.compare.ICompareFilter"/>
- <message_argument value="setInput(Object, Object, Object, Object)"/>
- </message_arguments>
- </filter>
- </resource>
-</component>
diff --git a/bundles/org.eclipse.team.core/.settings/.api_filters b/bundles/org.eclipse.team.core/.settings/.api_filters
deleted file mode 100644
index 2562537c8..000000000
--- a/bundles/org.eclipse.team.core/.settings/.api_filters
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?><component id="org.eclipse.team.core" version="2">
- <resource path="src/org/eclipse/team/core/Team.java" type="org.eclipse.team.core.Team">
- <filter id="338944126">
- <message_arguments>
- <message_argument value="org.eclipse.team.core.Team"/>
- <message_argument value="getBundleImporters()"/>
- </message_arguments>
- </filter>
- </resource>
-</component> \ No newline at end of file

Back to the top