Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikita Nemkin2019-05-26 04:27:02 -0400
committerAlexander Kurtakov2019-05-27 03:35:05 -0400
commitc83818c94bd287b439978f8e052d74aff37d37f8 (patch)
tree79071578305fe857d8b4ad3302423427ffa23570 /bundles/org.eclipse.swt/Eclipse SWT PI
parent8e642d710e087732cc0ec77807334c2e46afa004 (diff)
downloadeclipse.platform.swt-c83818c94bd287b439978f8e052d74aff37d37f8.tar.gz
eclipse.platform.swt-c83818c94bd287b439978f8e052d74aff37d37f8.tar.xz
eclipse.platform.swt-c83818c94bd287b439978f8e052d74aff37d37f8.zip
Bug 547672 - [GTK] Webkit extensions fail to build on Ubuntu
build.sh script requests posix shell (/bin/sh), but uses bash syntax extensions (== operator), which results in build failures and non-functional BrowserFunction implementation. Change-Id: If53732b7e59104c526d21bf9178c2520143dd529 Signed-off-by: Nikita Nemkin <nikita@nemkin.ru>
Diffstat (limited to 'bundles/org.eclipse.swt/Eclipse SWT PI')
-rwxr-xr-xbundles/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh14
1 files changed, 7 insertions, 7 deletions
diff --git a/bundles/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh b/bundles/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh
index 2d69ba69f7..f4b4f0229f 100755
--- a/bundles/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh
+++ b/bundles/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh
@@ -131,7 +131,7 @@ case $SWT_OS.$SWT_ARCH in
# java-1.8.0-openjdk-........i386
# java-9-openjdk....i386
JAVA_FOLDER=$(ls /usr/lib/jvm | grep java | grep -i openjdk | grep i386 | sort | tail -n 1)
- if [ "${JAVA_FOLDER}" == "" ]; then
+ if [ "${JAVA_FOLDER}" = "" ]; then
func_echo_error "ERROR: Could not find JAVA_HOME/AWT_LIB_PATH on 32bit build system automatically. Expecting it to be in /usr/lib/jvm/ but none was found. See also Bug 533496"
fi
@@ -190,7 +190,7 @@ case $SWT_OS.$SWT_ARCH in
export PKG_CONFIG_PATH="/usr/lib64/pkgconfig"
fi
;;
-esac
+esac
# For 64-bit CPUs, we have a switch
@@ -250,7 +250,7 @@ fi
## Interaction(s) with makefile(s) below:
-# Configure OUTPUT_DIR
+# Configure OUTPUT_DIR
if [ "x${OUTPUT_DIR}" = "x" ]; then
OUTPUT_DIR=../../../../../eclipse.platform.swt.binaries/bundles/org.eclipse.swt.gtk.${SWT_OS}.${SWT_ARCH}
if [ -d "$OUTPUT_DIR" ]; then
@@ -307,10 +307,10 @@ func_build_gtk4 () {
# Dictate Webkit2 Extension only if pkg-config flags exist
pkg-config --exists webkit2gtk-web-extension-4.0
- if [ $? == 0 ]; then
+ if [ $? = 0 ]; then
export BUILD_WEBKIT2EXTENSION="yes";
else
- func_echo_error "Warning: Cannot compile Webkit2 Extension because 'pkg-config --exists webkit2gtk-web-extension-4-0' check failed. Please install webkitgtk4-devel.ARCH on your system."
+ func_echo_error "Warning: Cannot compile Webkit2 Extension because 'pkg-config --exists webkit2gtk-web-extension-4.0' check failed. Please install webkitgtk4-devel.ARCH on your system."
fi
func_echo_plus "Building GTK4 bindings:"
@@ -329,10 +329,10 @@ func_build_gtk3 () {
# Dictate Webkit2 Extension only if pkg-config flags exist
pkg-config --exists webkit2gtk-web-extension-4.0
- if [ $? == 0 ]; then
+ if [ $? = 0 ]; then
export BUILD_WEBKIT2EXTENSION="yes";
else
- func_echo_error "Warning: Cannot compile Webkit2 Extension because 'pkg-config --exists webkit2gtk-web-extension-4-0' check failed. Please install webkitgtk4-devel.ARCH on your system."
+ func_echo_error "Warning: Cannot compile Webkit2 Extension because 'pkg-config --exists webkit2gtk-web-extension-4.0' check failed. Please install webkitgtk4-devel.ARCH on your system."
fi
func_echo_plus "Building GTK3 bindings:"

Back to the top