Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Keller2013-10-11 14:48:36 -0400
committerMarkus Keller2013-10-11 14:48:36 -0400
commite9eb9c7c2a1b74fe35fb593e4138c35bc7e4316e (patch)
treee6ba5f2274903285355c98021a0a334e394adf86
parent70a2f2c1c94e25b115c37690e0081e2501c12d38 (diff)
downloadeclipse.platform.swt-e9eb9c7c2a1b74fe35fb593e4138c35bc7e4316e.tar.gz
eclipse.platform.swt-e9eb9c7c2a1b74fe35fb593e4138c35bc7e4316e.tar.xz
eclipse.platform.swt-e9eb9c7c2a1b74fe35fb593e4138c35bc7e4316e.zip
try to solve raw type warnings for HashMap in LauncherPlugin in the buildv4409cI20131022-0800I20131015-0800
-rw-r--r--examples/org.eclipse.swt.examples.launcher/.classpath4
-rw-r--r--examples/org.eclipse.swt.examples.launcher/META-INF/MANIFEST.MF1
2 files changed, 3 insertions, 2 deletions
diff --git a/examples/org.eclipse.swt.examples.launcher/.classpath b/examples/org.eclipse.swt.examples.launcher/.classpath
index 065ac06e19..2fbb7a23e1 100644
--- a/examples/org.eclipse.swt.examples.launcher/.classpath
+++ b/examples/org.eclipse.swt.examples.launcher/.classpath
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<classpath>
- <classpathentry kind="src" path="src"/>
+ <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.4"/>
<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
- <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="src" path="src"/>
<classpathentry kind="output" path="bin"/>
</classpath>
diff --git a/examples/org.eclipse.swt.examples.launcher/META-INF/MANIFEST.MF b/examples/org.eclipse.swt.examples.launcher/META-INF/MANIFEST.MF
index 783f0f7c1e..4a36e9949a 100644
--- a/examples/org.eclipse.swt.examples.launcher/META-INF/MANIFEST.MF
+++ b/examples/org.eclipse.swt.examples.launcher/META-INF/MANIFEST.MF
@@ -20,3 +20,4 @@ Require-Bundle: org.eclipse.ui.ide,
org.eclipse.debug.core,
org.eclipse.jdt.core
Bundle-ActivationPolicy: lazy
+Bundle-RequiredExecutionEnvironment: J2SE-1.4

Back to the top