Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSilenio Quarti2013-08-13 11:11:16 -0400
committerSilenio Quarti2013-08-13 11:11:50 -0400
commit41fef8a0211614691b700109e324d643be4a5ce6 (patch)
tree46bf16a6fca291295a1f3485b97030191777f8ff
parent74ac3427ca8e2fdfddd4bb196918e6e96381898a (diff)
downloadeclipse.platform.swt-41fef8a0211614691b700109e324d643be4a5ce6.tar.gz
eclipse.platform.swt-41fef8a0211614691b700109e324d643be4a5ce6.tar.xz
eclipse.platform.swt-41fef8a0211614691b700109e324d643be4a5ce6.zip
revert changes for Bug 361901 - p2 metadata of org.eclipse.swt is incompletev4404bI20130813-1330I20130813-1200
-rw-r--r--bundles/org.eclipse.swt/META-INF/p2.inf83
-rw-r--r--pom.xml17
2 files changed, 1 insertions, 99 deletions
diff --git a/bundles/org.eclipse.swt/META-INF/p2.inf b/bundles/org.eclipse.swt/META-INF/p2.inf
index 89f93448e9..5730e8a1f0 100644
--- a/bundles/org.eclipse.swt/META-INF/p2.inf
+++ b/bundles/org.eclipse.swt/META-INF/p2.inf
@@ -8,85 +8,4 @@ requires.2.namespace=java.package
requires.2.name=org.eclipse.swt.accessibility2
requires.2.optional=true
requires.2.greedy=false
-requires.2.range=0.0.0
-
-# ensure that the applicable implementation fragment gets installed (bug 361901)
-requires.3.namespace = org.eclipse.equinox.p2.iu
-requires.3.name = org.eclipse.swt.win32.win32.x86
-requires.3.range = [$version$,$version$]
-requires.3.filter = (&(osgi.os=win32)(osgi.ws=win32)(osgi.arch=x86)(!(org.eclipse.swt.buildtime=true)))
-
-requires.4.namespace = org.eclipse.equinox.p2.iu
-requires.4.name = org.eclipse.swt.win32.win32.x86_64
-requires.4.range = [$version$,$version$]
-requires.4.filter = (&(osgi.os=win32)(osgi.ws=win32)(osgi.arch=x86_64)(!(org.eclipse.swt.buildtime=true)))
-
-requires.5.namespace = org.eclipse.equinox.p2.iu
-requires.5.name = org.eclipse.swt.gtk.linux.x86
-requires.5.range = [$version$,$version$]
-requires.5.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=x86)(!(org.eclipse.swt.buildtime=true)))
-
-requires.6.namespace = org.eclipse.equinox.p2.iu
-requires.6.name = org.eclipse.swt.gtk.linux.s390x
-requires.6.range = [$version$,$version$]
-requires.6.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=s390x)(!(org.eclipse.swt.buildtime=true)))
-
-requires.7.namespace = org.eclipse.equinox.p2.iu
-requires.7.name = org.eclipse.swt.gtk.linux.s390
-requires.7.range = [$version$,$version$]
-requires.7.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=s390)(!(org.eclipse.swt.buildtime=true)))
-
-requires.8.namespace = org.eclipse.equinox.p2.iu
-requires.8.name = org.eclipse.swt.gtk.solaris.sparc
-requires.8.range = [$version$,$version$]
-requires.8.filter = (&(osgi.os=solaris)(osgi.ws=gtk)(osgi.arch=sparc)(!(org.eclipse.swt.buildtime=true)))
-
-requires.9.namespace = org.eclipse.equinox.p2.iu
-requires.9.name = org.eclipse.swt.gtk.solaris.x86
-requires.9.range = [$version$,$version$]
-requires.9.filter = (&(osgi.os=solaris)(osgi.ws=gtk)(osgi.arch=x86)(!(org.eclipse.swt.buildtime=true)))
-
-requires.10.namespace = org.eclipse.equinox.p2.iu
-requires.10.name = org.eclipse.swt.gtk.linux.ppc
-requires.10.range = [$version$,$version$]
-requires.10.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=ppc)(!(org.eclipse.swt.buildtime=true)))
-
-requires.11.namespace = org.eclipse.equinox.p2.iu
-requires.11.name = org.eclipse.swt.gtk.linux.ppc64
-requires.11.range = [$version$,$version$]
-requires.11.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=ppc64)(!(org.eclipse.swt.buildtime=true)))
-
-requires.12.namespace = org.eclipse.equinox.p2.iu
-requires.12.name = org.eclipse.swt.gtk.linux.x86_64
-requires.12.range = [$version$,$version$]
-requires.12.filter = (&(osgi.os=linux)(osgi.ws=gtk)(osgi.arch=x86_64)(!(org.eclipse.swt.buildtime=true)))
-
-requires.13.namespace = org.eclipse.equinox.p2.iu
-requires.13.name = org.eclipse.swt.cocoa.macosx
-requires.13.range = [$version$,$version$]
-requires.13.filter = (&(osgi.os=macosx)(osgi.ws=cocoa)(osgi.arch=ppc)(!(org.eclipse.swt.buildtime=true)))
-
-requires.14.namespace = org.eclipse.equinox.p2.iu
-requires.14.name = org.eclipse.swt.cocoa.macosx
-requires.14.range = [$version$,$version$]
-requires.14.filter = (&(osgi.os=macosx)(osgi.ws=cocoa)(osgi.arch=x86)(!(org.eclipse.swt.buildtime=true)))
-
-requires.15.namespace = org.eclipse.equinox.p2.iu
-requires.15.name = org.eclipse.swt.cocoa.macosx.x86_64
-requires.15.range = [$version$,$version$]
-requires.15.filter = (&(osgi.os=macosx)(osgi.ws=cocoa)(osgi.arch=x86_64)(!(org.eclipse.swt.buildtime=true)))
-
-requires.16.namespace = org.eclipse.equinox.p2.iu
-requires.16.name = org.eclipse.swt.gtk.aix.ppc
-requires.16.range = [$version$,$version$]
-requires.16.filter = (&(osgi.os=aix)(osgi.ws=gtk)(osgi.arch=ppc)(!(org.eclipse.swt.buildtime=true)))
-
-requires.17.namespace = org.eclipse.equinox.p2.iu
-requires.17.name = org.eclipse.swt.gtk.aix.ppc64
-requires.17.range = [$version$,$version$]
-requires.17.filter = (&(osgi.os=aix)(osgi.ws=gtk)(osgi.arch=ppc64)(!(org.eclipse.swt.buildtime=true)))
-
-requires.18.namespace = org.eclipse.equinox.p2.iu
-requires.18.name = org.eclipse.swt.gtk.hpux.ia64
-requires.18.range = [$version$,$version$]
-requires.18.filter = (&(osgi.os=hpux)(osgi.ws=gtk)(osgi.arch=ia64)(!(org.eclipse.swt.buildtime=true)))
+requires.2.range=0.0.0 \ No newline at end of file
diff --git a/pom.xml b/pom.xml
index d55f6068bf..8d2925e058 100644
--- a/pom.xml
+++ b/pom.xml
@@ -41,23 +41,6 @@
</repository>
</repositories>
- <build>
- <plugins>
- <plugin>
- <groupId>org.eclipse.tycho</groupId>
- <artifactId>target-platform-configuration</artifactId>
- <version>${tycho.version}</version>
- <configuration>
- <dependency-resolution>
- <profileProperties>
- <profileProperty>org.eclipse.swt.buildtime=true</profileProperty>
- </profileProperties>
- </dependency-resolution>
- </configuration>
- </plugin>
- </plugins>
- </build>
-
<modules>
<module>bundles/org.eclipse.swt</module>
<module>bundles/org.eclipse.swt.opengl</module>

Back to the top