aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Sievers2013-03-05 10:06:36 (EST)
committerThanh Ha2013-03-06 10:23:25 (EST)
commit5d724baf041f535d61d4ac241ac2663cca840eaa (patch)
tree6310001d732e2defe1bab9534498d30c8dabf9f2
parent80deea9de02bda5961d96ebc68414701b49ddd4c (diff)
downloadeclipse.platform.releng.aggregator-5d724baf041f535d61d4ac241ac2663cca840eaa.zip
eclipse.platform.releng.aggregator-5d724baf041f535d61d4ac241ac2663cca840eaa.tar.gz
eclipse.platform.releng.aggregator-5d724baf041f535d61d4ac241ac2663cca840eaa.tar.bz2
381057 Fix api description generation
- use cbi mvan plugin 1.0.1-SNAPSHOT which includes required fixes - use generated .apibuild.xml from target/ folder - include generated .api_description file from target/ folder into outer bundle jar via additionalFileSets (see bug 402095)
-rw-r--r--eclipse-platform-parent/pom.xml23
1 files changed, 21 insertions, 2 deletions
diff --git a/eclipse-platform-parent/pom.xml b/eclipse-platform-parent/pom.xml
index 7e3917f..34ecdab 100644
--- a/eclipse-platform-parent/pom.xml
+++ b/eclipse-platform-parent/pom.xml
@@ -33,6 +33,7 @@
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<cbi-jdt-repo.url>https://repo.eclipse.org/content/repositories/eclipse-staging/</cbi-jdt-repo.url>
<cbi-jdt-version>3.9.0.v20130129-050623</cbi-jdt-version>
+ <cbi-snapshots-repo.url>https://repo.eclipse.org/content/repositories/cbi-snapshots/</cbi-snapshots-repo.url>
<eclipse-repo.url>https://repo.eclipse.org/content/repositories/releases/</eclipse-repo.url>
<eclipse-p2-repo.url>http://download.eclipse.org/eclipse/updates/4.3-I-builds</eclipse-p2-repo.url>
</properties>
@@ -104,6 +105,16 @@
<enabled>true</enabled>
</snapshots>
</pluginRepository>
+ <pluginRepository>
+ <id>cbi-snapshots</id>
+ <url>${cbi-snapshots-repo.url}</url>
+ <releases>
+ <enabled>false</enabled>
+ </releases>
+ <snapshots>
+ <enabled>true</enabled>
+ </snapshots>
+ </pluginRepository>
</pluginRepositories>
<build>
<plugins>
@@ -116,7 +127,7 @@
<plugin>
<groupId>org.eclipse.cbi.maven.plugins</groupId>
<artifactId>eclipse-cbi-plugin</artifactId>
- <version>1.0.0</version>
+ <version>1.0.1-SNAPSHOT</version>
<executions>
<execution>
<goals>
@@ -284,6 +295,14 @@
<archive>
<addMavenDescriptor>false</addMavenDescriptor>
</archive>
+ <additionalFileSets>
+ <fileSet>
+ <directory>${project.build.directory}</directory>
+ <includes>
+ <include>.api_description</include>
+ </includes>
+ </fileSet>
+ </additionalFileSets>
</configuration>
</plugin>
<plugin>
@@ -565,7 +584,7 @@
<!-- this is to fix some lucene 3.x compatibility issue -->
<argLine>-XX:-UseLoopPredicate -Dhelp.lucene.tokenizer=standard</argLine>
<!-- actuall indexer call -->
- <appArgLine>-application org.eclipse.ant.core.antRunner -buildfile .apibuild.xml</appArgLine>
+ <appArgLine>-application org.eclipse.ant.core.antRunner -buildfile target/.apibuild.xml</appArgLine>
<dependencies>
<!-- list of bundles that we need -->
<dependency>