aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kurtakov2013-12-03 17:05:29 (EST)
committerGerrit Code Review @ Eclipse.org2013-12-04 08:02:07 (EST)
commit466f55fb8c1229e639455113f1f340519d58d056 (patch)
treed7d059037f983031ec22fcd7b5099a815d394813
parent2257cc86c4c257b9cd01cfa247680a967c5b4f7b (diff)
downloadeclipse.platform.releng.aggregator-466f55fb8c1229e639455113f1f340519d58d056.zip
eclipse.platform.releng.aggregator-466f55fb8c1229e639455113f1f340519d58d056.tar.gz
eclipse.platform.releng.aggregator-466f55fb8c1229e639455113f1f340519d58d056.tar.bz2
Bug 423105 - Improve parent pomrefs/changes/74/19274/2
Add prereq section to define that maven 3.0.5 is the min required version due to cbi-plugins requiring it. This will make it obvious from the start if one tries to build with old Maven. Also update maven-resources-version to version 2.6 which supports maven.test.skip parameter and will skip resources calls to shave the build time a bit. Change-Id: I3a8b3128779e64f4022e116d5ea59368b198e0c4 Signed-off-by: Alexander Kurtakov <akurtako@redhat.com>
-rw-r--r--eclipse-platform-parent/pom.xml5
1 files changed, 4 insertions, 1 deletions
diff --git a/eclipse-platform-parent/pom.xml b/eclipse-platform-parent/pom.xml
index 752895c..bfc8502 100644
--- a/eclipse-platform-parent/pom.xml
+++ b/eclipse-platform-parent/pom.xml
@@ -15,6 +15,9 @@
<artifactId>eclipse-platform-parent</artifactId>
<version>4.4.0-SNAPSHOT</version>
<packaging>pom</packaging>
+ <prerequisites>
+ <maven>3.0.5</maven>
+ </prerequisites>
<properties>
<maven.test.skip>true</maven.test.skip>
<maven.build.timestamp.format>yyyyMMdd-HHmm</maven.build.timestamp.format>
@@ -273,7 +276,7 @@
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-resources-plugin</artifactId>
- <version>2.5</version>
+ <version>2.6</version>
<executions>
<execution>
<id>filter-resources</id>