Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMickael Istria2017-09-13 04:07:40 -0400
committerAlexander Kurtakov2017-09-29 08:52:37 -0400
commit5cd28510f96779ea2193086236f355014a08c3c2 (patch)
tree99e4e5726e66993697c10297593d0f9cd0706328
parent161fcdb0826daab591066dcbcdeb28035b6ad3e1 (diff)
downloadeclipse.platform.releng.aggregator-5cd28510f96779ea2193086236f355014a08c3c2.tar.gz
eclipse.platform.releng.aggregator-5cd28510f96779ea2193086236f355014a08c3c2.tar.xz
eclipse.platform.releng.aggregator-5cd28510f96779ea2193086236f355014a08c3c2.zip
Bug 522223 - Use compare-version-with-baseline
As this requires signing to be enabled to work, compare-version-with-baseline is included in the eclipse-sign profile. Change-Id: I204ccd78e17b9cf697a169942493bcb19da0b39b Signed-off-by: Mickael Istria <mistria@redhat.com>
-rw-r--r--eclipse-platform-parent/pom.xml23
1 files changed, 23 insertions, 0 deletions
diff --git a/eclipse-platform-parent/pom.xml b/eclipse-platform-parent/pom.xml
index d73acbed..16647fc5 100644
--- a/eclipse-platform-parent/pom.xml
+++ b/eclipse-platform-parent/pom.xml
@@ -158,6 +158,8 @@
<qualifier.format>'v'yyyyMMdd-HHmm</qualifier.format>
+ <compare-version-with-baselines.skip>true</compare-version-with-baselines.skip>
+
</properties>
<distributionManagement>
@@ -372,6 +374,27 @@
</execution>
</executions>
</plugin>
+ <plugin>
+ <groupId>org.eclipse.tycho.extras</groupId>
+ <artifactId>tycho-p2-extras-plugin</artifactId>
+ <version>${tycho.version}</version>
+ <executions>
+ <execution> <!-- Checks versions are properly bumped from one stream to the other -->
+ <id>compare-attached-artifacts-with-release</id>
+ <goals>
+ <goal>compare-version-with-baselines</goal>
+ </goals>
+ <configuration>
+ <skip>${compare-version-with-baselines.skip}</skip>
+ <baselines>
+ <baseline>http://download.eclipse.org/eclipse/updates/4.7-M-builds/</baseline> <!-- upcoming maintenance build of previous release -->
+ <baseline>http://download.eclipse.org/eclipse/updates/4.8/</baseline> <!-- Next release (useful after 4.8 is released to compare upcoming 4.8 maitenance with last 4.8 release) -->
+ </baselines>
+ <comparator>zip</comparator>
+ </configuration>
+ </execution>
+ </executions>
+ </plugin>
</plugins>
<pluginManagement>
<plugins>

Back to the top