summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Cox2011-09-29 15:30:58 (EDT)
committercwindatt2011-10-14 15:14:25 (EDT)
commite1237d99cd17c3fc1613887820c4fc478a95083f (patch)
tree7d0f6a44d6caea30612ebfd97031b3d87be97db1
parent298e31911fa04f97a92b60302cd07362c0e4be40 (diff)
downloadeclipse.pde.ui-e1237d99cd17c3fc1613887820c4fc478a95083f.zip
eclipse.pde.ui-e1237d99cd17c3fc1613887820c4fc478a95083f.tar.gz
eclipse.pde.ui-e1237d99cd17c3fc1613887820c4fc478a95083f.tar.bz2
Make the deprecated warning for Eclipse-GenericCapability andv20111017
Eclipse-GenericRequire only enabled when the target is >= 3.7.
-rw-r--r--ui/org.eclipse.pde.core/src/org/eclipse/pde/internal/core/builders/BundleErrorReporter.java4
1 files changed, 2 insertions, 2 deletions
diff --git a/ui/org.eclipse.pde.core/src/org/eclipse/pde/internal/core/builders/BundleErrorReporter.java b/ui/org.eclipse.pde.core/src/org/eclipse/pde/internal/core/builders/BundleErrorReporter.java
index 30df9f1..52873b1 100644
--- a/ui/org.eclipse.pde.core/src/org/eclipse/pde/internal/core/builders/BundleErrorReporter.java
+++ b/ui/org.eclipse.pde.core/src/org/eclipse/pde/internal/core/builders/BundleErrorReporter.java
@@ -474,7 +474,7 @@ public class BundleErrorReporter extends JarManifestErrorReporter {
return;
}
String message;
- if (fOsgiR4 && isCheckDeprecated()) {
+ if ((TargetPlatformHelper.getTargetVersion() >= 3.7) && isCheckDeprecated()) {
message = NLS.bind(PDECoreMessages.BundleErrorReporter_eclipse_genericCapabilityDeprecated, ICoreConstants.ECLIPSE_GENERIC_CAPABILITY, Constants.PROVIDE_CAPABILITY);
report(message, header.getLineNumber() + 1, CompilerFlags.P_DEPRECATED, PDEMarkerFactory.CAT_DEPRECATION);
}
@@ -487,7 +487,7 @@ public class BundleErrorReporter extends JarManifestErrorReporter {
return;
}
String message;
- if (fOsgiR4 && isCheckDeprecated()) {
+ if ((TargetPlatformHelper.getTargetVersion() >= 3.7) && isCheckDeprecated()) {
message = NLS.bind(PDECoreMessages.BundleErrorReporter_eclipse_genericRequireDeprecated, ICoreConstants.ECLIPSE_GENERIC_REQUIRED, Constants.REQUIRE_CAPABILITY);
report(message, header.getLineNumber() + 1, CompilerFlags.P_DEPRECATED, PDEMarkerFactory.CAT_DEPRECATION);
}