Skip to main content
aboutsummaryrefslogtreecommitdiffstats
blob: ff624fbeb4212ee89ad87285e9740dcdc1014de7 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
Manifest-Version: 1.0
Export-Package: org.eclipse.papyrus.infra.ui,
 org.eclipse.papyrus.infra.ui.command,
 org.eclipse.papyrus.infra.ui.contentoutline,
 org.eclipse.papyrus.infra.ui.converter,
 org.eclipse.papyrus.infra.ui.dnd,
 org.eclipse.papyrus.infra.ui.editor,
 org.eclipse.papyrus.infra.ui.editor.reload,
 org.eclipse.papyrus.infra.ui.editorsfactory,
 org.eclipse.papyrus.infra.ui.extension.commands,
 org.eclipse.papyrus.infra.ui.extension.diagrameditor,
 org.eclipse.papyrus.infra.ui.internal.commands;x-internal:=true,
 org.eclipse.papyrus.infra.ui.internal.preferences;x-internal:=true,
 org.eclipse.papyrus.infra.ui.lifecycleevents,
 org.eclipse.papyrus.infra.ui.menu,
 org.eclipse.papyrus.infra.ui.multidiagram.actionbarcontributor,
 org.eclipse.papyrus.infra.ui.preferences,
 org.eclipse.papyrus.infra.ui.preferences.dialog,
 org.eclipse.papyrus.infra.ui.providers,
 org.eclipse.papyrus.infra.ui.services,
 org.eclipse.papyrus.infra.ui.services.internal;x-internal:=true,
 org.eclipse.papyrus.infra.ui.util
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)";visibility:=reexport,
 org.eclipse.core.expressions;bundle-version="[3.5.0,4.0.0)";visibility:=reexport,
 org.eclipse.ui.ide;bundle-version="[3.12.0,4.0.0)";visibility:=reexport,
 org.eclipse.papyrus.infra.core.sasheditor.di;bundle-version="[2.0.0,3.0.0)";visibility:=reexport,
 org.eclipse.emf.edit.ui;bundle-version="[2.12.0,3.0.0)",
 org.eclipse.papyrus.infra.widgets;bundle-version="[3.0.0,4.0.0)";visibility:=reexport,
 org.eclipse.ui.views;bundle-version="[3.8.0,4.0.0)";visibility:=reexport,
 org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)",
 org.eclipse.papyrus.infra.widgets.toolbox;bundle-version="[2.0.0,3.0.0)",
 org.eclipse.papyrus.infra.tools;bundle-version="[3.0.0,4.0.0)",
 org.eclipse.papyrus.infra.core.architecture;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %providerName
Bundle-Version: 2.1.0.qualifier
Eclipse-BuddyPolicy: dependent
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.ui.Activator
Bundle-Description: Plugin dedicated to manage generic menus and actions,
 linked to EMF but not to UML nor GMF technologies.
Bundle-SymbolicName: org.eclipse.papyrus.infra.ui;singleton:=true
Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
 com.google.common.cache;version="[27.1.0, 28.0.0)",
 com.google.common.collect;version="[27.1.0, 28.0.0)",
 com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.ui

Back to the top