Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'releng/org.eclipse.papyrus.oomph/setups/papyrus.setup')
-rwxr-xr-xreleng/org.eclipse.papyrus.oomph/setups/papyrus.setup70
1 files changed, 35 insertions, 35 deletions
diff --git a/releng/org.eclipse.papyrus.oomph/setups/papyrus.setup b/releng/org.eclipse.papyrus.oomph/setups/papyrus.setup
index e475c030300..39715d9c94a 100755
--- a/releng/org.eclipse.papyrus.oomph/setups/papyrus.setup
+++ b/releng/org.eclipse.papyrus.oomph/setups/papyrus.setup
@@ -55,7 +55,7 @@
</setupTask>
</setupTask>
<setupTask xsi:type="setup:VariableTask" name="git.checkout.branch" value="${scope.project.stream.name}"/>
- <setupTask xsi:type="setup:VariableTask" name="eclipse.target.platform" defaultValue="2018-12" storageURI="scope://Workspace"/>
+ <setupTask xsi:type="setup:VariableTask" name="eclipse.target.platform" defaultValue="2019-03" storageURI="scope://Workspace"/>
<setupTask xsi:type="git:GitCloneTask" id="papyrus.git.clone" remoteURI="papyrus/org.eclipse.papyrus" pushURI="" checkoutBranch="${git.checkout.branch}">
<description>Papyrus</description>
<annotation source="http://www.eclipse.org/oomph/setup/InducedChoices">
@@ -77,23 +77,23 @@
<requirement name="org.eclipse.emf.sdk.feature.group"/>
<requirement name="org.apache.xerces"/>
<requirement name="org.eclipse.wst.xml.core"/>
- <repositoryList name="2018-12">
- <repository url="http://download.eclipse.org/eclipse/updates/4.10/R-4.10-201812060815/">
+ <repositoryList name="2019-03">
+ <repository url="http://download.eclipse.org/eclipse/updates/4.11/R-4.11-201903070500/">
<annotation source="http://www.eclipse.org/Papyrus/2014/releng/dependencytools">
<detail key="updateFrom">
<value>Eclipse</value>
</detail>
</annotation>
</repository>
- <repository url="http://download.eclipse.org/modeling/emf/emf/builds/release/2.16">
+ <repository url="http://download.eclipse.org/modeling/emf/emf/builds/release/2.17">
<annotation source="http://www.eclipse.org/Papyrus/2014/releng/dependencytools">
<detail key="updateFrom">
<value>EMF (Core)</value>
</detail>
</annotation>
</repository>
- <repository url="http://download.eclipse.org/modeling/emf/transaction/updates/milestones/S201805140824"/>
- <repository url="http://download.eclipse.org/modeling/emf/validation/updates/milestones/S201805030717"/>
+ <repository url="http://download.eclipse.org/modeling/emf/transaction/updates/releases/R201805140824"/>
+ <repository url="http://download.eclipse.org/modeling/emf/validation/updates/releases/R201812070911"/>
<repository url="http://download.eclipse.org/tools/gef/updates/legacy/releases/4.0.0_gef-master_1952">
<annotation source="http://www.eclipse.org/Papyrus/2014/releng/dependencytools">
<detail key="updateFrom">
@@ -101,36 +101,36 @@
</detail>
</annotation>
</repository>
- <repository url="http://download.eclipse.org/modeling/gmp/gmf-runtime/updates/milestones/S201806010809">
+ <repository url="http://download.eclipse.org/modeling/gmp/gmf-runtime/updates/releases/R201806010809">
<annotation source="http://www.eclipse.org/Papyrus/2014/releng/dependencytools">
<detail key="updateFrom">
<value>GMF Runtime</value>
</detail>
</annotation>
</repository>
- <repository url="http://download.eclipse.org/modeling/gmp/gmf-notation/updates/milestones/S201805221301"/>
- <repository url="http://download.eclipse.org/modeling/emft/mwe/updates/releases/2.9.1/">
+ <repository url="http://download.eclipse.org/modeling/gmp/gmf-notation/updates/releases/R201805221301"/>
+ <repository url="http://download.eclipse.org/modeling/emft/mwe/updates/releases/2.10.0">
<annotation source="http://www.eclipse.org/Papyrus/2014/releng/dependencytools">
<detail key="updateFrom">
<value>EMFT MWE</value>
</detail>
</annotation>
</repository>
- <repository url="http://download.eclipse.org/mmt/qvto/updates/milestones/3.9.1/S201812101559">
+ <repository url="http://download.eclipse.org/mmt/qvto/updates/milestones/3.9.2/S201903130834">
<annotation source="http://www.eclipse.org/Papyrus/2014/releng/dependencytools">
<detail key="updateFrom">
<value>QVT Operational for 2018-12</value>
</detail>
</annotation>
</repository>
- <repository url="http://download.eclipse.org/acceleo/updates/milestones/3.7/S201812041426">
+ <repository url="http://download.eclipse.org/acceleo/updates/milestones/3.7/S201902261618">
<annotation source="http://www.eclipse.org/Papyrus/2014/releng/dependencytools">
<detail key="updateFrom">
<value>M2T ACCELEO</value>
</detail>
</annotation>
</repository>
- <repository url="http://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.6.0/S201812101441">
+ <repository url="http://download.eclipse.org/modeling/mdt/ocl/updates/milestones/6.7.0/S201903111843">
<annotation source="http://www.eclipse.org/Papyrus/2014/releng/dependencytools">
<detail key="updateFrom">
<value>OCL for 2018-12</value>
@@ -151,24 +151,24 @@
</detail>
</annotation>
</repository>
- <repository url="http://download.eclipse.org/modeling/tmf/xtext/updates/releases/2.16.0">
+ <repository url="http://download.eclipse.org/modeling/tmf/xtext/updates/releases/2.17.0">
<annotation source="http://www.eclipse.org/Papyrus/2014/releng/dependencytools">
<detail key="updateFrom">
<value>Xtext, Xtend</value>
</detail>
</annotation>
</repository>
- <repository url="http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201812111422/">
+ <repository url="http://download.eclipse.org/modeling/emf/compare/updates/milestones/3.3/S201903050300/">
<annotation source="http://www.eclipse.org/Papyrus/2014/releng/dependencytools">
<detail key="updateFrom">
<value>EMF COMPARE</value>
</detail>
</annotation>
</repository>
- <repository url="https://download.eclipse.org/webtools/downloads/drops/R3.12.0/S-3.12.0.RC1-20181130055351/repository/">
+ <repository url="https://download.eclipse.org/webtools/downloads/drops/R3.13.0/S-3.13.0.RC2-20190308131645/repository/">
<annotation source="http://www.eclipse.org/Papyrus/2014/releng/dependencytools">
<detail key="updateFrom">
- <value>WebTools 3.12 for Simrel 2018-12</value>
+ <value>WebTools 3.13 for Simrel 2019-03</value>
</detail>
</annotation>
</repository>
@@ -182,7 +182,7 @@
<repository url="http://download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases-3.3.1a"/>
<repository url="http://download.eclipse.org/nattable/releases/1.5.0/repository/"/>
<repository url="http://download.eclipse.org/nebula/releases/1.2.0/"/>
- <repository url="http://download.eclipse.org/tools/orbit/downloads/drops/R20181128170323/repository"/>
+ <repository url="https://download.eclipse.org/tools/orbit/downloads/drops/R20190226160451/repository"/>
</repositoryList>
<repositoryList name="Oxygen">
<repository url="http://download.eclipse.org/eclipse/updates/4.7/R-4.7.3-201803010715/">
@@ -315,12 +315,12 @@
<requirement name="org.eclipse.emf.compare" versionRange="[3.3.0,4.0.0)"/>
<requirement name="org.eclipse.gmf.tooling.feature.group"/>
<requirement name="org.eclipse.m2m.qvt.oml.feature.group" versionRange="[3.6.0,4.0.0)"/>
- <repositoryList name="2018-12"/>
+ <repositoryList name="2019-03"/>
<repositoryList name="Oxygen"/>
</targlet>
<targlet activeRepositoryList="${eclipse.target.platform}" name="Papyrus Main Plug-ins">
<requirement name="org.eclipse.papyrus.sdk.feature.feature.group"/>
- <repositoryList name="2018-12">
+ <repositoryList name="2019-03">
<repository url="http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/master"/>
</repositoryList>
<repositoryList name="Oxygen">
@@ -330,7 +330,7 @@
<targlet activeRepositoryList="${eclipse.target.platform}" name="Papyrus Toolsmiths Dependencies">
<requirement name="org.eclipse.gmf.tooling.feature.group"/>
<requirement name="org.eclipse.emf.compare" versionRange="[3.3.0,4.0.0)"/>
- <repositoryList name="2018-12">
+ <repositoryList name="2019-03">
<repository url="https://download.eclipse.org/oomph/drops/release/1.11.0">
<annotation source="http://www.eclipse.org/Papyrus/2014/releng/dependencytools">
<detail key="updateFrom">
@@ -510,7 +510,7 @@
<requirement name="org.eclipse.emf.mwe2.launcher.feature.group"/>
</targlet>
</setupTask>
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
<setupTask xsi:type="setup.targlets:TargletTask">
<targlet activeRepositoryList="${eclipse.target.platform}" name="Papyrus Infra Master Dependencies">
@@ -559,7 +559,7 @@
</predicate>
</workingSet>
</setupTask>
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
</stream>
<stream label="streams/3.0-maintenance (Oxygen/3.x)" name="streams/3.0-maintenance">
@@ -650,7 +650,7 @@
<setupTask xsi:type="setup.p2:P2Task">
<requirement name="org.eclipse.xtend.sdk.feature.group"/>
</setupTask>
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
</stream>
<stream label="streams/3.0-maintenance (Oxygen/3.x)" name="streams/3.0-maintenance">
@@ -702,7 +702,7 @@
<requirement name="org.eclipse.m2m.qvt.oml.runtime.feature.group"/>
</targlet>
</setupTask>
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
</stream>
<stream label="streams/3.0-maintenance (Oxygen/3.x)" name="streams/3.0-maintenance">
@@ -748,7 +748,7 @@
<setupTask xsi:type="setup.p2:P2Task">
<requirement name="org.eclipse.xtend.sdk.feature.group"/>
</setupTask>
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
</stream>
<stream label="streams/3.0-maintenance (Oxygen/3.x)" name="streams/3.0-maintenance">
@@ -782,7 +782,7 @@
</predicate>
</workingSet>
</setupTask>
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
</stream>
<stream label="streams/3.0-maintenance (Oxygen/3.x)" name="streams/3.0-maintenance">
@@ -814,7 +814,7 @@
</predicate>
</workingSet>
</setupTask>
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
</stream>
<stream label="streams/3.0-maintenance (Oxygen/3.x)" name="streams/3.0-maintenance">
@@ -856,7 +856,7 @@
<requirement name="org.eclipse.xtext.junit4"/>
</targlet>
</setupTask>
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
</stream>
<stream label="streams/3.0-maintenance (Oxygen/3.x)" name="streams/3.0-maintenance">
@@ -864,7 +864,7 @@
</stream>
</project>
<project label="Others" name="misc">
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
</stream>
<stream label="streams/3.0-maintenance (Oxygen/3.x)" name="streams/3.0-maintenance">
@@ -878,7 +878,7 @@
<requirement name="org.eclipse.oomph.setup.targlets.feature.group" optional="true"/>
<requirement name="org.eclipse.oomph.setup.feature.group" optional="true"/>
<requirement name="org.eclipse.cbi.p2repo.aggregator.engine.feature.feature.group"/>
- <repositoryList name="2018-12">
+ <repositoryList name="2019-03">
<repository url="${oomph.update.url}"/>
<repository url="http://download.eclipse.org/cbi/updates/aggregator/ide/4.8/"/>
</repositoryList>
@@ -962,7 +962,7 @@
</predicate>
</workingSet>
</setupTask>
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
</stream>
<stream label="streams/3.0-maintenance (Oxygen/3.x)" name="streams/3.0-maintenance">
@@ -1006,7 +1006,7 @@
</setupTask>
<project label="Oomph Setup" name="Oomph">
<setupTask xsi:type="setup:EclipseIniTask" option="-Doomph.redirection.papyrussetups" value="=http://git.eclipse.org/c/papyrus/org.eclipse.papyrus.git/plain/releng/org.eclipse.papyrus.oomph/setups/->${papyrus.git.clone.location|uri}/releng/org.eclipse.papyrus.oomph/setups/" vm="true"/>
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
</stream>
<stream label="streams/3.0-maintenance (Oxygen/3.x)" name="streams/3.0-maintenance">
@@ -1071,7 +1071,7 @@
</predicate>
</workingSet>
</setupTask>
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
</stream>
<stream label="streams/3.0-maintenance (Oxygen/3.x)" name="streams/3.0-maintenance">
@@ -1084,7 +1084,7 @@
</stream>
<description>Release engineering tools, including the POM and Oomph Setup dependencies updater actions.</description>
</project>
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
</stream>
<stream label="streams/3.0-maintenance (Oxygen/3.x)" name="streams/3.0-maintenance">
@@ -1092,7 +1092,7 @@
</stream>
<description>Sources and tools required for working on the Papyrus developer tools (not part of the product). Does not install the developer tools in your IDE: use the Developer Tools sub-project for that.</description>
</project>
- <stream label="master (2018-12/4.2)" name="master">
+ <stream label="master (2019-03/4.3)" name="master">
<setupTask xsi:type="setup:VariableTask" name="papyrus.bugzilla.version" value="${papyrus.bugzver.201812}"/>
<setupTask xsi:type="jdt:JRETask" version="JavaSE-1.8" location="${jre.location-1.8}"/>
<setupTask xsi:type="setup.targlets:TargletTask">

Back to the top