Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'plugins')
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/META-INF/MANIFEST.MF10
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.core/pom.xml4
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/META-INF/MANIFEST.MF8
-rw-r--r--plugins/infra/core/org.eclipse.papyrus.infra.tools/pom.xml4
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/pom.xml2
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF6
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/pom.xml4
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF8
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.emf/pom.xml4
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/META-INF/MANIFEST.MF6
-rw-r--r--plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/pom.xml4
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/pom.xml2
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/META-INF/MANIFEST.MF6
-rw-r--r--plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/pom.xml4
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/META-INF/MANIFEST.MF6
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/pom.xml4
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/pom.xml4
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/META-INF/MANIFEST.MF8
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/pom.xml4
-rwxr-xr-xplugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF8
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/pom.xml2
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/pom.xml2
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/pom.xml4
-rw-r--r--plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/pom.xml2
-rw-r--r--plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/pom.xml4
-rw-r--r--plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/META-INF/MANIFEST.MF6
-rw-r--r--plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/pom.xml4
-rwxr-xr-xplugins/infra/misc/org.eclipse.papyrus.infra.sync/META-INF/MANIFEST.MF10
-rw-r--r--plugins/infra/misc/org.eclipse.papyrus.infra.sync/pom.xml4
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/pom.xml4
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/META-INF/MANIFEST.MF6
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/pom.xml4
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/pom.xml4
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF8
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/pom.xml4
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.edit/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.edit/pom.xml4
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/pom.xml4
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.validation/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/services/org.eclipse.papyrus.infra.services.validation/pom.xml4
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.core/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/types/org.eclipse.papyrus.infra.types.core/pom.xml2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/pom.xml2
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/META-INF/MANIFEST.MF10
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.ui/pom.xml4
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.widgets/META-INF/MANIFEST.MF4
-rw-r--r--plugins/infra/ui/org.eclipse.papyrus.infra.widgets/pom.xml4
-rw-r--r--plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/META-INF/MANIFEST.MF4
-rw-r--r--plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/pom.xml4
-rw-r--r--plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java2
-rwxr-xr-xplugins/toolsmiths/org.eclipse.papyrus.releng.dev.release/release.digestbin4328 -> 4729 bytes
-rwxr-xr-xplugins/toolsmiths/org.eclipse.papyrus.releng.dev.release/release.xml19
-rwxr-xr-xplugins/toolsmiths/org.eclipse.papyrus.releng.main.release/release.digestbin29986 -> 30132 bytes
-rwxr-xr-xplugins/toolsmiths/org.eclipse.papyrus.releng.main.release/release.xml123
-rwxr-xr-xplugins/toolsmiths/org.eclipse.papyrus.releng.tools/META-INF/MANIFEST.MF6
-rw-r--r--plugins/toolsmiths/org.eclipse.papyrus.releng.tools/pom.xml2
-rw-r--r--plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/META-INF/MANIFEST.MF4
-rw-r--r--plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/pom.xml4
-rw-r--r--plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/META-INF/MANIFEST.MF4
-rw-r--r--plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/pom.xml2
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/pom.xml2
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/META-INF/MANIFEST.MF8
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/pom.xml4
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/META-INF/MANIFEST.MF10
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/pom.xml4
-rwxr-xr-xplugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/META-INF/MANIFEST.MF8
-rw-r--r--plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/pom.xml4
-rwxr-xr-xplugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity/META-INF/MANIFEST.MF4
-rwxr-xr-xplugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/pom.xml4
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/pom.xml4
-rwxr-xr-xplugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/pom.xml4
-rwxr-xr-xplugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/pom.xml4
-rwxr-xr-xplugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/META-INF/MANIFEST.MF4
-rwxr-xr-xplugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/pom.xml4
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/pom.xml4
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/pom.xml4
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/pom.xml4
-rw-r--r--plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/pom.xml4
-rw-r--r--plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/pom.xml4
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/pom.xml4
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.filters/META-INF/MANIFEST.MF4
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.filters/pom.xml2
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF10
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.modelrepair/pom.xml4
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.profile/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.profile/pom.xml4
-rw-r--r--plugins/uml/org.eclipse.papyrus.uml.service.types/META-INF/MANIFEST.MF2
-rw-r--r--plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/pom.xml4
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/pom.xml2
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools/META-INF/MANIFEST.MF6
-rw-r--r--plugins/uml/tools/org.eclipse.papyrus.uml.tools/pom.xml2
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF6
-rw-r--r--plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/pom.xml4
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/META-INF/MANIFEST.MF4
-rw-r--r--plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/pom.xml4
-rw-r--r--plugins/views/validation/org.eclipse.papyrus.views.validation/META-INF/MANIFEST.MF6
-rw-r--r--plugins/views/validation/org.eclipse.papyrus.views.validation/pom.xml4
121 files changed, 343 insertions, 333 deletions
diff --git a/plugins/infra/core/org.eclipse.papyrus.infra.core/META-INF/MANIFEST.MF b/plugins/infra/core/org.eclipse.papyrus.infra.core/META-INF/MANIFEST.MF
index 687e8c6c46f..90750e186ea 100644
--- a/plugins/infra/core/org.eclipse.papyrus.infra.core/META-INF/MANIFEST.MF
+++ b/plugins/infra/core/org.eclipse.papyrus.infra.core/META-INF/MANIFEST.MF
@@ -31,15 +31,15 @@ Require-Bundle: org.eclipse.emf.workspace;bundle-version="[1.5.0,2.0.0)",
org.eclipse.papyrus.infra.core.architecture;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.0.200.qualifier
+Bundle-Version: 3.1.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-Activator: org.eclipse.papyrus.infra.core.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.core;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)",
- com.google.common.io;version="[21.0.0, 22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)",
+ com.google.common.io;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.core
diff --git a/plugins/infra/core/org.eclipse.papyrus.infra.core/pom.xml b/plugins/infra/core/org.eclipse.papyrus.infra.core/pom.xml
index 2a6be614546..12666e987f9 100644
--- a/plugins/infra/core/org.eclipse.papyrus.infra.core/pom.xml
+++ b/plugins/infra/core/org.eclipse.papyrus.infra.core/pom.xml
@@ -9,6 +9,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.core</artifactId>
- <version>3.0.200-SNAPSHOT</version>
+ <version>3.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/core/org.eclipse.papyrus.infra.tools/META-INF/MANIFEST.MF b/plugins/infra/core/org.eclipse.papyrus.infra.tools/META-INF/MANIFEST.MF
index 4df02fe471d..eb1e704ebaa 100644
--- a/plugins/infra/core/org.eclipse.papyrus.infra.tools/META-INF/MANIFEST.MF
+++ b/plugins/infra/core/org.eclipse.papyrus.infra.tools/META-INF/MANIFEST.MF
@@ -13,14 +13,14 @@ Require-Bundle: org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)
org.apache.commons.io;bundle-version="2.2.0"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.1.0.qualifier
+Bundle-Version: 3.2.0.qualifier
Eclipse-BuddyPolicy: dependent
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.infra.tools.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.tools;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.tools
diff --git a/plugins/infra/core/org.eclipse.papyrus.infra.tools/pom.xml b/plugins/infra/core/org.eclipse.papyrus.infra.tools/pom.xml
index b0887fe3bcd..028c4f3c61b 100644
--- a/plugins/infra/core/org.eclipse.papyrus.infra.tools/pom.xml
+++ b/plugins/infra/core/org.eclipse.papyrus.infra.tools/pom.xml
@@ -6,6 +6,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.tools</artifactId>
- <version>3.1.0-SNAPSHOT</version>
+ <version>3.2.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/META-INF/MANIFEST.MF b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/META-INF/MANIFEST.MF
index f079016b828..cf05cad19f7 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/META-INF/MANIFEST.MF
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/META-INF/MANIFEST.MF
@@ -9,12 +9,12 @@ Require-Bundle: org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.emf.workspace;bundle-version="[1.5.0,2.0.0)";visibility:=reexport
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.100.qualifier
+Bundle-Version: 1.3.0.qualifier
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.infra.emf.internal.gmf.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.emf.gmf;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Localization: plugin
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.emf.gmf
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/pom.xml b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/pom.xml
index f10ab0ae121..4dc7a609405 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/pom.xml
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.gmf/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.emf.gmf</artifactId>
- <version>1.2.100-SNAPSHOT</version>
+ <version>1.3.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF
index 16162a78c8b..e66689ea384 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/META-INF/MANIFEST.MF
@@ -11,13 +11,13 @@ Require-Bundle: org.eclipse.papyrus.infra.onefile;bundle-version="[2.1.0,3.0.0)"
org.eclipse.papyrus.infra.internationalization;bundle-version="[1.0.0,2.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.0.0.qualifier
+Bundle-Version: 3.1.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.emf.readonly.Activator
Bundle-SymbolicName: org.eclipse.papyrus.infra.emf.readonly;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.emf.readonly
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/pom.xml b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/pom.xml
index eb8d834bfa0..a5d59477a1f 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/pom.xml
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.emf.readonly/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.emf.readonly</artifactId>
- <version>3.0.0-SNAPSHOT</version>
+ <version>3.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF b/plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF
index fcbf4342bf1..a4bc06da6e0 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.emf/META-INF/MANIFEST.MF
@@ -17,14 +17,14 @@ Require-Bundle: org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)";vi
org.eclipse.papyrus.emf.facet.custom.core;bundle-version="[3.0.0,4.0.0)";visibility:=reexport
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.0.0.qualifier
+Bundle-Version: 3.1.0.qualifier
Bundle-Name: EMF Tools
Bundle-Activator: org.eclipse.papyrus.infra.emf.Activator
Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.emf;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.emf
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.emf/pom.xml b/plugins/infra/emf/org.eclipse.papyrus.infra.emf/pom.xml
index 7bbcce138f4..bc520d3d5f1 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.emf/pom.xml
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.emf/pom.xml
@@ -7,6 +7,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.emf</artifactId>
- <version>3.0.0-SNAPSHOT</version>
+ <version>3.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/META-INF/MANIFEST.MF b/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/META-INF/MANIFEST.MF
index d4da534db54..10a98ea3506 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/META-INF/MANIFEST.MF
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/META-INF/MANIFEST.MF
@@ -20,13 +20,13 @@ Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="[2.12.0,3.0.0)";visibili
org.eclipse.papyrus.infra.internationalization.utils;bundle-version="[1.0.0,2.0.0)"
Bundle-Vendor: %pluginProvider
Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.1.0.qualifier
+Bundle-Version: 2.2.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-Activator: org.eclipse.papyrus.infra.ui.internal.emf.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.ui.emf;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.ui.emf
diff --git a/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/pom.xml b/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/pom.xml
index bd40569377b..c4252b268c7 100644
--- a/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/pom.xml
+++ b/plugins/infra/emf/org.eclipse.papyrus.infra.ui.emf/pom.xml
@@ -7,6 +7,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.ui.emf</artifactId>
- <version>2.1.0-SNAPSHOT</version>
+ <version>2.2.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/META-INF/MANIFEST.MF
index f852ab6935c..d53fbb8b4c6 100644
--- a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Export-Package: org.eclipse.papyrus.infra.gmfdiag.assistant.internal.ui;x-intern
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 1.3.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.assistant.internal.ui.Activator
@@ -15,5 +15,5 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.assistant.ui;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.assistant.ui
diff --git a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/pom.xml b/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/pom.xml
index 89b5124f048..5a739e20617 100644
--- a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/pom.xml
+++ b/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant.ui/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.gmfdiag.assistant.ui</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>1.3.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/META-INF/MANIFEST.MF
index 561726a6ce7..0b146e7f453 100644
--- a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/META-INF/MANIFEST.MF
@@ -18,7 +18,7 @@ Export-Package: org.eclipse.papyrus.infra.gmfdiag.assistant,
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.4.0.qualifier
+Bundle-Version: 1.5.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.assistant.internal.core.AssistantPlugin$Implementation
@@ -26,6 +26,6 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.assistant;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.assistant
diff --git a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/pom.xml b/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/pom.xml
index 7ed8bc8e4d7..682aa00bdd9 100644
--- a/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/pom.xml
+++ b/plugins/infra/gmfdiag/assistant/org.eclipse.papyrus.infra.gmfdiag.assistant/pom.xml
@@ -9,6 +9,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.gmfdiag.assistant</artifactId>
- <version>1.4.0-SNAPSHOT</version>
+ <version>1.5.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/META-INF/MANIFEST.MF
index 14b1b7f8c3b..9b0308b7013 100644
--- a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/META-INF/MANIFEST.MF
@@ -9,12 +9,12 @@ Require-Bundle: org.eclipse.papyrus.infra.properties.ui;bundle-version="[3.0.0,4
org.eclipse.papyrus.infra.gmfdiag.dnd;bundle-version="[1.2.0,2.0.0)"
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.0.0.qualifier
+Bundle-Version: 3.1.0.qualifier
Bundle-Name: CSS Properties
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.css.properties.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.css.properties;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.css.properties
diff --git a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/pom.xml b/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/pom.xml
index a3240dd9e62..fce2cd748ac 100644
--- a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/pom.xml
+++ b/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css.properties/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.gmfdiag.css.properties</artifactId>
- <version>3.0.0-SNAPSHOT</version>
+ <version>3.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/META-INF/MANIFEST.MF
index 39921d8f4e9..2099ec6dee2 100644
--- a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/META-INF/MANIFEST.MF
@@ -33,12 +33,12 @@ Require-Bundle: org.eclipse.e4.ui.css.core;bundle-version="[0.11.0,1.0.0)",
org.eclipse.papyrus.infra.architecture.representation;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.3.100.qualifier
+Bundle-Version: 2.4.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.css.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.css;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.css
diff --git a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/pom.xml b/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/pom.xml
index 63a5c38f9ad..1d28248e5bc 100644
--- a/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/pom.xml
+++ b/plugins/infra/gmfdiag/css/org.eclipse.papyrus.infra.gmfdiag.css/pom.xml
@@ -9,6 +9,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.gmfdiag.css</artifactId>
- <version>2.3.100-SNAPSHOT</version>
+ <version>2.4.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/META-INF/MANIFEST.MF
index 29371745026..787758ee6f7 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Export-Package: org.eclipse.papyrus.infra.gmfdiag.canonical.editpolicy,
org.eclipse.papyrus.infra.gmfdiag.canonical.strategy
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 2.1.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.canonical.internal.Activator
@@ -15,7 +15,7 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.canonical;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.canonical
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/pom.xml b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/pom.xml
index c6a2307dd91..4ad962e35c0 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/pom.xml
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.canonical/pom.xml
@@ -7,6 +7,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.gmfdiag.canonical</artifactId>
- <version>2.0.0-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF
index 17d427a1bc3..aa6f8bba424 100755
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/META-INF/MANIFEST.MF
@@ -82,14 +82,14 @@ Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.common.Activator
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 3.101.200.qualifier
+Bundle-Version: 3.102.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.common;singleton:=true
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0, 22.0.0)",
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)",
org.osgi.service.component.annotations;version="1.3.0";resolution:=optional
Service-Component: OSGI-INF/org.eclipse.papyrus.infra.gmfdiag.common.internal.service.EditPolicyProviderServiceImpl.xml,
OSGI-INF/org.eclipse.papyrus.infra.gmfdiag.common.internal.service.ViewProviderServiceImpl.xml
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/pom.xml b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/pom.xml
index da88ec3c4e2..c6d5aa9b747 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/pom.xml
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.common/pom.xml
@@ -9,6 +9,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.gmfdiag.common</artifactId>
- <version>3.101.200-SNAPSHOT</version>
+ <version>3.102.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/META-INF/MANIFEST.MF
index 7401c577c04..108f03a4b50 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/META-INF/MANIFEST.MF
@@ -7,12 +7,12 @@ Export-Package: org.eclipse.papyrus.infra.gmfdiag.menu,
org.eclipse.papyrus.infra.gmfdiag.menu.utils
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 1.3.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.menu.Activator
Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.menu;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.menu
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/pom.xml b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/pom.xml
index 59bd5e400de..def6ff5de43 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/pom.xml
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.menu/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.gmfdiag.menu</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>1.3.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF
index 6c713a4a0a1..f20d60ab0c9 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/META-INF/MANIFEST.MF
@@ -14,7 +14,7 @@ Require-Bundle: org.eclipse.papyrus.infra.properties.ui;bundle-version="[3.4.0,4
org.eclipse.papyrus.infra.architecture.representation;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy;exclude:="org.eclipse.papyrus.infra.gmfdiag.properties.constraint"
-Bundle-Version: 4.0.100.qualifier
+Bundle-Version: 4.1.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.properties.Activator
@@ -22,5 +22,5 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.properties;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.properties
diff --git a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/pom.xml b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/pom.xml
index 3c7ca941d39..01599d01099 100644
--- a/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/pom.xml
+++ b/plugins/infra/gmfdiag/org.eclipse.papyrus.infra.gmfdiag.properties/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.gmfdiag.properties</artifactId>
- <version>4.0.100-SNAPSHOT</version>
+ <version>4.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/META-INF/MANIFEST.MF b/plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/META-INF/MANIFEST.MF
index 053680d6727..fb9c9c1f291 100644
--- a/plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/META-INF/MANIFEST.MF
+++ b/plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor;singleton:=true
-Bundle-Version: 3.1.1.qualifier
+Bundle-Version: 3.2.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.presentation.PaletteConfigurationEditorPlugin$Implementation
Bundle-Vendor: %providerName
@@ -37,5 +37,5 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
org.eclipse.gmf.runtime.diagram.ui.properties;bundle-version="1.7.0",
org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)"
Bundle-ActivationPolicy: lazy
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor
diff --git a/plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/pom.xml b/plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/pom.xml
index 2ef40318029..e340eee1888 100644
--- a/plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/pom.xml
+++ b/plugins/infra/gmfdiag/paletteconfiguration/org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor/pom.xml
@@ -11,6 +11,6 @@
<relativePath>../../../../toolsmiths/pom.xml</relativePath>
</parent>
<artifactId>org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor</artifactId>
- <version>3.1.1-SNAPSHOT</version>
+ <version>3.2.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/META-INF/MANIFEST.MF b/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/META-INF/MANIFEST.MF
index 6de33a66c95..8a80727e54e 100644
--- a/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/META-INF/MANIFEST.MF
+++ b/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.infra.internationalization.readonly;singleton:=true
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 1.1.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -11,5 +11,5 @@ Require-Bundle: org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.emf.readonly;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.internationalization;bundle-version="[1.0.0,2.0.0)"
Bundle-ActivationPolicy: lazy
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.internationalization.readonly
diff --git a/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/pom.xml b/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/pom.xml
index 6dfdc6fa1dd..5905e8df03e 100644
--- a/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/pom.xml
+++ b/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization.readonly/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.internationalization.readonly</artifactId>
- <version>1.0.0-SNAPSHOT</version>
+ <version>1.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/META-INF/MANIFEST.MF b/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/META-INF/MANIFEST.MF
index 38fe6e18ec3..563a47f0112 100644
--- a/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/META-INF/MANIFEST.MF
+++ b/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.infra.internationalization;singleton:=true
-Bundle-Version: 1.0.100.qualifier
+Bundle-Version: 1.2.0.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -27,6 +27,6 @@ Require-Bundle: org.eclipse.emf.ecore;bundle-version="[2.12.0,3.0.0)";visibility
org.eclipse.papyrus.infra.emf.gmf;bundle-version="[1.2.0,2.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.eclipse.papyrus.infra.internationalization.Activator
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.internationalization
diff --git a/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/pom.xml b/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/pom.xml
index 5151dd8cccb..8f0f5289a8c 100644
--- a/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/pom.xml
+++ b/plugins/infra/internationalization/org.eclipse.papyrus.infra.internationalization/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.internationalization</artifactId>
- <version>1.0.100-SNAPSHOT</version>
+ <version>1.2.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/misc/org.eclipse.papyrus.infra.sync/META-INF/MANIFEST.MF b/plugins/infra/misc/org.eclipse.papyrus.infra.sync/META-INF/MANIFEST.MF
index c9f6aaaba33..1b98bfc2e73 100755
--- a/plugins/infra/misc/org.eclipse.papyrus.infra.sync/META-INF/MANIFEST.MF
+++ b/plugins/infra/misc/org.eclipse.papyrus.infra.sync/META-INF/MANIFEST.MF
@@ -7,15 +7,15 @@ Export-Package: org.eclipse.papyrus.infra.sync,
org.eclipse.papyrus.infra.sync.service
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 2.1.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.sync.Activator
Bundle-SymbolicName: org.eclipse.papyrus.infra.sync;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)",
- com.google.common.reflect;version="[21.0.0, 22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)",
+ com.google.common.reflect;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.sync
diff --git a/plugins/infra/misc/org.eclipse.papyrus.infra.sync/pom.xml b/plugins/infra/misc/org.eclipse.papyrus.infra.sync/pom.xml
index 623de643406..fe2e465f6cd 100644
--- a/plugins/infra/misc/org.eclipse.papyrus.infra.sync/pom.xml
+++ b/plugins/infra/misc/org.eclipse.papyrus.infra.sync/pom.xml
@@ -6,6 +6,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.sync</artifactId>
- <version>2.0.0-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF
index 9a4d29f9c94..487f6e96e2e 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/META-INF/MANIFEST.MF
@@ -26,11 +26,11 @@ Require-Bundle: org.eclipse.papyrus.infra.nattable;bundle-version="[6.0.0,7.0.0)
org.eclipse.papyrus.infra.architecture.representation;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 5.1.0.qualifier
+Bundle-Version: 5.2.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.infra.nattable.common.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.nattable.common;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.nattable.common
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/pom.xml b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/pom.xml
index ca7618945d3..aac59bec95c 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/pom.xml
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.common/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.nattable.common</artifactId>
- <version>5.1.0-SNAPSHOT</version>
+ <version>5.2.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/META-INF/MANIFEST.MF b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/META-INF/MANIFEST.MF
index dbec808e7ae..45f626facb5 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/META-INF/MANIFEST.MF
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/META-INF/MANIFEST.MF
@@ -8,13 +8,13 @@ Require-Bundle: org.eclipse.papyrus.infra.services.controlmode;bundle-version="[
org.eclipse.papyrus.infra.nattable.common;bundle-version="[5.0.0,6.0.0)"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.0.100.qualifier
+Bundle-Version: 2.1.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.infra.nattable.controlmode.Activator
Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.nattable.controlmode;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.nattable.controlmode
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/pom.xml b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/pom.xml
index 37f5449ef5d..3f054e7814c 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/pom.xml
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable.controlmode/pom.xml
@@ -7,6 +7,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.nattable.controlmode</artifactId>
- <version>2.0.100-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF
index e06bc4fa1b4..e8c7c896f16 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF
@@ -76,12 +76,12 @@ Require-Bundle: org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0
javax.inject;bundle-version="[1.0.0,2.0.0)"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 6.2.0.qualifier
+Bundle-Version: 6.3.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.infra.nattable.Activator
Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.nattable;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.nattable
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/pom.xml b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/pom.xml
index 4c129903258..6758a2694ab 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/pom.xml
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/pom.xml
@@ -9,6 +9,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.nattable</artifactId>
- <version>6.2.0-SNAPSHOT</version>
+ <version>6.3.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF b/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF
index 13ade560a0b..db8a104e550 100644
--- a/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF
+++ b/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/META-INF/MANIFEST.MF
@@ -25,14 +25,14 @@ Require-Bundle: org.eclipse.emf.edit.ui;bundle-version="[2.12.0,3.0.0)";visibili
org.eclipse.papyrus.infra.onefile;bundle-version="[2.1.0,3.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.0.100.qualifier
+Bundle-Version: 2.1.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.infra.services.controlmode.ControlModePlugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.services.controlmode;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.services.controlmode
diff --git a/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/pom.xml b/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/pom.xml
index dda957f2595..96e7971343a 100644
--- a/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/pom.xml
+++ b/plugins/infra/services/org.eclipse.papyrus.infra.services.controlmode/pom.xml
@@ -6,6 +6,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.services.controlmode</artifactId>
- <version>2.0.100-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/services/org.eclipse.papyrus.infra.services.edit/META-INF/MANIFEST.MF b/plugins/infra/services/org.eclipse.papyrus.infra.services.edit/META-INF/MANIFEST.MF
index 1a57467c5cb..d2792503d87 100644
--- a/plugins/infra/services/org.eclipse.papyrus.infra.services.edit/META-INF/MANIFEST.MF
+++ b/plugins/infra/services/org.eclipse.papyrus.infra.services.edit/META-INF/MANIFEST.MF
@@ -14,12 +14,12 @@ Require-Bundle: org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0
org.eclipse.papyrus.infra.core.architecture;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.1.0.qualifier
+Bundle-Version: 3.2.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.infra.services.edit.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.services.edit;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.services.edit
diff --git a/plugins/infra/services/org.eclipse.papyrus.infra.services.edit/pom.xml b/plugins/infra/services/org.eclipse.papyrus.infra.services.edit/pom.xml
index c6e94d651d6..8498900f7cc 100644
--- a/plugins/infra/services/org.eclipse.papyrus.infra.services.edit/pom.xml
+++ b/plugins/infra/services/org.eclipse.papyrus.infra.services.edit/pom.xml
@@ -6,6 +6,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.services.edit</artifactId>
- <version>3.1.0-SNAPSHOT</version>
+ <version>3.2.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/META-INF/MANIFEST.MF b/plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/META-INF/MANIFEST.MF
index d731db4896c..ae0bc7040e4 100644
--- a/plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/META-INF/MANIFEST.MF
+++ b/plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/META-INF/MANIFEST.MF
@@ -6,12 +6,12 @@ Require-Bundle: org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)";vi
org.eclipse.papyrus.infra.emf;bundle-version="[3.0.0,4.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 2.1.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.services.localizer.internal.Activator
Bundle-SymbolicName: org.eclipse.papyrus.infra.services.localizer;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.services.localizer
diff --git a/plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/pom.xml b/plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/pom.xml
index ac5fed6c7e4..433e7344dcb 100644
--- a/plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/pom.xml
+++ b/plugins/infra/services/org.eclipse.papyrus.infra.services.localizer/pom.xml
@@ -6,6 +6,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.services.localizer</artifactId>
- <version>2.0.0-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/services/org.eclipse.papyrus.infra.services.validation/META-INF/MANIFEST.MF b/plugins/infra/services/org.eclipse.papyrus.infra.services.validation/META-INF/MANIFEST.MF
index 0a98516f398..74b256ea0aa 100644
--- a/plugins/infra/services/org.eclipse.papyrus.infra.services.validation/META-INF/MANIFEST.MF
+++ b/plugins/infra/services/org.eclipse.papyrus.infra.services.validation/META-INF/MANIFEST.MF
@@ -12,12 +12,12 @@ Require-Bundle: org.eclipse.gmf.runtime.emf.commands.core;bundle-version="[1.7.0
org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %pluginProvider
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.0.0.qualifier
+Bundle-Version: 3.1.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.infra.services.validation.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.services.validation;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.services.validation
diff --git a/plugins/infra/services/org.eclipse.papyrus.infra.services.validation/pom.xml b/plugins/infra/services/org.eclipse.papyrus.infra.services.validation/pom.xml
index ab62c2a3085..d572b92e704 100644
--- a/plugins/infra/services/org.eclipse.papyrus.infra.services.validation/pom.xml
+++ b/plugins/infra/services/org.eclipse.papyrus.infra.services.validation/pom.xml
@@ -7,6 +7,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.services.validation</artifactId>
- <version>3.0.0-SNAPSHOT</version>
+ <version>3.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/types/org.eclipse.papyrus.infra.types.core/META-INF/MANIFEST.MF b/plugins/infra/types/org.eclipse.papyrus.infra.types.core/META-INF/MANIFEST.MF
index ad305634352..776e3b2bc59 100644
--- a/plugins/infra/types/org.eclipse.papyrus.infra.types.core/META-INF/MANIFEST.MF
+++ b/plugins/infra/types/org.eclipse.papyrus.infra.types.core/META-INF/MANIFEST.MF
@@ -16,12 +16,12 @@ Export-Package: org.eclipse.papyrus.infra.types.core,
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 4.0.0.qualifier
+Bundle-Version: 4.1.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.infra.types.core.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.types.core;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.types.core
diff --git a/plugins/infra/types/org.eclipse.papyrus.infra.types.core/pom.xml b/plugins/infra/types/org.eclipse.papyrus.infra.types.core/pom.xml
index 1fe68e236be..64f1b1c2a1b 100644
--- a/plugins/infra/types/org.eclipse.papyrus.infra.types.core/pom.xml
+++ b/plugins/infra/types/org.eclipse.papyrus.infra.types.core/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.types.core</artifactId>
- <version>4.0.0-SNAPSHOT</version>
+ <version>4.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/META-INF/MANIFEST.MF b/plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/META-INF/MANIFEST.MF
index 6c82345ef7a..cefe19263e2 100644
--- a/plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/META-INF/MANIFEST.MF
+++ b/plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/META-INF/MANIFEST.MF
@@ -5,12 +5,12 @@ Require-Bundle: org.eclipse.ltk.core.refactoring;bundle-version="[3.7.0,4.0.0)",
org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.2.0.qualifier
+Bundle-Version: 1.3.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.infra.ui.resources.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.infra.ui.resources;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.ui.resources
diff --git a/plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/pom.xml b/plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/pom.xml
index 261cf9074f6..7801db2db35 100644
--- a/plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/pom.xml
+++ b/plugins/infra/ui/org.eclipse.papyrus.infra.ui.resources/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.ui.resources</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>1.3.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/infra/ui/org.eclipse.papyrus.infra.ui/META-INF/MANIFEST.MF b/plugins/infra/ui/org.eclipse.papyrus.infra.ui/META-INF/MANIFEST.MF
index f87b6b7df27..ff624fbeb42 100644
--- a/plugins/infra/ui/org.eclipse.papyrus.infra.ui/META-INF/MANIFEST.MF
+++ b/plugins/infra/ui/org.eclipse.papyrus.infra.ui/META-INF/MANIFEST.MF
@@ -37,15 +37,15 @@ Require-Bundle: org.eclipse.papyrus.infra.core;bundle-version="[3.0.0,4.0.0)";vi
org.eclipse.papyrus.infra.tools;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.core.architecture;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %providerName
-Bundle-Version: 2.0.100.qualifier
+Bundle-Version: 2.1.0.qualifier
Eclipse-BuddyPolicy: dependent
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.infra.ui.Activator
Bundle-Description: Plugin dedicated to manage generic menus and actions,
linked to EMF but not to UML nor GMF technologies.
Bundle-SymbolicName: org.eclipse.papyrus.infra.ui;singleton:=true
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.cache;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.cache;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.ui
diff --git a/plugins/infra/ui/org.eclipse.papyrus.infra.ui/pom.xml b/plugins/infra/ui/org.eclipse.papyrus.infra.ui/pom.xml
index 4a1d577baa6..ef4ea5c457f 100644
--- a/plugins/infra/ui/org.eclipse.papyrus.infra.ui/pom.xml
+++ b/plugins/infra/ui/org.eclipse.papyrus.infra.ui/pom.xml
@@ -9,7 +9,7 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.ui</artifactId>
- <version>2.0.100-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<description>Plugin dedicated to manage generic menus and actions, linked to EMF but not to UML nor GMF technologies.</description>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/infra/ui/org.eclipse.papyrus.infra.widgets/META-INF/MANIFEST.MF b/plugins/infra/ui/org.eclipse.papyrus.infra.widgets/META-INF/MANIFEST.MF
index 33a14829ee4..74b2689da51 100644
--- a/plugins/infra/ui/org.eclipse.papyrus.infra.widgets/META-INF/MANIFEST.MF
+++ b/plugins/infra/ui/org.eclipse.papyrus.infra.widgets/META-INF/MANIFEST.MF
@@ -31,7 +31,7 @@ Export-Package: org.eclipse.papyrus.infra.widgets,
org.eclipse.papyrus.infra.widgets.wizard.pages
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.4.0.qualifier
+Bundle-Version: 3.5.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
@@ -39,5 +39,5 @@ Bundle-Activator: org.eclipse.papyrus.infra.widgets.Activator
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.infra.widgets;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.infra.widgets
diff --git a/plugins/infra/ui/org.eclipse.papyrus.infra.widgets/pom.xml b/plugins/infra/ui/org.eclipse.papyrus.infra.widgets/pom.xml
index 9625760f98a..fa6404e31ab 100644
--- a/plugins/infra/ui/org.eclipse.papyrus.infra.widgets/pom.xml
+++ b/plugins/infra/ui/org.eclipse.papyrus.infra.widgets/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.infra.widgets</artifactId>
- <version>3.4.0-SNAPSHOT</version>
+ <version>3.5.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/META-INF/MANIFEST.MF b/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/META-INF/MANIFEST.MF
index e56e5de8293..5ff43073616 100644
--- a/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/META-INF/MANIFEST.MF
+++ b/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/META-INF/MANIFEST.MF
@@ -12,7 +12,7 @@ Export-Package: org.eclipse.papyrus.uml.profile.types.generator.ui.internal,
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.3.0.qualifier
+Bundle-Version: 1.4.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-ManifestVersion: 2
@@ -20,5 +20,5 @@ Bundle-Activator: org.eclipse.papyrus.uml.profile.types.generator.ui.internal.Ac
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.profile.types.generator.ui;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.profile.types.generator.ui
diff --git a/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/pom.xml b/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/pom.xml
index 4594aa475e3..039d3743853 100644
--- a/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/pom.xml
+++ b/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator.ui/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.profile.types.generator.ui</artifactId>
- <version>1.3.0-SNAPSHOT</version>
+ <version>1.4.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java b/plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java
index e26ea46f4bb..aa688a72bae 100644
--- a/plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java
+++ b/plugins/toolsmiths/org.eclipse.papyrus.dev.project.management/src/org/eclipse/papyrus/dev/project/management/internal/operations/VersionRules.java
@@ -38,7 +38,7 @@ public class VersionRules {
new CurrentVersionRule(), // The default behaviour
new FixedRangeRule(dep -> dep.startsWith("org.apache.batik"), "[1.6.0,1.7.0)"), //$NON-NLS-1$//$NON-NLS-2$
new SkipRule("com.ibm.icu"), //$NON-NLS-1$
- new FixedRangeRule("com.google.guava", "21.0.0") //$NON-NLS-1$
+ new FixedRangeRule("com.google.guava", "27.1.0") //$NON-NLS-1$
);
public VersionRules() {
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.releng.dev.release/release.digest b/plugins/toolsmiths/org.eclipse.papyrus.releng.dev.release/release.digest
index 82a78d1c29f..8db93068100 100755
--- a/plugins/toolsmiths/org.eclipse.papyrus.releng.dev.release/release.digest
+++ b/plugins/toolsmiths/org.eclipse.papyrus.releng.dev.release/release.digest
Binary files differ
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.releng.dev.release/release.xml b/plugins/toolsmiths/org.eclipse.papyrus.releng.dev.release/release.xml
index 72adb33c19a..f6bffe3e94d 100755
--- a/plugins/toolsmiths/org.eclipse.papyrus.releng.dev.release/release.xml
+++ b/plugins/toolsmiths/org.eclipse.papyrus.releng.dev.release/release.xml
@@ -44,24 +44,27 @@
<plugin name="org.eclipse.papyrus.toolsmiths.palette" version="3.0.100"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.paletteconfiguration.editor" version="3.1.1"/>
<plugin name="org.eclipse.papyrus.views.properties.toolsmiths" version="2.0.2"/>
- <plugin name="org.eclipse.papyrus.uml.properties.generation" version="2.1.0"/>
+ <plugin name="org.eclipse.papyrus.uml.properties.generation" version="2.1.100"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.expansion.edit" version="2.1.0"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.expansion.editor" version="2.1.0"/>
<plugin name="org.eclipse.papyrus.infra.emf.types.ui.properties" version="3.0.0"/>
+ <plugin name="org.eclipse.papyrus.toolsmiths.ecore" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.toolsmiths.expressions" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.uml.types.ui.properties" version="3.1.100"/>
<plugin name="org.eclipse.papyrus.toolsmiths.profilemigration" version="0.7.200"/>
<plugin name="org.eclipse.papyrus.toolsmiths.profilemigration.ui" version="0.8.0"/>
<plugin name="org.eclipse.papyrus.toolsmiths" version="1.2.0"/>
</feature>
- <feature name="org.eclipse.papyrus.uml.m2m.qvto.tests.tools.feature" version="1.0.0">
- <feature name="org.eclipse.license" version="2.0.0" license="true"/>
- <plugin name="org.eclipse.papyrus.uml.m2m.qvto.tests.tools" version="1.0.0"/>
- </feature>
<feature name="org.eclipse.papyrus.toolsmiths.validation.feature" version="1.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
<plugin name="org.eclipse.papyrus.toolsmiths.validation.common" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.toolsmiths.validation.profile" version="1.0.0"/>
+ <plugin name="org.eclipse.papyrus.toolsmiths.validation.elementtypes" version="1.0.0"/>
+ <plugin name="org.eclipse.papyrus.dev.ui" version="0.0.1"/>
+ </feature>
+ <feature name="org.eclipse.papyrus.uml.m2m.qvto.tests.tools.feature" version="1.0.0">
+ <feature name="org.eclipse.license" version="2.0.0" license="true"/>
+ <plugin name="org.eclipse.papyrus.uml.m2m.qvto.tests.tools" version="1.0.0"/>
</feature>
<feature name="org.eclipse.papyrus.user.examples.feature" version="0.0.1">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
@@ -116,10 +119,14 @@
<plugin name="org.eclipse.papyrus.releng.dev.release" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.releng.tools" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.toolsmiths" version="1.2.0"/>
+ <plugin name="org.eclipse.papyrus.toolsmiths.ecore" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.toolsmiths.expressions" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.toolsmiths.palette" version="3.0.100"/>
<plugin name="org.eclipse.papyrus.toolsmiths.profilemigration" version="0.7.200"/>
<plugin name="org.eclipse.papyrus.toolsmiths.profilemigration.ui" version="0.8.0"/>
+ <plugin name="org.eclipse.papyrus.toolsmiths.validation.common" version="1.0.0"/>
+ <plugin name="org.eclipse.papyrus.toolsmiths.validation.elementtypes" version="1.0.0"/>
+ <plugin name="org.eclipse.papyrus.toolsmiths.validation.profile" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.emftree" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.uml.m2m.qvto.tests.tools" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.uml.profile.assistants.generator" version="4.0.0"/>
@@ -128,7 +135,7 @@
<plugin name="org.eclipse.papyrus.uml.profile.newchildmenu.generator.ui" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.uml.profile.types.generator" version="2.2.0"/>
<plugin name="org.eclipse.papyrus.uml.profile.types.generator.ui" version="1.3.0"/>
- <plugin name="org.eclipse.papyrus.uml.properties.generation" version="2.1.0"/>
+ <plugin name="org.eclipse.papyrus.uml.properties.generation" version="2.1.100"/>
<plugin name="org.eclipse.papyrus.uml.types.ui.properties" version="3.1.100"/>
<plugin name="org.eclipse.papyrus.views.properties.toolsmiths" version="2.0.2"/>
</release>
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.releng.main.release/release.digest b/plugins/toolsmiths/org.eclipse.papyrus.releng.main.release/release.digest
index e7992b2ba8f..5749abfda91 100755
--- a/plugins/toolsmiths/org.eclipse.papyrus.releng.main.release/release.digest
+++ b/plugins/toolsmiths/org.eclipse.papyrus.releng.main.release/release.digest
Binary files differ
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.releng.main.release/release.xml b/plugins/toolsmiths/org.eclipse.papyrus.releng.main.release/release.xml
index d90ce35e7f2..b3a173301eb 100755
--- a/plugins/toolsmiths/org.eclipse.papyrus.releng.main.release/release.xml
+++ b/plugins/toolsmiths/org.eclipse.papyrus.releng.main.release/release.xml
@@ -81,9 +81,10 @@
<plugin name="org.eclipse.papyrus.emf.facet.widgets.celleditors" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.emf.facet.widgets.celleditors.ecore" version="1.2.0"/>
</feature>
- <feature name="org.eclipse.papyrus.emf.feature" version="1.0.0">
+ <feature name="org.eclipse.papyrus.emf.feature" version="1.1.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
<plugin name="org.eclipse.papyrus.emf" version="1.0.0"/>
+ <plugin name="org.eclipse.papyrus.emf.ui" version="1.0.0"/>
</feature>
<feature name="org.eclipse.papyrus.infra.architecture.feature" version="1.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
@@ -94,21 +95,21 @@
</feature>
<feature name="org.eclipse.papyrus.infra.core.feature" version="3.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
- <plugin name="org.eclipse.papyrus.infra.core" version="3.0.100"/>
+ <plugin name="org.eclipse.papyrus.infra.core" version="3.0.200"/>
<plugin name="org.eclipse.papyrus.infra.core.architecture" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.infra.core.architecture.edit" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.infra.core.log" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.infra.core.sasheditor" version="2.1.0"/>
- <plugin name="org.eclipse.papyrus.infra.core.sasheditor.di" version="2.0.0"/>
- <plugin name="org.eclipse.papyrus.infra.core.sashwindows.di" version="1.2.0"/>
- <plugin name="org.eclipse.papyrus.infra.tools" version="3.0.0"/>
+ <plugin name="org.eclipse.papyrus.infra.core.sasheditor.di" version="2.0.100"/>
+ <plugin name="org.eclipse.papyrus.infra.core.sashwindows.di" version="1.3.0"/>
+ <plugin name="org.eclipse.papyrus.infra.tools" version="3.1.0"/>
</feature>
<feature name="org.eclipse.papyrus.infra.emf.expressions.feature" version="1.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
- <plugin name="org.eclipse.papyrus.infra.emf.expressions" version="1.0.0"/>
- <plugin name="org.eclipse.papyrus.infra.emf.expressions.edit" version="1.0.0"/>
- <plugin name="org.eclipse.papyrus.infra.emf.expressions.editor" version="1.0.0"/>
- <plugin name="org.eclipse.papyrus.infra.emf.expressions.properties" version="1.0.0"/>
+ <plugin name="org.eclipse.papyrus.infra.emf.expressions" version="1.1.0"/>
+ <plugin name="org.eclipse.papyrus.infra.emf.expressions.edit" version="1.1.0"/>
+ <plugin name="org.eclipse.papyrus.infra.emf.expressions.editor" version="1.1.0"/>
+ <plugin name="org.eclipse.papyrus.infra.emf.expressions.properties" version="1.0.100"/>
</feature>
<feature name="org.eclipse.papyrus.infra.emf.feature" version="3.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
@@ -156,7 +157,7 @@
</feature>
<feature name="org.eclipse.papyrus.infra.gmfdiag.css.feature" version="3.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
- <plugin name="org.eclipse.papyrus.infra.gmfdiag.css" version="2.3.0"/>
+ <plugin name="org.eclipse.papyrus.infra.gmfdiag.css" version="2.3.100"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.css.configuration" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.css.properties" version="3.0.0"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.css3.xtext" version="3.0.0"/>
@@ -173,7 +174,7 @@
<plugin name="org.eclipse.papyrus.infra.gmfdiag.preferences" version="3.0.0"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.properties" version="4.0.100"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.widgets" version="1.2.0"/>
- <plugin name="org.eclipse.papyrus.infra.gmfdiag.common" version="3.101.0"/>
+ <plugin name="org.eclipse.papyrus.infra.gmfdiag.common" version="3.101.200"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.expansion" version="3.0.0"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.gef" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.modelexplorer" version="1.2.0"/>
@@ -216,7 +217,7 @@
<plugin name="org.eclipse.papyrus.infra.nattable.model" version="4.1.0"/>
<plugin name="org.eclipse.papyrus.infra.nattable.model.edit" version="4.0.100"/>
<plugin name="org.eclipse.papyrus.infra.nattable.model.editor" version="5.0.0"/>
- <plugin name="org.eclipse.papyrus.infra.nattable" version="6.1.0"/>
+ <plugin name="org.eclipse.papyrus.infra.nattable" version="6.2.0"/>
<plugin name="org.eclipse.papyrus.infra.nattable.common" version="5.1.0"/>
<plugin name="org.eclipse.papyrus.infra.nattable.modelexplorer" version="4.0.100"/>
<plugin name="org.eclipse.papyrus.infra.nattable.views.config" version="5.0.0"/>
@@ -252,7 +253,7 @@
</feature>
<feature name="org.eclipse.papyrus.infra.ui.feature" version="3.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
- <plugin name="org.eclipse.papyrus.infra.ui" version="2.0.0"/>
+ <plugin name="org.eclipse.papyrus.infra.ui" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.infra.ui.architecture" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.infra.onefile.ui" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.infra.ui.emf" version="2.1.0"/>
@@ -279,18 +280,18 @@
<plugin name="org.eclipse.papyrus.infra.widgets.toolbox" version="2.0.0"/>
<plugin name="org.eclipse.nebula.widgets.richtext" version="1.2.0"/>
</feature>
- <feature name="org.eclipse.papyrus.sdk.feature" version="4.2.0">
+ <feature name="org.eclipse.papyrus.sdk.feature" version="4.5.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
<feature name="org.eclipse.papyrus.infra.feature" version="3.0.0"/>
<feature name="org.eclipse.papyrus.editor.feature" version="2.0.0"/>
- <feature name="org.eclipse.papyrus.emf.feature" version="1.0.0"/>
+ <feature name="org.eclipse.papyrus.emf.feature" version="1.1.0"/>
<feature name="org.eclipse.papyrus.emf.facet.feature" version="3.0.0"/>
<feature name="org.eclipse.papyrus.uml.feature" version="4.0.0"/>
<feature name="org.eclipse.papyrus.views.feature" version="1.0.0"/>
<feature name="org.eclipse.papyrus.doc.feature" version="3.1.0"/>
- <plugin name="com.google.guava" version="21.0.0"/>
+ <plugin name="com.google.guava" version="27.1.0"/>
<plugin name="com.google.gson" version="2.7.0"/>
- <plugin name="org.eclipse.papyrus.sdk" version="4.2.0"/>
+ <plugin name="org.eclipse.papyrus.sdk" version="4.5.0"/>
</feature>
<feature name="org.eclipse.papyrus.uml.alf.feature" version="3.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
@@ -327,27 +328,27 @@
</feature>
<feature name="org.eclipse.papyrus.uml.diagram.feature" version="3.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.clazz" version="3.0.200"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.common" version="3.3.100"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.clazz" version="3.1.0"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.common" version="3.3.200"/>
<plugin name="org.eclipse.papyrus.uml.diagram.common.groups" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.component" version="3.2.0"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.deployment" version="3.1.200"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.deployment" version="3.2.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.icons" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.menu" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.uml.diagram.modelexplorer" version="1.2.100"/>
<plugin name="org.eclipse.papyrus.uml.diagram.navigation" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.profile" version="3.1.0"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.statemachine" version="3.1.100"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.statemachine" version="3.1.200"/>
<plugin name="org.eclipse.papyrus.uml.diagram.usecase" version="4.0.200"/>
<plugin name="org.eclipse.papyrus.uml.diagram.wizards" version="3.2.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.communication" version="4.0.100"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.sequence" version="5.1.100"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.activity" version="3.4.0"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.sequence" version="5.2.100"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.activity" version="3.5.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.composite" version="3.1.100"/>
<plugin name="org.eclipse.papyrus.uml.diagram.dnd" version="1.3.100"/>
<plugin name="org.eclipse.papyrus.uml.diagram.stereotype.edition" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.uml.diagram.timing" version="1.4.200"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.interactionoverview" version="3.0.100"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.interactionoverview" version="3.0.200"/>
<plugin name="org.eclipse.papyrus.uml.diagram.symbols" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.symbols.properties" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.linklf" version="2.0.100"/>
@@ -355,8 +356,8 @@
</feature>
<feature name="org.eclipse.papyrus.uml.expressions.feature" version="1.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
- <plugin name="org.eclipse.papyrus.uml.expressions" version="2.0.0"/>
- <plugin name="org.eclipse.papyrus.uml.expressions.edit" version="2.0.0"/>
+ <plugin name="org.eclipse.papyrus.uml.expressions" version="2.1.0"/>
+ <plugin name="org.eclipse.papyrus.uml.expressions.edit" version="2.1.0"/>
<plugin name="org.eclipse.papyrus.uml.expressions.properties" version="1.0.100"/>
</feature>
<feature name="org.eclipse.papyrus.uml.feature" version="4.0.0">
@@ -387,7 +388,7 @@
<plugin name="org.eclipse.papyrus.uml.profile" version="3.1.100"/>
<plugin name="org.eclipse.papyrus.uml.profile.drafter" version="1.3.0"/>
<plugin name="org.eclipse.papyrus.uml.resourceloading.profile" version="1.2.100"/>
- <plugin name="org.eclipse.papyrus.uml.service.types" version="4.1.0"/>
+ <plugin name="org.eclipse.papyrus.uml.service.types" version="4.3.0"/>
<plugin name="org.eclipse.papyrus.uml.service.types.ui" version="2.1.0"/>
<plugin name="org.eclipse.papyrus.uml.templaterepository" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.uml.documentation.profile" version="1.3.0"/>
@@ -404,12 +405,12 @@
<feature name="org.eclipse.papyrus.uml.internationalization.feature" version="1.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
<plugin name="org.eclipse.papyrus.uml.internationalization" version="1.0.0"/>
- <plugin name="org.eclipse.papyrus.uml.internationalization.edit" version="1.100.0"/>
+ <plugin name="org.eclipse.papyrus.uml.internationalization.edit" version="1.100.100"/>
<plugin name="org.eclipse.papyrus.uml.internationalization.utils" version="1.0.0"/>
</feature>
<feature name="org.eclipse.papyrus.uml.m2m.qvto.feature" version="1.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
- <plugin name="org.eclipse.papyrus.uml.m2m.qvto.common" version="1.0.100"/>
+ <plugin name="org.eclipse.papyrus.uml.m2m.qvto.common" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.uml.m2m.qvto.common.blackboxes" version="1.0.0"/>
</feature>
<feature name="org.eclipse.papyrus.uml.modelexplorer.feature" version="2.0.0">
@@ -419,7 +420,7 @@
</feature>
<feature name="org.eclipse.papyrus.uml.nattable.feature" version="4.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
- <plugin name="org.eclipse.papyrus.uml.nattable" version="5.2.0"/>
+ <plugin name="org.eclipse.papyrus.uml.nattable" version="5.2.300"/>
<plugin name="org.eclipse.papyrus.uml.nattable.generic" version="1.2.100"/>
<plugin name="org.eclipse.papyrus.uml.nattable.generic.config" version="1.2.100"/>
<plugin name="org.eclipse.papyrus.uml.nattable.matrix" version="1.0.200"/>
@@ -434,7 +435,7 @@
</feature>
<feature name="org.eclipse.papyrus.uml.properties.feature" version="3.0.0">
<feature name="org.eclipse.license" version="2.0.0" license="true"/>
- <plugin name="org.eclipse.papyrus.uml.properties" version="3.2.0"/>
+ <plugin name="org.eclipse.papyrus.uml.properties" version="3.3.0"/>
<plugin name="org.eclipse.papyrus.uml.properties.xtext" version="1.3.0"/>
</feature>
<feature name="org.eclipse.papyrus.uml.search.feature" version="2.0.0">
@@ -523,7 +524,7 @@
</feature>
<plugin name="ca.odell.glazedlists" version="1.9.0"/>
<plugin name="com.google.gson" version="2.7.0"/>
- <plugin name="com.google.guava" version="21.0.0"/>
+ <plugin name="com.google.guava" version="27.1.0"/>
<plugin name="org.eclipse.nebula.cwt" version="1.0.0"/>
<plugin name="org.eclipse.nebula.widgets.nattable.core" version="1.5.0"/>
<plugin name="org.eclipse.nebula.widgets.nattable.extension.glazedlists" version="1.5.0"/>
@@ -579,6 +580,7 @@
<plugin name="org.eclipse.papyrus.emf.facet.widgets" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.emf.facet.widgets.celleditors" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.emf.facet.widgets.celleditors.ecore" version="1.2.0"/>
+ <plugin name="org.eclipse.papyrus.emf.ui" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.extensionpoints.editors" version="3.1.0"/>
<plugin name="org.eclipse.papyrus.infra.architecture" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.infra.architecture.doc" version="1.0.0"/>
@@ -588,13 +590,13 @@
<plugin name="org.eclipse.papyrus.infra.constraints.edit" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.infra.constraints.editor" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.infra.constraints.ui" version="2.0.0"/>
- <plugin name="org.eclipse.papyrus.infra.core" version="3.0.100"/>
+ <plugin name="org.eclipse.papyrus.infra.core" version="3.0.200"/>
<plugin name="org.eclipse.papyrus.infra.core.architecture" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.infra.core.architecture.edit" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.infra.core.log" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.infra.core.sasheditor" version="2.1.0"/>
- <plugin name="org.eclipse.papyrus.infra.core.sasheditor.di" version="2.0.0"/>
- <plugin name="org.eclipse.papyrus.infra.core.sashwindows.di" version="1.2.0"/>
+ <plugin name="org.eclipse.papyrus.infra.core.sasheditor.di" version="2.0.100"/>
+ <plugin name="org.eclipse.papyrus.infra.core.sashwindows.di" version="1.3.0"/>
<plugin name="org.eclipse.papyrus.infra.doc" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.infra.editor.welcome" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.infra.editor.welcome.internationalization" version="2.0.0"/>
@@ -602,11 +604,11 @@
<plugin name="org.eclipse.papyrus.infra.emf" version="3.0.0"/>
<plugin name="org.eclipse.papyrus.infra.emf.appearance" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.infra.emf.diagram.common" version="2.0.0"/>
- <plugin name="org.eclipse.papyrus.infra.emf.expressions" version="1.0.0"/>
+ <plugin name="org.eclipse.papyrus.infra.emf.expressions" version="1.1.0"/>
<plugin name="org.eclipse.papyrus.infra.emf.expressions.doc" version="1.0.0"/>
- <plugin name="org.eclipse.papyrus.infra.emf.expressions.edit" version="1.0.0"/>
- <plugin name="org.eclipse.papyrus.infra.emf.expressions.editor" version="1.0.0"/>
- <plugin name="org.eclipse.papyrus.infra.emf.expressions.properties" version="1.0.0"/>
+ <plugin name="org.eclipse.papyrus.infra.emf.expressions.edit" version="1.1.0"/>
+ <plugin name="org.eclipse.papyrus.infra.emf.expressions.editor" version="1.1.0"/>
+ <plugin name="org.eclipse.papyrus.infra.emf.expressions.properties" version="1.0.100"/>
<plugin name="org.eclipse.papyrus.infra.emf.gmf" version="1.2.100"/>
<plugin name="org.eclipse.papyrus.infra.emf.nattable" version="5.1.0"/>
<plugin name="org.eclipse.papyrus.infra.emf.readonly" version="3.0.0"/>
@@ -621,10 +623,10 @@
<plugin name="org.eclipse.papyrus.infra.gmfdiag.assistant.ui" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.canonical" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.commands" version="3.0.0"/>
- <plugin name="org.eclipse.papyrus.infra.gmfdiag.common" version="3.101.0"/>
+ <plugin name="org.eclipse.papyrus.infra.gmfdiag.common" version="3.101.200"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.common.doc" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.controlmode" version="1.2.0"/>
- <plugin name="org.eclipse.papyrus.infra.gmfdiag.css" version="2.3.0"/>
+ <plugin name="org.eclipse.papyrus.infra.gmfdiag.css" version="2.3.100"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.css.configuration" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.css.doc" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.infra.gmfdiag.css.model" version="1.3.0"/>
@@ -668,7 +670,7 @@
<plugin name="org.eclipse.papyrus.infra.internationalization.readonly" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.infra.internationalization.ui" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.infra.internationalization.utils" version="1.0.100"/>
- <plugin name="org.eclipse.papyrus.infra.nattable" version="6.1.0"/>
+ <plugin name="org.eclipse.papyrus.infra.nattable" version="6.2.0"/>
<plugin name="org.eclipse.papyrus.infra.nattable.common" version="5.1.0"/>
<plugin name="org.eclipse.papyrus.infra.nattable.controlmode" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.infra.nattable.doc" version="1.3.0"/>
@@ -714,7 +716,7 @@
<plugin name="org.eclipse.papyrus.infra.services.viewersearch" version="3.0.0"/>
<plugin name="org.eclipse.papyrus.infra.services.viewlabelprovider" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.infra.sync" version="2.0.0"/>
- <plugin name="org.eclipse.papyrus.infra.tools" version="3.0.0"/>
+ <plugin name="org.eclipse.papyrus.infra.tools" version="3.1.0"/>
<plugin name="org.eclipse.papyrus.infra.types" version="4.0.0"/>
<plugin name="org.eclipse.papyrus.infra.types.core" version="4.0.0"/>
<plugin name="org.eclipse.papyrus.infra.types.doc" version="3.0.0"/>
@@ -722,7 +724,7 @@
<plugin name="org.eclipse.papyrus.infra.types.editor" version="3.1.0"/>
<plugin name="org.eclipse.papyrus.infra.types.rulebased" version="4.0.0"/>
<plugin name="org.eclipse.papyrus.infra.types.ui" version="3.0.100"/>
- <plugin name="org.eclipse.papyrus.infra.ui" version="2.0.0"/>
+ <plugin name="org.eclipse.papyrus.infra.ui" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.infra.ui.architecture" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.infra.ui.emf" version="2.1.0"/>
<plugin name="org.eclipse.papyrus.infra.ui.fonts" version="1.0.0"/>
@@ -732,7 +734,7 @@
<plugin name="org.eclipse.papyrus.infra.widgets.toolbox" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.releng.main.release" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.req.reqif.doc" version="1.2.0"/>
- <plugin name="org.eclipse.papyrus.sdk" version="4.2.0"/>
+ <plugin name="org.eclipse.papyrus.sdk" version="4.5.0"/>
<plugin name="org.eclipse.papyrus.toolsmiths.profilemigration.doc" version="0.7.0"/>
<plugin name="org.eclipse.papyrus.uml.alf" version="3.0.0"/>
<plugin name="org.eclipse.papyrus.uml.alf.common" version="2.0.0"/>
@@ -749,39 +751,40 @@
<plugin name="org.eclipse.papyrus.uml.decoratormodel.doc" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.uml.decoratormodel.properties" version="4.0.0"/>
<plugin name="org.eclipse.papyrus.uml.decoratormodel.ui" version="2.0.0"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.activity" version="3.4.0"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.clazz" version="3.0.200"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.common" version="3.3.100"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.activity" version="3.5.0"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.clazz" version="3.1.0"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.common" version="3.3.200"/>
<plugin name="org.eclipse.papyrus.uml.diagram.common.doc" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.common.groups" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.communication" version="4.0.100"/>
<plugin name="org.eclipse.papyrus.uml.diagram.component" version="3.2.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.composite" version="3.1.100"/>
<plugin name="org.eclipse.papyrus.uml.diagram.css" version="2.0.100"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.deployment" version="3.1.200"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.deployment" version="3.2.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.dnd" version="1.3.100"/>
<plugin name="org.eclipse.papyrus.uml.diagram.icons" version="1.2.0"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.interactionoverview" version="3.0.100"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.interactionoverview" version="3.0.200"/>
<plugin name="org.eclipse.papyrus.uml.diagram.linklf" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.uml.diagram.menu" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.uml.diagram.modelexplorer" version="1.2.100"/>
<plugin name="org.eclipse.papyrus.uml.diagram.navigation" version="2.0.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.profile" version="3.1.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.profile.doc" version="1.2.0"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.sequence" version="5.1.100"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.sequence" version="5.2.100"/>
<plugin name="org.eclipse.papyrus.uml.diagram.sequence.restrictions" version="1.0.0"/>
- <plugin name="org.eclipse.papyrus.uml.diagram.statemachine" version="3.1.100"/>
+ <plugin name="org.eclipse.papyrus.uml.diagram.statemachine" version="3.1.200"/>
<plugin name="org.eclipse.papyrus.uml.diagram.stereotype.edition" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.uml.diagram.symbols" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.symbols.properties" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.uml.diagram.timing" version="1.4.200"/>
<plugin name="org.eclipse.papyrus.uml.diagram.usecase" version="4.0.200"/>
<plugin name="org.eclipse.papyrus.uml.diagram.wizards" version="3.2.0"/>
+ <plugin name="org.eclipse.papyrus.uml.disable.helper.advices.example" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.uml.doc" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.uml.documentation.profile" version="1.3.0"/>
<plugin name="org.eclipse.papyrus.uml.export" version="1.0.0"/>
- <plugin name="org.eclipse.papyrus.uml.expressions" version="2.0.0"/>
- <plugin name="org.eclipse.papyrus.uml.expressions.edit" version="2.0.0"/>
+ <plugin name="org.eclipse.papyrus.uml.expressions" version="2.1.0"/>
+ <plugin name="org.eclipse.papyrus.uml.expressions.edit" version="2.1.0"/>
<plugin name="org.eclipse.papyrus.uml.expressions.properties" version="1.0.100"/>
<plugin name="org.eclipse.papyrus.uml.extensionpoints" version="1.3.0"/>
<plugin name="org.eclipse.papyrus.uml.filters" version="1.3.0"/>
@@ -789,15 +792,15 @@
<plugin name="org.eclipse.papyrus.uml.icons" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.uml.import" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.uml.internationalization" version="1.0.0"/>
- <plugin name="org.eclipse.papyrus.uml.internationalization.edit" version="1.100.0"/>
+ <plugin name="org.eclipse.papyrus.uml.internationalization.edit" version="1.100.100"/>
<plugin name="org.eclipse.papyrus.uml.internationalization.utils" version="1.0.0"/>
- <plugin name="org.eclipse.papyrus.uml.m2m.qvto.common" version="1.0.100"/>
+ <plugin name="org.eclipse.papyrus.uml.m2m.qvto.common" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.uml.m2m.qvto.common.blackboxes" version="1.0.0"/>
<plugin name="org.eclipse.papyrus.uml.modelexplorer" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.uml.modelexplorer.widgets" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.uml.modelrepair" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.uml.modelrepair.doc" version="1.2.0"/>
- <plugin name="org.eclipse.papyrus.uml.nattable" version="5.2.0"/>
+ <plugin name="org.eclipse.papyrus.uml.nattable" version="5.2.300"/>
<plugin name="org.eclipse.papyrus.uml.nattable.clazz.config" version="5.0.0"/>
<plugin name="org.eclipse.papyrus.uml.nattable.generic" version="1.2.100"/>
<plugin name="org.eclipse.papyrus.uml.nattable.generic.config" version="1.2.100"/>
@@ -821,13 +824,13 @@
<plugin name="org.eclipse.papyrus.uml.profile.newchildmenu.generator.ui" version="1.2.0"/>
<plugin name="org.eclipse.papyrus.uml.profile.types.generator" version="2.2.0"/>
<plugin name="org.eclipse.papyrus.uml.profile.types.generator.ui" version="1.3.0"/>
- <plugin name="org.eclipse.papyrus.uml.properties" version="3.2.0"/>
- <plugin name="org.eclipse.papyrus.uml.properties.generation" version="2.1.0"/>
+ <plugin name="org.eclipse.papyrus.uml.properties" version="3.3.0"/>
+ <plugin name="org.eclipse.papyrus.uml.properties.generation" version="2.1.100"/>
<plugin name="org.eclipse.papyrus.uml.properties.xtext" version="1.3.0"/>
<plugin name="org.eclipse.papyrus.uml.resourceloading.profile" version="1.2.100"/>
<plugin name="org.eclipse.papyrus.uml.search.ui" version="2.0.100"/>
<plugin name="org.eclipse.papyrus.uml.search.ui.doc" version="1.2.0"/>
- <plugin name="org.eclipse.papyrus.uml.service.types" version="4.1.0"/>
+ <plugin name="org.eclipse.papyrus.uml.service.types" version="4.3.0"/>
<plugin name="org.eclipse.papyrus.uml.service.types.ui" version="2.1.0"/>
<plugin name="org.eclipse.papyrus.uml.service.validation" version="2.1.0"/>
<plugin name="org.eclipse.papyrus.uml.services.decoration" version="1.2.0"/>
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.releng.tools/META-INF/MANIFEST.MF b/plugins/toolsmiths/org.eclipse.papyrus.releng.tools/META-INF/MANIFEST.MF
index fe994750228..7661c2a2fa9 100755
--- a/plugins/toolsmiths/org.eclipse.papyrus.releng.tools/META-INF/MANIFEST.MF
+++ b/plugins/toolsmiths/org.eclipse.papyrus.releng.tools/META-INF/MANIFEST.MF
@@ -12,12 +12,12 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
org.eclipse.cbi.targetplatform.model;bundle-version="[3.0.0,4.0.0)"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 2.1.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.releng.tools.internal.Activator
Bundle-SymbolicName: org.eclipse.papyrus.releng.tools;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.releng.tools
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.releng.tools/pom.xml b/plugins/toolsmiths/org.eclipse.papyrus.releng.tools/pom.xml
index a4ea710f78a..b57fe2e800c 100644
--- a/plugins/toolsmiths/org.eclipse.papyrus.releng.tools/pom.xml
+++ b/plugins/toolsmiths/org.eclipse.papyrus.releng.tools/pom.xml
@@ -9,6 +9,6 @@
</parent>
<artifactId>org.eclipse.papyrus.releng.tools</artifactId>
<groupId>org.eclipse.papyrus</groupId>
- <version>2.0.0-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/META-INF/MANIFEST.MF b/plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/META-INF/MANIFEST.MF
index 9d1a4a689b6..4d296a028e1 100644
--- a/plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/META-INF/MANIFEST.MF
+++ b/plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Bundle-Name
Bundle-SymbolicName: org.eclipse.papyrus.uml.m2m.qvto.tests.tools;singleton:=true
-Bundle-Version: 1.0.0.qualifier
+Bundle-Version: 1.1.0.qualifier
Bundle-Vendor: %Bundle-Vendor
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)",
@@ -13,7 +13,7 @@ Require-Bundle: org.eclipse.papyrus.infra.core.log;bundle-version="[1.2.0,2.0.0)
org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.papyrus.junit.utils;bundle-version="[2.0.0,3.0.0)",
org.eclipse.emf.compare;bundle-version="[3.3.0,4.0.0)",
- com.google.guava;bundle-version="[21.0.0, 22.0.0)",
+ com.google.guava;bundle-version="[27.1.0, 28.0.0)",
org.eclipse.gmf.runtime.notation.edit;bundle-version="[1.0.0,2.0.0)",
org.eclipse.papyrus.infra.constraints;bundle-version="[2.0.0,3.0.0)"
Bundle-Activator: org.eclipse.papyrus.uml.m2m.qvto.tests.tools.Activator
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/pom.xml b/plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/pom.xml
index b980b71640e..61f00ab1fef 100644
--- a/plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/pom.xml
+++ b/plugins/toolsmiths/org.eclipse.papyrus.uml.m2m.qvto.tests.tools/pom.xml
@@ -10,6 +10,6 @@
<groupId>org.eclipse.papyrus</groupId>
<artifactId>org.eclipse.papyrus.uml.m2m.qvto.tests.tools</artifactId>
<description>Papyrus Model to Model with QvTo tools help methods for tests</description>
- <version>1.0.0-SNAPSHOT</version>
+ <version>1.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/META-INF/MANIFEST.MF b/plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/META-INF/MANIFEST.MF
index 487b0a4de72..9e0ab04b76d 100644
--- a/plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/META-INF/MANIFEST.MF
+++ b/plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/META-INF/MANIFEST.MF
@@ -2,10 +2,10 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.toolsmiths.profilemigration;singleton:=true
-Bundle-Version: 0.7.200.qualifier
+Bundle-Version: 0.8.0.qualifier
Bundle-ClassPath: .
Require-Bundle: org.eclipse.ui,
- com.google.guava;bundle-version="[21.0.0, 22.0.0)",
+ com.google.guava;bundle-version="[27.1.0, 28.0.0)",
org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)",
org.eclipse.emf.compare;bundle-version="[3.3.0,4.0.0)",
org.eclipse.papyrus.uml.service.types;bundle-version="[4.0.0,5.0.0)",
diff --git a/plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/pom.xml b/plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/pom.xml
index a2b3afcced7..61b838e7ad7 100644
--- a/plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/pom.xml
+++ b/plugins/toolsmiths/profilemigration/org.eclipse.papyrus.toolsmiths.profilemigration/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.toolsmiths.profilemigration</artifactId>
- <version>0.7.200-SNAPSHOT</version>
+ <version>0.8.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/META-INF/MANIFEST.MF b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/META-INF/MANIFEST.MF
index 90d7e2500af..ab6cc2b07e5 100644
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/META-INF/MANIFEST.MF
+++ b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/META-INF/MANIFEST.MF
@@ -14,7 +14,7 @@ Export-Package: org.eclipse.papyrus.uml.decoratormodel.internal.controlmode;x-in
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.2.200.qualifier
+Bundle-Version: 1.3.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.uml.decoratormodel.internal.controlmode.Activator
@@ -22,6 +22,6 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.decoratormodel.controlmode;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.decoratormodel.controlmode
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/pom.xml b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/pom.xml
index 30b39699d8a..3f15e31a7c1 100644
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/pom.xml
+++ b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.controlmode/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.decoratormodel.controlmode</artifactId>
- <version>1.2.200-SNAPSHOT</version>
+ <version>1.3.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/META-INF/MANIFEST.MF b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/META-INF/MANIFEST.MF
index cff02b96aeb..dce4414d8c7 100644
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/META-INF/MANIFEST.MF
+++ b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/META-INF/MANIFEST.MF
@@ -11,14 +11,14 @@ Export-Package: org.eclipse.papyrus.uml.decoratormodel.internal.properties.const
org.eclipse.papyrus.uml.decoratormodel.properties.widgets
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy;exclude:="org.eclipse.papyrus.uml.decoratormodel.internal.properties.constraints"
-Bundle-Version: 4.0.0.qualifier
+Bundle-Version: 4.1.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.decoratormodel.properties.Activator
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.decoratormodel.properties;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.decoratormodel.properties
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/pom.xml b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/pom.xml
index f9e6e7b5da5..f93c977e53a 100644
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/pom.xml
+++ b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.properties/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.decoratormodel.properties</artifactId>
- <version>4.0.0-SNAPSHOT</version>
+ <version>4.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/META-INF/MANIFEST.MF b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/META-INF/MANIFEST.MF
index 8ab73c19322..1a4075a6c6c 100644
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/META-INF/MANIFEST.MF
+++ b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/META-INF/MANIFEST.MF
@@ -19,7 +19,7 @@ Export-Package: org.eclipse.papyrus.uml.decoratormodel.internal.ui,
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 2.1.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.uml.decoratormodel.internal.ui.Activator
@@ -27,8 +27,8 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.decoratormodel.ui;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)",
- com.google.common.eventbus;version="[21.0.0, 22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)",
+ com.google.common.eventbus;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.decoratormodel.ui
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/pom.xml b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/pom.xml
index 24d8642f3df..e14a7060c69 100644
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/pom.xml
+++ b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel.ui/pom.xml
@@ -7,6 +7,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.decoratormodel.ui</artifactId>
- <version>2.0.0-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/META-INF/MANIFEST.MF b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/META-INF/MANIFEST.MF
index ff0b20fb13b..dfd22be1cce 100755
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/META-INF/MANIFEST.MF
+++ b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/META-INF/MANIFEST.MF
@@ -26,7 +26,7 @@ Export-Package: org.eclipse.papyrus.uml.decoratormodel,
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy;exclude:=org.eclipse.papyrus.uml.decoratormodel.internal.expressions
Bundle-ClassPath: .
-Bundle-Version: 2.2.0.qualifier
+Bundle-Version: 2.3.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.uml.decoratormodel.Activator
@@ -34,7 +34,7 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.decoratormodel;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.decoratormodel
diff --git a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/pom.xml b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/pom.xml
index efd719fef44..3e4c9efa6a1 100644
--- a/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/pom.xml
+++ b/plugins/uml/decoratormodel/org.eclipse.papyrus.uml.decoratormodel/pom.xml
@@ -9,6 +9,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.decoratormodel</artifactId>
- <version>2.2.0-SNAPSHOT</version>
+ <version>2.3.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity/META-INF/MANIFEST.MF
index aad30c79e4a..1d76340bae0 100755
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.activity/META-INF/MANIFEST.MF
@@ -94,6 +94,6 @@ Bundle-Version: 3.5.0.qualifier
Bundle-Activator: org.eclipse.papyrus.uml.diagram.activity.part.UMLDiagramEditorPlugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.activity; singleton:=true
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.activity
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/META-INF/MANIFEST.MF
index 43515848f25..9f1ad764c40 100755
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/META-INF/MANIFEST.MF
@@ -79,11 +79,11 @@ Require-Bundle: org.eclipse.ui.navigator;visibility:=reexport;bundle-version="[3
org.eclipse.papyrus.infra.architecture;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %providerName
Eclipse-LazyStart: true
-Bundle-Version: 3.1.0.qualifier
+Bundle-Version: 3.2.0.qualifier
Bundle-Activator: org.eclipse.papyrus.uml.diagram.clazz.part.UMLDiagramEditorPlugin
Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.clazz; singleton:=true
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.clazz
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/pom.xml b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/pom.xml
index f715225e9d0..764ccb51332 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/pom.xml
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.diagram.clazz</artifactId>
- <version>3.1.0-SNAPSHOT</version>
+ <version>3.2.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
index e159e26e080..167b693620f 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/META-INF/MANIFEST.MF
@@ -92,11 +92,11 @@ Require-Bundle: org.eclipse.papyrus.infra.gmfdiag.extensionpoints.editors;bundle
org.eclipse.papyrus.infra.gmfdiag.style;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.infra.gmfdiag.representation;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %providerName
-Bundle-Version: 3.3.200.qualifier
+Bundle-Version: 3.4.0.qualifier
Eclipse-BuddyPolicy: dependent
Bundle-Activator: org.eclipse.papyrus.uml.diagram.common.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.common;singleton:=true
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.common
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/pom.xml b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/pom.xml
index e5dc27f122b..12a42669c42 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/pom.xml
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.common/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.diagram.common</artifactId>
- <version>3.3.200-SNAPSHOT</version>
+ <version>3.4.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/META-INF/MANIFEST.MF
index c920867fff0..1c8bee73836 100755
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/META-INF/MANIFEST.MF
@@ -72,9 +72,9 @@ Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.resources.editor.ide;bundle-v
org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[2.0.0,4.0.0)"
Bundle-Vendor: %providerName
Eclipse-LazyStart: true
-Bundle-Version: 4.0.100.qualifier
+Bundle-Version: 4.1.0.qualifier
Bundle-Activator: org.eclipse.papyrus.uml.diagram.communication.part.UMLDiagramEditorPlugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.communication; singleton:=true
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.communication
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/pom.xml b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/pom.xml
index 02095f46494..3ce5718e6c1 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/pom.xml
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.communication/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.diagram.communication</artifactId>
- <version>4.0.100-SNAPSHOT</version>
+ <version>4.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/META-INF/MANIFEST.MF
index 3bf35d011f6..45b6dfb6bb9 100755
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/META-INF/MANIFEST.MF
@@ -78,9 +78,9 @@ Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.providers.ide;bundle-version=
org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[2.0.0,4.0.0)"
Bundle-Vendor: %providerName
Eclipse-LazyStart: true
-Bundle-Version: 3.1.100.qualifier
+Bundle-Version: 3.2.0.qualifier
Bundle-Activator: org.eclipse.papyrus.uml.diagram.composite.part.UMLDiagramEditorPlugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.composite; singleton:=true
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.composite
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/pom.xml b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/pom.xml
index 28ccf020062..42dc8c0291b 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/pom.xml
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.composite/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.diagram.composite</artifactId>
- <version>3.1.100-SNAPSHOT</version>
+ <version>3.2.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/META-INF/MANIFEST.MF
index 69b1a1eb4ce..600dd8adff6 100755
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/META-INF/MANIFEST.MF
@@ -28,12 +28,12 @@ Require-Bundle: org.eclipse.gmf.runtime.diagram.ui.providers;bundle-version="[1.
org.eclipse.papyrus.infra.viewpoints.policy;bundle-version="[2.0.0,4.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.0.200.qualifier
+Bundle-Version: 3.1.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.uml.diagram.interactionoverview.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.interactionoverview;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.interactionoverview
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/pom.xml b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/pom.xml
index a22e0e7667c..5e122bbe239 100755
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/pom.xml
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.interactionoverview/pom.xml
@@ -7,6 +7,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.diagram.interactionoverview</artifactId>
- <version>3.0.200-SNAPSHOT</version>
+ <version>3.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/META-INF/MANIFEST.MF
index 056de662d8a..1ebb6665b24 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/META-INF/MANIFEST.MF
@@ -80,10 +80,10 @@ Require-Bundle: org.eclipse.papyrus.uml.profile;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.services.markerlistener;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %providerName
Eclipse-LazyStart: true
-Bundle-Version: 3.1.0.qualifier
+Bundle-Version: 3.2.0.qualifier
Bundle-Activator: org.eclipse.papyrus.uml.diagram.profile.part.UMLDiagramEditorPlugin
Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.profile; singleton:=true
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.profile
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/pom.xml b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/pom.xml
index d7bdf350f79..bccc1f259b6 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/pom.xml
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.profile/pom.xml
@@ -9,6 +9,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.diagram.profile</artifactId>
- <version>3.1.0-SNAPSHOT</version>
+ <version>3.2.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/META-INF/MANIFEST.MF
index 10d90a2eb81..c4addd602c9 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/META-INF/MANIFEST.MF
@@ -70,9 +70,9 @@ Require-Bundle: org.eclipse.ui.navigator;bundle-version="[3.6.0,4.0.0)";visibili
org.eclipse.papyrus.uml.service.validation;bundle-version="[2.1.0,3.0.0)",
org.eclipse.papyrus.infra.services.validation;bundle-version="[3.0.0,4.0.0)"
Bundle-Vendor: %providerName
-Bundle-Version: 5.2.100.qualifier
+Bundle-Version: 5.3.0.qualifier
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.diagram.sequence.part.UMLDiagramEditorPlugin
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.sequence; singleton:=true
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.sequence
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/pom.xml b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/pom.xml
index 170272d1c8d..a5e6fa6cb12 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/pom.xml
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.sequence/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.diagram.sequence</artifactId>
- <version>5.2.100-SNAPSHOT</version>
+ <version>5.3.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/META-INF/MANIFEST.MF b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/META-INF/MANIFEST.MF
index 25d8896abc1..c2da4ed418e 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/META-INF/MANIFEST.MF
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/META-INF/MANIFEST.MF
@@ -77,10 +77,10 @@ Require-Bundle: org.eclipse.emf.ecore;visibility:=reexport;bundle-version="[2.12
Bundle-Vendor: %providerName
Ant-Version: Apache Ant 1.7.0
Eclipse-LazyStart: true
-Bundle-Version: 3.1.200.qualifier
+Bundle-Version: 3.2.0.qualifier
Bundle-Activator: org.eclipse.papyrus.uml.diagram.statemachine.part.UMLDiagramEditorPlugin
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.diagram.statemachine; singleton:=true
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.diagram.statemachine
diff --git a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/pom.xml b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/pom.xml
index 6e6350ce012..74b610ea4b6 100644
--- a/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/pom.xml
+++ b/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.statemachine/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.diagram.statemachine</artifactId>
- <version>3.1.200-SNAPSHOT</version>
+ <version>3.2.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/META-INF/MANIFEST.MF b/plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/META-INF/MANIFEST.MF
index e71ab62f9a4..4cd668401cc 100644
--- a/plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/META-INF/MANIFEST.MF
+++ b/plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.papyrus.uml.m2m.qvto.common;singleton:=true
-Bundle-Version: 1.0.100.qualifier
+Bundle-Version: 1.1.0.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.papyrus.uml.m2m.qvto.common.Activator
Bundle-Vendor: %providerName
@@ -36,6 +36,6 @@ Export-Package: org.eclipse.papyrus.uml.m2m.qvto.common,
org.eclipse.papyrus.uml.m2m.qvto.common.MigrationParameters,
org.eclipse.papyrus.uml.m2m.qvto.common.MigrationParameters.impl,
org.eclipse.papyrus.uml.m2m.qvto.common.MigrationParameters.util
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.m2m.qvto.common
diff --git a/plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/pom.xml b/plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/pom.xml
index c4c19175576..18609b6c729 100644
--- a/plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/pom.xml
+++ b/plugins/uml/m2m/org.eclipse.papyrus.uml.m2m.qvto.common/pom.xml
@@ -9,6 +9,6 @@
</parent>
<artifactId>org.eclipse.papyrus.uml.m2m.qvto.common</artifactId>
<description>Papyrus Model to Model with QvTo transformations common plugin.</description>
- <version>1.0.100-SNAPSHOT</version>
+ <version>1.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF b/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF
index ba7bcfc6469..4ea839044a9 100644
--- a/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF
+++ b/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/META-INF/MANIFEST.MF
@@ -16,12 +16,12 @@ Require-Bundle: org.eclipse.papyrus.views.modelexplorer;bundle-version="[3.0.0,4
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 2.0.100.qualifier
+Bundle-Version: 2.1.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.modelexplorer.Activator
Bundle-SymbolicName: org.eclipse.papyrus.uml.modelexplorer;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.modelexplorer
diff --git a/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/pom.xml b/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/pom.xml
index 89f3bc8e2d5..bc22e59a0e2 100644
--- a/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/pom.xml
+++ b/plugins/uml/modelexplorer/org.eclipse.papyrus.uml.modelexplorer/pom.xml
@@ -7,6 +7,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.modelexplorer</artifactId>
- <version>2.0.100-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/META-INF/MANIFEST.MF
index 9aa053a5b66..722e03c1f71 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/META-INF/MANIFEST.MF
@@ -8,13 +8,13 @@ Require-Bundle: org.eclipse.papyrus.infra.services.controlmode;bundle-version="[
org.eclipse.emf.validation.ui;bundle-version="[1.7.0,2.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.0.100.qualifier
+Bundle-Version: 2.1.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.uml.controlmode.profile.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.controlmode.profile;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.controlmode.profile
diff --git a/plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/pom.xml b/plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/pom.xml
index 9ef2bf86c4c..34864229cf2 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/pom.xml
+++ b/plugins/uml/org.eclipse.papyrus.uml.controlmode.profile/pom.xml
@@ -7,6 +7,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.controlmode.profile</artifactId>
- <version>2.0.100-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/org.eclipse.papyrus.uml.filters/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.filters/META-INF/MANIFEST.MF
index fd4d1f123c1..65b0ca6acf8 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.filters/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.filters/META-INF/MANIFEST.MF
@@ -15,7 +15,7 @@ Export-Package: org.eclipse.papyrus.infra.filters.internal;x-internal:=true,
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .
-Bundle-Version: 1.3.0.qualifier
+Bundle-Version: 1.4.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.infra.filters.internal.UMLFiltersPlugin$Implementation
@@ -23,5 +23,5 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.filters;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.7
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.filters
diff --git a/plugins/uml/org.eclipse.papyrus.uml.filters/pom.xml b/plugins/uml/org.eclipse.papyrus.uml.filters/pom.xml
index bad4d045b91..0cd7c52571b 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.filters/pom.xml
+++ b/plugins/uml/org.eclipse.papyrus.uml.filters/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.filters</artifactId>
- <version>1.3.0-SNAPSHOT</version>
+ <version>1.4.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
</project>
diff --git a/plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF
index 6872f58a134..75225302d65 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.modelrepair/META-INF/MANIFEST.MF
@@ -16,15 +16,15 @@ Require-Bundle: org.eclipse.papyrus.uml.extensionpoints;bundle-version="[1.2.0,2
org.eclipse.uml2.uml.edit;bundle-version="[5.3.0,6.0.0)"
Bundle-Vendor: Eclipse Modeling Project
Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.0.100.qualifier
+Bundle-Version: 2.1.0.qualifier
Bundle-Name: Model Repair
Bundle-Activator: org.eclipse.papyrus.uml.modelrepair.Activator
Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.modelrepair;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)",
- com.google.common.eventbus;version="[21.0.0, 22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)",
+ com.google.common.eventbus;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.modelrepair
diff --git a/plugins/uml/org.eclipse.papyrus.uml.modelrepair/pom.xml b/plugins/uml/org.eclipse.papyrus.uml.modelrepair/pom.xml
index 633c8c01efc..0206a690a62 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.modelrepair/pom.xml
+++ b/plugins/uml/org.eclipse.papyrus.uml.modelrepair/pom.xml
@@ -7,6 +7,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.modelrepair</artifactId>
- <version>2.0.100-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/org.eclipse.papyrus.uml.profile/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.profile/META-INF/MANIFEST.MF
index 3ff9b3b827f..504e16e4d9d 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.profile/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.profile/META-INF/MANIFEST.MF
@@ -27,13 +27,13 @@ Require-Bundle: org.eclipse.papyrus.uml.tools.utils;bundle-version="[3.0.0,4.0.0
org.eclipse.papyrus.infra.internationalization.utils;bundle-version="[1.0.0,2.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.1.100.qualifier
+Bundle-Version: 3.2.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-Activator: org.eclipse.papyrus.uml.profile.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.profile;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0,22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0,22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.profile
diff --git a/plugins/uml/org.eclipse.papyrus.uml.profile/pom.xml b/plugins/uml/org.eclipse.papyrus.uml.profile/pom.xml
index 40bb381ae8b..9b9972bdc44 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.profile/pom.xml
+++ b/plugins/uml/org.eclipse.papyrus.uml.profile/pom.xml
@@ -7,6 +7,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.profile</artifactId>
- <version>3.1.100-SNAPSHOT</version>
+ <version>3.2.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/org.eclipse.papyrus.uml.service.types/META-INF/MANIFEST.MF b/plugins/uml/org.eclipse.papyrus.uml.service.types/META-INF/MANIFEST.MF
index cb26c731237..b78ab2c830e 100644
--- a/plugins/uml/org.eclipse.papyrus.uml.service.types/META-INF/MANIFEST.MF
+++ b/plugins/uml/org.eclipse.papyrus.uml.service.types/META-INF/MANIFEST.MF
@@ -26,5 +26,5 @@ Bundle-Activator: org.eclipse.papyrus.uml.service.types.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.service.types;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.service.types
diff --git a/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/META-INF/MANIFEST.MF b/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/META-INF/MANIFEST.MF
index dbc1feaf84b..89ff29ba660 100644
--- a/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/META-INF/MANIFEST.MF
+++ b/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/META-INF/MANIFEST.MF
@@ -17,13 +17,13 @@ Export-Package: org.eclipse.papyrus.uml.profile.drafter,
org.eclipse.papyrus.uml.profile.drafter.utils
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 1.3.0.qualifier
+Bundle-Version: 1.4.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.uml.profile.drafter.Activator
Bundle-SymbolicName: org.eclipse.papyrus.uml.profile.drafter;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.profile.drafter
diff --git a/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/pom.xml b/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/pom.xml
index b6c780ac458..c479f45387f 100644
--- a/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/pom.xml
+++ b/plugins/uml/profile/org.eclipse.papyrus.uml.profile.drafter/pom.xml
@@ -6,6 +6,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.profile.drafter</artifactId>
- <version>1.3.0-SNAPSHOT</version>
+ <version>1.4.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF
index 823f4c167d8..02160f66419 100644
--- a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF
+++ b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/META-INF/MANIFEST.MF
@@ -12,14 +12,14 @@ Require-Bundle: org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)";visibility:=
org.eclipse.papyrus.uml.internationalization.utils;bundle-version="[1.0.0,2.0.0)"
Bundle-Vendor: %pluginProvider
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.4.100.qualifier
+Bundle-Version: 3.5.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.uml.tools.utils.Activator
Bundle-ManifestVersion: 2
Bundle-SymbolicName: org.eclipse.papyrus.uml.tools.utils;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Bundle-Description: %Bundle-Description
Automatic-Module-Name: org.eclipse.papyrus.uml.tools.utils
diff --git a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/pom.xml b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/pom.xml
index b5d1fbb2e20..1a9e158d2d2 100644
--- a/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/pom.xml
+++ b/plugins/uml/tools/org.eclipse.papyrus.uml.tools.utils/pom.xml
@@ -8,7 +8,7 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.tools.utils</artifactId>
- <version>3.4.100-SNAPSHOT</version>
+ <version>3.5.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<description>This plugin contributes a set of common utils tools for UML</description>
</project>
diff --git a/plugins/uml/tools/org.eclipse.papyrus.uml.tools/META-INF/MANIFEST.MF b/plugins/uml/tools/org.eclipse.papyrus.uml.tools/META-INF/MANIFEST.MF
index 66e444f44ca..1bb3865acaf 100644
--- a/plugins/uml/tools/org.eclipse.papyrus.uml.tools/META-INF/MANIFEST.MF
+++ b/plugins/uml/tools/org.eclipse.papyrus.uml.tools/META-INF/MANIFEST.MF
@@ -33,13 +33,13 @@ Require-Bundle: org.eclipse.uml2.uml;bundle-version="[5.3.0,6.0.0)";visibility:=
org.eclipse.papyrus.infra.services.decoration;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
-Bundle-Version: 4.1.0.qualifier
+Bundle-Version: 4.2.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.uml.tools.Activator
Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.uml.tools;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)",
- com.google.common.util.concurrent;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)",
+ com.google.common.util.concurrent;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.uml.tools
diff --git a/plugins/uml/tools/org.eclipse.papyrus.uml.tools/pom.xml b/plugins/uml/tools/org.eclipse.papyrus.uml.tools/pom.xml
index 78dd48f7c21..6d634f293e3 100644
--- a/plugins/uml/tools/org.eclipse.papyrus.uml.tools/pom.xml
+++ b/plugins/uml/tools/org.eclipse.papyrus.uml.tools/pom.xml
@@ -9,7 +9,7 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.uml.tools</artifactId>
- <version>4.1.0-SNAPSHOT</version>
+ <version>4.2.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<description>This plugin contributes a set of common tools for UML</description>
</project>
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
index d1f508da60e..1df5f326463 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/META-INF/MANIFEST.MF
@@ -28,7 +28,7 @@ Require-Bundle: org.eclipse.ui.navigator;bundle-version="[3.6.0,4.0.0)";visibili
org.eclipse.papyrus.infra.architecture.representation;bundle-version="[2.0.0,3.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 3.0.100.qualifier
+Bundle-Version: 3.1.0.qualifier
Bundle-Localization: plugin
Bundle-Name: %pluginName
Bundle-Activator: org.eclipse.papyrus.views.modelexplorer.Activator
@@ -36,6 +36,6 @@ Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.views.modelexplorer;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.views.modelexplorer
diff --git a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/pom.xml b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/pom.xml
index 0bd6208cf4d..5bc6cecd0f9 100644
--- a/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/pom.xml
+++ b/plugins/views/modelexplorer/org.eclipse.papyrus.views.modelexplorer/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.views.modelexplorer</artifactId>
- <version>3.0.100-SNAPSHOT</version>
+ <version>3.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/META-INF/MANIFEST.MF b/plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/META-INF/MANIFEST.MF
index bc84888daf2..5937914a2ae 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/META-INF/MANIFEST.MF
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/META-INF/MANIFEST.MF
@@ -12,12 +12,12 @@ Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
Bundle-ClassPath: .,
bin
-Bundle-Version: 2.0.2.qualifier
+Bundle-Version: 2.1.0.qualifier
Bundle-Name: %Bundle-Name
Bundle-Activator: org.eclipse.papyrus.views.properties.toolsmiths.Activator
Bundle-ManifestVersion: 2
Bundle-Description: %pluginDescription
Bundle-SymbolicName: org.eclipse.papyrus.views.properties.toolsmiths;singleton:=true
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
-Import-Package: com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.views.properties.toolsmiths
diff --git a/plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/pom.xml b/plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/pom.xml
index 9ca46f5cde6..0d0b811a7d5 100644
--- a/plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/pom.xml
+++ b/plugins/views/properties/org.eclipse.papyrus.views.properties.toolsmiths/pom.xml
@@ -11,6 +11,6 @@
<relativePath>../../../toolsmiths/pom.xml</relativePath>
</parent>
<artifactId>org.eclipse.papyrus.views.properties.toolsmiths</artifactId>
- <version>2.0.2-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>
diff --git a/plugins/views/validation/org.eclipse.papyrus.views.validation/META-INF/MANIFEST.MF b/plugins/views/validation/org.eclipse.papyrus.views.validation/META-INF/MANIFEST.MF
index e63e9e6712b..85b3cd9c4d3 100644
--- a/plugins/views/validation/org.eclipse.papyrus.views.validation/META-INF/MANIFEST.MF
+++ b/plugins/views/validation/org.eclipse.papyrus.views.validation/META-INF/MANIFEST.MF
@@ -4,13 +4,13 @@ Require-Bundle: org.eclipse.papyrus.infra.ui;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.infra.services.validation;bundle-version="[3.0.0,4.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 2.1.0.qualifier
Bundle-Name: %pluginName
Bundle-Localization: plugin
Bundle-ManifestVersion: 2
Bundle-Activator: org.eclipse.papyrus.views.validation.internal.Activator
Bundle-SymbolicName: org.eclipse.papyrus.views.validation;singleton:=true
Bundle-RequiredExecutionEnvironment: J2SE-1.5
-Import-Package: com.google.common.base;version="[21.0.0, 22.0.0)",
- com.google.common.collect;version="[21.0.0, 22.0.0)"
+Import-Package: com.google.common.base;version="[27.1.0, 28.0.0)",
+ com.google.common.collect;version="[27.1.0, 28.0.0)"
Automatic-Module-Name: org.eclipse.papyrus.views.validation
diff --git a/plugins/views/validation/org.eclipse.papyrus.views.validation/pom.xml b/plugins/views/validation/org.eclipse.papyrus.views.validation/pom.xml
index 98d63db66bf..78ee317ea39 100644
--- a/plugins/views/validation/org.eclipse.papyrus.views.validation/pom.xml
+++ b/plugins/views/validation/org.eclipse.papyrus.views.validation/pom.xml
@@ -8,6 +8,6 @@
<version>0.0.1-SNAPSHOT</version>
</parent>
<artifactId>org.eclipse.papyrus.views.validation</artifactId>
- <version>2.0.0-SNAPSHOT</version>
+ <version>2.1.0-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
-</project> \ No newline at end of file
+</project>

Back to the top