Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--features/org.eclipse.papyrus.diagram.block-feature/.project2
-rw-r--r--features/org.eclipse.papyrus.diagram.block-feature/feature.xml47
-rw-r--r--features/org.eclipse.papyrus.diagram.internalblock-feature/feature.xml42
3 files changed, 18 insertions, 73 deletions
diff --git a/features/org.eclipse.papyrus.diagram.block-feature/.project b/features/org.eclipse.papyrus.diagram.block-feature/.project
index 805dd3b1b04..0ed8bc0672f 100644
--- a/features/org.eclipse.papyrus.diagram.block-feature/.project
+++ b/features/org.eclipse.papyrus.diagram.block-feature/.project
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
- <name>org.eclipse.papyrus.diagram.block-feature</name>
+ <name>org.eclipse.papyrus.diagram.blockdefinition-feature</name>
<comment></comment>
<projects>
</projects>
diff --git a/features/org.eclipse.papyrus.diagram.block-feature/feature.xml b/features/org.eclipse.papyrus.diagram.block-feature/feature.xml
index c1d35c3ec1d..fc6ca83a654 100644
--- a/features/org.eclipse.papyrus.diagram.block-feature/feature.xml
+++ b/features/org.eclipse.papyrus.diagram.block-feature/feature.xml
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<feature
- id="org.eclipse.papyrus.diagram.block"
+ id="org.eclipse.papyrus.diagram.blockdefinition"
label="%featureName"
version="0.7.0.qualifier"
provider-name="%providerName">
@@ -30,47 +30,20 @@ http://www.eclipse.org/legal/epl-v10.html
<requires>
<import plugin="org.eclipse.core.runtime"/>
- <import plugin="org.eclipse.core.resources"/>
- <import plugin="org.eclipse.core.expressions"/>
- <import plugin="org.eclipse.jface"/>
- <import plugin="org.eclipse.ui.ide"/>
- <import plugin="org.eclipse.ui.views"/>
- <import plugin="org.eclipse.ui.navigator"/>
- <import plugin="org.eclipse.ui.navigator.resources"/>
- <import plugin="org.eclipse.emf.ecore"/>
- <import plugin="org.eclipse.emf.ecore.xmi"/>
- <import plugin="org.eclipse.emf.edit.ui"/>
- <import plugin="org.eclipse.gmf.runtime.emf.core"/>
- <import plugin="org.eclipse.gmf.runtime.emf.commands.core"/>
- <import plugin="org.eclipse.gmf.runtime.emf.ui.properties"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.properties"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.providers"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.providers.ide"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.render"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.resources.editor"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.resources.editor.ide"/>
- <import plugin="org.eclipse.draw2d"/>
- <import plugin="org.eclipse.papyrus.diagram.common"/>
- <import plugin="org.eclipse.papyrus.sysml"/>
- <import plugin="org.eclipse.papyrus.sysml.edit"/>
- <import plugin="org.eclipse.emf.ecore.edit"/>
- <import plugin="org.eclipse.papyrus.uml.standard"/>
- <import plugin="org.eclipse.papyrus.uml.standard.edit"/>
- <import plugin="org.eclipse.uml2.uml"/>
- <import plugin="org.eclipse.uml2.uml.edit"/>
- <import plugin="org.eclipse.papyrus.resource"/>
- <import plugin="org.eclipse.papyrus.resource.edit"/>
- <import plugin="org.eclipse.gef"/>
- <import plugin="org.eclipse.papyrus.preferences"/>
- <import plugin="org.eclipse.papyrus.extensionpoints.editors"/>
<import plugin="org.eclipse.papyrus.core.adaptor.gmf" version="0.7.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.papyrus.diagram.clazz" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.gmf.runtime.draw2d.ui"/>
+ <import plugin="org.eclipse.ui"/>
+ <import plugin="org.eclipse.papyrus.sysml" version="0.7.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.papyrus.diagram.common" version="0.7.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.emf.common.ui" version="2.5.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.gmf.runtime.diagram.ui.resources.editor" version="1.2.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.gmf.runtime.diagram.ui.providers" version="1.3.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.core.expressions" version="3.4.100" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.papyrus.preferences" version="0.7.0" match="greaterOrEqual"/>
</requires>
<plugin
- id="org.eclipse.papyrus.sysml.diagram.blockdiagram"
+ id="org.eclipse.papyrus.sysml.diagram.blockdefinition"
download-size="0"
install-size="0"
version="0.0.0"
diff --git a/features/org.eclipse.papyrus.diagram.internalblock-feature/feature.xml b/features/org.eclipse.papyrus.diagram.internalblock-feature/feature.xml
index d19b67ac145..93df3aa00cc 100644
--- a/features/org.eclipse.papyrus.diagram.internalblock-feature/feature.xml
+++ b/features/org.eclipse.papyrus.diagram.internalblock-feature/feature.xml
@@ -30,43 +30,15 @@ http://www.eclipse.org/legal/epl-v10.html
<requires>
<import plugin="org.eclipse.core.runtime"/>
- <import plugin="org.eclipse.core.resources"/>
- <import plugin="org.eclipse.core.expressions"/>
- <import plugin="org.eclipse.jface"/>
- <import plugin="org.eclipse.ui.ide"/>
- <import plugin="org.eclipse.ui.views"/>
- <import plugin="org.eclipse.ui.navigator"/>
- <import plugin="org.eclipse.ui.navigator.resources"/>
- <import plugin="org.eclipse.emf.ecore"/>
- <import plugin="org.eclipse.emf.ecore.xmi"/>
- <import plugin="org.eclipse.emf.edit.ui"/>
- <import plugin="org.eclipse.gmf.runtime.emf.core"/>
- <import plugin="org.eclipse.gmf.runtime.emf.commands.core"/>
- <import plugin="org.eclipse.gmf.runtime.emf.ui.properties"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.properties"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.providers"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.providers.ide"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.render"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.resources.editor"/>
- <import plugin="org.eclipse.gmf.runtime.diagram.ui.resources.editor.ide"/>
- <import plugin="org.eclipse.draw2d"/>
- <import plugin="org.eclipse.papyrus.sysml"/>
- <import plugin="org.eclipse.papyrus.sysml.edit"/>
- <import plugin="org.eclipse.emf.ecore.edit"/>
- <import plugin="org.eclipse.papyrus.uml.standard"/>
- <import plugin="org.eclipse.papyrus.uml.standard.edit"/>
- <import plugin="org.eclipse.uml2.uml"/>
- <import plugin="org.eclipse.uml2.uml.edit"/>
- <import plugin="org.eclipse.papyrus.resource"/>
- <import plugin="org.eclipse.papyrus.resource.edit"/>
- <import plugin="org.eclipse.gef"/>
- <import plugin="org.eclipse.papyrus.core"/>
- <import plugin="org.eclipse.papyrus.editor" version="0.7.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.papyrus.diagram.common" version="0.7.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.papyrus.core.adaptor.gmf" version="0.7.0" match="greaterOrEqual"/>
<import plugin="org.eclipse.papyrus.diagram.composite" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.papyrus.diagram.common" version="0.7.0" match="greaterOrEqual"/>
- <import plugin="org.eclipse.papyrus.preferences"/>
+ <import plugin="org.eclipse.ui"/>
+ <import plugin="org.eclipse.papyrus.sysml" version="0.7.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.emf.common.ui" version="2.5.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.gmf.runtime.diagram.ui.resources.editor" version="1.2.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.gmf.runtime.diagram.ui.providers" version="1.3.0" match="greaterOrEqual"/>
+ <import plugin="org.eclipse.papyrus.preferences" version="0.7.0" match="greaterOrEqual"/>
</requires>
<plugin

Back to the top