summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Eidsness2014-06-10 21:38:49 (EDT)
committerCamille Letavernier2014-06-11 07:28:38 (EDT)
commit1d57b5d7ba08abc967cc22e7bfa9bb7ccbecaf4c (patch)
treed964129d900b02db722db43af468cc66ebf4767e
parent0f66a1e3d4f1404d0846da3ce36dd011251d0a8e (diff)
downloadorg.eclipse.papyrus-1d57b5d7ba08abc967cc22e7bfa9bb7ccbecaf4c.zip
org.eclipse.papyrus-1d57b5d7ba08abc967cc22e7bfa9bb7ccbecaf4c.tar.gz
org.eclipse.papyrus-1d57b5d7ba08abc967cc22e7bfa9bb7ccbecaf4c.tar.bz2
Bug 436368: Add missing CDT dependency.refs/changes/10/28310/3
The CDT New project wizard is used to create an output project. That wizard is implemented in cdt.ui, but uses dependency injection to execute code from managedbuilder.ui. This change adds that bundle dependency so that binary installations will work properly. I'm not able to test the buckminster build and install, but I've simulated this by running with and without the managedbuilder.ui plugin. Change-Id: Ie28697ecd6744a5222524966d726941b54f96d7d Signed-off-by: Andrew Eidsness <andrewe@jfront.com>
-rw-r--r--extraplugins/codegen/org.eclipse.papyrus.cpp.cdtproject/META-INF/MANIFEST.MF3
1 files changed, 2 insertions, 1 deletions
diff --git a/extraplugins/codegen/org.eclipse.papyrus.cpp.cdtproject/META-INF/MANIFEST.MF b/extraplugins/codegen/org.eclipse.papyrus.cpp.cdtproject/META-INF/MANIFEST.MF
index db52482..31d50e2 100644
--- a/extraplugins/codegen/org.eclipse.papyrus.cpp.cdtproject/META-INF/MANIFEST.MF
+++ b/extraplugins/codegen/org.eclipse.papyrus.cpp.cdtproject/META-INF/MANIFEST.MF
@@ -12,7 +12,8 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.papyrus.acceleo;bundle-version="1.0.0",
org.eclipse.papyrus.cpp.profile;bundle-version="1.0.0",
org.eclipse.papyrus.codegen.extensionpoints;bundle-version="1.0.0",
- org.eclipse.papyrus.cpp.codegen;bundle-version="1.0.0"
+ org.eclipse.papyrus.cpp.codegen;bundle-version="1.0.0",
+ org.eclipse.cdt.managedbuilder.ui;bundle-version="8.0.0"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-Version: 1.0.0.qualifier