Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Le Menez2017-03-22 10:13:48 -0400
committerGerrit Code Review @ Eclipse.org2017-03-24 06:55:32 -0400
commit172c9b0b63ba3be2c93ff710a8b7b4d288db633e (patch)
tree6eb2a5d47555479616ed503c322554f1ef9d6c6b /tests/framework
parent28f1f7a11c28f8e416afdc7bac212f2275d0c85f (diff)
downloadorg.eclipse.papyrus-172c9b0b63ba3be2c93ff710a8b7b4d288db633e.tar.gz
org.eclipse.papyrus-172c9b0b63ba3be2c93ff710a8b7b4d288db633e.tar.xz
org.eclipse.papyrus-172c9b0b63ba3be2c93ff710a8b7b4d288db633e.zip
[releng] [oxygen] Update guava dependencies to 21.0.0
- Update target definitions to the latest orbit repository and set guava dependecy to 21.0.0 - Update MANIFEST.MF guava version references to 21.0.0 throughout the repository - regenerate the target platforms - update the sdk feature.xml to point on guava 21.0.0.v20170206-1425 from guava 15.0.0.v201403281430 - modified manifests and java classes to fit the new API - ameneded the tests on guava version targets in the manifests Change-Id: I7d15679cd28585f6ea517466e70bc0848dd3179d Signed-off-by: Quentin Le Menez <quentin.lemenez@cea.fr>
Diffstat (limited to 'tests/framework')
-rw-r--r--tests/framework/org.eclipse.papyrus.tests.framework/META-INF/MANIFEST.MF3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/framework/org.eclipse.papyrus.tests.framework/META-INF/MANIFEST.MF b/tests/framework/org.eclipse.papyrus.tests.framework/META-INF/MANIFEST.MF
index fcfe5d0fcd8..0bb944a131e 100644
--- a/tests/framework/org.eclipse.papyrus.tests.framework/META-INF/MANIFEST.MF
+++ b/tests/framework/org.eclipse.papyrus.tests.framework/META-INF/MANIFEST.MF
@@ -34,7 +34,8 @@ Require-Bundle: org.junit;bundle-version="[4.12.0,5.0.0)";visibility:=reexport,
org.eclipse.papyrus.tests.framework.annotations;bundle-version="[1.2.0,2.0.0)",
org.eclipse.gmf.runtime.notation;bundle-version="[1.8.0,2.0.0)",
com.google.inject;bundle-version="[3.0.0,4.0.0)";visibility:=reexport,
- org.eclipse.xtext.util;bundle-version="[2.10.0,3.0.0)"
+ org.eclipse.xtext.util;bundle-version="[2.10.0,3.0.0)",
+ com.google.guava;bundle-version="21.0.0"
Bundle-Vendor: %providerName
Eclipse-LazyStart: true
Bundle-Version: 1.2.0.qualifier

Back to the top