Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPauline DEVILLE2019-07-17 03:18:51 -0400
committerPauline DEVILLE2019-07-17 04:29:32 -0400
commit95d7c94d6b6ed8cf87f25630152449d029d41c47 (patch)
tree61148ad61fbae7922a6d03d2a4382d295eb90e2e /plugins
parentc73c650c7ca4a8cb3f129c87e218f00637fb6661 (diff)
downloadorg.eclipse.papyrus-95d7c94d6b6ed8cf87f25630152449d029d41c47.tar.gz
org.eclipse.papyrus-95d7c94d6b6ed8cf87f25630152449d029d41c47.tar.xz
org.eclipse.papyrus-95d7c94d6b6ed8cf87f25630152449d029d41c47.zip
Bug 549266 - Update dependencies for 2019-09 M14.5.0_M1
* Update target platform * Add javax.inject as required bundle since org.eclipse.core.runtine does not export it anymore ( https://git.eclipse.org/r/#/c/144814 ) Change-Id: Ie512891f2e8c46c9ccaa2280ae782690115709b8 Signed-off-by: Pauline DEVILLE <pauline.deville@cea.fr>
Diffstat (limited to 'plugins')
-rw-r--r--plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF3
-rw-r--r--plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.assistants.generator/META-INF/MANIFEST.MF3
-rw-r--r--plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator/META-INF/MANIFEST.MF3
-rw-r--r--plugins/toolsmiths/org.eclipse.papyrus.def/META-INF/MANIFEST.MF3
-rw-r--r--plugins/toolsmiths/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF3
5 files changed, 10 insertions, 5 deletions
diff --git a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF
index b52a7306dd3..e06bc4fa1b4 100644
--- a/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF
+++ b/plugins/infra/nattable/org.eclipse.papyrus.infra.nattable/META-INF/MANIFEST.MF
@@ -72,7 +72,8 @@ Require-Bundle: org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0
org.eclipse.papyrus.infra.internationalization.utils;bundle-version="[1.0.0,2.0.0)",
org.eclipse.papyrus.infra.architecture;bundle-version="[2.0.0,3.0.0)",
org.eclipse.papyrus.infra.core.architecture;bundle-version="[2.0.0,3.0.0)",
- org.eclipse.papyrus.infra.architecture.representation;bundle-version="[2.0.0,3.0.0)"
+ org.eclipse.papyrus.infra.architecture.representation;bundle-version="[2.0.0,3.0.0)",
+ javax.inject;bundle-version="[1.0.0,2.0.0)"
Bundle-Vendor: %Bundle-Vendor
Bundle-ActivationPolicy: lazy
Bundle-Version: 6.2.0.qualifier
diff --git a/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.assistants.generator/META-INF/MANIFEST.MF b/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.assistants.generator/META-INF/MANIFEST.MF
index eeb03daaeb2..792b94c7a42 100644
--- a/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.assistants.generator/META-INF/MANIFEST.MF
+++ b/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.assistants.generator/META-INF/MANIFEST.MF
@@ -6,7 +6,8 @@ Require-Bundle: org.eclipse.xtend.lib;bundle-version="[2.10.0,3.0.0)",
org.eclipse.papyrus.infra.gmfdiag.assistant;bundle-version="[1.3.0,2.0.0)";visibility:=reexport,
org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.8.0,2.0.0)",
org.eclipse.papyrus.uml.filters;bundle-version="[1.2.0,2.0.0)",
- org.eclipse.papyrus.infra.types;bundle-version="4.0.0"
+ org.eclipse.papyrus.infra.types;bundle-version="4.0.0",
+ javax.inject;bundle-version="[1.0.0,2.0.0)"
Export-Package: org.eclipse.papyrus.uml.profile.assistants.generator,
org.eclipse.papyrus.uml.profile.assistants.generator.internal;x-internal:=true
Bundle-Vendor: %providerName
diff --git a/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator/META-INF/MANIFEST.MF b/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator/META-INF/MANIFEST.MF
index 4ac12d413df..24a77c280d3 100644
--- a/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator/META-INF/MANIFEST.MF
+++ b/plugins/toolsmiths/assistants/org.eclipse.papyrus.uml.profile.types.generator/META-INF/MANIFEST.MF
@@ -4,7 +4,8 @@ Require-Bundle: org.eclipse.xtend.lib;bundle-version="[2.10.0,3.0.0)",
com.google.inject;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.uml.types.core;bundle-version="[4.0.0,5.0.0)",
org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)"
+ org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)",
+ javax.inject;bundle-version="[1.0.0,2.0.0)"
Export-Package: org.eclipse.papyrus.uml.profile.types.generator,
org.eclipse.papyrus.uml.profile.types.generator.internal;x-internal:=true
Bundle-Vendor: %providerName
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.def/META-INF/MANIFEST.MF b/plugins/toolsmiths/org.eclipse.papyrus.def/META-INF/MANIFEST.MF
index 5d08497e4e7..89827cd6235 100644
--- a/plugins/toolsmiths/org.eclipse.papyrus.def/META-INF/MANIFEST.MF
+++ b/plugins/toolsmiths/org.eclipse.papyrus.def/META-INF/MANIFEST.MF
@@ -14,7 +14,8 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.12.0,4.0.0)",
org.eclipse.papyrus.gmfgenextension;bundle-version="[2.0.0,3.0.0)",
org.eclipse.gmf.runtime.emf.type.core;bundle-version="[1.9.0,2.0.0)",
org.eclipse.papyrus.infra.types.core;bundle-version="[4.0.0,5.0.0)",
- org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)"
+ org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)",
+ javax.inject;bundle-version="[1.0.0,2.0.0)"
Bundle-Vendor: %providerName
Bundle-ClassPath: .
Bundle-Version: 1.3.100.qualifier
diff --git a/plugins/toolsmiths/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF b/plugins/toolsmiths/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF
index 2405e37abf8..4b03972b2cf 100644
--- a/plugins/toolsmiths/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF
+++ b/plugins/toolsmiths/org.eclipse.papyrus.dev.assistants.codegen/META-INF/MANIFEST.MF
@@ -7,7 +7,8 @@ Require-Bundle: com.google.inject;bundle-version="[3.0.0,4.0.0)",
org.eclipse.papyrus.infra.types;bundle-version="[4.0.0,5.0.0)",
org.eclipse.gmf.runtime.emf.ui;bundle-version="[1.0.0,2.0.0)",
org.eclipse.uml2.uml;bundle-version="[5.0.0,6.0.0)",
- org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.0.0,2.0.0)"
+ org.eclipse.gmf.runtime.diagram.ui;bundle-version="[1.0.0,2.0.0)",
+ javax.inject;bundle-version="[1.0.0,2.0.0)"
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-Version: 1.2.100.qualifier

Back to the top