Skip to main content
aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCamille Letavernier2018-01-10 10:44:23 -0500
committerRemi Schnekenburger2018-01-18 04:05:07 -0500
commita8ddb196038c8d2a5ad8326d22f92630705fc432 (patch)
tree794c5aa656a64c2ac4bbbb65b37ab0498b239094 /plugins/views/org.eclipse.papyrus.views.search
parente520ac4b2e6039310e5140a02c83b1dd395bd605 (diff)
downloadorg.eclipse.papyrus-a8ddb196038c8d2a5ad8326d22f92630705fc432.tar.gz
org.eclipse.papyrus-a8ddb196038c8d2a5ad8326d22f92630705fc432.tar.xz
org.eclipse.papyrus-a8ddb196038c8d2a5ad8326d22f92630705fc432.zip
Bug 528421: [API Tools] Change default settings for Papyrus projects
https://bugs.eclipse.org/bugs/show_bug.cgi?id=528421 - Use more flexible options wrt. Constant values and Reexported APIs - Display errors directly in the code rather than Manifest, when relevant Change-Id: I7a48bca8a9a84487957a3d97a8dddfb145cdfd78 Signed-off-by: Camille Letavernier <cletavernier@eclipsesource.com>
Diffstat (limited to 'plugins/views/org.eclipse.papyrus.views.search')
-rw-r--r--plugins/views/org.eclipse.papyrus.views.search/.settings/org.eclipse.pde.api.tools.prefs18
1 files changed, 12 insertions, 6 deletions
diff --git a/plugins/views/org.eclipse.papyrus.views.search/.settings/org.eclipse.pde.api.tools.prefs b/plugins/views/org.eclipse.papyrus.views.search/.settings/org.eclipse.pde.api.tools.prefs
index 23fb95e120f..b2260f87129 100644
--- a/plugins/views/org.eclipse.papyrus.views.search/.settings/org.eclipse.pde.api.tools.prefs
+++ b/plugins/views/org.eclipse.papyrus.views.search/.settings/org.eclipse.pde.api.tools.prefs
@@ -1,15 +1,17 @@
+ANNOTATION_ELEMENT_TYPE_ADDED_FIELD=Error
ANNOTATION_ELEMENT_TYPE_ADDED_METHOD_WITHOUT_DEFAULT_VALUE=Error
ANNOTATION_ELEMENT_TYPE_CHANGED_TYPE_CONVERSION=Error
ANNOTATION_ELEMENT_TYPE_REMOVED_FIELD=Error
ANNOTATION_ELEMENT_TYPE_REMOVED_METHOD=Error
ANNOTATION_ELEMENT_TYPE_REMOVED_TYPE_MEMBER=Error
API_COMPONENT_ELEMENT_TYPE_REMOVED_API_TYPE=Error
-API_COMPONENT_ELEMENT_TYPE_REMOVED_REEXPORTED_API_TYPE=Error
-API_COMPONENT_ELEMENT_TYPE_REMOVED_REEXPORTED_TYPE=Error
+API_COMPONENT_ELEMENT_TYPE_REMOVED_REEXPORTED_API_TYPE=Warning
+API_COMPONENT_ELEMENT_TYPE_REMOVED_REEXPORTED_TYPE=Warning
API_COMPONENT_ELEMENT_TYPE_REMOVED_TYPE=Error
API_USE_SCAN_FIELD_SEVERITY=Error
API_USE_SCAN_METHOD_SEVERITY=Error
API_USE_SCAN_TYPE_SEVERITY=Error
+CLASS_ELEMENT_TYPE_ADDED_FIELD=Warning
CLASS_ELEMENT_TYPE_ADDED_METHOD=Error
CLASS_ELEMENT_TYPE_ADDED_RESTRICTIONS=Error
CLASS_ELEMENT_TYPE_ADDED_TYPE_PARAMETER=Error
@@ -34,14 +36,14 @@ ENUM_ELEMENT_TYPE_REMOVED_ENUM_CONSTANT=Error
ENUM_ELEMENT_TYPE_REMOVED_FIELD=Error
ENUM_ELEMENT_TYPE_REMOVED_METHOD=Error
ENUM_ELEMENT_TYPE_REMOVED_TYPE_MEMBER=Error
-FIELD_ELEMENT_TYPE_ADDED_VALUE=Error
+FIELD_ELEMENT_TYPE_ADDED_VALUE=Warning
FIELD_ELEMENT_TYPE_CHANGED_DECREASE_ACCESS=Error
FIELD_ELEMENT_TYPE_CHANGED_FINAL_TO_NON_FINAL_STATIC_CONSTANT=Error
FIELD_ELEMENT_TYPE_CHANGED_NON_FINAL_TO_FINAL=Error
FIELD_ELEMENT_TYPE_CHANGED_NON_STATIC_TO_STATIC=Error
FIELD_ELEMENT_TYPE_CHANGED_STATIC_TO_NON_STATIC=Error
FIELD_ELEMENT_TYPE_CHANGED_TYPE=Error
-FIELD_ELEMENT_TYPE_CHANGED_VALUE=Error
+FIELD_ELEMENT_TYPE_CHANGED_VALUE=Warning
FIELD_ELEMENT_TYPE_REMOVED_TYPE_ARGUMENT=Error
FIELD_ELEMENT_TYPE_REMOVED_VALUE=Error
ILLEGAL_EXTEND=Warning
@@ -49,6 +51,7 @@ ILLEGAL_IMPLEMENT=Warning
ILLEGAL_INSTANTIATE=Warning
ILLEGAL_OVERRIDE=Warning
ILLEGAL_REFERENCE=Warning
+INTERFACE_ELEMENT_TYPE_ADDED_DEFAULT_METHOD=Warning
INTERFACE_ELEMENT_TYPE_ADDED_FIELD=Ignore
INTERFACE_ELEMENT_TYPE_ADDED_METHOD=Error
INTERFACE_ELEMENT_TYPE_ADDED_RESTRICTIONS=Error
@@ -87,12 +90,15 @@ TYPE_PARAMETER_ELEMENT_TYPE_REMOVED_CLASS_BOUND=Error
TYPE_PARAMETER_ELEMENT_TYPE_REMOVED_INTERFACE_BOUND=Error
UNUSED_PROBLEM_FILTERS=Warning
automatically_removed_unused_problem_filters=Enabled
+changed_execution_env=Warning
eclipse.preferences.version=1
-incompatible_api_component_version=Error
+incompatible_api_component_version=Warning
incompatible_api_component_version_include_major_without_breaking_change=Disabled
incompatible_api_component_version_include_minor_without_api_change=Disabled
+incompatible_api_component_version_report_major_without_breaking_change=Error
+incompatible_api_component_version_report_minor_without_api_change=Error
invalid_since_tag_version=Error
malformed_since_tag=Error
-missing_since_tag=Warning
+missing_since_tag=Error
report_api_breakage_when_major_version_incremented=Disabled
report_resolution_errors_api_component=Warning

Back to the top